Programma ProgettoGDPR

Guida in linea del programma
ProgettoGDPR
General Data Protection Regulation

Il programma ProgettoGDPR serve per aiutare a redigere la documentazione richiesta dal Regolamento Europeo in materia di Protezione dei Dati ed per servire da supporto per la messa in atto di misure adeguate atte a proteggere i dati.

La guida si compone di una parte generale che descrive il funzionamento delle principali modalità operative del programma, ad esempio vengono descritti l'uso della tastiera nei vari punti del programma e l'uso dei pulsanti standard delle finestre.

Nella parte di riferimento del programma vengono descritte le voci che compongono il menù del programma. La guida descrive la versione più completa del programma, perciò sono presenti tutte le voci di menù, è possibile invece che l'utente disponga di una versione con un numero minore di moduli installati e quindi con minori voci di menù.

Nella parte riguardante lo scopo del programma, viene presentata una breve introduzione al programma.

Vengono anche forniti alcuni consigli utili per gestire al meglio tutti gli aspetti connessi con la gestione della privacy.


Il programma ProgettoGDPR è stato sviluppato per agevolare la stesura e la manutenzione del documento chiamato "Registro dei Trattamenti" e di tutta l'altra documentazione richiesta o utile per la gestione dal Regolamento Europeo 2016/679 GDPR.

Il Registro dei trattamenti non è obbligatorio per molte categorie di aziende, ma è fortemente consigliato anche dal Garante per documentare lo stato del trattamento dei dati e quindi deve essere considerato una forma di tutela dell'azienda nei confronti di eventuali controlli.

Il programma inoltre produce altri documenti non previsti dalla normativa ma utili per istruire il personale al trattamento dei dati nel migliore dei modi.

Infine la possibilità di documentare le modifiche che avvengono nel tempo lo rendono uno strumento utile per il continuo miglioramento dei parametri di sicurezza aziendali.

L'adeguamento alla normativa non deve essere considerato esclusivamente un onere, ma può essere visto anche come un'opportunità, infatti i temi di sicurezza dei dati oltre che tutelare i diritti dei soggetti di cui trattiamo i dati, sono anche importanti perché tutelano la disponibilità dei dati aziendali che sono sempre più un prezioso valore aziendale la cui perdita o danneggiamento spesso sono un danno molto grave.


Il programma produce tutta la documentazione richiesta dalla normativa ed anche documenti non strettamente richiesti ma utili. Consigliamo di utilizzare un driver di stampa che produce documenti in formato PDF per la portabilità dei documenti. Tra i tanti drivers gratuiti disponibili e reperibili consigliamo di usare il programma BullZip PDF Printer che è integrato nel programma e può essere utilizzato per produrre documenti in modo automatico.

Il registro dei trattamenti viene prodotto nel rispetto dell'art. 30 del regolamento e per la sua realizzazione si è tenuto conto delle indicazioni contenute nel tracciato proposto dal Garante belga e tradotto in inglese.

In tema di sicurezza, si possono trovare in internet molte risorse gratuite, segnaliamo alcuni utili programmi.

Oltre ai più diffusi programmi antivirus a pagamento, esistono molti programmi gratuiti discretamente efficienti, segnaliamo AVG e Avira. Anche se spesso può essere sufficiente utilizzare i sistemi di sicurezza proposti da Microsoft per le varie versioni del proprio sistema operativo.

Se serve sono disponibili programmi in grado di realizzare dischi virtuali cifrati che potrebbero essere utilizzati per memorizzare in sicurezza dati di tipo particolare. Ad esempio Cryptainer

Per il backup dei dati esistono programmi in grado di fare copie incrementali dei soli dati modificati, ad esempio SyncBackFree

Assieme al programma ProgettoGDPR, vengono forniti anche tracciati di documento in formato Microsoft Word. Se non si dispone di Word, i documenti possono essere letti e scritti utilizzando il programma gratuito LibreOffice

Assieme al programma, vengono forniti anche altri utili documenti, per maggiori dettagli consultare la cartella _EXTRA presente all'interno della cartella principale del programma.

Il programma ProgettoDGPR è stato pensato per essere un progetto dinamico che cresce nel tempo. Per questo motivo la documentazione viene proposta in modo preferenziale sotto forma di "Formulario". Mantenendo il programma aggiornato, sarà possibile aggiornare il formulario in modo ma migliorare costantemente la qualità della documentazione.

Esiste anche una lista di "Trattamenti tipici", che possono essere utilizzati e personalizzati per le proprie particolari esigenze.

La Compusoft gradisce anche il supporto ed il riscontro degli utenti i quali possono inviare in forma anonima situazioni non ancora previste dai formulari e dai tracciati standard.


Questa pagina contiene la traccia delle modifiche che vengono apportate nel tempo al programma. In questo modo gli utenti possono verificare personalmente le novità introdotte mano a mano che vengono fatti aggiornamenti, le modifiche vengono presentate in ordine inverso di data.

1.0.5 | 29/06/18 | Aggiunte le slides per l'introduzione alla sicurezza informatica.
1.0.4 | 29/06/18 | Aggiornamento di formulario e strumenti e trattamenti comuni.
1.0.3 | 01/06/18 | Aggiunto il campo tipo operatore agli addetti
1.0.2 | 18/05/18 | Aggiunto il campo Livello di rischio agli strumenti
1.0.1 | 17/05/18 | Aggiunto la possibilità di vedere il testo in fase di scelta delle formule
1.0.0 | 14/05/18 | Rilascio programma


In questa sezione sono contenute informazioni di carattere generale che spiegano la struttura del programma e le logiche di utilizzo dei vari tipi di procedura, vengono elencati i tasti funzionali e spiegato il significato dei pulsanti disponibili nei vari momenti di utilizzo del programma.

La finestra principale, illustra il punto di ingresso del programma.
Gestione dei dati, illustra le modaltà utilizzate per operare con i dati.
Finestre per immissione dati, spiega l'uso delle finestre con campi dati.
Gestione documenti per questo programma è una particolare finestra di inserimento dati che gestisce la logica di testata-righe.
Stampe spiega la modalità di utilizzo del sistema di reporting utilizzato per le stampe.
Diritti di accesso spiega le modalità utilizzate da alcuni programmi per la gestione dei diritti di accesso alle varie procedure da parte degli utenti.
Archiviazione documenti descrive una particolare funzionalità di alcuni programmi di gestire i collegamenti a documenti esterni.
Gestione spunte Alcuni archivi dispongono della possibilità di spuntare le singole registrazioni per fare operazioni, come ad esempio stampe, solo sui dati spuntati.

E' molto importante leggere con attenzione queste annotazioni per sfruttare il programma in tutte le sue potenzialità.


Normalmente all'avvio il programma apre una finestra che occupa interamente il video. Questa finestra contiene il menù che permette di accedere a tutte le funzionalità del programma. Per rendere più agevole il lavoro dell'operatore, oltre al classico menù a tendina presente nella parte alta della finestra, è presente subito sotto il menù una barra con i comandi più frequenti ed anche un menù ad albero nella parte sinistra della finestra. in questo modo, l'operatore può scegliere la modalità di utilizzo che trova più congeniale.

I comandi del menù File che permettono di accedere alle funzioni di manutenzione standard, sono però preseni solo nel menù principale.

Nella parete bassa della finestra principale sono presenti alcune caselle che contengono informazioni riguardo all'utilizzo del programma, da sinistra a destra le caselle contengono: L'archivio corrente, l'utente del programma, il nome della stazione di lavoro e la data di utilizzo del programma.

E' possibile configurare il programma in modo che la finestra principale si presenti in modo diverso, per fare questo si aggiunge alla riga di comando una istruzione sullo stile della finestra, sono disponibili i comandi: /STYLE:TREE, /STYLE:SDI, /STYLE:COMBO e /STYLE:MDI. Il funzionamento del programma è esattamente lo stesso, quindi queste opzione hanno solo una valenza estetica.
Nello stile MDI è possibile includere o escludere la ToolBar, per forzare l'esclusione si deve scrivere un file di testo di nome "csToolBar.txt" con contenuto NO nella cartella del programma, per forzare l'inclusione lo stesso file deve avere contenuto YES.
Se necessario si può lanciare automaticamente una determinata procedura all'avvio del programma aggiungendo la dicitura /PROC:<nome_procedura> alla riga di comando.


Lo scopo principale di un programma di gestione amministrativa basato si database è la gestione di dati. I dati vengono acquisiti nel programma con immissione da parte di un utente, oppure possono essere acquisiti con sitemi di rilevamento automatici, o infine sono il frutto di elaborazione da parte del programma stesso.

Normalmente i dati vengono immessi da un utente, quindi il programma deve fornire tutti i meccanismi per gestirli interattivamente, se ne deve poter aggiungere, si deve poter cancellare, si devono fare ricerche e stampe, inoltre il programma molto spesso si deve preoccupare che i dati inseriti siano coerenti e completi, ad esempio si deve impedire che due registrazioni abbiano lo stesso codice perchè questo genererebbe ambiguità.

In questa sezione verranno illustrati i meccanismi per la gestione interattiva dei dati, la più usuale è la gestione di files, ma esiste anche la gestione di altre tabelle, inoltre verranno elencati i pulsanti di controllo e verrà spiegato l'uso della tastiera.


I dati di database normalmente sono tabelle composte da un numero variabile di registazioni (records), ognuno di questi records è suddiviso in colonne (campi), lo scopo della gestione di files è quello di permettere l'introduzione di records, la loro modifica e la loro cancellazione. Nei programmi Compusoft, la gestione dei files avviene mostrando la tabella di dati.

La finestra si compone solitamente di due aree, nella parte superiore è presente una barra di pulsanti con cui è possibile dare comandi che hanno valore sulla riga selezionata e la parte centrale della finestra contiene la tabella con i dati, infine alle volte nella parte sottostante può essere presente un area che visualizza i dati più rilevanti dalla riga selezionata. Questa struttura è la più comune, ma si possono trovare finestre di gestione files strutturate in modo diverso per motivi specifici, ad esempio l'area di visualizzazione può essere assente, oppure la barra dei pulsanti può essre posizionata nella parte bassa della finestra.

La barra dei pulsanti di controllo a seconda delle esigenze visualizza solo i pulsanti che svolgono le funzioni necessarie in quel momento, tutti i comandi sono accessibili anche da tastiera e ci sono alcuni comandi che sono accessibili solo da tastiera.

Alle volte tra i comandi speciali dei pulsanti di controllo è presente il comando per attivare la spunta dei records. Questa funzionalità permette di scegliere solo alcuni dei records presenti nella tabella, ad esempio per stampare le etichette solo per alcuni clienti oppure per stampare solo alcuni documenti e così via. Dopo aver attivato il comando, viene visualizzata nella sinistra una colonna con le spunte, facendo doppio click sulla colonna vengono inserite o tolte le spunte, premendo con il tasto destro del mouse sulla colonna è possibile salvare le spunte attuali o ricaricare spunte salvate in precedenza. Dopo aver spuntato tutti i records desiderati, si può avviare il comando prescelto, non è detto però che tutti i comandi tengano conto delle spunte, ad esempio alcune stampe potrebbero tenerne conto ed altre no.


La gestione di altre tabelle è concettualmente molto simile alla gestione dei files la differenza sostanziale consiste nel fatto che mentre nella gestione dei files ogni modifica, inserimento o cancellazione effettuati sono immediatamente operativi e definitivi, nella gestione di altre tabelle si effettuano modifiche che vengono confermate o rifiutate in blocco alla fine.

I pulsanti di controllo chiave sono Conferma ed Annulla che pongono termine alla elaborazione con accettazione o rifiuto.


Pulsanti di controllo

La barra dei pulsanti di controllo è presente solitamente nella parte superiore di una finestra di gestione dati, si presenta con questo aspetto:

Tutti i comandi possono essere impartiti premendo tasti funzionali oppure cliccando con il mouse sul pulsante. A seconda delle necessità possono essere presenti più o meno pulsanti:

Primo

 Va alla prima riga

Precedente

 Va alla riga precedente

Successivo

 Va alla riga successiva

Ultimo

 Va all'ultima riga

Esportazione dati

 Permette di esportare i dati attualmente presenti nella gestione dati. I formati disponibili sono Testo ed Excel.
Il formato testo presenta una riga per ogni riga della gestione dati e le colonne sono separate da tabulatore, questo formato è facilmente importabile con altri programmi.
Il formato Excel viene presentato solo se nella macchina è installato MS Excel, quando viene scelto, apre un fogli di calcolo con i dati contenuti nella gestione dati.

Aggiungi [Ins]

 Aggiunge una riga

Cancella [Canc]

 Cancella una riga

Modifica [Invio] [Ctrl-Invio]

 Modifica la riga corrente, nella gestione di files aperta da un pulsante collegato corrisponde al tasto [Ctrl-Invio] perché il tasto [Invio] serve per confermare la selezione.

Conferma [F12] [Invio]

 Nella gestione di altre tabelle questa voce conferma tutte le modifiche effettuate, nella gestione di files è presente solo quando viene aperta da un pulsante collegato e serve per confermare la scelta e corrisponde al tasto [Invio].

Annulla [Esc]

 Nella gestione di altre tabelle questa voce annulla tutte le modifiche effettuate, nella gestione di files è presente solo quando viene aperta da un pulsante collegato e serve per annullare la scelta.

Sposta Su [<]

 Questa voce è presente solo nella gestione di altre tabelle e sposta verso l'alto la riga corrente

Sposta Giù [>]

 Questa voce è presente solo nella gestione di altre tabelle e sposta verso il basso la riga corrente

Stampa [F5]

 Se presente viene eseguita la stampa dei dati presenti in tabella. Prima di eseguire la stampa, si possono eseguire selezioni ed ordinamenti per stampare solo i dati che si desidera.

Ricerca [F2]

 Cerca nella colonna corrente, questo comando può essere attivato anche cliccando sulla colonna con il tasto destro del mouse, si apre una finestra in cui viene chiesto il valore da cercare, si può scegliere di cominciare a cercare da capo, oppure di continuare una ricerca, o infine di presentare una lista con tutti i dati che soddisfano la ricerca. se il valore viene trovato il cursore si posiziona sulla riga trovata, altrimenti viene segnalato l'errore di ricerca.

Ordina [F3]

Nella gestione di files viene scelto l'ordinamento tra quelli previsti (indici) e permette di inserire il valore da cercare nei campi di ordinamento.

Nella gestione di altre tabelle, questo comando riordina la tabella utilizzando la colonna corrente, l'ordinamento avviene prima per ordine crescente e poi per ordine decrescente.

Selezioni [F4]

 Questa voce è presente solo nella gestione di files e serve per scegliere dall'archivio corrente solo i records che soddisfano determinati criteri. Si apre una finestra con la lista dei campi che possono essere assoggettati a selezione:

Per ogni campo viene evidenziato il nome, il tipo di selezione effettuata ed i valori di selezione. Per ogni voce si può effettuare la scelta del tipo di selezione che sono:
= | Uguale, vengono selezionati solo i records con valore uguale a quello inserito.
<> | Diverso, vengono selezionati solo i records con valore diverso da quello inserito
<= | Minore o uguale, vengono selezionati solo i records con valore minore o uguale a quello inserito.
< | Minore, vengono selezionati solo i records con valore minore a quello inserito.
> | Maggiore, vengono selezionati solo i records con valore maggiore a quello inserito.
>= | Maggiore o uguale, vengono selezionati solo i records con valore maggiore o uguale a quello inserito.
$ | Contiene, vengono selezionati solo i records che in questo campo contengono in qualsiasi posizione il valore inserito.
>< | Compreso tra, vengono selezionati i records in cui il valore del campo è compreso tra quelli inseriti
nd | Non definito, non viene eseguita nessuna selezione su questo campo

Comandi speciali [Barra-Spazio]

 Questo pulsante è presente quando, sono disponibili comandi speciali su questa riga, premendolo si apre un menù con la lista dei comandi disponibili, nella voce viene sottolineato il tasto di scelta rapida che può essere usato per accedere direttamente al comando,

ad esempio nel menù evidenziato premendo C è possibile attivare il comando "Contatti" anche senza premere la barra spaziatrice.

I pulsante Selezioni normalmente permette di effettuare le selezioni sui campi più rilevanti dell'archivio, il programma permette anche di personalizzare le selezioni che vengono fatte più frequentemente. per fare questo si deve inserire nelle risorse utente risorse di tipo 'FLT' con codice uguale al nome interno della finestra (chiedere il nome alla Compusoft per ciascun archivio), il testo deve avere il seguente formato:

' Documenti del mese
' TMG
= DATANUM
<
@----------+--+----------------------------+--------------------------------
DATA       >< @curMonthIni                 @curMonthEnd
T_DOC      =  D
CODAGE
D_CONS
CAUS       >< 0                            9
TANA       =  C
ANAG
CODTDO

&---------------------------------------------------------------------------

 I campi vengono elencati uno per riga a partire dalla riga successiva a quella che inizia con il carattere at '@', prima di questa riga, se esiste una riga che iniza con uguale '=' quello che segue è il nome del indice da applicare, oltre a questo se esiste una riga che iniza con il segno minore '<' la visualizzazione viene posta automaticamente alla fine dei dati.
Dopo la riga che indica l'inizio dei campi (quella che inizia con '@'), in ogni riga si inserisce: a colonna 1 il nome del campo, a colonna 12 il tipo di selezione predefinito, a colonna 15 il primo valore di filtro predefinito ed a colonna 44 il secondo valore di filtro per selezioni di tipo "compreso tra". Le righe che seguono quella che inizia con il carattere e commerciale '&' vengono ignorate. Nei valori dei campi si possono inserire alcuni comandi speciali che sono:
@Today = data odierna
@curMonthIni = inizio del mese corrente
@curMonthEnd = fine del mese corrente
@LastMonthIni = inizio del mese precedente
@LastMonthEnd = fine del mese precedente
@curYearIni = inizio dell'anno corrente
@curYearEnd = fine dell'anno corrente
@LastYearIni = inizio dell'anno precedente
@LastYearEnd = fine dell'anno precedente

Compusoft di Driussi Claudio Viale Libertà, 23/d 33170 Pordenone


Durate la gestione dei dati sono disponibili un certo numero di comandi, la maggior parte di essi sono anche raggiungibili attraverso i pulsanti di controllo disponibili durante questa fase operativa, altri comandi sono raggiungibili solo con la tastiera (per il significato dei comandi non documentati consultare la voce "pulsanti di controllo").

Tasto | Pulsante | Comando
Freccia Sù |  | Riga precedente
Freccia Giù |  | Riga successiva
Pagina Sù |  | Pagina precedente
Pagina Giù |  | Pagina successiva
Ctrl + PagSù |  | Prima riga
Ctrl + PagGiù |  | Ultima riga
Freccia Sinistra |  | Campo a sinistra
Freccia a Destra |  | Campo a destra
Inizio |  | Primo campo
Fine |  | Ultimo campo
Ctrl + Freccia Sinistra |  | Sposta la colonna a sinistra
Ctrl + Freccia a Destra |  | Sposta la colonna a destra
Ins |  | Aggiungi
Canc |  | Cancella
Invio |  | Modifica
Ctrl + Invio |  | Modifica
< |  | Sposta Sù (solo altre tabelle)
> |  | Sposta Giù (solo altre tabelle)
* |  | Inserisce una riga nella posizione corrente invece che alla fine (solo altre tabelle)
F1 |  | Richiama la guida in linea
F2 |  | Cerca nella colonna, questo comando può essere attivato anche cliccando sulla colonna con il tasto destro del mouse, si apre una finestra in cui viene chiesto il valore da cercare nella colonna e se si debba incominciare da capo, se il valore viene trovato il cursore si posiziona sulla riga trovata, altrimenti viene segnalato l'errore di ricerca.
F3 |  | Ordina
F4 |  | Selezioni
F5 |  | Stampa
F7 |  | Esportazione
Barra spaziatrice |  | Comandi speciali disponibili per la riga.
F11 |  | Seleziona singola cella o tutta la riga. Questa scelta rimane memorizzata.
F12 |  | Conferma ed esci
ESC |  | Annulla ed esci


Le finestre di immissione dati vengono utilizzate quando l'utente deve inserire dati nel programma, principalmente questo avviene utilizzando la tastiera, il contenuto di una finestra alla fine può essere confermato dando via a procedure di memorizzazione o di elaborazione, oppure annullato.

La finestra può essere multipagina come in questo caso oppure più spesso monopagina e contiene principalmente caselle di testo ma anche altri controlli tra i quali un ruolo particolare rivestoni i pulsanti collegati. Nella selezione dedicata all'uso della tastiera vengono elencati i tasti disponibili in questa fase.

Nella parte bassa è visibile la barra di stato della finestra in cui vengono evidenziati eventuali annotazioni all'utente ed i tasti annulla e conferma rispettivamenti attivabili dai testi [Esc] e [F12].


Le caselle di testo sono il principale mezzo per introdurre dati nel programma,

durante l'immissione sono disponibili vari comandi attivabili da tastiera, il programma riconosce il tipo di dato da inseire e non permette di inserire dati non coerenti, ad esempio non si possono inserire date con formato errato, oppure di inserire dati non numerici dove sono richiesti numeri.

In alcuni casi la casella di testo dispone di un pulsante collegato che facilita la scelta del dato da inserire, inoltre alle volte il contenuto della casella viene specificato da un campo affiancato.

Nei campi data si può inserire la data del giorno prememdo i tasto [F3], inoltre solitamante dispongono di un pulsante collegato che apre un calendario da cui scegliere il gionro.

I pulsanti nella riga inferiore da sinistra a destra significano: Anno Precedente, Mese Precedente, Mese Successivo, Anno Successivo, Data del giorno, Annulla e Conferma, la selezione puo essere effettuata con il mouse ed anche con le frecce ed il tasto invio.

In alcuni casi sono disponibili combinazioni di caselle di testo chiamate "selezioni" con cui si possono stabilire criteri per estrapolare dati da un archivio, il primo campo permette di stabilire il tipo di selezione da effettuare ed a fianco sono disponibili uno o due campi in cui si può specificare i valori da confrontare.

Il significato del dato da introdurre nella casella di testo normalmente viene spiegato nella guida in linea che viene attivata premendo il tasto [F1], ma alle volte viene evidenziata una breve spiegazione nella barra di stato della finestra.


Oltre alle caselle di testo, nelle finestre di dialogo possono essere presenti altri controlli, quelli che si incontrano più spesso sono le caselle di spunta che permettono di inserire un valore si/no

Oppure i pulsanti che permettono di avviare svariati comandi.

I pulsanti vengono spesso usati per inserire un "memo" che è un posto in cui si possono memorizzare un breve testo, in questo caso si apre una finestra o un programma che permette di inserire il testo, il programma esterno viene chiamato se è stato configurato nei dati fissi.


I pulsanti collegati affiancano una casella di testo e servono per scegliere il valore da inserire nella casella. Il comando può essere richiamato cliccando con il mouse sul pulsante oppure più velocemente premendo [F2] nella casella di testo.

Quando si deve scegliere tra poche opzioni, il pulsante una lista di scelte vicino alla casella di testo.
Altre volte viene utilizzato quando si deve inserire un codice, in questo caso si apre una finestra con la gestione di files da cui scegliere, ma in cui è anche possibile inserire nuovi dati o modificare quelli esistenti.
Infine può succedere che il pulsante sia utilizzato per avviare comandi speciali che attraverso calcoli assegnano il valore alla casella di testo.


L'uso della tastiera si applica principalmente alle caselle di testo che sono i controlli più frequenti nelle finestre di immissione dati, gli altri controlli rispondono di solito ad una parte dei tasti elencati qui.

Inizio | Inizio del testo
Fine | Fine del testo
Freccia Sinistra | Un carattere a sinistra
Freccia Destra | Un carattere a destra
Ctrl + Freccia Sinistra | Una parola a sinistra
Ctrl + Freccia Destra | Una parola a destra
Ctrl + T | Cancella una parola a destra del cursore
Ctrl + Y | Calcella tutto a destra del cursore
Ctrl + U | Annulla le modifiche al campo.
Canc | Cancella il carattere sotto il cursore
Canc Indietro | Cancella il carattere a sinistra del cursore
F1 | Richiama la guida in linea.
F2 | Nei campi con pulsante collegato, richiama il comando del pulsante.
F3 | Nei campi data inserisce la data del programma.
Ins | Commutazione modo inserimento/sovrascrittura.
Shift + Freccia destra | Seleziona a destra
Shift + Freccia sinistra | Seleziona a sinsitra
Ctrl + Ins | Copia selezione
Shift + Canc | Taglia selezione.
Shift + Ins | Incolla selezione.
Freccia Sù | Campo precedente
Freccia Giù | Campo successivo
Tab | Campo successivo
Shift + Tab | Campo precedente
Invio | Campo successivo, sull'ultimo campo conferma ed esce.
Ctrl + Inizio | Primo campo della pagina
Ctrl + Fine | Ultimo campo della pagina
Pagina Sù | Nella gestione multipagina và alla pagina precedente, nella gestione monopagina conferma ed esce
Pagina Giù | Nella gestione multipagina và alla pagina successiva, nella gestione monopagina conferma ed esce
Esc | Annulla ed esce
F12 | Conferma ed esce
Barra spaziatrice | Nei pulsanti attiva il comando, nelle caselle di spunta commuta la spunta e nelle caselle di testo inserisce uno spazio


Un documento per questo programma è una particolare situazione in cui c'è una testata ed un numero variabile di righe solidali con la testata, il tipico caso di documento è una fattura a cliente nella quale in testata si inserisce la data, il numero, il codice cliente ecc... e nelle righe si inseriscono i dati dei prodotti venduti. Operativamente si presenta come una finestra di immissione dati che contiene anche una gestione di altre tabelle,

Confermando la testata vengono anche confermate tutte le righe ed annullando la testata vengono anche annullate tutte le righe. Alle volte un documento ha anche un piede in cui vengono visualizzati i totali del documento ed inseriti dati finali.

La particolarità della gestione dei documenti consiste nel fatto che i dati non possono essere inseriti contemporaneamente in testata e nelle righe, infatti quando si sta inserendo la testata le righe sono disabilitate e vengono visualizzate con una tonalità più scura.

Alla fine dell'inserimento dalla testata avviene la validazione dei dati inseriti e se sono corretti per gli scopi della procedura si può passare all'inserimento delle righe che viene segnalato con un cambio della tonalità di colore delle righe.

Un altra validazione avviene alla conferma delle righe, se i dati dell'intero documento sono corretti si procede alla memorizzazione, altrimenti si rimane nel documento fintanto che i dati non sono corretti.

I pulsanti di conferma ed annulla della finestra, nel contesto del documento significano avanti ed indietro, il pulsante di conferma dalla testata passa alle righe e dalle righe passa alla conferma del documento, mentre il pulsante di annulla dalle righe passa alla testata e dalla testata passa all'abbandono del documento.


Quando si richiede una stampa si apre una finestra che ci permette di sceglere il tracciato di stampa (se ne sono disponibili più di uno), il titolo della stampa, il numero di copie, il tipo di stampa o esportazione dati, l'anteprima ed il livello di zoom in anteprima.

Se si sceglie l'anteprima alla fine della elaborazione dei dati si presenta una finestra che visualizza i dati stampati:

da questa finestra è possibile selezionare e configurare la stampante di destinazione e visualizzare tutte le pagine stampate con diversi livelli di zoom.

L'esportazione può essere fatta in formato HTML che è il formato delle pagine internet, oppure in formato EXCEL ed in questo caso è necessario che sia installato MS Excel nel computer, oppure in formato JPG che è un formato grafico.

In alternativa al formato JPG, si può esportare in formato PDF che è un formato molto diffuso soprattutto per comunicare dati in internet. Per attivare il formato PDF è necessario installare il programma PDFCreator che è un driver di stampa che produce documenti PDF e che può essere scaricato gratuitamente da http://www.pdfforge.org.

Le stampe vengono effettuate utilizzando un sistema di tracciati stampa, questo significa che le stampe sono in una certa misura modificabili. Il tracciato riguarda la parte estetica della stampa ed i contenuti della stessa, ma la disponibilità di dati e l'ordine di presentazione è codificata all'interno del programma. Una stessa stampa può avere più tracciati per rispondere a diverse esigenze di visualizzazione e possono essere aggiunti su richiesta dell'utente.
I tracciati possono essere modificati dall'utente, ma i dettagli tecnici sulle voci da inserire nella stampa devono sempre essere richiesti alla Compusoft o da tecnici autorizzati dalla stessa, fisicamente i tracciati sono contenuti nelle risorse del programma e possono essere modificate con un apposito editor visuale.


I programmi della Compusoft possono disporre di due diversi modelli di gestione degli utenti e dei diritti. Il modello utilizzato dipende dal programma, alcuni programmi utilizzano il modello semplificato ed alri il modello completo.

Il modello completo dipone di metodi anche sofisticati per identificare quali utenti possono accedere a quali procedure. Il modello semplificato invece serve solo per inibire l'accesso al programma a coloro che non conoscono i dati di login.

Poiché il modello completo dei diritti è piuttosto sofisticato, la sua gestione non è semplicissima e si consiglia che venga effettuata da personale tecnico. Le note che seguono sono le istruzioni tecniche per tale tipo di personale.

Le definizione delle voci soggette a modalità di accesso sono definite in modo gerarchico con relazioni di tipo padre figlio. Il vantaggio di questo tipo di approccio consiste nel fatto che si possono gestire "profili" di utente facilmente modificabili con il mutare delle condizioni senza dover modificare a mano lunghe sequenze di diritti per cisacun utente.

Tracciato di configurazione

La configurazione delle voci soggette a modalità di accesso viene fatta mediante un tracciato, con il programma solitamente viene fornito un tracciato che soddisfa le esigenze più comuni. Il tracciato si trova tra le Risorse di Sistema ed è di tipo 'MNU' e si chiama 'RIGHTS'. Se è necessario fare modifiche al tracciato, lo si deve copiare tra le Risorse Utente e quindi modificarlo a mano.

Il tracciato serve per definire quali sono i punti del programma il cui accesso viene regolato ed anche quali relazioni intercorrono tra le varie voci.

Questo è un piccolo esempio di tracciato:

' REGOLE PER I DIRITTI DI ACCESSO
= STANDARD, IDR
MNU ----------------------------------------------+---------+-------------------
File                                              rfFile
  Archivio di lavoro                              rfOpen    BACKUP
  Cambia data                                     rfDate
  Copia dati                                      rfCopia   BACKUP
  Utilità                                         rfUtil
    Ricostruzione dati                            rfPack    BACKUP
    Chiudi tutte le finestre                      rfCloseW
    Manutenzione archivio                         rfEdData  CONFIG
    Risorse/Informazioni                          rfRes     CONFIG
  Fine                                            rfEnd
Dati                                              rdBase
  Eventi                                          RNN01     RNN, CONFIG
  Addetti                                         ADT01     ADT
  Tabelle e liste                                 rmTab     CONFIG
    Progetti                                      PRJ01     PRJ

DDF ----------------------------------------------+---------+-------------------
Addetti / Dipendenti                              ADT       USR
Progetti                                          PRJ       CONFIG
Eventi                                            RNN

GRP ----------------------------------------------+---------+-------------------
Addetti configurazione                            CONFIG
Copie a manutenzione archivi                      BACKUP    CONFIG
Visualizza prezzi                                 PRZ
Utenti                                            USR

%-------------------------------------------------------------------------------
Commenti e note.

Le righe che iniziano con il segno "'" (singolo apice) sono commenti ininfluenti ai fini del tracciato.

Tutto quello che viene trovato dopo la riga che inizia con il segno "%" (percentuale) viene ignorato, perciò si possono inserire in questa posizione note e commenti.

La riga che inizia con il segno "=" (uguale) contiene i riferimenti dei tracciati di menù utilizzati separati da virgoal, solitamente l'utente non dovrebbe modificare questa riga.

Le righe di definizione dei diritti sono organizzate in modo gerarchico, ogni riga può fare riferimento a zero, una o più righe padre e se non viene definita una regola di accesso per la singola voce vengono utilizzate quelle definite per le righe padre.

Le righe che non hanno riferimento padre sono le finali a cui vengono assegnati i diritti per ogni utente.

Le righe di definizione dimensioni fisse, sulla sinistra c'è la descrizione della riga, a colonna 51 c'è il codice univoco che la identifica ed a colonna 61 si inseriscono i riferimenti a elementi padre separati da virgole.

Esistono tre tipi di righe di definizione dei diritti divisi in gruppi, i tipi sono "MNU", "DDF" e "GRP" ed iniziano quando si incontra una riga che inizia con lo stesso codice.

Le righe "MNU" hanno la stessa sequenza dei menù del programma e servono per definire i diritti di accesso alle singole voci di menu, se un utente non ha i diritti per un determinato menu, semplicemente non vede la voce. Da questo consegue che tutti i sottomenu di una voce nascosta sono a loro volta nascosti anche che hanno un diritto di accesso più liberale.

Le righe "DDF" regolano l'accesso alle tabelle di database utilizzate dal programma.

Le righe "GRP" infine servono a definire raggruppamenti di altre voci e sono utilizzate per assegnare o revocare diritti in modo globale a tutte le voci figlie del raggruppamento.

Le righe di tipo MNU e DDF possono variare nel tempo a mano a mano che che il programma viene modificato ed aggiornato, di queste righe si possono solo modificare i riferimenti a righe padre.

Da notare che solitamente le voci di menù che accedono a tabelle del database hanno come riferimento padre la tabella e quindi ne "ereditano" i diritti.

Le righe di tipo GRP sono inserite e modificate manualmente e non vengono alterate da modifiche al programma. Per gruppo si intende sia elementi che sono padri di altri elementi, sia elementi che non sono padri e che vengono gestiti in modo diretto dalla applicazione.

Assegnazione dei diritti

I diritti di accesso alle voci definite dal tracciato di configurazione vengono assegnati individualmente per ciascun utente.

I diritti possono avere vari livelli di accesso. I livelli hanno senso solo per la gestione delle tabelle, nel caso dei menù o l'accesso è negato o in tutti gli altri casi è concesso.

I livelli sono:
0 | Non assegnato | Il diritto concesso o negato a seconda del tipo di voce. I MNU ed i DDF vegnono sempre concessi, i GRP invece vengono negati.
1 | Negato | Non è possibile nessun accesso.
2 | Sola lettura | Il dato è solo leggibile ma non modificabile.
3 | Inserimento | Si possono solo inserire nuovi valori ma non modificare o cancellare quelli esistenti.
4 | Modifica | è il livenllo meno restrittivo, si possono inserire, cancellare e modificare i dati.

Se non viene assegnato nessun diritto, l'utente è superuser ed ha accesso a tutto il programma, se viene assegnato almeno un diritto, tutti i diritti non citati vengono negati se sono GRP oppure vengono accordati se sono MNU o DDF.

Nel programma ogni punto di accesso ha un codice che corrisponde ai codici del tracciato,per stabilire i diritti di accesso, quando viene trovato un nome, si cerca a ritroso nelle definizioni del tracciato fino alla voce senza riferimento padre, oppure fino a che non viene fatta una assegnazione di diritti diretta a quella voce. L'ereditarietà dei diritti è multipla, la ricerca viene effettuata per ogni riferimento e viene applicato il criterio meno restrittivo che viene trovato.

A partire dalla gestione degli utenti è solitamente disponibile una procedura che aiuta a scegliere i diritti in modo visuale.

Questa procedura presenta tutte le voci presenti nel tracciato di configurazione e permette per ciascuna di inserire il livello di accesso. Se viene assegnato un levello per una voce che è padre di altre sottovoci, tutte queste otterranno lo stesso livello di accesso.

Per facilitare l'assegnazione si può scegliere di vedere solo i gruppi (GRP), oppure i Menù e database (MNU, DDF) oppure tutte le voci.

Si può anche sceglere se si desidera vedere solo quelli che non hanno riferimenti padre, oppure quelli che li hanno oppure tutte le voci.

Una volta scelta una voce si può scegliere un livello di assegnazione che sottostanno a tutte le regole esposte in precedenza.

Nota: Alle volte è più comodo e veloce intervenire manualmente sui diritti di ciascun utente, per fare questo si deve modificare il testo con la lista dei diritti assegnati nel quale ogni riga contiene il codice della voce seguito da una virgola e dal livello di accesso. Tutte le voci non citate non sono assegnate.

Importante:

La gestione della sicurezza è benché sia piuttosto sofisticata, è stata pensata più come detterrente che come una vera e propria difesa contro le intrusioni di tipo malevolo, i dati non sono crittografati e quindi sono visibili abbastanza facilmente utlizzando programmi di manutenzione dati. Per questo motivo se ci sono esigenze di maggiore sicurezza, è necessario attivare sistemi di sicurezza esterni al programma.


In alcuni casi i programma della Compusoft permettono di collegare documenti elettronici ai dati del programma.

Ad esempio, se questa funzione è abilitata, si possono legare documenti Word o Excel, oppure immagini o disegni tecnici ad un cliente o un fornitore, in questo se vogliamo cercare un documento fatto per un certo cliente basta andare su quel cliente ed aprire i suoi documenti.

L'uso di questa funzione è semplice, ma racchiude in se una certa sofisticazione e la possibilità di configurare il sistema in modo molto raffinato.

Esempio di utilizzo

Per spiegare l'uso di questa funzione conviene fare un esempio pratico.

Supponiamo di voler fare un preventivo ad un cliente con MS Excel e di voler conservare il documento nel sistema di gestione documentale. Si dovrà agire così:

Prima di tutto si scrive il documento, poi lo si salva in una cartella che il sistema riconosce come come cartella di trasito (di solito questa cartella è "C:\CS\Documenti")

Quindi si va nell'archivio dei Clienti, si trova il cliente a cui stiamo facendo il preventivo, e si attiva la funzione di gestione documenti (solitamente premendo il pulsante dei comandi speciali)

A questo punto si apre la finestra con la lista dei documenti legati a questo clienti, premendo il pulsante di inserimento nuovi dati, si apre la finestra di apertura documenti che automaticamente si posiziona sulla cartella di transito, in cui troviamo il documento salvato in precedenza. Lo scegliamo e clicchiamo il pulsante "Ok"

Fatto questo il sistema ci chiede la descirzione del documento e da data di inserimento e se confermiamo il tutto alla fine copia il file in una propria cartella e lo cancella dalla cartella di transito.

In seguito il documento potrà essere aperto e modificato come illustrato in questa videata.

e sarà facilmente reperibile in seguito.

Dettagli tecnici

Come dicevamo precendentemente, il sistema è piuttosto sofisticato e configurabile. La configurazione avviene utilizzando files di configurazione in formato INI (che è un formato di files tipico di Windows). Ogni archivio può avere un file di configurazione diversa, ad esempio i Clienti possono avere una configurazione diversa dagli Articoli.

Ci possono essere 3 livelli di files di configurazione in modo da consentire ad ogni utente di configurare la propria macchina. Il nome del file di configurazione può cambiare da archivio ad archivio e solitamente inizia con "DR", per primo viene cercato il file nella cartella del programma, poi viene cercato un file con lo stesso nome nella cartella temporanea locale del programma che di solito è C:\CS, infine viene cercato un file di nome "DOCREP.INI" nella cartella C:\CS. Se nessuno di questi 3 files è presente vengono adottati i parametri di configurazione standard illustrati nel seguente esempio di file di inizializzaizone:

; La procedura di gestione dei documeti esterni riconosce 3 files INI di
; configurazione. Il primo file si trova nella cartella del programma e può
; avere un nome diverso per ogni archivio che gestisce documenti, il secondo
; ha lo stesso nome del primo ma si trova nella cartella C:\CS di ogni utente
; e serve per configurare le impostazioni locali per ogni utente, ed infine
; il file di nome DOCREP.INI nella cartella C:\CS solitamente viene utilizzato
; per configurare le associazioni alle estensioni di files non riconosciute
; per ogni utente.

; Parametri di configurazione
;
; ROOTDIR    directory di partenza per i documenti
; BAKDIR     directory in cui copiare i files prima della cancellazione
; IMPORTDIR  directory temporanea che contiene i documenti da importare
; TEMPLDIR   directory in cui memorizzare tracciati standard di documenti
; SUBPATH    percorso delle directory in cui memorizzare i documenti importati
; PREFIX     prefisso dei nomi di files
; NPROG      numero di caratteri del progressivo numerico
;
; nei nomi delle cartelle e del prefisso vengono riconosciuti i seguenti nomi:
; @NAME      nome mnemonico che solitamente corrisponde alla ragione sociale del soggetto
; @CODE      è un codice numerico abbinato al nome mnemonico per evitare nomi ambigui
; @EXT       estensione del documento
; @YEAR      anno della data corrente
; @MONTH     mese della data corrente
; @DAY       giorno della data corrente

[SETUP]
;ROOTDIR = _DOC
;BAKDIR = _BAK
;IMPORTDIR = C:\CS\Documenti
;TEMPLDIR = C:\CS\Documenti\Tracciati
;SUBPATH = @NAME@CODE\@YEAR\@EXT
;PREFIX = @NAME@MONTH@DAY_
;NPROG = 4

; Estensioni riconosciute
;
; In questa posizione si possono inserire i nomi dei programmi che aprono
; i files con l'estensione indicata, se l'estensione non è presente tra queste
; viene utilizzata l'associazione predefinita di Windows.

[EXTENSIONS]
;JPG = MSPAINT.EXE
;TXT = NOTEPAD.EXE

Come si può vedere, si possono configurare vari aspetti del programma. Ad esempio si può dire con quale programma si devono aprire i files con una determinata estensione.

C'è un altro aspetto importante. Il sistema gestisce i documenti in tre modi diversi a seconda della posizione in qui si trovano nel momento che vengono importati nel sistema:
Se il file da importare si trova nella cartella di transito (solitamente C:\CS\Documenti), il file viene copiato nella cartella di sistema e cancellato dalla cartella di transito.
Se il file si trova nella cartella dei tracciati (solitamente C:\CS\Documenti\Tracciati), il file viene copiato nella cartella di sistema, ma non viene cancellato l'originale ed in questo modo si possono fare documenti simili per usi simili.
Infine se il documento si trova in un altra posizione, semplicemente viene gestito il riferimento esterno ed in questo modo si può assegnare lo stesso documento a più di un dato, ma anche si deve fare attenzione a non cancellare il documento senza cancellare anche i riferimenti.

Nel file INI dell'esempio sono anche illustrate la posizione standard di memorizzazione e le convenzioni sui nomi.


La gestione delle spunte è disponibile solo in alcuni archivi e viene solitamente attivata dai comandi speciali.

Quando viene attivata, viene visualizzata una nuova colonna alla sinistra delle altre colonne che compongono la lista delle registrazioni che si stanno utilizzando.

Facendo doppio click sulla colonna, oppure premendo invio quando ci si trova sopra, si mette o si toglie una spunta sulla riga corrente.

Se si fa click con il pulsante destro, compare un menù che permette di salvare lo stato delle spunte fino a questo momento, oppure di caricare una configurazione di spunte salvate in precedenza.

La possibilità di salvare e caricare liste di spunte consente di interrompere e riprendere il lavoro di gestione spunte in diverse sessioni di lavoro. Inoltre è utile per memorizzare liste di spunte da utilizzare per scopi specifici, ad esempio si potrebbe memorizzare una lista dei clienti a cui desideriamo mandare gli auguri di Buon Natale.

Altri comandi del menù consentono di selezionare solo le righe spuntate e quindi di nascondere le righe non spuntate e poi di invertire le spunte, oppure spuntare tutte le righe o togliere tutte le spunte.

L'utilità di gestire le spunte consiste nel fatto che alcuni comandi possono agire solo sui dati spuntati, il caso più frequente è quello delle stampe che se sono state attivate le spunte ignorano tutte le righe non spuntate.


La parte di riferimento della guida in linea illustra il funzionamento delle voci di menù del programma,

File è il menù comune a tutti i programmi Compusoft e permette di attivare procedure di servizio,
Dati contiene voci per la gestione di archivi e tabelle utilizzati dal programma.
Stampe contiene le voci di menù usate per le stampe


In questo menù sono contenute voci di manutenzione generale del programma.

Archivio di lavoro permette di scegliere l'archivio su cui lavorare,
Cambia data permette di cambiare la data di riferimento all'interno del programma,
Copia dati serve per automatizzare le copie dei dati di lavoro,
Configurazione contiene voci per configurare il programma a seconda delle necessità dell'utente,
Utilità contiene voci per la manutenzione del programma, da ultimo
Fine permette di uscire dal programma.


I programmi Compusoft permettono di lavorare su archivi diversi con dati diversi, ad esempio si possono tenere su archivi diversi i dati di ditte diverse, oppure relativi ad anni diversi. Con questa procedura si può scegliere l'archivio su cui lavorare.

Oltre a scegliere l'archivio su cui lavorare, questa procedura permette anche di creare archivi nuovi, cancellare archivi esistenti, oppure copiare dati da un archivio ad un altro. La procedura funziona come una normale gestione di files con i tasti di creazione e cancellazione abilitati, premendo il tasto di comandi speciali viene attivata la procedura di copia dati.

Per convenzione l'archivio di lavoro normalmente utilizzato si chiama "DATI", quindi se non c'è un buon motivo per utilizzare un nome diverso oppure la necessità di lavorare su più archivi si raccomanda di lavorare su questo.

Di solito i dati di ogni archivio sono fisicamente memorizzati in una cartella separata per ogni archivo dentro alla cartella contentene il programma, i dati sono nel popolare formato DBF e quindi possono essere visualizati, importati ed esportati con altri programmi, comunque per mantenere l'integrità funzionale del programma si raccomanda di non eseguire modificare i dati con programmi diversi ma usarli eventualmente solo per eseguire esportazioni.


All'avvio del programma viene presa come data di riferimento la data del computer, con questa procedura si può cambiare data al programma senza che venga cambiata la data del computer. Questa data viene proposta automaticamente in varie occasioni all'interno del programma.

premendo il pulsante collegato, o il tasto F2 si apre una finesta con un piccolo calendario, con i pulsanti del calendario si può passare da un mese all'altro, da un anno all'altro, inserire la data odierna, confermare ed annullare.


Questa procedura serve per fare le copie dei dati su dischetti o sul disco fisso.

Le copie sono molto importanti per evitare di perdere tutto il lavoro fatto in caso di perdita accidentale dei dati. La perdita dei dati fortunatamente non è un evento frequente ma è molto grave, infatti la cancellazione dei dati può comportare la perdita di centinaia di ore di lavoro ed addirittura la perdita di dati non ricostruibili, per questi motivi

Consigliamo di fare le copie dei dati molto spesso, anche ogni giorno.

Per eseguire le copie viene chiamato un programma esterno che esegue il lavoro in modo completamente automatico. Si presenta la seguente videata:

Per avviare la copia è sufficiente premere il pulsante Esegui.

La copia può essere fatta su dischetti o su disco fisso, solitamente si sceglie di salvare su disco fisso quando si dispone di un masterizzatore o di altri dispositivi di backup e gli archivi sono molto grandi tanto che la copia su dischetti risulta lenta.

Se la copia viene fatta sui dischetti, si può richiedere la formattazione, invece se la copia viene fatta su disco fisso può essere utile aggiungere al nome del file la data di copia.

I files da copiare possono essere aggiunti o tolti manualmente, ma normalmente non serve modificare i dati proposti.


Nel menù di Configurazione sono contenute voci che consentono di impostare dati di carattere generale usate dal programma,

Intestazione ditta pernette di inserire l'intestazione degli archivi quando è presente la licenza multiditta.
Dati Fissi permette di inserire alcuni dati di configurazione di carattere generale.
Licenza software è la voce che permette di abilitare la funzionalità completa del programma.
Licenza aggiornamenti con questa voce si inseriscono i dati della licenza temporanea per gli aggiornamenti.
Utenti permette di inserire la lista degli utenti autorizzati ad utilizzare il programma.
Stazioni degli Utenti permette di configurare gli utenti abituali di una stazione di lavoro.


L'intestazione multiditta è disponibile solo se è stata attivato il modulo multiditta nella licenza software.

La licenza multiditta consente di intestare gli archivi di lavoro ad utenti diversi, è una funzionalità tipicamente usata dai commercialisti che tengono la contabilità per più ditte e desiderano quindi che le stampe fiscali siano intestate ai vari clienti.

Si inseriscono i dati che si desidera vengano stampati nelle intestazioni delle pagine.


Questa voce permette di configurare alcuni dati di carattere generale del programma.

Gestione sicurezza | Abilita la richiesta di nome utente e password per entrare nel programma.
Storico accessi | Se si abilita questa funzione, ogni accesso ad una voce di menù viene memorizzata in un file di testo, su ogni riga viene memorizzata la data e l'ora dell'accesso, l'utente, la stazione e la voce di menù.
Memorizza posizione finestre | Normalmente le finestre hanno una dimensione stabilita e vengono posizionate al centro del video, ma se si abilita questa voce, il programma ricorderà la dimensione e posizione di ogni finestra.
Prezzi con 2 decimali in più | Questa voce si applica soltanto ai programmi che trattano prezzi unitari. Normalmente i prezzi e tutti gli importi monetari in genere presentano 2 decimali, si si abilita questa voce, i campi che riportano prezzi unitari vengono esposti con 4 decimali.
Abilita comandi obsoleti | Alle volte accade che per motivi tecnici o per aggiornamenti normativi, alcuni comandi non siano più attuali per cui vengono tolti dal menù e vengono resi visibili solo se richiesti esplicitamente
Abilita copie automatiche | Questa opzione fa partire automaticamente le copie alla chiusura del programma.
Archivio dati predefinito | In questa posizione si può inserire il nome dell' archivio di lavoro utilizzato comunemente in modo che se per errore si va su un altro archivio e ci si dimentica di ritornare nell'archivio abituale viene emessa una segnalazione.
Anno base delle date | Per brevità e semplicità le date vengono inserite indicando solo le ultime 2 cifre dell'anno, ad esempio il primo gennaio 2000 viene scritto "01/01/00", in questa posizione viene inserito l'anno di partenza per la gestione del secolo, in pratica se si inserisce 1980, le date con anno da 80 a 99 apparterranno al 1900 e quelle comprese tra 00 e 79 apparterranno al 2000.
Directory per copie | In questa posizione si può inserire la directory utilizzata dalla procedura di copia dati per fare le copie dei dati del programma, se si lascia vuoto questo campo la copia viene fatta sul dischetto A:\, altrimenti viene fatta nella directory indicata. Se il PC su cu si effettua la copia dispone di Windows XP è possibile copiare i dati anche su un CD.
Password per copie e conferma password | Per criptare i dati delle copie si può inserire una password di protezione.
File alternativo di database | Normalmente i dati del programma vengono memorizzati in cartelle che risiedono all'interno della cartella che contiene il programma, però in casi particolari è possibile indicare al programma che si deve utilizzare una posizione diversa, in questo campo si può memorizzare i dati sulla posizione diversa.
Editor per i campi memo | In questo campo si può inserire il nome del programma che si desidera utilizzare per modificare i campi Memo.


La licenza Software è il metodo utilizzato dalla dalla Compusoft per evitare usi non autorizzati del programma, se la chiave di attivazione inserita non è corretta per i dati del titolare della licenza ed moduli installati, il programma funziona in modalità dimostrativa, il che significa che si può provare il programma in tutte le sue parti, ma vengono impostate limitazioni nella quantità di dati inseribili.

I dati dell'utente vanno inseriti nelle prime sei righe di testo, quindi si inserisce l'elenco dei moduli installati che a seconda del programma e delle necessità dell'utente possono essere diversi, infine si inserisce il tipo di licenza che può essere per monoutenza o per multiutenza.

Con questi dati si può chiedere alla Compusoft la chiave di attivazione che è una sequenza di 10 caratteri unica per ogni combinazione di dati utente e moduli installati e che verrà fornita in base alle condizioni di cessione.

Il tipo di licenza di monoutenza o multiutenza condiziona il tipo di utilizzo che può essere fatto. In caso di monoutenza il programma potrà essere utilizzato da un solo utente, se il programma è installato in una rete di computers si potrà utilizzarlo in qualsiasi stazione, ma solo un utente per volta, questa limitazione cade in caso di multiutenza e quindi si potrà utilizzare il programma contemporaneamente da più stazioni, naturalmente il programma si preoccupa di evitare che due utenti accedano contemporaneamente allo stesso dato in modo da garantirne l'integrità.


Questa procedura serve per inserire i dati della licenza temporanea utilizzata da alcuni programmi Compusoft.

Esistono due tipi di licenza, la licenza di aggiornamento e la licenza temporanea.

La licenza di aggiornamento serve ad indicare il periodo entro cui è legittimo eseguire gli aggiornamenti del programma che possono essere facilmente eseguiti anche dall'utente finale scaricando dal sito internet di Compusoft la versione ultima del programma. Dopo la scadenza della licenza l'utente ha ancora il diritto di utilizzare pienamente il programma ma non più di eseguire aggiornamenti al programma.

La licenza temporanea invece viene utilizzata per dare la possibilità di utilizzare il programma pe un determinato periodo di tempo. Alla fine del periodo fissato il programma non permetterà più l'inserimento di nuovi dati.

Se si eseguono aggiornamenti dopo la scadenza della licenza di aggiornamento e quindi fuori dai termini di licenza, si provoca la fine del funzionamento del programma, per ripristinarne la funzionalità sarà necessario ripristinare una copia funzionante eseguita prima della scadenza della licenza, oppure richiedere alla Compusoft una estensione della licenza. Attenzione! la Compusoft non conserva le copie delle versioni compilate in data precedente all'ultima versione e quindi per ripristinare la funzionalità sarà in grado solamente di fornire estensioni di licenza .


Questa procedura permette di memorizzare la lista degli untenti abilitati ad utilizzare il programma.

La gestione degli utenti ha senso solo se è stata abilitata la sicurezza nella gestione dei Dati Fissi, in questo caso per entrare nel programma viene richiesto il nome utente e la password.

Chi non conosce un nome utente ed una password validi non riesce ad entrare nel programma.

I programmi della Compusoft possono disporre di due diversi modelli di gestione degli utenti e dei diritti. Il modello utilizzato dipende dal programma, alcuni programmi utilizzano il modello semplificato ed alri il modello completo.

Modello semplificato

Il modello semplificato di gestione degli utenti funziona in modo "Tutto o niemte" e serve solo per inibire l'accesso al programma a coloro che non conoscono i dati di login. Quando un utente riesce ad entrare ha a disposizione tutte le procedure previste senza alcuna limitazione.

Per ogni utente si memorizza il nome utente, la password e la descrizione. Vengono chiesti anche i privilegi dell'utente, ma al momento questo dato è ininfluente.

Modello completo

I programmi che utilizzano il modo completo di gestione degli utenti, permettono di stabilire in modo anche molto sofisticato quali utenti possono accedere alle varie risorse del programma.

Con questo modello si possono nascondere le voci di menù che si desidera che gli utenti non vadano, e si riesce a limitare l'accesso alle tabelle del programma.

I dati richiesti in questo tipo di gestione possono variare da programma a programma, ma solitamente sono richiesti almeno questi dati:

Codice | è il codice che identifica l'utente, ma non corrisponde con il codice che viene richiesto quando si effettua il login, invece a seconda dei programmi può essere utilizzato per indetificare gli utenti in varie procedure.
Cognome e Nome | Si inseriscono il dati anagrafici dell'utente.
Codice utente | è il codice che si inserisce in fase di login. Questo codice può essere cambiato in ogni momento.
Cambia password | Premendo questo pulsante si può cambiare la password di questo utente. La password deve essere inserita due volte per controllare che non ci siano errori di battitura.
Diritti di accesso | Premendo questo pulsante, si attiva una procedura che permette di scegliere a quali procedura ha accesso questo utente. Il funzionamento di questa procedura è spiegata assieme alla gestione dei diritti di accessi.
Data di scadenza | Vengono rifiutati i tentativi di login effettuati in data successiva a quella inserita. Se la data è in bianco, non c'è alcuna data di scadenza.
Accesso sospeso | Se si spunta questa casella, non si riesce ad effettuare il login con questo utente fino a rimozione della spunta.
Altri dati | A seconda del programma ci possono essere altri dati da inserire.

Nella gestione dei diritti di accesso, viene spiegata in dettaglio tutta la metodica utilizzata per configurare l'accesso alle varie parti del programma utilizzando la modalità completa.


Nel menù di Utilità sono contenute voci di manutenzione che servono a garantire il corretto funzionamento del programma.

Ricostruzione dati ricostruisce l'integrità dei dati dopo chiusure non corrette o accidentali del programma
Ripristina posizioni cancella la memoria della posizione e dimensione delle finestre.
Manutenzione archivio permette di modificare i dati di tutti gli archivi gestiti dal programma
Variabili utente serve per personalizzare alcune delle anagrafiche gestite dal programma.
Risorse/Informazioni permette la manutenzione di alcuni dati tecnici


Questa voce permette di ricostruire l'integrità dei dati in caso di danneggiamenti dovuti a caduta di tensione o ad uscite accidentali dal programma, volendo è anche possibile cancellare dati vecchi accumulati e non più necessari.

Viene presentata la lista delle tabelle che il programma utilizza. Per ogni tabella vengono evidenziati il nome, la descrizione della funzione della tabella, l'indicazione se qualche altro utente sta utilizzando la tabella al momento, il numero di records, la sigla ed il percorso fisico nel disco fisso.

In caso di multiutenza, se nel momento che si decide di effettuare la ricostruzione ci sono altri utenti che utilizzano il programma, le tabelle impegnate vengono evidenziate come bloccate e non è possibile ricostruirle, tra i comandi speciali è disponibile un comando che cerca le tabelle bloccate in modo di da far uscire e controllare le tabelle prima di eseguire la procedura.

Se si desidera si può spuntare o togliere la spunta alle tabelle che non si desidera ricostruire.

Quando si conferma la ricostruzione (premendo la spunta verde presente nella barra dei pulsanti), viene chiesto il tipo di ricostruzione. Di solito è sufficiente fare la reindicizzazione ma se si preferisce si può fare la compattazione che contemporaneamente recupera lo spazio utilizzato dai records cancellati.

Questa procedura potrebbe anche richiedere molto tempo se gli archivi da ristruttrare sono molto grandi, per files con centinaia di migliaia di registrazioni è normale un'attesa di 15 minuti o più. Per ogni tabella ricostruita, viene evidenziato il tempo impiegato.

Alla fine se si desidera si può stampare un resoconto delle operazioni eseguite.


Durante l'uso, il programma memorizza alcune scelte che vengono effettuate dall'utente, questa procedura permette di azzerare questi dati memorizzati. I dati che si possono azzerare sono:

La memoria delle posizioni delle finestre, questa procedura ha senso solo se è stata abilitata la memorizzazione delle posizioni delle finestre nella gestione dei dati fissi, dopo averla utilizzata le finestre quando vengono aperte vengono posizionate al centro dello schermo nella loro dimensione normale.

La memoria della posizione delle colonne nelle finestre di gestione dei dati che durante l'uso possono essere spostate con i comandi CTRL + Freccia Destra e CTRL + Freccia Sinistra.

Infine la memoria delle impostazioni delle ricerche che vengono memorizzate quando nella finestra di gestione dei dati viene premuto il tasto F2 per fare le ricerche sulle colonne dei dati.


Questa voce permette di eseguire la manutenzione di tutti i dati gestiti dal programma con accesso a tutti i campi compresi quelli che normalmente sono gestiti automaticamente dal programma e quindi nascosti all'utente.

Dopo aver scelto il nome dell'archivio da modificare, si presenta una finestra di gestione files da cui è possibile eseguire tutte le operazioni di gestione del database.

Questa procedura data la sua ampia possibilità di gestione dei dati potrebbe anche provocare incongruenze gestionali e quindi va utilizzata con la massima cautela.


In alcuni casi il programma permette di personalizzare la struttura dei dati di alcuni archivi, per esempio può essere utile inserire il numero di targa della vettura di un cliente, oppure serve aggiungere ai fornitari la marca principale trattata. In questi casi si possono utilizzare la variabili utenti.

Non tutti gli archivi possono essere configurati per utilizzare le variabili utenti, inoltre il loro utilizzo funzionale potrebbe dipendere da procedure presenti nel programma, per questi motivi per utilizzare questa funzionalità si consiglia di contattare un tecnico specializzato.


La gestione delle risorse è affidata a personale tecnico, per il momento basti sapere che le risorse sono particolari archivi in cui vengono memorizzati dati di configurazione del programma, ad esempio le risorse contengono i tracciati stampa, le liste di scelte, le voci di menù ed altri dati ancora.
Questo menù inoltre permette di visualizzare le informazioni sull'ultimo errore segnalato dal sistema, questo dato è utile in caso di segnalazioni al servizio tecnico.

Esistono diversi tipi di risorse: le risorse di sistema contengono informazioni predefinite del programma, le risorse utente contengono dati di configurazione di carattere generale o modifiche alle risorse di sistema, le risorse di archivio contengono dati relativi ad ogni singolo archivio utilizzato, le risorse di stazione contengono la memoria delle posizioni delle finestre e le risorse di database contengono la lista degli archivi apribili.


Questa voce di menù permette di uscire dal programma, richiamare questa voce è l'unico sistema per uscire in modo corretto. Si può uscire solo quando non ci sono altre finestre aperte, se ce ne sono il programma chiede se si desidera forzarne la chiusura, è preferibile rispondere "No" e chiudere manualmente tutte le finestre prima di chiudere.


Questa voce di menù permette di accedere a tutti i dati gestiti dal programma.


Un trattamento è qualsiasi operazione o complesso di operazioni compiute ed applicate a dati personali. (Art. 4)

L'archivio dei trattamenti serve per memorizzare i trattamenti fatti dall'azienda e che poi verranno impiegati per fare la stampa del "Registro dei trattamenti", e permette di inserire per ogni trattamento tutti i dati richiesti.

I dati sono articolati in modo che oltre al registro dei trattamenti si possano stampare anche tutti gli altri documenti destinati a responsabili ed addetti.

I dati richiesti sono stati strutturati seguendo uno schema condiviso ed accettato atto ad inserire tutti i dati richiesti, in particolare si è tenuto conto del tracciato proposto dal Garante belga

Esistono trattamenti comuni che vengono effettuati dalla maggior parte delle aziende, ad esempio la gestione della contabilità oppure le paghe. Altri trattamenti sono invece particolari e specifici della singola attività.

In questi casi si devono valutare attentamenti i processi seguiti per effettuare i trattamenti per valutare il livello di dettaglio e quando suddividere i trattamenti in trattamenti subordinati. In linea di massima riteniamo che un buon parametro per indentificare il trattamento sia il gruppo di addetti che lo effettuano. Addetti che fanno lo stesso tipo di lavoro sui dati, effettuano di fatto uno stesso trattamento.

I dati da inserire sono:

Codice | Il codice identifica in modo univoco il trattamento e viene proposto in modo automatico.
Titolo | E' il nome assegnato al trattamento
Finalità | Nelle finalità del trattamento si deve descrivere lo scopo per cui viene effettuato ed anche le basi che ne garantiscono la liceità. Nei casi previsti per la "Valutazione di impatto" Art. 35 si devono riportare anche i risultati ottenuti. Premendo i pulsante memo, si può inserire la descrizione, oppure se è disponibile si può utilizzare una formula di testo già pronta.
Tipo di trattamento | Riporta in modo puntuale la lista di tipologie di trattamento previste dall'art. 6 che definisce quali sono i trattamenti leciti. Premendo il pulsante a fianco o il tasto F2 si apre la lista di scelte
Dati particolari | Nel caso vengano trattati i tipi particolari di dati previsti dal art. 9, come ad esempio dati che rivelano origini etniche, opinioni politiche o dati sulla salute. Si dovrà spuntare questa casella.
Categorie particolari e subordinate | Si deve apporre la spunta su questa casella se le categoria di dati trattati riguardano soggetti deboli o subordinati come ad esempio minori, dipendenti o pazienti.
Tipo di dati e soggetti | In questa posizione si inserisce il tipo di dati trattati, ad esempio dati anagrafici, dati fiscali, contatti telefonici, email ecc... Ed anche le categorie di soggetti interessati ad esempio clienti e fornitori. Infine si deve indicare se i dati provengono da database multipli, ed infine l'origine dei dati se provenienti da fonti esterne, ad esempio dati collezionati da registri pubblici o liberamente disponibili come ad esempio elenchi telefonici raggruppati per categoria. Premendo i pulsante memo, si può inserire la descrizione, oppure se è disponibile si può utilizzare una formula di testo già pronta.
Comunicazione dei dati | In caso di comunicazione dei dati a terzi, si devono inserire le categorie di destinatari come ad esempio Banche, Commercialisti, Uffici legali e trasportatori ed anche il tipo di dati comunicati ad esempio i dati delle fatture per le richieste di incasso. Nel caso particolare di comunicazione di dati presso Paesi terzi al di fuori della Unione Europea si deve indicare la natura del trasferimento ed anche le indicazioni dei documenti di sanvaguardia che giustificano il trasferimento. Premendo i pulsante memo, si può inserire la descrizione, oppure se è disponibile si può utilizzare una formula di testo già pronta.
Notifica ed esercizio dei diritti | In questa posizione si devono indicare le modalità con cui vengono notificati i diritti degli interessati e l'eventuale necessità di consenso esplicito. Se devono anche indicare le procedure messe in atto per l'esercizio dei diritti da parte dell'interessato. Premendo i pulsante memo, si può inserire la descrizione, oppure se è disponibile si può utilizzare una formula di testo già pronta.
Codice gruppo assegnatario | Il gruppo assegnatario permette di individuare il "Responsabile del trattamento" e tutti gli addetti che sotto il controllo del responsabile hanno accesso al trattamento stesso. Premendo il pulsante a fianco o il tasto F2 si apre la lista dei gruppi.
Responsabili esterni | Il Responsabile del trattamento ha la facoltà di nominare responsabili esterni subordinati. Ad esempio si possono nominare responsabili esterni per la manutenzione del software, oppure in materia di medicina del lavoro. Premendo questo pulsante è possibile scegliere tra gli addetti esterni eventuali responsabili esterni subordinati.
Cancellazione dei dati | In questa casella si indica il periodo oltre il quale si può effettuare la cancellazione dei dati che può dipendere da vincoli contrattuali o da prescrizioni di legge. Ad esempio se viene emessa una fattura, sussiste l'obbligo di conservazione di 5 anni per motivi fiscali e 10 anni per motivi legali. Premendo pulsante collegato si apre la lista di scelte, se necessario si possono aggiungere altre scelte alla lista.
Tecnologie impiegate | Si possono descrivere brevemente le tecnologie impiegate per il trattamento. Premendo il pulsante "Strumenti", è possibile scegliere quali strumenti informatici e non informatici vengono utilizzati. A loro volta negli strumenti è possibile indicare la valutazione del rischio ed eventuali misure di mitigazione.
Note generali | Se necessario si possono scrivere ulteriori annotazioni e precisazioni.
Data inzio | Inserire la data di inizio del trattamento oppure la data di inizio del monitoraggio.
Data aggiornamento | In caso di modifiche al trattamento, inserire la data in cui sono avvenute.
Data fine | Se il trattamento viene dismesso, si può indicare la data di dismissione.
Responsabile protezione DPO | Se per questo trattamento è necessario avere un Responsabile DPO Art. 37, in questa posizione si può indicare il codice dell'addetto designato.
Trattamento sostitutivo | In caso di dismissione del trattamento, si può indicare se il trattamento dismesso è stato sostituito da un altro.

I comandi speciali disponibili sono:

Modifiche a trattamenti | Da questa posizione si possono vedere le modifiche fatte per questo trattamento
Importa trattamenti comuni | A mano a mano che viene aggiornato il programma, gli sviluppatori individuano trattamenti che potrebbero essere comuni a più tipologie di aziende e li aggiungono ad un archivio standard di trattamenti che possono essere importati e modificati per le proprie esigenze.
Spunta trattamenti | E' possibile attivare la colonna delle spunte. Se si spuntano i trattamenti in stampa verranno stampati solo gli spuntati

Le Stampe disponibili sono:

Lista trattamenti | Viene fatta una lista semplice di tutti i trattamenti
Registro dei trattamenti | E' la stampa vera e propria del registro dei trattamenti e contiene tutti i dati richiesti dalla normativa. In fase di sampa vengono fatte alcune richieste come ad esempio se si desidera stampare un trattamento per pagina e se si desidera stampare le note. La stampa viene fatta sui trattamenti spuntati ed è possibile fare selezioni in modo da stampare solo i trattamenti desiderati.


Il regolamento GDPR all art. 28 prevede che il titolare nomini un responsabile del trattamento, il quale a sua volta deve garantire che le persone autorizzate al trattamento siano impegnate alla riservatezza.

Per questo motivo, anche se non espressamente richiesto dalla normativa, abbiamo ritenuto utile formare dei gruppi di persone incaricate di effettuare il trattamento e guidate dal responsabile.

In questo modo sarà possibile individuare chi è autorizzato al trattamento e sarà possibile preparare delle lettere di incarico personalizzate con il vincolo di riservatezza.

I dati da inserire sono:

Codice | Viene assegnato automaticamente un codice univoco al gruppo.
Descrizione | Si descrive brevemente la finalità del gruppo.
Responsabile | Il responsabile è l'addetto designato dal titolare come responsabile dei trattamenti assegnati a questo gruppo.
Addetti | Facendo click su questo pulsante, viene proposta la lista di tutti gli addetti ed è possibile mettare la spunta su quelli che fanno parte di questo gruppo
Note | Se si desidera si può aggiungere una annotazione libera.
Data inizio | Si può inserire la data di formazione del gruppo.
Data fine | Se il gruppo viene sciolto, si può indicare da data da cui non è più attivo.

I comandi speciali disponibili sono:

Modifiche a gruppi | Da questa posizione si possono vedere le modifiche fatte per questo gruppo
Spunta gruppi | E' possibile attivare la colonna delle spunte.


L'archivio degli addetti serve per memorizzare i dati di tutti i soggetti conivolti nel trattamento dei dati personali. Si inseriscono i nomi dei responsabili dei trattamenti, ma anche degli addetti che operano sui dati ed anche di eventuali persone o società che abbiamo delegato come responsabile subordinato (ad esempio chi fa la manutenzione del software o il commercialista). Infine se presente anche il nome del Responsabile DPO.

Gli addetti possono appartenere a gruppi coordinati dal responsabile e sono i gruppi che operano sui trattamenti.

Per ogni tipologia di soggetto è possibile indicare il testo delle lettere di nomina o incarico, il testo può essere inserito utilizzando il formulario, in questo modo figure simili avranno lettere simili.

I dati da inserire sono:

Codice | E' il codice univoco proposto dal programma che identifica l'addetto.
Cognome e nome o denominazione ditta | Se l'addetto è una ditta, nominata ad esempio come responsabile esterno, si inseresce la denominazione. Per le persone invece si inserisce il cognome e nome separati con una virgola, in questo modo il programma sa distinguere tra nome e cognome. Premendo il pulsante a fianco, si può inserire cognome e nome separatamente.
Tipo operatore | Si può inserire una breve descrizione del ruolo dell'addetto.
Via, CAP, Città e Provinca | Inserire l'indirizzo del addetto.
Telefoni/contatti | Se si desidera si possono inserire i contatti di questo addetto.
Gruppi | Premendo questo pulsante, viene presentata la lista dei gruppi e si può mettere la spunta su quelli a cui appartiene questo addetto.
Strumenti | Premendo questo pulsante, viene presentata la lista degli strumenti e si può mettere la spunta su quelli affidati a questo addetto, che vengono aggiunti agli strumenti utilizzati per i trattamenti assegnati.
Trattamenti | Se l'addetto è esterno, premendo questo pulsante, viene presentata la lista dei trattamenti e si possono spuntare quelli a cui l'addetto è assegnato come responsabile esterno.
Note | Si può inserire una descrizione aggiuntiva generica.
Lettera di incarico | Il programma prepara automaticamente una lettera di incarico per tutti gli addetti che operano sui trattamenti. In quesa posizione si inserisce il testo con le regole da osservare. Se si desidera si può utilizzare una formula di testo già pronta tra quelle disponibili.
Nomina responsabile | Se l'addetto è nominato responsabile per alcuni trattamenti, in questa posizione si può inserire il testo della lettera di nomina. Se si desidera si può utilizzare una formula di testo già pronta tra quelle disponibili.
Responsabile esterno | Se l'addetto è stato nominato responsabile esterno per alcuni trattamenti, in questa posizione si può inserire il testo della lettera di nomina. Se si desidera si può utilizzare una formula di testo già pronta tra quelle disponibili.
Responsabile DPO | Se l'addetto è stato nominato responsabile per la protezione dei dati per alcuni trattamenti, in questa posizione si può inserire il testo della lettera di nomina. Se si desidera si può utilizzare una formula di testo già pronta tra quelle disponibili.
Femmina | Se l'addetto è di sesso femminile, si può mettere questa spunta, in questo modo nella stampa delle lettere viene tenuto conto del genere.
Esterno | Con questa spunta si indica che l'addetto non è un nostro dipendente diretto. I responsabili esterni possono essere nominati solo tra gli addetti esterni.
Data inizio | Si può inserire la data di assunzione dell'addetto.
Data fine | Si può indicare da data da cui l'addetto non è più attivo.

I comandi speciali disponibili sono:

Modifiche agli addetti | Da questa posizione si possono vedere le modifiche fatte per questo addetto
Duplica addetto | Con questo comando si possono duplicare velocemente addetti che hanno profili simili.
Spunta addetti | E' possibile attivare la colonna delle spunte.


Questo archivio serve a memorizzare la lista dei strumenti informatici e non informatici utilizzati per i trattamenti.

Oltre agli strumenti impiegati per i trattamenti si possono memorizzare gli strumenti non specifici per i trattamenti, ma comunque affidati agli addetti, in modo che possano essere citati nelle lettere di incarico.

Il censimento degli strumenti serve per individuare i rischi a cui sono sottoposti i dati dei trattamenti, il compito del titolare e del responsabile è quello di valutare l'adeguatezza degli strumenti ed in caso di necessità di pianificare le azioni necessarie a mitigare i rischi.

I dati da inserire sono:

Codice | Viene proposto un codice univoco automatico.
Descrizione | Inserire una breve descrizione dello strumento.
Tipo strumento | Si può indicare la tipologia a cui appartiene lo strumento. Questo ci dà alcune indicazione sulla categoria di rischio dello strumento.
Livello di rischio | E' una valutazione del livello di rischio a cui è sottoposto lo strumento, nel corso del tempo si tenderà ad adottare le misure atte ad abassare il livello al minimo possibile.
Descrizione estesa | Se si desidera si possono inserire ulteriori dettagli per identificare meglio lo strumento, ad esempio le caratteristiche tecniche.
Rischi | Inserire una descrizione a cui per sua natura è esposto lo strumento. A volte strumenti simili sono soggetti a rischi simili, per questo motivo se si desidera si può utilizzare una formula ricorrente per questa descrizione.
Misure di mitigazione | Nel corso del tempo, il titolare sotto la propria responsabilità adotta misure per ridurre o annullare i rischi a cui sono sottoposti i dati. In questa posizione si inseriscono le misure che vengono adottate oppure che verranno adottate in futuro. Anche in questo caso si può utilizzare una formula di testo precompilata in caso di descrizioni ricorrenti.
Data inizio | Si può inserire la data in cui viene messo in uso lo strumento.
Data aggiornamento | Inserire la data in qui è stato aggiornato per l'ultima volta lo strumento, ad esempio per aggiornare le misure di mitigazione dei rischi.
Data fine | Si può indicare la data di dismissione dello strumento.
Trattamenti | Premendo questo pulsante, viene presentata la lista dei trattamenti e si può mettere la spunta su quelli che hanno in uso questo strumento.
Addetti | Premendo questo pulsante, viene presentata la lista degli addetti a cui viene affidato lo strumento e si può mettere la spunta sugli addetti che lo hanno in uso. Gli addetti oltre agli strumenti affidati direttamente hanno in uso anche gli strumenti utilizzati per i trattamenti a cui sono stati incaricati.

I comandi speciali disponibili sono:

Modifiche agli strumenti | Da questa posizione si possono vedere le modifiche fatte per questo strumento, ad esempio quando vengono messe in atto misure di mitigazione dei rischi.
Duplica strumento | Con questo comando si possono duplicare velocemente strumenti simili.
Importa strumenti comuni | A mano a mano che viene aggiornato il programma, gli sviluppatori individuano stumenti che potrebbero essere comuni per più tipologie di aziende e li aggiungono ad un archivio standard di strumenti che possono essere importati e modificati per le proprie esigenze.
Spunta strumenti | E' possibile attivare la colonna delle spunte.


A mano a mano che vengono fatte modifiche ai dati o perché vengono modificati trattamenti, strumenti o addetti, oppure perché vengono messe in atto misure per la protezione dei dati, è bene che tali modifiche vengano segnalate in modo da certidicare il lavoro che viene fatto in termini di gestione della sicurezza dei dati.

In questa tabella si possono inserire tali modifiche.

I dati da inserire sono:

Codice | Viene proposto un codice univoco automatico.
Data | Inserire la data in cui viene messa in atto la modifica.
Nota interna | Le note interne sono riservate e non vengono stampate su documenti come ad esempio il Registro dei Trattamenti.
Tipo modifica | Si possono catalogare le modifiche in base alla loro tipologia.
Descrizione | Inserire una breve descrizione della modifica
Note | Se si desidera, si può inserire una descrizione più estesa della modifica fatta.
Codice trattamento, strumento, gruppo, addetto | Si possono inserire codici dei dati pertinenti coinvolti nella modifica. Si possono inserire tutte le tipologie, oppure solo alcune.

I comandi speciali disponibili sono:

Spunta modifiche Si apre una colonna che permette di spuntare le modifiche in questo modo quando si stampa la lista delle modifiche verranno stampate solo quelle spuntate.


Questo sotto menù permette di accedere a dati usati raramente.

Oltre a contenere i dati di utenti e formulari, si possono anche inserire liste di scelte utilizzati in alcune posizioni del programma.


Se si desidera si può fare in modo che l'uso di questo programma venga protetto da password.

Questa tabella serve per memorizzare gli utenti che accedono al programma ed i diritti di accesso alle varie voci di menu.


Questo archivio contiene i testi delle formule di testo standard utilizzate in vari punti del programma.

Sarebbe preferile non modificare i dati che vi sono contenuti perché gli sviluppatori hanno messo a punto una procedura che permette di tenere sempre aggiornato questo archivio a mano a mano che vengono apportate migliorie ai testi standard.

In fase di inserimento di una formula in un campo che la prevede, è possibile richiedere la visualizzazione del testo in modo da controllare se corrisponde a quello che serve ed in caso per copiare il testo da inserire nel campo e modificare.


Le procedure di manutenzione vengono eseguite raramente e solo in caso di necessità.

Oltre alla procedura per l'aggiornamento del formulario e per importare dati aggiornati forniti dai tecnici via email di volta in volta, è anche possibile accedere alle tabelle usate per i collegamenti tra gli archivi principali del programma quando sussistono relazioni di molti a molti.


Il formulario viene utilizzato in vari punti del programma per utilizzare testi comuni nelle varie tipoligie di documenti che vengono prodotti.

I produttori del software aggiornano costantemente i testi contenuti nel formulario in modo da metterlo a disposizione degli utenti che possono in questo modo utilizzare testi adeguati in termini di aderenza alla normativa e per problematiche comuni.

Dopo aver aggiornato il programma con le con le metodiche illustrate dal personale tecnico, con questa procedura è possibile aggiornare i testi del formulario standard.

Per questo motivo si consiglia di non modificare manualmente i dati del formulario, ma di affidarsi sempre ai testi proposti.

Prima di procedere, per motivi di sicurezza il programma chiede conferma per eseguire.


Può succedere che il personale addetto alla istruzione ed al rilevamento dei dati, prelevi i dati per controlli e revisioni da effettuare presso i propri uffici e per aggiornare i dati della licenza software.

In questi casi dopo aver fatto le opportune revisioni, al cliente verrà inviata una mail con i dati e la licenza aggiornati, ed anche con i documenti stampati in formato PDF.

Con questa procedura è possibile aggiornare i dati sostituendo quelli presenti con quelli ricevuti via mail.

Per evitare perdite di dati, si consiglia di fare le copie prima di procedere alla importazione.

In ogni caso prima di procedere per maggiore sicurezza viene chiesta la conferma.


Da questa voce di menù è possibile effettuare tutte le stampe previste dal programma.


Il registro dei trattamenti è la stampa più importante del programma.

La stampa riporta lo stato di tutti i trattamenti attivi al momento in cui viene effettuata. Per ogni trattamento vengono riportati tutti i dati richiesti dalla normativa, e vengono anche riportate le modifiche fatte nel tempo.


Viene fatta una stampa che contiene le lettera di nomina di tutti i responsabili dei trattamenti.

Per ogni addetto individuato come responsabile di un gruppo assegnato ai trattamenti, viene stampata la lista di tutti i trattamenti di cui è responsabile, e di seguito viene riportato il testo che gli è stato assegnato in qualità di responsabile.


I responsabili esterni o subordinati sono soggetti nominati dal responsabile dei trattamenti per occuparsi di particolari aspetti dei trattamenti, ad esempio responsabili esterni potrebbero essere i consulenti informatici, i commercialisti o i consulenti del lavoro.

Questa stampa permette di produrre tutte le lettere di nomina per i responsabili esterni elencando i trattamenti a cui sono stati nominati.


Il responsabile della sicurezza dei dati (DPO) è una figura particolare richiesta in alcuni casi specifici, ad esempio per le pubbliche amministrazioni o per le aziende al di sopra dei 250 dipendenti o infine per coloro che effettuano tipi particolari di trattamenti.

In caso di necessità si può assegnare ai trattamenti i codice dell'addetto individuato come DPO.

Viene fatta una stampa che contiene le lettera di nomina di tutti i responsabili DPO.

Per ogni addetto individuato come DPO di trattamento, viene stampata la lista di tutti i trattamenti di cui è responsabile, e di seguito viene riportato il testo che gli è stato assegnato in qualità di responsabile.


Benché non espressamente richiesto dalla normativa, è bene individuare gli addetti che sono incaricati ai trattamenti dei dati. In questo modo si potra indicare chiaramente quali sono i trattamente a cui sono addetti e si possono stabilire le regole di comportamento atte a migliorare la sicurezza dei dati.

Per ogni addetto vengono elencati i trattamenti a cui è incaricato e la lista degli strumenti che gli vengono messi a disposizione.

Alla fine di tali liste viene stampato il testo contenente le regole aziendali che deve rispettare per garantire la sicurezza dei dati, il testo riportato è quello che gli è stato assegnato in fase di inserimento dell'addetto.


Se è stato installato il programma BullZip PDF Printer, è possibile attivare questa procedura che prepara automaticamente tutte le stampe previste dal programma in formato PDF.

Le stampe vengono messe in una cartella contenuta nella stessa cartella del programma e che nel titolo contiene la data in cui vengono fatte le stampe. In questo modo si possono conservare le stampe effettuate in momenti diversi.


Questa procedura, se presente, permette di assegnare una stazione di lavoro ad un utente anche se il programma non è stato configurato per la gestione della sicurezza.

In pratica, siccome si suppone che un utente lavori abitualmente sempre su una stessa stazione o al massimo alcune stazioni, con questa procedura su indica al programma quale è l'agente che presumibilmente utilizza il programma.

Alcuni programmi possono utilizzare questi dati di configurazione per fornire informazioni automatiche all'utente abituale.

Per aggiungere una stazione si aggiunge una riga e poi si inseriscono i seguenti dati:

Stazione | Indicare il nome della stazione che è composta dal nome del computer più il nome dell'utente inserito al momento dell'accesso al computer. Il tasto a fianco assegna automaticamente i dati relativi alla stazione corrente.
Utente | Inserire il codice dell'utente corrispondente.
Note | Se si desidera si può inserire una breve nota.

Ogni utente può essere l'utente preferenziale di più di una stazione, però se per la stessa stazione si inserisce più di un utente, viene preso in considerazione solo il primo.


Le procedure specifiche del programma sono raggiungibile con due voci di menù.

Il menù dati permette di inserire tutti i dati del programma.

Il menù stampe invece permette di effettuare le stampe che sono il risultato della elaborazione dei dati inseriti.