Programma Zefiro

Guida in linea del programma
Zefiro

Il programma Zefiro è destinato alla gestione amministrativa e contabile completa di un'azienda. Nella parte contabile si inseriscono le registrazioni contabili e si ottengono le stampe necessarie ai fini fiscali e per uso amministrativo. Nella parte gestionale si inseriscono documenti di magazzino come ad esempio ordini, documenti di trasporto e fatture, si gestiscono le giacenze di magazzino e si ottengono varie stampe di tipo statistico. Il programma inoltre dispone di molte procedure per risolvere esigenze specifiche, ad esempio è disponibile la gestione completa di scadenze passive ed attive, si possono gestire cespiti, ritenute d'acconto, articoli con varianti, provvigioni agenti e molto altro.

Il programma è modulare, questo significa che l'utente può acquistare solo i moduli di cui ha bisogno ed acquistare altri moduli in seguito se si presenterà l'esigenza.

Gli utenti che già utilizzano il programma dopo ogni aggiornamento possono vedere queli sono state le novità introdotte consultando la pagina delle versioni del programma.

La guida si compone di una parte generale che descrive il funzionamento delle principali modalità operative del programma, ad esempio vengono descritti l'uso della tastiera nei vari punti del programma e l'uso dei pulsanti standard delle finestre.

Nella parte di riferimento del programma vengono descrittele voci che compongono il menù del programma. La guida descrive la versione più completa del programma, perciò sono presenti tutte le voci di menù, è possibile invece che l'utente disponga di una versione con un numero minore di moduli installati e quindi con minori voci di menù.

Inseriamo anche alcuni testi di carattere generale utili alla comprensione di alcuni argomenti correlati alla gestione aziendale.

Introduzione alla contabilità è un breve testo che spiega alcuni principi di contabilità agli utenti che non conoscono questa meteria.
Codifica degli articoli fornisce alcuni suggerimenti sugli scopi e le tecniche da utilizzare per la codifica degli articoli di magazzino.


Zefiro è un programma modulare, questo significa delle molte funzionalità di cui dispone il cliente può acquistare solo quelle di cui ha effettivamente bisogno. Le principali funzionalità vengono attivate automaticamente quando l'utente installa la versione dimostrativa del programma, altre possono essere attivate in modalità dimostrativa inserendo manualmente il codice del modulo nella procedura di attivazione del programma.

Alcuni moduli per funzionare hanno bisogno di altri moduli, ad esempio la procedura di gestione dei Cespiti necessita del modulo di Contabilità, oppure la gestione della Vendita al banco richiede la presenza del modulo di Magazzino, in ogni caso il programma richiede la presenza minima o del modulo di Contabilità o del modulo di Magazzino.

La presente guida illustra tutte le funzionalità del programma, anche se queste non sono presenti nella configurazione scelta dall'utente.

I moduli disponibili sono:

CNT | Contabilità | È il modulo di gestione della contabilità ordinaria con il metodo della partita doppia, gestisce anche tutta la problematica IVA e di gestione dei bilanci.
MAG | Magazzino e documenti | È il modulo di gestione del magazzino attraverso l'inserimento di documenti di magazzino di vario tipo
POR | Scadenzario e portafoglio effetti | Serve per la gestione automatica di incassi e pagamenti, ha un legame automatico con il magazzino e la contabilità e permette di gestire le distinte bancarie e le RI.BA.
SCD | Scadenze impegni | Con questo modulo si possono gestire scadenze generiche di varia natura.
RIT | Ritenute d'acconto | Serve per la gestione dei pagamenti di ritenute d'acconto a professionisti, questo modulo è collegato alla contabilità.
FPA | Fattura PA e Split Payment | Coloro che emettono fatture agli enti pubblici devono sottostare alle norme sulla fattura elettronica e sullo split payment, questo modulo permette di gestire tutta la problematica.
CSP | Cespiti | Serve per tenere il registro dei beni ammortizzabili e per la gestione delle scritture contabili collegate.
ANT | Anticipi bancari | Questo modulo è in grado di tenere conto delle concessioni di credito che le banche fanno su presentazione di fatture di vendita.
PCR | Riclassificazione piano dei conti | Con questo moduli si possono realizzare bilanci riclassificati secondo vari criteri per ottenere indici di bilancio, bilanci previsionali, bilancio europeo ed altro.
FTT | Fatturazione semplice | È una piccola procedura di fatturazione che può essere utilizzata da chi utilizza la Contabilità ma non ha bisogno di una procedura complessa di gestione documenti di magazzino.
DEP | Gestione depositi e cantieri | È un modulo legato alla gestione di magazzino che consente di utilizzare depositi multipli, questa procedura serve anche per la gestione della tentata vendita e per la gestione di cantieri.
VRN | Gestione varianti | Questo modulo consente di gestire gli articoli con varianti, utile per la gestione della produzione ed in altri casi circoscritti.
AGE | Agenti e provvigioni | Serve per la gestione delle provvigioni degli agenti e per i calcoli dei budget di vendita.
BCO | Vendita al banco | Questo modulo aggiuntivo della procedura di Magazzino serve per gestire la vendita diretta al pubblico e per le operazioni in cui è richiesta la gestione dei codici a barre.
DST | Distinta Base | È il modulo base per la gestione della produzione, permette di inserire le Distinte di componenti che servono per realizzare un composto, permette inoltre di inserire i documenti di produzione che scaricano la materia prima e caricano il prodotto finito.
CRM | Gestione Contatti | Questo modulo permette di memorizzare informazioni sui contatti che intercorrono tra l'azienda ed i propri clienti e fornitori, viene messa anche a disposizione la gestione documentale che lega a specifici clienti, fornitori ed articoli i documenti elettronici che li riguardano.
ECZ | E-Commerce | Questo modulo permette di interfacciare Zefiro al programma di commercio on-line ZenCart. Si possono esportare gli articoli, i clienti e tutti i dati necessari, e si possono importare gli ordini raccolti con ZenCart.
CVA | Gestione veicoli usati | Questo modulo è utile alle ditte che vengono autoveicoli usati. Permette di memorizzare i dati dei veicoli oggetto di compravendita e di eseguire vari tipi di procedure come ad esempio la gestione della sospensione d'imposta e la stampa dei registri di beni usati.
TVE | Tentata vendita | Questo modulo permette di produrre documenti di tentata vendita con l'utilizzo di terminali portatili ed il caricamento automatico degli stessi nei documenti di magazzino.
DCA | Cauzioni noleggi e comodati | Questo modulo viene utilizzato soprattutto per gestire le cauzioni di contenitori con cui viene consegnata la merce che viene venduta, ma può essere utilizzata anche per la gestione di noleggi e comodati d'uso, alcune procedure consentono di stampare la lista dei depositi esistenti presso clienti.
TRT | Rintracciabilità alimenti | Questa procedure permette di gestire la rintracciabilità degli alimenti come richiesto dal Recgolamento CE 178/2002.
PCV | Commercializzazione vini | Questo modulo permette di stampare i registri richiesti dalla normativa che regola la produzione e la commercializzazione di vino.
AGR | Vendita prodotti per agricoltura. | Questo modulo aggiunge alcune funzinalità utili per chi vende prodotti per l'agricoltura, in particolare vengono effettuate stampe speciali per la gestione dei fitofarmaci e vengono gestiti i lotti di sementi.
MTR | Gestione matricole articoli | Questo modulo pemette di inserire e rintracciare i numeri di matricola dei prodotti.
SCF | Saldaconto fatture | Questo modulo serve a coloro che emettono fatture e non gestiscono la contabilità ma vogliono tenere traccia dei saldi delle fatture e delle note di accredito emesse.
QLT | Qualità ISO 9001:2008 | Sono state aggiunte alcune procedure e tabelle per la gestione della documentazione richiesta per la certificazione ISO 9001:2008.
CMB | Commesse forniture | Questo modulo è stato sviluppato appositamente per la gestione di forniture di mobili, arredo bagno e materiale edile in genere.


Questa pagina contiene la traccia delle modifiche che vengono apportate nel tempo al programma. In questo modo gli utenti possono verificare personalmente le novità introdotte mano a mano che vengono fatti aggiornamenti, le modifiche vengono presentate in ordine inverso di data.

2.30.1 | 21/13/24 | Aggiunta l'importazione di tutte le fatture d'acquisto presenti in una cartella, ed aggiunta la possibilità di stampare sempre le fatture di acquisto importate anche con apertura degli allegati.
2.29.7 | 02/10/23 | Migliorata la stampa di "Raggruppamento righe" dei documenti con aggiunta della esportazione anche parametrizzata dei dati.
2.29.6 | 19/09/23 | Nei documenti le spese di incasso vengono addebitate automaticamente solo in fattura.
2.29.5 | 18/09/23 | Nella gestione dei fidi ai clienti è stata aggiunta la possibilità di configurare un fido aggiuntivo in AGC.ini per distinguere ad esempio i fidi assicurati da quelli commerciali.
2.29.4 | 18/09/23 | Aggiunta la stampa del giornale di magazzino.
2.29.3 | 21/07/23 | Posizione finestra principale, il programma ricorda l'ultima posizione della finestra, ma se necessario si può ripristinare la posizione predefinita passando il parametro /REPOS sulla riga di comando.
2.29.2 | 21/07/23 | Gestione multi monitor, ora il programma posiziona bene le finestra anche sui monitor diversi da quello principale.
2.29.1 | 27/06/23 | Aggiunto campo Ammortamento primo anno intero per i cespiti. Ricalcolo cespiti.
2.28.27 | 29/05/23 | Miglioramenti a Gestione cespiti: Stampa definitiva senza scrittura, calcolo ammortamenti di più anni, visualizza righe spunta righe ecc...
2.28.26 | 05/05/23 | Fattura elettronica, in agc.ini fissata l'aliquota iva per le righe descrittive ed il numero di decimali dei prezzi unitari
2.28.25 | 17/04/23 | Gestione giacenze, aggiunta procedura di controllo del valore delle giacenze consolidate e miglioramento calcolo giacenza da articoli.
2.28.24 | 13/03/23 | Gestione registri IVA esclusi da liquidazione IVA autotrasportatori
2.28.23 | 17/02/23 | Genera ordine a fornitore da ordine cliente, applica la logica del costo standard.
2.28.22 | 17/02/23 | Aggiunto il controllo della data inserimento documenti, segnala se la data si discosta oltre un certo numero di giorni dalla data corrente.
2.28.21 | 13/02/23 | Evasione/ripristino ordini, aggiunta la possibilità di agire solo sui flag di forzatura
2.28.20 | 05/01/23 | La stampa del fatturato dei clienti ora suddivide gli imponibili fino a 5 anni, e si può scegliere la stampa estesa o compatta
2.28.19 | 13/12/22 | La procedura di importazione articoli da file, ora permette di importare prezzi di listino con sconti. Vedi _EXTRA\ImportART.cfg
2.28.18 | 04/10/22 | Aggiunta la possibilità di esportare tutti i dati dei documenti di magazzino e di configurare il formato.
2.28.17 | 02/09/22 | Ora l'esportazione che si fa dalla stampa inventario può essere parametrizzata in AGC.ini
2.28.16 | 20/06/22 | Ora la conversione semplice di unità di misura nei documenti è bidirezionale.
2.28.15 | 01/06/22 | Fattura elettronica: cambiato il tipo di dato in idDocumento ed aggiunto il campo Riferimento amministrazione per le fatture PA.
2.28.14 | 20/05/22 | Calcola la decorrenza termini di tutte le iva per cassa fino alla data indicata
2.28.13 | 18/05/22 | Aggiunta la validazione delle fatture elettroniche prima dell'invio a SdI
2.28.12 | 13/05/22 | Nella stampa dei cespiti vengono evidenziati i giorni di possesso e la data di cessione per possibili operazioni di calcolo.
2.28.11 | 12/05/22 | Dagli articoli posso chiedere la "Lista evasione articolo" che permette di vedere lo stato di evasione ordini o conto lavoro di quel articolo.
2.28.10 | 02/05/22 | Aggiunto il campo "Categorie merceologiche" ai fornitori, utile per fare selezioni.
2.28.9 | 14/04/22 | In evasione documenti di magazzino c'è un comando rapido per evadere completamente una riga.
2.28.8 | 14/04/22 | Aggiunta la gestione degli arrotondamenti di riga nei documenti di magazzino.
2.28.7 | 07/04/22 | Aggiunta la possibilità di inviare email generiche per i documenti di magazzino.
2.28.6 | 06/04/22 | Aggiunta la chiave di ricerca per le mail inviate.
2.28.5 | 24/03/22 | Nel file AGC.ini è possibile configurare un file di configurazione sendmail.ini diverso da quello standard.
2.28.4 | 15/03/22 | In documenti se nel primo ordine da evadere le condizioni sono diverse viene proposto di aggiornare i dati di testata. (Abilitare in agc.ini)
2.28.3 | 11/03/22 | Importazione Fattura elettronica, apre allegati da finestra di importazione.
2.28.2 | 02/03/22 | Fattura elettronica, applica split payment solo alle righe con iva.
2.28.1 | 02/02/22 | Aggiunta procedure ricalcolo stato evasione ordini
2.28.0 | 19/01/22 | Modificata la gestione della qualità, aggiunti i campi "origine del problema" alla gestione delle non conformità.
2.27.13 | 14/01/22 | Nel file agc.ini si possono configurare i tipi di documento da escludere nei riferimenti di DDT nella fattura elettronica.
2.27.12 | 07/12/21 | Aggiunti i riferimenti alla dichiarazione d'intento nella fattura elettronica
2.27.11 | 23/11/21 | Ora è possibile configurare per ogni stazione il server ed il mittente per l'invio delle email
2.27.10 | 28/10/21 | In Scadenze Impegni ora si possono generare le scadenze dei sottogruppi e notificare gli avvisi di tutti gli agenti
2.27.9 | 26/10/21 | Aggiunto il confronto tra le scadenze calcolate ed importate in importazione fatture elettroniche.
2.27.8 | 25/10/21 | Aggiunto CDC predefinito nel piano dei conti e riclassificazione movimenti
2.27.7 | 21/10/21 | Aggiunti campi liberi ai clienti e resi obsoleti i campi utente e password
2.27.6 | 09/09/21 | Controllo scadenze / saldi contabili
2.27.6 | 07/09/21 | Nuova procedura di ricalcolo dei protocolli.
2.27.5 | 20/07/21 | Calcolo IVA a forfait regimi agricoli
2.27.4 | 30/06/21 | Aumentato da 10 a 60 il numero dei registri IVA disponibili
2.27.3 | 21/05/21 | Aggiunto il campo "Non in uso" ai fornitori, in import fatture elettroniche prima si cercano quelli in uso e poi tutti.
2.27.2 | 20/05/21 | Nel calcolo della quota di ammortamento cespiti del primo anno si può decidere se calcolare a forfait in 50% o se calcolare i giorni di effettivo utilizzo
2.27.1 | 12/05/21 | Nei tipi di documento si può inserire il numero di decimali dei prezzi del documento.
2.27.0 | 03/05/21 | Cambiate le procedure per la gestione degli inventari
2.26.5 | 16/04/21 | Esportazione stampa giacenze, importazione documenti da file, ricalcolo data ultimo movimento articoli.
2.26.4 | 30/03/21 | Nelle note d'accredito generate automaticamente vengono riportati i riferimenti alla fattura come riga descrittiva ed anche nella fattura elettronica.
2.26.3 | 25/03/21 | Sistemazione della esportazione dei contatti di clienti e fornitori e delle circolari email
2.26.2 | 12/03/21 | Nella lista degli ordini inevasi si può decidere di esportare i dati in Excel o altri formati
2.26.1 | 23/02/21 | Aggiunta le gestione dei costi standard degli articoli, se presenti vengono utilizzati al posto del costo ultimo
2.25.2 | 20/01/21 | Aggiunta la colonna della ragione sociale nelle scadenze ed aggiunti i colori per tipo di scadenza
2.25.1 | 04/01/21 | Aggiunta la gestione della generazione automatica delle righe di magazzino.
2.24.8 | 23/12/20 | Aggiunta la soglia per la distinzione tra Sconto ed Arrotondamento in fattura elettronica
2.24.7 | 14/12/20 | Aggiunta la gestione delle auto fatture per la fattura elettronica 1.6 con i documenti SDF
2.24.6 | 23/11/20 | La procedura controllo costo ultimo degli articoli ora permette di aggiornare i costi.
2.24.5 | 20/11/20 | Modificata la gestione della scontistica di magazzino, ora sono stati aggiunti gli sconti per quantità.
2.24.4 | 21/10/20 | Aggiunta la generazione del bilancio riclassificato.
2.24.3 | 13/10/20 | Stampa scadenze da tabella clienti e fornitori, in questo modo si possono scegliere le anagrafiche da stampare.
2.24.2 | 03/09/20 | Attivata la contabilità dipartimentale che consente di sommare i bilanci e le liquidazioni di più dati separati.
2.24.1 | 28/08/20 | Aggiunta la gestione degli stati dei documenti
2.23.5 | 27/08/20 | Da documenti, quando si inviano le mail di tutti i documenti spuntati con forzatura del destinatario, si controlla se le anagrafiche sono omogenee.
2.23.4 | 22/07/20 | Ora la comunicazione Esterometro può essere anche trimestrale.
2.23.3 | 24/06/20 | Dalla primanota si possono selezionare e spuntare le registrazione che si desidera e poi si può calcolare il bilancio solo delle registrazione scelte.
2.23.2 | 11/05/20 | Attivata la possibilità di filtrare le righe dei documenti in fase di stampa. Le procedure di filtro possono essere personalizzate per ciascun tipo di documento.
2.23.1 | 21/04/20 | Attivata la versione 1.6 della fatturazione elettronica
2.22.15 | 26/02/20 | Agli articoli è stata aggiunta una procedura per calcolare variazioni automatiche dei prezzi di costo. Si può variare il costo in percentuale ed anche gli sconti in valore assoluto o precentuale.
2.22.14 | 25/02/20 | La procedura "Evadibilità ordine" dei documenti ora produce una stampa con il dettaglio della giacenza con la situazione degli ordini clienti e fornitori
2.22.13 | 25/02/20 | Modificata la stampa del fatturato Clienti e Fornitori, è stato aggiungo il raggruppamento per Provincia ed è possibile esportare i risultati in Excel o LibreOffice per ulteriori analisi.
2.22.12 | 30/01/20 | Nella stampa del riepilogo dei documenti si possono escludere le righe di articoli che appartengono a determinati gruppi, ad esempio per escludere spese di trasporto o altro.
2.22.11 | 20/01/20 | Ora è possibile emettere fatture elettroniche semplificate anche per clienti esteri.
2.22.10 | 23/12/19 | Migliorato il protocollo di importazione articoli da terminale, ora si possono importare files nei formati previsti anche provenienti dal programma ListeCodici per Android.
2.22.9 | 06/12/19 | Aggiunta la procedura per la generazione delle scritture "Fatture da ricevere" per le scritture registrate in data di ricezione.
2.22.8 | 28/11/19 | Nella liquidazione IVA ora si possono inserire annotazioni libere.
2.22.7 | 22/11/19 | Aggiunto il tracciato della stampa inventario con codici a barre per i controlli.
2.22.6 | 22/11/19 | La stampa inventario può essere fatta dagli articoli e tiene conto di selezioni e spunte.
2.22.5 | 19/11/19 | E' stato aggiunto un tracciato per stampare il riepilogo dei documenti di magazzino suddiviso per aliquota iva.
2.22.4 | 12/11/19 | E' possibile configurare le mail per inviare i titoli cambiando da maiuscole a minuscole.
2.22.3 | 24/10/19 | Nei documenti di magazzino è possibile generare automaticamente una Nota d'accredito a partire da una Fattura.
2.22.2 | 17/10/19 | Aggiunto il campo per inserire il tetto imponibile Enasarco.
2.22.1 | 16/09/19 | Aggiunta le gestione della fattura elettronica semplificata. Per emettere le fatture si usa il cliente generico configurato nelle preferenze ed il formato viene riconosciuto anche per l'importazione.
2.21.13 | 29/07/19 | Ora la procedura di stampa liquidazione IVA genera automaticamente le scritture contabili dei giroconti IVA
2.21.12 | 26/07/19 | Ora in fase di importazione delle fatture elettroniche in contabilità è stata attivata l'importazione automatica dei cespiti e delle ritenute d'acconto.
2.21.11 | 25/07/19 | Nella stampa del registro acquisti vengono evidenziate meglio le registrazioni con competenza iva diversa.
2.21.10 | 01/07/19 | Ora è possibile inserire il numero di decimali dei prezzi per singoli documenti. Si tiene conto dei decimali nella evasione degli ordini e nella fattura differita.
2.21.9 | 01/07/19 | Nella fatturazione automatica ora si può scegliere se datare le fatture con la data dell'ultimo DDT di ogni cliente.
2.21.8 | 26/06/19 | Nella stampa del fatturato di clienti e fornitori ora viene evidenziata la data dell'ultima fattura emessa o ricevuta.
2.21.7 | 25/06/19 | Nei documenti evadibili (Ordini, C/Lavoro, ecc...) si possono colorare le righe in base allo stato di evasione.
2.21.6 | 10/06/19 | Ora nelle stampe che hanno più di un tracciato è stato aggiunto un pulsante per copiare il titolo dal tracciato al titolo della stampa.
2.21.5 | 10/05/19 | Aggiunto il modulo per la gestione dei centri di costo
2.21.4 | 09/05/19 | Ristrutturazione del file AGC.INI, ora le voci possono essere raggruppate in sezioni più dettagliate, le configurazioni precedenti continuano a funzionare.
2.21.3 | 06/05/19 | Nell'importazione delle fatture elettroniche ora si possono aprire gli allegati
2.21.2 | 02/05/19 | Aggiunta la possibilità di allegare la fattura in formato PDF alle fatture elettroniche ed anche di aggiungere un allegato di propria scelta.
2.21.1 | 29/04/19 | Aggiunta la gestione della messaggistica interna tra utenti
2.20.32 | 17/04/19 | Aggiunta la procedura per preparare la comunicazione "Esterometro"
2.20.31 | 16/04/19 | Quando si preparano le fatture elettroniche ora si può scegliere se inviare oppure no le proprie mail in caso di assenza delle mail dei destinatari.
2.20.30 | 16/04/19 | Nella importazione delle note d'accredito elettroniche se gli importi sono negativi vengono girati di segno
2.20.29 | 15/04/19 | Nella stampa dei registri e delle liquidazioni si possono stampare separatamente gli importi con IVA per competenza diversa del periodo.
2.20.28 | 10/04/19 | Aggiunti alcuni controlli sulla validità dei dati anagrafici per la fattura elettronica.
2.20.27 | 05/04/19 | Aggiunta nei clienti e fornitori la possibilità di mandare circolari tramite e mail.
2.20.26 | 05/04/19 | Nei documenti di magazzino, ora è possibile convertire le righe da Articolo ad Extramagazzino e viceversa.
2.20.25 | 20/03/19 | Modificata la stampa del fatturato Clienti e Fornitori, ora è possibile raggruppare i dati secondo vari criteri e c'è il calcolo della percentuale per ogni anagrafica rispetto al gruppo ed al totale.
2.20.24 | 12/03/19 | Aggiunta la procedura per copiare righe della distinta base da incollare o cancellare su tutti gli articoli spuntati
2.20.23 | 07/03/19 | Aggiunto il campo data di competenza in fase di importazione delle fatture elettroniche.
2.20.22 | 05/03/19 | In fase di importazione delle fatture elettroniche in contabilità è possibile cambiare il codice numerico assegnato per evitare ambiguità nei numeri alfanumerici.
2.20.21 | 22/02/19 | Aggiunta la possibilità di inserire diciture fisse nelle fatture elettroniche
2.20.20 | 04/02/19 | Aumentata a 5 la scaletta dei prezzi per quantità di clienti e fornitori
2.20.19 | 01/02/19 | Nella preparazione cumulativa delle fatture elettroniche, si possono scegliere le fatture da spedire ed eventualmente di rispedire anche quelle preparate in precedenza.
2.20.18 | 30/01/19 | Ora la fattura elettronica tiene anche conto di Enasarco.
2.20.17 | 23/01/19 | E' possibile segnalare nei documenti di magazzino articoli non movimentati da oltre un certo periodo.
2.20.16 | 11/01/19 | Ai clienti è stata aggiunta la stampa della lista dei recapiti per la fattura elettronica per sapere se i clienti che si andranno a fatturare hanno tutti i dati necessari
2.20.15 | 11/01/19 | Velocizzata l'apertura delle finestre con colonne non modificate.
2.20.14 | 11/01/19 | Modificata la gestione dei bolli in fattura. Ora si possono dichiarare il clienti soggetti a bollo oppure si possono applicare i bolli a tutte le fatture.
2.20.13 | 11/01/19 | Nelle anagrafiche dei clienti ora si possono inserire solo provincie a due cifre e codice SDI al massimo di 7 caratteri
2.20.12 | 21/12/18 | Configurati alcuni portali di spedizione delle fatture elettroniche, gestione cartella predefinita di import fatture.
2.20.11 | 14/12/18 | Ora si può leggere e stampare direttamente una fattura elettronica, nel formato ministeriale o nel formato proposto da AssoSoftware.
2.20.10 | 07/12/18 | Nel file di configurazione AGC.INI si possono inserire parametri per la fatturazione elettronica.
2.20.9 | 30/11/18 | Nei tracciati stampa delle fatture è possibile inserire la dicitura "Documento di cortesia" per le fatture elettroniche a soggetti con partita iva.
2.20.9 | 13/11/18 | Viene preparata la fattura elettronica anche per le fatture con ritenute d'acconto, nelle preferenze di magazzino si deve inserire la causale di pagamento prevista nel Modello 770.
2.20.8 | 31/10/18 | In contabilità è possibile cambiare la data di competenza IVA che consente di cambiare la data di calcolo ai fini della liquidazione iva.
2.20.7 | 30/10/18 | E' stata aggiunta la procedura per la stampa della lista dei bolli virtuali applicati alle fatture elettroniche, in modo da effettuare il pagamento a consuntivo.
2.20.6 | 29/10/18 | Nella lista dei clienti nei tipi di contatto sono visibili anche il tipo 'P' che indica se è stata inserita la PEC ed il tipo 'U' che indica la presenza del codice univoco per la fattura elettronica.
2.20.5 | 19/10/18 | Si possono importare anche fatture elettroniche firmate.
2.20.4 | 19/10/18 | Modificata la fattura elettronica, ora è possibile importare fatture elettroniche di vendita emesse con altri programmi.
2.20.3 | 01/10/18 | Modificata la gestione della Fattura Elettronica con gestione delle fatture elettroniche tra privati e configurazione dei services esterni.
2.20.2 | 26/09/18 | Nelle fatture i bolli non generano l'addebito automatico, ma vengono indicati nella fattura elettronica. Se si desidera si può forzare l'addebito nella finestra dei totali documento.
2.20.1 | 24/09/18 | Attivata la compilazione con la versione 2.0 delle librerie di runtime Xbase++
2.13.7 | 17/09/18 | In fatturazione automatica, se è stata abilitata la scelta delle bolle da fatturare, nella lista si vedono i clienti che hanno un promemoria e si può vedere il testo.
2.13.6 | 07/08/18 | Cambiata la procedura di cancellazione ordini evasi, ora si possono cancellare o forzare la chiusura di Ordini, Preventivi e C/Lavoro in modo interattivo scegliendo cosa cancellare e cosa chiudere forzatamente.
2.13.5 | 07/08/18 | Aggiunto il codice di esenzione globale nell'anagrafica ditta per le attività che operano in regime di esenzione come ad esempio le forfettarie.
2.13.4 | 26/07/18 | In scadenze impegni è cambiata la modalità di notifica delle scadenze imminenti, ora è possibile scegliere se visualizzare le scadenze imminenti come prima, oppure mandare una mail di notifica all'agente. Si configura in AGC.INI alla voce SCTNOTIFICHE
2.13.3 | 20/07/18 | Aggiunta l'importazione della fattura elettronica.
2.13.2 | 10/07/18 | Il sistema riconosce la prima installazione e copia automaticamente il file AGC.INI predefinito
2.13.1 | 10/07/18 | Ricalcolo dello sconto a piede per uniformità con la fattura elettronica, si deve inserire in AGC.INI la data di partenza e si devono configurare i tracciati personalizzati dei documenti di magazzino.
2.12.9 | 02/07/18 | Aggiunto alle banche il codice CUC che è richiesto per emettere i bonifici SEPA.
2.12.8 | 08/06/18 | Configurato il link per scaricare l'informativa GDPR
2.12.7 | 29/05/18 | Nei tracciati descrittivi dei documenti si possono inserire righe multiple spuntabili. Vedi tracciato standard 5.
2.12.6 | 29/05/18 | Nei documenti si possono usare i tracciati descrittivi oltre che per le righe descrittive anche per le righe articolo ed extramagazzino.
2.12.5 | 25/05/18 | Ora è possibile inserire tracciati documenti diversi per ogni archivio, si deve inserire nell'archivio la cartella _TRACCIATI che conterrà le versioni modificate.
2.12.4 | 06/04/18 | Allargato il campo descrizione degli articoli.
2.12.3 | 16/03/18 | Nel file di configurazione AGC.INI si può scegliere come applicare le modalità di pagamento in fase di evasione ordini.
2.12.2 | 15/03/18 | Modificata la comunicazione telematica delle fatture per inviare sempre anche i semestri
2.12.1 | 27/02/18 | Aggiunta stampa dei registri di incassi e pagamenti per la determinazione del reddito secondo il criterio di cassa per la contabilità semplificata.
2.12.0 | 09/02/18 | Aggiunta la gestione della fatturazione elettronica tra privati.
2.11.9 | 16/01/18 | E' disponibile un file delle banche italiane più aggiornato.
2.11.8 | 16/01/18 | Ora tutte le stampe si possono indirizzare direttamente su un file pdf ed è possibile inserire uno sfondo. Nei documenti si può inserire uno sfondo automatico.
2.11.7 | 13/11/17 | Durante l'invio dei documenti tramite mail è possibile inserire un testo aggiuntivo anche utilizzando un testo ricorrente, i testi si possono modificare utilizzando la risorsa "TM","DOCSMAIL", per i dettagli chiedere al personale tecnico.
2.11.6 | 13/11/17 | Alle righe dei documenti è stato aggiunto il comando "Assegna prezzi" che permette di inserire rapidamente i prezzi a tutte le righe.
2.11.5 | 09/10/17 | Aggiunti i dati di StabileOrganizzazione e RappresentanteFiscale a clienti e fornitori per le comunicazioni trimestrali fatture.
2.11.4 | 04/10/17 | E' stata aggiunta la procedura di annullamento delle comunicazioni trimestrali fatture e sono stati aggiunti alcuni controlli.
2.11.3 | 18/09/17 | Aggiunto il numero esteso documento per i numeri che superano le 6 cifre
2.11.2 | 11/09/17 | Aggiunta la stampa delle schede di saldaconto fatture dai clienti.
2.11.1 | 30/08/17 | Aggiunta la gestione dell'invio trimestrale delle fatture.
2.10.7 | 03/08/17 | Aggiunto il calcolo del primo codice cliente o fornitore disponibile quando si inseriscono nuovi dati.
2.10.6 | 21/07/17 | Aggiunta la gestione Split Payment per clienti non PA.
2.10.5 | 17/07/17 | Nella stampa della lista dei movimenti di un articolo ora è possibile selezionare il tipo di documento.
2.10.4 | 13/07/17 | Nella procedura di Inserimento corrispettivi cumulativa, ora si può copiare i dati da un foglio excel.
2.10.3 | 14/06/17 | E' stata aggiunta agli articoli una procedura che facilita il calcolo della scorta minima
2.10.2 | 06/06/17 | E' stata aggiunta agli articoli la procedura di ricalcolo del costo dei movimenti di vendita, viene fatta la sincronizzazione con i costi degli acquisti.
2.10.1 | 22/05/17 | E' stato cambiato il funzionamento delle procedure di vendite al banco, ora gli scontrini vengono memorizzati in un archivio apposito.
2.9.38 | 02/05/17 | Ora è possibile modificare la dicitura fissa per il trasporto conto terzi ed altre descrizioni fisse del programma. Si inseriscono tracciati particolari nelle risorse.
2.9.37 | 28/04/17 | Aggiunta la possibilità di copiare ed incollare righe di documenti utilizzando gli appunti di Windows. Bisogna abilitare il parametro APPFLAGS in AGC.INI
2.9.36 | 24/04/17 | Aggiunta le gestione di commesse o cantieri rapidi. Si attivano abilitando il parametro DDF2CTR nel file di configurazione AGC.INI
2.9.35 | 19/04/17 | Sono stati allargati i campi descrizione delle scritture contabili.
2.9.34 | 12/04/17 | Aggiunto il campo codice libero agli agenti, aggiunta la procedura di duplicazione agenti.
2.9.33 | 06/04/17 | Aggiunta la possibilità di preparare una lista di clienti o fornitori per invio di circolari via mail.
2.9.32 | 06/04/17 | Aggiunta la modalità di pagamento per importi minimi da applicare ai clienti.
2.9.31 | 14/03/17 | Modificata la procedura di saldaconto fattura. Ora è possibile interagire con la scheda di tutte le posizioni di un cliente.
2.9.30 | 08/03/17 | Nelle scritture contabili acquisti intra, ora nella causale si può indicare se stornare l'iva su IVA C/ACQUISTI o IVA C/VENDITE, si deve attivare l'accumulatore A
2.9.28 | 01/03/17 | Nella stampa dei documenti di magazzino ora è possibile stampare il primo livello di distinta.
2.9.27 | 24/02/17 | Ora nella stampa delle etichette colli è possibile cercare le note aggiuntive inserite nei documenti per quel articolo e quel cliente/fornitore.
2.9.27 | 16/02/17 | Modificata la stampa dell'inventario, ora si può chiedere di prendere in considerazione solo gli articoli movimentati.
2.9.26 | 16/02/17 | In caso di depositi multipli, nel calcolo giacenze vengono visualizzate le giacenze di tutti i depositi
2.9.25 | 10/02/17 | Ora è possibile stampare i documenti in due copie formato A5 su un singolo foglio A4
2.9.24 | 18/01/17 | Nei clienti e fornitori è possibile vedere il tipo di contatti inseriti per ciascuna anagrafica, in clienti, fornitori e documenti è possibile vedere il numero di documenti abbinati.
2.9.23 | 18/01/17 | E' stata aggiunta ai documenti di magazzino la possibilità di aprire una cartella per i documenti abbinati, che vengono spediti automaticamente quando si invia il documento via mail.
2.9.22 | 16/01/17 | Ora quando si inviano documenti ed altre stampe via e-mail è possibile indicare l'indirizzo del mittente che si può scegliere dalla lista dei contatti dell'agente che ha effettuato il login.
2.9.21 | 03/01/17 | Aggiunta l'evasione automatica degli ordini con lettura righe da terminale
2.9.20 | 03/01/17 | Ristrutturato il menu dei comandi speciali degli articoli
2.9.19 | 02/01/17 | E' stata potenziata la procedura di ricerca dei codici degli articoli. Sono stati aggiunti parametri di configurazione per la lettura di condici barcode ed è possibile utilizzare i codici dei Clienti/Fornitori per cercare gli articoli.
2.9.18 | 27/12/16 | E' stata migliorata la procedura di importazione di righe da terminale impKeyboardRows() per la lettura consecutiva di codici con lettore barcode
2.9.17 | 12/12/16 | E' stata abbinata a Clienti / Fornitori / Agenti una cartella per contenere documenti di vario genere, dalle angrafiche è possibile aprire direttamente la cartella collegata.
2.9.16 | 05/12/16 | Nella procedura di esportazione a Excel e LibreOffice delle tabelle ora vengono aggiunti i nomi delle colonne come prima riga
2.9.15 | 29/11/16 | Aggiunta nei clienti la procedura per aggiornare gli ordini quando cambia il codice di esenzione.
2.9.14 | 13/11/16 | Nelle scadenze dei clienti è stata attivata la procedura per spedire via mail tutti gli avvisi di scadenza per pagamenti bonifico e rimessa diretta.
2.9.13 | 19/10/16 | Nella stampa della lista degli ordini e c/lavoro inevasi si possono escludere alcuni tipi di documenti, in agc.ini si modifica il parametro STNOEVA
2.9.12 | 06/10/16 | Nelle righe dei documenti sono stati raggruppati i comandi per inserire altri dati della riga.
2.9.11 | 06/10/16 | Ora è possibile forzare le provvigioni del capoarea nelle righe dei documenti.
2.9.10 | 27/09/16 | Le note d'accredito dei fornitori stornate dalle riba possono essere stornate nella procedura di pagamento riba dei fornitori.
2.9.09 | 27/09/16 | Nella presentazione effetti ora è possibile stornare le Note d'accredito dalle riba.
2.9.08 | 24/09/16 | Aggiunta la procedura di controllo delle righe evase dati documenti confrontando le righe generatrici.
2.9.07 | 12/09/16 | Aggiunto il calcolo delle provvigioni dei capiarea.
2.9.06 | 27/06/16 | Aggiunta la procedura "Genera causale contabile" alle registrazioni di primanota, permette di generare una causale con gli stessi sottoconti usati nella scrittura corrente.
2.9.05 | 27/06/16 | Nella procedura di Giroconto Accredito SBF (Incassi ed Insoluti), ora è possibile scegliere se fare una sola riga di contropartita sul conto ordinario o una riga per ogni scadenza. Per attivare inserire "IR" nella procedura compatibile della causale.
2.9.04 | 16/06/16 | Aggiunto il campo promemoria agli articoli, se c'è viene visualizzato sempre quando si usa l'articolo nel documento. Si somma ad eventuali configurazioni di MBArt nel file AGC.INI
2.9.03 | 16/06/16 | Se c'è la selezione sugli articoli di clienti e fornitori nei documenti, è possibile indicare clienti con articoli condivisi o clienti che possono vedere tutti gli articoli
2.9.02 | 16/06/16 | Nei documenti di evasione ordini è possibile configurare la possibilità di filtrare gli articoli da evadere.
2.9.01 | 01/06/16 | Oltre ad Excel Vengono supportati anche OpenOffice e LibreOffice per esportare dati e stampe in formato tabellare.
2.8.16 | 19/05/16 | Aggiunta alcuni campi utente alle distinte base
2.8.15 | 28/04/16 | Aggiunta alcuni campi utente alle testate dei documenti di magazzino.
2.8.14 | 27/04/16 | Aggiunta la selezione dei numeri di fattura nell'invio automatico delle fatture via mail per evitare di essere considerati spam dal server di posta.
2.8.13 | 20/04/16 | Aggiunta la possibilità di personalizzare la gestione dei centri di costo e ricavo con tabelle esterne.
2.8.12 | 17/03/16 | Aggiunta la lista delle e-mail inviate ed aggiunta la possibilità di scegliere l'indirizzo di destinazione a seconda del tipo di documento
2.8.11 | 02/03/16 | Sono stati aggiunti numeri e campi liberi agli articoli.
2.8.10 | 22/02/16 | E' stata realizzata una procedura per esportare i dati delle ritenute d'acconto in formato Excel utile per automatizzare la generazione delle Certificazioni Uniche
2.8.09 | 09/02/16 | Nelle scadenze impegni è stata aggiunta la spunta sui gruppi in uso e la possibilità di aprire una cartella per inserire documenti per ogni gruppo di scadenze.
2.8.08 | 01/02/16 | Aggiunta la gestione delle quantità nei movimenti intrastat ed aggiunto il dettaglio nella stampa dei riepiloghi.
2.8.07 | 28/01/16 | Ora è possibile assegnare colori diversi ai tipi di documento nei documenti di magazzino
2.8.06 | 26/01/16 | Le scadenze del tipo obsoleto T=TRATTA non vengono più equiparate alle RIBA come scadenza bancaria, ma vengono considerate parcheggiate e per attivare gli automatismi si deve cambiare il tipo negli altri tipi riconosciuti come Riba, Bonifico o Rimessa diretta
2.8.05 | 21/01/16 | Sviluppata la procedura per importare gli ordini del programma di e-commerce Magento2
2.8.04 | 18/01/16 | Dagli ordini ad cliente ora è possibile generare automaticamente gli ordini a fornitore
2.8.03 | 02/12/15 | Nelle liste degli articoli ora si può eseguire l'esportazione ad excel scegliendo i campi da esportare
2.8.02 | 30/11/15 | Attivata la possibilità di condividere documenti di magazzino con servizi cloud come ownCloud o anche DropBox Google Drive ed altri.
2.8.01 | 24/11/15 | Aggiunti i campi Utente inserimento e Utente ultima modifica Ai documenti di magazzino, aggiunto il campo forza chiusura ordine nelle righe dei documenti
2.7.51 | 12/11/15 | Modificata la procedura per la gestione della vendita di prodotti fitosanitari.
2.7.50 | 06/11/15 | Attivata la gestione del controllo fido clienti
2.7.49 | 06/11/15 | Nella configurazione delle stampe è possibile cercare il primo telefono o cellulare dei clienti inserendo il comando "getFirstContatti(cli->contatti,'TC')" o "getFirstContatti(cli->contatti,'CT')"
2.7.48 | 02/11/15 | Nei documenti a clienti è possibile forzare il controllo di di alcuni dati anagrafici, per maggiori dettagli vedere in AGC.INI la sessione DOCUM, codice CHKCLI
2.7.47 | 19/10/15 | Nelle righe descrittive dei documenti è possibile inserire il campo dei dati aggiuntivi, che può essere utile per elaborazioni speciali o per riportare dati nelle stampe
2.7.46 | 24/09/15 | Nella fattura PA ora è possibile escludere la trasmissione dei riferimenti dei DDT.
2.7.45 | 28/08/15 | Nella fattura PA viene gestita l'esclusione dallo split payment per categoria contribuente o su singoli documenti
2.7.44 | 15/07/15 | Nella stampa delle schede contabili sono stati aggiunte alcune selezioni
2.7.43 | 08/07/15 | Nella procedura di incassi ed insoluti è possibile forzare l'apertura del conto ordinario invece del conto sbf.
2.7.42 | 16/06/15 | Ora è possibile attivare l'esportazione al sistema di Analisi rischio crediti payline.it
2.7.41 | 15/05/15 | Modificata la procedura di generazione "Reverse Charge" per permettere l'esclusione di una riga iva dal calcolo.
2.7.40 | 08/04/15 | La stampa della distinta di appartenenza è disponibile sia per i singoli articoli che per le stampe di fabbisogno ed è possibile stampare il primo livello di appartenenza oppure andare agli articoli finali.
2.7.39 | 08/04/15 | Nella stampa dei fabbisogni ora è possibile stampare le distinte di appartenenza dei semilavorati.
2.7.38 | 25/03/15 | Modificata la procedura di vendita al banco, aggiunta la possibilità di inserire il codice del cliente e la distinzione tra scontrini e ricevute.
2.7.37 | 22/01/15 | Aggiunta la gestione del regime IVA di "Split Payment" per le fatture emessa alla Pubblica Amministrazione.
2.7.36 | 07/01/15 | Aggiunta la possibilità di inviare contemporaneamente più documenti di magazzino via mail, l'opzione è disponibile se sono state attivate le spunte.
2.7.35 | 06/11/14 | Quando si stampa il registro Cespiti di prova, si può decidere se calcolare i ratei alla data indicata o l'intera quota.
2.7.34 | 30/10/14 | Nelle righe dei documenti è stato aggiunto un comando per aggiornare il prezzi all'ultimo prezzo di costo o di vendita presente, il comando viene proposto anche quando si duplica un documento
2.7.33 | 22/10/14 | Nella agenda cronologico è stato aggiunto un comando rapido per il cambio di stato e la possibilità di filtrare le date nella stampa dell'agenda.
2.7.32 | 15/10/14 | Nel cronologico dei contatti è stata aggiunta la possibilità di collegare gli articoli agli argomenti del cronologico.
2.7.31 | 24/09/14 | Nella stampa delle statistiche di vendita ora è possibile fare l'ordinamento in ordine alfabetico.
2.7.30 | 19/09/14 | Nella stampa inventario, ora si può scegliere di valorizzare all'ultimo costo memorizzato. Serve per coloro che preferiscono inserire il prezzo di calcolo dell'inventario direttamente nell'anagrafica dell'articolo.
2.7.29 | 27/06/14 | Piccole modifiche alla procedura solleciti ordini fornitori. Si possono parametrizzare i tempi di preavviso e si possono fissare gli indirizzi mail di default.
2.7.28 | 18/06/14 | Si possono inviare fatture in formato elettronico alle PA secondo il formato ministeriale.
2.7.27 | 28/05/14 | Si possono emettere fatture con ritenuta d'acconto e ritenuta Enasarco.
2.7.26 | 27/05/14 | Nella stampa del riepilogo dei documenti di magazzino ora si può calcolare il subtotale mensile.
2.7.25 | 23/05/14 | Nel file di configurazione ACG.INI si possono inserire righe da inserire automaticamente in fattura in base alla modalità di pagamento, serve ad esempio per aggiungere sconti di tipo finanziario o addebiti vari.
2.7.24 | 08/05/14 | In primanota è stata aggiunta la procedura per la generazione automatica delle fatture in reverse charge
2.7.23 | 08/05/14 | Aggiunti alcuni campi nella testata delle commesse forniture (CMB), aggiunta il salvataggio delle versioni dei documenti.
2.7.22 | 06/05/14 | Nelle fatture con ritenuta d'acconto ora si può forzare percentuali diverse da quelle inserite nelle preferenze.
2.7.21 | 12/03/14 | Aggiunta la stampa di controllo del costo ultimo degli articoli di magazzino.
2.7.20 | 11/03/14 | Aggiunta una procedura per spostare i movimenti di magazzino da un articolo ad un altro.
2.7.19 | 07/03/14 | Modificata la gestione dell'invio automatico e-mail. La nuova versione permette l'invio da server diversi e memorizza lo storico di invio dei documenti.
2.7.18 | 31/01/14 | Modificato lo spesometro, stampa del modello polivalente.
2.7.17 | 16/12/13 | Aggiunta la procedura per la stampa dell'analisi del fatturato.
2.7.15 | 03/12/13 | Allargato il campo descrizione della modalità di pagamento
2.7.14 | 20/11/13 | Modificata la funzione di ricerca delle colonne nelle tabelle, ora si può fare una selezione veloce.
2.7.13 | 13/11/13 | Aggiunto il campo Tipo Attività ai clienti per fini statistici.
2.7.12 | 08/11/13 | Quando si esegue una stampa con invio automatico della e-mail alla fine dell'invio viene aperto automaticamente il file pdf
2.7.11 | 31/10/13 | Nella stampa del riepilogo vendite si può decidere di calcolare il costo medio di un periodo di riferimento
2.7.10 | 25/10/13 | Ora è possibile configurare il tipo stampa per le righe descrittive generate da evasione ordini dei documenti.
2.7.9 | 22/10/13 | Aggiunti campi liberi ai gruppi di scadenze impegni.
2.7.8 | 17/10/13 | Aggiunto il nuovo spesometro
2.7.7 | 16/10/13 | Aggiunta la possibilità di inserire conitestatari delle fatture di vendita in contabilità.
2.7.6 | 14/10/13 | Aggiunti ai clienti tre campi numerici liberi a disposizione degli utenti.
2.7.5 | 02/10/13 | Aggiunta la selezione automatica dei clienti non operativi e degli articoli obsoleti.
2.7.4 | 30/09/13 | Controllo conversione aliquota iva da 21% a 22%
2.7.3 | 18/09/13 | Al modulo CMB è stato aggiunto il calcolo dello sconto praticato a cliente nelle righe delle commesse.
2.7.2 | 18/09/13 | Al modulo CMB è stato aggiunto il campo "Origine segnalazione" che serve a fini statistici.
2.7.1 | 06/09/13 | Aggiunta la stampa del riepilogo di ordini e conto lavoro inevasi.
2.7.0 | 06/08/13 | Aggiunto il modulo CMB commesse forniture.
2.6.45 | 17/07/13 | Aggiunto il campo volume nei dati trasporto
2.6.44 | 08/07/13 | E' stato aggiunto un avviso quando si tenta di modificare un DDT già fatturato.
2.6.43 | 31/05/13 | In alcune stampe di clienti, fornitori ed articoli è possibile cambiare l'ordinamento dei dati.
2.6.42 | 21/05/13 | Aggiunto il campo SWIFT alle banche.
2.6.41 | 10/05/13 | Aggiunta la procedura di stampa degli insoluti ricevuti da clienti in un periodo.
2.6.40 | 09/05/13 | Aggiunta la procedura di raggruppamento delle scadenze dei clienti.
2.6.39 | 22/04/13 | Nei documenti di magazzino è stata aggiunta la stampa "Residuo evasione ordine", che indica lo stato di evasione degli ordini evasi da un documento.
2.6.38 | 12/04/13 | Per esigenze particolari il campo degli articoli "Codice presso fornitore" è stato allargato a 30 caratteri.
2.6.37 | 10/04/13 | E' stata modificata la gestione dei tracciati nelle righe descrittive dei documenti, ora si possono inserire dati codificati. Vedere esempio nelle risorse di sistema.
2.6.36 | 08/04/13 | Nella rilevazione tempi della gestione commesse è stata aggiunta la possibilità di inserire note libere.
2.6.35 | 15/03/13 | Modificata la gestione della scadenza impegni. Ora si può associare un cliente o fornitore ad una scadenza ed anche un documento da generare al momento dell'evasione.
2.6.34 | 14/03/13 | Aggiunto il campo "non in uso" ai codici iva per controllare che non vengano inseriti per errore codici obsoleti.
2.6.33 | 18/02/13 | Aggiunta l'opzione della scorta minima nella stampa dell'inventario di magazzino. Per utilizzarla è necessario abilitare il campo nel file AGC.ini
2.6.32 | 05/02/13 | Aggiunta la gestione degli indirizzi precedenti nei recapiti dei clienti, in modo da stampare la corretta intestazione in base alla data dei documenti.
2.6.31 | 01/02/13 | Aggiunta la possibilità di inserire kit di prodotti nei documenti di magazzino.
2.6.30 | 30/01/13 | Aggiunta la procedura per il pagamento di bonifici generici. Viene stampata una distinta e preparato il file per la spedizione tramite home banking.
2.6.29 | 30/01/13 | Ora dalla procedura di pagamento bonifici si prepara il file per la spedizione tramite home banking.
2.6.28 | 28/01/13 | Dalle registrazioni di primanota di fatture e note è possibile richiamare le scadenze.
2.6.27 | 24/01/13 | Aggiunta la gestione automatica del IVA per cassa nei clienti
2.6.26 | 18/01/13 | Nei documenti di magazzino è stata aggiunta la stampa della lista righe.
2.6.25 | 11/01/13 | Agli articoli è stata aggiunta la stampa riepilogo movimenti che fa gli stessi calcoli della stampa lista movimenti ma senza riportare il dettaglio di movimentazione.
2.6.24 | 09/01/13 | Aggiunto il campo codice pagamento ai tipi documento per forzare il codice in fase di inserimento documenti
2.6.23 | 09/01/13 | Aggiunto il campo giorni aggiuntivi alla modalità di pagamento, i giorni vengono aggiunti alla fine del calcolo di tutte le scadenze
2.6.22 | 08/01/13 | Per ottemperare alle disposizioni della legge di stabilità 2012 sono stati modificati i tracciati stampa delle fatture e dei registri aggiungendo l'anno alla numerazione.
2.6.21 | 04/01/13 | Ora il campo corrente nelle finestre di dialogo viene evidenziato con un colore diverso, se si desidera si può ritornare ai colori standard cambiando un parametro in AGC.INI
2.6.20 | 04/01/13 | Modificata la stampa delle statistiche di vendita, aggiunta la possibilità di richiedere il dettaglio per cliente o per categoria.
2.6.19 | 05/12/12 | Aggiunta la gestione della qualità ISO 9001:2008
2.6.18 | 28/11/12 | Modificata la gestione dei tempi di lavorazione delle commesse, aggiunta la gestione degli straordinari
2.6.17 | 30/10/12 | Aggiunta la gestione della fatturazione di merci deperibili con fatturazione separata delle bolle.
2.6.16 | 19/10/12 | Aggiunta la data di modifica in distinta base
2.6.15 | 19/10/12 | Aggiunta la stampa del fabbisogno lavorazioni al modulo di produzione.
2.6.14 | 12/10/12 | Modifiche minori a distinta base e fabbisogni. Ora quando si stampano i fabbisogni si tiene conto delle descrizioni modificate delle righe
2.6.13 | 20/09/12 | Modificata la procedura di salvataggio colonne, ora se si modifica la larghezza di una colonna, la nuova dimensione viene ricordata, la posizione delle colonne puo' essere spostata con i tasti CTRL+Sinistra e CTRL+Destra
2.6.12 | 31/08/12 | Modificata la gestione di scadenze impegni: ora i gruppi possono essere gerarchici, c'è la stampa delle degli impegni per giorno e si possono evadere contemporaneamente più scadenze.
2.6.11 | 19/07/12 | Ora si possono stampare le etichette colli anche per i documenti dei fornitori e se si stampano dagli articoli viene chiesto il tipo di anagrafica.
2.6.10 | 19/07/12 | Aggiunto il campo data modifica negli articoli, viene registrata automaticamente la data dell'ultima modifica effettuata da un utente
2.6.9 | 22/05/12 | Aggiunto il calcolo dell'IVA pro-rata.
2.6.8 | 23/04/12 | Aggiunta la visualizzazione automatica dei codici presso clienti e fornitori degli articoli nella stampa dei documenti.
2.6.7 | 16/04/12 | Aggiunta la possibilità di fatturare un singolo DDT, bisogna indicare nel tipo documento il documento da generare.
2.6.6 | 13/04/12 | Nella stampa del giornale da contabilità semplificata si tiene conto dei registri iva.
2.6.5 | 13/04/12 | Modificata la fatturazione semplice, aggiunti i registri iva.
2.6.4 | 15/03/12 | Aggiunta la pubblicazione di documenti nel web via ftp
2.6.3 | 21/02/12 | In evasione ordini ora si può fare il calcolo della conversione di unità di misura.
2.6.2 | 13/02/12 | In fatturazione automatica quando si scelgono i clienti da fatturare, si possono scegliere anche le singole bolle.
2.6.1 | 03/02/12 | Riscritta la procedura di ricostruzione dati.
2.6.0 | 16/01/12 | Aggiunto il modulo gestione commesse
2.5.19 | 14/12/11 | Ora è possibile cambiare la dimensione delle barre dei comandi delle liste.
2.5.18 | 09/12/11 | Aggiunta la generazione dei dati per lo Spesometro.
2.5.17 | 05/12/11 | Aggiunta la possibilità di escludere le procedure obsolete nei dati fissi.
2.5.16 | 17/11/11 | Aggiunto il campo avviso causale documento per evitare inserimento errato di documenti usati raramente.
2.5.15 | 03/11/11 | Aggiunto il campo Descrizione alternativa Bilancio nel piano dei conti per diversificare la descrizione nel bilancio a seconda se il conto è in dare o in avere.
2.5.14 | 25/10/11 | Nella stampa dei registri iva di prova vengono segnalati gli errori di protocollo
2.5.13 | 13/10/11 | Aggiunta la ricerca alfabetica di clienti e fornitori nei documenti di magazzino
2.5.12 | 16/09/11 | Aggiunta la procedura per la conversione delle aliquote IVA da 20 a 21
2.5.11 | 09/09/11 | Potenziata la gestione dei filtri speciali per agente, ora si può attivare un filtro per un gruppo di agenti oppure per tutti.
2.5.10 | 06/09/11 | Dai documenti di magazzino si possono aprire direttamente i telefoni e contatti di clienti e fornitori.
2.5.9 | 09/08/11 | Inserita la possibilità di visualizzare messaggi quando si usano determinati articoli in documenti, vedi AGC.INI
2.5.8 | 20/07/11 | Gestione scritture contabili anticipo da clienti a partire dai DDT dei clienti
2.5.7 | 08/07/11 | Nel modulo di gestione di contatti cronologico è stata aggiunta la possibilità di inviare e-mail dirette.
2.5.6 | 17/06/11 | Aggiunto il modulo di riclassificazione Piano dei Conti.
2.5.5 | 25/05/11 | Aggiunta la stampa di controllo della numerazione dei documenti.
2.5.4 | 29/04/11 | Nei documenti viene proposto automaticamente l'agente che ha fatto il login, e viene anche messo il suo registro iva predefinito.
2.5.3 | 29/04/11 | Nei documenti di magazzino è possibile fare il calcolo automatico dei colli. Si può passare il nome del campo degli articoli dei pezzi per confezione, oppure il blocco di codice con la funzione da chiamare per il calcolo.
2.5.2 | 21/04/11 | Dai documenti di magazzino ora è possibile aggiornare direttamente la lista dei preferiti di clienti e fornitori.
2.5.1 | 21/04/11 | La procedura di contabilizzazione delle fatture differite è stata modificata per contabilizzare fatture e note contemporaneamente.
2.5.0 | 21/04/11 | Aggiunto l'aggiornamento automatico dei DDT quando si modificano le fatture differite
2.4.23 | 05/04/11 | Aggiunto il copia/incolla delle righe dei documenti.
2.4.22 | 29/03/11 | Modificato il calcolo della covers9ione tra unità di misura, ora si può configurare in AGC.INI come fare il calcolo.
2.4.21 | 21/02/11 | Aggiunta la gestione dei preferiti anche per i fornitori.
2.4.20 | 14/02/11 | Aggiunta l'ora fine contatto nella gestione del cronologico.
2.4.19 | 09/02/11 | Aggiunta la gestione dei permessi utenti per la gestione del cronologico contatti.
2.4.18 | 04/01/11 | Modificata la contabilizzazione delle scadenze bancarie, ora si può indicare il conto di anticipazioni SBF
2.4.17 | 22/12/10 | Aggiunta la gestione della sospensione di imposta
2.4.16 | 07/12/10 | In inserimento corrispettivi viene segnalata la data dell'ultima scrittura inserita.
2.4.15 | 07/12/10 | Nella lista delle scritture di primanota, vengono visualizzati i dati della prima riga dei movimenti.
2.4.14 | 07/12/10 | Aggiunto il campo riferimento in scadenze impegni.
2.4.13 | 25/10/10 | Aggiunta il modulo scadenze impegni.
2.4.12 | 19/10/10 | Aggiunta la stampa della lista preferiti nei clienti e negli articoli.
2.4.11 | 05/10/10 | Modificata la procedure delle stampe, ora si possono esportare più formati e la gestione delle e-mail è integrata in tutte le stampe.
2.4.10 | 02/09/10 | Aggiunta l'invio automatico di documenti in PDF tramite e-mail
2.4.9 | 27/07/10 | Modificato il calcolo delle scadenze, ora la scadenza a vista, ma con giorno scadenza 31 viene portata a fine mese.
2.4.8 | 16/07/10 | Aggiunta la gestione degli effetti RID oltre che RIBA.
2.4.7 | 12/07/10 | Aggiunta la procedura di applica sconti automatici nel corpo del documento.
2.4.6 | 01/07/10 | Migliorata la stampa delle etichette barcode e gestione dei soli codici articolo maiuscoli
2.4.5 | 30/06/10 | Aggiunta la selezione dei movimenti di cronologico nei clienti e fornitori.
2.4.4 | 15/06/10 | Nei clienti e fornitori, si puo configurare i tipi di documento per inserire il tracciato di un testo da aggiungere automaticamente.
2.4.3 | 11/06/10 | Potenziato il modulo di gestione contatti cronologico, ora è collegabile ad un programma esterno dedicato.
2.4.2 | 09/04/10 | Aggiunto il modulo di commercio elettronico.
2.4.1 | 23/03/10 | Aggiunta la procedura controllo prezzi bolle.
2.4.0 | 15/03/10 | Aggiunto il modulo di Gestione contatti cronologico.
2.3.32 | 26/02/10 | Modificata la procedura di evasione ordini, ora si può forzare la chiusura di una riga anche se le quantità sono diverse
2.3.31 | 16/02/10 | Nella cancellazione dei documenti di magazzino che hanno effettuato evasioni viene proposto di ripristinare le quantità evase
2.3.30 | 15/02/10 | Modificata procedura cessione cespite, ora il calcolo della quota residua di ammortamento è opzionale.
2.3.29 | 05/02/10 | Aggiunto la procedura di azzeramento automatico delle giacenze.
2.3.29 | 02/02/10 | Aggiunto il campo massa netta nei prospetti intrastat.
2.3.28 | 05/01/10 | Aggiunto il controllo di accesso nei menu dei comandi speciali.
2.3.28 | 05/01/10 | Aggiunto il log di inserimento, modifica e cancellazione scritture. Viene attivato assieme al log di accesso ai menu.
2.3.27 | 05/01/10 | Aggiunti i filtri speciali nella gestione archivi per singolo utente, si attiva con AGC.INI
2.3.26 | 05/01/10 | Aggiunta gestione filtri di default in gestione archivi, si attiva inserendo risorse di tipo 'FLB'
2.3.25 | 02/12/09 | Aggiunta la gestione dell'incasso dell'IVA per Cassa.
2.3.24 | 30/10/09 | Inserita la modalità di pagamento alternativa nei clienti che viene attivata al superamento di un determinato importo in fattura.
2.3.23 | 06/10/09 | Nella evasione ordini se le condizioni di pagamento ed agente sono diverse si può scegliere di evadere solo gli ordini con determinate condizioni, questa funzione deve essere abilitata in AGC.INI
2.3.22 | 02/10/09 | Ora è possibile ordinare l'evasione ordini per data evasione, si configura un parametro in AGC.INI
2.3.21 | 18/09/09 | Modifiche ai dati del trasporto dei documenti: aggiunto il calcolo del peso e modificata la gestione della destinazione.
2.3.20 | 15/09/09 | Aggiunta la procedura di contabilizzazione delle fatture di acquisto registrate in documenti di magazzino.
2.3.19 | 09/09/09 | Aggiunta la procedura di inserimento automatico dei corrispettivi di un periodo.
2.3.18 | 31/07/09 | Aggiunta la procedura di copia listino degli articoli. Si possono duplicare i prezzi di un listino su un altro listino calcolando uno sconto o una maggiorazione.
2.3.17 | 30/07/09 | Aggiunti alcuni campi ai cespiti, aggiunta la procedura di generazione scrittura dei ratei di ammortamento cespiti.
2.3.16 | 27/07/09 | Ai vettori sono stati aggiunti i campi: Partita IVA, Codice Fiscale e N. iscrizione all'albo. Sono dati che è possibile inserire nei documenti di trasporto.
2.3.15 | 22/07/09 | In fatturazione automatica si può fare il riepilogo anche per ddt, indicare nel cliente il tipo di raggruppamento da applicare.
2.3.14 | 29/04/09 | Nella stampa del riepilogo documenti da gestione documenti di magazzino ora si possono stampare solo le fatture e le note di accredito, ed in questo caso le note vengono indicate con il segno meno e stornano gli importi delle fatture.
2.3.13 | 22/04/09 | Le note d'accredito generano le provvigioni con segno negativo, prima non venivano generate provvigioni
2.3.12 | 21/04/09 | La procedura di incassi ed insoluti permette di inserire l'importo delle spese bancarie per gli insoluti ed il rimborso da chiedere al cliente nella stampa del sollecito di pagamento.
2.3.11 | 20/04/09 | In evasione documenti di magazzino si possono modificare i prezzi prima di confermare l'evasione.
2.3.10 | 16/02/09 | Modificata la stampa delle statistiche di vendita di magazzino, ora si può chiedere il tipo di ordinamento dei risultati.
2.3.9 | 16/02/09 | Aggiunta la procedura di cancellazione cumulativa articoli, è disponibile solo se viene attivata nel file di configurazione AGC.INI
2.3.8 | 26/01/09 | Aggiunto il campo note nelle scadenze, aggiunta la lista delle scadenze nella stampa globale delle partite, stampa delle schede scadenze in ordine alfabetico.
2.3.7 | 21/01/09 | Aggiunto imponibile lordo ed imponibile netto nelle provvigioni per distinguere gli importi soggetti e non soggetti a provvigione.
2.3.6 | 17/12/08 | Aggiunta la possibilità di inserire una lista di scelte nei dati aggiuntivi delle righe articolo, nel file agc.ini si possono abilitare i campi quantità 1-5 delle righe.
2.3.5 | 06/11/08 | Nella stampa della lista scadenze è stato aggiunto il protocollo contabile.
2.3.4 | 15/10/08 | Aggiunta la stampa della scheda movimenti con gestione della giacenza.
2.3.3 | 14/10/08 | Nella gestione delle liste articolo si può generare gli ordini a fornitori scegliendo il fornitore per ogni articolo.
2.3.2 | 09/10/08 | E' possibile attivare la visualizzazione dei prezzi di listino nella finestra degli articoli, si deve attivare nel file di configurazione AGC.INI
2.3.1 | 26/09/08 | Sviluppata la procedura di controllo dei documenti di magazzino.
2.3.0 | 26/09/08 | Riscritto il calcolo delle giacenze e della valorizzazione, la procedura recalcMovCosto() permette di aggiornare le righe di magazzino.
2.2.9 | 11/09/08 | Aggiunto il calcolo dei riepiloghi delle cessioni Intrastat
2.2.8 | 22/07/08 | Modificata la stampa delle scadenze bancarie, è stata aggiunta la stampa del flusso finanziario.
2.2.7 | 22/07/08 | Aggiunta la spunta per gli addebiti automatici nei fornitori e nelle scadenze
2.2.6 | 21/07/08 | Aggiunto il campo banca per bonifici alle anagrafiche clienti
2.2.5 | 17/07/08 | Modificata la stampa delle partite, ora si possono includere le scadenze
2.2.4 | 17/07/08 | Modificata la procedura di Incassi ed Insoluti, ora vengono visualizzati i totali selezionati.
2.2.3 | 15/07/08 | Aggiunta la procedura Stima scadenze acquisti.
2.2.2 | 11/07/08 | Modificata l'evasione ordini, si possono raggruppare gli articoli di un singolo ordine
2.2.1 | 17/06/08 | Aggiunta la gestione della storicizzazione dei documenti di magazzino
2.2.0 | 03/06/08 | Abilitata la gestione dei diritti degli utenti, gli utenti vengono inseriti come agenti.
2.1.55 | 23/05/08 | Nella stampa del listino semplice se l'ordinamento è per categoria viene stampata l'intestazione di categoria e si può fare il salto pagina.
2.1.54 | 23/05/08 | In incassi e pagamenti si può aggiungere la descrizione di riga.
2.1.53 | 22/05/08 | Aggiunta la procedura per annullare le distinte bancarie.
2.1.52 | 20/05/08 | Aggiunta la possibilità di fare incassi e pagamenti su clienti e fornitori diversi nella procedura di incassi e pagamenti.
2.1.51 | 20/05/08 | Aggiunto il deposito a fatturazione automatica.
2.1.50 | 06/05/08 | Aggiunta la procedura di importazione articoli da files di testo
2.1.49 | 25/03/08 | Nella stampa degli ordini e del conto lavoro inevaso è inserire anche le righe descrittive.
2.1.48 | 10/03/08 | Aumentati i campi liberi degli articoli e modificata la finestra di immissione
2.1.47 | 22/02/08 | Aggiunta la possibilità di definire tracciati stampa preferenziali per i documenti dei clienti e fornitori, purtroppo non funziona con la fatturazione automatica.
2.1.46 | 21/02/08 | In contabilizzazione fatture ora è possibile scegliere la causale da utilizzare, si possono duplicare le causali contabili.
2.1.45 | 28/01/08 | Aggiunto il codice registro ai depositi, in questo modo si può assegnare automaticamente il codice registro a seconda del deposito.
2.1.44 | 15/01/08 | Aggiunta la possibilità di esportare le gestioni dei dati in formato testo o Excel.
2.1.43 | 10/01/08 | Modificata la gestione dei documenti, entrando un un ordine si vede lo stato di evasione.
2.1.42 | 10/01/08 | Aggiunto il campo porto ai documenti di magazzino
2.1.41 | 27/12/07 | Aggiunto il calcolo automatico dell'IBAN nelle banche e nei fornitori.
2.1.40 | 12/12/07 | Aggiunto il modulo per la gestione del saldaconto fattura.
2.1.39 | 26/11/07 | Aggiunto il codice IBAN ai fornitori per i pagamenti a mezzo bonifico bancario.
2.1.38 | 07/11/07 | Aggiunta la stampa della statistica di acquisto.
2.1.37 | 08/10/07 | Modificata la variazione automatica listini. Ora viene presentata la lista modificabile dei prezzi calcolati e la si può fare anche da Preferiti Clienti, Listini e Prezzi Articoli.
2.1.36 | 18/09/07 | Modificata la stampa delle schede contabili, in caso di clienti e fornitori si possono stampare anche le scadenze aperte.
2.1.35 | 07/09/07 | Modificata la procedura di incassi e pagamenti, ora si può inserire il totale incassato e ripartire l'importo. Inserito duplica riga e copia ultimo importo in primanota. Fissato un tetto di segnalazione per la vendita al banco.
2.1.34 | 31/07/07 | Sviluppata la versione definitiva degli allegati clienti e fornitori.
2.1.33 | 31/07/07 | Modificata stampa listini, ora si può stampare i listini di più clienti contemporaneamente.
2.1.32 | 27/07/07 | Tolto il tipo documento dalle registrazioni iva, viene preso automaticamente quello della causale, inserita la possibilità di indicare anno di riferimento diverso per le note di accredito.
2.1.31 | 02/07/07 | Aggiunte spunte alla primanota.
2.1.30 | 12/06/07 | Aggiunti i campi utente web e password a clienti, modificato layout di Clienti e Fornitori.
2.1.29 | 07/06/07 | Aggiunto il modulo di gestione matricole articoli.
2.1.28 | 17/05/07 | Modificata la fatturazione automatica, ora è possibile scegliere il clienti da fatturare.
2.1.27 | 10/05/07 | Aggiunto il modulo gestione anticipi bancari.
2.1.26 | 08/05/07 | Aggiunta la possibilità di inserire descrizioni estese in primanota, aggiunti tracciati stampa.
2.1.25 | 23/04/07 | Aggiunta la stampa di etichette per colli su singoli clienti, fornitori, recapiti.
2.1.24 | 13/04/07 | Ora è possibile spostare le colonne delle finestre con i comandi ALT+DESTRA e ALT+SINISTRA, le posizioni vengono salvate e ripristinate automaticamente.
2.1.23 | 13/04/07 | Aggiunti i totali nella stampa ordini evasi ed in riepilogo righe dei documenti.
2.1.23 | 11/04/07 | Aggiunto costo lordo ultimo e sconti alle anagrafiche articoli ed ai prezzi di fornitori e clienti, aggiornati anche i calcoli relativi.
2.1.22 | 11/04/07 | Modificata la procedura di stampa etichette colli che ora è disponibile a partire da un documento o libere per articolo.
2.1.21 | 11/04/07 | Aggiunto l'indice per provincia e Città nei clienti.
2.1.20 | 11/04/07 | Abilitata la gestione delle spunte su Clienti, Fornitori e Documenti.
2.1.19 | 14/02/07 | E' disponibile la stampa degli allegati clienti e fornitori. La versione elettronica sarà disponibile quando ci saranno indicazioni ministeriali sul formato.
2.1.18 | 02/02/07 | Aggiunta la possibilità di inserire comunicazioni alla clientela nella fatturazione automatica
2.1.17 | 01/02/07 | Aggiunta l'emissione di documenti con ritenuta d'acconto
2.1.16 | 08/01/07 | Aggiunto calcolo evadibilità ordine in gestione documenti di magazzino
2.1.15 | 08/01/07 | Modificata stampa lista articoli con aggiunta di informazioni di dettaglio.
2.1.14 | 08/01/07 | Modificati i tracciati stampa dei documenti per aggiungere codice fiscale ed intestazione righe
2.1.13 | 27/12/06 | Aggiunto il modulo di gestione vendita prodotti per agricoltura con gestione fitosanitari.
2.1.12 | 12/12/06 | Aggiunta la possibilità negli articoli di calcolare il barcode anche per il campo codice alternativo.
2.1.11 | 15/11/06 | Nelle registrazioni contabili di documenti iva ora si può copiare la data di registrazione sulla data del documento.
2.1.10 | 03/11/06 | Nella fatturazione semplice ora si possono inserire tracciati per automatizzare le righe.
2.1.9 | 30/10/06 | Aggiunta una procedura per la generazione automatica di articoli con varianti e con calcolo del prezzo per mezzo di tracciati.
2.1.8 | 30/10/06 | Aggiunta l'esportazione delle stampe in formato PDF utilizzando PDFCreator
2.1.7 | 27/10/06 | Ora è possibile stampare numeri in lettere nei documenti
2.1.6 | 13/10/06 | Modificata la primanota, ora è possibile scegliere se scrivere una contropartita per ogni aliquota IVA.
2.1.5 | 12/10/06 | Aggiunto il calcolo del prezzo prezzo per quantità
2.1.4 | 15/09/06 | Aggiunta procedura di numerazione fogli per stampe contabili.
2.1.4 | 11/08/06 | Aggiunta la possibilità di collegare un documento agli articoli, è possibile stampare automaticamente tutti i documenti collegati ad un documento di magazzino.
2.1.3 | 10/08/06 | Aggiunta la gestione del calcolo del numero di colli nei dati di trasporto e nelle etichette colli.
2.1.2 | 10/08/06 | Aggiunto nella testata documenti un campo per inserire riferimenti esterni di clienti o fornitori.
2.1.1 | 09/08/06 | Aggiunta la ToolBar per i comandi rapidi
2.1.0 | 03/08/06 | Compilazione con la versione 1.9 della libreria. Attivata la conversione dei dati in formato FOXBASE
2.0.22 | 28/07/06 | Modificata la procedura di fatturazione semplice, ora si effettua anche la fatturazione con ritenuta d'acconto.
2.0.21 | 08/06/06 | Aggiunta la possibilità di vedere il costo ultimo durante l'inserimento di righe articolo nei documenti di magazzino.
2.0.20 | 01/06/06 | Aggiunta nella stampa documenti la possibilità di stampare con una differente intestazione.
2.0.19 | 29/05/06 | Nella stampa inventario ora si può includere o escludere gli articoli non fiscali, è stata aggiunta la possibilità di configurare il calcolo automatico del peso nei DDT.
2.0.18 | 09/05/06 | Nella stampa del listino articoli si può calcolare la giacenza, nella stampa del inventario si possono stampare gli articoli esauriti.
2.0.17 | 05/05/06 | Aggiunta la possibilità di duplicare le scritture contabili.
2.0.16 | 20/04/06 | Nella stampa delle schede contabili, ora si può scegliere di stampare solo quelle con saldo diverso da zero.
2.0.15 | 22/03/06 | Nella procedura di vendita al banco è stata aggiunta la possibilità di ristampare l'ultimo scontrino.
2.0.14 | 03/03/06 | Nella procedura Incassi e Pagamenti, quando si esegue l'incasso o il pagamento viene visualizzato il protocollo contabile del documento.
2.0.13 | 14/02/06 | Aggiunta la possibilità di copiare i clienti e fornitori negli appunti.
2.0.12 | 14/02/06 | Modificato il ricalcolo protocolli, ora il numero iniziale non viene modificato.
2.0.11 | 09/02/06 | Aggiunta l'esportazione dei clienti e fornitori ai contatti dei palmari PalmOS
2.0.10 | 31/01/06 | Modificato il formato di setup di distribuzione del programma
2.0.9 | 26/01/06 | Modificata la procedura di gestione delle selezioni
2.0.8 | 13/01/06 | Aggiunta la variazione automatica dei listini prezzi degli articoli e la cancellazione dei preferiti fino a data.
2.0.7 | 29/12/05 | Modifica la stampa dei riepiloghi iva, ora si può anche calcolare da data a data
2.0.6 | 16/12/05 | Aggiunta generazione liquidabilità provvigioni da incassi e pagamenti ed incassi ed insoluti.
2.0.5 | 15/12/05 | Aggiunta la stampa della lista di Clienti o Fornitori che hanno un promemoria
2.0.4 | 09/12/05 | Modificata la stampa delle schede contabili, ora si deve scegliere il tipo di conto da stampare
2.0.3 | 05/12/05 | Aggiunta la stampa dei prospetti IVA
2.0.2 | 02/12/05 | Aggiunto il campo data registrazione in testata delle scritture iva
2.0.1 | 20/10/05 | Aggiunta la gestione dei promemoria clienti e fornitori
2.0.0 | 30/08/05 | Cambiata la struttura delle varianti e di tutti gli archivi connessi, ora si possono modificare le tabelle ed anche i singoli movimenti.
1.2.26 | 08/08/05 | Modificata la gestione dei listini, ora ogni cliente può avere i suoi articoli preferiti con il proprio prezzo. Questo rende obsoleta la gestione della lista preferiti precedente.
1.2.25 | 20/07/05 | Aggiunta la gestione della "Lista preferiti" nei documenti di magazzino.
1.2.24 | 18/07/05 | Nella gestione dei documenti il tasto '*' permette di aggiungere righe alla posizione corrente, in AGC.INI si può aggiungere un opzione per copiare il codice articolo inserendo nuove righe.
1.2.23 | 01/07/05 | Nei documenti, per velocizzare l'introduzione delle righe, premendo 1, 2 o 3 si va subito in inserimento nuove righe
1.2.22 | 30/06/05 | Aggiunto il log delle versioni nella documentazione
1.2.21 | 30/06/05 | se si inserisce il file di testo IMPROWS.PRG in C:\CS viene bypassata la procedura delle preferenze, aggiunta funzione impKeybordRows()
1.2.20 | 25/06/05 | Aggiunta gestione giroconti iva intracee in fatture d'acquisto intra
1.2.19 | 25/05/05 | Aggiunta data modifica prezzi di listino, modifica visione dettagli documenti e primanota
1.2.18 | 09/05/05 | Cambiate icone dei pulsanti, modificato il font delle spunte
1.2.17 | 05/05/05 | Aggiunto calcolo giorni valuta in stima castelletto.
1.2.16 | 04/05/05 | Aggiunta gestione spunte in schede contabili.
1.2.15 | 30/03/05 | Aggiunta visualizzazione giacenza in righe articolo. Modificata stampa schede articolo
1.2.14 | 17/03/05 | Aggiunta gestione commercializzazione vini
1.2.13 | 16/03/05 | Aggiunto "meter" per monitorare l'attività del programma
1.2.12 | 23/02/05 | Stampa schede contabili multiesercizio, stampa Bolla di carico per tentata vendita
1.2.11 | 16/02/05 | Aggiunta stampa cumulativa partite contabili
1.2.10 | 14/01/05 | Aggiunta procedura cambia listino in documenti
1.2.9 | 14/01/05 | Aggiunta gestione codici articoli di clienti e fornitori con aggiornamento costi fornitori
1.2.8 | 12/01/05 | Aggiunta la gestione della rintracciabilità degli alimenti.
1.2.7 | 07/01/05 | Modificato l'aspetto visivo del programma, ora l'applicazione ha aspetto MDI
1.2.6 | 02/12/04 | Aggiunta gestione delle cauzioni, noleggi e comodati.
1.2.5 | 29/11/04 | Modifica tipi documenti, aggiunta causale del trasporto di default
1.2.4 | 26/11/04 | Gestione provvigioni agenti e budget agenti
1.2.3 | 18/11/04 | Aggiunta visualizza totali in incassi/pagamenti, stampa scheda ultimi prezzi
1.2.2 | 04/11/04 | Aggiunta la procedura di forzatura delle partite contabili
1.2.1 | 11/08/04 | Aggiunta lista banche italiane, modifica tracciato banche proprie usare fillAbiCab() per aggiornare le banche
1.2.0 | 07/08/04 | Attivata la gestione delle licenze di aggiornamento
1.1.11 | 04/08/04 | In stampa schede contabili si possono stampare clienti e fornitori in ordine alfabetico
1.1.10 | 13/07/04 | Stampa documenti con listini alternativi, cerca ultime condizioni
1.1.9 | 05/07/04 | Gestione bonifici bancari attivi e passivi, pagamento fornitori.
1.1.8 | 30/06/04 | Gestione conversione unità di misura nelle quantità dei documenti.
1.1.7 | 11/06/04 | Aggiunto ai clienti il campo esclusione spese incasso
1.1.6 | 31/05/04 | Gestione tentata vendita e lettura codici con palmari Palm
1.1.5 | 26/02/04 | Gestione liste di articoli per giacenza, documenti ed etichette
1.1.4 | 11/02/04 | Aggiunta gestione righe automatiche da tipo documento.
1.1.3 | 07/01/04 | Aggiunto campo cliente di riferimento in Articoli.
1.1.2 | 18/11/03 | Aggiunta gestione comuni e calcolo codice fiscale, aggiunta gestione immagini
1.1.1 | 31/10/03 | Aggiunto campo "aggiornamento automatico costo" agli articoli
1.1.0 | 12/09/03 | Vendita al banco, documenti clienti al costo, distinta base
1.0.3 | 28/07/03 | Gestione destinatario in testata documenti di magazzino
1.0.2 | 14/07/03 | Gestione centri di costo e ricavo, gestione vendita al banco
1.0.1 | 12/06/03 | Stesura guida in linea
1.0.0 | 14/04/03 | Rilascio programma


Le note che seguono non hanno la pretesa spiegare in modo completo ed esauriente la gestione contabile, hanno solo lo scopo di introdurre la materia a beneficio di coloro che non la conoscono in modo che possano trarre vantaggio dall'uso del presente programma.

La contabilità deve essere tenuta per legge da ogni soggetto che svolge un'attività imprenditoriale, ma oltre a questo obbligo di legge ci sono buoni motivi per la sua tenuta, infatti la contabilità ci dà informazioni sul andamento del lavoro e ci aiuta a pianificare le azioni, a migliorare i risultati ed a tenere sotto controllo debiti e crediti.

La contabilità può essere grossomodo divisa in due parti, la parte contabile vera e propria e la parte IVA, Zefiro contiene molti automatismi che facilitano la gestione della parte IVA, infatti registrando le fatture di acquisto, di vendita e le note di accredito di clienti e fornitori, si ottengono in modo automatico oltre alla parte contabile anche tutte le stampe richieste dalla legislazione fiscale.

La parte contabile vera e propria viene tenuta con il metodo contabile classico detto della "Partita Doppia" .

Nella partita doppia tutte le componenti dell'attività vengono raggruppate in "Conti", ad esempio ogni cliente ed ogni fornitore ha un proprio conto separato, anche le banche e la cassa hanno un loro conto. Altri conti servono a raggruppare le spese ad esempio le spese telefoniche vengono separate dalle spese per energia elettrica, oppure dalle spese di affitto dei locali o ancora dalle spese per l'acquisto di merci e beni di consumo. Infine anche i ricavi possono essere separati in base alla loro natura, ad esempio ricavi per vendita di merci vengono separati dai ricavi per vendita di servizi.

Per maggiore chiarezza, normalmente i conti vengono raggruppati in base alla loro natura, si può pensare ai conti raggruppati come a scatole che contengono cartelle che a loro volta contengono schede in cui vengono registrate le entrate e le uscite, e questo è proprio il modo in cui veniva tenuta la contabilità prima dell'avvento dei Computers. Zefiro utilizza un raggruppamento dei conti a tre livelli chiamati Mastri, Conti e Sottoconti. I Mastri corrispondono alle scatole di cui sopra, i Conti sono le cartelle ed i Sottoconti sono le schede, le scritture contabili vengono eseguite solo a livello di sottoconto.

Nei sottoconti vengono registrati tutti gli eventi contabili che interessano un'azienda, le registrazioni possono essere entrate o uscite, le entrate vengono chiamate "Dare" ed hanno segno positivo le uscite vengono chiamate "Avere" ed hanno segno negativo.

La regola della partita doppia dice che: ogni registrazione che comporta una uscita (Avere) da un conto deve essere compensata da una entrata (Dare) in uno o più altri conti. Questa affermazione in un primo momento può sembrare sconcertante infatti può sembrare che una scrittura in cui le entrate pareggiano le uscite sia una scrittura nulla, ma questa considerazione non tiene conto del fatto che la contabilità non rappresenta la nostra ditta opposta al resto del mondo, ma rappresenta tutte le relazioni della nostra azienda con il resto del mondo.

Vista in quest'ottica, per fare un esempio, una operazione come un versamento di denaro in banca, viene registrato contabilmente come una uscita (Avere) di Cassa ed una entrata (Dare) di banca, più brevemente si dice che la Cassa va in Avere e la Banca va in Dare.

Facciamo altri esempi per facilitare la comprensione:

1) Quando vendiamo un prodotto ad un nostro cliente c'è un uscita di merce a favore del cliente, inoltre per legge dobbiamo addebitare al cliente un importo chiamato IVA che dovremo in seguito pagare all'erario, normalmente questa transazione viene ufficializzata emettendo un documento chiamato Fattura. Contabilmente il sottoconto delle "Merci Vendute" va in Avere, il sottoconto dell' "IVA su vendite" va in Avere ed il conto del "Cliente" va in Dare per la somma degli importi della merce e del conto iva.

2) Quando il cliente effettua il pagamento, normalmente ci da denaro o assegni, oppure effettua il pagamento direttamente presso la nostra Banca, in questo caso il cliente ha una uscita e quindi va in Dare e la Cassa o la Banca hanno un entrate e quindi vanno in Avere. Da notare che il Cliente con l'emissione della fattura andava in Dare, con il pagamento va in Avere, se la somma di tutti gli importi Dare corrisponde alla somma di tutti gli importi Avere di dice che il conto è chiuso ed in tal caso noi non abbiamo crediti o debiti nei suoi confronti.

3) Quando acquistiamo beni o servizi dai fornitori, in modo speculare a quanto avviene con i clienti, abbiamo il Fornitore in Avere, e l'"IVA su acquisti" e la "Merce" o "Servizio" in Dare e quando effettuiamo il pagamento la "Cassa" (se paghiamo in contanti) o la "Banca" (se stacchiamo un assegno o facciamo un bonifico) vanno in Avere.

4) Non sempre le scritture contabili registrano una transazione effettiva di denaro, alle volte vengono eseguite operazioni che servono per mettere ordine nei conti, ad esempio, alle volte può essere utile spostare importi da un conto all'altro al solo scopo meglio evidenziare particolari somme.

Ogni scrittura contabile viene evidenziata in stampa in due modi distinti, la stampa del giornale espone le scritture in modo cronologico, in esso sono riportate le operazioni a mano a mano che accadono, le stesse scritture vengono anche registrate in modo cronologico nella scheda del sottoconto a cui appartengono. Ovviamente con il computer si registra una sola volta la scrittura e si ottengono entrambe le stampe.

Un altra utile stampa è la stampa del bilancio che sommariamente è la lista dei saldi dei sottoconti, questa stampa è particolarmente importante perché con l'esposizione di pochi numeri rende immediatamente le informazioni sull'andamento dell'azienda.

La gestione contabile ha una propria ciclicità, periodicamente si tirano le somme dell'andamento aziendale per fare confronti con periodi precedenti e per conteggiare gli utili (se ci sono) da suddividere tra i soci. Il periodo di riferimento per convenzione è l'anno solare e questa è normalmente la durata di un esercizio contabile, quasi sempre l'esercizio inizia il 1° gennaio e termina il 31 dicembre, ma questa non è una regola fissa, si potrebbe chiudere e riaprire in date diverse e questo in effetti accade alle volte quando l'azienda ha un tipo di attività influenzato dalla stagione.

Il fatto che ci siano aperture e chiusure contabili, suggerisce che ci sono alcuni conti che partono da zero ad inizio esercizio ed arrivano a valori diversi a fine esercizio, questi conti vengono chiamati conti economici e sono i conti che indicano costi e ricavi (i costi normalmente si trovano in Dare ed i ricavi si trovano in Avere), ad esempio i ricavi per vendita di merce iniziano a zero ad inizio anno, ed il saldo che si trova a fine anno indica le vendite di merci che sono state effettuate, allo stesso modo le spese per carburanti e lubrificanti inizia a zero ad inizio esercizio ed il saldo finale ci dice quale incidenza ha questo costo sulle spese sostenute.

Altri conti invece non sono soggetti ad andamento annuale, questi sono i conti patrimoniale, il loro valore non si azzera automaticamente ma solo in forza della gestione economica, ad esempio il saldo del conto in banca non viene azzerato ad inizio anno e neppure i debiti e crediti nei confronti di clienti e fornitori, anche il valore dei fabbricati e di macchinari ed attrezzature non viene modificato dalle chiusure contabili. I conti patrimoniali vengono suddivisi normalmente in Attività e Passività (Attività normalmente in dare e Passività normalmente in Avere).

Le operazione di chiusura ed apertura dei conti vengono effettuate da Zefiro in modo automatico essendo questa una procedura essenzialmente matematica, mediante questa procedura viene determinato automaticamente l'utile o la perdita d'esercizio. La chiusura viene preceduta da alcune scritture chiamate di assestamento con le quali si eseguono operazioni contabili periodiche, ad esempio vengono calcolate le quote di ammortamento dei beni durevoli che servono a ripartire il costo di tali beni nel corso di più anni, ad esempio il costo di un'autovettura viene suddiviso in un periodo di cinque anni.

Come detto in precedenza, la contabilità comprende anche una parte fiscale che serve a rispettare alcuni obblighi di legge relativi soprattutto alla normativa sull'Imposta sul Valore Aggiunto (IVA), Zefiro con una singola scrittura è in grado di registrare sia la parte contabile che la parte IVA dei corrispettivi per vendita al pubblico, delle fatture di vendita, delle fatture di acquisto e delle note di accredito di clienti e fornitori, i documenti registrati vengono mensilmente o trimestralmente stampati su appositi registri chiamati registro dei Corrispettivi, registro IVA Vendite e registro IVA Acquisti. Inoltre viene stampate la Dichiarazione IVA nella quale sono sommati l'ammontare di IVA su Vendite ed IVA su acquisti, la differenza tra tali importi indica l'importo da pagare all'erario o viceversa l'importo di cui siamo a credito.

Non rientra tra gli scopi di Zefiro, la gestione di calcoli fiscali più approfonditi come ad esempio la stampa delle Denunce annuali IVA o la stesura della dichiarazione dei Redditi, infatti Zefiro vuole essere un ausilio agile e snello per la tenuta della contabilità aziendale delegando a figure professionali aggiornate con la normativa fiscale il compito di occuparsi di queste tematiche.

Invece Zefiro si assume il compito di fornire assistenza al di là della semplice tenuta contabile per rendere più agevole il lavoro amministrativo nel suo complesso, infatti viene stabilita una forte relazione tra la contabilità e la gestione delle scadenze, la contabilità genera automaticamente le scadenze e le scadenze a loro volta generano automaticamente le scritture contabili di incasso e pagamento, altre utili procedure permettono la gestione delle partite contabili che sono un meccanismo che pone in relazione le fatture con i pagamenti.


Gli articoli contengono le informazioni anagrafiche dei prodotti che vengono gestiti dal programma di magazzino, alcuni o anche tutti questi prodotti sono posti in vendita altri articoli invece possono essere usati a fini interni per esempio per la gestione della produzione. In questo campo la variabilità da ditta a ditta può essere molto grande, alcune ditte trattano solo pochi articoli, altri invece possono avere anche un numero enorme di prodotti diversi, per queste ditte è molto importante pianificare con cura la codifica degli articoli perché questo aiuta molto nel trattamento dei dati.

Prima di iniziare codificare gli articoli, consigliamo di individuare le categoria di prodotti, il raggruppamento in categorie è utile per dare ordine all'archivio e soprattutto per ottenere statistiche raggruppate, inoltre la gestione delle categorie permette di velocizzare l'inserimento degli articoli assegnando alcuni valori predefiniti comuni a tutte le categorie.

Nella codifica degli articoli, prima di tutto si deve decidere se si intende utilizzare lettori di codici a barre, in caso di risposta positiva è preferibile utilizzare codici numerici perché i codici a barre che contengono caratteri alfabetici sono normalmente più lungi di quelli che contengono solo numeri e quindi richiedono etichette più grandi e normalmente si preferisce stampare etichette più piccole possibili.

In ogni caso i codici devono essere il più possibile "parlanti" cioé devono essere composti da caratteri che permettono di individuare immediatamente la natura del prodotto per fare qualche esempio, si può includere nel codice la sigla del fornitore se questo dato è rilevante, oppure si può inserire il codice della categoria o infine si possono inserire sigle che indentificano misure o colori. Per contro è consigliabile evitare di inserire informazioni non necessarie o rindondanti in modo da rendere il codice più corto possibile.

In alcuni casi può essere utile utilizzare codici articoli con varianti. Il più tipico esempio di articoli con varianti è quello degli articoli di abbigliamento nei quali lo stesso prodotto può avere più taglie diverse e può essere disponibile in vari colori. Il vantaggio di utilizzare le varianti è evidente: se abbiamo ad esempio 8 taglie in 4 colori otteniamo 8 X 4 = 32 articoli diversi, usando le varianti possiamo utilizzare un solo articolo, alrimenti dobbiamo usare fino ad un massimo di 32 articoli e maggiore è il numero di articoli maggiore è la difficolta di gestione, la prolissità delle stampe ed il tempo di immissione dati. Per contro la gestione delle varianti è più macchinosa ed a volte ci possono essere casi in cui i dati di movimentazione vengono raggruppati sull'articolo base senza tener conto delle varianti. Quindi la regola sull'uso delle varianti è che sono sicuramente vantaggiose da utilizzare ma vanno usate con cautela.

Nella gestione dei codici a barre si deve tener conto di alcune caratteristiche proprie di ogni tipo di codice. I codici principali utilizzati sono EAN 13, 2/5 Industrial ed Interleaved, CODE 39 e vari derivati.
  • Il codice EAN13 è il codice usato nei prodotti di largo consumo, è lungo 13 caratteri in cui i primi due sono il codice della nazione (80 per l'Italia), cinque cifre per il codice del produttore che viene fornito da un ente di standardizzazione, cinque cifre per il codice del prodotto che viene assegnato dal produttore ed infine il codice di controllo che serve per ridurre il rischio di errori di lettura. I codici con codice nazione da 20 a 29 sono liberi e possono essere usati dai rivenditori per i propri scopi, ad esempio i venditori di prodotti alimentari utilizzano questi codici per frutta, verdura, carni pane ecc..
  • Il codice 2/5 è molto compatto ma prevede l'uso di sole cifre e la lunghezza del codice deve essere pari.
  • Il codice 39 è meno compatto del codice 2/5 ma ha il vantaggio di utilizzare anche caratteri alfabetici e segni di punteggiatura, da questo codice sono state tratte alcune varianti come ad esempio il code 128 che differiscono per il numero di caratteri supportati.

Il programma Zefiro prevede alcune strategie per la gestione dei codici con codice a barre, infatti è in grado di generare codici di articolo compatibili con tutti e tre i tipi di barcode menzionati, è anche in grado di gestire i codici con varianti uilizzando la codifica EAN13 purché la somma di codice + varianti non superi i 10 caratteri e che tutti i codici di articolo e varinati siano numerici.


La determinazione dei prezzi di vendita è molto variabile a seconda delle politiche gestionali di ciascuna azienda e può essere influenzata da molti fattori.

Quando gli articoli ed i clienti sono pochi o c'è molta variabilità, i prezzi possono essere gestiti di volta in volta manualmente, ma se articoli o clienti sono molti, si rende necessario stabilire regole più stringenti.

Zefiro dispone di un sistema di gestione prezzi molto articolato e versatile che ci auguriamo sia in grado di soddisfare molte delle esigenze che si possono presentare.

Determinazione del prezzo

Durante l'inserimento dei documenti di magazzino dei clienti, i prezzi degli articoli vengono determinati nel seguente modo:

Ad ogni cliente viene assegnato un listino ed in ogni documento si può forzare l'applicazione di un listino diverso.

I listini sono strutturati in modo gerarchico, ad esempio il listino 101 potrebbe avere come listino padre il listino 1 Questo significa che se l'articolo A10 non ha un prezzo specifico per il listino 101, viene applicato quello del listino 1. In questo modo si possono inserire tutti i prezzi nel listino 1 ed inserire nel listino 101 solo alcuni prezzi destinati a clienti particolari.

Per ciascun cliente si possono inserire dei prezzi "preferiti" che hanno la doppia funzione di permettere la scelta rapida in fase di inserimento e di applicare prezzi personalizzati.

Una volta trovato il prezzo di listino da applicare, si controlla se ci sono prezzi diversificati in funzione della quantità acquistata, si possono inserire scaglioni di prezzi che calano con il crescere della quantità.

Al prezzo possono essere applicati degli sconti fissi mettendo la spunta sul campo "Applica sconti", questo è particolarmente utile nel caso degli articoli preferiti e significa che non vengono eseguite ulteriori ricerche di sconto seguendo le regole di scontistica che illustriamo di seguito.

Una volta trovato il prezzo, se non viene forzato lo sconto di listino, si possono attivare alcune regole per determinare gli sconti. L'ordine di applicazione degli sconti è il seguente:

  1. Categoria e Cliente Si applica a tutti gli articoli di una categoria per questo cliente specifico.
  2. Gruppo Articoli e Cliente Gli articoli di più categorie possono appartenere ad uno stesso gruppo, lo sconto si applica a tutti gli articoli del gruppo per questo cliente.
  3. Categoria articoli e gruppo clienti I clienti possono essere suddivisi in gruppi, ad esempio "Ingrosso", "Grande distribuzione" ecc... , in questo caso lo sconto si applica alla categoria di articoli ed al gruppo di clienti.
  4. Gruppo articoli e gruppo clienti Infine la regola più generale. In questo caso lo sconto si applica a tutti gli articoli di un gruppo per tutti i clienti di un gruppo.

Anche in questo caso gli sconti possono variare al variare della quantità acquistata e si applica lo stesso meccanismo usato per la determinazione del prezzo.

La scontistica trovata serve anche per determiare la provvigione agli eventuali agenti. Il meccanismo standard prevede che per ogni tabella di scontistica trovata si possa indicare la colonna di provvigione assegnata all'agente. Però molto spesso le regole per il calcolo della provvigione sono basate su logiche particolari che variano da azienda ad azienda, pertanto di dovrà valutare caso per caso.

Consigli

A livello generale consigliamo di gestire articoli e clienti per categoria o gruppo e di limitare al massimo le eccezioni. Questo facilita il lavoro e richiede un minore ricorso ai rapporti interpersonali.

L'adozione di regole precise facilita anche il rapporto con eventuali agenti nella determinazione delle provvigioni.

L'uso dei listini gerarchici dovrebbe essere limitato a casi particolari e motivati. In caso di dubbio si dovrebbe scegliere di utilizzare i prezzi preferiti dei clienti.

In caso di prezzi per quantità, consigliamo di preferire la gestione della scontistica con sconti per quantità, questo facilita il lavoro in caso di variazioni di prezzo. I prezzi per quantità possono essere utili in caso di preferiti o per articoli molto specifici.


Fattura elettronica

La Pubblica Amministrazione allo scopo di ottimizzare i costi e di migliorare le proprie funzionalità amministrative ed anche per disporre di più efficaci strumenti di controllo, ha messo a punto un sistema per la gestione delle fatture in formato elettronico.

Il processo si è sviluppato in vari tempi. A partire dal 06-06-2014 per le fatture verso la PA fino al 01-01-2019 con l'entrata a regime la fattura elettronica tra privati per tutti i soggetti non esentati.

Con l'entrata in vigore dell'obbligo di inviare i corrispettivi in formato elettronico, è stato messo a punto un formato di "fattura elettronica semplificata" che permette di inserire un numero contenuto di informazioni, particolarmente adatto per gli strumenti elettronici poco interattivi come ad esempio i registratori di cassa fiscali.

A partire dal 01/01/2021 è entrato in vigore il formato 1.6 della fattura elettronica che introduce nuove specifiche per i codici IVA (natura iva) e nuovi tipi di documento che consentono di inviare al SdI alcuni tipi di documento come le autofatture per reverse charge, acquisti dall'estero ed autoconsumo, inoltre viene fatta una distinzione tra le fatture immediate e fatture differite.

Tutte le informazioni tecniche relative alla fatturazione elettronica sono disponibili nel sito fatturapa

Informazioni operative

Il sistema della fattura elettronica richiede che le fatture e le note di accredito vengano compilate e spedite utilizzando un formato XML conforme alle specifiche tecniche.

Sul mercato nazionale esistono diversi operatori che rendono disponibili servizi on-line per facilitare la gestione delle fatture e che si occupano di tutti i dettagli tecnici previsti dalla normativa.

Per volumi modesti di documenti, in alternativa si possono utilizzare i servizi messi a disposizione dalla PA pricipalmente nel sito iva e corrispettivi appositamente predisposto.

Zefiro è in grado di preparare automaticamente i files xml da spedire ed anche di importare in contabilità i documenti dei nostri fornitori. Vengono riconosciuti sia il formato ordinario che semplificato.

Descrizione del sistema

E' comunque utile fornire alcuni dettagli tecnici che ci aiutano a capire il funzionamento del sistema.

Sui files XML preparati, se sono destinati alla PA c'è l'obbligo di apporre la firma digitale, invece per le fatture tra privati la firma digitale è facoltativa.

I files XML devono essere inviati al Sistema di Interscambio (SDI) il quale si occoperà di recapitarle ai rispettivi destinatari.

Dopo aver spedito le fatture, sussiste l'obbligo della conservazione digitale sostitutiva che rende superflua la conservazione cartacea. La conservazione sostitutiva è sottoposta ad un disciplinare tecnico che di fatto obbliga gli operatori ad avvalersi di servizi esterni che possono essere gratuiti o a pagamento. Recentemente anche Agenzia delle Entrate ha messo a disposizione la possibilità di conservare i documenti che per bassi volumi può essere sufficiente, invece per volumi maggior consigliamo comunque di avvalersi di un servizio esterno.

Oltre alle fatture di vendita, c'è l'obbligo della conservazione sostitutiva anche delle fatture di acquisto.

Il sistema di interscambio inoltra le fatture ai destinatari indicati con un apposito "Codice destinatario" o in sua assenza ad un indirizzo PEC.

Per i soggetti esentati dalla fattura elettronica, come ad esempio i privati cittadini non detentori di Partita IVA oppure per i destinatari esteri, non viene indicato nessun indirizzo di spedizione ed i documenti vengono conservati e resi consultabili dal sistema. In questo caso persiste l'obbligo della notifica dei documenti con i metodi tradizionali.

Per le fatture di acquisto, possiamo dare ai nostri fornitori il nostro indirizzo PEC, oppure ci possiamo iscrivere al SDI per ottenere un nostro codice univoco, ma dopo aver ricevuto le fatture dovremo provvedere alla loro conservazione sostituiva utilizzando il servizio che avremo scelto.

In alternativa, i fornitori di servizi propongono di dare ai fornitori il loro codice univoco in modo che le fatture arrivano direttamente a loro che si occupano anche della conservazione e noi possiamo semplicemente scaricarle per la registrazione contabile.

Specifiche tecniche 1.6

Come accennato in precedenza, dal 01/01/2021 entrano in vigore le specifiche tecniche 1.6. Le differenze sostanziali sono due. Sono stati aumentati di tipi di documento che si possono spedire e sono state inserite ulteriori specifiche per la "Natura" delle esenzioni IVA.

Lo scopo è quello di consentire agli utenti di spedire anche i documenti di tipo "autofattura" in modo da superare altre incombenze come ad esempio l'Esterometro e se l'utente decide di inviare tutti i documenti, può ottenere la liquidazione IVA pre compilata.

Per la registrazione e relativa spedizione delle autofatture, Zefiro ha reso disponibile un tipo di documento apposito, di solito nominato "SDI" che è in grado di preparare i nuovi tipi di documenti SDI.

Split payment

Dal 01-01-2015 è entrata in vigore la norma dello "Split Payment" secondo il quale la parte IVA delle fatture emesse alla PA non verrà più liquidata dal fornitore come accade normalmente, ma direttamente dalla PA destinataria della fattura. E quindi il fornitore richiederà il pagamento della sola parte imponibile della fattura.

Per quanto riguarda la normativa IVA, tutto rimane come prima, con l'eccezione che i fase di liquidazione IVA, verrà stornato dal debito IVA la parte IVA delle fatture emesse alla PA.

Lo "Split Payment" prevede alcune eccezioni, se il contribuente rientra tra le categorie escluse, è possibile attivare la spunta di esclusione nella scheda di inserimento dei dati anagrafici della ditta. In questo caso, tutte le fatture PA potranno essere inviate correttamente, ma non saranno soggette a Split Payment. E' anche possibile attivare l'esclusione di singole fatture selezionando il registro IVA indicato nelle preferenze.

Modalità operativa "Split Payment"

Zefiro è in grado di produrre e spedire le fatture utilizzano i formati e le modalità richieste, ed è anche in grado di registrare automaticamente le fatture ricevute.

Per la gestione delle fatture verso la PA viene richiesta l'attivazione di un registro sezionale iva apposito in cui verranno emesse e registrate esclusivamente le fatture sottoposte a regime di split payment, in questo modo in fase di liquidazione IVA il programma sa qual'è l'importo di IVA vendite che deve essere stornato dal debito.

Se si ha necessità si possono indicare nella procedura di configurazione ulteriori sezionali iva soggetti a split payment.

Nelle anagrafiche dei clienti si possono indicare tutti i dati specifici compreso il codice univoco e l'indirizzo PEC. Se necessario si può anche indicare se è una PA soggetta a Split Paymente ed eventualmente il registro sezionale preferenziale.

Se i documento vengono emessi con i documenti di magazzino il programma si occupa automaticamente di fare in modo che vengano assegnati al registro iva corretto. Nella stampa delle fatture il tracciato di stampa è configurato per citare automaticamente la norma sullo split payment e viene stornata la parte iva del totale dovuto.

In fase di contabilizzazione, nelle fatture appartenenti al registro Split Payment, viene automaticamente fatto lo storno della parte iva dal debito del cliente e viene generata la scadenza per la sola parte imponibile. Allo stesso modo quando si registrano manualmente Fatture PA, viene generato lo storno contabile.

Quando si fa la stampa dei registri iva, il programma riconosce automaticamente il registro PA e annota che è soggetto allo "Split Payment".

Infine quando si fa la stampa delle liquidazioni IVA, viene effettuato lo storno dell'IVA su fatture emesse alla PA a piede dopo il calcolo dei totali della liquidazione.

Modalità operativa "Fattura elettronica"

Prima di procedere alla spedizione delle fatture, è necessario configurare i dati per la preparazione e spedizione dei documenti.

I clienti esteri vengono riconosciuti perché hanno il prefisso iva diverso da 'IT' ed i clienti privati si riconoscono perché non hanno la partita IVA, infine si possono escludere singoli clienti esentati scrivendo 'NO' al posto del codice unvoco. Per tutti questi soggetti, i documenti vengono inviati ugualmente, ma non vengono recapitati ai destinatari.

In fase di registrazione dei documenti fattura alla PA, è possibile indicare alcuni dati che possono essere richiesti dai clienti ad esempio il "Codice CIG"

Dopo aver emesso le fatture è disponibile una procedura che esegue automaticamente la preparazione e spedizione delle fatture in formato XML

Per la spedizione di singoli documenti si può attivare il comando presente nella gestione dei documenti di magazzino questa procedura serve anche per fare invii sostituiti in caso di contestazioni da parte dei clienti.

Il sistema richiede che ogni nome di file spedito abbia un codice univoco differente da tutti gli altri spediti in precedenza. Per questo motivo Zefiro assegna un numero unico ad ogni documento nel momento di preparazione del file, in questo modo vengono evitati invii duplicati. In caso scarto per errori formali o di rifiuto da parte del destinatario, è possibile preparare nuovamente il file corretto e se necessario assegnarli un codice sostitutivo. Ad ogni modo, se ci avalliamo di un fornitore di servizi per l'invio, il nome del file viene riassegnato da loro.

Le procedure che fanno la preparazione dei documenti sono anche in grado di spedire automaticamente i documenti al SDI se è stato configurato il protocollo di spedizione che può variare in funzione del servizio prescelto, nel più semplice dei casi i documenti vengono copiati in una cartella temporanea per facilitare la spedizione manuale.

Il formato XML è definito in modo rigoroso e non accetta files che non rispettano le regole, ad esempio il CAP dei clienti deve essere composto da 5 cifre numeriche e la province deve essere composta da 2 lettere maiuscole.

Si devono anche configurare i dati anagrafici della ditta, i codici IVA e le corrispondenze di condice nelle modalità di pagamento. In assenza di questi dati Zefiro non consente di preparare i files.

In ogni caso è probabile che almeno nei primi tempi alcuni dei nostri documenti risultino non conformi, per questo motivo consigliamo utilizzare la procedura di controllo presente sul sito della fatturapa.

Argomenti particolari

Il formato della fattura elettronca considera lo "Sconto a piede" della fattura come sconto finanziario che deve essere calcolato dopo il calcolo dell'IVA. Di fatto lo sconto a piede equivale ad un abbuono. Se prima della fattura elettronica si considerava lo sconto a piede cone sconto commerciale ora si deve tener conto la sua applicazione comporta un costo maggiore per la differenza dell'IVA e quindi conviene considerare l'opportunità di applicare gli sconti sul corpo fattura.

In alcuni casi è richiesto di apporre sulle fatture una imposta di Bollo. Per la fattura elettronca è possibile applicare un "Bollo virtuale" che dovrà essere pagato in seguito mediante modulo F24. Zefiro permette di indicare il bollo emesso e richiede se si desidera addebitare l'importo al cliente.

I nome dei files delle fatture devono essere unici e sono composti dal prefisso 'IT' seguito dal codice fiscale, il segno di sottolineato '_' ed una sequenza unica di 5 caratteri alfabetici e numerici. Per garantire l'univocità è stato messo a punto un sistema di calcolo che a partire da un numero genera un codice di permuntazione. Potrebbe capitare che chi ha emesso fatture verso la PA negli anni scorsi trovi dei codici che vanno in conflitto. Se succede, il SDI scarterà il file, ma sarà sufficiente trovare un altro numero libero e tormare a spedire.

La fattura elettronica è un argomento articolato, Zefiro riesce a gestire in modo agevole la maggior parte delle problematiche, però esistono casi particolari che richiedono confiugurazioni precise. Per questo motivo nel file di configurazione AGC.ini è disponibile un sezione particolare per questo tipo di tarature.

Alcuni link

Il sito della fattura PA è il punto di partenza per tutte le indicazioni necessarie:
http://www.fatturapa.gov.it

La documentazione ufficiale sul formato delle fatture elettroniche si trova su:
https://www.agenziaentrate.gov.it/portale/web/guest/fatturazione-elettronica-e-dati-fatture-transfrontaliere-new

Il “Codice Univoco Ufficio” per le fatture verso la PA per ciascun Ente può essere cercato su:
http://www.indicepa.gov.it/

Prima di spedire i files XML prodotti si può controllare che siano corretti su:
https://ivaservizi.agenziaentrate.gov.it/portale/

In questa posizione si trova un utile programma per la visualizzazione e stampa delle fatture:
http://www.assosoftware.it/assoinvoice

Servizi gratuiti della PA per invio e conservazione:
https://ivaservizi.agenziaentrate.gov.it/portale/
https://fatturaelettronica.infocamere.it


In questa sezione sono contenute informazioni di carattere generale che spiegano la struttura del programma e le logiche di utilizzo dei vari tipi di procedura, vengono elencati i tasti funzionali e spiegato il significato dei pulsanti disponibili nei vari momenti di utilizzo del programma.

La finestra principale, illustra il punto di ingresso del programma.
Gestione dei dati, illustra le modaltà utilizzate per operare con i dati.
Finestre per immissione dati, spiega l'uso delle finestre con campi dati.
Gestione documenti per questo programma è una particolare finestra di inserimento dati che gestisce la logica di testata-righe.
Stampe spiega la modalità di utilizzo del sistema di reporting utilizzato per le stampe.
Diritti di accesso spiega le modalità utilizzate da alcuni programmi per la gestione dei diritti di accesso alle varie procedure da parte degli utenti.
Archiviazione documenti descrive una particolare funzionalità di alcuni programmi di gestire i collegamenti a documenti esterni.
Gestione spunte Alcuni archivi dispongono della possibilità di spuntare le singole registrazioni per fare operazioni, come ad esempio stampe, solo sui dati spuntati.

E' molto importante leggere con attenzione queste annotazioni per sfruttare il programma in tutte le sue potenzialità.


Normalmente all'avvio il programma apre una finestra che occupa interamente il video. Questa finestra contiene il menù che permette di accedere a tutte le funzionalità del programma. Per rendere più agevole il lavoro dell'operatore, oltre al classico menù a tendina presente nella parte alta della finestra, è presente subito sotto il menù una barra con i comandi più frequenti ed anche un menù ad albero nella parte sinistra della finestra. in questo modo, l'operatore può scegliere la modalità di utilizzo che trova più congeniale.

I comandi del menù File che permettono di accedere alle funzioni di manutenzione standard, sono però preseni solo nel menù principale.

Nella parete bassa della finestra principale sono presenti alcune caselle che contengono informazioni riguardo all'utilizzo del programma, da sinistra a destra le caselle contengono: L'archivio corrente, l'utente del programma, il nome della stazione di lavoro e la data di utilizzo del programma.

E' possibile configurare il programma in modo che la finestra principale si presenti in modo diverso, per fare questo si aggiunge alla riga di comando una istruzione sullo stile della finestra, sono disponibili i comandi: /STYLE:TREE, /STYLE:SDI, /STYLE:COMBO e /STYLE:MDI. Il funzionamento del programma è esattamente lo stesso, quindi queste opzione hanno solo una valenza estetica.
Nello stile MDI è possibile includere o escludere la ToolBar, per forzare l'esclusione si deve scrivere un file di testo di nome "csToolBar.txt" con contenuto NO nella cartella del programma, per forzare l'inclusione lo stesso file deve avere contenuto YES.
Se necessario si può lanciare automaticamente una determinata procedura all'avvio del programma aggiungendo la dicitura /PROC:<nome_procedura> alla riga di comando.


Lo scopo principale di un programma di gestione amministrativa basato si database è la gestione di dati. I dati vengono acquisiti nel programma con immissione da parte di un utente, oppure possono essere acquisiti con sitemi di rilevamento automatici, o infine sono il frutto di elaborazione da parte del programma stesso.

Normalmente i dati vengono immessi da un utente, quindi il programma deve fornire tutti i meccanismi per gestirli interattivamente, se ne deve poter aggiungere, si deve poter cancellare, si devono fare ricerche e stampe, inoltre il programma molto spesso si deve preoccupare che i dati inseriti siano coerenti e completi, ad esempio si deve impedire che due registrazioni abbiano lo stesso codice perchè questo genererebbe ambiguità.

In questa sezione verranno illustrati i meccanismi per la gestione interattiva dei dati, la più usuale è la gestione di files, ma esiste anche la gestione di altre tabelle, inoltre verranno elencati i pulsanti di controllo e verrà spiegato l'uso della tastiera.


I dati di database normalmente sono tabelle composte da un numero variabile di registazioni (records), ognuno di questi records è suddiviso in colonne (campi), lo scopo della gestione di files è quello di permettere l'introduzione di records, la loro modifica e la loro cancellazione. Nei programmi Compusoft, la gestione dei files avviene mostrando la tabella di dati.

La finestra si compone solitamente di due aree, nella parte superiore è presente una barra di pulsanti con cui è possibile dare comandi che hanno valore sulla riga selezionata e la parte centrale della finestra contiene la tabella con i dati, infine alle volte nella parte sottostante può essere presente un area che visualizza i dati più rilevanti dalla riga selezionata. Questa struttura è la più comune, ma si possono trovare finestre di gestione files strutturate in modo diverso per motivi specifici, ad esempio l'area di visualizzazione può essere assente, oppure la barra dei pulsanti può essre posizionata nella parte bassa della finestra.

La barra dei pulsanti di controllo a seconda delle esigenze visualizza solo i pulsanti che svolgono le funzioni necessarie in quel momento, tutti i comandi sono accessibili anche da tastiera e ci sono alcuni comandi che sono accessibili solo da tastiera.

Alle volte tra i comandi speciali dei pulsanti di controllo è presente il comando per attivare la spunta dei records. Questa funzionalità permette di scegliere solo alcuni dei records presenti nella tabella, ad esempio per stampare le etichette solo per alcuni clienti oppure per stampare solo alcuni documenti e così via. Dopo aver attivato il comando, viene visualizzata nella sinistra una colonna con le spunte, facendo doppio click sulla colonna vengono inserite o tolte le spunte, premendo con il tasto destro del mouse sulla colonna è possibile salvare le spunte attuali o ricaricare spunte salvate in precedenza. Dopo aver spuntato tutti i records desiderati, si può avviare il comando prescelto, non è detto però che tutti i comandi tengano conto delle spunte, ad esempio alcune stampe potrebbero tenerne conto ed altre no.


La gestione di altre tabelle è concettualmente molto simile alla gestione dei files la differenza sostanziale consiste nel fatto che mentre nella gestione dei files ogni modifica, inserimento o cancellazione effettuati sono immediatamente operativi e definitivi, nella gestione di altre tabelle si effettuano modifiche che vengono confermate o rifiutate in blocco alla fine.

I pulsanti di controllo chiave sono Conferma ed Annulla che pongono termine alla elaborazione con accettazione o rifiuto.


Pulsanti di controllo

La barra dei pulsanti di controllo è presente solitamente nella parte superiore di una finestra di gestione dati, si presenta con questo aspetto:

Tutti i comandi possono essere impartiti premendo tasti funzionali oppure cliccando con il mouse sul pulsante. A seconda delle necessità possono essere presenti più o meno pulsanti:

Primo

 Va alla prima riga

Precedente

 Va alla riga precedente

Successivo

 Va alla riga successiva

Ultimo

 Va all'ultima riga

Esportazione dati

 Permette di esportare i dati attualmente presenti nella gestione dati. I formati disponibili sono Testo ed Excel.
Il formato testo presenta una riga per ogni riga della gestione dati e le colonne sono separate da tabulatore, questo formato è facilmente importabile con altri programmi.
Il formato Excel viene presentato solo se nella macchina è installato MS Excel, quando viene scelto, apre un fogli di calcolo con i dati contenuti nella gestione dati.

Aggiungi [Ins]

 Aggiunge una riga

Cancella [Canc]

 Cancella una riga

Modifica [Invio] [Ctrl-Invio]

 Modifica la riga corrente, nella gestione di files aperta da un pulsante collegato corrisponde al tasto [Ctrl-Invio] perché il tasto [Invio] serve per confermare la selezione.

Conferma [F12] [Invio]

 Nella gestione di altre tabelle questa voce conferma tutte le modifiche effettuate, nella gestione di files è presente solo quando viene aperta da un pulsante collegato e serve per confermare la scelta e corrisponde al tasto [Invio].

Annulla [Esc]

 Nella gestione di altre tabelle questa voce annulla tutte le modifiche effettuate, nella gestione di files è presente solo quando viene aperta da un pulsante collegato e serve per annullare la scelta.

Sposta Su [<]

 Questa voce è presente solo nella gestione di altre tabelle e sposta verso l'alto la riga corrente

Sposta Giù [>]

 Questa voce è presente solo nella gestione di altre tabelle e sposta verso il basso la riga corrente

Stampa [F5]

 Se presente viene eseguita la stampa dei dati presenti in tabella. Prima di eseguire la stampa, si possono eseguire selezioni ed ordinamenti per stampare solo i dati che si desidera.

Ricerca [F2]

 Cerca nella colonna corrente, questo comando può essere attivato anche cliccando sulla colonna con il tasto destro del mouse, si apre una finestra in cui viene chiesto il valore da cercare, si può scegliere di cominciare a cercare da capo, oppure di continuare una ricerca, o infine di presentare una lista con tutti i dati che soddisfano la ricerca. se il valore viene trovato il cursore si posiziona sulla riga trovata, altrimenti viene segnalato l'errore di ricerca.

Ordina [F3]

Nella gestione di files viene scelto l'ordinamento tra quelli previsti (indici) e permette di inserire il valore da cercare nei campi di ordinamento.

Nella gestione di altre tabelle, questo comando riordina la tabella utilizzando la colonna corrente, l'ordinamento avviene prima per ordine crescente e poi per ordine decrescente.

Selezioni [F4]

 Questa voce è presente solo nella gestione di files e serve per scegliere dall'archivio corrente solo i records che soddisfano determinati criteri. Si apre una finestra con la lista dei campi che possono essere assoggettati a selezione:

Per ogni campo viene evidenziato il nome, il tipo di selezione effettuata ed i valori di selezione. Per ogni voce si può effettuare la scelta del tipo di selezione che sono:
= | Uguale, vengono selezionati solo i records con valore uguale a quello inserito.
<> | Diverso, vengono selezionati solo i records con valore diverso da quello inserito
<= | Minore o uguale, vengono selezionati solo i records con valore minore o uguale a quello inserito.
< | Minore, vengono selezionati solo i records con valore minore a quello inserito.
> | Maggiore, vengono selezionati solo i records con valore maggiore a quello inserito.
>= | Maggiore o uguale, vengono selezionati solo i records con valore maggiore o uguale a quello inserito.
$ | Contiene, vengono selezionati solo i records che in questo campo contengono in qualsiasi posizione il valore inserito.
>< | Compreso tra, vengono selezionati i records in cui il valore del campo è compreso tra quelli inseriti
nd | Non definito, non viene eseguita nessuna selezione su questo campo

Comandi speciali [Barra-Spazio]

 Questo pulsante è presente quando, sono disponibili comandi speciali su questa riga, premendolo si apre un menù con la lista dei comandi disponibili, nella voce viene sottolineato il tasto di scelta rapida che può essere usato per accedere direttamente al comando,

ad esempio nel menù evidenziato premendo C è possibile attivare il comando "Contatti" anche senza premere la barra spaziatrice.

I pulsante Selezioni normalmente permette di effettuare le selezioni sui campi più rilevanti dell'archivio, il programma permette anche di personalizzare le selezioni che vengono fatte più frequentemente. per fare questo si deve inserire nelle risorse utente risorse di tipo 'FLT' con codice uguale al nome interno della finestra (chiedere il nome alla Compusoft per ciascun archivio), il testo deve avere il seguente formato:

' Documenti del mese
' TMG
= DATANUM
<
@----------+--+----------------------------+--------------------------------
DATA       >< @curMonthIni                 @curMonthEnd
T_DOC      =  D
CODAGE
D_CONS
CAUS       >< 0                            9
TANA       =  C
ANAG
CODTDO

&---------------------------------------------------------------------------

 I campi vengono elencati uno per riga a partire dalla riga successiva a quella che inizia con il carattere at '@', prima di questa riga, se esiste una riga che iniza con uguale '=' quello che segue è il nome del indice da applicare, oltre a questo se esiste una riga che iniza con il segno minore '<' la visualizzazione viene posta automaticamente alla fine dei dati.
Dopo la riga che indica l'inizio dei campi (quella che inizia con '@'), in ogni riga si inserisce: a colonna 1 il nome del campo, a colonna 12 il tipo di selezione predefinito, a colonna 15 il primo valore di filtro predefinito ed a colonna 44 il secondo valore di filtro per selezioni di tipo "compreso tra". Le righe che seguono quella che inizia con il carattere e commerciale '&' vengono ignorate. Nei valori dei campi si possono inserire alcuni comandi speciali che sono:
@Today = data odierna
@curMonthIni = inizio del mese corrente
@curMonthEnd = fine del mese corrente
@LastMonthIni = inizio del mese precedente
@LastMonthEnd = fine del mese precedente
@curYearIni = inizio dell'anno corrente
@curYearEnd = fine dell'anno corrente
@LastYearIni = inizio dell'anno precedente
@LastYearEnd = fine dell'anno precedente

Compusoft di Driussi Claudio Viale Libertà, 23/d 33170 Pordenone


Durate la gestione dei dati sono disponibili un certo numero di comandi, la maggior parte di essi sono anche raggiungibili attraverso i pulsanti di controllo disponibili durante questa fase operativa, altri comandi sono raggiungibili solo con la tastiera (per il significato dei comandi non documentati consultare la voce "pulsanti di controllo").

Tasto | Pulsante | Comando
Freccia Sù |  | Riga precedente
Freccia Giù |  | Riga successiva
Pagina Sù |  | Pagina precedente
Pagina Giù |  | Pagina successiva
Ctrl + PagSù |  | Prima riga
Ctrl + PagGiù |  | Ultima riga
Freccia Sinistra |  | Campo a sinistra
Freccia a Destra |  | Campo a destra
Inizio |  | Primo campo
Fine |  | Ultimo campo
Ctrl + Freccia Sinistra |  | Sposta la colonna a sinistra
Ctrl + Freccia a Destra |  | Sposta la colonna a destra
Ins |  | Aggiungi
Canc |  | Cancella
Invio |  | Modifica
Ctrl + Invio |  | Modifica
< |  | Sposta Sù (solo altre tabelle)
> |  | Sposta Giù (solo altre tabelle)
* |  | Inserisce una riga nella posizione corrente invece che alla fine (solo altre tabelle)
F1 |  | Richiama la guida in linea
F2 |  | Cerca nella colonna, questo comando può essere attivato anche cliccando sulla colonna con il tasto destro del mouse, si apre una finestra in cui viene chiesto il valore da cercare nella colonna e se si debba incominciare da capo, se il valore viene trovato il cursore si posiziona sulla riga trovata, altrimenti viene segnalato l'errore di ricerca.
F3 |  | Ordina
F4 |  | Selezioni
F5 |  | Stampa
F7 |  | Esportazione
Barra spaziatrice |  | Comandi speciali disponibili per la riga.
F11 |  | Seleziona singola cella o tutta la riga. Questa scelta rimane memorizzata.
F12 |  | Conferma ed esci
ESC |  | Annulla ed esci


Le finestre di immissione dati vengono utilizzate quando l'utente deve inserire dati nel programma, principalmente questo avviene utilizzando la tastiera, il contenuto di una finestra alla fine può essere confermato dando via a procedure di memorizzazione o di elaborazione, oppure annullato.

La finestra può essere multipagina come in questo caso oppure più spesso monopagina e contiene principalmente caselle di testo ma anche altri controlli tra i quali un ruolo particolare rivestoni i pulsanti collegati. Nella selezione dedicata all'uso della tastiera vengono elencati i tasti disponibili in questa fase.

Nella parte bassa è visibile la barra di stato della finestra in cui vengono evidenziati eventuali annotazioni all'utente ed i tasti annulla e conferma rispettivamenti attivabili dai testi [Esc] e [F12].


Le caselle di testo sono il principale mezzo per introdurre dati nel programma,

durante l'immissione sono disponibili vari comandi attivabili da tastiera, il programma riconosce il tipo di dato da inseire e non permette di inserire dati non coerenti, ad esempio non si possono inserire date con formato errato, oppure di inserire dati non numerici dove sono richiesti numeri.

In alcuni casi la casella di testo dispone di un pulsante collegato che facilita la scelta del dato da inserire, inoltre alle volte il contenuto della casella viene specificato da un campo affiancato.

Nei campi data si può inserire la data del giorno prememdo i tasto [F3], inoltre solitamante dispongono di un pulsante collegato che apre un calendario da cui scegliere il gionro.

I pulsanti nella riga inferiore da sinistra a destra significano: Anno Precedente, Mese Precedente, Mese Successivo, Anno Successivo, Data del giorno, Annulla e Conferma, la selezione puo essere effettuata con il mouse ed anche con le frecce ed il tasto invio.

In alcuni casi sono disponibili combinazioni di caselle di testo chiamate "selezioni" con cui si possono stabilire criteri per estrapolare dati da un archivio, il primo campo permette di stabilire il tipo di selezione da effettuare ed a fianco sono disponibili uno o due campi in cui si può specificare i valori da confrontare.

Il significato del dato da introdurre nella casella di testo normalmente viene spiegato nella guida in linea che viene attivata premendo il tasto [F1], ma alle volte viene evidenziata una breve spiegazione nella barra di stato della finestra.


Oltre alle caselle di testo, nelle finestre di dialogo possono essere presenti altri controlli, quelli che si incontrano più spesso sono le caselle di spunta che permettono di inserire un valore si/no

Oppure i pulsanti che permettono di avviare svariati comandi.

I pulsanti vengono spesso usati per inserire un "memo" che è un posto in cui si possono memorizzare un breve testo, in questo caso si apre una finestra o un programma che permette di inserire il testo, il programma esterno viene chiamato se è stato configurato nei dati fissi.


I pulsanti collegati affiancano una casella di testo e servono per scegliere il valore da inserire nella casella. Il comando può essere richiamato cliccando con il mouse sul pulsante oppure più velocemente premendo [F2] nella casella di testo.

Quando si deve scegliere tra poche opzioni, il pulsante una lista di scelte vicino alla casella di testo.
Altre volte viene utilizzato quando si deve inserire un codice, in questo caso si apre una finestra con la gestione di files da cui scegliere, ma in cui è anche possibile inserire nuovi dati o modificare quelli esistenti.
Infine può succedere che il pulsante sia utilizzato per avviare comandi speciali che attraverso calcoli assegnano il valore alla casella di testo.


L'uso della tastiera si applica principalmente alle caselle di testo che sono i controlli più frequenti nelle finestre di immissione dati, gli altri controlli rispondono di solito ad una parte dei tasti elencati qui.

Inizio | Inizio del testo
Fine | Fine del testo
Freccia Sinistra | Un carattere a sinistra
Freccia Destra | Un carattere a destra
Ctrl + Freccia Sinistra | Una parola a sinistra
Ctrl + Freccia Destra | Una parola a destra
Ctrl + T | Cancella una parola a destra del cursore
Ctrl + Y | Calcella tutto a destra del cursore
Ctrl + U | Annulla le modifiche al campo.
Canc | Cancella il carattere sotto il cursore
Canc Indietro | Cancella il carattere a sinistra del cursore
F1 | Richiama la guida in linea.
F2 | Nei campi con pulsante collegato, richiama il comando del pulsante.
F3 | Nei campi data inserisce la data del programma.
Ins | Commutazione modo inserimento/sovrascrittura.
Shift + Freccia destra | Seleziona a destra
Shift + Freccia sinistra | Seleziona a sinsitra
Ctrl + Ins | Copia selezione
Shift + Canc | Taglia selezione.
Shift + Ins | Incolla selezione.
Freccia Sù | Campo precedente
Freccia Giù | Campo successivo
Tab | Campo successivo
Shift + Tab | Campo precedente
Invio | Campo successivo, sull'ultimo campo conferma ed esce.
Ctrl + Inizio | Primo campo della pagina
Ctrl + Fine | Ultimo campo della pagina
Pagina Sù | Nella gestione multipagina và alla pagina precedente, nella gestione monopagina conferma ed esce
Pagina Giù | Nella gestione multipagina và alla pagina successiva, nella gestione monopagina conferma ed esce
Esc | Annulla ed esce
F12 | Conferma ed esce
Barra spaziatrice | Nei pulsanti attiva il comando, nelle caselle di spunta commuta la spunta e nelle caselle di testo inserisce uno spazio


Un documento per questo programma è una particolare situazione in cui c'è una testata ed un numero variabile di righe solidali con la testata, il tipico caso di documento è una fattura a cliente nella quale in testata si inserisce la data, il numero, il codice cliente ecc... e nelle righe si inseriscono i dati dei prodotti venduti. Operativamente si presenta come una finestra di immissione dati che contiene anche una gestione di altre tabelle,

Confermando la testata vengono anche confermate tutte le righe ed annullando la testata vengono anche annullate tutte le righe. Alle volte un documento ha anche un piede in cui vengono visualizzati i totali del documento ed inseriti dati finali.

La particolarità della gestione dei documenti consiste nel fatto che i dati non possono essere inseriti contemporaneamente in testata e nelle righe, infatti quando si sta inserendo la testata le righe sono disabilitate e vengono visualizzate con una tonalità più scura.

Alla fine dell'inserimento dalla testata avviene la validazione dei dati inseriti e se sono corretti per gli scopi della procedura si può passare all'inserimento delle righe che viene segnalato con un cambio della tonalità di colore delle righe.

Un altra validazione avviene alla conferma delle righe, se i dati dell'intero documento sono corretti si procede alla memorizzazione, altrimenti si rimane nel documento fintanto che i dati non sono corretti.

I pulsanti di conferma ed annulla della finestra, nel contesto del documento significano avanti ed indietro, il pulsante di conferma dalla testata passa alle righe e dalle righe passa alla conferma del documento, mentre il pulsante di annulla dalle righe passa alla testata e dalla testata passa all'abbandono del documento.


Quando si richiede una stampa si apre una finestra che ci permette di sceglere il tracciato di stampa (se ne sono disponibili più di uno), il titolo della stampa, il numero di copie, il tipo di stampa o esportazione dati, l'anteprima ed il livello di zoom in anteprima.

Se si sceglie l'anteprima alla fine della elaborazione dei dati si presenta una finestra che visualizza i dati stampati:

da questa finestra è possibile selezionare e configurare la stampante di destinazione e visualizzare tutte le pagine stampate con diversi livelli di zoom.

L'esportazione può essere fatta in formato HTML che è il formato delle pagine internet, oppure in formato EXCEL ed in questo caso è necessario che sia installato MS Excel nel computer, oppure in formato JPG che è un formato grafico.

In alternativa al formato JPG, si può esportare in formato PDF che è un formato molto diffuso soprattutto per comunicare dati in internet. Per attivare il formato PDF è necessario installare il programma PDFCreator che è un driver di stampa che produce documenti PDF e che può essere scaricato gratuitamente da http://www.pdfforge.org.

Le stampe vengono effettuate utilizzando un sistema di tracciati stampa, questo significa che le stampe sono in una certa misura modificabili. Il tracciato riguarda la parte estetica della stampa ed i contenuti della stessa, ma la disponibilità di dati e l'ordine di presentazione è codificata all'interno del programma. Una stessa stampa può avere più tracciati per rispondere a diverse esigenze di visualizzazione e possono essere aggiunti su richiesta dell'utente.
I tracciati possono essere modificati dall'utente, ma i dettagli tecnici sulle voci da inserire nella stampa devono sempre essere richiesti alla Compusoft o da tecnici autorizzati dalla stessa, fisicamente i tracciati sono contenuti nelle risorse del programma e possono essere modificate con un apposito editor visuale.


I programmi della Compusoft possono disporre di due diversi modelli di gestione degli utenti e dei diritti. Il modello utilizzato dipende dal programma, alcuni programmi utilizzano il modello semplificato ed alri il modello completo.

Il modello completo dipone di metodi anche sofisticati per identificare quali utenti possono accedere a quali procedure. Il modello semplificato invece serve solo per inibire l'accesso al programma a coloro che non conoscono i dati di login.

Poiché il modello completo dei diritti è piuttosto sofisticato, la sua gestione non è semplicissima e si consiglia che venga effettuata da personale tecnico. Le note che seguono sono le istruzioni tecniche per tale tipo di personale.

Le definizione delle voci soggette a modalità di accesso sono definite in modo gerarchico con relazioni di tipo padre figlio. Il vantaggio di questo tipo di approccio consiste nel fatto che si possono gestire "profili" di utente facilmente modificabili con il mutare delle condizioni senza dover modificare a mano lunghe sequenze di diritti per cisacun utente.

Tracciato di configurazione

La configurazione delle voci soggette a modalità di accesso viene fatta mediante un tracciato, con il programma solitamente viene fornito un tracciato che soddisfa le esigenze più comuni. Il tracciato si trova tra le Risorse di Sistema ed è di tipo 'MNU' e si chiama 'RIGHTS'. Se è necessario fare modifiche al tracciato, lo si deve copiare tra le Risorse Utente e quindi modificarlo a mano.

Il tracciato serve per definire quali sono i punti del programma il cui accesso viene regolato ed anche quali relazioni intercorrono tra le varie voci.

Questo è un piccolo esempio di tracciato:

' REGOLE PER I DIRITTI DI ACCESSO
= STANDARD, IDR
MNU ----------------------------------------------+---------+-------------------
File                                              rfFile
  Archivio di lavoro                              rfOpen    BACKUP
  Cambia data                                     rfDate
  Copia dati                                      rfCopia   BACKUP
  Utilità                                         rfUtil
    Ricostruzione dati                            rfPack    BACKUP
    Chiudi tutte le finestre                      rfCloseW
    Manutenzione archivio                         rfEdData  CONFIG
    Risorse/Informazioni                          rfRes     CONFIG
  Fine                                            rfEnd
Dati                                              rdBase
  Eventi                                          RNN01     RNN, CONFIG
  Addetti                                         ADT01     ADT
  Tabelle e liste                                 rmTab     CONFIG
    Progetti                                      PRJ01     PRJ

DDF ----------------------------------------------+---------+-------------------
Addetti / Dipendenti                              ADT       USR
Progetti                                          PRJ       CONFIG
Eventi                                            RNN

GRP ----------------------------------------------+---------+-------------------
Addetti configurazione                            CONFIG
Copie a manutenzione archivi                      BACKUP    CONFIG
Visualizza prezzi                                 PRZ
Utenti                                            USR

%-------------------------------------------------------------------------------
Commenti e note.

Le righe che iniziano con il segno "'" (singolo apice) sono commenti ininfluenti ai fini del tracciato.

Tutto quello che viene trovato dopo la riga che inizia con il segno "%" (percentuale) viene ignorato, perciò si possono inserire in questa posizione note e commenti.

La riga che inizia con il segno "=" (uguale) contiene i riferimenti dei tracciati di menù utilizzati separati da virgoal, solitamente l'utente non dovrebbe modificare questa riga.

Le righe di definizione dei diritti sono organizzate in modo gerarchico, ogni riga può fare riferimento a zero, una o più righe padre e se non viene definita una regola di accesso per la singola voce vengono utilizzate quelle definite per le righe padre.

Le righe che non hanno riferimento padre sono le finali a cui vengono assegnati i diritti per ogni utente.

Le righe di definizione dimensioni fisse, sulla sinistra c'è la descrizione della riga, a colonna 51 c'è il codice univoco che la identifica ed a colonna 61 si inseriscono i riferimenti a elementi padre separati da virgole.

Esistono tre tipi di righe di definizione dei diritti divisi in gruppi, i tipi sono "MNU", "DDF" e "GRP" ed iniziano quando si incontra una riga che inizia con lo stesso codice.

Le righe "MNU" hanno la stessa sequenza dei menù del programma e servono per definire i diritti di accesso alle singole voci di menu, se un utente non ha i diritti per un determinato menu, semplicemente non vede la voce. Da questo consegue che tutti i sottomenu di una voce nascosta sono a loro volta nascosti anche che hanno un diritto di accesso più liberale.

Le righe "DDF" regolano l'accesso alle tabelle di database utilizzate dal programma.

Le righe "GRP" infine servono a definire raggruppamenti di altre voci e sono utilizzate per assegnare o revocare diritti in modo globale a tutte le voci figlie del raggruppamento.

Le righe di tipo MNU e DDF possono variare nel tempo a mano a mano che che il programma viene modificato ed aggiornato, di queste righe si possono solo modificare i riferimenti a righe padre.

Da notare che solitamente le voci di menù che accedono a tabelle del database hanno come riferimento padre la tabella e quindi ne "ereditano" i diritti.

Le righe di tipo GRP sono inserite e modificate manualmente e non vengono alterate da modifiche al programma. Per gruppo si intende sia elementi che sono padri di altri elementi, sia elementi che non sono padri e che vengono gestiti in modo diretto dalla applicazione.

Assegnazione dei diritti

I diritti di accesso alle voci definite dal tracciato di configurazione vengono assegnati individualmente per ciascun utente.

I diritti possono avere vari livelli di accesso. I livelli hanno senso solo per la gestione delle tabelle, nel caso dei menù o l'accesso è negato o in tutti gli altri casi è concesso.

I livelli sono:
0 | Non assegnato | Il diritto concesso o negato a seconda del tipo di voce. I MNU ed i DDF vegnono sempre concessi, i GRP invece vengono negati.
1 | Negato | Non è possibile nessun accesso.
2 | Sola lettura | Il dato è solo leggibile ma non modificabile.
3 | Inserimento | Si possono solo inserire nuovi valori ma non modificare o cancellare quelli esistenti.
4 | Modifica | è il livenllo meno restrittivo, si possono inserire, cancellare e modificare i dati.

Se non viene assegnato nessun diritto, l'utente è superuser ed ha accesso a tutto il programma, se viene assegnato almeno un diritto, tutti i diritti non citati vengono negati se sono GRP oppure vengono accordati se sono MNU o DDF.

Nel programma ogni punto di accesso ha un codice che corrisponde ai codici del tracciato,per stabilire i diritti di accesso, quando viene trovato un nome, si cerca a ritroso nelle definizioni del tracciato fino alla voce senza riferimento padre, oppure fino a che non viene fatta una assegnazione di diritti diretta a quella voce. L'ereditarietà dei diritti è multipla, la ricerca viene effettuata per ogni riferimento e viene applicato il criterio meno restrittivo che viene trovato.

A partire dalla gestione degli utenti è solitamente disponibile una procedura che aiuta a scegliere i diritti in modo visuale.

Questa procedura presenta tutte le voci presenti nel tracciato di configurazione e permette per ciascuna di inserire il livello di accesso. Se viene assegnato un levello per una voce che è padre di altre sottovoci, tutte queste otterranno lo stesso livello di accesso.

Per facilitare l'assegnazione si può scegliere di vedere solo i gruppi (GRP), oppure i Menù e database (MNU, DDF) oppure tutte le voci.

Si può anche sceglere se si desidera vedere solo quelli che non hanno riferimenti padre, oppure quelli che li hanno oppure tutte le voci.

Una volta scelta una voce si può scegliere un livello di assegnazione che sottostanno a tutte le regole esposte in precedenza.

Nota: Alle volte è più comodo e veloce intervenire manualmente sui diritti di ciascun utente, per fare questo si deve modificare il testo con la lista dei diritti assegnati nel quale ogni riga contiene il codice della voce seguito da una virgola e dal livello di accesso. Tutte le voci non citate non sono assegnate.

Importante:

La gestione della sicurezza è benché sia piuttosto sofisticata, è stata pensata più come detterrente che come una vera e propria difesa contro le intrusioni di tipo malevolo, i dati non sono crittografati e quindi sono visibili abbastanza facilmente utlizzando programmi di manutenzione dati. Per questo motivo se ci sono esigenze di maggiore sicurezza, è necessario attivare sistemi di sicurezza esterni al programma.


In alcuni casi i programma della Compusoft permettono di collegare documenti elettronici ai dati del programma.

Ad esempio, se questa funzione è abilitata, si possono legare documenti Word o Excel, oppure immagini o disegni tecnici ad un cliente o un fornitore, in questo se vogliamo cercare un documento fatto per un certo cliente basta andare su quel cliente ed aprire i suoi documenti.

L'uso di questa funzione è semplice, ma racchiude in se una certa sofisticazione e la possibilità di configurare il sistema in modo molto raffinato.

Esempio di utilizzo

Per spiegare l'uso di questa funzione conviene fare un esempio pratico.

Supponiamo di voler fare un preventivo ad un cliente con MS Excel e di voler conservare il documento nel sistema di gestione documentale. Si dovrà agire così:

Prima di tutto si scrive il documento, poi lo si salva in una cartella che il sistema riconosce come come cartella di trasito (di solito questa cartella è "C:\CS\Documenti")

Quindi si va nell'archivio dei Clienti, si trova il cliente a cui stiamo facendo il preventivo, e si attiva la funzione di gestione documenti (solitamente premendo il pulsante dei comandi speciali)

A questo punto si apre la finestra con la lista dei documenti legati a questo clienti, premendo il pulsante di inserimento nuovi dati, si apre la finestra di apertura documenti che automaticamente si posiziona sulla cartella di transito, in cui troviamo il documento salvato in precedenza. Lo scegliamo e clicchiamo il pulsante "Ok"

Fatto questo il sistema ci chiede la descirzione del documento e da data di inserimento e se confermiamo il tutto alla fine copia il file in una propria cartella e lo cancella dalla cartella di transito.

In seguito il documento potrà essere aperto e modificato come illustrato in questa videata.

e sarà facilmente reperibile in seguito.

Dettagli tecnici

Come dicevamo precendentemente, il sistema è piuttosto sofisticato e configurabile. La configurazione avviene utilizzando files di configurazione in formato INI (che è un formato di files tipico di Windows). Ogni archivio può avere un file di configurazione diversa, ad esempio i Clienti possono avere una configurazione diversa dagli Articoli.

Ci possono essere 3 livelli di files di configurazione in modo da consentire ad ogni utente di configurare la propria macchina. Il nome del file di configurazione può cambiare da archivio ad archivio e solitamente inizia con "DR", per primo viene cercato il file nella cartella del programma, poi viene cercato un file con lo stesso nome nella cartella temporanea locale del programma che di solito è C:\CS, infine viene cercato un file di nome "DOCREP.INI" nella cartella C:\CS. Se nessuno di questi 3 files è presente vengono adottati i parametri di configurazione standard illustrati nel seguente esempio di file di inizializzaizone:

; La procedura di gestione dei documeti esterni riconosce 3 files INI di
; configurazione. Il primo file si trova nella cartella del programma e può
; avere un nome diverso per ogni archivio che gestisce documenti, il secondo
; ha lo stesso nome del primo ma si trova nella cartella C:\CS di ogni utente
; e serve per configurare le impostazioni locali per ogni utente, ed infine
; il file di nome DOCREP.INI nella cartella C:\CS solitamente viene utilizzato
; per configurare le associazioni alle estensioni di files non riconosciute
; per ogni utente.

; Parametri di configurazione
;
; ROOTDIR    directory di partenza per i documenti
; BAKDIR     directory in cui copiare i files prima della cancellazione
; IMPORTDIR  directory temporanea che contiene i documenti da importare
; TEMPLDIR   directory in cui memorizzare tracciati standard di documenti
; SUBPATH    percorso delle directory in cui memorizzare i documenti importati
; PREFIX     prefisso dei nomi di files
; NPROG      numero di caratteri del progressivo numerico
;
; nei nomi delle cartelle e del prefisso vengono riconosciuti i seguenti nomi:
; @NAME      nome mnemonico che solitamente corrisponde alla ragione sociale del soggetto
; @CODE      è un codice numerico abbinato al nome mnemonico per evitare nomi ambigui
; @EXT       estensione del documento
; @YEAR      anno della data corrente
; @MONTH     mese della data corrente
; @DAY       giorno della data corrente

[SETUP]
;ROOTDIR = _DOC
;BAKDIR = _BAK
;IMPORTDIR = C:\CS\Documenti
;TEMPLDIR = C:\CS\Documenti\Tracciati
;SUBPATH = @NAME@CODE\@YEAR\@EXT
;PREFIX = @NAME@MONTH@DAY_
;NPROG = 4

; Estensioni riconosciute
;
; In questa posizione si possono inserire i nomi dei programmi che aprono
; i files con l'estensione indicata, se l'estensione non è presente tra queste
; viene utilizzata l'associazione predefinita di Windows.

[EXTENSIONS]
;JPG = MSPAINT.EXE
;TXT = NOTEPAD.EXE

Come si può vedere, si possono configurare vari aspetti del programma. Ad esempio si può dire con quale programma si devono aprire i files con una determinata estensione.

C'è un altro aspetto importante. Il sistema gestisce i documenti in tre modi diversi a seconda della posizione in qui si trovano nel momento che vengono importati nel sistema:
Se il file da importare si trova nella cartella di transito (solitamente C:\CS\Documenti), il file viene copiato nella cartella di sistema e cancellato dalla cartella di transito.
Se il file si trova nella cartella dei tracciati (solitamente C:\CS\Documenti\Tracciati), il file viene copiato nella cartella di sistema, ma non viene cancellato l'originale ed in questo modo si possono fare documenti simili per usi simili.
Infine se il documento si trova in un altra posizione, semplicemente viene gestito il riferimento esterno ed in questo modo si può assegnare lo stesso documento a più di un dato, ma anche si deve fare attenzione a non cancellare il documento senza cancellare anche i riferimenti.

Nel file INI dell'esempio sono anche illustrate la posizione standard di memorizzazione e le convenzioni sui nomi.


La gestione delle spunte è disponibile solo in alcuni archivi e viene solitamente attivata dai comandi speciali.

Quando viene attivata, viene visualizzata una nuova colonna alla sinistra delle altre colonne che compongono la lista delle registrazioni che si stanno utilizzando.

Facendo doppio click sulla colonna, oppure premendo invio quando ci si trova sopra, si mette o si toglie una spunta sulla riga corrente.

Se si fa click con il pulsante destro, compare un menù che permette di salvare lo stato delle spunte fino a questo momento, oppure di caricare una configurazione di spunte salvate in precedenza.

La possibilità di salvare e caricare liste di spunte consente di interrompere e riprendere il lavoro di gestione spunte in diverse sessioni di lavoro. Inoltre è utile per memorizzare liste di spunte da utilizzare per scopi specifici, ad esempio si potrebbe memorizzare una lista dei clienti a cui desideriamo mandare gli auguri di Buon Natale.

Altri comandi del menù consentono di selezionare solo le righe spuntate e quindi di nascondere le righe non spuntate e poi di invertire le spunte, oppure spuntare tutte le righe o togliere tutte le spunte.

L'utilità di gestire le spunte consiste nel fatto che alcuni comandi possono agire solo sui dati spuntati, il caso più frequente è quello delle stampe che se sono state attivate le spunte ignorano tutte le righe non spuntate.


La parte di riferimento della guida in linea illustra il funzionamento delle voci di menù del programma,

File è il menù comune a tutti i programmi Compusoft e permette di attivare procedure di servizio,
Dati contiene voci per la gestione di archivi e tabelle utilizzati dal programma,
Contabilità si occupa della gestione contabile dell'azienda,
Scadenze permette di gestire le scadenze di clienti e fornitori ed il portafoglio effetti.
Magazzino contiene voci per la gestione del magazzino e dei documenti amministrativi.


In questo menù sono contenute voci di manutenzione generale del programma.

Archivio di lavoro permette di scegliere l'archivio su cui lavorare,
Cambia data permette di cambiare la data di riferimento all'interno del programma,
Copia dati serve per automatizzare le copie dei dati di lavoro,
Configurazione contiene voci per configurare il programma a seconda delle necessità dell'utente,
Utilità contiene voci per la manutenzione del programma, da ultimo
Fine permette di uscire dal programma.


I programmi Compusoft permettono di lavorare su archivi diversi con dati diversi, ad esempio si possono tenere su archivi diversi i dati di ditte diverse, oppure relativi ad anni diversi. Con questa procedura si può scegliere l'archivio su cui lavorare.

Oltre a scegliere l'archivio su cui lavorare, questa procedura permette anche di creare archivi nuovi, cancellare archivi esistenti, oppure copiare dati da un archivio ad un altro. La procedura funziona come una normale gestione di files con i tasti di creazione e cancellazione abilitati, premendo il tasto di comandi speciali viene attivata la procedura di copia dati.

Per convenzione l'archivio di lavoro normalmente utilizzato si chiama "DATI", quindi se non c'è un buon motivo per utilizzare un nome diverso oppure la necessità di lavorare su più archivi si raccomanda di lavorare su questo.

Di solito i dati di ogni archivio sono fisicamente memorizzati in una cartella separata per ogni archivo dentro alla cartella contentene il programma, i dati sono nel popolare formato DBF e quindi possono essere visualizati, importati ed esportati con altri programmi, comunque per mantenere l'integrità funzionale del programma si raccomanda di non eseguire modificare i dati con programmi diversi ma usarli eventualmente solo per eseguire esportazioni.


All'avvio del programma viene presa come data di riferimento la data del computer, con questa procedura si può cambiare data al programma senza che venga cambiata la data del computer. Questa data viene proposta automaticamente in varie occasioni all'interno del programma.

premendo il pulsante collegato, o il tasto F2 si apre una finesta con un piccolo calendario, con i pulsanti del calendario si può passare da un mese all'altro, da un anno all'altro, inserire la data odierna, confermare ed annullare.


Questa procedura serve per fare le copie dei dati su dischetti o sul disco fisso.

Le copie sono molto importanti per evitare di perdere tutto il lavoro fatto in caso di perdita accidentale dei dati. La perdita dei dati fortunatamente non è un evento frequente ma è molto grave, infatti la cancellazione dei dati può comportare la perdita di centinaia di ore di lavoro ed addirittura la perdita di dati non ricostruibili, per questi motivi

Consigliamo di fare le copie dei dati molto spesso, anche ogni giorno.

Per eseguire le copie viene chiamato un programma esterno che esegue il lavoro in modo completamente automatico. Si presenta la seguente videata:

Per avviare la copia è sufficiente premere il pulsante Esegui.

La copia può essere fatta su dischetti o su disco fisso, solitamente si sceglie di salvare su disco fisso quando si dispone di un masterizzatore o di altri dispositivi di backup e gli archivi sono molto grandi tanto che la copia su dischetti risulta lenta.

Se la copia viene fatta sui dischetti, si può richiedere la formattazione, invece se la copia viene fatta su disco fisso può essere utile aggiungere al nome del file la data di copia.

I files da copiare possono essere aggiunti o tolti manualmente, ma normalmente non serve modificare i dati proposti.


Nel menù di Configurazione sono contenute voci che consentono di impostare dati di carattere generale usate dal programma,

Intestazione ditta pernette di inserire l'intestazione degli archivi quando è presente la licenza multiditta.
Dati Fissi permette di inserire alcuni dati di configurazione di carattere generale.
Licenza software è la voce che permette di abilitare la funzionalità completa del programma.
Licenza aggiornamenti con questa voce si inseriscono i dati della licenza temporanea per gli aggiornamenti.
Utenti permette di inserire la lista degli utenti autorizzati ad utilizzare il programma.
Stazioni degli Utenti permette di configurare gli utenti abituali di una stazione di lavoro.


L'intestazione multiditta è disponibile solo se è stata attivato il modulo multiditta nella licenza software.

La licenza multiditta consente di intestare gli archivi di lavoro ad utenti diversi, è una funzionalità tipicamente usata dai commercialisti che tengono la contabilità per più ditte e desiderano quindi che le stampe fiscali siano intestate ai vari clienti.

Si inseriscono i dati che si desidera vengano stampati nelle intestazioni delle pagine.


Questa voce permette di configurare alcuni dati di carattere generale del programma.

Gestione sicurezza | Abilita la richiesta di nome utente e password per entrare nel programma.
Storico accessi | Se si abilita questa funzione, ogni accesso ad una voce di menù viene memorizzata in un file di testo, su ogni riga viene memorizzata la data e l'ora dell'accesso, l'utente, la stazione e la voce di menù.
Memorizza posizione finestre | Normalmente le finestre hanno una dimensione stabilita e vengono posizionate al centro del video, ma se si abilita questa voce, il programma ricorderà la dimensione e posizione di ogni finestra.
Prezzi con 2 decimali in più | Questa voce si applica soltanto ai programmi che trattano prezzi unitari. Normalmente i prezzi e tutti gli importi monetari in genere presentano 2 decimali, si si abilita questa voce, i campi che riportano prezzi unitari vengono esposti con 4 decimali.
Abilita comandi obsoleti | Alle volte accade che per motivi tecnici o per aggiornamenti normativi, alcuni comandi non siano più attuali per cui vengono tolti dal menù e vengono resi visibili solo se richiesti esplicitamente
Abilita copie automatiche | Questa opzione fa partire automaticamente le copie alla chiusura del programma.
Archivio dati predefinito | In questa posizione si può inserire il nome dell' archivio di lavoro utilizzato comunemente in modo che se per errore si va su un altro archivio e ci si dimentica di ritornare nell'archivio abituale viene emessa una segnalazione.
Anno base delle date | Per brevità e semplicità le date vengono inserite indicando solo le ultime 2 cifre dell'anno, ad esempio il primo gennaio 2000 viene scritto "01/01/00", in questa posizione viene inserito l'anno di partenza per la gestione del secolo, in pratica se si inserisce 1980, le date con anno da 80 a 99 apparterranno al 1900 e quelle comprese tra 00 e 79 apparterranno al 2000.
Directory per copie | In questa posizione si può inserire la directory utilizzata dalla procedura di copia dati per fare le copie dei dati del programma, se si lascia vuoto questo campo la copia viene fatta sul dischetto A:\, altrimenti viene fatta nella directory indicata. Se il PC su cu si effettua la copia dispone di Windows XP è possibile copiare i dati anche su un CD.
Password per copie e conferma password | Per criptare i dati delle copie si può inserire una password di protezione.
File alternativo di database | Normalmente i dati del programma vengono memorizzati in cartelle che risiedono all'interno della cartella che contiene il programma, però in casi particolari è possibile indicare al programma che si deve utilizzare una posizione diversa, in questo campo si può memorizzare i dati sulla posizione diversa.
Editor per i campi memo | In questo campo si può inserire il nome del programma che si desidera utilizzare per modificare i campi Memo.


La licenza Software è il metodo utilizzato dalla dalla Compusoft per evitare usi non autorizzati del programma, se la chiave di attivazione inserita non è corretta per i dati del titolare della licenza ed moduli installati, il programma funziona in modalità dimostrativa, il che significa che si può provare il programma in tutte le sue parti, ma vengono impostate limitazioni nella quantità di dati inseribili.

I dati dell'utente vanno inseriti nelle prime sei righe di testo, quindi si inserisce l'elenco dei moduli installati che a seconda del programma e delle necessità dell'utente possono essere diversi, infine si inserisce il tipo di licenza che può essere per monoutenza o per multiutenza.

Con questi dati si può chiedere alla Compusoft la chiave di attivazione che è una sequenza di 10 caratteri unica per ogni combinazione di dati utente e moduli installati e che verrà fornita in base alle condizioni di cessione.

Il tipo di licenza di monoutenza o multiutenza condiziona il tipo di utilizzo che può essere fatto. In caso di monoutenza il programma potrà essere utilizzato da un solo utente, se il programma è installato in una rete di computers si potrà utilizzarlo in qualsiasi stazione, ma solo un utente per volta, questa limitazione cade in caso di multiutenza e quindi si potrà utilizzare il programma contemporaneamente da più stazioni, naturalmente il programma si preoccupa di evitare che due utenti accedano contemporaneamente allo stesso dato in modo da garantirne l'integrità.


Questa procedura serve per inserire i dati della licenza temporanea utilizzata da alcuni programmi Compusoft.

Esistono due tipi di licenza, la licenza di aggiornamento e la licenza temporanea.

La licenza di aggiornamento serve ad indicare il periodo entro cui è legittimo eseguire gli aggiornamenti del programma che possono essere facilmente eseguiti anche dall'utente finale scaricando dal sito internet di Compusoft la versione ultima del programma. Dopo la scadenza della licenza l'utente ha ancora il diritto di utilizzare pienamente il programma ma non più di eseguire aggiornamenti al programma.

La licenza temporanea invece viene utilizzata per dare la possibilità di utilizzare il programma pe un determinato periodo di tempo. Alla fine del periodo fissato il programma non permetterà più l'inserimento di nuovi dati.

Se si eseguono aggiornamenti dopo la scadenza della licenza di aggiornamento e quindi fuori dai termini di licenza, si provoca la fine del funzionamento del programma, per ripristinarne la funzionalità sarà necessario ripristinare una copia funzionante eseguita prima della scadenza della licenza, oppure richiedere alla Compusoft una estensione della licenza. Attenzione! la Compusoft non conserva le copie delle versioni compilate in data precedente all'ultima versione e quindi per ripristinare la funzionalità sarà in grado solamente di fornire estensioni di licenza .


Questa procedura permette di memorizzare la lista degli untenti abilitati ad utilizzare il programma.

La gestione degli utenti ha senso solo se è stata abilitata la sicurezza nella gestione dei Dati Fissi, in questo caso per entrare nel programma viene richiesto il nome utente e la password.

Chi non conosce un nome utente ed una password validi non riesce ad entrare nel programma.

I programmi della Compusoft possono disporre di due diversi modelli di gestione degli utenti e dei diritti. Il modello utilizzato dipende dal programma, alcuni programmi utilizzano il modello semplificato ed alri il modello completo.

Modello semplificato

Il modello semplificato di gestione degli utenti funziona in modo "Tutto o niemte" e serve solo per inibire l'accesso al programma a coloro che non conoscono i dati di login. Quando un utente riesce ad entrare ha a disposizione tutte le procedure previste senza alcuna limitazione.

Per ogni utente si memorizza il nome utente, la password e la descrizione. Vengono chiesti anche i privilegi dell'utente, ma al momento questo dato è ininfluente.

Modello completo

I programmi che utilizzano il modo completo di gestione degli utenti, permettono di stabilire in modo anche molto sofisticato quali utenti possono accedere alle varie risorse del programma.

Con questo modello si possono nascondere le voci di menù che si desidera che gli utenti non vadano, e si riesce a limitare l'accesso alle tabelle del programma.

I dati richiesti in questo tipo di gestione possono variare da programma a programma, ma solitamente sono richiesti almeno questi dati:

Codice | è il codice che identifica l'utente, ma non corrisponde con il codice che viene richiesto quando si effettua il login, invece a seconda dei programmi può essere utilizzato per indetificare gli utenti in varie procedure.
Cognome e Nome | Si inseriscono il dati anagrafici dell'utente.
Codice utente | è il codice che si inserisce in fase di login. Questo codice può essere cambiato in ogni momento.
Cambia password | Premendo questo pulsante si può cambiare la password di questo utente. La password deve essere inserita due volte per controllare che non ci siano errori di battitura.
Diritti di accesso | Premendo questo pulsante, si attiva una procedura che permette di scegliere a quali procedura ha accesso questo utente. Il funzionamento di questa procedura è spiegata assieme alla gestione dei diritti di accessi.
Data di scadenza | Vengono rifiutati i tentativi di login effettuati in data successiva a quella inserita. Se la data è in bianco, non c'è alcuna data di scadenza.
Accesso sospeso | Se si spunta questa casella, non si riesce ad effettuare il login con questo utente fino a rimozione della spunta.
Altri dati | A seconda del programma ci possono essere altri dati da inserire.

Nella gestione dei diritti di accesso, viene spiegata in dettaglio tutta la metodica utilizzata per configurare l'accesso alle varie parti del programma utilizzando la modalità completa.


Questa procedura, se presente, permette di assegnare una stazione di lavoro ad un utente anche se il programma non è stato configurato per la gestione della sicurezza.

In pratica, siccome si suppone che un utente lavori abitualmente sempre su una stessa stazione o al massimo alcune stazioni, con questa procedura su indica al programma quale è l'agente che presumibilmente utilizza il programma.

Alcuni programmi possono utilizzare questi dati di configurazione per fornire informazioni automatiche all'utente abituale.

Per aggiungere una stazione si aggiunge una riga e poi si inseriscono i seguenti dati:

Stazione | Indicare il nome della stazione che è composta dal nome del computer più il nome dell'utente inserito al momento dell'accesso al computer. Il tasto a fianco assegna automaticamente i dati relativi alla stazione corrente.
Utente | Inserire il codice dell'utente corrispondente.
Note | Se si desidera si può inserire una breve nota.

Ogni utente può essere l'utente preferenziale di più di una stazione, però se per la stessa stazione si inserisce più di un utente, viene preso in considerazione solo il primo.


Nel menù di Utilità sono contenute voci di manutenzione che servono a garantire il corretto funzionamento del programma.

Ricostruzione dati ricostruisce l'integrità dei dati dopo chiusure non corrette o accidentali del programma
Ripristina posizioni cancella la memoria della posizione e dimensione delle finestre.
Manutenzione archivio permette di modificare i dati di tutti gli archivi gestiti dal programma
Variabili utente serve per personalizzare alcune delle anagrafiche gestite dal programma.
Risorse/Informazioni permette la manutenzione di alcuni dati tecnici


Questa voce permette di ricostruire l'integrità dei dati in caso di danneggiamenti dovuti a caduta di tensione o ad uscite accidentali dal programma, volendo è anche possibile cancellare dati vecchi accumulati e non più necessari.

Viene presentata la lista delle tabelle che il programma utilizza. Per ogni tabella vengono evidenziati il nome, la descrizione della funzione della tabella, l'indicazione se qualche altro utente sta utilizzando la tabella al momento, il numero di records, la sigla ed il percorso fisico nel disco fisso.

In caso di multiutenza, se nel momento che si decide di effettuare la ricostruzione ci sono altri utenti che utilizzano il programma, le tabelle impegnate vengono evidenziate come bloccate e non è possibile ricostruirle, tra i comandi speciali è disponibile un comando che cerca le tabelle bloccate in modo di da far uscire e controllare le tabelle prima di eseguire la procedura.

Se si desidera si può spuntare o togliere la spunta alle tabelle che non si desidera ricostruire.

Quando si conferma la ricostruzione (premendo la spunta verde presente nella barra dei pulsanti), viene chiesto il tipo di ricostruzione. Di solito è sufficiente fare la reindicizzazione ma se si preferisce si può fare la compattazione che contemporaneamente recupera lo spazio utilizzato dai records cancellati.

Questa procedura potrebbe anche richiedere molto tempo se gli archivi da ristruttrare sono molto grandi, per files con centinaia di migliaia di registrazioni è normale un'attesa di 15 minuti o più. Per ogni tabella ricostruita, viene evidenziato il tempo impiegato.

Alla fine se si desidera si può stampare un resoconto delle operazioni eseguite.


Durante l'uso, il programma memorizza alcune scelte che vengono effettuate dall'utente, questa procedura permette di azzerare questi dati memorizzati. I dati che si possono azzerare sono:

La memoria delle posizioni delle finestre, questa procedura ha senso solo se è stata abilitata la memorizzazione delle posizioni delle finestre nella gestione dei dati fissi, dopo averla utilizzata le finestre quando vengono aperte vengono posizionate al centro dello schermo nella loro dimensione normale.

La memoria della posizione delle colonne nelle finestre di gestione dei dati che durante l'uso possono essere spostate con i comandi CTRL + Freccia Destra e CTRL + Freccia Sinistra.

Infine la memoria delle impostazioni delle ricerche che vengono memorizzate quando nella finestra di gestione dei dati viene premuto il tasto F2 per fare le ricerche sulle colonne dei dati.


Questa voce permette di eseguire la manutenzione di tutti i dati gestiti dal programma con accesso a tutti i campi compresi quelli che normalmente sono gestiti automaticamente dal programma e quindi nascosti all'utente.

Dopo aver scelto il nome dell'archivio da modificare, si presenta una finestra di gestione files da cui è possibile eseguire tutte le operazioni di gestione del database.

Questa procedura data la sua ampia possibilità di gestione dei dati potrebbe anche provocare incongruenze gestionali e quindi va utilizzata con la massima cautela.


In alcuni casi il programma permette di personalizzare la struttura dei dati di alcuni archivi, per esempio può essere utile inserire il numero di targa della vettura di un cliente, oppure serve aggiungere ai fornitari la marca principale trattata. In questi casi si possono utilizzare la variabili utenti.

Non tutti gli archivi possono essere configurati per utilizzare le variabili utenti, inoltre il loro utilizzo funzionale potrebbe dipendere da procedure presenti nel programma, per questi motivi per utilizzare questa funzionalità si consiglia di contattare un tecnico specializzato.


La gestione delle risorse è affidata a personale tecnico, per il momento basti sapere che le risorse sono particolari archivi in cui vengono memorizzati dati di configurazione del programma, ad esempio le risorse contengono i tracciati stampa, le liste di scelte, le voci di menù ed altri dati ancora.
Questo menù inoltre permette di visualizzare le informazioni sull'ultimo errore segnalato dal sistema, questo dato è utile in caso di segnalazioni al servizio tecnico.

Esistono diversi tipi di risorse: le risorse di sistema contengono informazioni predefinite del programma, le risorse utente contengono dati di configurazione di carattere generale o modifiche alle risorse di sistema, le risorse di archivio contengono dati relativi ad ogni singolo archivio utilizzato, le risorse di stazione contengono la memoria delle posizioni delle finestre e le risorse di database contengono la lista degli archivi apribili.


Questa voce di menù permette di uscire dal programma, richiamare questa voce è l'unico sistema per uscire in modo corretto. Si può uscire solo quando non ci sono altre finestre aperte, se ce ne sono il programma chiede se si desidera forzarne la chiusura, è preferibile rispondere "No" e chiudere manualmente tutte le finestre prima di chiudere.


Il menù dati permette di gestire gli archivi e le tabelle utilizzati dal programma.

Archivi contiene gli archivi anagrafici principali del programma
Tabelle contiene archivi di configurazione di utilizzo meno frequente
Liste di scelte permette di gestire alcune particolari tabelle di dati
Altri archivi contiene archivi che vengono utilizzati dal programma e di cui normalmente non viene effettuata la manutenzione diretta.


Nel menù degli archivi vengono memorizzati i principali archivi anagrafici gestiti dal programma, questi archivi vengono gestiti frequentemente per inserire nuovi dati e per estrapolare dati ed eseguire varie stampe.

Clienti contiene le anagrafiche dei clienti e permette di accedere a varie procedure legate ai clienti..
Fornitori contiene le anagrafiche dei fornitori
Piano dei Conti contiene la lista dei conti utilizzati dalla contabilità
Articoli contiene la lista dei prodotti utilizzati dal magazzino
Listini Articoli permette di organizzare i prezzi dei prodotti.
Agenti contiene le anagrafiche degli agenti che realizzano le vendite


Questo archivio contiene le informazioni anagrafiche dei Clienti della ditta.

I dati da inserire sono:

Codice | E' il codice univoco che individua il cliente, viene proposto automaticamente dal programma.
Mastro e Conto | Questo campo stabilisce il legame tra i Clienti ed il Piano dei conti, premendo pulsante collegato si apre la lista di scelte
Ragione sociale | Inserire il nome del cliente.
Via e num. civico
CAP
Città
Provincia
 Inserire l'indirizzo del cliente. Se è disponibile l'archivio dei comuni italiani, inserendo il CAP automaticamente vengono aggiornati il campo Città ed il campo Provincia con quelli corrispondenti al CAP inserito, inoltre a fianco del campo CAP viene visualizzato un pulsante collegato che apre la lista dei comuni da cui scegliere.
Persona fisica | In passato per le persone fisiche era necessario inserire Cognome e Nome per produrre un documento richiesto, ora questo dato non è più obbligatorio.
Prefisso Partita IVA CEE | E' il prefisso nazionale per la partita IVA, viene proposto automaticamente "IT" per Italia, premendo pulsante collegato si apre la lista di scelte
Partita IVA | Si inserisce la partita IVA del cliente, il programma è in grado di riconoscere se la partita IVA è corretta ed in caso di errore emette una segnalazione.
Codice Fiscale | Si può inserire il codice fiscale del cliente. Se il cliente è una persona fisica viene controllata la correttezza del codice inserito ed in caso di errore emette una segnalazione. Inoltre se è disponibile l'archivio dei comuni italiani, viene visualizzato un pulsante collegato che apre una finestra in cui si può calcolare il codice fiscale conoscendo data e luogo di nascita.
Codice esenzione IVA | Normalmente in fattura viene applicata l'aliquota IVA propria del tipo di prodotto venduto, alcuni clienti possono essere esentati dal pagamento dell'IVA per vari motivi, in questo campo si inserisce il codice di esenzione IVA proprio del cliente, se il cliente non ha esenzioni si lascia il campo vuoto. Premendo il pulsante collegato si apre la lista dei Codici IVA.
Dichiarazione d'intento | Gli esportatori abituali sono esentati dal pagamento dell'IVA ma devono inviare ai loro fornitori una dichiarazione che deve essere riportata nelle fatture, in fattura elettronica devono essere riportati gli estremi di protocollo della richiesta inviata alla Agenzia delle entrate.
Testo | Si può inserire il testo della dichiarazione d'intento che si desidera riportare nella fattura di cortesia.
Codice modalità pagamento | Inserire la modalità di pagamento abituale del cliente, questo dato viene proposto automaticamente nell'inserimento dei documenti di magazzino e nella primanota. Premendo il pulsante collegato si apre la lista delle Modalità di Pagamento.
Mese escluso pagamenti 1, 2 e giorno pagamento mese successivo | Questi campi vengono utilizzati per la generazione delle scadenze. Si possono inserire fino a due mesi esclusi dal pagamento (tipicamente agosto e dicembre) ed inserire il giorno del mese successivo su cui vengono spostate le scadenze.
Codice banca di appoggio | Inserire la banca d'appoggio del cliente, questo dato viene usato nella gestione delle ricevute bancarie. Premendo il pulsante collegato si apre la lista delle Banche.
Escludi spese di incasso | Se si spunta questa casella, le spese bancarie non verranno applicate in fattura anche se la modalità di pagamento le prevede.
Raggruppamento scadenze | Durante la generazione della distinta bancaria per la presentazione delle RI.BA. se ci sono più scadenze alla stessa data per lo stesso cliente ed il cliente ha abilitata questa opzione, viene eseguito il raggruppamento delle scadenze in un unica scadenza in modo di diminuire i costi bancari.
Telefoni/Contatti | Premendo questo pulsante si apre una lista in cui si posono inserire numeri di telefono, di fax, indirizzi e-mail e web di questo cliente, questa lista è accessibile anche esternamente dai comandi speciali.
Dati commerciali Premendo questo pulsante si apre una finestra in cui inserire dati commerciali del cliente.
Codice agente | Inserire il codice dell'agente che abitualmente effettua le vendite a questo cliente. Premendo il pulsante collegato si apre la lista degli Agenti.
Codice listino | Inserire il codice di listino abitualmente usato per questo cliente. Premendo il pulsante collegato si apre la lista dei Listini.
Gruppo sconto / categoria Questo campo serve per raggruppare i clienti in categorie economiche. Ai clienti dello stesso gruppo possono essere applicate uguali condizioni di sconto per maggiori dettagli vedere l'archivio della scontistica. Premendo il pulsante collegato si apre la lista di scelte, questo campo viene anche usato per la gestione dei centri di ricavo delle fatture di vendita per indicare il centro di ricavo a cui appartiene un gruppo di clienti, si inserisce nella descrizione della lista di scelte dei gruppi il segno due punti ":" seguito dal codice del centro di ricavo.
Nelle preferenze di contabilità o di magazzino è possibile definire il codice gruppo che corrisponde ai "Contatti" cioé ai clienti che non hanno mai acquistato ma a cui abbiamo fatto preventivi e che forse acquisteranno in seguito, ed il gruppo che corrisponde ai clienti "Non Operativi" cioé quelli che hanno acquistato in passato ma che ora non acquistano più per vari motivi. Assegnando questi codici ai clienti, è possibile escludere i clienti che non ci interessano dalle ricerche o dalle liste.
Codice zona | I clienti possono essere divisi in zone per fini statistici e per fare selezioni. Premendo il pulsante collegato si apre la lista di scelte
Codice tipo di attività | Si possono catalogare i clienti in base al tipo di attività che praticano. Questo dato viene usato solo per motivi statistici e per fare selezioni. Premendo il pulsante collegato si apre la lista di scelte
Codice libero | È un campo disponibile per inserire codifiche personali.
Codice spedizioniere | Inserire il codice del vettore che abitualmente esegue il trasporto della merce. Premendo il pulsante collegato si apre la lista dei Vettori.
Spedizione | Indicare se la spedizione della merce viene effettuata abitualmente a mezzo del mittente, del destinatario o del vettore. Premendo il pulsante collegato si apre la lista di scelte
Raggruppamento bolle | Indica il tipo di raggruppamento che viene effettuato durante la fatturazione automatica dei DDT. inserendo 'S' i DDT vengono raggruppati in un unica fattura, inserendo 'N' non si esegue il raggruppamento, inserendo 'P' i DDT vengono riepilogati generando una sola riga per gli stessi articoli con lo stesso prezzo, inserendo 'B' viene fatta una sola riga extramagazzino per ogni Codice IVA diverso di ogni DDT. Premendo il pulsante collegato si apre la lista di scelte.
Fido concesso Inserire in questo campo il limite di fido concesso al cliente, se si inserisce zero viene preso il limite abituale presente nel file di configurazione AGC.INI, il valore -1 significa fido illimitato. Questo valore viene usato per la stampa ed il controllo dei fidi e richiede la presenta dei moduli di contabilità e magazzino.
Oltre a questo fido, è possibile configurare un campo di fido aggiuntivo nel file ACG.INI, questo serve per esempio se il fido primario corrisponde a quello concesso da compagnie di assicurazione e noi per alcuni clienti ci assumiano un rischio aggiuntivo
Blocco fatturazione | Questo campo serve per bloccare le vendite ai clienti. Quando si inserisce un documento di magazzino per un cliente bloccato viene fatta una segnalazione di blocco.
Modalità di pagamento alternativa | Si può inserire una modalità di pagamento che viene attivata in fattura al superamento di un determinato importo. Premendo il pulsante collegato si apre la lista delle Modalità di pagamento..
Importo minimo per pagamento alternativo | Inserire l'importo oltre il quale viene attivata la modalità di pagamento alternativa.
Modalità di pagamento per importi minimi | Si può inserire una modalità di pagamento che viene applicata se non viene superato un importo minimo fissato. Premendo il pulsante collegato si apre la lista delle Modalità di pagamento..
Importo soglia per minimo fatturabile | Inserire l'importo al di sotto del quale viene attivata la modalità di pagamento per importi minimi.
Recapiti | Premendo questo pulsante si apre una lista in cui si posono inserire altri recapiti della ditta oltre all'indirizzo principale, come ad esempio sedi operative, commerciali o altro, questi dati vengono utilizzati durante la stampa dei Documenti di magazzino per determinare l'indirizzo di intestazione. Si possono anche inserire gli indirizzi di intestazioni precedenti che possono essere cambiati in seguito a trasferimento di indirizzo o altro, in questo caso si inserisce la data di cambio di instestazione e nella stampa dei documenti viene inserita l'intestazione esatta in base alla data.
Altri codici e dati Premendo questo pulsante si apre una finestra in cui si possono inserire dati e codici aggiuntivi.
Codice libero | E un codice che può essere usato liberamente dall'utente, questo campo è indicizzato, quindi può essere utile per ordinare i clienti secondo criteri diversi. Nel caso di utilizzo della procedura per i prodotti fitosanitari, questo campo viene utilizzato per inserire il numero del patentino e la data di rilascio dei soggetti autorizzati all'uso di prodotti fitosanitari.
Campo libero 1, 2, 3 | Si possono inserire fino a 3 testi utilizzabili liberamente dall'utente per memorizzare informazioni di vario tipo, alle volte vengono utilizzati per fare personalizzazioni.
Numero utente 1, 2, 3 | Si possono inserire fino a 3 numeri utilizzabili liberamente dall'utente per memorizzare informazioni di vario tipo, alle volte vengono utilizzati per fare personalizzazioni.
Data di nascita | Per le persone fisiche si può inserire la data di nascita. Questo è utile per il calcolo del codice fiscale e per alcuni dati richiesti dalle amministrazioni pubbliche
Luogo di nascita | Per le persone fisiche si può inserire il luogo di nascita. Questo è utile per il calcolo del codice fiscale e per alcuni dati richiesti dalle amministrazioni pubbliche
Provincia di nascita | Per le persone fisiche si può inserire il luogo di nascita. Questo è utile per il calcolo del codice fiscale e per alcuni dati richiesti dalle amministrazioni pubbliche
Stato estero | Se il cliente è un cliente estero, si può inserire il codice dello stato di appartenenza utilizzando il sistema di codifica adottato per il modello Unico per la dichiarazione dei redditi. Questo dato viene richiesto dalle amministrazioni pubbliche in alcuni casi. Deve essere inserito solo se il cliente è rilevante per le comunicazioni alla P.A.
Banca bonifici bancari | Alle volte i clienti hanno preferenze riguardo alla banca presso cui fare i bonifici dei pagamenti, in questo campo si può inserire il codice della della banca e quindi in fase di fatturazione o registrazione delle fatture, viene utilizzata questa al posto di quella prevista nelle preferenze di contabilità o di magazzino. Ovviamente è necessario che la su cui il cliente richiede di fare il bonifico sia anche una banca su cui abbiamo un conto corrente.
Dati fatturazione Premendo questo pulsante si apre una finestra in cui si possono inserire i dati per l'invio automatico delle fatture e per la fattura elettronica.
E-Mail per invio automatico pdf fatture | In questa posizione si può inserire l'indirizzo e-mail per l'invio automatico delle fatture di cortesia e degli altri documenti in formato PDF.
PEC per fattura elettronica | Per la fatturazione elettronca tra privati, se il cliente è accreditato presso il sistema di interscambio SDI, inserendo il codice, la fattura viene recapitata in modo corretto, altrimenti per fare in modo che il cliente la riceva, è necessario inserire la PEC del cliente, se non si conosce la PEC, la fattura viene inoltrata nel indirizzo di spedizione delle fatture in formato PDF, però se possibile è preferibile inserire la PEC.
Codice SDI | Inserire il codice per la fatturazione elettronica. Nel caso di clienti appartenenti alla Pubblica Amministrazione si inserisce il codice unico reperibile sul indice delle PA. In caso di fatturazione tra privati, si inserisce il codice attribuito al cliente dal canale di interscambio SDI, oppure si lascia in bianco se questo dato non è disponibile. Se i inserisce esplicitamente il valore '0000000', le fatture vengono inviate normalmente ma si segnala a Zefiro che il cliente è esentato, ad esempio perché è forfettario o soggetto al regime dei minimi, e quindi le fatture emesse saranno documenti ufficiali e non documenti di cortesia. Infine se il cliente dichiara che non serve alcun codice, si può scrivere 'NO' in modo da sapere che il codice non è richiesto e la sua assenza non è una omissione.
Bolli virtuali | Mettendo questa spunta si indica al programma che le fatture emesse per questo cliente sono assoggettate a bollo, e ne verrà proposto l'addebito indipendentemente dalla modalità di pagamento scelta. Se l'importo della fattura è inferiore al minimo previsto per legge che al momento è di Euro 77,47, i Bolli non vengono mai applicati.
Split Payment | Lo Split Payment è un regime fiscale particolare a cui sono assoggettati i clienti che sono Pubbliche Amministrazioni o società private di proprietà di pubbliche amministrazioni. In questa posizione va indicato se il cliente rientra in questi parametri.
Registro IVA Split Payment | In Zefiro è possibile configurare il registro IVA sezionale utilizzato per lo Split Payment e quindi di solito questo campo può essere lasciato in bianco. Ma se per qualsiasi motivo si ha necessità di avere più di un registro di Split Payment, se ne possono aggiungere nella configurazione della fattura elettronica e poi in questa posizione si può inserire il sezionale scelto per questo cliente.
Data inserimento | Questo campo contiene la data di inserimento del cliente oppure dell'ultima modifica ai dati anagrafici. E' utile per fini statistici e per i trasferimenti di dati.
Promemoria | In questo memo si può inserire una nota che verrà automaticamente visualizzata quando si inserisce questo cliente nei documenti di magazzino o in primanota.
Note generali | In questo memo si può inserire una descrizione libera.

Le Stampe disponibili sono:
Lista clienti | Stampa una semplice lista di clienti.
Riferimenti fattura elettronica | Questa stampa è utile prima di preparare le fatture elettroniche e serve ad evitare di omettere il codice SDI oppure la PEC nelle fatture preparate. Si può inserire il periodo di tempo da considerare ed il programma legge le fatture, le note d'accredito ed i DDT del periodo ed include nella stampa solo i clienti interessati.
Etichette clienti | Questa procedura permette di stampare su fogli con etichette da attaccare alle buste per spedire circolari o altro. Il tracciato proposto contiene 2 etichette per riga dell'altezza di 4,8cm e della larghezza di 10,5cm che è un formato che si può trovare facilmente nelle cartolerie che vendono fogli di etichette per computer.
Lista promemoria | Con questa stampa è possibile elencare tutti i clienti che hanno un promemoria.
Lista preferiti | Con questa stampa si ottiene la lista di tutti gli articoli preferiti che ha ciascun cliente. Si possono stampare soli i clienti che hanno articoli preferiti, oppure tutti oppure infine solo quelli che non hanno preferiti. Si può decidere di fare il salto pagina alla fine di ogni cliente.
Etichetta colli | Si può fare una semplice stampa di etichette da applicare a colli da spedire.
Lista saldi | Viene stampata la lista dei saldi dei clienti, si può scegliere di stampare tutti i clienti solo quelli movimentati, quelli con saldo diverso da zero o infine solo quelli il cui saldo ha superato il fido concesso. È anche possibile limitare la stampa ad un determinato periodo i tempo.
Fatturato | Questa stampa esegue la lista dei clienti con esposizione del fatturato effettuato, Si possono ordinare e raggruppare i dati secondo vari criteri, si possono scegliere i limiti di data ed anche di raggruppare i clienti con fatturato al di sotto di una determinata soglia. Durante il calcolo vengono suddivisi gli imponibili per anno fiscale, così se si richiedono limiti di data superiori ad un anno si può scegliere il tracciato di stampa con la suddivisione per anno. Si possono suddividere fino ad un massimo di 5 anni. I dati calcolati possono anche essere esportati in vari formati.
Situazione fidi | Questa procedura stampa per ogni cliente la situazione del fido ed evidenzia anche il totale degli ordini non evasi. Si possono stampare solo i clienti che superano il fido, oppure si può decidere di visualizzare tutti coloro che hanno una esposizione superiore ad il valore indicato o infine quelli che hanno una disponibilità inferiore a quella indicata. Se è stata configurata la gestione di extrafido, nella stampa viene presentato il fido totale con fra parentesi l'extrafido commerciale concesso.
Scheda movimenti | Viene stampata la lista dei movimenti di magazzino del cliente. Se è attivo lo storico, viene chiesto se si desidera stampare tutti i dati oppure solo quelli correnti o solo quelli storici.
Scheda documenti | Questa stampa è simile alla precedente, ma permette di stampare tutti i dati di magazzino, non solo quelli dei documenti che effettuano carico e scarico. Anche in questo caso è presente la gestione dei documenti storici.
Lista depositi/cauzioni | Questa stampa viene proposta solo se è stato abilitato il modulo di gestione cauzioni e permette di sapere quali clienti hanno in deposito mostri materiali, il deposito può essere soggetto a cauzione oppure no come nel caso di comodati e noleggi, la stampa può essere analitica o sintetica, la stampa analitica elenca tutte le operazioni di carico e scarico dalla data iniziale in poi, la stampa sintetica evidenzia solo i totali di movimentazione. Si può indicare la data iniziale del calcolo in modo da esaminare la movimentazione di un determinato periodo, il saldo precedente viene evidenziato in un campo di riporto.
Scheda depositi/cauzioni | Questa stampa è ugaule alla precedente, con la differenze che stampa solo la scheda del cliente corrente.

I Comandi speciali disponibili sono:
Telefoni/Contatti | Si apre una lista in cui è possibile inserire numeri di telefono, fax, indirizzi e-mail ed indirizzi web.
Recapiti | Si apre una lista in cui è possibile inserire indirizzi aggiuntivi a quello principale, ad esempio sedi operative, commerciali o altro, questi dati vengono utilizzati durante la stampa dei Documenti di magazzino per determinare l'indirizzo di intestazione.
Liste di contatti Spesso capita di avere necessità di inviare comunicazioni alla clientela, come ad esempio per cambiamenti di ragione sociale o banca d'appoggio. Questa procedura può assolvere a questo compito in due modi differenti:

Invia circolare email: Questa procedura presenta la lista di tutti i clienti selezionati oppure spuntati, e per ciascuno si può scegliere se inviare la mail oppure no. Si può anche scegliere a che indirizzo inviare la mail tra quelli presenti per questa anagrafica, e si possono anche scegliere fino a ulteriori 4 indirizzi aggiuntivi di spedizione.
Per evitare problemi di spam, si può decidere di inviare solo una parte delle mail e rimandare il resto della spedizione in un momento futuro. Per sapere quali sono le regole di anti-spam si deve consultare il proprio provider di invio posta. Alcuni ad esempio pongono limitazioni nel numero di messaggi che si possono inviare in un ora, oppure in un giorno.
Alla fine si possono inviare le mails. Nel momento della spedizione si può inserire il messaggio da inviare e premendo un pulsante si possono inserire i campi variabili specifici per ogni cliente, ad esempio la ragione sociale, o il nome della persona. Si possono anche scegliere gli allegati da spedire e si può decidere di inserire una pausa tra le spedizioni. Questo serve perché alcuni provider utilizzano un sistema di cache che potrebbe andare in conflitto con spedizioni troppo veloci.

Prepara lista: Questa procedura, in alternativa alla precedente, generata una lista comoda da usare per l'invio di mail con programmi esterni, o anche per preparare rubriche telefoniche. Vengono inviati i dati di tutti i clienti selezionati oppure spuntati.
I dati vengono preparati in formato CSV o se disponibili in MS Excel o LibreOffice. In fase di generazione si può scegliere i tipi di contatto da esportare ed anche quali dati inserire nella lista.
Per l'invio delle e-mail, consigliamo di usare il programma Mozilla Thunderbird che ha un plugin di nome "Mail Merge" che è perfetto per fare questo genere di cose.
Tipo documento In questa posizione è possibile inserire una lista che serve a configurare il comportamento dei tipi di documento per questo cliente.
  • Si possono inserire i tracciati di stampa preferenziali per questo cliente per ciascun tipo di documento di magazzino che vengono utilizzati al posto di quelli previsti dal tipo di documento.
  • Si può inserire li codice di un "Tracciato memo" che permette di inserire automaticamente un testo fisso alla fine del documento. Il testo del "Tracciato memo" va inserito nelle risorse utente (per maggiori dettagli chiedere al personale tecnico).
Promemoria | Se questo cliente ha un promemoria, viene visualizzato.
Ricalcola codici IVA documenti del cliente | Questa procedura viene usata quando il cliente cambia codice di esenzione ed applica la nuova alquota agli ordini in corso non ancora evasi. Si possono anche rettificare in modo retroattivo le fatture ed i DDT emessi che eventualmente sono stati generati in modo errato. Se le fatture sono già state contabilizzate, è necessario modificare la parte contabile a mano e rigenerare le scadenze.
Selezione tipo cliente Questa voce di menù permette di selezionare automaticamente i tipi di clienti secondo le categorie inserite nelle preferenze di contabilità o di magazzino si possono escludere dalla visualizzazione i "Contatti" e "Non Operativi", oppure solo in "Non Operativi" o infine visualizzare tutti i clienti.
Durante l'inserimento di codici cliente dalle procedure di contabilità o di magazzino, vengono automaticamente esclusi (filtrati) i clienti definiti "Contatti" e "Non Operativi".
Invio a sito FTP Questa voce è presente solo se è stata configurata correttamente la gestione dell'invio di documenti a sito FTP.
Se il cliente è tra quelli abilitati, permette di inviare tutti i documenti compresi nel periodo indicato al sito FTP.
Spunta clienti | Viene attivata la spunta dei clienti.
Dati aggiuntivi comunicazione trimestrale | Questa voce viene usata raramente solo nei casi particolari in cui si debbano aggiungere dati anagrafici per la comunicazione trimestrale delle fatture.
Scheda contabile | Si apre la gestione delle schede contabili con il codice del cliente preimpostato.
Scheda partite | Si apre la gestione delle schede partite con il codice del cliente preimpostato.
Controllo Saldo contabile / Scadenze | Controlla che il saldo contabile dei clienti corrisponda con il totale delle scadenze.
Controllo fido cliente | Permette di vedere la situazione del fido del cliente corrente.
Documenti di magazzino | Si aprono i Documenti di magazzino del cliente.
Lista preferiti Questa opzione permette di inserire la lista degli articoli preferiti del cliente. La gestione è del tutto simile alla gestione prezzi attivabile dai listini e dagli articoli. In fase di calcolo di un prezzo, il prezzo preferito dei clienti ha la precedenza sul prezzo di listino.
Da questa posizione è anche possibile fare variazioni automatiche di prezzi utilizzando la stessa procedura disponibile per gli articoli.
Scontistica cliente | Si apre una finestra che permette di inserire la scontistica per questo cliente.
Apri cartella documenti cliente | Ogni cliente può disporre di una propria cartella per memorizzare documenti di qualsiasi natura. Questo comando apre la cartella che l'utente può utilizzare come preferisce. La localizzazione delle cartelle può essere configurata nel file AGC.INI
Documenti | Con questa voce si accede alla archiviazione documentale che permette di legare specifici documenti elettronici a questo cliente.
Cronologico contatti Questa voce disponibile solo se è stato attivato il modulo CRM contiene le seguenti voci:
Cronologico | Permette di accedere ai movimenti di cronologico dei clienti.
Genera lista | Questa procedura assolutamente simile alla stessa presente nei movimenti di cronologico permette di generare liste di clienti.
Selezioni cronologico | Questo comando ha una duplice funzione, da un lato permette di selezionare i movimenti di cronologico da visualizzare, e questo è utile per concentrare la propria attenzione solo sui movimenti che interessano, e dall'altra parte consente di selezionare i clienti che hanno o non hanno movimenti del tipo selezionato. Questo è utile ad esempio per trovare tutti i clienti che non sono stati visitati negli ultimi 12 mesi. Il comando è disponibile anche nelle selezioni standard del cliente tra le "selezioni speciali", ma è stato portato fuori per renderlo più facilmente accessibile.
Importa cliente | Questa procedura è disponibile se Zefiro è abbinato a InfoBox e permette di importare i contatti disponibili in quel programma e farli diventare clienti di Zefiro.
Visualizza cronologico | Questa opzione permette di visualizzare o nascondere automaticamente alcune righe dei contatti intercorsi con questo cliente.

Gestione fidi

Se si dispone dei moduli di contabilità e magazzino, è disponibile una funzione di gestione dei fidi dei clienti. Questa procedura funzionerà correttamente solo se le situazioni contabili dei clienti e gli effetti da incassare sono aggiornati.

La procedura agisce in vari punti del programma:

  • Nei clienti per il singolo cliente si può chiedere la situazione comprensiva di ordini inevasi
  • Nei clienti si può chiedere la stampa della lista delle situazioni con la possibilità di inserire alcuni parametri: Si può scegliere di stampare solo quelli che hanno superato il fido, si possono escludere dalla stampa quelli che hanno una esposizione inferiore ad un valore minimo inserito, infine si possono escludere quelli che hanno una disponibilità residua maggiore al valore inserito.
  • Nei documenti se è stato attivato il controllo automatico, all'inserimento di un documento dei clienti viene contollato i fido ed in caso di sforamento viene presentata la situazione.
  • Nelle righe dei documenti di magazzino è possibile interrogare la situazione del fido per evitare sforamenti
  • Alla fine dell'inserimento di un nuovo documento di magazzino viene controllato se il documento corrente porta allo sforamento del fido.

La procedura può essere configurata con il file AGC.INI che permette di inserire il limite di fido predefinito per tutti i clienti, l'abilitazione del controllo automatico nei documenti ed infile se si desidera impedire l'inserimento di documenti che sforano il fido.

Nei clienti è possibile inserire l'importo del fido, se si lascia zero viene usato l'importo predefinito, se si inserisce -1 significa fido illimitato.

Il calcolo della esposizione avviene leggendo il saldo contabile del cliente a cui va sommato il valore delle riba emesse ma non ancora incassate ed anche il valore (IVA inclusa) dei DDT emessi e non ancora fatturati.
Nella stampa della lista dei fidi viene anche evidenziato il valore degli ordini non ancora evasi che non sono realmente una esposizione, ma sono comunque un dato indicativo.

Se è stato attivato il controllo automatico dei fidi nei documenti di magazzino, si può scegliere se si desidera offrire la possibilità all'utente di forzare il blocco, oppure se vietare l'inserimento fino alla rimozione della esposizione.


Questo archivio contiene le informazioni anagrafiche sui Fornitori della ditta.

I dati da inserire sono:

. Questo campo viene utilizzato per alcune procedure fiscali come ad esempio lo spesometro, ed il prefisso diverso da 'IT' indica le importazioni che di norma sono escluse. Un caso particolare si applica a schede carburante ed altre spese minime come i pranzi, in questi casi inserendo il carattere asterisco '*' si indica che si tratta di un fornitore di raggruppamento che nello spesometro viene indicato senza partita IVA e codice fiscale ma con la spunta su 'Documento riepilogato'.
Codice E' il codice univoco che individua il fornitore, viene proposto automaticamente dal programma.
Mastro e Conto | Questo campo stabilisce il legame tra i Fornitori ed il Piano dei conti, premendo il pulsante collegato si apre la lista di scelte
Ragione sociale | Inserire il nome del fornitore.
Via e num. civico
 CAP
 Città
 Provincia 		Inserire l'indirizzo del fornitore. Se è disponibile l'archivio dei comuni italiani, inserendo il CAP automaticamente vengono aggiornati il campo Città ed il campo Provincia con quelli corrispondenti al CAP inserito, inoltre a fianco del campo CAP viene visualizzato un pulsante collegato che apre la lista dei comuni da cui scegliere.
Prefisso Partita IVA CEE | E' il prefisso nazionale per la partita IVA, viene proposto automaticamente "IT" per Italia, premendo pulsante collegato si apre la lista di scelte.
Partita IVA | Si inserisce la partita IVA del fornitore, il programma è in grado ri riconoscere se la partita IVA è corretta ed in caso di errore emette una segnalazione.
Codice Fiscale | Si può inserire il codice fiscale del fornitore. Se il fornitore è una persona fisica viene controllata la correttezza del codice inserito ed in caso di errore emette una segnalazione. Inoltre se è disponibile l'archivio dei comuni italiani, viene visualizzato un pulsante collegato che apre una finestra in cui si può calcolare il codice fiscale conoscendo data e luogo di nascita.
Codice modalità pagamento | Inserire la modalità di pagamento abituale del fornitore, questo dato viene proposto automaticamente nella primanota. Premendo il pulsante collegato si apre la lista delle Modalità di Pagamento.
Contropartita contabile | Questo campo serve per automatizzare la scelta del sottoconto da utilizzare durante l'inserimento delle registrazioni di primanota. Premendo il pulsante collegato si apre la lista del Piano dei Conti.
Banca di presentazione | Inserire la banca in cui il fornitore ci appoggia gli effetti, questo dato viene usato per effettuare la stampa dell'impegno bancario. Premendo il pulsante collegato si apre la lista delle Banche.
IBAN bonifici bancari | E' il codice IBAN da utilizzare per fare bonifici al fornitore. In precedenza erano disponibili anche i campi "Banca per bonifici" e "Conto corrente per bonifici" che però ora sono obsoleti perché sono già presenti nel codice IBAN.
Codice presso fornitore | Inserire in questo campo il codice che il fornitore usa per identificarci.
Categorie merceologiche | Si possono scegliere le categorie merceologiche trattate dal fornitore, questo serve per fare selezioni di fornitori in base a questo parametro, sono disponibili scelte multiple.
E-Mail per invio documenti | In questa posizione si può inserire l'indirizzo e-mail per l'invio automatico dei documenti. Se si inserisce questo dato sarà molto agevole e rapido mandare documenti in PDF tramite e-mail.
Telefoni/Contatti | Premendo questo pulsante si apre una lista in cui si posono inserire numeri di telefono, di fax, indirizzi e-mail e web di questo fornitore, questa lista è accessibile anche esternamente dai comandi speciali.
Recapiti | Premendo questo pulsante si apre una lista in cui si posono inserire altri recapiti della ditta oltre all'indirizzo principale, come ad esempio sedi operative, commerciali o altro, questi dati vengono utilizzati durante la stampa dei Documenti di magazzino per determinare l'indirizzo di intestazione.
Ritenuta Premendo questo pulsante si apre una finestra in cui si possono inserire di retenuta d'acconto per i fornitori che ne sono soggetti.
Fornitore soggetto a ritenuta d'acconto | Questo campo serve ad indicare se il fornitore è soggetto a ritenuta d'acconto, in tal caso durante le registrazioni di primanota viene attivata la gestione automatica delle ritenute d'acconto.
Percentuale Ritenuta | Campo utilizzato per la gestione delle ritenute d'acconto, inserire la percentuale di ritenuta.
Percentuale non soggetta a ritenuta | Campo utilizzato per la gestione delle ritenute d'acconto. Per alcuni soggetti a ritenuta è possibile pagare solo una parte della ritenuta.
Codice tipo versamento ritenuta | Campo utilizzato per la gestione delle ritenute d'acconto, è il codice da utilizzare per il versamento delle ritenute. Premendo il pulsante collegato si apre la lista di scelte
Data di Nascita | Campo utilizzato per la gestione delle ritenute d'acconto inserire la data di nascita del professionista. Viene anche utilizzato per alcune comunicazioni alla Agenzia delle Entrate.
Luogo di nascita | Campo utilizzato per la gestione delle ritenute d'acconto, inserire il luogo di nascita del professionista. Viene anche utilizzato per alcune comunicazioni alla Agenzia delle Entrate.
Provincia | Questo dato viene utilizzato per alcune comunicazioni alla Agenzia delle Entrate.
Stato estero | Se il fornitore è un fornitore estero, si può inserire il codice dello stato di appartenenza utilizzando il sistema di codifica adottato per il modello Unico per la dichiarazione dei redditi. Questo dato viene richiesto dalle amministrazioni pubbliche in alcuni casi e deve essere inserito solo se rilevante ai fini delle comunicazioni.
Data inserimento/modifica | Questo campo contiene la data di inserimento del fornitore oppure dell'ultima modifica ai dati anagrafici. E' utile per fini statistici e per i trasferimenti di dati.
Promemoria | In questo memo si può inserire una nota che verrà automaticamente visualizzata quando si inserisce questo fornitore nei documenti di magazzino o in primanota.
Note generali | In questo memo si può inserire una descrizione libera.

Le Stampe disponibili sono:
Lista fornitori | Stampa una semplice lista di fornitori.
Etichette fornitori | Questa procedura permette di stampare su fogli con etichette da attaccare alle buste per spedire circolari o altro. Il tracciato proposto contiene 2 etichette per riga dell'altezza di 4,8cm e della larghezza di 10,5cm che è un formato che si può trovare facilmente nelle cartolerie che vendono fogli di etichette per computer.
Lista promemoria | Con questa stampa è possibile elencare tutti i fornitori che hanno un promemoria.
Etichetta colli | Si può fare una semplice stampa di etichette da applicare a colli da spedire.
Lista saldi | Viene stampata la lista dei saldi dei fornitori, si può scegliere di stampare tutti i fornitori solo quelli movimentati, quelli con saldo diverso da zero.
Fatturato | Questa stampa esegue la lista dei fornitori con esposizione del fatturato effettuato, Si possono ordinare e raggruppare i dati secondo vari criteri, si possono scegliere i limiti di data ed anche di raggruppare i fornitori con fatturato al di sotto di una determinata soglia.
Scheda movimenti | Viene stampata la lista dei movimenti di magazzino del fornitore. Se è attivo lo storico, viene chiesto se si desidera stampare tutti i dati oppure solo quelli correnti o solo quelli storici.
Scheda documenti | Questa stampa è simile alla precedente, ma permette di stampare tutti i dati di magazzino, non solo quelli dei documenti che effettuano carico e scarico. Anche in questo caso è presente la gestione dei documenti storici.

I Comandi speciali disponibili sono:
Telefoni/Contatti | Si apre una lista in cui è possibile inserire numeri di telefono, fax, indirizzi e-mail ed indirizzi web.
Recapiti | Si apre una lista in cui è possibile inserire indirizzi aggiuntivi a quello principale, ad esempio sedi operative, commerciali o altro, questi dati vengono utilizzati durante la stampa dei di magazzino per determinare l'indirizzo di intestazione. Si possono anche inserire gli indirizzi di intestazioni precedenti che possono essere cambiati in seguito a trasferimento di indirizzo o altro, in questo caso si inserisce la data di cambio di intestazione e nella stampa dei documenti viene inserita l'intestazione esatta in base alla data.
Liste di contatti Spesso capita di avere necessità di inviare comunicazioni ai fornitori, come ad esempio per cambiamenti di ragione sociale o banca d'appoggio. Questa procedura può assolvere a questo compito in due modi differenti:

Invia circolare email: Questa procedura presenta la lista di tutti i fornitori selezionati oppure spuntati, e per ciascuno si può scegliere se inviare la mail oppure no. Si può anche scegliere a che indirizzo inviare la mail tra quelli presenti per questa anagrafica, e si possono anche scegliere fino a ulteriori 4 indirizzi aggiuntivi di spedizione.
Per evitare problemi di spam, si può decidere di inviare solo una parte delle mail e rimandare il resto della spedizione in un momento futuro. Per sapere quali sono le regole di anti-spam si deve consultare il proprio provider di invio posta. Alcuni ad esempio pongono limitazioni nel numero di messaggi che si possono inviare in un ora, oppure in un giorno.
Alla fine si possono inviare le mails. Nel momento della spedizione si può inserire il messaggio da inviare e premendo un pulsante si possono inserire i campi variabili specifici per ogni cliente, ad esempio la ragione sociale, o il nome della persona. Si possono anche scegliere gli allegati da spedire e si può decidere di inserire una pausa tra le spedizioni. Questo serve perché alcuni provider utilizzano un sistema di cache che potrebbe andare in conflitto con spedizioni troppo veloci.

Prepara lista: Questa procedura, in alternativa alla precedente, generata una lista comoda da usare per l'invio di mail con programmi esterni, o anche per preparare rubriche telefoniche. Vengono inviati i dati di tutti i clienti selezionati oppure spuntati.
I dati vengono preparati in formato CSV o se disponibili in MS Excel o LibreOffice. In fase di generazione si può scegliere i tipi di contatto da esportare ed anche quali dati inserire nella lista.
Per l'invio delle e-mail, consigliamo di usare il programma Mozilla Thunderbird che ha un plugin di nome "Mail Merge" che è perfetto per fare questo genere di cose.
Tipo documento In questa posizione è possibile inserire una lista che serve a configurare il comportamento dei tipi di documento per questo fornitore.
  • Si possono inserire i tracciati di stampa preferenziali per questo fornitore per ciascun tipo di documento di magazzino che vengono utilizzati al posto di quelli previsti dal tipo di documento.
  • Si può inserire li codice di un "Tracciato memo" che permette di inserire automaticamente un testo fisso alla fine del documento. Il testo del "Tracciato memo" va inserito nelle risorse utente (per maggiori dettagli chiedere al personale tecnico).
Promemoria | Se questo fornitore ha un promemoria, viene visualizzato.
Invio a sito FTP Questa voce è presente solo se è stata configurata correttamente la gestione dell'invio di documenti a sito FTP.
Se il fornitore è tra quelli abilitati, permette di inviare tutti i documenti compresi nel periodo indicato al sito FTP.
Spunta fornitori | Viene attivata la spunta dei fornitori.
Dati aggiuntivi comunicazione trimestrale | Questa voce viene usata raramente solo nei casi particolari in cui si debbano aggiungere dati anagrafici per la comunicazione trimestrale delle fatture.
Scheda contabile | Si apre la gestione delle schede contabili con il codice del fornitore preimpostato.
Scheda partite | Si apre la gestione delle schede partite con il codice del fornitore preimpostato.
Controllo Saldo contabile / Scadenze | Controlla che il saldo contabile dei fornitori corrisponda con il totale delle scadenze.
Documenti di magazzino | Si aprono i Documenti di magazzino del fornitore.
Apri cartella documenti fornitori | Ogni fornitore può disporre di una propria cartella per memorizzare documenti di qualsiasi natura. Questo comando apre la cartella che l'utente può utilizzare come preferisce. La localizzazione delle cartelle può essere configurata nel file AGC.INI
Documenti | Con questa voce si accede alla archiviazione documentale che permette di legare specifici documenti elettronici a questo fornitore.
Cronologico contatti Questa voce disponibile solo se è stato attivato il modulo CRM contiene le seguenti voci:
Cronologico | Permette di accedere ai movimenti di cronologico dei fornitori.
Genera lista | Questa procedura assolutamente simile alla stessa presente nei movimenti di cronologico permette di generare liste di fornitori.
Selezioni cronologico | Questo comando corrisponde all'analogo comando presente nei Clienti e permette di selezionare i movimenti di cronologico da visualizzare e di filtrare i fornitori in base a quella selezione.
Importa fornitore | Questa procedura è disponibile se Zefiro è abbinato a InfoBox e permette di importare i contatti disponibili in quel programma e farli diventare fornitori di Zefiro.
Visualizza cronologico | Questa opzione permette di visualizzare o nascondere automaticamente alcune righe dei contatti intercorsi con questo fornitore.


Il programma Zefiro viene fornito con il Piano dei Conti già inserito e compatibile con le causali. Naturalmente l'utente ha la possibilità di inserire il proprio piano dei conti personalizzato, ma in questo caso è costretto a modificare anche le causali e gli altri automatismi presenti nel programma. Nel piano dei conti si devono inserire solo i conti di contabilità generale, i Clienti ed i Fornitori vanno inseriti con le procedure specifiche. Il Piano dei conti è a 3 livelli ed i codici sono una sequenza di 10 caratteri numerici in cui le prime 2 cifre rappresentano il Mastro, le seconde 2 rappresentano il Conto e le rimanenti 6 rappresentano il sottoconto. Nel codice non ci possono essere spazi bianchi perciò la procedura li riempie automaticamente con zeri non significativi.

Per un corretto funzionamento della procedura, si devono inserire il Mastro ed i Conti dei Clienti e dei Fornitori, la codifica deve essere equivalente a quella presente nell'apposito campo di Clienti e di Fornitori. Il codice completo è composto da Mastro, Conto ed il codice del Cliente o Fornitore.

Nelle varie posizioni del programma in cui viene richiesto l'inserimento di un sottoconto, sono disponibili alcune facilitazioni che rendono più agevole e veloce la digitazione. Infatti è possibile dividere Mastro, Conto e Sottoconto da punti, ad esempio de devo inserire il codice "0101000001" si può inserire semplicemente "1.1.1" e la macchina automaticamente esegue la conversione. Inoltre se viene inserito un codice errato o non coerente, si apre automaticamente la lista dei sottoconti da cui scegliere. E' sempre disponibile il pulsante collegato che permette di scegliere il sottoconto dalla lista. Per accedere ai Clienti basta scrivere "C" e premere il pulsante, per accedere ai Fornitori basta scrivere "F" e premere il pulsante. Infine in base al contesto è possibile che sia obbligatorio inserire Clienti/Fornitori o Sottoconti, in questo caso la macchina impedisce l'introduzione di codici non coerenti.

I dati da inserire sono:

Codice | E' il codice del conto. Per inserire il Conto è necessario che sia già presente in archivio il corrispondente Mastro, ad esempio per inserire il Conto "0101000000" bisogna che sia già presente il mastro "0100000000", allo stesso modo non si può inserire un Sottoconto se non è presente il corrispondente Conto, ad esempio per inserire "0101000001" deve essere presente "0101000000".
Descrizione | E' la descrizione del Mastro/Conto/Sottoconto.
Tipo sottoconto | E' il tipo di conto, si può scegliere tra A=Attività, P=Passività, C=Costi, R=Ricavi O=Conti d'ordine. Il Tipo di un sottoconto deve essere uguale a quello dei corrispondenti Conto e Mastro questo e necessario per una corretta gestione dei bilanci e delle chiusure e riaperture di bilancio. Premendo il pulsante collegato si apre la lista di scelte
Tipo costo IVA | Nella dichiarazione IVA annuale tra le molte cose viene chiesta la suddivisione degli acquisti in base al tipo, i valori ammessi sono: M=merci, B=beni strumentali ed S=altre spese. In questa posizione si inserisce il tipo predefinito per ciascun sottoconto che viene proposto in fase di inserimento della primanota. Poi durante la stampa del bilancio, si può richiedere il raggruppamento per questo parametro ed i risultati possono essere inseriti nella dichiarazione IVA. Naturalmente questo parametro è rilevante solo per i sottoconti di costo.
Centro di costo/ricavo predefinito | In fase di inserimento della primanota, si può scegliere di riclassificare le scritture in base a propri criteri che vengono definiti Centri di Costo e Ricavo. In questa posizione si può inserire il valore predefinito per ciascun conto. Questo dato è rilevante solo per i conti economici di costo e ricavo.
Percentuale ammortamento cespite | Inserendo un valore diverso da zero, si indica che il sottoconto abilita la procedura di gestione automatica cespiti (vedi Primanota e Cespiti).
Sottoconto fondo ammortamento | Inserire il codice del sottoconto che viene utilizzato come fondo di ammortamento per i cespiti. Il programma non esegue nessun controllo sulla correttezza del dato inserito, quindi è bene verificare che il codice sia corretto.
Sottoconto ammortamento | Inserire il codice del sottoconto che viene utilizzato per gli ammortamenti. Il programma non esegue nessun controllo sulla correttezza del dato inserito, quindi è bene verificare che il codice sia corretto.
Quota intera 1^ anno | Di norma il primo anno la quota di ammortamento viene calcolata forfettariamente al 50%, mettendo questa spunta il primo anno viene comunque calcolata il 100% della quota perché questo è previsto per alcuni tipi di cespiti.
Descrizione alternativa bilancio | Questo campo ha il solo scopo di cambiare la descrizione che compare nel bilancio quando il segno del saldo è diverso da quello previsto dal tipo di conto. Ad esempio se il conto "DEBITI VERSO ERARIO" è stato messo tra le Passività e quando si stampa il bilancio il saldo è in dare invece che in avere, nella stampa del bilancio viene inserita la descrizione che si trova in questo campo che in questo caso potrebbe essere "CREDITI VERSO ERARIO".

I comandi speciali disponibili sono:

Duplica conto | Con questo comando si duplica il conto attualemente selezionato. è utile per inserire conti simili.
Prepara riclassificazione | Questo comando è disponibile solo se è stato attivato il modulo di riclassificazione di bilancio e permette di preparare un file di configurazione vuoto che sarà necessario integrare con la riclassificazione per garantirne il funzionamento.


Nell'archivio Articoli, vengono memorizzati i dati anagrafici dei prodotti che vengono commercializzati ed anche dei prodotti utilizzati internamente per la produzione o per altri motivi. E' bene che l'inserimento dell'archivio dei prodotti sia attentamente pianificato, prima di inserire gli articoli si consiglia di identificare in modo chiaro ed esteso le Categorie di Articoli, e di studiare un sistema di codifica adatto ad ordinare i prodotti in modo efficiente, inoltre è bene stabilire quali Listini utilizzare e le strategie di scontistica clienti.

Per velocizzare al massimo l'introduzione degli articoli, l'inserimento di nuovi dati viene preceduto dalla scelta della Categoria, in questo modo, molti dati richiesti, vengono proposto in modo automatico, inoltre viene chiesta la descrizione del prodotto ed è presente un pulsante che permette di copiare la descrizione dell'articolo corrente, questo permette di velocizzare l'inserimento di descrizioni simili.

E' interessante notare che quando si esegue la cancellazione di un articolo di magazzino, vengono modificate tutte le righe dei documenti di magazzino che lo contengono, da riga Articolo vengono trasformate in riga Extramagazzino e la descrizione dell'articolo viene inserita con descrizione della riga.

I dati richiesti sono:

Codice | Il codice è alfanumerico di 16 caratteri, nelle Preferenze. Se la categoria utilizzata prevede il calcolo automatico del codice, viene inserito un codice coerente con la configurazione della generazione automatica dei codici presente nelle preferenze. Il codice può essere calcolato anche premendo il pulsante collegato. Questo dato è inseribile solo durante l'inserimento di nuovi articoli, per cambiare codici già inseriti si utilizza una apposita procedura che cambia anche i riferimenti al codice in tutto il programma.
Descrizione | E' la descrizione che compare nei listini e nei documenti.
Categoria | Gli articoli normalmente vengono raggruppati in categorie. Premendo il pulsante collegato si apre la lista delle Categorie di Articoli.
Costo ultimo acquisto | Questo campo viene aggiornato automaticamente ogni volta che viene acquistato il prodotto con il costo al netto di sconti, oltre al costo netto vengono memorizzati anche il costo ultimo lordo e gli sconti. Premendo il pulsante collegato, è possibile modificare il costo lordo e gli sconti.
Aggiornamento automatico costo | Con questa opzione è possibile indicare se il costo può essere aggiornato automaticamente dalla gestione documenti quando si inserisce un documento di carico o se invece deve essere gestito manualmente. Normalmente si attiva l'aggiornamento automatico, ma in alcuni casi particolare si può desiderare che questo dato venga gestito manualmente.
Costo standard | In questa posizione si può inserire il costo abituale del prodotto. Se presente, in fase di inserimento dei documenti di carico viene proposto al posto del costo ultimo. La gestione è manuale e viene usato quando si desidera evitare l'automatismo di gestione dei prezzi di costo ultimo. Premendo il pulsante collegato, è possibile modificare il costo lordo e gli sconti.
Copia costo | Questo pulsante copia il costo ultimo nel costo standard per fissare i prezzi di costo.
Codice alternativo(barcode) | In questo campo si può inserire un codice alternativo per l'articolo. Nelle preferenze si può scegliere se si desidera utilizzare questo campo per la ricerca degli articoli, in tal caso prima di cercare il codice naturale viene effettuata la ricerca su questo codice. Si deve tener conto che su questo campo non viene effettuato alcun controllo, quindi si rischia di inserire codici alternativi doppi, oppure codici alternativi uguali a codici naturali di articoli diversi, in questi casi le ricerche potrebbero dare risultati errati. Tipicamente si può utilizzare questo codice per inserire il barcode dei prodotti, oppure si può utilizzare per realizzare ordinamenti alternativi. Il codice può essere calcolato anche premendo il pulsante collegato.
Unità di misura | E' l'unità di misura in cui vengono espresse le quantità.
Unità di misura alternativa | Alle volte alcuni prodotti vengono acquistati in una unità di misura alternativa rispetto a quella di vendita, ad esempio si acquistano bobine a chilo e si vende a metro lineare, in questo campo si inserisce l'unità di misura utilizzata per l'acquisto.
Rapporto conversione unità di misura | Se è stata indicata una unità di misura alternativa, in questo campo si indica il rapporto di conversione presente tra le due. Il tipo di calcolo che viene eseguito dipende da un parametro di configurazione (in AGC.INI), di norma il rapporto di conversione viene diviso per la quantità alternativa, ad esempio se si acquista a dozzine e si vende a pezzi nel rapporto di conversione si inserisce 12. In alternativa si può fare in modo che il programma divida la quantità alternativa per il rapporto di conversione, ad esempio se si acquistano bobine a chilo e si vende a metro, bisogna indicare quanto pesa un metro di materiale. Quindi ML = KG / Peso. Questo dato viene utilizzato dalla procedura Documenti di magazzino per facilitare l'inserimento nei documenti di acquisto.
Codice IVA | E' il codice IVA abituale del prodotto, viene proposto automaticamente quello della categoria di appartenenza. Premendo il pulsante collegato si apre la lista dei Codici IVA.
Gruppo sconto/provvigioni | Il gruppo di sconto/provvigioni serve a determinare la percentuale di sconto da praticare ai clienti e di provvigione da accordare agli agenti. Sugli articoli appartenenti allo stesso gruppo vengono applicate uguali condizioni di sconto per maggiori dettagli vedere l'archivio della scontistica. Premendo il pulsante collegato si apre la lista di scelte.
Tipo movimentazione | Questo dato serve a determinare in che modo questo articolo verrà movimentato nelle operazioni di carico e scarico. Il comportamento normale è quello che i documenti di carico e scarico movimentano le quantità di prodotto. Se il prodotto viene definito "Servizio", significa che viene fatto il carico e scarico per motivi di gestione interna, però l'articolo viene escluso da alcune stampe ed in particolare nella stampa dell'inventario si usa solitamente per l'addebito di manodopera, oppure spese di trasporto. Infine se l'articolo è classificato come "Non movimenta", esso diventerà ininfluente ai fini del carico e scarico, si usa se si desidera mantenere una descrizione senza influenzare le operazioni di magazzino. Premendo il pulsante collegato si apre la lista di scelte.
Fornitore abituale | Inserire il codice del fornitore abituale di questo prodotto, questo campo viene utilizzato in alcune stampe statistiche. Premendo il pulsante collegato si apre la lista dei Fornitori.
Codice presso fornitore | Si può inserire il codice utilizzato dal fornitore abituale oppure il codice della marca del prodotto. Questo dato ad esempio può essere utilizzato nella stampa degli ordini a fornitore
Cliente di riferimento | Alcune volte, alcuni articoli vengono acquistati da un solo cliente, in questa posizione è possibile inserire il codice del cliente che acquista questo articolo. In fase di inserimento dei documenti di magazzino, si può configurare il programma in modo che durante la ricerca degli articoli vengano presentati solo gli articoli del cliente del documento, la procedura è comunque più sofisticata, si possono gestire gruppi di clienti con codici uguali o anche clienti con accesso a tutti gli articoli. In ogni caso gli articoli possono essere forzati inserendo direttamente il codice corretto. Premendo il pulsante collegato si apre la lista dei Clienti.
Data Inserimento | Questo campo contiene la data di inserimento dell'articolo e viene proposta automaticamente quando si inserisce un nuovo articolo. E' utile per fini statistici e per i trasferimenti di dati.
Data modifica | Indica la data in cui l'articolo è stato movimentato l'ultima volta e viene aggiornato automaticamente dai movimenti di magazzino. E' utile a fini statistici e per tenere sotto controllo gli articoli poco utilizzati.
Note | In questo memo si può inserire una descrizione libera che in alcune configurazioni di documenti, può comparire nelle stampe.
Promemoria | In questo memo si può inserire descrizione che viene visualizzata come promemoria quando si utilizza l'articolo nei documenti di magazzino. Si usa ad esempio per avvisare l'utente della presenza di condizioni particolari di utilizzo. Oltre a questa modalità Zefiro dispone di un meccanismo di avviso standard applicabile a gruppi di articoli e configurabile nel campo MBART del file AGC.INI
Numero utente 1-8 e Campo utente 1-4 | Spesso la natura diversa dei prodotti trattabili con il programma di magazzino richiede che l'utente inserisca dati anagrafici particolari tipici del prodotto, per questo scopo si possono utilizzare fino a 20 campi numerici e 6 campi alfabetici liberi. La descrizione dei campi può essere configurata nelle preferenze. A esempio si potrebbe utilizzare questi campi per inserire la scorta minima, oppure il codice articolo per la gestione del deposito cauzionale di recipienti, o anche per indicare il peso di un oggetto o il materiale impiegato.
Altri campi | Se è necessario utilizzare più degli 8 campi numerici liberi o più dei 4 campi alfabetici disponibili nella pagina principale dell'articolo, si può premere questo pulsante che apre una finestra che permette di inserire anche quelli non presenti in prima pagina. In questa pagina sono presenti anche dati usati più raramente come ad esempio il codice Intrastat che viene utilizzato per fare la stampa del prospetto delle cessioni Intrastat.

Alla fine dell'inserimento o modifica di articoli viene proposta una finestra per inserimento dei prezzi di listino.

Si possono inserire fino ad un massimo di 8 prezzi per rispettivi listini diversi, la scelta dei listini da utilizzare può essere effettuata con un'apposita procedura. I dai da inserire per ciascuna riga sono:

Prezzo | Inserire il prezzo per questo listino. Premendo il pulsante collegato, viene calcolato il prezzo applicando una ricarica al prezzo di acquisto, viene proposta la ricarica abituale per quel listino, i prezzo viene calcolato nel modo seguente: se l'articolo costa 100,00 e la ricarica è del 50,00%, il prezzo calcolato sarà 150,00 ma se il listino prevede lo scorporo viene aggiunta l'IVA così se lo stesso articolo ha l'aliquota IVA del 20% ed il listino prevede lo scorporo il prezzo sarà 180,00. Se il prezzo è zero significa che per questo listino non viene gestito il prezzo di questo articolo, ma non significa che non ha prezzo, infatti se il listino prevede un listino padre, il prezzo viene preso da quello. Per maggiori dettagli vedere l'archivio Listini.
Sconti | E' una casella di spunta che abilita l'introduzione degli sconti a livello di listino, se si inseriscono conti in questa posizione, vengono ignorati gli sconti di scontistica ed applicati sempre questi.
Forza prezzo zero | Abitualmente quando non si inserisce un prezzo per un certo listino, questo indica che viene preso il prezzo del listino padre, ma alle volte può essere desiderabile per un listino che li prezzo sia effettivamente zero e non il prezzo del listino padre, con questa casella di spunta si forza il prezzo a zero.
Sconto 1 - 3 | Questi campi sono visibili quando è abilitata la casella di spunta sconti, si inseriscono gli sconti fissi.

Nei prezzi modificati viene anche memorizzata la data in cui viene modificato il prezzo, questa data viene visualizzata nella stampa del listino, oppure durante la gestione dei prezzi con il comando da "Vedi archivio prezzi", la data corrente viene visualizzata nella barra del titolo, per modificarla si può premere l'apposito pulsante.

Le Stampedisponibili sono:

Lista articoli | Viene effettuata una lista semplice degli articoli. In questa stampa è possibile chiedere si si desidera il dettagli dei codice di Fornitori e Clienti, dei prezzi di listino e preferiti, e se è attivata la gestione della distinta base anche dei dettagli di distinta base e di distinte di appartenenza.
Stampa listino Questa procedura stampa il listino prezzi degli articoli.
Si può scegliere di stampare il listino di un cliente specifico, oppure un determinato listino per un gruppo di clienti, se si sceglie la stampa per singolo cliente e si lascia vuoto il codice cliente, prima di stampare viene chiesto di spuntare la lista dei clienti di cui si vuole stampare il listino, in questo modo si possono fare liste cumulative. Se agli articoli sono collegati le immagini, si può anche effettuare la stampa del listino con immagini, in questo caso si può scegliere il numero di colonne (da 1 a 4) e se stampare solo gli articoli con immagini collegate. Se per un articolo sono disponibili più immagini, viene stampata solo la prima immagine.
La stampa può essere ordinata per categoria di articoli o secondo l'ordine corrente, se si sceglie di ordinare per categoria, vengono anche stampate le intestazioni di categoria. Inoltre si può scegliere se escludere dalla stampa gli articoli che non appartengono al listino prescelto ed in questo caso ad esempio si può stampare solo i prezzi speciali di un listino ignorando quelli appartenenti al listino padre. Si può anche scegliere di escludere dalla stampa gli articoli che hanno valore zero per questo listino. Se si utilizza la gestione della conversione di unità di misura, si può scegliere se stampare il prezzo convertito per gli articoli che hanno un valore nel rapporto di conversione. Si può anche scegliere di calcolare la giacenza per gli articoli da stampare. Se è stata scelta la stampa del listino di un cliente, si può scegliere anche di stampare solo gli articoli preferiti del clinte.
Listino semplice Questa procedura stampa un listino semplice con i prezzi dei primi 6 listini selezionati, se l'ordinamento dell'archivio è per categoria, viene stampata l'intestazione di categoria e si può fare anche il salto pagina.
Listino fornitori Con questa stampa si ottiene la lista dei prezzi che i fornitori ci praticano. Vengono chiesti alcuni dati:
Codice fornitore | Inserire il codice del fornitore di cui si desidera stampare il listino.
Ultimi prezzi acquisto | Se c'è la spunta vengono cercati gli ultimi prezzi praticati nei documenti di magazzino.
Prezzi memorizzati | Se c'è la spunta vengono cercati i prezzi memorizzati nei Codici Clienti/Fornitori
Solo articoli valorizzati | Con questa opzione si effettua la stampa solo se ci sono ultimi prezzi di acquisto oppure prezzi memorizzati, altrimenti l'articolo viene escluso dalla stampa.
Solo articoli fornitore abituale | Con questa opzione si richiede la stampa dei soli articoli che hanno il fornitore scelto come fornitore abituale.
Il prezzo che viene presentato nella stampa dipende dai dati che sono presenti. Tra l'ultimo prezzo praticato ed il prezzo memorizzato viene scelgo quello che ha la data più recente, se questi sono assenti viene presentato il prezzo di costo presente in anagrafica articoli.
Lista preferiti | Con questa stampa si ottiene la lista di tutti i prezzi preferiti dei clienti per ciascun articolo. Si possono stampare soli gli aricoli che hanno prezzi preferiti, oppure tutti, oppure infine solo quelli che non hanno preferiti. Si può decidere di fare il salto pagina alla fine di ogni articolo.
Controllo costo ultimo | Questa procedura controlla se il costo ultimo memorizzato negli articoli corrisponde effettivamente con il costo rilevato nel ultimo documento di acquisto inserito. Vengono presentati solo gli articoli con differenze tra il costo del ultimo acquisto ed il costo memorizzato. Se non ci sono acquisti l'articolo non viene considerato. Dalla lista degli articoli trovati è possibile fare la stampa e se si conferma vengono aggiornati tutti i costi.
Lista movimenti | Si può eseguire la stampa della scheda dei movimenti di magazzino dell'articolo. Vengono richiesti alcuni comuni parametri di selezione e quindi viene eseguita la stampa. Se è attivo lo storico, viene chiesto se si desidera stampare tutti i dati oppure solo quelli correnti o solo quelli storici. Si può scegliere di stampare solo l'articolo corrente oppure tutti quelli selezionati o spuntati.
Scheda movimenti | Questa stampa è simile alla lista dei movimenti, ma riporta anche i progressivi di giacenza. I dati di storico non vengono considerati, pertanto è necessario partire da una data non ancora trasmessa a storico.
Riepilogo movimenti | Questa stampa fa gli stessi calcoli della lista movimenti ma presenta solo i totali per tutti gli articoli selezionati senza il dettaglio di tutti i movimenti, si può stampare il riepilogo complessivo, oppure il riepilogo mese per mese ordinato per mesi o per articoli.
Stampa etichette articoli | Questa procedura abbinata alla gestione della vendita al banco esegue la stampa di una etichetta per ogni articolo presente in anagrafica e correntemente selezionato.
Lista barcode | Se i codici degli articoli hanno un formato alfanumerico compatibile con i codici a barre, questa stampa produce una lista che contiene codice a barre e descrrizone articolo.
Stampa inventario | Se si desidera la stampa dell'inventario si può fare direttamente dalla lista degli articoli, in questo modo c'è il vantaggio che si possono filtrare e spuntare a piacere.
Stampa etichette svendita | Questa procedura abbinata alla gestione della vendita al banco esegue la stampa delle etichette da applicare ai prodotti in svendita, in ciascuna etichetta vengono riportati il codice, la descrizione, il prezzo originale lo sconto ed il prezzo di svendita.
Progressivi giacenza | Questa stampa permette di ricostruire le situazioni storiche di giacenza del articolo corrente, il dettaglio può essere giornaliero, settimanale o mensile.
Tabella mensile giacenza | Questa stampa evidenza per ogni articolo la situazione di giacenza per 12 mesi a partire dal mese inserito.

I comandi speciali disponibili sono:

Gestione prezzi Questo comando apre un sottomenù con le seguenti voci:
Ultimi prezzi clienti | Questa procedura apre una finestra in cui sono elencati gli ultimi prezzi praticati ai clienti per questo articolo, la lista comprende tutti i clienti che hanno acquistato almeno una volta questo articolo. I dati così ottenuti possono essere ordinati in base ai vari campi ed anche stampati.
Ultimi prezzi fornitori | Questa procedura è analoga alla precedente con la differenza che vengono elencati i prezzi che ci sono stati praticati dai fornitori.
Variazione automatica listini Questa procedura permette di variare in modo automatico i prezzi dei prodotti correntemente selezionati.

Il tipo di aggiornamento può essere in perceutale, per un importo fisso, oppure applicando la ricarica dal costo memorizzata nel listino, O infine inserendo un importo unico da applicare a tutti i prezzi.
Dopo aver confermato l'elaborazione, si può segliere se si desidera che le modifiche vengano eseguite in modo automatico, oppure se aprire la lista modificabile dei prezzi calcolati o infine se si vuole salvare i dati calcolati per elaborarli in un secondo momento.
Si possono scegliere i listini e le liste prefieriti clienti a cui applicare la variazione. Il valore inserito verrà applicato in percentuale o sommato a valore fisso a seconda del tipo di aggiornamento scelto. Il prezzo può essere diminuto di un determinato importo per generare prezzi "magici" come ad esempio 3,99 o 4,49.
L'opzione di elaborazione differita, permette di salvare le modifiche ai prezzi in un file di testo temporaneo per eventualmente variare manualmente i prezzi con un programma di elaborazione testi tipo il NOTEPAD.EXE ed effettuare l'aggiornamento effettivo ai prezzi in un secondo momento. Il file di testo generato si chiama "VARIALST.TXT" e si trova nella stessa cartella in cui risiede il programma (solitamente C:\CS\AGC). Se sono presenti liste per aggiornamento differito, all'avvio della procedura, viene chiesto se si desidera effettuare l'aggiornamento.
Duplica listino Questa procedura permette di generare automaticamente i prezzi di un listino a partire da un altro listino.

I dati richiesti sono il codice del listino di partenza, il codice del listino di arrivo, il tipo di variazione prezzi che può essere uno sconto oppure una maggiorazione, la percentuale di variazione ed infine la conferma dell'elaborazione.
Le variazioni avvengono solo sugli articoli selezionati e per gli articoli spuntati. Questo consente di eseguire variazioni diversificate per tipo di articoli. Ad esempio se il listino 2 ha i prezzi del listino 1 scontati del 30% escluso che per una categoria in cui lo sconto è del 20%, si può prima generare lo sconto 30% su tutti gli articoli e poi selezionare solo gli articoli a cui applicare il 20% e rilanciare la procedura con il nuovo sconto.
Se un prezzo è presente solo nel listino di destinazione e non nel listino di partenza, viene cancellato il prezzo del listino di destinazione.
Imposta listini attivi | Il programma Zefiro ha la possibilità di gestire un numero molto elevato di listini diversi, durante l'introduzione degli articoli, si inseriscono anche i prezzi di al massimo otto listini contemporaneamente, di norma vengono proposti i primi otto listini, ma con questa procedura si può scegliere i listini che si desidera inserire. Se per esempio si desidera impostare un listino speciale per un determinato cliente, si genera il listino, quindi lo si assegna al cliente ed infine si imposta il listino tra i primi otto con questa procedura e si procede ad inserire i prezzi degli articoli con prezzo speciale.
Ricalcolo costi movimenti Quando vengono registrati documenti di vendita, viene memorizzato nelle righe, il valore dell'ultimo costo di acquisto, in questo modo quando si fanno le statistiche la ricarica viene calcolata sul costo che il prodotto aveva in quel momento. Succede però che per vari motivi a volte il costo delle righe non è corretto, ad esempio perché i documenti di acquisto vengono registrati dopo aver registrato quelli di vendita.
Con questa procedura, vengono trovate le differenze di costo tra acquisti e vendite e viene presentata una lista delle differenze trovate con la possibilità di stampare le schede corrispondenti ed alla fine di riscrivere i dati corretti degli articoli che si decide di correggere mettendo le spunte.
Nel calcolo delle differenze di prezzo si può indicare una tolleranza per evitare di ricalcolare prezzi con differenze dovute ad arrotondamenti.
Calcolo scorta minima Questa procedura serve per facilitare il calcolo della scorta minima da assegnare ad ogni prodotto. Vengono letti i movimenti di vendita di un periodo a scelta e vengono effettuati alcuni calcoli statistici che aiutano per determinare la scorta ottimale per garantire il servizio ai clienti con il miglior impegno di giacenza.
Per il corretto funzionamento è necessario configurare nel file AGC.ini i campi numerici degli articoli utilizzati per: Scorta minima, Scorta di sicurezza, Giorni di approvigionamento, Frequenza di riordino e lotto di riordino.
Quando si lancia la procedura vengono letti i dati di movimentazione, vengono fatti i calcoli statistici e vengono proposti i dati attuali di configurazione, dalla lista è possibile aggiornare i dati ed alla fine si possono salvare le modifiche.
In fondo a questa pagina è presente una descrizione approfondita di questo argomento
Variazione prezzi di costo Questa procedura serve per variare automaticamente il prezzo di costo degli articoli ed è disponibile solo se sono state attivate le spunte.
Normalmente il prezzo di costo viene aggiornato automaticamente quanto si fanno registrazioni di acquisto, ma questa opzione può essere disabilitata per forzare la gestione manuale dei prezzi di costo.
Può accadere che i fornitori ci comunichino variazioni di prezzo ed in questo caso si può utilizzare questa procedura. Conviene fare una selezione sugli articoli interessati, ad esempio solo quelli di una categoria e solo quelli di un determinato fornitore abituale, dopo di che si spuntano i soli articoli interessati (facendo click con il tasto destro sulla colonna delle spunte si possono spuntare tutti gli articoli). Poi si lancia questa procedura che chiede la variazione percentuale sul costo, ad esempio se c'è stato un aumento del 5% si scrive 5 ed in caso di riduzione del 5% si scrive -5. Si può anche variare gli sconti ed in questo caso si può scegliere se applicare la percentuale o applicare il nuovo sconto. Ad esempio se c'era uno sconto del 50% e c'è stata una riduzione dello sconto del 5% si scrive -5 e lo sconto passerà al 45%, oppure si scrive 45% e si toglie la spunta.
Alla fine viene presentata la lista degli articoli con i vecchi prezzi ed i nuovi, si possono fare variazioni individuali ed alla fine si può confermare per applicare i nuovi prezzi.
Archivio prezzi Con questa procedura si possono vedere e modificare i prezzi presenti per questo articolo su tutti i listini e per tutti i clienti e si possono anche fare modifiche. In questa posizione si possono anche inserire i prezzi diversificati in base alle quantità inserite nei documenti.
Se si desidera, si possono anche fare variazioni automatiche di listini come spiegato poco sopra che hanno effetto su tutti i prezzi di questo articolo.
Cerca articolo In alcuni punti del programma è possibile cercare gli articoli oltre che cercando il codice primario anche usando altri codici. In questa posizione si può effettuare la ricerca utilizzando tali criteri.
Dopo aver inserito un codice, prima viene cercato il codice primario, se non viene trovato si cercano criteri particolari personalizzati (ad esempio il codice con un prefisso), poi viene cercato il codice alternativo, poi se stiamo cercano per un cliente o fornitore specifico, viene cercato il codice speciale di quel cliente o fornitore. Infine se ancora non è stato trovato un articolo si cerca in tutti i codici dei clienti o fonritori.
Naturalmente il primo codice trovato nasconde tutti i criteri successivi. Ad esempio se ho un articolo con codice primario "A123" ed ho un articolo "B456" che ha come codice alternativo "A123" che è lo stesso del primo articolo, viene trovato il primo articolo ed il secondo viene nascosto.
Duplica articolo | E' possibile duplicare l'articolo corrente generando un nuovo articolo con tutte le caratteristiche di quello corrente, ma con un nuovo codice.
Cambia codice | Questa procedura permette di cambiare il codice all'articolo quando la codifica adottata in precedenza non dovesse più essere soddisfacente. Il nuovo codice viene applicato a tutti gli archivi che lo utilizzano.
Sposta movimenti | Può accadere di inserire per errore articoli con codici diversi che si riferiscono allo stesso prodotto. Con questa procedura è possibile spostare tutti i movimenti da dall'articolo duplicato all'articolo originale e se si desidera si esegue anche la cancellazione dell'articolo duplicato.
Calcola giacenza | Questa procedura permette di vedere la giacenza dell'articolo, si possono inoltre vedere i dati sugli ordini da clienti e gli ordini a fornitori, inoltre si può vedere il dettaglio per variante per gli articoli che le hanno, infine si può indicare la data limite e si può vedere le giacenze di tutti i depositi.
Lista evasione articolo | Esegue la stampa disponibile con Lista ordini inevasi e Lista conto lavoro inevaso ma limitata a questo singolo articolo.
Gestione lista articoli Questa procedura premette di gestire liste di articoli che possono essere utilizzate per velocizzare alcune procedure di inserimento dati, per ciascun articolo si può inserire la quantità da inserire in lista, se è attiva la gestione delle varianti, prima viene chiesta la combinazione di varianti+opzioni a cui si riferisce la quantità che si sta per inserire. Si possono attivare più liste contemporaneamente, ad esempio un utente può gestire una lista per stampare etichette e contemporaneamente un altro utente può lavorare sulle giacenze inventariali, ed una lista può rimanere aperta per un tempo indefinito, ad esempio si può tenere attiva la lista della gestione delle giacenze inventariali per tutto il tempo necessario a completare l'inventario.

I dati da inserire sono:
Num. lista | Si inserisce il numero di lista su cui si vuole operare, viene proposta la lista che si sta correntemente utilizzando.
Forza quantità zero | Solitamente quando si inserisce la quantità zero la riga di gestione lista viene cancellata, ma in alcuni casi è richiesto l'inserimento forzato della quantità zero, ad esempio quando si inseriscono giacenze inventariali, in questo caso si deve spuntare questa casella.
Quantità | Inserire la quantità di questo articolo nella lista.

Dopo aver completato la lista si possono attivare tre funzioni premendo i relativi pulsanti.
Giacenza | Viene attivata la procedura di inserimento giacenze con il contenuto della lista.
Documento | Viene generato automaticamente un documento con il contenuto della lista.
Ordini fornitori | Permette di scegliere i fornitori a cui ordinare gli articoli presenti nella lista. Si apre una finestra che elenca tutti gli articoli della lista ed i prezzi di costo praticati dai fornitori in base agli ultimi prezzi praticati ed ai prezzi memorizzati nei codici clienti/fornitori, l'utente può quindi scegliere in base al prezzo più basso o ad altri criteri il fornitore a cui ordinare i vari prodotti. Posizionando il cursore su una riga si può generare l'ordine per il fornitore corrispondente.
Etichette | Viene attivata la funzione di stampa etichette con il contenuto della lista.
Prezzi Cliente/Fornitore | Questa opzione permette di inserire il codice utilizzato da clienti o fornitori per questo stesso articolo, si apre la lista dei codici già inseriti in cui è possibile modificare o aggiungere codici. Per ogni codice viene chiesto il tipo di anagrafica, il codice del cliente o fornitore, il codice utilizzato, l'ultimo costo ed il costo lordo con gli sconti, ovviamente l'ultimo costo è rilevante solo nel caso dei fornitori. I dati inseriti in questa posizione escludono le regole di applicazione dei costi nel inserimento dei documenti di magazzino. Ad esempio quando si inserisce un DDT da fornitore se è presente un prezzo in questa posizione viene utilizzato ignorando costo ultimo e costo standard.
Etichette colli | Con questa procedura si possono stampare le etichette da applicare ai colli da spedire, si possono stampare tutte le etichette di un documento, oppure si possono stampare etichette libere per ciascun articolo.
Stampa etichette | Questa voce permette di stampare in modo rapido etichette di un singolo articolo.
Spunta articoli | Con questo comando si apre o si chiude una colonna a sinistra in qui si possono spuntare alcuni degli articoli. Alcuni dei comandi del programma, se è apera la colonna delle spunte agiscono solo sugli articoli spuntati, ad esempio se si desidera stampare una lista o l'inventario solo di alcuni articoli, si spuntano solo gli interessati.
Documenti | Questa voce è disponibile solo se è stato attivato il modulo CRM e permette di accedere alla archiviazione documentale che serve a legare specifici documenti elettronici a questo articolo.
Documento articolo | Questa voce è visibile solo se è stata attivata la gestione dei documenti collegati agli articoli nel file AGC.INI. In questo caso, se è stato scritto il nome del file nel campo configurato, si può aprire o stampare il documento.
Presenza web e-commerce | Questa voce è presente solo se è stato installato il modulo per la gestione del commercio elettronico e permette di indicare il tipo di prodotto a cui appartiene nel programma di e-commerce. Se si inserisce zero, l'articolo non viene esportato.
Articolo cauzione | Questa procedura è disponibile sono se è stato abilitato il modulo di gestione depositi cauzionali, e permette di inserire il codice dell'articolo di cauzione legato a questo articolo di vendita.
Selezione tipo articolo | Nelle preferenze di magazzino è possibile indicare il codice del gruppo di articoli che vengono considerati esauriti ed obsoleti. Quando si entra nella gestione degli articoli, dalla lista vengono esclusi automaticamente quelle che appartengono a questi gruppi, con questa voce si possono attivare o disattivare.
Articoli cumulativi Questa voce è disponibile solo se è stata esplicitamente attivata con l'apposta voce nel file di configurazione AGC.INI (per maggiori dettagli consultare un tecnico). Presenta un sotto-menu con le seguenti voci:
Cancellazione articoli esauriti | Permette di cancellare gli articoli che risultano esauriti ad una determinata data. Questo è utile per le attività che hanno una forte rotazione di prodotti. Se si desidera si può forzare l'eliminazione anche dei prodotti che risultano a giacenza negativa. In ogni caso vengono cancellati solo gli articoli presenti nella selezione corrente. Dopo aver confermato, viene presentato il numero di articoli trovati che soddisfano le caratteristiche e viene chiesta un ulteriore conferma prima di eseguire la definitiva cancellazione degli articoli.
Cancellazione cumulativa | Permette di cancellare automaticamente una serie di articoli di magazzino. Si deve scegliere il codice iniziale ed il codice finale, e poi si deve confermare l'elaborazione. In ogni caso vengono cancellati solo gli articoli presenti nella selezione corrente. Dopo aver confermato, viene presentato il numero di articoli trovati che soddisfano le caratteristiche e viene chiesta un ulteriore conferma prima di eseguire la definitiva cancellazione degli articoli.
Ripristino articolo cancellato | Può accadere a volte di cancellare inavvertitamente un articolo di magazzino. Quando si fa questo Zefiro trasforma tutte le righe dei documenti da riga articolo a riga extra-magazzino, se si reinserisce l'articolo le righe trasformate rimangono di tipo extra-magazzino. Con questa procedura è possibile recuperare le righe che nella descrizione contengono la descrizione esatta presente nel articolo e trasformarle nuovamente in riga articolo. Questa voce è disponibile solo se è stata esplicitamente attivata con l'apposta voce nel file di configurazione AGC.INI.
Cambia prefisso codici | Permette di cambiare automaticamente il codice ad un gruppo di articoli. Accade spesso che nella codifica degli articoli si utilizzi un prefisso che fa riferimento ad uno stesso fornitore oppure ad una stessa categoria e può succedere che si desideri cambiare il prefisso per svariati motivi, questa procedura rende possibile questa operazione. Si deve scegliere il vecchio prefisso e quello nuovo. In ogni caso vengono cambiati solo gli articoli presenti nella selezione corrente. Dopo aver confermato, viene presentato il numero di articoli trovati che soddisfano le caratteristiche e viene chiesta un ulteriore conferma prima di eseguire la definitiva modifica dei codici degli articoli.
Visualizza prezzi/immagine Quando si abilita questa opzione nella parte destra della lista degli articoli compare un pannello nel quale vengono visualizzati i prezzi dei listini correnti dell'articolo corrente, inoltre se è stata abilitata la gestione delle immagini viene anche visualizzata l'immagine dell'articolo, infine possono essere visualizzate altre informazioni come ad esempio la gestione delle liste o altro.
Facendo doppio click su uno dei prezzi, si va direttamente alla gestione prezzi, facendo doppio click sull'immagine si apre una finestra che visualizza meglio l'immagine e permette di visualizzare altre immagini eventualmente inserite per questo articolo.
Per abilitare la gestione delle immagini, si deve inserire la directory delle immagini nelle preferenze di magazzino.
Per effettuare l'abbinamento tra articolo ed immagine in modo corretto si deve inserire l'immagine nella directory indicata con il nome di file uguale al codice dell'articolo o per inserire più di un immagine con il nome che inizia con il codice dell'articolo seguito dal carattere di sottolineatura "_" ed un progressivo numerico diverso per ogni immagine. I formati di immagine riconosciuti sono "BMP", "JPG" e "EMF".
Per la gestione ottimale delle immagini, si consiglia di valutare attentamente la dimensione ed il tipo di immagine da inserire, infatti immagini troppo grandi spesso non sono più utili di quelle di medie dimensioni ed hanno lo svantaggio di occupare molto più spazio su disco e di essere più ingombranti nelle operazioni di copia. E' preferibile inserire immagini con un rapporto di 4/3 tra larghezza ed altezza, ad esempio 320x240 o 640x480 o 800x600 perché questo formato viene stampato meglio con la procedura di stampa listino.
Si deve anche tener presente che la cancellazione di articoli o il cambiamento di codice non comportano l'automatica cancellazione e/o modifica del nome delle immagini ad essi collegati, quindi in caso di cancellazione o modifica codice si deve provvedere a risolvere il collegamento perso delle immagini.
Componi kit di prodotti Questa voce è disponibile solo se non è stato abilitato il modulo di Distinta Base.
Con questa voce si possono comporre gruppi di prodotti che possono essere inseriti automaticamente e contemporaneamente nella gestione dei documenti di magazzino.
Distinta base Questa voce e le seguenti sono disponibili solo se è stato abilitato il modulo di Distinta Base.
Con questa voce si inseriscono i dati della distinta base appartenente al articolo corrente. Per maggiori dettagli vedere l'archivio della Distinta base.
In questa posizione è presente il comando per copiare una riga della distinta che poi puo essere usata per incollare o cancellare le righe con gli stessi codici su tutti gli articoli spuntati con la procedura "Incolla/cancella riga distinta"
Stampa distinta | Questa stampa è disponibile solo se è stato abilitato il modulo di distinta base. Si può effettuare la stampa della distinta esplodendo tutti i livelli di distinta, oppure stampare solo il primo livello, viene chiesto inoltre se si desidera stampare le note delle righe di distinta (se presenti), infine viene chiesto se di desidera stampare solo la distinta dell'articolo corrente o di tutti gli articoli con distinta.
Ricalcola costo | Questa procedura permette di ricalcolare il costo di tutti gli articoli che hanno una distinta in base al costo ultimo di tutti i componenti della distinta.
Distinte di appartenenza | Questa procedura elenca tutte le voci di distinta di cui questo articolo è membro, è utile per sapere a quali distinte appartiene questo articolo.
Copia distinta | Questa procedura serve per effettuare la duplicazione veloce di una distinta da un articolo ad un altro, e viene utilizzata quando alcuni articoli hanno distinte simili. Ci si posiziona sull'articolo con la distinta da copiare e si chiama questa voce.
Incolla distinta | Questa voce viene visualizzata solo se è già stata copiata una distinta, in questo caso ci si posiziona sull'articolo che dovrà ricevere la distinta copiata e si chiama questa voce.
Incolla/cancella riga distinta Questa voce viene visualizzata solo se sono state attivate le spunte e se è stata copiata una riga in una distinta modificata in precedenza con la voce "Distinta base" e permette di fare copie e cancellazioni massive di rige della distinta.
Si possono fare tre tipi di operazioni:
Copia se non c'è aggiunge al tutte le distinte degli articoli spuntati la riga della distinta se non c'è già una riga con lo stesso articolo.
Copia ed aggiorna se nelle distinte degli articoli spuntati non trova la riga la aggiunge altrimenti la sostituisce con quella copiata.
Cancella Cancella dalle distinte le righe cono lo stesso codice.
Dopo aver letto tutti gli articoli spuntati, viene presentata la lista di quelli che soddisfano i parametri e si può togliere le spunte a quelli che si desidera lasciare senza modifiche.
Lista matricole | Questa voce è presente solo se è stato attivato il modulo di gestione matricole e cerca tutte le matricole che sono state utilizzate per questo articolo. viene presentata una lista che indica il numero di matricola, il numero e la data del ultimo documento che ha usato questa matricola ed il numero di docuemnti che lo utilizzano. È possibile fare la stampa con la lista delle matricole anche con il dettaglio di tutti gli utilizzi.
Cerca matricola | Questa voce è presente solo se è stato attivato il modulo di gestione matricole e permette di cercare a quale articolo appartiene il codice di matricola che si inserisce.

Calcolo della scorta minima

La scorta minima da assegnare agli articoli è un argomento che si presta ad interpretazioni diverse, ed i criteri da applicare dipendono dalla tipologia di prodotto e da scelte aziendali. Ad esempio alcuni tipi di prodotto sono soggetti a stagionalità e pertanto in periodi diversi dell'anno la scorta minima potrebbe essere diversa.
Zefiro non gestisce la stagionalità, perciò i dati di scorta vanno riferiti al periodo di massimo fabbisogno.

Il meccanismo per funzionare richiede ce venga configurata nel file AGC.ini la variabile ARTSCORTA nella quale devono essere indicati i numeri dei campi liberi usati per:

  • Scorta minima
  • Scorta di sicurezza
  • Giorni di approvigionamento
  • Frequenza di riordino
  • Lotto di acquisto

Quando viene richiamata la procedura, vengono letti i movimenti del periodo di calcolo prescielto e sulla base di questo vengono fatti alcuni calcoli statistici che vengono presentati in una lista in modo da facilitare la valutazione.
Dalla lista dei dati calcolati è possibile inserire i dati per ciascun articolo ed alla fine se si conferma vengono scritti i dati di ciascun articolo.

La procedura utilizza alcuni concetti di statistica classica per facilitare il compito di decidere i dati di scorta. Per approfondimenti consultare i concetti di statistica reperibili anche su Wikipedia.

La Media si calcola divedendo la quantità per il numero di rilevazioni.
La Varianza chiamata anche "Scarto quadratico medio" è un indice che identifia gli scostamenti rispetto alla media delle singole rilevazioni. Se ogni volta che si effettua una vendita le quantità vendute sono più o meno simili, la varianza è bassa, invece se le quantità variano molto, la varianza è alta.
La Deviazione standard è la media della varianza sulle rilevazioni ed indica la deviazione media di ogni rilevazione rispetto al campione.
Zefiro effettua questi calcoli rispetto ai giorni totali di rilevamente e rispetto ai giorni in qui sono state fatte effettivamente delle vendite.

I dati calcolati sono i seguenti:

  • Giorni di calcolo: sono i giorni totali che passano dalla data di inizo calcolo alla data di fine calcolo. Si considerano approssimativamente solo i gorni lavorativi considerando 5 giorni alla settimana.
  • Numero di vendite: è il numero di giorni in qui sono state effettivamente fatte vendite.
  • Quantità venduta: è la quantità totale venduta nel periodo.
  • Media del periodo: è la media delle vendite prendendo in considerazione i giorni compresi tra la data di inizio e fine calcolo
  • Media di vendita: viene calcolata la media dei soli giorni in cui sono state fatte vendite.
  • DS su periodo: Viene calcolata la deviazione standard sul periodo calcolato.
  • DS su vendite: Viene calcolata la deviazione standard considerando solo i giorni in cui sono state fatte vendite.

Per aiutare a decidere i dati di scorta minima e scorta di sicurezza, si deve considerare il livello di rotazione degli articoli. Se abbiamo un elevato livello di rotazione e quindi ci sono articoli che vendiamo tutti i giorni a diversi clienti, le formule proposte sono efficaci, invece se la rotazione è bassa l'efficacia diminuisce perché ogni evento è in grado di falsare le statistiche.

La fornula proposta è la seguente:

Scorta minima operativa
((consumo medio giornaliero) + (Deviazione standard)) * ((gg approvigionamento) + (frequenza riordino))

Scorta di sicurezza
((consumo medio giornaliero) + (Deviazione standard)) * (3 giorni)

I numeri proposti dalla procedura fornisconi indicazioni utili per decidere come applicare le formule, ed in ogni caso forniscono indicazioni utili di valutazione.

Nota:
Ci sono alcune considerazioni utili per facilitare l'operatività della procedura.
La procedura opera sugli articoli selezionati, quindi se si desidera effettuare i calcoli solo su alcune categorie, si possono scegliere i dati da esaminare facendo le opportune selezioni.
Se attiviano le spunte degli articoli inoltre, il calcolo verrà effettuato solo sugli articoli spuntati.

Nota:
Per facilitare le operazioni di immissione dati, è stata realizzata l'integrazione con i fogli di calcolo.
Una volta effettuato il calcolo è possibile esportare i dati ad un foglio Excel o LibreOffice premendo il pulsante di esportazione sulla barra dei pulsanti.
Poi si può usare il foglio di calcolo per fare tutte le considerazioni ed eventualmente applicare formule di calcolo. Alla fine si può copiare le righe che interessano dal foglio di calcolo alla lista calcolata con la proceudra, ma è importante che nella prima riga copiata, ci siano i nomi dei campi uguali a quelli esportati.


In questo archivio si definiscono i listini che poi verranno utilizzati dagli Articoli per inserire i prezzi e dai Documenti di Magazzino per applicare i prezzi in base al listino utilizzato. Il programma Zefiro permette di gestire un numero molto grande di listini prezzi, e con la gestione dei listini padre e della scontistica, si possono realizzare strategie di gestione prezzi anche molto sofisticate.

La gestione dei prezzi però è ancora più sofisticata, infatti si possono avere prezzi speciali per ciascun articolo su ciascun cliente.

I dati da inserire sono:

Codice | E' il codice numerico che identifica il listino
Descrizione | Inserire una breve descrizione del listino.
Codice Valuta | E' il codice della valuta che viene utilizzata per esprimere i prezzi di questo listino. Durante l'inserimento di documenti di magazzino, scegliendo il listino viene automaticamente proposta la valuta ed il tasso di cambio con Euro. Inserire un codice solo se si desidera utilizzare una valuta diversa da Euro, se non si inserisce alcun codice, i prezzi vengono espressi in Euro. Premendo il pulsante collegato si apre la lista delle Valute Estere.
Scorporo | Serve per specificare se i prezzi di questo listino sono comprensivi di IVA oppure no, se sono comprensivi di IVA, nel calcolo dei totali dei documenti di magazzino viene effettuato lo scorporo della parte IVA.
Applica sconti | Durante l'inserimento dei prezzi negli articoli, viene chiesto se applicare gli sconti o seguire la scontistica standard per cliente/articolo, in questo campo si può inserire la scelta preferenziale.
Ricarica da costo | In questo campo si può inserire la ricarica preferenziale per il calcolo del prezzo di vendita durante l'inserimento dei prezzi negli articoli.
Data inizio validità | Attualmente questo campo ha solo un valore descrittivo e non viene usato per il calcolo dei prezzi.
Data fine validità | Attualmente questo campo ha solo un valore descrittivo e non viene usato per il calcolo dei prezzi.
Listino padre | Se il prezzo per un determinato articolo non viene trovato nel listino corrente, il programma va a cercare se è stato inserito il prezzo nel listino padre e se neanche in questo è presente cerca nel padre del padre e così via a ritroso. Questo meccanismo consente di assegnare ad un Cliente un listino con il prezzo speciale per alcuni articoli mantenendo il prezzo base per i restanti. Premendo il pulsante collegato si apre la lista dei Listini. Il listino padre viene accettato solo se ha gli stessi parametri di Codice Valuta e di Scorporo.

Le Stampe disponibili sono:

Stampa Lista | Viene effettuata una lista semplice dei listini.
Lista dipendenze | Viene stampata una lista ad albero delle dipendenze tra listini, in questo modo si ottiene una mappa che ci aiuta a capire il modo in cui i prezzi vengono determinati.

I comandi speciali disponibili sono:

Prezzi Questo comando permette di aprire l'archivio dei prezzi impostati per ciascun articolo, vengono visualizzati solo gli articoli con i prezzi inseriti per questo listino, per ogni articolo si può inserire il prezzo e gli sconti, la data dell'ultima modifica al prezzo ed anche i prezzi diversificati in base alle quantità inserite nei documenti.
Da questa posizione è anche possibile fare variazioni automatiche di prezzi utilizzando la stessa procedura disponibile per gli articoli.


L'archivio dei depositi serve normalmente per gestire i movimenti di magazzino delle ditte che dispongono di più di un deposto, nei documenti di magazzino, viene sempre richiesto il codice del deposito presso cui viene effettuato il documento e sono anche disponibili documenti che effettuano il trasferimento di merce da un deposito ad un altro. Inoltre questo archivio può essere utilizzato per gestioni particolari come ad esempio la gestione della tentata vendita con furgoni, oppure la gestione di cantieri per le ditte che eseguono impianti elettrici, idraulici o altro.

I dati da inserire sono:

Codice | E' un codice alfabetico di 6 caratteri.
Descrizione | Inserire la descrizione del deposito.
Indirizzo CAP, Città e Prov. | Si possono inseririe i dati riguardanti l'indirizzo del deposito.
Data inizio | Si può inserire la data in cui viene aperto il deposito.
Data fine | Si può inserire la data in cui viene chiuso il deposito
Campo utente 1-3 | Questi campi sono liberi a disposizione dell'utente, possono essere utili per inserire dati particolari come ad esempio la targa dei furgoni di tentata vendita.
Registro IVA | Se si inserisce un valore, durante l'inserimento di documenti di magazzino viene applicato automaticamente questo registro quando si cambia deposito.

I Comandi speciali disponibili sono:
Recapiti | Si apre una lista in cui è possibile inserire indirizzi aggiuntivi a quello principale, ad esempio sedi operative, commerciali o altro.
Contatti | Si apre una lista in cui è possibile inserire numeri di telefono, fax, indirizzi e-mail ed indirizzi web.


L'archivio degli agenti contiene i dati anagrafici degli agenti a cui viene affidata la commercializzazione dei prodotti. Per ogni agente viene anche indicata la percentuale di provvigione assegnata per 10 scaglioni di provvigione.

Oltre a memorizzare gli agenti commerciali, questa tabella viene impiegata anche per altri scopi e quindi rappresenta genericamente i dipendenti dell'azienda. Viene utilizzata per memorizzare gli utenti che accedono al programma, gli utenti del sistema di gestione contatti e di impegni in scadenza infine vengono utilizzati per il rilevamento tempi della gestione commesse.

Il calcolo delle provvigioni è soggetto a variazioni notevoli da ditta a ditta, per questo motivo è difficile predisporre metodi di calcolo che possano tener conto di tutte le varie possibilità, il metodo standard utilizzato da Zefiro consiste nel determinare lo scaglione da utilizzare presente nella scontistica del cliente, questo calcolo viene fatto ogni volta che viene determinato il prezzo e dipende dal cliente o gruppo di clienti, dall'articolo o gruppo di articoli e dal listino adottato. Se questo metodo di calcolo non dovesse risultare soddisfacente, si dovrà inserire la provvigione a mano oppure richiedere una personalizzazione del calcolo alla Compusoft.

L'archivio degli agenti viene anche utilizzato per inserire gli utenti del programma per la gestione dei diritti d'accesso. Se viene abilitata la gestione della sicurezza, dopo aver inserito codice utente e password si accede al programma ed il programma sa chi è l'agente corrente e può utilizzare questa informazione in vari punti.

L'identificazione dell'utente può essere attivata anche senza chiedere l'inserimento delle credenziali, semplicemente riconoscendo la stazione da qui viene avviato il programma. Per collegare la stazione all'utente si usa la procedura Utenti della stazione.

I dati da inserire sono:

Codice | E' il codice che identifica l'agente
Ragione sociale | Inserire la ragione sociale ovvero il cognome e nome dell'agente
Via e num. civico
CAP
Città
Provincia 		Inserire l'indirizzo dell'agente
Partita IVA
Codice Fiscale 		Inserire i dati fiscali disponibili.
Registro documenti | Questo dato è rilevate per la gestione della tentata vendita e per la gestione documenti. Serve ad indicare il resistro dei documenti per evitare duplicazioni di numerazione.
Tipo liquidazione provvigioni | Indica il metodo utilizzato per la liquidazione delle provvigioni, le scelte possibili sono: 'F' a fine incasso, le provvigioni vengono liquidate dopo che è stata incassata l'ultima rata della fattura da liquidare, 'R' dopo l'incasso di ogni rata viene liquidata la provvigione in percentuale alla quota incassata, 'S' la provvigione viene liquidata alla data di emissione della fattura.
Codice deposito | Questo dato è rilevate per la gestione della tentata vendita e serve ad indicare il deposito in cui verrà effettuata la movimentazione di carico e scarico.
Costo orario | Questo dato viene usato nell'archivio dei tempi di lavorazione nella gestione delle commesse di lavorazione.
Costo straordinario | Questo dato viene usato nell'archivio dei tempi di lavorazione nella gestione delle commesse di lavorazione.
Provvigioni scala da 0 a 9 | Inserire la percentuale di provvigione assegnata per ogni scala. Il numero di scala assegnata per ogni articolo ed ogni cliente viene determinato combinazione di scontistica.
Codice zona | E' la zona assegnata all'agente. Premendo il pulsante collegato si apre la lista di scelte
Capoarea | A ciascun agente può essere assegnato il codice di un Agente Capoarea al quale verranno calcolate le provvigioni con un apposita procedura di calcolo. La struttura dei capiarea è gerarchica e quindi anche i capiarea possono avere dei supervisori che percepiscono provvigioni.
Diritti d'accesso

Questo pulsante apre una finestra in qui è possibile inserire i dati relativi ai diritti di accesso al programma, questa funzionalità è disponibile solo se è stata attivata la gestione della sicurezza.

I dati da inserire sono

Codice Utente | Inserire il codice mnemonico che l'utente utilizza per entrare nel programma.
Data scadenza | E' possibile assegnare diritti temporanei indicando la data di scadenza dell'utente, se non si inserisce la data, la password non ha scadenza.
Accesso sospeso | Si può inibire temporaneamente l'accesso a determinati utenti.
Cambia password | Premendo questo pulsante di apre una finestra in cui si può digitare la password che deve essere inserita 2 volte per evitare errori di battitura.
Diritti d'accesso | Premendo questo pulsante si apre la finestra per l'assegnazione dei diritti a questo utente.
Modifica diritti | Alle volte può essere più comodo modificare manualmente i diritti, questo pulsante permette di effettuare queste modifiche ottentendo un risultato equivalente a quello ottenuto con la voce precedente.
Note generali | In questo memo si può inserire una descrizione libera.

I Comandi speciali disponibili sono:
Telefoni/Contatti | Si apre una lista in cui è possibile inserire numeri di telefono, fax, indirizzi e-mail ed indirizzi web.
Apri cartella documenti agenti | Ogni agente può disporre di una propria cartella per memorizzare documenti di qualsiasi natura. Questo comando apre la cartella che l'utente può utilizzare come preferisce. La localizzazione delle cartelle può essere configurata nel file AGC.INI


Le tabelle sono archivi che solitamente vengono utilizzati meno di frequente e servono per lo più per motivi funzionali. Le tabelle disponibili sono:

Modalità di Pagamento hanno valore descrittivo nei documenti di magazzino e vengono utilizzate per la gestione dello scadenzario
Banche vengono utilizzate per la gestione delle ricevute bancarie.
Codici IVA servono per calcolare la percentuale di IVA dei documenti e per descrivere i codici di esenzione iva
Valute estere vengono utilizzate nei listini e nei documenti di magazzino
Causali contabili servono per l'inserimento della primanota
Categorie Articoli servono a raggruppare gli articoli ed a guidarne l'inserimento
Tipi Documento sono per i documenti l'equivalente delle causali contabili per la primanota
Vettori vengono utilizzati nei documenti di trasporto per indicare i soggetti che si occupano del trasporto.
Scontistica Clienti serve per stabilire regole automatiche di sconto e provvigione.
Varianti servono per specificare tutte le combinazioni di variante ed opzione.
Gruppi Varianti configurano i raggruppamenti di varianti utilizzati dagli articoli.
Depositi servono a localizzare le merci in punti diversi.


Questo archivio permette di memorizzare le modalità abituali di pagamento dei clienti e le modalità con cui abitualmente paghiamo i fornitori. Durante la registrazione contabile delle fatture di vendita e di acquisto, la modalità di pagamento permette di generare automaticamente le scadenze in base ai meccanismi di calcolo sotto esposti, questi meccanismi vengono inoltre utilizzati nella stampa delle fatture per esporre le scadenze e per generare le scadenze e/o le scritture di incasso durante la contabilizzazione delle fatture.

I dati da inserire sono:

Codice Tipo pagamento | E' un campo di 3 caratteri inseribile solo durante la fase di inserimento nuovi dati.
Descrizione | Permette di descrivere brevemente la modalità di pagamento.
Giorno scadenza | Permette di indicare il giorno in cui dovranno scadere le ricevute, ad esempio se scriviamo 15 la scadenza avverrà al 15 del mese. Inserendo 0 la scadenza avverrà allo stesso giorno del mese in cui è stata emessa la fattura, scrivendo 31 invece la scadenza viene sempre portata a fine mese.
Giorni aggiuntivi | Si possono aggiungere giorni alla fine della scadenza, ad esempio se si desidera una scadenza a mezzo RIBA a 30 giorni più 10, si inserisce 31 nel campo giorno scadenza per portare la scadenza a fine mese e poi si inserisce 10 nei giorni aggiuntivi per aggiungere 10 giorni.
Tipo calcolo | Inserire M=mesi o G=giorni e sta ad indicare se le scadenze che si inseriscono nella tabella che segue non espresse in mesi o in giorni, nella quasi totalità dei casi il calcolo viene effettuato in mesi, quindi in caso di dubbio si inserisca 'M'. Premendo pulsante collegato si apre la lista delle scelte disponibili.
Tipo Pagamento IVA Indica il metodo usato nella ripartizione di imposta ed imponibile nelle scadenze e può assumere i valori:
S | IMPORTO SUDDIVISO: l'imposta viene suddivisa in parti uguali per ciascuna scadenza (è la modalità abituale).
P | IVA SU PRIMA SCADENZA: l'imposta viene addebitata tutta sulla prima scadenza, quindi la prima scadenza contiene la ripartizione della parte di imponibile più l'intera imposta.
1 | PRIMO PAGAMENTO SOLO IVA: la prima scadenza contiene l'intero importo dell'imposta e le successive la ripartizione della parte imponibile.
Ad esempio, se abbiamo una fattura di 100 Euro di imponibile più 20 Euro di IVA, ed un pagamento a 30 e 60 giorni, inserendo 'S' le rate saranno di 60 e 60, inserendo 'P' saranno di 70 e 50 ed inserendo '1' saranno di 20 e 100.
Tipo scadenza Indica la modalità con cui avverranno i pagamenti e può assumere i valori:
D | RIMESSA DIRETTA: Il pagamento verrà effettuato direttamente.
B | BONIFICO: Il debitore incarica la banca di effettuare il pagamento
R | RICEVUTA BANCARIA: Il creditore emette ricevuta bancaria RIBA o RID presso la banca d'appoggio del debitore.
T | TRATTA: Come la precedente ma utilizzando il mezzo della Cambiale Tratta (In disuso).
P | PAGATO: Al momento della consegna il debitore ha già effettuato il pagamento.
Durante la contabilizzazione delle fatture di vendita se la modalità di pagamento è 'P' viene effettuata la scrittura contabile di incasso, altrimenti vengono generate le scadenze.
Addebito automatico RID Questo campo è significaivo solo se il tipo di scadenza è 'R' (ricevuta bancaria) se non è spuntato la ricevuta è una RIBA, altrimenti è un RID.
La differenza tra RID e RIBA consiste nel fatto che nel caso dei RID il cliente debitore autorizza l'addebito automatico presso la propria banca da parte del creditore. Il caso più frequente di RID sono le utenze telefoniche o energetiche.
Dal punto di vista funzionale il programma se riconosce che la scadenza è di tipo RID, nel caso di scadenze passive, nella stampa della lista scadenze, permette di escludere dalla lista le scadenze di questo tipo. Nel caso di scadenze attive invece prepara un tracciato diverso per la spedizione della distinta in formato elettronico.
Spese incasso | Indica l'importo di spese incasso collegate alla modalità. Questo valore viene inserito automaticamente nei Documenti di magazzino.
Spese bolli | Indica l'importo di spese per bolli collegate alla modalità. Questo valore viene inserito automaticamente nei Documenti di magazzino.
Percentuale sconto cassa. | Indica lo sconto a piede di fattura da concedere per questa modalità di pagamento. Questo valore viene inserito automaticamente nei Documenti di magazzino.
Codice fattura PA | In caso di invio delle fatture alla PA in formato elettronico è necessario inserire la modalità di pagamento con un codice proprio che può essere trovato nella documentazione tecnica.
Mesi/Giorni scadenza | E' una tabella in cui si possono inserire fino ad 8 scadenze, le date di scadenza vengono calcolate a partire dalla data del documento, se nel campo "Tipo di calcolo" è stato inserito 'M' il calcolo avviene in mesi quindi il valore 1 significa un mese, 2 significa due mesi ecc., se invece è stato inserito 'G' il calcolo avviene in giorni e quindi per far scadere la rata dopo un mese si deve scrivere 30. Se la prima scadenza ha importo uguale a 0 (zero) significa scadenza a vista, le altre scadenze con importo 0 (zero) vengono ignorate. Ad esempio se il pagamento è metà alla consegna e metà a 30 gg. bisogna scrivere 0 sulla prima scadenza e 1 (con tipo di calcolo = 'M') sulla seconda.

NOTA:

A determinate modalità di pagamento possono essere abbinate righe articolo che che vengono generate automaticamente in fase di generazione o modifica delle fatture. In questo modo è possibile ad esempio aggiungere sconti di tipo finanziario che non impattano sul calcolo dell'iva, oppure addebiti automatici di spese. Per la configurazione si veda la voce: PAGROWS del file di configurazione AGC.INI


Questo archivio contiene la lista delle banche, si inseriscono le banche con cui la ditta lavora e le banche d'appoggio dei clienti e di bonifico a fornitori non presenti nell'archivio contenente la lista delle banche italiane.

I dati da inserire sono:
Codice banca (ABI+CAB) | Il codice della banca è composto dal codice ABI più il codice CAB della banca, durante l'inserimento sono tenuti separati, ma compongono un codice unico.
Codice alternativo | Solitamente il codice alternativo è uguale al codice banca composto da ABI+CAB, ma in fase di inserimento di nuove banche è possibile inserire un codice mnemonico diverso, in questo modo si possono avere più banche con lo stesso codice ABI+CAB, questo può essere utile per la gestione di incassi e pagamenti su codici diversificati.
Nome banca | Indicare il nome della banca.
Nome agenzia | Indicare la denominazione dello sportello e la località
Num. Conto Corrente | Per le banche con cui lavoriamo viene inserito il numero di conto corrente che viene utilizzato nella gestione delle distinte bancarie.
Castelletto | Indicare l'importo del castelletto accordato cioè il fido concesso dalla banca con garanzia degli effetti presentati per l'incasso. Questo dato viene utilizzato per la stampa della stima castelletto e quindi della disponibilità per nuove presentazioni di effetti.
Codice IBAN | E' il codice di coordinata bancaria internazionale, utile per la gestione di incassi e pagamenti con l'estero e per il pagamento di bonifici italiani. Il codice può essere calcolato automaticamente a partire da ABI, CAB e Conto corrente inserito.
Codice SWIFT | Il codice SWIFT viene utilizzato per pagamenti e transazioni internazionali.
Codice SIA | Questo codice viene utilizzato per l'invio delle Ri.Ba. elettroniche, però di solito non è obbligatorio.
Codice CIN | Il codice CIN è una coordinata necessaria per la gestione dei bonifici bancari. Il codice può essere calcolato automaticamente a partire da ABI, CAB e Conto corrente inserito, questo codice comunque fa parte del codice IBAN.
Sottoconto banca | Questo campo viene impiegato solo per le banche con cui lavoriamo, stabilisce il legame tra la banca e la contabilità e viene utilizzato nella gestione delle distinte bancarie e nella gestione degli incassi. Premendo il pulsante collegato si apre la lista del Piano dei Conti.
Sottoconto SBF | Questo campo viene utilizzato assieme al Sottoconto di movimentazione. Se presente durante le presentazione della distinta bancaria i clienti vengono chiusi con questo conto e ad avvenuto incasso l'importo viene girato sul sottoconto di movimentazione, altrimenti tutte le operazioni vengono effettuate sul sottoconto di movimentazione. Premendo il pulsante collegato si apre la lista del Piano dei Conti.
Anticipi portafoglio SBF | Questo campo viene utilizzato assieme ai due precedenti e serve per fare la contabilizzazione in modo diverso. Se la nostra banca utilizza un conto unico in cui viene anticipato direttamente l'importo delle ricevute salvo rettifiche in caso di insoluti, si inserisce in questo campo un conto per le anticipazioni in modo da chidere direttamente il cliente con il campo ordinario ma nel contempo movimentare il conto SBF ed anticipazioni. Se questo campo non è presente si opera con il conto SBF oppure con il solo conto ordinario. Premendo il pulsante collegato si apre la lista del Piano dei Conti.
Sottoconto Anticipi | Questo campo viene utilizzato assieme al Sottoconto di movimentazione per la gestione degli anticipi bancari. Se è presente le operazioni di anticipo vengono fatte su questo conto, altimenti viene tutto fatto utilizzando il conto ordinario. Premendo il pulsante collegato si apre la lista del Piano dei Conti.
Giorni valuta | Inserire i giorni di valuta che la banca ci addebita per l'accredito delle ricevute. Le nuove norme di intermediazione bancaria obbligano le banche ad accreditare le Ri.Ba. entro il giorno successivo alla scadenza quindi al momento questo dato risulta superfluo.
Giorni lavorativi | Questa spunta serve ad indicare se nel calcolo dei gionri di valuta vengono considerati solo i giorni lavorativi oppure anche i giorni festivi. Il programma è in grado di riconoscere le festività nazionali civili e religiose compresa la Pasqua e tutte le feste correlate.


In questo archivio vengono memorizzati i Codici IVA o i codici di esenzione dall'IVA a cui sono assoggettarti gli articoli posti in vendita.

Si deve inserire:

Codice | E' il codice univoco, si consiglia di inserire un codice uguale all'aliquota IVA per i codici con IVA ed una sigla simile al codice di esenzione per i codici relativi ad articoli di esenzione.
Descrizione | Inserire la descrizione del codice IVA
Aliquota IVA | Inserire la percentuale di imposta da applicare oppure 0 in caso di codici di esenzione.
Tipo IVA Indica il tipo di calcolo effettuato sull'IVA per questo codice ed ha una corrispondenza con i codici Natura previsti dalla fatturazione elettronicao. Può assumere i valori:
N | NORMALE: L'IVA viene applicata normalmente aggiungendo la percentuale indicata all'importo imponibile.
X (N1) | EX ART 15: solitamente usato per bolli ed altre imposte.
F (N2) | FUORI CAMPO IVA: L'importo non è assoggettabile ad IVA, pertanto non sarà menzionato nei libri IVA.
I (N3) | NON IMPONIBILE: L'importo a cui si riferisce non è imponibile, viene usato normalemente per le esportazioni.
E (N4) | ESENTE: L'importo a cui si riferisce è esente da IVA ed in questo caso nella descrizione è opportuno indicare i riferimenti di legge che danno diritto all'esenzione.
M (N5) | REGIME DEL MARGINE: Utilizzato per la vendita di beni usati.
R (N6) | REVERSE CHARGE: Per la emissione di fatture in Reverse charge.
S (N7) | IVA UE: IVA assolta in altro stato UE.
Premendo il pulsante collegato si apre la lista delle scelte disponibili.
Specifica fattura elettronica | Con la versione 1.6 delle specifiche per le fatture elettroniche, i codici per la Natura IVA sono stati ampliati con lo scopo di fornire informazioni più complete ed eliminare alcuni adempimenti come ad esempio l'esterometro. In questa posizione si possono inserire i codici completi. Per motivi storici sono stati mantenuti anche i codici precedenti e quindi in questa posizione si mettono solo i codici con specifica.
Escluso reverse charge | Questa spunta serve per indicare una funzionalità usata raramente. Quando si registrano fatture di acquisto in Reverse Charge, può capitare che nella singola fattura siano presenti contemporaneamente inporti soggetti a Reverse Charge ed importi soggetti a normale tassazione IVA. In questo caso particolare, per le righe soggette a tassazione normale si deve usare un codice IVA con la esclusione da Reverse Charge attivata.
Non in uso | Alla variazione per legge dell'aliquota IVA di categorie di prodotti, si deve applicare la nuova aliquota ai nuovi documenti e mantenere la vecchia nei documenti vecchi. Per evitare errori è stato aggiunto questo campo che serve ad indicare le aliquote vecchie, in questo modo viene emessa una segnalazione se si tenta di usare una aliquota vecchia in un nuovo documento.
Descrizione esenzione
 In questo memo si può inserire la descrizione estesa dell'articolo di esenzione che verrà utilizzata nella descrizione di esenzione nei documenti.


 Questo archivio serve per inserire i codici delle valute estere e del tasso di cambio, i listini di articoli possono essere espressi in valuta estera, ed in questo caso nei documenti di magazzino i prezzi vengono espressi in valuta e valorizzati in Euro in base al tasso di cambio inserito.

I dati da inserire sono:

Codice | E' un codice di 3 caratteri che identifica la valuta.
Descrizione | Nome della valuta
Data del cambio | Inserire la data di riferimento del cambio
Cambio | Inserire il cambio con Euro alla data indicata.


L archivio delle causali contabili è molto importante per il funzionamento della procedura di inserimento della primanota. La Compusoft fornisce le principali causali già correttamente configurate con il Piano dei Conti inserito, se si modifica il piano dei conti è necessario modificare anche la causali in modo che puntino ai sottoconti corretti. Si possono inserire nuove causali ma in ogni caso si deve fare particolare attenzione alla gestione degli automatismi.

I dati da inserire sono:

Codice Causale Contabile E' un codice di 3 caratteri che identifica la causale.
Descrizione Inserire la descrizione della causale, questa descrizione viene riportata nella descrizione delle scritture contabili ed in quella sede può essere modificata.
Giornale di competenza | Il programma Zefiro può gestire registri contabili multipli, in questo campo si inserisce il registro preferenziale di questa causale, il registro predefinito è 'A' ed è bene non modificarlo se non ci sono fondate ragioni.
Codice Registro IVA | Questo dato viene utilizzato solo per le scritture che contengono parte IVA, Si inserisce il codice di registro preferenziale per questa causale, il registro predefinito è 'A'.
Tipo registro Indica il tipo di registrazione che viene effettuata con questa causale, i valori possibili sono:
G | GIORNALE: Sono le registrazioni contabili che non implicano parte IVA
V | VENDITE: Sono le registrazioni delle fatture di vendita e delle note di accredito a cliente.
A | ACQUISTO: Sono le registrazioni delle fatture di acquisto e delle note di accredito da fornitori.
C | CORRISPETTIVI: Sono le registrazioni delle vendite effettuate al pubblico a mezzo corrispettivi.
Premendo il pulsante collegato si apre la lista di scelte
Tipo documento | Questo dato è rilevante solo per le registrazioni di Vendite ed Acquisto ed indicano il tipo di registrazione, sono rilevanti ai fini contabili le Fatture 'F' e le note di accredito 'N' che indicano il trattamento della registrazione nei registri IVA e nella generazione delle scadenze. Premendo il pulsante collegato si apre la lista di scelte
Procedura compatibile | Serve ad indicare le causali compatibili con alcune procedure del programma e viene normalmente utilizzato da personale tecnico. Premendo il pulsante collegato si apre la lista di scelte
Tipo movimento contabile | Serve per distinguere alcuni tipi di registrazioni contabili, in particolare vengono identificate le scritture di Apertura e Chiusura di Bilancio per ottenere risultati corretti durante la stampa dei bilanci. Premendo il pulsante collegato si apre la lista di scelte

I comandi speciali disponibili sono:

Duplica causale Questo comando permette di duplicare una causale esistente, per registrare velocemente causali simili.


L'archivio delle categoria di articoli ha un duplice scopo. Prima di tutto serve per raggruppare gli articoli in modo che su di essi sia possibile effettuare elaborazioni in modo raggruppato, ad esempio si possono effettuare statistiche per categoria invece che per singolo articolo, oppure si possono applicare elaborazioni solo agli articoli appartenenti ad una singola categoria. Il secondo scopo è che durante l'inserimento di nuovi articoli la macchina propone automaticamente alcuni valori presenti in categoria ed in questo modo si rende più veloce ed agevole l'inserimento di nuovi articoli.

I dati da inserire sono:
Codice | E' un codice di 3 caratteri che identifica la categoria.
Descrizione | Inserire la descrizione della categoria
Unita' di misura Unita' misura alternativa Rapporto conversione U.M. Tabella varianti Codice IVA Gruppo sconto/provvigioni Tipo movimentazione Numero utente 1-3 Campo utente 1-3 | Tutti questi campi vengono riportati automaticamente durante l'inserimento di nuovi articoli per velocizzare l'immissione dei dati, per il loro significato consultare gli Articoli.
Sottoconto merce | Inserire in questa posizione il codice del sottoconto su cui verranno contabilizzate le vendite effettuate per gli articoli di questa categoria.
Sottoconto fornitore | Inserire in questa posizione il codice del sottoconto su cui verranno contabilizzate le fatture di acquisto per gli articoli di questa categoria.
Calcolo codice articolo | Questa casella di spunta indica se deve essere eseguito il calcolo automatico del codice articolo durante l'inserimento di nuovi articoli, in caso affermativo, il codice viene calcolato utilizzando la procedura configurata nelle preferenze. Attualmente sono disponibili la procedura newCodeNormal() che costruisce un codice composto dalla categoria più un progressivo numerico, e la procedura newCodeEAN13() che costruisce un codice compatibile con i barcode EAN13, per questo tipo di codifica è necessario che il codice della categoria sia numerico riempito con zeri.
Categoria padre | Questo campo serve per organizzare le categorie in forma di albero gerarchico con relazioni padre/figlio. Al momento attuale questo dato viene utilizzato solo per il collegamento con programmi di commercio elettronico e per la stampa in ordine gerarchico.
Codice Intrastat | Inserire in questa posizione il Codice di nomenclatura combinata Intrastat che viene utilizzato per fare la stampa del prospetto delle cessioni Intrastat.
Note | Premendo il pulsante memo si può inserire la descrizione.

I comandi speciali disponibili sono:
Cambia codice Questa procedura permette di cambiare il codice alla categoria quando la codifica adottata in precedenza non dovesse più essere soddisfacente. Il nuovo codice viene applicato a tutti gli articoli che appartengono a questa categoria.


L archivio dei tipi documenti è molto importante per il funzionamento della procedura di inserimento dei documenti di magazzino. La Compusoft fornisce i principali tipi di documento già inseriti, si possono comunque inserire altri tipi di documenti se questo dovesse essere necessario, si deve tener presente che i tipi di documento sono utilizzati in vari parametri di configurazione, perciò si deve fare attenzione in caso di cancellazione o inserimento di dati.

I dati da inserire sono:
Codice | E' un codice alfabetico di 3 caratteri che identifica il tipo di documento.
Descrizione | Inserire una breve descrizione del tipo di pagamento
Tipo anagrafica | Può assumere i valori 'C' per Clienti, 'F' per Fornitori o 'I' per documento interno. Premendo il pulsante collegato si apre la lista di scelte
Tipo documento Indica il tipo di documento, questo campo ha una valenza funzionale e determina alcuni automatismi del programma i valori possibili sono:
F | Fattura, questo tipo di documento viene generato dalla fatturazione automatica oppure inserito manualmente e viene esportato alla contabilità
D | Documento di consegna, questo tipo di documento genera la fatturazione automatica se la causale del trasporto è una causale di vendita.
N | Nota d'accredito, questo documento viene esportato in contabilità
O | Ordine, questo documento viene evaso dai documenti di trasporto oppure dalle fatture immediate.
L | Carico C/Lavoro, serve per la gestione del conto lavoro e viene evaso dai documenti di reso lavorato.
V | Vendita corrispettivi, è un documento di vendita che non viene esportato in contabilità
I | Interno, documento utilizzato per movimentazioni interne.
P | Preventivo, serve per inserire preventivi a clienti.
G | Giacenza inventariale, questo documento serve per inserire le rettifiche di giacenza nella gestione dell'inventario.
Premendo il pulsante collegato si apre la lista di scelte
Codice registro | E' il codice di registro preferenziale, se non ci sono motivi particolari inserire il valore 'A'
Tipo movimenti Questo campo serve per inserire il tipo di movimentazione di magazzino che il documento realizza, i dati inseribili sono:
0 | Non movimenta, questo documento non esegue movimentazioni di magazzino ad esempio Fatture differite o Preventivi.
2 | Ordine di carico, viene utilizzato dagli ordini a fornitore.
3 | Carico convalidato, non viene utilizzato direttamente ma gestito automaticamente dalle procedure di gestione inventario.
4 | Carico, documento di carico.
5 | Scarico, documento di scarico.
6 | Scarico convalidato, non viene utilizzato direttamente ma gestito automaticamente dalle procedure di gestione inventario.
7 | Ordine di scarico, viene utilizzato dagli ordini da cliente.
9 | Giacenze inventariali, non viene utilizzato dai documenti, ma dalla procedura di gestione inventario.
Premendo pulsante collegato o il tasto F2 si apre la lista di scelte
Causale del trasporto | Inserire la causale del trasporto predefinita per il tipo di documento. l'inserimento di questo campo è utile solo per i documenti di consegna. Premendo il tasto [F2] si apre la lista di scelte.
Tracciato report | Per i documenti stampabili si deve inserire il nome del tracciato da utilizzare. Viene inserito il tracciato più usato, ma in fase di stampa si può decidere di utilizzare un tracciato diverso. I tracciati sono memorizzati nelle risorse del programma, si possono utilizzare quelli esistenti oppure inserirne di personalizzati.
Copie da stampare | Per i documenti stampaìbili inserire il numero di copie per ogni documento, Zero indica che il documento non è stampabile.
Accumulatore progressivi | Questo campo serve per la gestione automatica dei progressivi di numerazione. I progressivi vengono gestiti dall'archivio dei numeratori, più tipi di documento possono utilizzare lo stesso numeratore, ad esempio le Fatture Differite e le Fatture Immediate oppure i DDT a Cliente ed i DDT a Fornitore. L'automatismo dei numeratori prevede che il numero viene incrementato solo quando si inserisce un numero superiore a quello memorizzato, ad esempio se la procedura di gestione documenti propone il numero 100 significa che il numero memorizzato nei numeratori è 99 se confermo o inserisco un numero superiore tale numero verrà memorizzato nei numeratori, se invece inserisco un numero inferiore, nel numeratore verrà conservato il numero 99.
Modalità di pagamento | Se si desidera si può inserire la modalità di pagamento predefinita per questo tipo di documento, in fase di inserimento documenti verrà proposta questa modalità ignorando quella prevista per il cliente.
Tipo evasione | Alcuni documenti sono in grado di evadere altri documenti ad esempio i DDT a cliente o le fatture immediate evadono gli ordini da cliente, oppure i DDT di reso lavorato evadono i DDT di carico in conto lavorazione. Premendo il pulsante collegato si apre la lista di scelte.
Tipo movimenti automatici | I documenti sono composti da testata e righe, in fase di memorizzazione del documento è possibile generare righe automatiche, ad esempio quando si esegue un trasferimento da un deposito ad un altro, ci sono le righe manuali che eseguono lo scarico dal deposito di partenza e le righe automatiche che eseguono il carico nel deposito di destinazione. Premendo il pulsante collegato si apre la lista di scelte.
Tipo fattura elettronica | La fattura elettronica prevede la possibilità di inviare varie tipologie di documenti. Zefiro è normalmente in grado di determinare il codice corretto in base al tipo di documento e di alcuni parametri, ma è possibile indicare esattamente il tipo di documento della fattura elettronica per ogni tipo di documento di Zefiro. In ogni caso in fase di spedizione della fattura elettronica è possibile indicare un codice diverso a seconda delle necessità.
Avviso causale documento | Questo campo serve per limitare gli errori di inserimento di documenti non desiderati. Se si inserisce una descrizione, quando si inserisce un documento di questo tipo, viene presentato a video un avviso che chiede la conferma per poter proseguire.
Visualizza dati trasporto | Questa casella di spunta serve ad indicare se si desidera che vengano chiesti di dati di trasporto nel piede del documento.
Visualizza totali | Questa casella di spunta serve ad indicare se si desidera che vengono visualizzati i totali del documento con la possibilità di inserire sconti e spese nel piede del documento.
Movimenti negativi | Indica se sommare o sottrarre le quantità nei calcoli di giacenza.
Valorizzazione al costo | Nei documenti clienti solitamente viene presentato negli articoli il prezzo di vendita, con questa opzione viene proposto il prezzo di costo, questo serve per fare documenti di giroconto.
Calcolo ritenuta d'acconto | Con questa opzione si abilita il calcolo della ritenuta d'acconto per questo documento. La ritenuta viene calcolata sugli articoli appartenenti ai gruppi indicati nelle preferenze di magazzino. Vengono anche generate automaticamente le righe di rimborsi previdenziali dei professionisti.
Num. decimali dei prezzi Zefiro permette di scegliere a livello globale se utilizzare 2 o 4 decimali per i prezzi dei documenti e se si scelgono 4 decimali in tutti i campi in cui si inserisce un prezzo e in tutte le stampe, verranno presentati i 4 decimali.
Alle volte però strutturalmente si usano i 2 decimali ma può servire di avere necessità di più decimali solo in casi specifici ed isolati. Nella gestione dei documenti di magazzino è possibile per un singolo documento decidere di usare un numero di decimali diverso dallo standard che verrà usato per i calcoli, per la stampa e per i documenti generati.
In questa posizione si può decidere che un determinato tipo di documento avrà sempre il numero di decimali indicato. Se si lascia zero, il documento applicherà i decimali globali previsti dal programma.
Stati del documento I documenti possono avere alcuni "Stati" che possono essere attivati o disattivati. Ogni tipo di documento può avere stati diversi, ad esempio le Fatture possono avere lo stato di CONTABILIZZATA ed i ddt possono avere lo stato di FATTURATO. I codici degli stati sono di una lettera e documenti diversi potrebbero utilizzare lo stesso codice per funzionalità diverse. Alcuni stati sono automatici e dipendono dalla configurazione, altri possono essere personalizzati premendo questo pulsante. Gli stati automatici sono:
S STAMPATO | Indica se un documento stampabile è stato stampato oppure no.
M EMAIL | Indica se il documento stampabile è stato inviato via email in formato PDF.
E ELETTRONICA | Se il documento è una fattura a clienti si può indicare se la fattura elettronica è stata preparata.
C CONTABILIZZATA | Se il documento è una fattura si indica se è stata contabilizzata oppure no.
F DOC. FATTURATO | Se il documento è un DDT o in ogni caso è un documento fatturabile con questo stato si indica che è già stato fatturato.
E DOC. EVASO | Per gli ordini, il conto lavoro ed i preventivi si indica se il documento è stato completamente evaso.
Alcune procedure potrebbero attivare automaticamente gli stati automatici, ad esempio quando si invia un documento tramite mail la procedura potrebbe attivare autonomamente lo stato "M".
ATTENZIONE! La Compusoft si riserva la libertà in futuro di aggiungere altri stati automatici che potrebbero andare in conflitto con gli stati personalizzati inseriti dagli utenti. Per evitare conflitti, si consiglia di usare come condice le cifre, oppure le lettere miunscole.
Campo libero 1-5 | Questi campi vengono usati per realizzare automatismi di programmazione. Ad esempio nel campo 1 si inserisce la descrizione da inserire nei documenti generati (ad esempio da Ordine a DDT) e nella descrizione 2 si inserisce la descrizione da visualizzare nella stampa del documento e nella riga 3 si inserisce il codice del tipo documento da generare automaticamente.


Questo archivio viene utilizzato nei documenti di trasporto per indicare il vettore che lo effettua.

I dati da inserire sono molto semplici:

Codice | E' il codice che indentifica in maniera univoca il trasportatore.
Ragione sociale | Inserire la ragione sociale della ditta che effettua il trasporto.
Indirizzo | Inserire la via ed il numero civico.
Città | Inserire la Città ed eventualmente il CAP e la Provincia.
Partita IVA | Inserire la Partita IVA del trasportatore.
Codice Fiscale | Inserire il codice fiscale del trasportatore.
Iscrizione albo autotrasportatori | Inserire il numero di iscrizione all'albo.


La tabella della scontistica serve per determinare gli sconti e la provvigione da applicare agli articoli nei documenti di magazzino.

Per maggiori dettagli sulla applicaizone degli sconti invitiamo a consultare la pagina del Calcolo dei prezzi di vendita

I dati da inserire sono:

Gruppo articoli | Questo sconto verrà applicato a tutti gli articoli di questo gruppo, questo campo è alternativo alla categoria di articoli.
Categoria articoli | Questo sconto verrà applicato a tutti gli articoli della categoria indicata.
Gruppo clienti | Questo sconto verrà applicato a tutti i clienti di questo gruppo, questo campo è alternativo al codice cliente.
Codice cliente | Questo sconto verrà applicato solo a questo cliente.
Codice listino | Questo sconto viene applicato solo se viene utilizzato questo listino.
Scala provvigioni | E' il numero di scala di provvigione da applicare, il numero va da '0' a '9' e la provvigione applicata sarà quella presente nella corrispondente scala dell'agente.
Sconto 1, 2, 3 | Sono gli sconti da applicare
Sconti per quantità | Si possono avere fino a 3 scaglioni di sconto. Al raggiungimento della quantità indicata viene applicato lo sconto corrispondente. Le quantità devono essere crescenti e la prima quantità a zero interrompe il calcolo. Ad esempio: se lo sconto normale è 10% e la prima riga indica quantità 100 e sconto 10% + 5%, fino a quantità 99 viene applicato lo sconto 10% e da 100 in su si applica 10% + 5%


Questa tabella serve per configurare il calcolo di conversione tra unità di misura. Lo scopo per cui viene utilizzata è per la gestione delle conversioni complesse in cui ad esempio sono coinvolte misure per ottenere metri cubi o metri quadrati. Nel caso delle conversioni più semplici è sufficiente la conversione standard prevista dal programma descritta in anagrafica Articoli ed in Documenti di Magazzino.

Si deve inserire:
Tipo anagrafica | Scegliere se questa conversione viene applicata ai documenti dei Clienti o dei Fornitori. Premendo pulsante collegato o il tasto F2 si apre la lista di scelte.
Unità di di misura | Inserire il codice della Unità di misura degli articoli a cui applicare questo metodo di conversione.
Unità di misura alternativa | Inserire il codice della Unità di misura alternativa degli articoli a cui applicare questo metodo di conversione.
Campo per rapporto di conversione | Siccome si possono utilizzare cinque campi numerici per la gestione della conversione, in questa posizione si può indicare in quale campo deve essere proposto il rapporto di conversione presente negli articoli, lasciare zero se non interessa usare il rapporto di conversione.
Descrizione | Inserire una breve descrizione.
Descrizione campo 1-5 | Per ognuno dei cinque campi si descrive il significato per facilitare il compito dell'utente.
Valore predefinito campo 1-5 | Per ogni campo si può indicare un valore predefinito che verrà proposto in fase di conversione, esistono alcuni valori speciali che permettono di inserire numeri ricavati dagli archivi: I valori -0.001, -0.002 e -0.003 inseriscono i campi NUM01, NUM02 e NUM03 dell'articolo corrente. Il valore -0.004 inserisce il prezzo unitario della riga corrente. I valori -0.005, -0.006, -0.007 e -0.008 inseriscono il prezzo unitario lordo e gli sconti della riga corrente.
Formula per calcolo quantità | Inserire la formula da utilizzare per calcolare la conversione della quantità. i campi da 1 a 5 vengono indicati con la dicitura V1, V2, V3, V4 e V5
Formula per calcolo valore | Inserire la formula da utilizzare per calcolare la conversione del valore complessivo della riga, i campi da 1 a 5 vengono indicati con la dicitura V1, V2, V3, V4 e V5. Se la formula è assente non viene calcolato alcun valore. Il prezzo unitario viene calcolato dividendo il valore complessivo con la quantità convertita.

In fase di inserimento dati nei documenti di magazzino, alla richiesta della quantità, premendo il tasto F2 viene avviata la gestione della conversione. Se non c'è una tabella di conversione specifica viene attivata la modalità di conversione semplificata

che chiede il rapporto di conversione, la quantità espressa nell'unità di misura alternativa ed il prezzo unitario nella unità di misura alternativa, in risposta fornisce la quantità nella unità di misura corrente ed il prezzo unitario convertito.

Se invece esiste una tabella di conversione specifica viene presentata la finestra per l'introduzione dei dati per il calcolo della formula di conversione.

e mano a mano che si inseriscono i dati vengono calcolati quantità e prezzo della conversione, alla fine se la conversione viene confermata, i dati vengono riportati nella riga del documento ed i dati di conversione vengono memorizzati per eventuali modifiche o usi particolari come ad esempio la stampa con tracciati speciali.


La tabella delle righe automatiche dei documenti permette di attivare una funzionalità avanzata della gestione dei documenti di magazzino.

Trattandosi di una proceduta sofisticata, la sua gestione richiede la conoscenza approfondita del programma. Ciò significa che in caso di necessità, per la sua attivazione è consigliabile affidarsi all'aiuto di personale esperto.

La sua funzione è quella di aggiungere righe automatiche ai documenti che vengono inseriti o generati. Per fare questo vengono applicate particolari formule di calcolo che operano sulle righe del documento.

Un esempio tipico è l'applicazione delle spese di trasporto. Ad esempio si potrebbe applicare una percentuale fissa sul valore dell'intero documento, oppure si potrebbe attivare un addebito automatico forfettario. Un altro esempio potrebbe essere l'applicazione di uno sconto percentuale concordato ad singolo un cliente.

Per i casi più semplici vengono fornite dal programma alcune formule di calcolo generiche che illustriamo in seguito. Nei casi più complessi o particolari, sarà necessario richiedere una personalizzazione del programma per includere il calcolo mancante. Ad esempio se le spese di trasporto vengono applicate in percentuale, ma solo fino ad un certo importo oppure solo per determinati tipi di prodotto.

I dati da inserire sono:

Codice | Viene proposto il codice automatico che può essere utilizzato per le esclusioni.
Descrizione | Una breve descrizione del compito della riga
Causale documento | E' la causale del documento a cui applicare la regola. Se la stessa regola si applica a più tipi di documento, ad esempio le fatture immediate e le fatture differite è necessario duplicare la regola.
Codice Cliente/Fornitore | Si sceglie il codice del cliente o fornitore a cui applicare la regola. Se si lascia Zero, la regola viene applicata a tutti ad eccezione di quelli esplicitamente esclusi.
Codice Articolo | Se si desidera generare una riga di tipo Articolo si inserisce il codice, se si lascia in bianco verrà generata una riga Extramagazzino, oppure una riga descrittiva se la quantità della riga è zero.
Comando calcolo valore | In questa posizione si inserisce la formula che viene usata per calcolare quantità e valore della riga. La sintassi deve essere corretta e riconosciuta dal programma, alla fine di questa trattazione elenchiamo le sintassi standard riconosciute dal programma.
Codice IVA | Se si lascia in bianco, viene trovato il codice automaticamente con le regole standard di Zefiro, altrimenti viene forzato il codice inserito.
Descrizione riga | La descrizione della riga del documento, utile soprattutto per le righe Extramagazzino e Descrittive.
Tipo stampa riga | Utile soprattutto per le righe descrittive, indica come viene stampata la riga utilizzando le regole standard dei documenti.
Attivazione automatica | Se si metta la spunta, la riga viene generata automaticamente quando si inserisce il documento, altrimenti la riga viene inserita solo manualmente quando si modificano i documenti.
Esclusione riga | Se è stata attivata una regola generica che si applica a tutte le anagrafiche di un determinato tipo di documento, inserendo i codice della regola generica la si può escludere per un determinato cliente o fornitore. Viene usata quando una regola si applica a quasi tutti con qualche eccezione.

I comandi speciali disponibili sono:

Duplica riga automatica Quando alcuni clienti o fornitori condividono la stessa regola, si può fare la duplicazione della registrazione per cambiare solo il codice

Il funzionamento della generazione automatica è il seguente.

Quando si modifica un documento, nelle righe è presente il comando speciale il comando "Genera righe automatiche" che presenta la lista delle righe generabili per per il documento in corso. Questo è utile per generare righe che non si desidera vengano generate automaticamente o per rifare la generazione in caso di modifica di un documento.

Dopo aver inserito manualmente un documento, oppure quando viene usata una procedura che genera automaticamente i documenti, vengono generate le righe usando la regola che segue:

  • Vengono trovate tutte le regole per questo tipo di documento che hanno codice anagrafica Zero. Ad esempio si può attivare una regola alle Fatture di tutti i clienti.
  • Vengono trovate tutte le regole per uno specifico tipo di documento per una specifica anagrafica, ad esempio si può applicare uno sconto ad un determinato cliente in ciascun DDT
  • Infine si applicano le esclusioni, ad esempio se una regola viene applicata a tutte le fatture ad eccezione di quelle di alcuni clienti.

A questo punto vengono generate tutte le righe che soddisfano le condizioni. Se una riga Articolo o Extramagazzino nel calcolo ha la quantità a Zero, la riga non viene generata. Quantità e valore vengono generati utilizzando la formula inserita. In caso di necessità particolari è possibile richiedere una personalizzazione, al momento le formule riconosciute sono:

o:calc_x100(x100, aCTAin, aCTAout, lExtra) Viene applicata una percentuale sommando il valore di tutte le righe. i parametri sono:
  • x100 percentuale da applicare
  • aCTAin lista delle categorie articoli da includere, ad esempio {"010","020"}.
  • aCTAout lista delle categorie articoli da escludere, ad esempio {"999"}.
  • lExtra si può decidere di inculdere o escludere le righe Extramagazzino dal calcolo.
Solo il primo parametro è obbligatorio, se gli altri parametri vengono omessi il calcolo si applica a tutte le righe. Quando si usa questa fornula, se nella descrizione si inserisce la sigla "@IMPO;", in fase di calcolo la sigla viene sostituita con l'importo su cui viene fatto il calcolo. Ad esempio se scrivo "SCONTO DEL 5% SU @IMPO; EURO" e l'importo calcolato delle righe è di 100,00 la descrizione finale sarà "SCONTO DEL 5% SU 100,00 EURO"
o:calc_qtprz(qta, nPrunit, nsc01, nsc02, nsc03) Vengono assegnati quantità e prezzo fissi. i parametri sono:
  • qta la quantità della riga
  • nPrunit il prezzo unitario.
  • nsc01 nsc02 nsc03 gli sconti 1, 2 e 3.
Solo il primo parametro è obbligatorio, se gli altri parametri vengono omessi nelle righe articolo vengono applicate le condizioni standard.

Ecco alcuni esempi di applicazione


Questo archivio serve per memorizzare tutte le combinazioni di gruppo variante e codice variante.

I dati da inserire sono:

Codice variante | Indica una variante a cui possono appartenere un certo numero di opzioni. Premendo pulsante collegato si apre la lista delle varianti disponibili quando si devono inserire codici di opzione.
Codice opzione | E' il codice che indica una opzione appartenente alla variante, se questo campo è vuoto significa che stiamo inserendo la descrizione di una variante.
Sigla | E' una breve sigla che descrive la variante, questo campo viene utilizzato nella stampe per descrivere la variante.
Descrizione | Si può inserire una descrizione più estesa. Premendo pulsante collegato si copia la sigla.
Numero misura | Questo campo viene chiesto solo per le varianti e non per le opzioni ed indica il numero di campo utilizzato per precisare le varianti a misura, se è zero indica che non si specificano misure, altrimenti si inserisce un numero da 1 a 5, che indica il campo dei movimenti di magazzino utilizzato per la quantità
Valore predefinito | Questo campo viene chiesto solo per le varianti ed indica l'opzione preferenziale che viene proposta quando si inseriscono le varianti nelle movimentazioni.
Note | Premendo il pulsante memo si può inserire una descrizione aggiuntiva.


L'archivio dei gruppi di varianti serve per indicare quale è la combinazione di varianti predefinita per ciascun articolo. Quando si inseriscono articoli nei documenti di magazzino ed in genere in tutte le posizioni in cui si inseriscono movimenti di magazzino, se la tabella varianti associata all'articolo prevede le varianti, si devono inserire anche le opzioni scelte le varianti indicate, da notare che la gestione delle varianti non è rigida, infatti quando si apre la finestra di selezione delle opzioni, si possono inserire anche varianti diverse o togliere alcune delle varianti preimpostate, naturalmente ogni combinazione di varianti+opzioni ha la gestione della giacenza separata, pertanto quando si
usano combinazioni diverse da quelle proposte si deve anche gestirne il carico e scarico. La gestione flessibile delle varianti consente di modificare nel tempo la gestione delle varianti aggiungendo un grado di libertà alla gestione degli articoli di magazzino.

I dati da inserire sono:
Codice tabella | E' il codice che identifica il gruppo.
Descrizione | Inserire una breve descrizione del gruppo
Note | Premendo il pulsante memo si può inserire una descrizione più approfondita
Variante 1-10 | Inserire i codici di variante utilizzate. Premendo pulsante collegato o il tasto F2 si apre la lista dei Gruppi di varianti.


Le liste di scelte sono Altre tabelle utilizzate da pulsanti collegati presenti in vari punti del programma, le liste disponibili sono:

Gruppi clienti | Questa lista permette di raggruppare i clienti in categorie economiche e viene utilizzata per la gestione della contistica e delle provvigioni degli agenti, viene inoltre utilizzata per la suddivisione dei clienti nei centri di ricavo contabili, per assegnare il centro di ricavo si inserisce il il carattere due punti ":" alla fine della descrizione seguito dal codice corretto del centro di costo/ricavo.
Codici zone | Serve per raggruppare i clienti in base alla zona di appartenenza
Tipi attività clienti | Serve per raggruppare i clienti in base alla tipologia di attività svolta
Categorie merceologiche fornitori | Serve per raggruppare i fornitori in base alla categoria di prodotti o servizi che forniscono.
Tipo gruppo scadenze | Questa lista è disponibile solo se si usa il modulo di scadenze generiche, e serve per raggruppare le scadenze
Tipo questionario clienti | Questa lista è disponibile solo se si usa il modulo di gestione della qualità, e serve per inviare questionari diversi a diversi tipi di cliente
Origne segnalazioni non conformità | Questa lista è disponibile solo se si usa il modulo di gestione della qualità, e serve per raggruppare le non conformità in funzione della motivazione che le ha generate.
Gruppi articoli | Serve per raggruppare gli articoli in categorie economiche da utilizzare nella scontistica dei clienti e per il calcolo delle provvigioni.
Causali del trasporto | Viene utilizzata nei documenti di trasporto, i DDT con codice causale da 0 (zero) a 9 (nove) vengono inclusi nella fatturazione automatica, gli altri codici servono ad indicare causali non di vendita.
Centri di costo e ricavo | I centri di costo e ricavo sono raggruppamenti utilizzati in contabilità per suddividere i conti economici secondo criteri aziendali rilevabili nella stampa del bilancio.
Prefissi partita IVA CEE | Indica la nazione CEE di appartenenza di clienti e fornitori, 'IT' indica Italia.
Mastro e conto Clienti | Questa lista stabilisce il legame tra il Piano dei Conti ed i clienti per la gestione dei codici di contabilità.
Mastro e conto Fornitori | Questa lista stabilisce il legame tra il Piano dei Conti ed i fornitori per la gestione dei codici di contabilità.


GLi altri archivi tabelle gestite automaticamente dal programma e che normalmente non serve gestire direttamente. Vengono resi disponibili per motivi di manutenzione, il loro uso dovrebbe essere riservato a personale tecnico, per questo motivo non vengono documentati in modo completo, a parte alcuni che a volte possono essere. Sono presenti i seguenti archivi:

Numeratori | L'archivio dei numeratori viene utilizzato per gestire i progressivi di numerazione utilizzati dal programma, ad esempio permette di memorizzare i progressivi di stampa della contabilità ed i numeri dei documenti di magazzino.
Registrazioni contabili | Questo archivio contiene le testate delle registrazioni contabili utilizzate dalla procedura di registrazione della primanota.
Movimenti contabili | Questo archivio contiene la parte contabile delle registrazioni di primanota.
Movimenti IVA | Questo archivio contiene la parte IVA delle registrazioni di primanota.
Liquidaziuoni IVA | L'archivio delle liquidazioni IVA viene utilizzato dalla procedura di stampa delle liquidazioni IVA e dei riepiloghi annuali.
Comunicazioni fatture | Questa tabella contiene i dati utilizzati per le comunicazioni trimestrali delle fatture. Serve per garantire l'univocità dei nomi dei files e dispone di alcuni comandi correlati all'invio dei dati.
Piano dei conti CEE | Il Piano dei conti CEE viene utilizzato per la riclassificazione del piano dei conti.
Comuni Italiani | L'archivio dei comuni italiani viene utilizzato per velocizzare l'inserimento di CAP Città e Provincia e per calcolare e controllare la validità del codice fiscale nei Clienti e nei Fornitori, di norma non si dovrebbero modificare i dati di questo archivio dato che la Compusoft nei files di distribuzione del software fornisce un archivio comuni contenente tutti i comuni d'Italia che può essere inserito nel programma.
Lista banche italiane | Nei files di distribuzione dei programmi Compusoft è presente la lista delle banche italiane che è utile per evitare di inserire nell'archivio delle Banche tutte le banche di appoggio dei clienti e le banche per i bonifici ai fornitori. In molte procedure, il programma cerca automaticamente il codice della banca nell'archivio delle banche e se non viene trovato, continua la ricerca in questo archivio, la ricerca fallisce solo se il codice non viene trovato nei due archivi.
Nomenclature itrastat | Contiene la lista delle nomenclature per i beni che vengono scambiati tra i paesi membri della UE. Sono esclusi i servizi, che dovranno essere aggiunti a mano.
Righe scadenza impegni | Tabella di supporto alla procedura di scadenze impegni.
Testate documenti | In questo archivio vengono memorizzate le testate dei Documenti di magazzino.
Righe documenti | Questo archivio contiene le righe dei documenti di magazzino.
Distinte listini | In questo archivio vengono memorizzati i prezzi di listino degli Articoli.
Aricoli clienti/fornitori | Questo archivio permette di memorizzare le codifiche ed i prezzi che fornitori e clienti utilizzano per gli Articoli.Solitamente questi dati vengono gestiti direttamente dall'archivio degli articoli.
Distinta base | Questo archivio contiene le distinte base degli articoli che sono raggruppamenti di articoli utilizzati per la gestione della produzione.


Questa tabella serve per memorizzare i progressivi automatici gestiti dal programma.

Di norma l'utente non ha necessità di modificare direttamente i dati inseriti, ma esistono delle eccezioni. Il caso più frequente di utilizzo si verifica quando per qualche motivo si deve cambiare il progressivo di numerazione dei documenti di magazzino, ad esempio può succedere di dover cancellare una fattura e rimpiazzare il numero con un altro documento. In questo caso si dovrà modificare il numeratore per indicare manualmente la data ed il numero dell'ultimo documento emesso in modo che la numerazione prosegua dal numero successivo.

I dati da inserire sono:

Anno | E' l'anno di riferimento dei numeratori, ogni anno i numeri ricominciano da zero.
Tipo | I numeratori sono raggruppati in tipi in modo che si possano usare codici uguali per tipi diversi
Codice | E' il codice del numeratore ad esempio le fatture potrebbero avere codice "FV"
Registro | E' il codice del registro a cui applicare il numeratore ad esempio potremmo avere registri diversi per i "DDT"
Numeri, Date, Importi | Si può gestire una scaletta di un massimo di 4 numeri a cui possono corrispondere una data ed un numero. Ad esempio Nelle fatture di magazzino il primo numeratore e data corrispondono alle fatture emesse ed il secondo alle fatture contabilizzate.


Questo archivio serve per memorizzare i prezzi di listino degli articoli.

Negli archivi è presente una voce che permette di inserire velocemente i prezzi nei casi più semplici, ma alle volte è necessario gestire situazioni più articolate ed in questi casi la tabella va gestita direttamente.

Per maggiori dettagli invitiamo a consultare la pagina del Calcolo dei prezzi di vendita

La tabella viene gestita direttamente dai preferiti dei clienti e dei fornitori e quando si devono gestire prezzi diversificati a seconda delle quantità

I dati da inserire sono:

Codice listino, Codice cliente, Codice fornitore | Questi codici sono alternativi, se ne può inserire solo uno. Se si Inserisce il listino il prezzo vale per tutti i clienti di quel listino, altrimenti si possono inserire i preferiti dei clienti o dei fornitori.
Codice Articolo | E' l'articolo a cui si riferisce il prezzo.
Ultima modifica | Si inserisce la data di variazione del prezzo, questo dato può essere utile per sapere se il prezzo è aggiornato.
Prezzo | Si inserisce il prezzo. Nel caso dei preferiti dei clienti, si può lasciare il prezzo a zero ed in tal caso il prezzo viene calcolato nel modo abituale.
Applica sconti | Se questa casella è spuntata, vengono applicati gli sconti indicati e non si prosegue oltre nel calcolo della scontistica. La casella vale anche quando gli sconti sono tutti a zero. Questo è utile ad esempio nella gestione dei preferiti.
Sconto 1, 2, 3 | Si inseriscono gli sconti che valgono solo se la casella precedente è spuntata.
Quantità predefinita | Questa casella serve per indicare la quantità abitualmente acquistata nei preferiti.
Note interne | Se si desidera si possono scrivere delle annotazioni.
Prezzi per quantità | Si possono avere fino a 3 scaglioni di prezzo. Al raggiungimento della quantità indicata viene applicato il prezzo corrispondente. Le quantità devono essere crescenti e la prima quantità a zero interrompe il calcolo. Ad esempio: se il prezzo normale è 10,00 e la prima riga indica quantità 100 e prezzo 8,00, fino a quantità 99 viene applicato il prezzo 10 e da 100 in su si applica 8,00

I comandi speciali disponibili sono:

Cancella preferiti vecchi Se i clienti non acquistano da un po' di tempo è possibile cancellare i preferiti per ritornare ai prezzi standard.

Le Stampe disponibili sono:

Stampa prezzi A seconda del contesto in quei viene chiesta, vengono stampati i prezzi secondo l'ordine più appropriato.


Le scritture della lista delle e-mail inviate vengono generate quando si inviano automaticamente stampe tramite e-mail.

La tabella ha unicamente lo scopo di contollare che cosa è stato inviato e se ci sono stati errori, quando i dati non sono più necessari si possono tranquillamente cancellare.

Se non ci sono errori di invio, significa che la mail è partita, ma non c'è nessuna garanzia che la mail sia effettivamente stata letta del destinatario. Infatti potrebbe succedere che il programma del destinatario consideri la nostra mail come posta indesiderata e che la cestini automaticamente.

Da Zefiro quando si invia la mail è possibile richiedere la ricevuta di ritorno, e se il destinatario ci invia la ricevuta abbiamo la certezza che è stata letta, ma se il destinatario non la invia non siamo in grado di sapere se l'ha ricevuta oppure no.

Questi limiti sono intrinsechi nel sistema di posta elettronica e non sono tecnicamente superabili. Se vogliamo avere la certezza del ricevimento della posta, dobbiamo effettuare l'invio tramite PEC (Posta Elettronica Certificata), ed in questo caso il sistema di posta è in grado di notificare automaticamente quando il messaggio è stato recapitato presso la casella di posta del destinatario.

In caso di errore di invio, invece nella registrazione viene indicato il tipo di errore riscontrato.

I dati da presenti sono:

Data e ora | Indica data ed ora in cui è stato inviato il messaggio, la data è quella del computer e non la data del programma che invece potrebbe essere stata modificata.
Utente | è il codice agente dell'utente che ha effettuato il login.
Mittente, destinatario, titolo e testo | Sono i dati che compaiono nella mail inviata.
Allegato | è il file in formato PDF inviato. Attenzione! Il file dopo tempo potrebbe non essere più reperibile, oppure potrebbe essere cambiato, quindi questo dato deve essere considerato semplicemente indicativo senza garanzia di corrispondenza.
Stazione di invio | Indica la postazione da cui è parita la mail. Il dato è composto dal nome del computer seguito dal nome dell'utente
Errore | Questo campo risulta spuntato se è avvenuto un errore in fase di invio.
Messaggio di errore | Viene riportato il messaggio di errore riportato del server di posta.

I comandi speciali disponibili sono:

Cancella registrazioni è possibile effettuare la cancellazione cumulativa di una serie di registrazioni.

Le Stampe disponibili sono:

Stampa lista è una semplice stampa che elenca le mail inviate


La gestione dei messaggi tra utenti è un semplice sistema per scambiare messaggi tra gli utenti di Zefiro.

La procedura è disponibile solo se è stata avviata la gestione dell'autenticazione tra utenti. Ogni utente può mandare un messaggio ad ogni altro utente ed al destinatario compare un messaggio di avviso che è arrivato un messaggio.

Quando arriva un messaggio di notifica si può indicare che il messaggio è stato letto, se non si conferma la lettura il messaggio di notifica compare ogni volta che si apre Zefiro.

I dati da inserire sono:

Data e ora | Data ed ora in cui viene inviato il messaggio, vengono proposti i dati attuali.
Mittente | Inserire il mittente che invia il messaggio, viene proposto l'utente corrente.
Destinatario | Inserire il codice del destinatario
Tipo messaggio | Si possono classificare i messaggi per tipo.
Titolo e testo | Inserire l'oggetto del messaggio
Fatto | Inserire lo stato del messaggio, si può indicare che in messaggio è stato letto in modo che non compaia più tra le notifiche.
Risposta | Se si desidera si può indicare il codice del messaggio a cui si sta rispondendo.

I comandi speciali disponibili sono:

Messaggio letto | Con questo comando si contrassegna rapidamente il messaggio come letto.
Messaggi non letti | Seleziona i messaggi ancora la leggere, se ce ne sono.
Messaggi ricevuti | Seleziona tutti i messaggi ricevuti.
Messaggi inviati | Seleziona tutti i messaggi inviati.
Tutti i messaggi | Toglie tutte le selezioni permettendo di vedere tutti i messaggi.


Con questa procedura si possono inserire dati anagrafici e fiscali della ditta che possono essere utilizzati da varie procedura del programma di volta in volta richieste per legge, come ad esempio la generazione degli allegati Clienti/Fornitori, spesometro, fattura elettronica, ecc... spesso alcuni dati che vengono inseriti in questa posizione coincidono con i dati anagrafici inseriti nella licenza software.

Il cognome e nome del titolare o del rappresentante legale devono essere inseriti separati da una virgola, in questo modo il programma è in grado di riempire correttamente i campi in qui questo dato viene richiesto separato.

Alcuni codici richiesti possono essere trovati in base alle regole predisposte dalla PA, ad esempio il codice ATECO ed il codice REA si trovano nella visura camerale, ed il codice regime fiscale per la Fattura elettronica si trova nel sito della documentazione tecnica (di solito è 'RF01').

Il codice di esenzione indica se l'azienda è esente IVA per qualche motivo, ad esempio per coloro che scelgono il regime dei minimi o il regime forfettario. Se si inserisce un codice, verrà applicato in tutti i documenti di vendita e verrà esclusa la descrizione di "Documento di cortesia" dalle fatture poiché solitamente i regimi esenti sono anche esentati dalla fatturazione elettronica.


Con questa procedura è possibile configurare i parametri per la gestione della fattura elettronica

I dati da inserire sono:

Percorso files XML | Tutte le fatture in formato XML vengono memorizzate in una cartella del PC, in questo modo sarà possibile consultarle in qualsiasi momento.
Percorso files di acquisto. | Zefiro dispone di una procedura per l'importazione automatica delle fatture elettroniche di acquisto, è conveniente salvare le fatture in un unica posizione per poterle consultare in qualsiasi momento.
Percorso files temporanei | Quando vengono preparete le fatture elettroniche, viene fatta una copia di quelle in fase di spedizione in una catella temporanea in modo da attivare procedure automatiche oppure per facilitare l'invio manuale.
Percorso temporaneo files di acquisto | Si può decidere di depositare le fatture di acquisto da importare sempre nella stessa posizione, e qui si indica il percorso prescelto. Se si lascia il campo vuoto, il percorso prescelto verrà desciso dal sistema operativo in base alle ultime ricerche.
Tipo esportazione La spedizione dei documeti al "Sistema di Interscambio" può essere fatto in vari modi, anche utilizzando dei fornitori terzi. Zefiro può essere configurato per utilizzare diversi fornitori di servizi al momento sono disponibili le seguenti opzioni. . A quel punto è sufficiente trascinare i files nella pagina di invio per attivare la spedizione.
SEMPLICE | Viene aperta la cartella temporanea di invio per facilitare la spedizione manuale. Questa modalità consente di configurare nei parametri l'indirizzo del portale da aprire automaticamente.
CARTELLA SINCRONIZZATA | Alcuni portali utilizzano sistemi di concronizzazione automatica di cartelle del computer. Con questa modalità i files vengono depositati nella cartella e poi le applicazioni del portale si occuperanno di tutto il resto.
APRI FATTURAZIONE ARUBA | Vengono aperte la cartella temporanea di invio ed il portale di Aruba
Parametri di esportazione | A seconda del tipo di esportazione scelto, si possono aggiungere vari parametri di configurazione, come ad esempio le credenziali per accedere al servizio.
Registri split payment aggiuntivi | Solitamente viene utilizzato un solo registro IVA per i documenti verso la PA in regime iva di "Split Payment" in questa posizione è possibile inserire registri aggiuntivi che utilizzano tale modalità

Alla fine vengono fatti alcuni controlli per verificare la validità dei dati inseriti. I percorsi di memorizzazione dei files devono fare riferimento a posizione assolute nel disco e devono contenere sotto cartelle.


Questa procedura si usa raramente, e solitamente viene usata da personale tecnico.

Quando si avvia il programma Zefiro, viene letto un file di configurazione chiamato AGC.ini che contiene molti parametri opzionali per il programma. Se si fanno modifiche al file, si deve uscire la programma e rientrare per caricarlo nuovamente. Con questa procedura si può ricaricare la configurazione senza dover uscire e rientrare.


La gestione del cronologico dei contatti, che viene attivata con il modulo Gestione contatti, aggiunge a Zefiro la possibilità di essere utilizzato come CRM.

La sigla CRM significa in inglese "Customer relationship management" e quindi Gestione delle relazioni con la clientela. In Zefiro il concetto viene esteso anche alla gestione dei fornitori.

Il CRM si estrinseca nella memorizzazione di tutti i fatti rilevanti che accadono con il cliente, lo scopo è duplice: da una parte si rendono le informazioni patrimonio dell'azienda e non solo della persona che le ha raccolte evitando anche che siano dimenticate o perdute, ed dall'altra parte si permette di incrociare le informazioni per ricavare spunti per migliorare la strategia comunicativa.

Oltre alla gestione dei contatti, il modulo attiva anche la gestione documentale che permette di collegare ai clienti, ai fornitori ed agli articoli, i documenti elettronici che li riguardano, centralizzando in questo modo la memorizzazione dei documenti e facilitando la loro conservazione.

L'abbinamento di un programma gestionale con una soluzione CRM di fatto trasformano Zefiro in un ERP (acronimo che significa "Enterprise Resource Planning") che tradotto significa "Pianificatore delle risorse aziendali". Questo significa che Zefiro diventa il centro di controllo in cui reperire tutte le risorse aziendali, questo aiuta a stabilire il sistema di regole ed a pianificare le strategie aziendali.

Il sistema può ulteriormente essere potenziato abbinando a Zefiro il programma InfoBox che applica le stesse funzionalità ma permette di potenziare il settore marketing utilizzando archivi di clienti e fornitori separati.

La procedura alla fine è comunque molto semplice e fa uso di un numero limitato di tabelle e procedure, questa semplicità aumenta la facilità d'uso e favorisce l'adozione di tecniche e regole all'interno dell'azienda.

Le procedure disponibili sono:
Cronologico contatti è l'archivio in cui in inseriscono i contatti con clienti e fornitori.
è una procedura di utilità che permette di spedire e-mail a partire da una lista.
 Tipi di azione è una tabella che raggruppa movimenti in base al tipo di azione che viene intrapresa.
Gruppi o Campagne è una tabella che raggruppa i movimenti sulla base di campagne promozionali o gruppi di operazioni.
Argomenti è un tabella di raggruppamento dei movimenti di cronologico in base all'argomento in oggetto.
Agente predefinito si può inserire l'agente che viene proposto automaticamente nell'inserimento dei movimenti.


Questo archivio contiene la lista di tutti i contatti che intratteniamo con clienti e fornitori.

Spesso è comodo utilizzarlo direttamente dalla lista dei clienti o fornitori in cui di ciascun soggetto vengono presentati i contatti propri.

Da questa posizione invece oltre a poter inserire i dati, è interessante poter fare selezioni per incrociare dati di tipo diverso, ad esempio tutti i movimenti di uno stesso tipo, oppure dello stesso gruppo.

I dati da inserire sono:

Tipo anagrafica | Inserire se il codice che segue si riferisce ad un cliente o a un fornitore.
Codice anagrafica | Inserire il codice del cliente o del fornitore con cui avviene il contatto.
Tipo azione | In questa posizione si inserisce il codice del tipo di azione, nei tipi si possono catalogare le telefonate fatte o ricevute, le visite dai clienti ecc. Il pulsante a fianco permette di scegliere il tipo.
Gruppo o Campagna | Se si desidera si possono catalogare i movimenti in base ad un gruppo omogeneo a ad una campagna. Il pulsante permette di scegliere la lista dei gruppi.
Argomento | Questo codice serve a raggruppare la natura dell'argomento principale di cui si è discusso nel contatto. Il pulsante permette di scegliere la lista degli argomenti.
Apri articolo | Questo pulsante serve per collegare gli argomenti agli articoli di magazzino. Premendolo si apre la lista degli articoli invece della lista degli argomenti, se viene confermato un articolo, viene anche fatta una ricerca per controllare se l'articolo scelto è anche presente negli argomenti ed in caso negativo viene aggiunto automaticamente.
Valore | Se si desidera si può inserire un valore che serve a qualificare la registrazione. Ad esempio si può inserire il fatturato di un determinato periodo, oppure l'importo di un insoluto o anche un punteggio (ad esempio da 1 a 10) dell'esito di una visita.
Descrizione | Si inserisce il titolo dell'argomento trattato
Codice utente | Inserire il codice dell'utente o agente che ha avuto il contatto.
Persona | Inserire il nome della persona con cui si ha parlato.
Data | Inserire la data del contatto.
Data scadenza | Si può inserire la scadenza dei contatti pianificati.
Ora | Inserire l'ora in cui è avvenuto un determinato contatto oppure l'ora di scadenza per gli contatti da fare.
Ora fine | Se si desidera si può inserire l'ora in cui è finito o in cui si prevede che sarà finito il contatto, premendo il pulsante si può inserire il tempo trascorso.
Stato avanzamento | Se si desidera si può indicare che il contatto deve ancora avvenire.
Note | Si può inserire la descrizione estesa del contatto.
Codice | Il programma assegna un codice automatico a questa registrazione, il codice serve per identificare la scrittura in modo univoco.

I comandi speciali disponibili sono:

Duplica cronologico | Con questa voce si può duplicare un cronologico, è utile quando si devono inserire dati ripetitivi per più clienti.
Invia eMail

Questo comando permette di inviare rapidamente una mail ad un destinatario, solitamente viene generata anche una riga di cronologico, però si può anche omettere.

Se si desidera si possono anche predisporre alcuni testi standard che possono essere richiamati velocemente.

Vengono chiesti:
Tipo e codice anagrafica | Si sceglie il tipo di anagrafica tra clienti e fornitori ed il codice del destinatario.
Indirizzo e-mail | Inserire l'indirizzo di spedizione, premendo il pulsante si può scegliere dalla lista delle e-mail dei contatti del cliente o fornitore.
Descrizione | Inserire il titolo (oggetto) della e-mail.
Testo | Inserire il testo della mail. Con il pulsante "leggi testo" si può leggere il testo tra una lista di testi preparati in precedenza. Per i dettagli su come preparare i testi chiedere al personale tecnico della Compusoft.
Allegati | Si può inserire una lista di files da allegare alla e-mail. I pulsanti a fianco "Allega" e "Svuota" permettono di scegliere gli allegati da inviare.
Genera cronologico | Con questa spunta si può decidere se generare una riga di cronologico oppure no.
Informazioni cronologico | I dati che seguono sono rilevanti solo se si sceglie di generare il cronologico e contengono gli stessi dati che poi vengono trovati nella riga di cronologico memorizzata.
Documenti | Con questa voce si accede alla archiviazione documentale che permette di legare specifici documenti elettronici a questa registrazione.
Spunta cronologico | Viene attivata la spunta del cronologico, serve anche per fare stampe filtrate, ma soprattutto per la generazione di liste.
Genera lista

Questo comando molto importante permette di generare una lista contenente i dati delle anagrafiche. Oltre che nel cronologico è disponibile anche nei clienti e nei fornitori

Le liste vengono generate in formati standard riconosciuti da molti programmi e possono essere utilizzate per effettuare operazioni sui dati scelti.

Uno degli utilizzi più comuni delle liste è per l'invio automatico di e-mail con l'apposita procedura.

Vengono chiesti:
Tipo file esportazione | Si può scegliere tra Testo delimitato da tabulatori, Testo CSV ed Excel. I primi due sono formati standard riconosciuti da molti programmi che possono essere usati anche per inviare e-mail con la procedura apposita.
Esclusione contatti vuoti | Si possono escludere dalla lista le anagrafiche che non hanno il telefono, il fax oppure l'e-mail.
Tipo selezione | Se è attivata la gestione delle spunte, si può scegliere se includere nella lista i spuntati, i non spuntati o tutti.
Genera cronologico | Si può decidere se generare oltre alla lista anche un movimento di cronologico per ciascuna anagrafica compresa nella lista. Questo è utile per tenere traccia delle azioni che vengono effettuate con la lista generata.
Campi movimenti cronologico | Se si genera i movimenti, è necessario inserire tutti i dati per i movimenti.


L'agenda permette di pianificare gli impegni memorizzati nel cronologico come "da fare" ed "urgenti".

La procedura funziona nella modalità di gestione documenti. Dopo aver inserito i dati di testata si può accedere agli impegni pianificati e fare tutte le operazioni di modifica, aggiunta o cancellazione.

I dati da inserire nella testata sono:

Data inizio | Inserire la data di inizio della visualizzazione del planning.
Visualizza scaduti | Se si inserisce questa spunta, vengono presentati anche gli impegni precedenti e successivi alla finestra temporale prevista.
Solo urgenti | Con questa spunta si escludono gli impegni non urgenti.
Agente/Utente | Si può scegliere di limitare la ricerca dei soli impegni di un singolo utente.
Altre selezioni | Se si desidera si possono effettuare altre selezioni ad esempio i soli impegni riferiti ad una campagna o argomento.
Giorni | Inserire il numero di giorni da visualizzare come finestra temporale. Vengono proposti automaticamente 60 giorni.

Dopo aver inserito i dati di testata si passa alle righe, si possono scorrere gli appuntamenti, effettuare modifiche, cancellazioni ed inserimenti.

Per facilitare la lettura i giorni del weekend vengono visualizzati in un altro colore e viene visualizzata solo l'ora degli appuntamenti successivi al primo.

Se si desidera si può fare la stampa dell'agenda selezionata, con la possibilità di scegliere ulteriormente i giorni da stampare.

Se si desidera si può fare la stampa dell'agenda selezionata, con la possibilità di scegliere ulteriormente i giorni da stampare.

I comandi speciali disponibili sono:

Telefoni e contatti | Si possono aprire rapidamente i contatti del cliente o fornitore.
Cronologico | Con questo comando si apre tutto il cronologico del cliente o fornitore della riga selezionata.
Cambia stato | Si usa per cambiare velocemente lo stato di un cronologico.


Questa procedura permette di mandare automaticamente la stessa e-mail a tutti i destinatari compresi in una lista. Vengono riconosciuti automaticamente i formati di files generati dalla procedura di genera liste. In questo senso si può dire che esiste un legame stretto tra la gestione delle liste e l'invio di e-mail.

Questa procedura funziona solo se è stata configurato correttamente il file sendmail.ini che contiene i dati del account di posta elettronica. Per maggiori ragguagli chiedere informazioni al personale tecnico della Compusoft.

I dati da inserire sono:

Lista destinatari | Si deve inserire il nome del file che contiene la lista dei destinatari, vengono riconosciuti automaticamente i formati di Files di testo e di Files CSV generati dalla procedura di genera liste. Il tipo viene scelto in base all'estensione.
Oggetto | Inserire l'oggetto della comunicazione
Testo | Inserire il testo della e-mail.
Allegati | Se si desidera si possono inserire un numero variabile di allegati.

Alla fine se tutti i dati sono corretti, vengono inviate le e-mail, questa operazione può richiedere anche molto tempo se ci sono allegati di grandi dimensioni o se ci sono molti destinatari. l'avanzamento della spedizione viene segnalata nella parte bassa della finestra.

I formati di file riconosciuti sono i files di testo in cui ogni riga contiene campi separati dal carattere di tabulazione, oppure files in formato CSV in cui i campi sono racchiusi tra doppi apici (") e sono separati da virgole (,).
In ogni caso la prima riga contiene i nomi dei campi e le successive contengono i dati.
Perché il file sia riconosciuto è necessario che sia presente un campo di nome EML_CONTATTO che indica l'indirizzo e-mail di ogni destinatario.


I tipi di azione servono per catalogare i movimenti di cronologico in base al tipo di contatto che avviene, ad esempio telefonata fatta o ricevuta, fax spedito o ricevuto ecc...

I dati da inserire sono:

Codice | Inserire il codice univoco di tre caratteri che identifica il tipo. Consigliamo di pianificare con attenzione il sistema di codifica per raggruppare alfabeticamente tra di loro i tipi simili. Ad esempio si potrebbe dedicare il primo carattere per separare le azioni fatte da quelle ricevute.
Descrizione | Inserire la descrizione del tipo.
Note | Se si desidera si può inserire una annotazione aggiuntiva.


I gruppi servono per catalogare i movimenti di cronologico sulla base di campagne promozionali o per gruppi di operazioni.

I dati da inserire sono:

Codice | Inserire il codice univoco di tre caratteri che identifica il gruppo.
Descrizione | Inserire la descrizione del tipo.
Note | Se si desidera si può inserire una annotazione aggiuntiva.


I gruppi servono per catalogare i movimenti di cronologico sulla base dell'argomento prevalente che è stato trattato.

I dati da inserire sono:

Codice | Inserire il codice univoco che identifica l'argomento.
Descrizione | Inserire la descrizione del tipo.
Articolo | Questa spunta viene attivata automaticamente quando si importa un articolo, serve per eseguire selezioni rapide sugli argomenti che sono legati agli articoli.
Non attivo | Quando un argomento diventa obsoleto è possibile spuntarlo come non attivo, in questo modo verrà automaticamente escluso dalle liste di ricerca. Sarà sempre possibile però renderlo visibile con le opportune selezioni.
Note | Se si desidera si può inserire una annotazione aggiuntiva.

I comandi speciali disponibili sono:

Disattiva/Attiva | Questo comando serve per attivare o disattivare l'argomento in modo veloce.
Seleziona attivi | Gli argomenti non attivi vengono automaticamente esclusi dalla selezione, con questo comando è possibile scegliere se visualizzarli oppure no.
Seleziona articoli | Questo comando serve per effettuare una selezione rapida degli argomenti che sono anche articoli di magazzino.


Con questa procedura si può inserire l'agente che viene proposto automaticamente nell'inserimento dei movimenti, questo evita l'inserimento di dati ripetitivi e diminuisce il rischio di errori di digitazione.


 Testo non disponibile...


Il modulo "Impegni in scadenza" si occupa di fornire un promemoria per le scadenze generiche a cui l'azienda deve fare fronte.

Solitamente le scadenze sono un costo aziendale che è necessario sostenere, esempi di scadenze di questo tipo sono: Tutte le scadenze fiscali, le scadenze legate alla gestione dei dipendenti, la manutenzione di macchine dell'azienda ed anche la convocazione di riunioni aziendali.

Gli impegni in scadenza, non devono essere confusi con le scadenze di clienti e fornitori che sono una cosa completamente diversa, quelli infatti riguardano gli incassi e pagamenti a fronte di riscontri contabili, questi invece si occupano semplicemente di fornire un promemoria per gli impegni che l'azienda deve sostenere.

Essendo che solitamente questo tipo di impegni sono costi che l'azienda sostiene, viene anche fornita una gestione dei costi che può essere utile per realizzare consuntivi utili realizzare analisi di costi.

Se si entra nel programma identificando il codice utente/agente o perchè è stata abilitata la gestione della sicurezza, oppure perché sono stati configurati gli utenti della stazione. Avviene la notifica automatica delle prossime scadenze, cioè quelle che sono già scadute, oppure che scadranno entro i giorni di preavviso.

E' comunque possibile configurare il programma per fare in modo che invece far comparire la notifica delle scadenze immninenti, venga mandata una mail all'agente incaricato con la lista delle scadenze imminenti. Per fare questo è necessario modificare il parametro SCTNOTIFICHE nel file AGC.INI

Le procedure disponibili sono:
Scadenze Impegni vengono elencate le scadenze non ancora evase.
Pianifica scadenze si possono stabilire i meccanismi di ripetitività delle scadenze per effettuare la generazione automatica.
Tutti gli impegni vengono elencate tutte le scadenze siano esse evase e non evase.
Gruppi di scadenze le scadenze possono essere raggruppate per tipologia.
Generazione scadenze questa procedura genera automaticamente le scadenze a partite dalle scadenze
Scadenze imminenti si possono far comparire le scadenze imminenti o scadute di un singolo agente.


L'archivio degli impegni in scadenza è unico, ma per convenienza operativa ha quattro voci di menù per visualizzare i diversi tipi di dati che può contenere.

La prima distinzione è tra "scadenze impegni" e "pianifica scadenze", le prime sono le scadenze effettive che bisogna evadere, le seconde contengono meccanismi per generare automaticamente scadenze ripetitive.

Poi la voce "tutti gli impegni" contiene oltre agli impegni in scadenza non evasi anche quelli già evasi. La conservazione dei quali può servire per analisi dei costi.

Ed infine la voce "Scadenze imminenti" fa vedere per ogni agente gli impegni prossimi alla scadenze e quelli già scaduti.

I dati da inserire in impegni in scadenza ed in tutti gli impegni sono:

Data scadenza | Si inserisce la data ultima entro la quale si deve evadere l'impegno.
Giorni preavviso | Indicare il numero di giorni entro cui avviene la notifica automatica degli impegni in scadenza.
Codice agente | Indicare l'agente/utente incaricato di evadere la scadenza. A questo agente verrà notificata automaticamente entro i giorni di preavviso.
Codice gruppo | Indicare il gruppo a cui appartiene questo impegno, questo serve soprattutto per l'analisi dei costi.
Riferimento | Se necessario si può inserire una sigla per raggruppare gli impegni secondo criteri aggiuntivi a quello del codice gruppo, questo può essere utile ad esempio per stampare solo gli impegni che hanno un certo riferimento.
Descrizione | Serve per descrivere l'impegno da assolvere.
Tipo anagrafica | Si può abbinare alla scadenza un cliente o un fornitore, in questa posizione si indica il tipo di anagrafica.
Codice anagrafica | Inserire il codice del cliente o fornitore.
Codice commessa | Se è stato abilitata la gestione delle commesse, si può inserire la commessa di riferimento di questa scadenza.
Documento | Si può inserire un documento di magazzino abbinato a questa scadenza, il documento viene solo tenuto in memoria, e verrà generato nel momento in cui si evade la scadenza. Su questo documento vengono fatti vari controlli come ad esempio la compatibilità con il tipo di anagrafica, il codice anagrafico la congruenza dei codici iva ecc... Dopo aver inserito il documento si può modificare e cancellare.
Note | Se si desidera si può inserire un testo che spiega in modo esaustivo la scadenza.
Notifica 1 e Notifica 2 | Si può configurare il programma per spedire delle mail di notifica per le scadenze imminenti e per quelle già scadute. Le mail vengono inviate quando ci sono le condizioni, nel momento che viene aperto il programma e dopo aver inviato le mail vengono messe le spunte di notifica.
Data evasione | Inserire la data in cui l'impegno viene evaso. Le voci che hanno inserita questa data vengono tolte dalla lista delle scadenze ma permangono nella lista di tutti gli impegni.
Agente evasione | Inserire il codice dell'agente che materialmente ha evaso la scadenza.
Note di evasione | Se si desidera si può inserire alcune note su come è stata evasa la scadenza.
Codice | E' il codice univoco che identifica l'impegno, viene gestito automaticamente.
Costi | Questo pulsante serve per la inserire la gestione dei costi associati all'impegno. Sono dati non obbligatori che vanno inseriti solo se si desidera gestire i costi.

Il pulsante costi apre una lista che permette di inserire tutti i costi associati alla spesa.

I costi possono essere inseriti nelle scadenze pianificate e poi si possono modificare nelle scadenze per effettuare ordini a fornitori o per inserire i costi consuntivi.

Per alcuni tipi di scadenza, ad esempio per la manutenzione di macchine, spesso è necessario acquistare i materiali necessari per eseguire il lavoro, per questo motivo dalla gestione dei costi è possibile effettuare automaticamente gli ordini ai fornitori.

La generazione automatica degli ordini avviene spuntando prima le voci di spesa relative a ciascun fornitore e poi chiamando la procedura di generazione ordini che chiede il codice del fornitore, data e tipo di documento.

Il dati da inserire sono:

Codice articolo | Questo dato viene chiesto solo se si dispone del modulo di magazzino. Indica il codice dell'articolo impiegato per evadere la scadenza. Potrebbero anche essere ore di lavoro del manutentore.
Note | Si può inserire la descrizione del costo, se non c'è il codice articolo, la descrizione è obbligatoria.
Quantità | Inserire la quantità
Costo | Inserire il costo unitario che moltiplicato per la quantità indica il costo totale della voce di spesa.
Codice fornitore e data e num. ordine. | Questi dati solitamente vengono inseriti automaticamente dalla procedura di generazione ordini e servono come riferimento agli ordini fatti.

I comandi speciali disponibili sono:

Fatto | Per le scadenze non ancora evase, con questa procedura si possono inserire i dati di evasione.
Apri documento | Se un documento è stato inserito e generato è possibile aprirlo per esaminarlo o modificarlo. Questa procedura funziona solo se gli estremi del documento (data, numero, registro, anagrafica) corrispondono a quelli inseriti in fase di generazione.
Genera / Rigenera | Questa procedura consente di generare o rigenerare un documento che è stato inserito in precedenza.
Duplica scadenza | Alle volte può essere utile duplicare singole voci di scadenza ripetitive che richiedono poche modifiche.
Spunta scadenze | In questo archivio è abilitata la gestione delle spunte che permette di scegliere solo alcune voci ad esempio per fare stampe selettive, o anche per evadere cumulativamente diverse scadenze.
>Apri cartella documenti gruppo | Questo comando permette di aprire una cartella del computer in cui è possibile inserire documenti legati al gruppo di apparteneza di questa scadenza.

Le Stampe disponibili sono:

Lista scadenze impegni | Viene presentata la lista degli impegni.
Lista dettagliata | Con questa stampa si possono stampare anche i dettagli di costo di ciascun impegno.


Questa procedura permette di stampare la lista delle scadenze, oppure il giornale delle scadenze evase raggruppate per giorno.

E' utile per pianificare i lavori da fare, oppure per stampare un resoconto delle cose fatte.

I dati da inserire sono:

Tipo stampa | Si può stampare la lista delle scadenze oppure il giornale di lavori fatti.
Da data a data | Si possono inserire i limiti di data entro per la stampa
Gruppo | Se si inserisce un gruppo verranno stampati solo i movimenti di quel gruppo e di tutti i gruppi figli.
Agente | Se si inserisce l'agente vengono stampati solo le scadenze assegnate a quel agente oppure le scadenze evase da quel agente.

Alla fine viene eseguita la stampa secondo i parametri previsti.


La pianificazione delle scadenze consente di inserire le informazioni sulle scadenze ripetitive che possono essere generate con la procedura di generazione scadenze.

I dati da inserire sono molto simili a quelli contenuti in scadenze impegni per questo motivo vengono evidenziate solo le differenze rispetto a quelle.

I dati da inserire sono:

Data inizio calcolo | Inserire da data da cui partire per fare il calcolo delle date di scadenza degli impegni.
Tipo di calcolo | Il calcolo per la generazione delle scadenze può essere fatto a mesi oppure a settimane. Se una scadenza si ripete ogni anno come ad esempio il pagamento dell'iscrizione alla camera di commercio, si inserisce il calcolo a mesi con ripetitività 12. Viceversa si possono inserire con tipo calcolo a settimane le scadenze che vanno evase ogni lunedì oppure ogni 2 martedì.
Ripetitività | Indica la ripetitività rispetto ai mesi o alle settimane con cui si devono generare le scadenza.
Altri dati... | Tutti gli altri dati sono comuni con le scadenze impegni.

I comandi speciali disponibili sono:

Oltre ai comandi di scadenze impegni è disponibile la voce per generare le scadenze che a differenza della procedura di generazione scadenze genera le scadenze per una singola voce.
Questa voce inoltre consente di generare le scadenze ai sottogruppi invece che al gruppo dichiarato. Ad esempio se preparo una pianificazione per il gruppo A0100 e nei gruppi dichiaro che il gruppo A0101 ha come gruppo padre il gruppo A0100, se metto la spunta viene generata la scadenza per il gruppo A0101 (e tutti gli altri sottogruppi), altrimenti viene generata la scandeza solo per il gruppo A0100


Questa voce è esattamente identica a Scadenze Impegni la sola differenza consiste nel fatto che vengono visualizzati oltre agli impegni non ancora scaduti anche quelli evasi.


Questa tabella permette di inserire le voci di raggruppamento degli impegni in base alla loro tipologia.

La motivazione più interessante per utilizzare questo raggruppamento consiste nel fatto che si possono stampare schede per ogni gruppo per la determinazione di analisi di costi.

I dati da inserire sono:

Codice | Inserire il codice univoco.
Descrizione | Inserire la descrizione del gruppo
Tipo | E' un ulteriore metodo di raggruppamento.
Agente preferenziale | Inserire il codice agente/utente che si desidera che venga proposto automaticamente quando si sceglie questo gruppo.
Codice gruppo padre | Si può inserire il codice di un gruppo di qui questo gruppo è figlio. In questo modo si possono costruire gerarchie di gruppi, questo è utile quando si stampa la lista degli impegni, perché se si sceglie un codice gruppo vengono stampate le scadenze anche di tutti i gruppi sottostanti.
Campo utente 1,2,3 | Si possono inserire fino a 3 descrizioni libere per identificare il gruppo
Numero utente 1,2,3 | Si possono inserire fino a 3 numeri liberi che hanno attinenza con il gruppo
Data utente 1,2,3 | Si possono inserire fino a 3 date libere che hanno attinenza con il gruppo
Note | Se si desidera si possono inserire note aggiuntive.
Non in uso | Quando un gruppo di scadenze non serve più si può attivare questa spunta che permette di nascondere automaticamente i gruppi che non sono più in uso.

I comandi speciali disponibili sono:

Spunta gruppi scadenze | Si possono attivare le spunte per effettuare stampe sui grupp selezionati
Duplica gruppo scadenze | Si può duplicare un gruppo per inserire velocemente gruppi simili.
>Apri cartella gruppo scadenze | Questo comando permette di aprire una cartella del computer in cui è possibile inserire documenti legati a questo gruppo. L'albero delle cartelle segue le dipendenze tra gruppi, vengono perciò create tutte le cartelle padre dei gruppi padre. Il punto di partenza delle cartelle può essere configurato nel file AGC.INI

Le Stampe disponibili sono:

Lista gruppi scadenza impegni | Viene stampata una semplice lista.
Schede gruppi | Permette di stampare una scheda dei costi sostenuti per questo gruppo.
Albero gruppi impegni | Viene stampata la lista dei codici organizzata in forma gerarchica.


Questa procedura effettua la generazione automatica di tutte le scadenze pianificate entro le date inserite.

Vengono lette tutte le scadenze pianificate e se esistono date pianificate tra quelle inserite vengono generate le scadenze.

Se si ripete l'operazione più volte per le stesse date, il sistema controlla ed evita la duplicazione di scadenze.

Se serve generare le scadenze per una sola voce pianificata, si può chamare la procedura da pianifica scadenze che prende in considerazione solo la voce corrente ed ha il vantaggio di generare le scadenze per i sottogruppi.


Questa voce è esattamente identica a Scadenze Impegni la differenza è che vengono visualizzate solo le scadenze imminenti dell'agente scelto e quelle già scadute.


La gestione della qualità abbinata a Zefiro consiste in alcune tabelle ed alcune procedure che aiutano a trattare i dati necessari per la certificazione ISO9001

Le regole e le norme da adottare per ottenere e confermare la certificazione non sono oggetto di questa trattazione e solitamente vengono messe a punto avvalendosi di consulenti specializzati.

Viene attivata la gestione delle Non conformità e delle Azioni correttive ed Azioni preventive con stampa di schede e registri.

Viene anche attivato un sistema per la valutazione dei fornitori abbinato alla gestione degli ordini. La valutazione consiste in una stima di tipo qualitativo ed è arbitraria, è compito dei responsabili stabilire la frequenza e le modalità del rilevamento.

Le procedure disponibili sono:
Non conformità in questa tabella si inseriscono i dati sulle non conformità rilevate.
Azioni correttive le non conformità possono dare origine ad azioni correttive e questa tabella serve per monitorare l'andamento di tali azioni.
Azioni preventive sono molto simili alle azioni correttive, ma a differenza di quest'ultime, non hanno origine da una non conformità ma da una iniziativa volta a prevenire problemi in seguito.
Valutazione dei fornitori in questa tabella si inseriscono valutazioni di tipo qualitativo sulle forniture dei fornitori valutati.
Questionari clienti Periodicamente vengono inviati ai clienti questionari da compilare che servono per ottimizzare il livello qualitativo dei servizi proposti.
Argomenti dei questionari I questionari che vengono inviati ai clienti per la compilazione nel tempo possono subire modificazioni per adattarsi alle varie necessità, in questa tabella si inseriscono le descrizioni dei quesiti da porre.
Registro NC e Azioni C/P questa stampa consente di tenere un registro delle Non Conformità e delle Azioni Correttive e Preventive in ordine di data.
Registro valutazioni questa stampa serve per riepilogare le valutazioni fatte per i fornitori valutati e quindi per decidere il loro impiego.


Una non conformità si verifica quando avviene un evento che contraddice i manuali di qualità. L'evento deve essere monitorato e se necessario deve dare origini ad Azioni correttive.

I dati da inserire sono:

Codice | Viene proposto un codice automatico formato dalle ultime due cifre dell'anno corrente seguite da un progressivo numerico.
Origine | La non conformità può avere origine da diverse situazioni, alcune di queste possono essere interne, oppure da problemi con fornitori o da reclami di clienti
Data rilievo | Inserire la data in cui è stata rilevata la non conformità
Codice cliente o fornitore | Questo dato viene richiesto se l'origine della non conformità implica clienti o fornitori.
Agente origine | Se la non conformità è stata generata da un operatore, si può inserire il codice.
Riferiementi esterni | Si possono inserire eventuali riferimenti, ad esempio il n. del documento del fornitore.
Fornitore origine | Se nella non conformità è coinvolto un fornitore, si può inserire il codice.
Agente rilievo | Inserire il codice dell'operatore che ha eseguito il primo rilevamento.
Richiede azioni correttive | A seconda della gravità delle non conformità si può decidere se avviare una azione correttiva o se è sufficiente inserire la segnalazione per le non conformità di lieve entità.
Descrizione | Si inserisce un breve titolo dalla non conformità
Codice articolo | Questo dato viene chiesto solo se è attivo il modulo di gestione del magazzino, e permette di legare la non conformità ad un prodotto specifico.
Data chiusura | Per le non conformità che non richiedono azioni correttive si indica la data in cui viene chiusa la non conformità, se invece è presente una azione correttiva questo dato ed anche i successivi vengono aggiornati automaticamente.
Agente chiusura | Indicare l'agente che effettua la chiusura.
Esito | Indicare l'esito delle azioni volte a risolvere la non conformità
Costo stimato | Si può inserire una indicazione del costo sostenuto per risolvere il problema.
Descrizione estesa | Si può descrivere il problema con maggiore dettaglio
Motivazione del problema | Se necessario si può indicare la causa che ha generato la non conformità
Note operative | Si possono inserire note che descrivono le metodiche adottate per la risoluzione del problema.
Descrizione esito | Si può inserire una nota descrittiva sull'esito della soluzione del problema.

Le Stampe disponibili sono:

Lista non conformità E' una semplice lista dei dati inseriti


Una azione correttiva serve a risolvere un problema generato da una non conformità

Le azioni correttive si articolano in più fasi. In un primo momento ci sono azioni a breve termine che servono a tamponare urgentemente il problema, di seguito ci possono essere azioni a lungo termine che sono operazioni messe in atto per evitare che il problema si ripresenti in seguito. Alla fine delle azioni c'è una fase di verifica che serve per controllare se le contromisure adottate sono state efficaci, infine c'è una fase di reporting con la quale si portano a conoscenza delle persone implicate i risultati delle azioni intraprese per stabilire la metodica adeguata e risolvere il problema.

Ad ogni fase operativa viene assegnata una tempistica che serve per darsi un termine entro il quale l'azione deve essere portata a compimento.

Per ogni fase viene indicato il codice dell'addetto che ne è responsabile. In modo da personalizzare l'impegno che viene preso.

Quando si inserisce una nuova azione correttiva viene richiesto il codice della non conformità a cui fa riferimento.

I dati da inserire sono:

Codice | Viene proposto automaticamente un codice composto da due cifre dell'anno in corso seguire da un progressivo numerico.
Codice non conformità | Viene visualizzato il codice della non conformità a cui si riferisce l'azione correttiva.
Data apertura | E' la data in cui è stata avviata l'azione.
Agente apertura | Inserire il codice dell'operatore che ha aperto l'azione.
Descrizione | Inserire il titolo dell'azione che si sta avviando.
Codice articolo | Serve per indicare l'eventuale prodotto implicato. Questo dato viene chiesto solo se è attivata la procedura di magazzino.
Descrizione estesa | Si può descrivere il problema con maggiore dettaglio
Note operative | Si possono inserire note che descrivono le metodiche adottate per la risoluzione del problema.
Azioni a breve termine,
Azioni a lungo termine,
Operazioni di verifica,
Distribuzione report 		Per ciascuna di queste fasi, si inseriscono alcune informazioni:
Descrizione | Si inserisce la descrizione dell'azione che deve essere svolta.
Data inizio | Si inserisce la data in cui inizia la fase.
Giorni previsti | E' una stima dei giorni necessari per portare a termine l'azione
Data chiusura | Si inserisce la data in cui effettivamente l'operazione è stata portata a termine, in confronto tra questa data ed i giorni stimati da la misura dell'efficenza realizzata.
Agente | Si inserisce il codice dell'operatore responsabile della fase.
Stato avanzamento | Si inserisce un codice che indica la fase in cui si trova l'azione.
Data chiusura | Si inserisce la data in cui è stata portata a termine l'azione.
Esito | Si inserisce un codice che indica il grado di soddisfazione rispetto al risultato dell'azione.
Agente chiusura | Si indica l'operatore che ha chiuso l'azione.
Descrizione esito | Si può descrivere in maggiore dettaglio l'esito e le considerazioni finali.
Costo stimato | Se si desidera si può inserire una indicazione del costo sostenuto per realizzare l'azione.

Le Stampe disponibili sono:

Lista azioni | E' una lista che riporta i dati salienti delle azioni.
Scheda azione | Per ogni azione si può stampare una scheda dettagliata di ciò che è stato fatto.


Le azioni preventive sono esattamente identiche nella modalità operative alle azioni correttive, ma a differenza di queste non prendono origine da una non conformità

Vengono invece originate da una iniziativa autonoma volta a prevenire problemi che potrebbero presentarsi in seguito.

Per i dettagli sui dati da inserire si può consultare la guida alle azioni correttive


La valutazione dei fornitori serve per stabilire quali sono i fornitori affidabili e che quindi vogliamo utilizzare per i nostri fabbisogni.

La valutazione richiede che siano stati stabiliti metodi di controllo il più possibile oggettivi in modo da ottenere dati reali. La valutazione può essere quindi una procedura complicata che può subire variazioni anche grandi a seconda del tipo di fornitura ed a seconda del prodotto realizzato dalla azienda.

Per fornire un ausilio operativo che facilita la gestione delle valutazioni abbiamo comunque deciso di fornire un sistema di valutazione basato su criteri qualitativi. Questo tipo di valutazione è comunque arbitrario e deve essere assoggettata ad una metodica rigorosa per ottenere dati affidabili.

Nell'anagrafica dei fornitori sono stati aggiunti alcuni campi che servono per questo tipo di gestione, in particolare il campo tipo valutazione serve per indicare se un fornitore è sottoposto a valutazione oppure no. Il criterio per escludere fornitori dalla valutazione può essere la marginalità, oppure il fatto che siamo obbligati ad utilizzarlo per vari motivi (esistenza di contratti, franchising ecc...)

La principale fonte di valutazione è l'evasione degli ordini. In fase di evasione si presenta una videata in cui si chiede se si desidera inserire la valutazione. In caso affermativo viene inserito il dato in questa tabella.

Si può però inserire il dato manualmente, oppure si possono modificare valutazioni esistenti nel caso la prima valutazione non sia stata precisa in fase di evasione.

I dati da inserire sono:

Codice | Viene proposto automaticamente un codice composto da due cifre dell'anno in corso seguite da un progressivo numerico.
Data rilevamento | E' la data in cui viene fatto il rilevamento.
Rilevanza | E' un fattore moltiplicativo che indica l'importanza attribuita a questa valutazione. Ad esempio se vengono fatte due valutazione in cui la prima ha rilevanza 1 e la seconda ha rilevanza 5 a tutti gli effetti è come se si fossero fatte 6 rilevazioni.
Codice fornitore | Inserire il codice del fornitore rilevato
Data e numero documento | Inserire il numero del documento interessato al rilevamento, di solito è il numero dell'ordine.
Agente rilievo | Inserire il codice del operatore che ha effettuato la valutazione.
Valutazioni Si inseriscono quattro valutazioni sulla fornitura, ogni valutazione può assumere un valore da 1 a 5, maggiore è il punteggio e migliore è la valutazione il significato cambia se il fornitore è un fornitore di servizi o prodotti, i parametri sono:
  • Costo
  • Conformità / Qualità
  • Tempi consegna / Velocità
  • Pagamento / Disponibilità


Periodicamente vengono inviati ai clienti questionari da compilare che servono per ottimizzare il livello qualitativo dei servizi proposti.

I questionari sono composti da un massimo di 10 domande a qui il cliente risponde assegnando un punteggio da 0 a 5, inoltre per ogni domanda può assegnare la rilevanza (peso) che essa ha nel proprio giudizio. Il valore della rilevanza va da 1 a 9, dove con 5 si assume la rilevanza media, se il cliente non esprime la valutazione e quindi assegna valore zero, si assume che abbia valore 5.

Il cliente ha inoltre la possibilità di esprimere alcuni suggerimenti.

I dati da inserire sono:

Codice | Viene assegnato automaticamente un codice numerico composto dalle ultime due cifre dell'anno corrente seguite da un progressivo numerico.
Data invio | Viene inserita la data in cui viene inviato il questionaro al cliente.
Codice cliente | E' il codice del cliente che viene rilevato.
Domande da 1 a 10 | Si possono esprimere fino a 10 domande per ogni questonario. Le domande possono variare tra una rilevazione e la successiva e tra un tipo di cliente ed un altro. Per ciascuna domanda si inserisce il Peso e la valutazione che fa il cliente.
Data risposta | Si inserisce la data in cui si ottiene la risposta del cliente. Se il cliente non risponde si lascia in bianco.
Suggerimenti del cliente | Il cliente ha facoltà di esprimere dei suggerimenti.

I comandi speciali disponibili sono:

Stampa questionario | Permette di stampare un singolo questionario. Se è stata attivata la gestione dell'invio automatico della posta, scegliendo l'opzione invio e-mail vengono proposti automaticamente l'indirizzo del cliente ed il testo della mail da inviare.
Duplica questionario | I quesitonari che vengono inviati ai vari clienti spesso sono uguali, per questo motivo viene proposta la possibilità di duplicare un questionario con tutte le sue domande.
Spunta questionari | Se si desidera si possono spuntare i questionari per fare stampe mirate di solo una parte dei dati.

Le Stampe disponibili sono:

Lista questionari | Questa stampa oltre ad elencare i questionari, calcola la media dei punteggi tenendo in considerazione anche la rilevanza delle domande. Inoltre stampa un riepilogo con i punteggi e le rilevanze di tutte le domande.
Stampa questionario | Permette di stampare un singolo questionario


I questionari che vengono inviati ai clienti, nel tempo possono variare in funzione di affinamenti delle richieste basati su risposte precedenti, oppure a seconda della tipologia di clienti si possono predisporre questionari diversi.

Per questo motivo esiste la tabella degli argomenti dei questionari in cui vengono inseriti i vari quesiti che nel tempo vengono posti. Con questo sistema nella stampa della lista dei questionari si possono calcolare i punteggi per ogni tipo di quesito

I dati da inserire sono:

Codice | E' un codice numerico assegnato automaticamente
Descrizione | Si inserisce la descrizione che verrà riportata nel questionario.
Note | Se si desidera si può inserire una annotazione.


Il registro delle non conformità e delle Azioni Correttive e Preventive presenta una lista ordinata per data delle azioni intraprese e delle non conformità che si sono verificate.

Per ciascun tipo di dato vengono presentate


Nel menù della contabilità sono contenute tutte le voci necessarie per la gestione contabile, le voci disponibili sono:

Primanota serve per inserire le registrazioni contabili,
Schede contabili permette di visualizzare e stampare le schede contabili,
Partite contabili permette di visualizzare e stampare le schede delle partite,
Stampe contiene voci per eseguire tutte le stampe contabili,
Gestione Cespiti serve per la gestione dei beni ammortizzabili,
Ritenute d'acconto permette di gestire gli obblighidi legge nei confronti dei soggetti a ritenuta,
Fatturazione semplice viene utilizzata da coloro che non necessitano della gestione completa di magazzino,
Preferenze permette di impostare alcuni parametri di configurazione,
Elaborazioni contiene voci utilizzate raramente che eseguono operazioni automatiche sui dati inseriti.


La registrazione di primanota è il cuore della parte contabile del programma Zefiro, la procedura permette di eseguire inserimenti, cancellazioni e modifiche delle scritture rispettando però le scritture stampate nei registri definitivi ed impedendo inserimenti in date già stampate.

Oltre alla registrazione manuale delle scritture, molte procedure del programma sono in grado di effettuare registrazioni contabili automatiche, ad esempio la gestione delle scadenze permette di generare scritture per la Presentazione Effetti, le registrazioni di Incasso e Pagamento, del registrazioni di Insoluto e di Pagamento Effettuato, la gestione dei Cespiti genera automaticamente le scritture di Ammortamento Cespiti e di Cessione/Eliminazione Cespite. La procedura di Contabilizzazione Fatture esegue la registrazione delle Fatture di Vendita e delle Note d'accredito e così via.

Quando si entra nella procedura, viene visualizzata la lista di tutte le scritture dell'esercizio corrente. Il programma riconosce automaticamente l'esercizio in base alla data del programma. Cambiando da data cambia l'esercizio su cui si lavora.

Sulle scritture presenti nella lista si possono attivare molte delle funzionalità del programma come ad esempio l'IVA per cassa, la gestione degli anticipi bancari o la sospensione d'imposta.

La procedura di primanota permette di inserire con un unica scrittura la parte contabile e per i documenti IVA anche la parte IVA della registrazione, nel caso delle fatture vengono anche generate automaticamente le scadenze in modo da gestire automaticamente la parte riguardante incassi e pagamenti.

Quando si inserisce una nuova scrittura, prima di tutto viene chiesta la causale contabile da utilizzare:

Dopo aver inserito una causale valida i dati richiesti dipendono dalla causale utilizzata, nel caso di causali di sola contabilità generale si passa direttamente alla parte contabile della scrittura, in caso di scritture che implicano IVA come ad esempio le fatture di vendita oppure le fatture di acquisto o ancora i corrispettivi e le note d'accredito, prima di passare alla parte contabile si devono inserire i dati IVA della scrittura.

I dati vengono inseriti utilizzando la modalità di gestione documenti, I dati da inserire in testata dipendono dalla causale utilizzata e sono:

Codice Anagrafica | A seconda della causale si deve inserire il codice del Cliente oppure del Fornitore o il Codice della Cassa nel caso di inserimento di corrispettivi. Premendo il pulsante collegato si apre l'archivio corretto, la procedura esegue un controllo per verificare che non vengano inseriti dati non validi. In caso di fattura emessa alla pubblica amministrazione viene automaticamente assegnato al cliente il registro iva dedicato alla PA.
Registro IVA | Il programma può gestire registri multipli, se è stata abilitata questa funzione viene chiesto il registro IVA a cui appartiene questo documento. In caso di fattura emessa alla pubblica amministrazione viene accettato solo il registro IVA dedicato alla PA.
Tipo , data e num. documento | Si inseriscono gli estremi del documento, questi dati non vengono richiesti in caso di corrispettivi. Il pulsante collegato alla data del documento permette di copiare la data di registrazione se è la stessa. Il pulsante collegato al numero del documento permette di inserire il numero documento in formato alfanumerico ed è utile per registrare le fatture di acquisto con riferimenti estesi. Dal dato inserito vengono estrapolate le ultime sei cifre e vengono inserite come numero di documento e questo dato viene utilizzato come riferimento in tutto il programma.
Importo | Inserire l'importo totale del documento comprensivo di iva ed eventuali arrotondamenti. Questo dato viene inserito per facilitare l'inserimento corretto dei documenti, infatti la macchina impedisce di confermare documenti in cui il totale inserito sia diverso dal totale calcolato. Premendo il pulsante collegato si può calcolare il totale del documento inserendo fino a tre righe di imponibile ed aliquota iva. Questo è particolarmente utile quando si inseriscono fatture intrace in reverse charge, poiché si deve aggiungere l'IVA che in fattura non viene esposta.
Modalità di Pagamento | Inserire la modalità di pagamento applicata per questo documento, viene proposto automaticamente il codice presente nell'anagrafica del Cliente o del Fornitore. Premendo il pulsante collegato si apre la lista delle Modalità di Pagamento, questo dato non viene chiesto per i corrispettivi.
Banca per bonifici | Se il tipo di pagamento della modalità di pagamento è per mezzo di bonifico bancario viene visualizzato questo pulsante che permette di indicare su quale banca il cliente dovrà accreditare il bonifico bancario. Il codice della banca verrà riportato nella scadenza in modo da poter stampare la lista dei bonifici attesi in ogni banca. Nelle preferenze può essere indicata la banca predefinita.

Dopo aver inserito la testata si passa alla gestione delle righe, si devono inserire tante righe quante sono le aliquote IVA utilizzate, in ciascuna riga si inserisce:

Codice IVA | Inserire il codice IVA della riga. Premendo il pulsante collegato si apre la lista dei Codici IVA.
Imponibile | Inserire l'importo imponibile, nelle registrazioni di corrispettivi si inserisce l'importo totale che poi viene scorporato.
Imposta | Viene calcolata automaticamente l'imposta corrispondente all'imponibile inserito, in caso di corrispettivi l'imponibile viene scorporato e viene inserita l'imposta corrispondente.
% Indetraibile | Durante la registrazione delle fatture d'acquisto viene chiesta anche la percentuale di indetraibilità IVA del bene acquistato.
Codice Intrastat | Questo dato viene chiesto solo se il Cliente o Fornitore ha il prefisso IVA appartenenti ad uno degli stati CE e non è italiano, e permette di inserire il codice ti nomenclatura combinata che verrà utilizzato per la stampa dei Riepiloghi Intrastat. Se si dispone della licenza di magazzino, si consiglia di eseguire la stampa del Riepilogo delle Cessioni con la procedura di magazzino e quindi di ignorare questo dato per le fatture di vendita.
Massa netta Intrastat | Se la registrazione è intrastat, viene chiesto anche la massa netta che deve essere riportate nei riepiloghi intrastat. E un dato che si inserisce manualmente e deve essere conosciuto a priori. Nella stampa del riepilogo viene semplicemente fatta la somma di tutte le masse inserite per la stessa nomenclatura.

Dopo aver inserito la parte IVA o dopo la causale per le causali che non prevedono IVA, si deve inserire la parte contabile della scrittura. Anche in questo caso si utilizza la modalità di gestione documenti.

Se si sta registrando una fattura emessa alla pubblica amministrazione Vengono automaticamente generate le righe di giroconto previste dalla norma dello "Split Payment", per le registrazioni precedenti all'introduzione di tale norma invece per le PA viene chiesto se attivare la sospensione di imposta come previsto del decreto IVA.

I dati da inserire in testata sono:

Descrizione | Viene proposta la descrizione della causale contabile che può essere modificata.
Registro IVA | Questo dato viene chiesto solo in casi molto particolari e precisamente quando si applica il regime di contabilità semplificata e se si adottano registri IVA multipli. Serve per indicare in quale dei registri iva devono essere stampati i costi ed i ricavi non fatturati.
Note | Se si desidera si può inserire una descrizione estesa legata alla testata della scrittura, questa descrizione può comparite in alcune stampe.
Registro contabile | Il programma può gestire registri multipli, se è stata abilitata questa funzione viene chiesto il registro contabile a cui appartiene questa scrittura.
Data registrazione | Inserire la data di registrazione, il programma su questa data esegue alcuni controlli per evitare l'inserimento di scritture in date già stampate o appartenenti ad esercizi contabili diversi da quello attuale.
Altri dati | Se si desidera si possono inserire alcuni dati normalmente non necessari come ad esempio gli estremi di un documento di riferimento.

Dopo aver inserito la testata si passa alla gestione delle righe, i documenti IVA automaticamente generano alcune righe che non possono essere modificate manualmente. Il programma non permette la registrazione di scritture sbilanciate nelle quali cioè il totale degli importi Dare sia diverso dal totale degli importi Avere. Alcune causali facilitano l'inserimento delle righe proponendo i codici di sottoconto che vengono normalmente utilizzati e proponendo Dare o Avere. In ciascuna riga si inserisce:

Codice sottoconto | Inserire il codice di sottoconto della riga. Premendo il pulsante collegato si apre la lista di Conti. Si possono inserire codici con mastro, conto e sottoconto separati da punti ed il codice viene trasformato in modo corretto, ad esempio se si inserisce 13.1.1 il codice viene trasformato in 1301000001. Se si inserisce 'C' seguito dai primi caratteri della ragione sociale (oppure dal codice numerico se lo conosciamo) e si preme invio si apre la lista dei Clienti, se si preme 'F' seguito dai primi caratteri della ragione sociale o dal codice si apre la lista dei Fornitori.
Importo Dare | Inserire l'importo se il sottoconto è in Dare, se ci sono importi in Avere vengono cancellati. Premendo il pulsante collegato viene calcolato il saldo della scrittura. Alcune volte questo campo non viene richiesto se la scrittura prevede inserimenti solo in Avere.
Importo Avere | Inserire l'importo se il sottoconto è in Avere, se ci sono importi in Dare vengono cancellati. Premendo il pulsante collegato viene calcolato il saldo della scrittura. Alcune volte questo campo non viene richiesto se la scrittura prevede inserimenti solo in Dare.
Descrizione aggiuntiva | Si può inserire una piccola descrizione aggiuntiva. Il pulsante collegato permette di copiare la descrizione aggiuntiva dell'ultima riga inserita in precedenza.
Note | Se necessario si può inserire una descrizione estesa per questa riga.
Data e N. riferimento | Questo dato viene chiesto solo se il sottoconto è un cliente o un fornitore e serve per la gestione delle partite contabili, si deve inserire la data ed il numero di fattura a cui la scrittura fa riferimento. Questo dato viene gestito automaticamente dalle procedure di gestione scadenze.
Centro di Costo/Ricavo | Questo campo viene visualizzato solo quando si inserisce un conto economico (Costo o Ricavo) e permette di suddividere il conto economico secondo criteri diversi rispetto al piano dei conti, durante la stampa del bilancio, è possibile richiedere il raggruppamento per centri di costo e ricavo. Questo dato può essere utile per l'analisi di costi industriali e dei ricavi per settore. Se necessario, è disponibile un modulo a parte per una gestione più avanzata dei CDC che oltre a fare quello che fa le versione base permette di inserire annotazioni generiche e di stampare alcuni reports specifici.
Tipo costo IVA | Nelle fatture di acquisto si può distinguere il tipo di costo ai fini della dichiarazione IVA, durante la stampa del bilancio, è possibile richiedere il raggruppamento per tipo di costo in modo da ottenere l'importo da copiare nella dichiarazione annuale IVA. Viene proposto automaticamente il dato presente nel sottoconto. Premendo il pulsante collegato si apre la lista di scelte.

Alla fine della registrazione di nuove scritture vengono attivate alcune procedure a seconda del tipo di registrazione inserita.

Per le fatture di Acquisto e di Vendita, vengono generate automaticamente le Scadenze utilizzando i meccanismi di generazione predisposti nelle Modalità di pagamento, quando si inseriscono fatture di acquisto di fornitori soggetti a ritenuta d'acconto, è bene lasciare vuoto il campo della modalità di pagamento perché un'apposita procedura si occupa della gestione del pagamento per questi soggetti.

Quando si registrano fatture di acquisto di beni ammortizzabili che sono indicati nel piano dei conti per il fatto di essere contrassegnati dalla percentuale di ammortamento, il programma propone la possibilità di registrare il cespite.

Si inseriscono i seguenti dati:

Descrizione | Inserire la descrizione del cespite.
% Ammortamento | Viene proposta la percentuale di ammortamento presente nel piano dei conti.
Anticipato | Indicare se per questo cespite si desidera effettuare l'ammortamento anticipato.
% Indeducibilità | Inserire la percentuale sul valore che non è deducibile.
Nuovo | Indicare se il bene acquistato è nuovo o usato.
Data inizio utilizzo | Viene proposta la data della registrazione contabile, ma si possono inserire date diverse. Questa è la data utilizzata in tutti calcoli di ammortamento.
Valore iniziale del bene. | Viene proposto il valore di acquisto del bene. Nel corso della vita del cespite questo valore può essere modificato da variazioni di valore che andranno ad incidere sui calcoli di ammortamento.

Quando si inseriscono fatture di acquisto di fornitori soggetti a ritenuta d'acconto, se è disponibile il relativo modulo, viene attivata la gestione della ritenuta d'acconto.

Vengono visualizzati di totali di imponibile, imposta ed importi non imponibili. I Dati da inserire sono:

Importo soggetto | Inserire l'importo imponibile soggetto a ritenuta d'acconto, viene proposto l'intero importo imponibile soggetto ad IVA, poiché generalmente corrisponde all'importo soggetto a ritenuta, ma potrebbe essere un importo diverso se in fattura sono presenti valori non soggetti a ritenuta.
% Ritenuta | Viene proposta la percentuale di ritenuta da applicare presente in anagrafica fornitore.
% non soggetta | Alcuni fornitori sono dispensati dal pagamento di parte della ritenuta d'acconto per una percentuale fissata per legge, in questa posizione si inserisce questa percentuale, viene proposto il valore memorizzato in anagrafica fornitore.
Codice tipo versamento | Inserire il codice da indicare in fase di pagamento della ritenuta, viene proposto il valore memorizzato in anagrafica fornitore.

Le Stampe disponibili per l'archivio della primanota sono:

Lista Primanota | Viene stampato un brogliaccio di primanota, l'aspetto è del tutto simile a quello della stampa del libro giornale.
Stampa scrittura | Viene stampata solo la scrittura corrente.

I comandi speciali disponibili per i documenti sono:

Cerca importo | Questa utile funzione permette di cercare un importo in tutte le registrazioni di primanota, viene presentato l'elenco di tutte le scritture che includono l'importo indicato.
Cambia causale | Con questa procedura è possibile cambiare la causale di una registrazione, la nuova causale deve essere compatibile per tipo con la vecchia. Oltre al codice si può copiare anche la descrizione della nuova causale.
Rigenera scadenze | Con questa procedura si rigenerano le scadenze legate alle fatture ed alle note d'accredito di clienti e fornitori. È necessario effettuare la rigenerazione quando viene cambiata la modalità di pagamento dopo aver registrato il documento. Non viene fatta la rigenerazione automatica perché nel frattempo potrebbero essere già state fatte modifiche alle scadenze, ad esempio si potrebbe aver già presentato le RIBA per l'incasso.
Vedi scadenze | In corrispondenza di fatture di acquisto o di vendita, può essere comodo esaminare le scadenze in essere. Con questo comando si possono vedere le scadenze relative a questo documento, oppure tutte le scadenze del cliente o fornitore corrente.
Saldo partita | Questa procedura permette di attivare il saldo partita su questa Fattura / Nota d'accredito, viene usata spesso nella gestione della contabilità semplificata in cui registrare gli incassi per il calcolo dei redditi.
Genera IVA per cassa. | Con questa procedura si attiva per le fatture la gestione dell'IVA per cassa ed è disponibile solo se è stato scelto questo particolare regime di calcolo IVA.
Data competenza IVA. | Per le Fatture e le Note d'accredito, è possibile cambiare la data di competenza ai fini della liquidazione iva. Ad esempio se emetto una fattura il 5 di Febbraio relativa vendite effettuare durante il mese di Gennaio, posso indicare come data di competenza il 31 Gennaio ed in questo modo nel calcolo della liquidazione IVA, il documento verrà incluso nella liquidazione di Gennaio.
Genera reverse charge

Questa procedura serve per generare automaticamente le fatture di vendita a compensazione delle fatture di acquisto in regime di "Reverse charge". Quando si riceve una fattura in reverse charge è necessario azzerare l'iva di acquisto registrando una equivalente fattura di vendita e l'iva di acquisto inoltre non è dovuta al fornitore e quindi deve essere stornata contabilmente e dalle scadenze. Con questa procedura si registra la fattura di vendita che contiene anche tutti i giroconto necessari. Vengono chiesti il codice del cliente fittizio usato per il giroconto ed il codice della causale contabile di fattura di vendita e viene generata la scrittura.

Può accadere che in una fattura non tutto l'imponibile sia in regime di "Reverse charge", in questo caso è possibile indicare quale delle righe iva non è soggetta e tutti i calcoli successivi non terranno conto di quella riga.

In caso di generazione già effettuata il programma emette una segnalazione e richiede se si desidera resettare la generazione (questo serve se è necessario rifare il reverse charge in caso di errori).

E' consigliabile registrare le fatture di acquisto in reverse charge in un registro iva separato, in questo modo si ottiene la concordanza dei protocolli.

E' consigliabile inserire nella causale di vendita una contropartita con accumulatore 'C' per il giroconto dei movimenti di vendita.

Tipo acquisto intrace

Per i soli acquisti sul registro IntraCE viene chiesto il tipo di acquisto che può essere di beni o di servizi. Questo dato viene richiesto dalla comunicazione trimestrale delle fatture.

Cambia esercizio | Questa procedura permette di cambiare l'esercizio di competenza di una scrittura contabile, viene utilizzata ad esempio per le scritture di rettifica che vengono fatte nell'anno in corso ma che si riferiscono all'esercizio precedente.
Duplica scrittura. | Questa procedura permette di duplicare una scrittura contabile, si applica solo alle scritture non IVA.
Genera nuova causale | Permette di generare una nuova causale contabile con i sottoconti utilizzati nella scrittura corrente, è utile per generare rapidamente causali per scritture ripetitive. Consigliamo di non abusare di questa funzione per evitare di avere causali ripetitive e poco riutilizzabili.
Anticipo bancario | Questa procedura serve per la gestione degli anticipi bancari. Viene fatta la scrittura di concessione dell'anticipo dal parte delle banca. Il codice della banca viene memorizzato in modo che venga segnalato se si tenta di effettuare scritture di anticipo più di una volta.
Sospensione d'imposta Questo comando è disponibile solo per le registrazioni precedenti alla introduzione della norma dello "Split payment". Se la fattura è stata emessa ad un cliente per cui è possibile chidere la sospensione d'imposta, da questa posizione si possono attivare tutte le funzionalità connesse come ad esempio disattivare o attivare la sospensione, oppure inserire la data di incasso.
Si tenga presente che l'incasso viene gestito automaticamente dalla procedura di incassi e pagamenti.
Per disattivare una sospensione attivata in precedenza si inserisce una data vuota, invece per disattivare l'incasso si inserisce come data quella del documento.
Importa fattura elettronica Questa prcedura permette di registrare automaticamente le fatture di acquisto ricevute nel formato della Fattura Elettronica nel formato XML previsto dal sistema di interscambio. Se le fatture da importare sono molte, per velocizzare le operazioni, oltre a questa procedura è disponibile anche una procedura che esegue l'importazione di tutte le fatture presenti in una cartella.
Si possono anche registrare le fatture di vendita eventualmente generate con programmi diversi da Zefiro.
Prima di tutto si deve scegliere il file XML da importare. In fase di importazione vengono fatti alcuni controlli, prima di tutto si controlla che il file sia effettivamente un file di fattura elettronica valido, poi si controlla se noi siamo effettivamente i destinatari, poi si controlla se il fornitore è già stato inserito, e se non è presente in anagrafica consente l'inserimento automatico.
Se la fattura contiene allegati, vengono estratti e viene chiesto all'utente se desidera aprire la cartella che li contiene in modo da poterli aprire ed eventualmente salvare da atra parte, dopo di che si può procedere alla importazione, vengono chiesti un po' di dati per dare corso alla registrazione, si deve inserire:
Causale contabile | Viene chiesta la causale per la registrazione e viene proposta la causale più appropriata.
Codice fornitore | Viene proposto il fornitore trovato.
Data registrazione | Viene proposta la data odierna, ma si può mettere la data di ricezione nel SdI, oppure la data del documento.
Data competenza IVA | E' la data in cui la fattura viene conteggiata nella liquidazione IVA, se viene lascaiata in bianco vale la data di registrazione. Tipicamente se ricevo una fattura ai primi di febbraio, ma la data del documento è di gennaio, nella data di competenza dovrei inserire l'ultimo giorno di gennaio.
Numero assegnato | Spesso le fatture elettroniche hanno numerazioni complesse ad esempio "AB 123/2019/01". Zefiro per motivi tecnici richiede di registrare i numeri dei documenti in formato numerico e perciò calcola il numero prendendo le ultime 6 cifre trovate. In questa posizione si può inserire il numero corretto, ad esempio se il numero proposto è 1232019, si potrebbe inserire 123.
Cancella file originale | Solitamente i files XML vengono scaricati da internet in una cartella temporanea, questa opzione propone di cancellare il file dopo l'importazione e solitamente "Si" è la risposta corretta.
Registro | Se la nostra installazione prevede registri iva multipli, in questa posizione si può inserire il registro di competenza, ad esempio per le fatture in reverse charge si potrebbe inserire il registro "R"
Alla fine dopo aver inserito i dati, il sistema controlla se la fattura non è già stata inserita ed in caso chiede di confermare la doppia registrazione.
Se tutto va a buon fine viene registrata la fattura e le relative scadenze e viene cancellato il file usato per l'importazione.
Se la fattura contiene codici di esenzione iva vi viene chiesto di inserire il codice più appropriato.
Se il file non contiene scadenze, sarà necessario fare la rigenerazione delle scadenze.
Stampa fattura elettronica Le fattue elettroniche sono in formato XML che è efficiente da elaborare per i computers, ma faticoso da leggere per gli umani.
Questa procedura trasforma una fattura elettronica in una pagina web facilmente leggibile e stampabile. Il formato di visualizzazione, dipende da un foglio di stile che si occupa della impaginazione.
Attualmente vengono messi a disposizione il formato ministeriale proposto da Agenzia delle Entrate ed il formato realizzato da AssoSoftware
Si sceglie il file e si indica il formato richiesto, ed alla fine viene aperta la pagina web con la fattura che può essere visualizzata e stampata. Se la fattura contiene allegati, è anche possibile aprire una cartella che li contiene per poterli aprire.
Durante la fase di importazione delle fatture, il testo del file XML, viene memorizzato in Zefiro, in questo modo è possibile stampare sempre il file importato. In questo caso ma macchina propone già il nome del file da stampare, altrimenti si dovrà scegliere il file XML che si desidera.
Visualizza righe | Con questa voce si visualizza o si nasconde la visualizzazione delle scritture contabili della registrazione. è utile per vedere in modo veloce il contenuto della registrazione senza doverci entrare in modifica.
Spunta registrazioni contabili | Viene attivata la spunta delle registrazioni contabili.
Bilancio scritture selezionate | Questa procedura permette di selezionare e spuntare le registrazioni contabili desiderate, e poi su queste si può calcolare il bilancio utilizzando le stesse procedure utilizzate per il bilancio completo in questo modo si possono fare raggruppamenti di scritture di tutti i tipi. Se dalla lista dei saldi si chiedono le schede contabili, vengono evidenziati solo i movimenti presenti nella selezione.

Sospensione d'imposta

La sospensione d'imposta viene di fatto abrogata dallo "Split payment". Per le registrazioni precedenti alla introduzione della nuova norma valgono le seguenti indicazioni:

L'articolo 6 comma 5 del DPR 633/72 sull'IVA stabilisce che coloro che forniscono beni alla pubblica amministrazione hanno il beneficio della sospensione dell'obbligo di pagare l'imposta fino a quando non avviene l'incasso di quanto dovuto.

Per attivare la sospensione d'imposta è necessario che il cliente a cui viene emessa la fattura sia un ente della pubblica amministrazione, questo viene segnalato inserendo nell'anagrafica dei clienti l'apposita spunta.

Quando si registrano fatture di vendita a questi clienti, viene automaticamente attivata la sospensione d'imposta. In fase di registrazione o anche in seguito si può decidere se disattivare la sospensione con il comando disponibile in corrispondenza della scrittura. Nella parte contabile della scrittura per queste fatture viene uilizzato il sottoconto di "IVA in sospensione d'imposta" al posto del sottoconto di "IVA vendite".

Quando si stampa il registro IVA delle vendite, vengono riconosciute ed annotate le fatture con iva sospesa e viene riportato il totale dell'iva sospesa nel riquadro del riepilogo iva.

Quando avviene il pagamento da parte del cliente è necessario effettuare un giroconto contabile tra il conto "IVA in sospensione" ed "IVA Vendite". Se è attivo il modulo delle scadenze, la procedura di Incassi e pagamenti è in grado di effettuare auomaticamente la scrittura di giroconto e di attivare l'incasso per il calcolo dell'imposta nelle liquidazione IVA.

Siccome generalmente la pubblica amministrazione effettua i pagamenti tramite bonifico bancario, la gestione automatica dell'incasso dell'IVA sospesa è stata attivata solo dalla suddetta procedura, se non si usa questa procedura è necessario procedere alla registrazione manuale del giroconto ed alla indicazione manuale della data di incasso.

Quando si stampa la liquidazione IVA, il programma annota automaticamente i documenti con IVA sospesa del periodo ed i documenti sospesi in precedenza che sono stati incassati nel periodo. Nel totale imposta da versare o a credito si tiene conto di questi dati.


Questa procedura permette di consultare le schede contabili dei conti del piano dei conti. Da questa procedura si può eseguire la stampa della scheda ed anche vedere e/o modificare le scritture che appartengono alla scheda.

Le schede dispongono anche di un utile funzionalità che è la gestione delle spunte, con questa procedura si possono marcare le scritture che sono state controllate e quando si effettua la stampa della scheda, vengono riepologate le scritture spuntate e quelle non spuntate. Questa procedura è utile ad esempio per fare il controllo degli estratti conto bancari, ma è utile in generale per il controllo di tutte le schede.

I dati vengono inseriti utilizzando la modalità di gestione documenti. In testata viene chiesto:

Codice sottoconto | Inserire il codice di sottoconto della riga. Premendo il pulsante collegato si apre la lista di Conti. Si possono inserire codici con mastro, conto e sottoconto separati da punti ed il codice viene trasformato in modo corretto, ad esempio se si inserisce 13.1.1 il codice viene trasformato in 1301000001. Se si inserisce 'C' seguito dai primi caratteri della ragione sociale (oppure dal codice numerico se lo conosciamo) e si preme invio si apre la lista dei Clienti, se si preme 'F' seguito dai primi caratteri della ragione sociale o dal codice si apre la lista dei Fornitori.
Da Data | Viene proposta la data di inizio dell'esercizio.
A Data | Viene proposta la data finale gestita dal programma, in questo modo potranno entrare a far parte della scheda anche scritture fatte in esercizi successivi ma con competenza dell'anno in corso.
Solo esercizio corrente | Questa casella di spunta serve ad indicare se si desidera leggere i movimenti del solo esercizio cottente, oppure si si preferisce leggere tutti i movimenti contenuti tra le date indicate.
Centro di costo/ricavo | Questa selezione viene chiesta solo per i conti economici (costi e ricavi) e serve per selezionare i movimenti di specifici centri di costo o ricavo, si possono ad esempio vedere i movimenti di un solo centro di costo/ricavo oppure di tutti.
Giornale | Questa opzione viene presentata solo se sono stati scelti i registri multipli, permette di scegliere il registro contabile da stampare, si può anche scegliere di cumulare le scritture di più registri.

Dopo aver inserito i dati di testata, se il sottoconto scelto ha scritture per il periodo scelto viene presentata la scheda con la lista delle scritture. Da qui se si desidera, si possono spuntare le scritture ad una ad una oppure tutte in un colpo con gli appositi comandi speciali, per salvare le spunte effettuate si deve confermare la scheda premendo il tasto [F12] oppure premendo il pulsante di conferma. Premendo [INVIO] in corrispondenza di una scrittura si apre la primanota di quella scrittura con la possibilità di fare anche modifiche.

La stampa della scheda consente di inserire alcune interessanti opzioni, si possono selezionare i movimenti da stampare e si può decidere se stampare la lista delle contropartite e le scadenze.

I dati richiesti sono:

Tipo movimento | Si può scegliere di stampare tutti i movimenti oppure solo quelli che sono in dare o in avere.
Cerca causale | Si può decidere si stampare solo i movimenti che appartengono ad una determinata causale, oppure tutti, ad esempio nella scheda dei clienti si possono cercare solo gli incassi.
Cerca contropartita | Si può decidere di stampare solo i movimenti che hanno nella scrittura una determinata contropartita contabile, ad esempio si può cercare tutte le vendite che hanno anche abbuoni passivi.
Tipo Spunta | Se sono state attivate le spunte, si può stampare solo i spuntati, oppure i non spuntati o tutti.
Stampa riepilogo spunte | Con questa opzione si decide se stampare un riepilogo delle somme spuntate alla fine della stampa.
Dettaglio contropartite | Si può decidere di stampare per ogni movimento anche le contropartite della scrittura contabile.
Stampa scadenze | Nel caso di clienti e fornitori, si può decidere di stampare anche la lista delle scadenze aperte. In questo modo ad esempio si può determinare l'esposizione dei confronti dei clienti anche se il cliente è chiuso contabilmente con la presentazione effetti.


Una partita contabile è la lista delle scritture che riguardano un documento di un Cliente o Fornitore, la partita è chiusa quando la somma degli importi Dare corrisponde con la somma degli importi Avere ed è aperta quando questa corrispondenza non c'è. La gestione delle partite è in gran parte automatica, infatti la registrazione della fattura apre la partita, e le procedure di incasso e di presentazione effetti la chiudono, ma è possibile gestirla anche manualmente andando a modificare i dati di partita delle scritture. In alcuni casi rimangono partite aperte anche quando in realtà sono chiuse (questo succede ad esempio quando ci sono compensazioni tra fatture di acquisto e note d'accredito o fatture di vendita) in questi casi si può forzare la chiusura della partita.

I dati vengono inseriti utilizzando la modalità di gestione documenti. In testata viene chiesto:

Codice cliente/fornitore | Inserire il codice del cliente o del fornitore di cui si desidera la partita. Premendo il pulsante collegato si apre la lista dei clienti se il primo carattere del codice è 'C' o dei fornitori se il primo carattere è 'F'.
Tipo partite | Si può scegliere se esaminare solo le partite aperte, oppure solo le partite chiuse oppure tutte le partite del cliente indipendentemente dal fatto che siano aperte o chiuse. Normalmente è interessante esaminare solo le partite aperte.
Da Data | Viene proposta la data iniziale gestita dal programma. Verranno prese in considerazione solo le partite che sono iniziate entro i limiti di data, l'inizio della partita corrisponde con il numero del documento.
A Data | Viene proposta la data finale gestita dal programma.

Dopo aver inserito i dati di testata, se ci sono partite disponibili viene presentata la lista. A questo punto si può eseguire la stampa delle partite che può essere analitica o sintetica, la stampa analitica include per ogni partita la lista delle scritture coinvolte, invece nella stampa sintetica viene presentato solo il saldo, nella stampa si può anche includere la lista delle scadenze in essere per il cliente o fornitore.

Premendo [Invio] in corrispondenza di ciascuna partita viene presentata la lista delle scrittura che la compongono e da qui è possibile andare a vedere e/o modificare le scritture contabili.

Per ciascuna partita sono disponibili i seguenti Comandi speciali:

Saldo partita Questo comando è presente solo se è abilitata la corrispondente voce nelle preferenze. Normalmente viene disabilitato se l'utente dispone dello scadenzario dato che in quel caso il saldo delle partite viene effettuato dalle gestione delle scadenze. Se l'opzione è abilitata vengono chiesti:
Causale | Inserire il codice della causale da utilizzare per effettuare l'incasso o il pagamento, vengono accettate solo le causali corrette.
Data | Inserire la data di incasso o di pagamento.
Codice giornale | Questo dato viene chiesto solo se è stata abilitata l'opzione dei registri multipli.
Descrizione | Inserire una breve descrizione della scrittura
Arrotondamento | Se ci sono differente tra l'importo a saldo della partita e l'importo inserito, si può decidere se portare ad arrotondamento tale importo.
Importo | Inserire l'importo a saldo della partita.
Contropartita | Inserire il codice di contropartita che normalmente può essere la Cassa o la Banca.
Alla fine viene generata la scrittura contabile a saldo.
Forza chiusura | Se una partita risulta aperta ma si desidera chiuderla perché sono state operate compensazioni o per la presenza di arrotondamenti non contabilizzati, con questo comando si può forzare la chiusura.
Riapri partita | Con questo comando si può forzare la riapertura di una partita chiusa in precedenza con la procedura di forza chiusura. Ovviamente la partita viene riaperta solo se le somme degli importi Dare e degli importi Avere sono differenti.


Alcune ditte concordano con le proprie banche una forma di concessione di credito chamata "Anticipi bancari", in cui a fronte della presentazione della fattura di vendita, la banca concede un credito che solitamente copre una parte dell'importo delle fattura presentata.

A mano a mano che i clienti saldano le fatture o che intervengono altri incassi, la ditta rimborsa gli anticipi ricevuti dalla banca.

Diventa in questi casi necessario essere in grado di individuare quali sono le somme anticipate e quali sono le somme rimborsate a copertura del credito concesso. Tutte queste operazioni vengono eseguite contabilmente, utilizzando un meccanismo simile a quello utilizzato per le partite contabili.

Per la gestione degli anticipi le banche possono fare tutte le operazioni su un singolo conto corrente, oppure utilizzare un secondo C/C appositamente istituito per questo tipo di operazioni. Nella tabelle delle banche, si può inserire il sottoconto contabile utilizzato per gli anticipi, se il campo resta in bianco significa che tutte le operazioni di anticipo vengono effettuate sul conto ordinario.

La prima scrittura contabile si effettua quando viene concesso il credito da parte della banca. La via più semplice per farla consiste nel andare in primanota, trovare la fattura su cui viene concesso l'anticipo ed utilizzare il comando speciale "Anticipo bancari". La scrittura effettua il giroconto della somma anticipata dal conto ordinario al conto anticipi e segna nella scrittura i riferimenti della fattura, nel caso che la banca utilizzi un solo conto, il giroconto viene effettuato sullo stesso conto e serve solo per segnare i riferimenti dell'anticipo.

I dati richiesti sono:

Causale | Inserire la causale di anticipo, il programma propone solo le causali appropriate.
Data | Inserire la data della scrittura contabile
Descrizione | Viene proposta la descrizione della causale ed eventualmente si può modificare.
Pecentuale anticipo | Spesso viene concesso un anticipo pari ad una percentuale dell'importo della fattura. Inserendo tale percentuale viene calcolato l'importo.
Solo imponibile | Spesso l'anticipo viene concesso solo sulla parte imponibile della fattura. Il calcolo dell'importo tiene conto di questo
Importo anticipato | Questo dato viene calcolato automaticamente se si inserisce la percenutale di anticipo, ma può essere inserito anche a mano.
Banca anticipo fattura | Inserire il codice della banca che eroga l'anticipo.

Dopo che è stato erogato l'anticipo, via via che i clienti pagano le fatture, si effettua il rimborso delle banche. Per gestire correttamente i rimborsi, è utile che il programma ci fornisca informazioni riguardo a tutti gli anticipi correntemente aperti, e che ci permetta di effettuare le scritture di rimborso in modo veloce ed accurato.

Per fare questo viene presentata una pagina simile a quella della gestione delle partite contabili, dato che le due procedure sono molto simili ed utilizzano lo stesso meccanismo di gestione dei riferimenti.

I dati vengono inseriti utilizzando la modalità di gestione documenti. In testata viene chiesto:

Banca anticipo fatture | Inserire il codice della banca che ha erogato gli anticipi.
Tipo anticipo | Si può scegliere se esaminare solo gli anticipi aperti, oppure solo quelli chiusi, oppure tutti gli anticipi indipendentemente dal fatto che siano aperti o chiusi. Normalmente è interessante esaminare solo quelli aperti.
Da Data | Viene proposta la data iniziale gestita dal programma. Verranno prese in considerazione solo gli anticipi che sono iniziati entro i limiti di data, l'inizio corrisponde con il numero della fattura.
A Data | Viene proposta la data finale gestita dal programma.

Dopo aver inserito i dati di testata, viene presentata la lista degli anticipi che hanno soddisfatto i parametri richiesti.

A questo punto si possono effettuare le scritture di rimborso premendo invio in corrispondenza dell'anticipo che si vuole rimborsare. I dati da inserire sono:

Causale | Inserire la causale di rimborso, il programma propone solo le causali appropriate.
Data | Inserire la data della scrittura.
Codice giornale | Questo dato viene chiesto solo se è stata abilitata l'opzione dei registri multipli.
Descrizione | Viene proposta la descrizione della causale ed eventualmente si può modificare.
Importo | Inserire l'importo rimborsato.
Contropartita | Inserire il codice di contropartita che normalmente può essere la Cassa o la Banca.

Oltre ad effattuare i rimborsi da questa posizione si possono stampare di dati degli anticipi, la stampa può essere analitica o sintetica, nel primo caso vengono evidenziate tutte le scritture, nel secondo caso viene presentato solo il saldo corrente.

I Comandi speciali disponibili sono:

Scritture anticipo | Questo comando presenta la lista di tutte le scritture che fanno parte di questo anticipo ed è anche possibile aprirle per esaminarle o modificarle.
Forza chiusura | Con questo comando si può forzare la chiusura degli anticipi che risultano contabilmente aperti, ma che non si desidera più gestire.
Riapri anticipo | Con questo comando si può forzare la riapertura di un anticipo chiuso in precedenza con la procedura di forza chiusura. Ovviamente la partita viene riaperta solo se le somme degli importi Dare e Avere sono differenti.


Questo menù permette di accedere alle stampe fiscali e non del programma di contabilità. Sono presenti:

Stampa giornale permette di stampare il giornale di contabilità in prova e definitivo
Stampa bilancio serve per stampare tutti i tipi di bilancio previsti dal programma
Bilancio riclassificato si possono stampare bilanci riclassificati secondo vari criteri.
Stampa schede serve per stampare in un colpo solo tutti o parte dei partitari di contabilità
Stampa partite serve per stampare in un colpo solo tutte o parte delle partite aperte o chiuse.
Stampa prospetti IVA con questa stampa si ottengono alcuni riepiloghi delle scritture IVA secondo vari criteri.
Riepiloghi intrastat si possono stampare riepiloghi che facilitano la stesura dei moduli intrastat.
Allegati Clienti/Fornitori viene generato il file di allegati Clienti/Fornitori da inviare alla Agenzia delle Entrate.
Registri IVA viene usata per stampare tutti i registri IVA in prova o definitivi.
Dichiarazioni IVA serve per stampare le dichiarazioni IVA in prova o definitive.
Riepilogo IVA annuale permette di stampare il riepilogo delle dichiarazioni IVA.


Con questa procedura si esegue la stampa del giornale di contabilità, i dati richiesti ed il tracciato stampa dipendono dal tipo di contabilità scelto nelle preferenze.

Se è stato scelto il regime di contabilità ordinaria, si presenta questa videata.

I dati richiesti sono:

Tipo di stampa | Si può fare la stampa di prova, oppure la stampa definitiva o la ristampa, queste ultime due stampe aggiornano i progressivi di stampa che vengono memorizzati nei numeratori, in questo modo viene impedita la possibilità di ulteriori modifiche delle scritture.
Data di stampa | Viene proposta la data del giorno ed è la data che viene riportata nelle stampe.
Registro | Se è stata abilitata l'opzione per i registri multipli, viene chiesto il registro contabile da stampare, si possono stampare più registri contemporaneamente.
Fino a data | Vengono stampate le registrazioni fino alla data inserita.
Da Data | Questa voce viene richiesta solo per la stampa di prova e per la ristampa ed indica la data di partenza della stampa, nel caso di stampa definitiva la prima registrazione stampata è quella successiva all'ultima stampata in definitivo.
Ultimo movimento Prog. giornale e movimento Progressivo Dare Progressivo Avere | Questi dati vengono chiesti solo in caso di ristampa e servono a risistemare i progressivi di stampa, si deve prendere questi dati dall'ultima pagina stampata correttamente.
Conferma inserimento bollato | Questo dato viene chiesto solo per la stampa definitiva e per la ristampa e serve ad evitare che vengano fatte stampe definitive non desiderate.
Num. pagina iniziale | Nella stampa definitiva e nella ristampa, si può indicare il numero di pagina da cui far partire la stampa, si vede il numero dell'ultima pagina stampata definitiva e si inserisce il numero seguente.

Alla fine viene effettuata la stampa.

In caso venga scelto nelle preferenze il regime di contabilità semplificata, si inseriscono le scritture di contabilità allo stesso modo del regime di contabilità ordinaria, ma in questo caso sono obbligatorie solo le scritture di acquisti e vendite con fattura e di altre spese e ricavi.

La stampa del registro contabile viene effettuata nel registro IVA Acquisti per le sole scritture relative a costi senza fattura (acquisti di cancelleria, valori bollati, ecc...) e nel registro IVA Vendite per le scritture relative a ricavi senza fattura (plusvalenze regalie, ecc...)

Precisamente con questa stampa vengono stampate le scritture relative a sottoconti di tipo Costo con importo in Dare nel registro IVA Acquisti e le scritture relative a sottoconti di tipo Ricavo con importo in Avere nel registro IVA Vendite.

I dati richiesti sono:

Tipo di stampa | Si può fare la stampa di prova, oppure la stampa definitiva o la ristampa, queste ultime due stampe aggiornano i progressivi di stampa che vengono memorizzati nei numeratori, in questo modo viene impedita la possibilità di ulteriori modifiche delle scritture.
Data di stampa | Viene proposta la data del giorno ed è la data che viene riportata nelle stampe.
Tipo registro | Si deve scegliere il tipo di registro IVA su cui stampare le registrazione contabili, si deve fare la stampa di entrambe i registri.
Registro | Se è stata abilitata l'opzione per i registri multipli, viene chiesto il registro IVA di applicabilità da stampare.
Fino a data | Vengono stampate le registrazioni fino alla data inserita.
Da Data | Questa voce viene richiesta solo per la stampa di prova e per la ristampa ed indica la data di partenza della stampa, nel caso di stampa definitiva la prima registrazione stampata è quella successiva all'ultima stampata in definitivo.
Ultimo movimento | Questo dato viene chiesto solo in caso di ristampa e serve per indicare il numero di registrazione del giorno di partenza da cui far partire la stampa.
Conferma inserimento bollato | Questo dato viene chiesto solo per la stampa definitiva e per la ristampa e serve ad evitare che vengano fatte stampe definitive non desiderate.
Num. pagina iniziale | Nella stampa definitiva e nella ristampa, si può indicare il numero di pagina da cui far partire la stampa, si vede il numero dell'ultima pagina stampata definitiva e si inserisce il numero seguente.

Alla fine viene effettuata la stampa.


Questa procedura di stampa quindi è richiesta solo se è stato scelto nelle preferenze il regime di contabilità semplificata ed e resa disponibile solo in questo caso.

Per le aziende in regime di contabilità semplificata, La legge 11 dicembre 2016, n. 232 ha modificato i criteri per la determinazione del imponibile IRPEF e IRAP. Ed è stato introdotto l'obbligo della tenuta dei registri degli incassi e dei pagamenti.

Per la tenuta corretta della contabilità semplificata sarà quindi necessario registrare oltre alle fatture di acquisti e di vendita, anche i relativi incassi e pagamenti perché solo in questo modo si potranno ottenere i registri. Sarà anche importante riportare nelle scritture numero e data del documento per la gestione corretta della partita contabile e per la stampa nei registri.

I dati richiesti sono:

Tipo di registro | Si possono stampare gli incassi, oppure i pagamenti, o infine si può stampare un riepilogo con i totali per le varie tipologie.
Da data di registrazione a data di registrazione | Si devono inserire le date del periodo che si desidera stampare. Il programma non fa alcun controllo sul esercizio contabile corrente ed è responsabilità dell'utente di eseguire le stampe complete del periodo richiesto. La stampa è in carta semplice e si può rifare quante volte si desidera.

Dopo aver confermato i dati, viene eseguita la stampa.

Vengono letti in ordine cronologico tutte le scritture contabili non IVA. Tutte le registrazioni per Clienti vengono stampate nel registro degli incassi. Tutte le scritture per Fornitori vengono stampate nel registro dei pagamenti.

In caso di pagamento di Note di Accredito o di giroconti su Anticipi o altro, il segno per l'importo viene messo negativo e sottratto dagli importi positivi.

Vengono stampate anche le scritture relative a costi o sopravvenienze non documentate da fattura come ad esempio l'acquisto di valori bollati o scontrini di pasti. Ma in questo caso corre l'obbligo di conservazione delle ricevute.


Questa procedura permette di stampare tutti i tipi di bilancio previsti dal programma. Prima di tutto vengono chiesti quali sono i dati da leggere per calcolare il bilancio.

Si deve inserire:

Da Data | Viene proposta la data di inizio dell'esercizio, ma è possibile inserire anche date successive per stampare bilanci relativi a periodo diversi, utili ad esempio per raggruppare il conto economico di periodi infra annuali.
A Data | Viene proposta la data del giorno.
Giornale | Questa opzione viene presentata solo se sono stati scelti i registri multipli, permette di scegliere il registro contabile da stampare, si può anche scegliere di cumulare le scritture di più registri, questo ad esempio è utile se si inseriscono scritture extra-contabili, ad esempio per calcolare ratei di ammortamento.
Centri di costo e tipo IVA | Si può scegliere di leggere i dati di bilancio raggruppati per centri di costo e tipo iva

Dopo aver inserito i dati richiesti, viene effettuata la lettura dei movimenti contabili compresi nelle scelte effettuate e vengono presentati i risultati in una lista che per ogni conto movimentato elenca CODICE, DESCRIZIONE, TIPO, DARE, AVERE. Se il saldo in base al tipo di conto ha il segno sbagliato, viene segnalato l'errore con un asterisco nella colonna E. Ai piedi della lista vengono visualizzati i totali di Attività, Passività, Costi e Ricavi e con la rilevazione dell'Utile o della Perdita d'esercizio.

Da questa posizione sono disponibili diverse utili funzioni. Ad esempio facendo doppio click su una riga è possibile vedere la scheda del conto.

Dal pulsante dei comandi speciali, è anche possibile fare la riclassificazione del bilancio, utile ad esempio per predisporre il bilancio in formato europeo, oppure per fare analisi di bilancio o per uniformare il bilancio ad esigenze di altri come commercialisti o banche.
Per riclassificare il bilancio è necessario preparare un foglio di calcolo Excel o LibreOffice con a sinistra codice e descrizione riclassificati ed a destra codice e descrizione di Zefiro. Se a sinistra si lasciano le caselle vuote viene utilizzata la riclassificazione delle prima riga non vuota sopra. Si può vedere un esempio nel file "BIL_Riclassificato.xls" si trova nella cartella _EXTRA dentro la cartella che contiene i programmi. Dopo di ciò viene eseguita la riclassificazione e viene generato un file con il formato scelto.

Zefiro consente di gestire le contabilità "Dipartimentali". In sostanza una azienda che ha attività separate, ma che condividono una Partita IVA unica, possono gestire i dipartimenti in archivi separati e quindi di fatto gestire le attività come se fossero aziende separate a tutti gli effetti, ma in fase di stampa del bilancio e delle liquidazioni iva, si possono riunire i dati sommando quelli di tutte le attività dipartimentali.

Per attivare la contabilità dipartimentale, bisogna modificare un parametro nel file di configurazione AGC.ini e questo da la possibilità di importare altri bilanci e di esportare i dati correnti. Con queste funzionalità è possibile stampare i bilanci separati per i vari dipartimenti, ma anche fare la stampa cumulativa di tutti i dipartimenti.

Da questa posizione si possono effettuare tutte le stampe previste che sono:

Stampa Bilancio:

Si deve inserire:

Tipo riepilogo | Premendo il pulsante collegato si apre la lista delle scelte possibili, inserendo 'T' vengono stampati i dettagli di tutti i sottoconti, con 'C' si stampano i totali di mastro e conto ma si escludono i dettagli dei sottoconti, infine con 'M' vengono stampati solo i totali di Mastro.
Riepilogo Clienti | Con questa voce si può scegliere di escludere dalla stampa i dettagli di saldo dei clienti.
Riepilogo Fornitori | Con questa voce si può scegliere di escludere dalla stampa i dettagli di saldo dei fornitori.
Tipo stampa | Con questa voce si sceglie il tracciato stampa da utilizzare. Il bilancio semplice stampa di seguito Attività, Passività, Costi e Ricavi con i totali di ogni sezione, il bilancio contrapposto stampa lo Stato Patrimoniale con le Attività e Passività affiancate ed il Conto Economico con i Costi ed i Ricavi Affiancati, per ogni sezione vengono stampati i totali. La stampa del bilancio sovrapposto espone i dati in modo più dettagliati infatti vengono esposti anche i progressivi di Dare ed Avere oltre che i saldi.
Stampa conti d'ordine | Questa voce viene presentata solo per il bilancio semplice e per il bilancio sovrapposto e serve per indicare se si desidera stampare anche i conti d'ordine oltre ad Attività, Passività, Costi e Ricavi.

Centri di costo/ricavo:

Questa procedura permette di stampare i conti economici (costi e ricavi) raggruppati secondo la tabella dei centri di costo e ricavo, si può scegliere di stampare il dettaglio dei sottoconti oppure solo i totali.

Raggruppamento IVA:

Questa procedura permette di stampare i costi separati per tipo IVA e serve per copiare i dati ricavati nella denuncia annuale IVA, si può scegliere di stampare il dettaglio dei sottoconti oppure solo i totali.


Questa procedura permette di effettuare calcoli di bilanci riclassificati, di effettuare diversi tipi di calcolo sui bilanci riclassificati ed infine di stampare di dati ottenuti.

La riclassificazione consiste nel predisporre un Piano dei Conti alternativo rispetto a quello che viene usato per inserire le scritture e di indicare in quali conti del PDC riclassificato vanno inseriti i saldi dei conti del PDC operativo.

Le riclassificazioni si fanno per ottenere bilanci organizzati in modo diverso ad esempio per effettuare la stampa del bilancio europeo, oppure per realizzare PDC semplificati si cui calcolare indici di bilancio.

Le indicazioni su come effettuare le riclassificazioni devono essere inserite in semplici files di testo che hanno una sintassi ben definita che deve essere rispettata per ottenere risultati corretti. La spiegazione su come devono essere strutturati questi files di testo ed alcuni esempi di tracciati funzionanti sono reperibili tra i files di installazione del programma, ma per maggiori chiarimenti preghiamo di contattare gli addetti della Compusoft.

Per effettuare il calcolo si devono indicare il file di configurazione da usare ed i periodi per cui si vuol fare il calcolo.

I dati da inserire sono:

Nome del file di configurazione | Si deve inserire il nome del file di configurazione utilizzato per fare il calcolo. I files riconosciuti solitamente hanno estensione PCR. Se il file non rispetta la sintassi dei files di configurazione viene segnaloto l'errore e si deve procedere quindi alle correzzioni fintano che il formato non è corretto. Esaminare i files forniti come esempio e la documentiazione specifica per realizzare files formalnmete corretti.
Esercizio | Si possono calcolare fino a 12 esercizi, nella stampa i numeri verranno affiancati per fare raffronti tra i numeri.
Da Data, A Data | Per ogni esercizio calcolato si possono inserire i limiti di data, questo serve per esempio per fare raffronti di periodi inferiori all'anno, ad esempio si possono confrontare gli andamenti dei 12 mesi.
Registri | Per ciascun esercizio si possono inserire i codici dei registri su cui effettuare il calcolo. In questo modo ad esempio si potrebbero utilizzare registri diversi per inserire dati previsionali e di budget per controllare nel tempo gli scostamenti.
Calcola | Questo pulsante permette di leggere tutte le scritture inserite per ciascun esercizio ed effettuare tutti i calcoli di riclassificazione. Il calcolo potrebbe richiedere molto tempo se i dati da leggere sono tanti o se sono stati richiesti molti esercizi. Comunque solitamente sono tempi assolutamente accettabili nell'ordine di minuti.
Stampa | Dopo aver effettuato il calcolo si può effettuare la stampa. L'aspetto della stampa dipende dal numero di esercizi richiesti e dalle direttive di stampa inserite nel tracciato.
Visualizza | Con questo pulsante si effettua una visualizzazione veloce dei dati calcolati.
Utilità | Questo pulsante mette a disposizione alcune procedure di utilità che sono utili soprattutto durante la fase di messa a punto dei tracciati. Il comando Stampa lista saldi, stampa la lista degli importi letti per ciascun conto del piano dei conti ed evidenzia il conto riclassificato che viene utilizzato, in modo da verificare in che modo vengono generati i numeri. Il comando Calcola riclassificazione permette di rileggere il file di configurazione senza dover rileggere i saldi del bilancio, in questo modo è possibile apportare semplici modifiche ai tracciati senza dover rileggere ogni volta il bilancio. I comandi Esportazione testo ed Esportazione Excel permettono di effettuare una esportazione grezza dei dati letti per effettuare eventuali altre elaborazioni.


Questa precedura permette di stampare tutte o parte delle schede di contabilità, si devono fare stampe separate per i conti ordinari, i clienti ed i fornitori.

I dati da inserire sono:

Tipo stampa | Si deve scegliere il tipo di conti da stampare, si possono scegliere conti ordinari, oppure clienti o fornitori.
Da sottoconto/Codice | Inserire il codice del primo sottoconto o cliente o fornitore da stampare. Premendo il pulsante collegato si apre la lista di dati appropriata.
A sottoconto/Codice | Inserire il codice dell'ultimo sottoconto, o cliente o fornitore da stampare. Premendo il pulsante collegato si apre la lista di dati appropriata.
Da Data | Viene proposta la data di inizio dell'esercizio.
A Data | Viene proposta la data finale gestita dal programma, in questo modo potranno entrare a far parte della scheda anche scritture fatte in esercizi successivi ma con competenza dell'anno in corso.
Giornale | Questa opzione viene presentata solo se sono stati scelti i registri multipli, permette di scegliere il registro contabile da stampare, si può anche scegliere di cumulare le scritture di più registri.
Solo esercizio corrente | Si può decidere se stampare solo le scritture appartenenti all'esercizio corrente oppure se si desidera stampare tutte le scritture comprese tra le date indicate.
Solo saldo diverso da zero | Si può sceglere di stampare solo le schede che hanno il saldo diverso da zero, in questo caso prima di stampare vengono letti i movimenti e se il saldo è uguale a zero non si effettua la stampa.
Dettaglio contropartite | Si può decidere i elencare per ogni scrittura anche la lista delle contropartite implicat e.
Ordine alfabetico | Per i clienti e fornitori è possibile scegliere se effettuare la stampa in ordine alfabetico.
Stampa scadenze | Per i clienti e fornitori è possibile stampare alla fine della scheda anche le scadenze ancora aperte. Se ci sono tra le scadenze anche effetti presentati in banca, viene evidenziato il totale degli effetti presentati ed il totale della esposizione.

Alla fine viene effettuata la stampa


Questa procedura permette di stampare le partite contabili tutte in una volta il formato di stampa è lo stesso utilizzato dalla procedura di gestione partite contabili.

I dati da inserire sono:

Tipo anagrafica | Con questa voce si sceglie se stampare le partite dei clienti o dei fornitori.
Tipo stampa | La stampa può essere sintetica o analitica. La stampa analitica elenca tutte le scritture che appartengono a ogni partita, viceversa la stampa sintetica stampa solo i totali di partita.
Tipo partite | Di norma si stampano solo le partite aperte, ma con questa opzione si possono stampare anche solo le partite chiuse o tutte le partite.
Includi scadenze | Con questa opzione si può indicare se si desidera stampare oltre ai dati delle partite, anche la lista delle scadenze del cliente o fornitore
Clienti/Fornitori | Si può scegliere di stampare tutte le anagrafiche che hanno partite aperte oppure se ne possono selezionare solo alcune.
Agenti | Questa selezione viene visualizzata solo per le partite dei clienti e permette di selezionare gli agenti in modo da dare ad ogni agente la stampa dei clienti da visitare.
Data partita | Si possono selezionare solo le partite comprese in una determinata data.
Ordine alfabetico | La lista può essere effettuata in ordine di codice o in ordine alfabetico.
Salto pagina | Si può decidere di stampare una scheda per pagina oppure tutte di seguito
Stampa totali | Volendo si può stampare il totale generale alla fine della stampa.

Alla fine viene effettuata la stampa


Questa procedura permette di stampare tutti i registri IVA in prova o in modo definitivo. Prima di effettuare questa stampa è bene eseguire la procedura di Verifica quadratura, per controllare e correggere eventuali errori nei protocolli poiché se ci sono errori di protocollo è possibile che la stampa dia risultati non corretti.

I dati richiesti sono:

Tipo registro | Si sceglie il tipo di registro IVA da stampare. Si possono stampare le Vendite, gli Acquisti, i Corrispettivi e se è stata abilitata l'apposita opzione nelle preferenze, anche il registro degli acquisti intracomunitari.
Tipo di stampa | Si può fare la stampa di prova, oppure la stampa definitiva o la ristampa, queste ultime due stampe aggiornano i progressivi di stampa che vengono memorizzati nei numeratori, in questo modo viene impedita la possibilità di ulteriori modifiche delle scritture.
Data di stampa | Viene proposta la data del giorno ed è la data che viene riportata nelle stampe.
Registro | Se è stata abilitata l'opzione per i registri multipli, viene chiesto il registro contabile da stampare, ad eccezione che per la stampa del registro degli acquisti intracomunitari in qui la macchina sa già qual è il codice del registro da stampare. In caso di registri multipli è necessario ripetere la stampa per tutti i registri utilizzati. Il registro degli acquisti intracomunitari deve essere stampato anche come registro acquisti normale.
Fino a data | Vengono stampate le registrazioni fino alla data inserita.
Ultimo protocollo | Questa voce viene richiesta solo per la stampa di prova e per la ristampa, si deve inserire il numero di protocollo precedente al primo da stampare. Premendo il pulsante collegato, viene chiesta la prima data da stampare e viene trovato il protocollo corretto.
Conferma inserimento bollato | Questo dato viene chiesto solo per la stampa definitiva e per la ristampa e serve ad evitare che vengano fatte stampe definitive non desiderate.
Num. pagina iniziale | Nella stampa definitiva e nella ristampa, si può indicare il numero di pagina da cui far partire la stampa, si deve trovare il numero dell'ultima pagina stampata definitiva sul cartaceo e si inserisce il numero seguente.

Alla fine viene effettuata la stampa


Questa procedura permette di stampare le liquidazioni periodiche IVA.

Si possono fare la stampa di prova, oppure la stampa definitiva o la ristampa. Ma per fare la stampa definitiva, prima si devono stampare i registgri in modo definitvo.

Zefiro in fase di registrazione delle fatture consente di indicare la "competenza IVA" con data documento diversa dalla data di registrazione. Ad esempio se nei primi giorni di Luglio si registrano fatture di Giungo e quindi con compentenza al mese precedente. Le fatture con competenza IVA diversa dalla data di registrazione, verranno stampate nei registri IVA secondo la data di registrazione ma verranno calcolate nella liquidazione del periodo IVA di compentenza.

Durante la fase di stampa se vengono trovate fatture con data di registrazione diversa dalla data di compentenza IVA, viene chiesto se nella liquidazione dovrà essere stampata una riga che evidenzia gli importi con registrazione diversa dalla compentenza. In questo modo diventa più facile fare i controlli.

I dati richiesti sono:

Tipo di stampa | Si può fare la stampa di prova, oppure la stampa definitiva o la ristampa, queste ultime due stampe aggiornano i progressivi letti nell'archivio delle dichiarazioni IVA, in modo da conservare i dati di stampa per effettuare riepiloghi.
Periodo IVA | Inserire il periodo da stampare, se nelle preferenze si è optato per la gestione trimestrale si inserisce il numero di trimestre, altrimenti il numero del mese, questo dato viene chiesto per la stampa di prova o per la ristampa poiché la stampa definitiva automaticamente stampa il periodo successivo all'ultimo stampato.
Credito precedente | Per la stampa di prova o per la ristampa è possibile inserire l'eventuale credito precedente, la stampa definitiva conosce automaticamente questo dato.
Margine precedente | Questo dato viene chiesto solo per la stampa di prova e per la ristampa se nelle preferenze è stato scelto il regime del margine che è un particolare regime IVA a cui sono soggetti coloro che commerciano beni usati.
Note | Si possono scrivere delle annotazioni che verranno riportate nella liquidazione.
Altri importi | Premendo questo pulsante si apre una finestra che permette di inserire fino a quatto righe con descrizione ed importo. Questo serve per inserire dati di compensazione tra imposte per abbassare o alzare l'importo della dichiarazione. Tra le altre cose viene inserito in questa posizione l'importo dell'acconto IVA versato nel mese di Novembre.
Genera scrittura contabile | Se si spunta questa opzione, Alla fine della stampa delle Liquidazione viene generata la scrittura contabile che gira il saldo tra l'IVA acquisto e l'IVA vendite verso il conto "Erario C/IVA". Perché funzioni, è necessario che le causali siano presenti e configurate correttamente. Se sono state registrate fatture con competenza IVA diversa, è possibile generare una scrittura che gira l'iva per competenza su un conto transitorio che verrà chiuso alla fine di tutte le registrazioni per compentenza. In questo modo è più facile fare i controlli.
Data Versamento e Codice Banca | Questi dati chiesti solo per la stampa definitiva e per la ristampa vengono riportati sulla stampa.
Conferma inserimento bollato | Questo dato viene chiesto solo per la stampa definitiva e per la ristampa e serve ad evitare che vengano fatte stampe definitive non desiderate.
Num. pagina iniziale | Nella stampa definitiva e nella ristampa, si può indicare il numero di pagina da cui far partire la stampa, si vede il numero dell'ultima pagina stampata definitiva e si inserisce il numero seguente.

Zefiro consente di gestire contabilità dipartimentali, per maggiori spiegazioni consultare la voce Stampa Bilancio. In sostanza si possono gestire attività separate come se fossero ditte separate i poi fare la stampa cumulativa delle liquidazioni.
Se è stata attivata questa funzionalità, viene chiesto si si desidera importare i dati delle liquidazioni dipartimentali per fare una stampa cumulativa unica e di salvare i dati della liquidazione del dipartimento corrente.

Alla fine viene effettuata la stampa e nel caso di stampa definitiva e ristampa vengono aggiornati i dati memorizzati nell'archivio delle dichiarazioni IVA

Nella stampa si tiene conto dello Split Payment e dell'IVA per cassa.


Questa procedura serve per predisporre i files da comunicare alla Agenzia delle Entrate contenete la lista trimestrale delle fatture emsesse e ricevute.

Dal 01/01/2019 con l'entrata in vigore della "Fatturazione elettronica tra privati" la comunicazione delle fatture denominata "Spesometro" non è più obbligatoria, ma rimane obbligatorio l'invio dei dati delle fatture estere emesse e ricevute, ad eccezione delle fatture emesse purché vengano inviate come "fatture elettroniche".

Sono stati perciò messe a disposizione due procedure. La prima che prepara lo spesometro come da normativa precedente, ed una nuova procedura che prepara esclusivamente la lista delle fatture estere.

I riferimenti tecnici e normativi si trovano nella pagina

La Compusoft ha predisposto una comunicazione che spiega il funzionamento ed i modi di utilizzo per l'invio di comunicazioni corrette, che è reperibile nella cartella "_EXTRA" dei files di distribuzione di Zefiro e che può essere consultata per maggiori chiarimenti.

Le richieste sono diversificate per la spedizione dello Spesometro e del Esterometro.

Nel caso dello spesometro, per avviare la generazione dei files si devono inserire i seguenti dati:

Anno di riferimento | Indicare l'anno dei documenti. Per la comunicazione per il quarto trimestre che viene fatta in febbraio, l'anno sarà quello precedente.
Trimestre | Inserire il trimestre da preparare.
Invia tutto il semestre | Se si desidera, invece che inviare i trimestri, si possono invare i semestri completi. Ad esempio per spedire il secondo semestre si deve scegliere il trimestre "3" e spuntare questa voce.
Tipo comunicazione | Scegliere il tipo di comunicazione che può essere quello delle fatture emesse o quello delle fatture ricevute. E' prevista anche la possibiltà di preparare una comunicazione di annullamento di una comunicazione precendente.

Per l'esterometro invece si devono inserire i seguenti dati:

Anno di riferimento | Indicare l'anno dei documenti. Per la comunicazione per il quarto trimestre che viene fatta in febbraio, l'anno sarà quello precedente.
Mese | Inserire il mese da preparare.
Tipo comunicazione | Scegliere il tipo di comunicazione che può essere quello delle fatture emesse o quello delle fatture ricevute. E' prevista anche la possibiltà di preparare una comunicazione di annullamento di una comunicazione precendente.

La procedura esegue una serie di controlli sui dati inseriti e da alcune segnalazioni che possono essere bloccanti nel caso in cui gli errori impedissero l'accettazione della comunicazione da parte della Agenzia delle Entrate, oppure possono essere segnalazioni di anomaliche che comunque non impediscono l'invio dei files.

Se non ci sono errori bloccanti viene prodotta la lista dei dati elaborati ed alla fine se si accetta la generazione del file viene prodotto il file pronto per essere spedito. E viene registrato il progressivo di invio. nella tabella delle comunicazioni presente alla voce di menù: Dati > Altri archivi > Comunicazione Fatture.

Per ogni scadenza dovranno essere predisposti due files, uno per le fatture emesse ed uno per le fatture ricevute.

La comunicazione può essere rifatta quante volte si vuole, però per poterla rifare, è necessario cancellare dalla tabella delle comunicazioni la riga della comunicazione precedente.

I files da spedire si trovano nella cartella "C:\CS\COM3FAT\" con una sottocartella per ogni anno di produzione dei files. Oltre ai files in formato XML da spedire, sono presenti anche i files in un formato intermedio json richiesto dalla procedura ed i files in formato testo contenenti la lista dei dati presenti nella comunicazione.

I nomi dei files rispettano le regole previste dalle specifiche tecniche, il progressivo di invio corrisponde al codice della comunicazione nella tabella con la lista delle comunicazioni ed è un progressivo numerico di 5 cifre composto dalle ultime due cifre dell'anno di spedizione ed un progressivo numerico di tre cifre. Ad esempio la prima spedizione del 2017 avrà come progressivo numerico 17001. Viene utilizzato l'anno di spedizione anche se la comunicazione si riferisce all'anno precedente. Ad esempio la comunicazione con progressivo 18001 si potrebbe riferire al quarto trimestre del 2017.

Per maggiori dettagli rimandiamo alla comunicazione già menzionata.


Questa procedura serve per stampare il riepilogo annuale dei movimenti IVA, viene utilizzto lo stesso tracciato stampa ultizzato per le dichiarazioni IVA. Questa stampa è utile per rilevare i dati da riportare nella dichiarazione annuale IVA.

I dati richiesti sono:

Tipo calcolo | I dati di riepilogo possono calcolati leggendo le registrazioni IVA indipendentemente dal fatto che siano state stampate o no, oppure letti dall'archivio delle dichiarazioni stampate in via definitiva, ed in questo caso è possibile includere nella stampa anche la lista dei versamenti effettuati. Infine possono essere calcolati leggendo i dati IVA registrati tra due date, in questo caso però non sarà possibile ottenere il calcolo corrento per i regimi IVA speciali scelti nelle preferenze.
Credito precedente | Se si sceglie di leggere i movimenti, è possibile inserire l'eventuale credito precedente.
Margine precedente | Questo dato viene chiesto solo per la stampa da lettura movimenti se nelle preferenze è stato scelto il regime del margine che è un particolare regime IVA a cui sono soggetti coloro che commerciano beni usati.
Altri importi | Premendo questo pulsante si apre una finestra che permette di inserire fino a quatto righe con descrizione ed importo, anche questo dato è disponibile solo in caso di lettura movimenti.
Dettaglio versamenti | Questo dato viene chiesto solo in caso di lettura dei dati dalle dichiarazioni, e serve per indicare se si desidera stampare anche il dettagli dei versamenti effettuati.
Da data a data | Questo dato viene chiesto solo in caso di lettura dei dati da data a altra data, ed indica le date limite di calcolo, vengono proposte le date iniziale e finale dell'anno in corso.
Num. pagina iniziale | Se si desidera stampare il riepilogo sui registri vidimati, si può indicare il numero di pagina da cui far partire la stampa, si vede il numero dell'ultima pagina stampata definitiva e si inserisce il numero seguente.


Lo stato ha emanato leggi e decreti che regolano il pagamento dell'IVA al momento dell'incasso da parte del creditore. La legge già presentata nel 2008 è stata nuovamente presentata con alcune modificazioni ai massimali.

I riferimenti legislativi sono:
Il Decreto legge n. 83 del 22/06/2012 (art. 32-bis) Convertito nella legge n. 134 del 07/08/2012

I riferimenti legislativi precedenti sono:
Il Decreto legge n. 185 del 29/11/2008 (art. 7) Convertito nella legge n. 2 del 28/01/2009
Il Decreto legge n. 26 del 26/03/09
La Circolare n. 20/e del 30/04/2009

In estrema sintesi i punti salienti della legge sono:

Possono usufruire del beneficio coloro che durante l'anno precedente hanno emesso fatture per un importo inferiore a 2.000.000,00 Euro.

Sono escluse le vendite effettuate a soggetti privi di partita IVA.

Il venditore può decidere quali sono le fatture a cui applicare l'esigibilità dell'IVA per cassa ed in caso deve apportare in fattura la dicitura “Operazione con imposta ad esigibilità differita ai sensi dell'articolo 7 del decreto legge n. 185 del 2008”

Il cliente che riceve questo tipo di fattura avrà diritto alla detrazione dell'IVA di acquisto nel momento in cui effettuerà il pagamento.

Passato un anno dalla emissione della fattura l'IVA diviene comunque esigibile anche se il pagamento non è stato ancora effettuato.

Nel calcolo della liquidazione periodica dell'IVA, verrà effettuato il calcolo dell'IVA sospesa e dell'IVA diventata esigibile perché è stato effettuato il pagamento o per decorrenza del limite temporale.

In caso di pagamenti parziali l'IVA diventa esigibile per la quota proporzionale all'importo incassato.

Il supporto di Zefiro alla legge:

Zefiro permette di gestire l'iva per cassa ma richiede che il controllo della congruità dei dati sia effettuato dall'operatore.

Il sistema permette di inserire i dati interessati dalla legge e poi in fase di stampa delle liquidazioni periodiche viene fatto il conteggio automatico in base ai dati inseriti.

L'inserimento dei dati è facilitato da alcune procedure:

  • L'inserimento di una fattura tra quelle interessate viene effettuato dalla primanota.
  • Dall'archivio delle fatture interessate si possono generare gli incassi ed i pagamenti
  • Dall'archivio delle fatture interessate si può stampare la lista delle fatture inserite con il saldo
  • Dall'archivio delle fatture si può generare il movimento di chiusura per decorrenza dei termini.

Nell'archivio dell'IVA per cassa vengono memorizzate le fatture, gli incassi e pagamenti e le chiusure per decorrenza ma per facilitare il lavoro di manutenzione, inizialmente vengono mostrate solo le fatture.

I Comandi speciali disponibili per ogni fattura presente sono:
Seleziona tutto oppure solo fatture e note | Con questo comando si può scegliere se visualizzare solo le fatture e le note d'accredito, oppure tutte le scritture compresi incassi e pagamenti e chiusure per decorrenza.
Calcola decorrenze termini | La legge impone che se il pagamento non viene fatto entro un anno dalla emissione della fattura venga comunque liquidata l'iva. Questa procedura chiede la data limite di decorrenza e scrive automaticamente le scritture di decorrenza di tutti i documenti oltre ai limiti. Prima di eseguire le scritture presenta la lista in qui si possono spuntere le scritture da fare. È importante notare che il programma non effettua alcun controllo sulla decorrenza dei termini, è quindi compito dell'operatore di eseguire periodicamente questa procedura.
Incasso/pagamento | Permette di inserire un incasso o un pagamento. Viene chiesta la data di incasso e l'importo. Viene generata una scrittura che riporta gli estremi della fattura e scorpora automaticamente la parte imponibile e la parte iva dell'incasso.
Decorrenza termini | Questa procedura esegue la scritture di chusura per decorrenza di questo singolo documento se risulta ancora aperto.
Stampa lista saldi | Questa stampa permette di individuare i documenti che sono ancora aperti per facilitare l'individuazione di quelli che stanno per uscire dalla decorrenza dei termini. Viene chiesto se di desidera stampare solo quelli aperti o anche quelli chiusi e se si desidera stampare tutti i movimenti o solo i saldi.

Solitamente non è necessario modificare a mano i dati dell'archivio poiché ci sono tutte le procedure necessarie per generare automaticamente tutte le scritture, ma in ogni caso i dati da inserire sono:

Codice anagrafica | È il sottoconto del cliente o del fornitore
Tipo data e numero di documento | Inserire gli estremi del documento, l'esattezza di questi dati consente di trovare la quadratura dei dati di emissione ed incasso.
Protocollo | Il protocollo IVA permette di trovare il documento nei registri.
Data operazione | Permette di individuare in quale dichiarazione periodica IVA deve essere inserita la scrittura.
Tipo di movimento | Indica il tipo di registrazione: "1" per le fatture o note ammesse, "2" per gli incassi o pagamenti e "3" per la chiusura per decorrenza dei termini.
Imponibile | Inserire la quota imponibile, nelle fatture è il totale imponibile del documento.
Imposta | Inserire la quota di imposta. Negli incassi e pagamenti e nella chiusura per decorrenza dei termini, l'imposta è proporzionale alla quota presente nella fattura. Ad esempio se la fattura è di 1000 Euro con 200 Euro di IVA, se si riceve un incasso di 600 Euro in proporzione la quota imponibile è di 500 Euro e la quota IVA è di 100 Euro

L'utilizzo di questi dati nelle dichiarazioni periodiche è automatico, però non ne viene tenuto conto in fase di stampa dei riepiloghi annuali.


 Questa utile stampa serve per fare controlli sui dati iva inseriti con la procedura di primanota, stampa infatti le registrazioni per codice iva o per codice anagrafica del cliente o del fornitore, alla fine di ogni codice presenta il riepilogo ed i totali.

I dati richiesti sono:
Tipo stampa | Si può eseguire la stampa raggruppata per codici iva o per codice del cliente o fornitore, il riepilogo finale verrà effettuato per il codice contrario.
Registro IVA | Il programma può gestire registri multipli, se è stata abilitata questa funzione viene chiesto il registro IVA di cui si vuole la stampa.
Tipo registro | Si deve scegliere il tipo di registro IVA di cui si vuole la stampa.
Codice cliente o fornitore | Se si lascia questo campo vuoto, verranno stamate tutte le registrazioni, altrimenti solo quelle appartenteni a questo codice, ovviamente se si sceglie un Cliente e si stampano gli Acquisti non si otterrà alcun risultato e viceversa per Fornitori e Vendite.
Codice IVA | Si può limitare la stampa al solo codice indicato, se si lascia vuoto il campo vengono stampati tuti codici IVA
Da data a Data | Il programma propone di stampare tutte le registrazioni IVA dell'esercizio corrente, ma volendo si può limitare la stampa ad un periodo diverso.
Stampa riepilogo | Si può sceglere se stampare il riepilogo finale per ogni codice oppure no.
Salto pagina | Con questa opzione si può decidere se andare a capo alla fine di ogni scheda.

Alla fine viene eseguita la stampa.


La procedura Riepiloghi Intrastat permette di stampare un prospetto che può essere copiato sui moduli previsti dal Ministero delle Finanze.

I dettagli su chi sono i soggetti obbligati, sulla modulistica e sulla periodicità possono essere trovati sul sito internet della agenzia delle dogane.

La stampa è assolutamente identica a quella che si ottiene con l'analoga procedura che analizza i dati di magazzino invece dei dati contabili. Se si dispone della licenza per la gestione del magazzino, è consigliabile utilizzare questa procedura solo per la stampa del riepilogo degli acquisti, ed invece delegare la stampa del riepilogo delle cessioni alla procedura di magazzino che permette di attivare automatismi tali da non richiedere l'inserimento dei codici Intrastat per ogni documento.

Vengono richieste la data iniziale e finale del periodo da calcolare, il periodo dipende dal volume di affari sviluppato o previsto, può essere a cadenza mensile, trimestrale o annuale.

Viene anche richiesto il tipo di riepilogo che si desidera stampare, che può essere degli acquisti o delle vendite.

Il calcolo viene fatto nel modo seguente:

Vengono prese in considerazione le fatture registrate nel periodo preso in considerazione di Clienti o Fornitori dei paesi CE esclusi gli italiani. I clienti e fornitori CE vengono riconosciuti dal prefisso della partita IVA che deve corrispondere con il codice ISO delle nazioni CE.

Per ogni documento trovato vengono vengono raggruppati i codici Intrastat inseriti, i dati vengono accettati anche se il codice viene lasciato vuoto. Nelle registrazioni si può omettere di inserire il codice per indicare che il prodotto appartiene alle categorie che per loro natura sono esclusi dalla normativa.

Dopo aver trovato i dati che devono essere inclusi nel prospetto, viene effettuata la stampa che riporta gli importi per ogni partita IVA e per ogni codice di nomenclatura, viene anche riportato il progressivo degli importi per facilitare la copiatura sui moduli ministeriali.

Nella stampa vengono evidenziate a parte le righe che si riferiscono a prodotti di cui non è stata trovata la nomenclatura Intrastat, in modo da poter verificare se si tratta di un errore o di prodotti normalmente esclusi. Sempre per motivi di controllo, viene esposta anche la ragione sociale dei clienti.


La gestione dei cespiti si compone di tre voci di menù:

Archivio Cespiti viene utilizzato per fare la manutenzione dei cespiti.
Stampa Registro permette di stampare il registro dei cespiti.
Calcolo ratei ammortamentoCalcola ratei di ammortamento per stampare bilanci provvisiori.
Movimenti Cespiti permette di vedere i movimenti eseguiti sui cespiti.


L'archivio dei Cespiti serve per memorizzare i dati dei beni ammortizzabili posseduti dall'azienda. Le procedure disponibili sono in grado di gestire tutte le necessità fiscali, infatti la procedura di stampa del registro è in grado di stampare gli ammortamenti e di fare le scritture di ammortamento. Un altra procedura è in grado di eseguire le scritture di Cessione o Eliminazione alla fine dell'utilizzo del cespite.

Normalmente i cespiti vengono attivati dalla procedura di gestione della primanota quando si registra la fattura di acquisto del cespite, ma niente vieta di inserirli manualmente.

I dati vengono inseriti utilizzando la modalità di gestione documenti, I dati da inserire in testata sono:

Numero Cespite | E' il codice univoco che identifica il cespite.
Data inizio utilizzo | Inserire la data di inizio utilizzo del cespite, è la data utilizzata come riferimento per i calcoli di ammortamento, normalmente coincide con la data della fattura d'acquisto ma potrebbe essere diversa.
Codice gruppo cespiti | E' il codice di sottoconto che identifica il tipo di cespite. Premendo il pulsante collegato si apre la lista dei Conti. Durante la stampa del registro i dati verranno raggruppati per gruppo e verranno stampati totali di gruppo.
Descrizione | Inserire una breve descrizione del bene.
Note | Si può inserire un memo che descrive ulteriormente il bene.
Ammortamento ordinario % | Inserire la percentuale di ammortamento ordinario del cespite. Normalmente è la stessa memorizzata nel Conto del gruppo.
Ammortamento anticipato | Per legge viene consentito di raddoppiare la percentuale di ammortamento durante i primi tre anni, ma il primo anno si deve dimezzare l'aliquota a forfait. Con questa voce si indica se si desidera effettuare l'ammortamento anticipato per questo cespite.
Codice Fornitore | Questo campo ha un valore sostanzialmente descrittivo e serve per memorizzare il codice del fornitore da cui è stato acquistato il bene. Premendo il pulsante collegato si apre la lista dei Fornitori.
Data documento Num. documento | Indicare gli estremi della fattura di acquisto del cespite, anche questi dati non hanno una valenza funzionale.
Valore iniziale del bene | Indicare il valore iniziale del bene che è il punto di partenza per effettuare i calcoli di ammortamento.
Indeducibilità % | Indicare in questo punto l'eventuale percentuale di indeducibilità del cespite.
Bene nuovo | Indicare in questa posizione se il bene era nuovo al momento dell'acquisto, questo valore è solo descrittivo.
Data cessione/esclusione | Questo campo viene gestito automaticamente dal programma e contiene la data in cui il cespite viene ceduto o eliminato.
Valore di cessione | Questo campo viene gestito automaticamente dal programma e contiene il valore di cessione del bene.
Localizzazione e codice deposito | Sono disponibili alcuni campi descrittivi che permettono la sua identificazione, si possono inserire localizzazioni e matricole interne.

Nelle righe vengono memorizzate informazioni di vario tipo. Gli ammortamenti vengono generati automaticamente dalla procedura di stampa definitiva dei cespiti. Altri tipi di riga possono essere inseriti manualmente. I dati da inserire sono:

Data | Inserire la data in cui avviene il movimento.
Tipo movimento | Si apre una lista da cui si può scegliere 1=Aumento di valore, 4=Diminuzione di valore, 5=Ammortamento, 6=Eliminazione, 7=Cessione/Vendita. Le righe di Ammortamento e di Eliminazione o Cessione vengono generate automaticamente, le altre si possono inserire manualmente.
Importo | Inserire il valore del movimento.
Ammortamento % | Se il movimento è un ammortamento, viene indicata la percentuale di ammortamento utilizzata.
Anticipato | Se il movimento è un ammortamento, viene indicato se è ammortamento anticipato oppure no.
Descrizione | Se si desidera si può inserire una breve descrizione del movimento.
Codice fornitore | In caso di aumento di valore, si può inserire il codice del fornitore da qui è stato acquistato il materiale o il servizio che determina l'aumento di valore.
Data e num. documento | Inserire la data ed il numero della fattura del fornitore.

Le Stampe disponibili sono:

Lista cespiti | Stampa una semplice lista di cespiti, se si attivano le spunte verranno stampati solo i cespiti spuntati.
Scheda cespite | Esegue la stampa della scheda del cespite corrente inclusiva di tutti i movimenti effettuati su quel cespite dal momento dell'acquisto.

I Comandi speciali disponibili sono:

Eliminazione / Cessione Quando un cespite viene dismesso per cessione (vendita) o per eliminazione, si devono fare alcune scritture contabili e si devono riportare queste informazioni nel registro dei cespiti. Questa procedura si occupa di effettuare queste operazioni. Se si desidera si può decidere di generare la riga di cessazione senza eseguire le relative scritture contabili.
I dati da inserire sono:
Tipo movimento | I tipi accettati sono '6' per eliminazione e '7' per cessione, premendo il pulsante collegato si apre la lista di scelte.
Data | Inserire la data in cui il cespite viene dismesso.
Valore | Nel caso di cessione del cespite si inserisce il prezzo realizzato per la vendita al netto di IVA.
Causale cessione | Inserire il codice della causale contabile utilizzata per registrare la scrittura di cessione del bene, premendo il pulsante collegato si apre la lista delle Causali. Vengono accettate solo le causali compatibili.
Genera registrazione | Se si toglie la spunta da questa opzione le scritture contabili non verranno fatte.
Genera ammortamento | Se si spunta questa opzione viene generata la scrittura di ammortamento fino alla data di cessione, altrimenti la quota di ammortamento non viene rilevata e la differenza tra valore residuo e valore di cessione viene interamente girata a plusvalenza o minusvalenza.
Registro | Questo dato viene chiesto solo se è stata abilitata l'opzione per i registri multipli.
Descrizione | Inserire una breve descrizione dell'operazione eseguita.
Causale ammortamento | Inserire il codice della causale contabile utilizzata per registrare la scrittura di ammortamento l'ammortamento viene calcolato considerando i giorni di effettivo utilizzo, premendo il pulsante collegato si apre la lista delle Causali. Vengono accettate solo le causali compatibili. Se non c'è la spunta su "Genera ammortamento" questa voce viene ignorata e la scrittura di ammortamento non viene fatta.
Alla fine vengono eseguite le scritture e vengono scritti i movimenti corrispondenti.
Calcola totali | Si apre la gestione delle schede contabili con il codice del cliente preimpostato.
Generazione automatica quote | Questa procedura serve solo se non sono state fatte di anno in anno le stampe definitive con generazione automatica delle scritture contabili. Permette di generare velocemente tutte le quote di ammortamento da una data iniziale ad una data finale. se non si inserisce la data iniziale, si parte dalla data di inizio del cespite. La spunta "Riscrivi quote" indica se ricalcolare le quote eventualmente già presenti.
Visualizza righe | Permette di vedere le righe del cespite senza entrare nella scrittura.
Spunta cespiti | Apre la colonna delle spunte. Si possono spuntare le righe per stampare la lista delle sole righe spuntate.


Questa procedura serve per effettuare la stampa del registro dei cespiti, la stampa può essere di prova oppure definitiva e nel secondo caso vengono anche effettuate le scritture contabili di ammortamento per l'esercizio corrente. La procedura viene sviluppata in tre fasi.

In un primo tempo vengono chiesti i dati sul tipo di stampa da effettuare.

I dati da inserire sono:

Tipo di stampa | Si può effettuare la stampa di prova dei cespiti non stampati oppure di tutti i cespiti (questa seconda stampa serve per ristampare dopo le stampe definitive), o la stampa definitiva dei cespiti
Data di stampa | Viene proposta la data del giorno.
Salto pagina a fine gruppo | Si può decidere di andare a capo alla fine di un gruppo di cespiti.
Anche già ammortizzati | Questo dato viene chiesto solo per le stampe di prova, e serve ad includere o escludere dalla stampa i cespiti che sono già stati ammortizzati completamente. Nella stampa definitiva invece vengono sempre inclusi fintanto che non vengono eliminati o ceduti.
Calcolo ratei | Questo dato viene chiesto solo per le stampe di prova, e serve ad indicare se si desidera che venga calcolata la quota di ammortamento per tutto l'esercizio contabile o solo il rateo fino alla data indicata.
Codice causale | Inserire il codice della causale contabile utilizzata per registrare la scrittura di ammortamento, premendo il pulsante collegato si apre la lista delle Causali. Vengono accettate solo le causali compatibili. Se si lascia vuoto questo campo non vengnon generate le scritture contabili.
Registro | Questa opzione viene presentata solo se sono stati scelti i registri multipli, permette di scegliere il registro contabile da stampare.
Conferma stampa definitiva | Questo dato viene chiesto solo in caso di stampa definitiva e serve per evitare operazioni accidentali.

Dopo aver confermato queste scelte viene aperta una finestra di gestione altre tabelle, contenente la lista dei cespiti con i relativi calcoli di ammortamento, questo dato viene presentato perché si può decidere di variare le aliquote di ammortamento oppure di rinunciare all'ammortamento anticipato, quindi per ogni cespite, se lo stesso non è già stato ammortizzato o ceduto, premendo [Invio] si possono inserire i nuovi dati di calcolo.

Il calcolo dell'ammortamento viene effettuato applicando la percentuale indicata che deve essere al massimo quella consentita per il tipo di cespite, ma il primo anno questa aliquota viene ridotta a forfait del 50%, durante i primi 3 anni di utilizzo del cespite la legge consente di raddoppiare l'aliquota ed in questo caso si ha l'ammortamento anticipato.

Da questa lista è possibile dare alcuni comandi. Si possono spuntare i cespiti da stampare, Si può aprire un singolo cespite per esaminarlo, si possono modificare i parametri di percentuale di ammortamento e di ammortamento anticipato e si può calcolare il valore totale degli ammortamenti per eventuali calibrazioni si percentuale.

Alla fine dopo aver esaminato i dati si è pronti per procedere alla stampa, per stampare si deve confermare la pagina, e se è stata scelta la stampa definitiva, vengono anche effettuate le scritture di ammortamento e registrati i movimenti relativi.


Con questa procedura si genera una scrittura contabile con i ratei di ammortamento dei cespiti fino ad una data prescelta. Dopo aver generato la scrittura di rateo sarà possibile effettuare stampe di bilancio che comprendono anche le quote di ammortamento fino alla data indicata.

È importante capire che la scrittura generata ha carattere temporaneo e deve essere cancellata dopo aver stampato i bilanci richiesti. Se si dimentica di fare la cancellazione si rischia di stampare definitivamente queste scrittura che hanno carattere temporaneo ed in tal caso non resta che fare una scrittura di storno. Si deve anche sapere che il calcolo di ratei non incide con la generazione automatica delle quote di ammortamento che avviene con la stampa definitiva e perciò se si dimentica di cancellare la scrittura di rateo contabilmente si ottengono ammortamenti errati.

Per evitare questi inconvenienti consigliamo di aggiungere nelle preferenze di contabilità un registro contabile aggiuntivo da adibire a registrazioni extra contabili e di fare la registrazione su quel registro, in questo modo si potranno fare stampe definitive del solo registro contabile ufficiale ed in fase di stampa di bilancio scegliere se stampare il bilancio del solo registro ufficiale o includere anche il registro extra contabile contenente i ratei.

I dati da inserire sono:

Codice causale | Inserire il codice della causale contabile utilizzata per registrare la scrittura di ammortamento, premendo il pulsante collegato si apre la lista delle Causali. Vengono accettate solo le causali compatibili.
Registro contabile | Inserire i codice del registro contabile in cui si desidera che venga registrata la scrittura di rateo, come detto in precedenza è fortamente consigliato utilizzare un registro per scritture extra contabili.
Data ratei | Inserire la data fino a cui calcolare i ratei.
Conferma generazione ratei | La scrittura non viene effettuata se non viene spuntata questa voce.

Alla fine viene generata la scrittura contabile che potrà essere utilizzata per la stampa di bilanci comprendenti i ratei.


Questo archivio contiene la lista dei movcimenti effettuati sui cespiti, normalmente viene generata automaticamente dalla stampa del registro di ammortamento o dalla procedura di eliminazione/cessione, ma può essere modificata anche manualmente.

Alcune volte i cespiti possono variare di valore, in caso di danneggiamenti subiscono una riduzione di valore, in caso di miglioramenti con l'aggiunta di accessori, subiscono un aumento di valore, queste variazioni di valore devono essere inserite manualmente con questa procedura.

I dati da inserire sono:

Codice Cespite | E' il codice del cespite a cui il movimento appartiene. Premendo il pulsante collegato si apre la lista dei Cespiti.
Data movimento | Insrire la data in cui avviene il movimento.
Tipo movimento | Inserire il tipo di movimento effettuato. Premendo pulsante collegato si apre la lista di scelte
Descrizione | Inserire la descrizione del movimento.
Ammortamento % | Questo dato viene chiesto solo per i movimenti di ammortamento annuale, ed iindica la percentuale di ammortamento ordinario applicata, per il primo anno la percentuale effettiva applicata è ridotta del 50%
Ammortamento anticipato | Viene indicato se è stato messo in atto l'ammortamento anticipato.
Importo | Indicare l'importo dell'operazione.


 Le ritenute d'acconto sono imposte che vengono pagate da chi fruisce di un servizio per conto del fornitore del servizio, i soggetti che sono soggetti alla normativa della ritenuta d'acconto sono individuati dalla legge, il programma riconosce i fornitori soggetti a ritenuta dal fatto che in anagrafica è stato dichiarato che lo sono ed allora all'inserimento delle fatture di acquisto viene avviata la procedura automatica di gestione. Le voci disponibili sono:

Archivio Ritenute contiene le ritenute
Pagamento Fornitori serve per registrare il pagamento del fornitore
Pagamento Ritenute con questa procedura si effettua il pagamento delle ritenute d'acconto
Lista ritenute da pagare ci informa di quali sono le ritenute in scadenza
Prospetto modello 770D è una stampa utile ai fini della dichiarazione dei redditi
Attestazioni percepienti viene utilizzata per inviare ai fornitori la lista delle ritenute pagate.


Nell'archivio dei Fornitore è possibile specificare quali sono i fornitori soggetti a ritenuta d'acconto, alla fine della registrazione di primanota delle fatture di questi fornitori vengono generate automaticamente le ritenute d'acconto che vengono memorizzate in questo archivio.

Solitamente non serve fare alcuna modifica ai dati inseriti che sono:

Codice Fornitore | E' il codice di sottoconto del fornitore. Premendo il pulsante collegato si apre la lista dei Conti.
Data Fattura Numero Fattura | Sono gli estremi della fattura di acquisto.
Numero Protocollo | E' il numero di protocollo assegnato alla fattura durante la registrazione di primanota.
Data Pagamento a Fornitore | E' da data in cui viene pagato il fornitore, questo dato viene inserito automaticamente dalla procedura di pagamento fornitore ed è la data di riferimento utilizzata per il pagamento delle ritenute.
Data Pagamento Ritenuta | E' la data in cui è stata pagata la ritenuta, questo dato viene inserito automaticamente dalla procedura di pagamento ritenute.
Banca o Esattoria | Contiene la descrizione della banca o esattoria in cui viene effettuato il pagamento delle ritenute.
Imponibile | Contiene l'importo della parte imponibile della fattura utilizzato per calcolare la ritenuta d'acconto.
Imposta | Contiene l'importo dell'imposta della fattura.
Importi non imponibili | Contiene l'importo delle somme non imponibili contenute nella fattura, solitamente sono importi di rimborso di spese sostenute dal fornitore.
Codice tipo versamento | E' il codice del tipo di versamento da riportare nei moduli di pagamento delle ritenute. Premendo il pulsante collegato si apre la lista di scelte, questo dato viene preso dai dati presenti nell'anagrafica del Fornitore.
Percentuale Ritenuta | E' la percentuale di ritenuta a cui è soggetto il fornitore.
Perc. non soggetta a ritenuta | E' la percentuale di imponibile non soggetta a ritenuta che può essere applicata ai soggetti che ne hanno diritto, solitamente i collaboratori che sostengono spese in proprio sono esentati dal 50% della ritenuta.
Importo ritenuta | E' l'importo della ritenuta da pagare.


Per legge l'obbligo di pagamento delle ritenute d'acconto parte dal momento in cui viene effettuato il pagamento della ritenuta d'acconto e non dall'emissione della fattura pertanto se è stata registrata una fattura con d'acconto, ma non è stato ancora pagato il fornitore, non scatta l'obbligo di pagamento della ritenuta, normalmente questo non succede perché è nell'interesse del fornitore di emettere la fattura solo nel momento in cui viene effettuato il pagamento ed infatti molti professionisti emettono il "preventivo di parcella" per ottenere il pagamento e solo dopo emettono la fattura vera e propria.

Questa procedura serve per fare la registrazione contabile di pagamento del fornitore, una finestra contenente una selezione delle sole ritenute per cui non è ancora stato pagato il fornitore. I dati contenuti sono esattamente gli stessi presenti in archivio ritenute.

Premendo [Spazio] si accede ai comandi speciali in cui è presente la voce Pagamento fornitore.

I dati da inserire sono:

Causale pagamento | Inserire il codice della causale contabile utilizzata per registrare la scrittura di pagamento del professionista, premendo il pulsante collegato si apre la lista delle Causali. Vengono accettate solo le causali compatibili.
Registro | Questo dato viene chiesto solo se è stata abilitata l'opzione per i registri multipli.
Data pagamento | Inserire la data in cui viene effettuato il pagamento del fornitore.
Descrizione | Inserire una breve descrizione dell'operazione eseguita.
Causale contropartita | Inserire il codice di sottoconto utilizzato per effettuare il pagamento, solitamente la Cassa o la banca, premendo il pulsante collegato si apre la lista dei Conti.

Alla fine viene effettuata la scrittura contabile di pagamento e vengono aggiornati i dati della ritenuta.


Con questa procedura si effettua il pagamento delle ritenute d'acconto.

I dati vengono inseriti utilizzando la modalità di gestione documenti, In testata vengono richiesti:

Causale pagamento | Inserire il codice della causale contabile utilizzata per registrare la scrittura di pagamento delle ritenute, premendo il pulsante collegato si apre la lista delle Causali. Vengono accettate solo le causali compatibili.
Data pagamento | Inserire la data in cui viene effettuato il pagamento delle ritenute.
Descrizione | Inserire una breve descrizione dell'operazione eseguita.
Causale contropartita | Inserire il codice di sottoconto utilizzato per effettuare il pagamento, solitamente la Cassa o la banca, premendo il pulsante collegato si apre la lista dei Conti.
Banca/Esattoria | Inserire la descrizione della banca o dell'esattoria in cui viene effettuato il pagamento.
Registro | Questo dato viene chiesto solo se è stata abilitata l'opzione per i registri multipli.

Dopo aver inserito i dati di testata, vengono letti i dati delle ritenute e se ci sono ritenute da pagare alla data inserita, si passa alla gestione delle righe nella quale si può scegliere individualmente le ritenute da pagare, normalmente si effettua il pagamento di tutte le ritenute dato che vengono presentate solo le ritenute che sono in scadenza.

Alla conferma del pagamento vengono effettuate le scritture di pagamento ritenute e vengono aggiornati i dati delle ritenute.


Per legge le ritenute d'acconto devono essere pagate entro il giorno 15 del mese successivo a quello in cui è avvenuto il pagamento del fornitore, questa stampa è molto utile perché richiede la data di riferimento ed esegue la stampa della lista delle ritenute che devono essere pagate, vengono calcolati i totali anche raggruppati per codice di pagamento.


Questa stampa fornisce la lista dei pagamenti a fornitori soggetti a ritenuta per l'anno richiesto. Vengono stampati tutti i dati che è necessario riportare nel modello 770D della dichiarazione dei redditi.


A tutti i soggetti a ritenuta d'acconto si devono spedire le attestazioni delle ritenute d'acconto versate per loro conto, con questa procedura si può eseguire questa stampa, si possono stampare le attestazioni di tutti i fornitori soggetti a ritenuta, oppure di uno solo.


Questa procedura al momento è disponibile solo se nel PC è installato MS Excel.

Consente di esportare i dati delle ritenute effettuate nell'esercizio indicato.

Vengono preparate due tabelle, la prima contiene la lista dei soggetti che hanno percepito compensi e la seconda è la lista delle fatture emesse con relative ritenute.

I dati contenuti prendono in considerazione solo le casistiche più comuni. Eventuali casi particolari dovranno essere integrati a mano.

In caso di necessità sarà possibile realizzare tracciati diversi sulla base di richieste specifiche.

Vengono richiesti l'anno di pagamento delle ritenute ed eventualmente il codice di un singolo fornitore.

Alla fine del calcolo vengono generati i due files Excel che contengono i dati.


I Centri di Costo (e di Ricavo), sono una classificazione delle scritture contabili.

Spesso la gestione dei CDC viene eseguita per raggruppare i Costi per area funzionale, ma funziona allo stesso modo anche per i Ricavi, e quindi se si desidera si possono separare anche i ricavi, anche se spesso si preferisce separarli utilizzando sottoconti separati immediatamente visibili a livello di bilancio.

Quando nelle registrazioni contabili si inseriscono conti di Costo o Ricavo, è possibile indicare il CDC a cui assegnare la spesa o il ricavo. in questo modo, sarà possibile calcolare totali per ogni CDC monitorato, Zefiro dispone di una gestione di base che consente di eseguire totalizzazioni a livello di bilancio. Questo modulo separato aggiunge alle funzionalità di base la possibilità di aggiungere annotazioni cronologiche anche con rilevazione di costi e ricavi extracontabili e la possibilità di fare alcune stampe specifiche.

Il modulo si basa su alcune tabelle specifiche che vengono abbinate alla scritture contabili.

La gestione dei Centri di Costo si compone di queste voci di menù:

Centri di Costo è l'archivio della ripartizione di costo e di ricavo abbinato alle scritture contabili.
Stampa Registro permette di stampare un registro cronologico della movimentazione dei CDC.
Annotazioni per ogni CDC è possibile scrivere annotazioni cronologiche anche con importi extra contabili.
Tipi di CDC si possono raggruppare i CDC per tipo.
Preferenze permette di configurare le procedure sui CDC.


In questa tabella si possono inserire i Centri di Costo e Ricavo che possono essere collegati alle registrazioni contabili.

I dati da inserire sono:

Codice | Inserire un codice univoco di tre caratteri.
Descrizione | È la descrizione generica del CDC
Tipo | Si pssono raggruppare i CDC per tipo, ad esempio si potrebbero separare le macchine di produzione dagli automezzi e dagli uffici.
Note | Si possono inserire annotazioni libere.

I comandi speciali disponibili sono:

Vedi annotazioni | Si possono inserire annotazioni cronologiche per questo CDC
Spunta CDC | Si apre la colonna di spunta per stampare solo i CDC spuntati
Conversione movimenti contabili | In caso di ripensamenti relativamente alla struttura dei CDC, si possono variare i condici nelle scritture contabili. Venvono chiesti i limiti di data ed i CDC di partenza ed arrivo e se viene data la conferma si esegue la sostituzione massiva dei movimenti contabili.

Le Stampe disponibili sono:

Lista | Viene fatta una semplice lista dei CDC
Scheda Centro di Costo | Si può fare una stampa dei movimenti e delle annotazioni per il CDC corrente. Si può anche stampare il riepilogo raggruppato per sottoconto.


Viene stampato il registro dei movimenti nei CDC

Vengono chiesti i limiti di data e si può spuntare i tipi di dati da stampare ed i riepiloghi desiderati. Si può anche decidere di escludere dalla stampa i movimenti che non sono stati assegnati a CDC specifici.


Si può tenere un registro cronologico degli avvinimenti per ciascun CDC, ad ogni annotazione è possibile indicare anche un importo di spesa o ricavo, non rilevato in altro modo attraverso la contabilità, ad esempio una manutenzione di macchine effettuata con personale interno non viene attribuita contabilmente perché i salari e stipendi del personale non vengono ripartiti per mansione, ed allora si può indicare in questa posizione l'imputazione della stima del costo.

I dati da inserire sono:

Data operazione | Indicare la data della annotazione
Codice CDC | Inserire il codice del CDC a cui si riferisce
Descrizione | Inserire la descrizione
Importo | Si può inserire il costo non rilevato contabilmente.
Ricavo | Se l'importo extracontabile è un ricavo si deve mettere questa spunta.
Note | Descrizione estesa della annotazione.
Codice | Identifica in modo univoco la scrittura

I comandi speciali disponibili sono:

Spunta Serve per scegliere le righe da stampare.

Le Stampe disponibili sono:

Lista Viene fatta la stampa della lista delle registrazione selezionate e spuntate e vengono anche calcolati i totali.


Questa procedura permette di ricalcolare automaticamente le assegnazioni dei centri di costo nelle scritture contabili per i sottoconti che hanno un centro di costo predefinito nel piano dei conti.

Solitamente non è necessario eseguirla. Infatti si usa solo in caso di ripensamente nella assegnazione dei centri di costo. Ma se necessario i dati richiesti sono:

Da data a Data | Vengono richieste la data iniziale e finale di calcolo, vengono proposti l'inizio e la fine dell'esercizio in corso.
Conferma | Trattandosi di una procedura che esegue modifiche massive, viene chiesta la conferma all'operatore.

Alla fine della lettura dei dati viene presentata la lista dei sottoconti interessati ed il numero di scritture da cambiare. Si possono spuntare solo i sottconti che si desidera riclassifcare ed alla conferma viene eseguita la riclassificazione.


La gestione dei centri di costo richiede un solo parametro di configurazione.

Si deve inserire:

CDC Predefinito È il Centro di Costo che viene poroposto automaticamente durante l'inserimento della primanota, di solito si riferisce alle spese generali.


Spesso i professionisti o anche alcune ditte non hanno necessità di utilizzare in sofisticato programma di gestione di magazzino e fatturazione, ma necessitano solo di un programma per la scrittura e la stampa di semplici fatture. Per questi soggetti è stata sviluppata questa procedura di fatturazione semplice. Le fatture non memorizzate in questo archivio per poter essere ristampate ed eventualmente modificate, la procedura esegue anche la registrazione contabile delle fatture. Si può configurare il programma in modo da emettere fatture con ritenuta d'acconto, per fare questo si deve inserire la percentuale di ritenuta nell'apposito campo delle preferenze di contabilità.

I dati vengono inseriti utilizzando la modalità di gestione documenti, In testata vengono richiesti:
Data documento | Inserire la data della fattura.
Numero documento | Questo dato viene proposto solo in modifica, in inserimento viene calcolato il numero in base al registro IVA.
Registro | Indicare il registro IVA della fattura.
Codice Cliente | Inserire il codice del cliente a cui viene effettuata la fattura. Premendo il pulsante collegato si apre la lista dei Clienti.
Sconto | Si può inserire uno sconto che verrà applicato sul totale della fattura, questo campo è presente solo se non è stata attivata la fatturazione copn ritenuta d'acconto.
Modalità di pagamento | Viene proposta la modalità di pagamento abituale del cliente. Premendo il pulsante collegato si apre la lista delle Modalità di pagamento
Note descrittive | Premendo il pulsante memo si può inserire una descrizione.

Alla fine della testata si passa alle righe, per ogni riga si deve inserire:

Descrizione | Inserire la descrizione della riga, la descrizione può essere su più righe, però non può superare i 1024 caratteri, se si necessita di descrizioni più lunghe, si deve spezzare la descrizione su più righe.
Quantità | Inserire la quantità per calcolare l'importo della riga, per inserire righe solo descrittive lasciare questo campo a zero.
Prezzo | Inserire il prezzo unitario che moltiplicato per la quantità da l'importo della riga, il prezzo può essere al netto di IVA o IVA compresa a seconda dell'impostazione presente nelle preferenze.
Sconto | Inserire lo sconto da effettuare sul prezzo di questa riga.
Codice IVA | Inserire il codice IVA da applicare a questa riga. Premendo il pulsante collegato si apre la lista dei Codici IVA.
Escludi da ritenuta | Questo campo è visibile solo se è stata abilitata la fatturazione con ritenuta d'acconto, serve per escludere la riga dal calcolo della ritenuta d'acconto ad esempio per inserire spese di previdenze professionali o rimborsi per spese sostenute.
Leggi tracciato | Il pulsante "Leggi tracciato" consente di inserire righe ripetitive prendendo i valori da un tracciato. I tracciati possono essere predisposti da personale tecnico e consistono nell'inserire nelle risorse utente una o più risorse di tipo "TM" e con codice "FTT_ROW01", "FTT_ROW02" ecc... Nella risorsa la prima riga indica la quantità, la seconda il prezzo, la terza lo sconto, la quarta il codice IVA e dalla quinta in poi il testo descrittivo. Il prezzo può essere espresso come valore assoluto o come percentuale sui valori inseriti finora, il programma riconosce i prezzi in percentuale perché sono preceduti dal carattere '%'.
Alla fine dell'inserimento di nuove fatture viene effettuata la stampa e la contabilizzazione.

Le Stampe disponibili sono:
Lista fatture | Stampa la lista delle fattura, a seconda del tracciato utilizzato si può stampare la lista semplice, oppure un riepilogo valorizzato
Ristampa fattura | Viene ristampata la fattura corrente.

I Comandi speciali disponibili sono:
Rigenera scrittura contabile Si può rigenerare la scrittura contabile e con essa anche le scadenze, questa procedura viene utilizzata quando per qualsiasi motivo viene modificata la fattura e gli importi differiscono da quelli precedenti.


Le preferenze di contabilità servono a memorizzare alcuni dati di configurazione del programma per quanto riguarda la parte contabile.

I dati da inserire sono:

Codici registri contabili | Il programma Zefiro può utilizzare registri multipli per le registrazioni contabili, questa opzione non viene usata molto spesso però può essere utile in consizioni particolari, ad esempio si possono registrare su registri separati le scritture appartenenti a filiai riverse per ottenere bilanci separati o congiunti, oppure si possono registrare dati extracontabili come ad esempio ratei di ammortamento per calcoli di bilancio o incassi e pagamenti previsti.
Codici registri IVA | Si possono gestrie anche registri IVA multipli, questa opzione è un po più frequente della precedente, infatti spesso ci sono ditte con più di un punto vendita e quindi con più di un registro dei corrispettivi, oppure c'è la necessità di gestire bollettari con numerazioni separate con fatturazione disgiunta o congiuta, in questo campo si possono inserire i codici dei registri previsti.
Registro IVA PA | Per le fatture emesse verso la Pubblica Amministrazione sono state attivate norme specifiche che riguardano la fatturazione elettronica, la conservazione sostitutiva ed il regime iva di Split Payment, per assolvere a questi obblighi le fatture dovranno essere registrate su un registro iva dedicato che va indicato in questa posizione. Nel secondo campo si può inserire il codice di registro per forzare l'esclusione dallo split payment di singole Fatture PA
Mese e Giorno inizio esercizio | Normalmente l'esercizio contabile coincide con l'anno solare e quindi incomincia il primo gennaio e finisce il 31 di dicembre, ma per vari motivi è possibile scegliere un altro giorno e quindi bilanci, giornale e schede contabili terranno conto dei dati inseriti, invece l'esercizio ai fini IVA inizia comunque il primo gennaio.
Tipo contabilità | Il programma gestisce sempre la contabilità con il metodo della partita doppia, ma per fini fiscali si può scegliere altri regimi contabili che esentano dalla scritture di molte registrazioni contabili, le scelte disponibili sono: 'O' per contabilità ordinaria e 'S' per contabilità semplificata. Queste informazioni sono rilevanti per il tipo di stampa effettuate nel giornale di contabilità.
Abilita saldo partite | Questa opzione permette di abilitare la possibilità di saldo delle partite contabili e cioè la possibilità di fare le scritture di incasso dalla procedura di gestione partite. Normalmente questa opzione viene abilitata se non si dispone del modulo di scadenzario.
Tipo liquidazione e interessi | La liquidazione IVA può essere mensile o trimestrale, in caso di liquidazione trimestrale sono dovuti interessi per rateazione.
Codice registro IVA acquisti intracee | La normativa IVA sugli acqusiti intracomunitari prevede che la registrazione delle fatture di acuisto provenienti da paesi CEE venga effettuata sia sul registro degli Acquisti che sul registro delle Vendite in modo che l'IVA sugli acquisti vada a compensare l'IVA sulle vendite comportando l'azzeramento dell'imposta su tali fatture. In questa posizione viene indicato quale è il codice di registro utilizzato per la registrazione di queste fatture in modo che effettuando la registrazione una sola volta, in fase di stampa dei registri venga stampata sia ai fini degli acquisti che ai fini della vendita.
Tipo calcolo liquidazione IVA Questo campo serve a configurare alcuni regimi IVA speciali gestiti dal programma, i valori possibili sono:
N | NORMALE la Ditta non è soggetta a regimi IVA speciali.
M | MARGINE a questo regime IVA sono assoggettati coloro che commerciano in beni usati ed in sostanza obbliga a pagare l'IVA sul margine di utile realizzato tra l'acquisto e la vendita del bene.
A | AUTOTRASPORTATORI gli autotrasportatori godono di un'agevolazione che consente di posticipare il pagamento dell'IVA sulle vendite di un periodo IVA, quindi con la liquidazione del primo trimestre viene pagata l'IVA sulle vendite del quarto trimestre dell'anno precedente, nel secondo l'IVA vendite del primo e così via.
S | SUBFORNITURE coloro che eseguono subforniture su appalti pubblici aggiudicati da terzi godono dell'agevolazione di liquidare trimestralmente l'IVA su vendite delle subforniture anche se sono a regime mensile.
Il programma tiene conto automaticamente di questi particolari regimi IVA in fase di stampa delle liquidazioni.
Contropartite separate per aliquota IVA | Con questa opzione si può decidere se in fase di registrazione di primanota delle fatture, si desidera che venga generata una riga di contropartita per ogni riga IVA inserite, questo serve perché spesso ogni la merce acquistata con aliqute IVA diverse viene girata su contropartite diverse.
Codice IVA normale gestione del margine | Nella gestione del margine indicare il codice IVA utilizzato per scorporare l'IVA sulla differenza tra acquisti e vendite, il codice IVA normale invece è quello che la ditta usa più frequentemente.
Tipo cliente contatto e non operativo e nascondi. | I clienti che non sono più operativi oer vari motivi o che non sono mai stati utilizzati possono essere nascosti in fase di ricerca durante l'immissione dalla prima nota e delle altre procedure di contabilità. In questo modo si evita di fare errori di attribuzione. I clienti nascosti possono comunque essere resi visibili in ogni momento e digitando il codice diretto vengono accettati.
Causali bilancio apertura e chiusura | Indicare i codici delle causali contabili utilizzati dalla procedura di chiusura ed apertura automatica di bilancio.
Causali fattura di vendita ed acquisto | Indicare i codici delle causali contabili di fatture di vendita ed acquisto, questi codici vengono utilizzati da varie procedure per la contabilizzazione automatica, ad esempio dalla procedura di contabilizzazione fatture e dalla procedura di fatturazione semplice.
Giroconti IVA | Indicare i codici delle causali contabili utilizzate in fase di stampa della liquidazione IVA per fare le scritture di giroconto iva e di giroconto dell'iva per compentenza diversa.
Percentuale ritenuta d'acconto, percentuale non soggetta e Causale ritenute | Questi campi servono ad indicare se nella fatturazione semplice sono da considerarsi comprensivi si applica la ritenuta d'acconto oppure no ai clienti (questa opzione serve ai professionisti soggetti a ritenuta).
Causali incasso e pagamento | Indicare i codici delle causali contabili di incasso e pagamento, queste causali vengono utilizzate dalla procedura di contabilizzazione fatture per le fatture con modalità di pagamento di pagamento effettuato per registrare il pagamento avvenuto invece della scadenza.
Causale giroconto iva in sospensione d'imposta | Indicare il codice della causale contabile utilizzata per il giroconto tra iva sospesa ed iva vendite, che viene utilizzata in fase di incasso delle fatture con iva sospesa. Per maggiori dettagli sulla sospensione d'imposta consultare la primanota.
Causali sconto attivo e passivo | Indicare i codici delle causali contabili di sconto attivo e passivo, queste causali vengono utilizzate nelle procedure di generazione automatica di scritture contabili, ad esempio dalla procedura di contabilizzazione fatture.
Scorporo IVA fatturazione semplice Con questo campo si indica che i prezzi indicati nella fatturazione semplice sono da considerarsi comprensivi di IVA e quindi dovranno essere scoporati per il calolo dei totali.
P.S. il modulo di "Fatturazione semplice" al momento è stato sospeso non essendo stato abilitato alla fatturazione elettronica.
Causali note d'accredito Clienti e Fornitori | Indicare i codici delle causali contabili di Nota d'accredito Clienti e Fornitori, queste causali vengono utilizzate dalla procedura di contabilizzazione fatture ed in genere da tutte le procedure che eseguono caontabilizzazioni automatiche di documenti.
Banca per bonifici | Indicare in questa posizione il codice della banca che verrà utilizzata di preferenza per i bonifici dei clienti. Il codice verrà proposto automaticamente nelle procedure di Primanota e di Documenti di Magazzino in caso di pagamento dei clienti a mezzo bonifico bancario.


Questo menù contiene voci che vengono utilizzate raramente e che svolgono elaborazioni sui dati presenti.

Inserimento corrispettivi permette di inserire in modo rapido i corrispettivi di un periodo.
Chiusura ed Apertura bilancio esegue le scritture dichiusura ed apertura di bilancio.
Verifica quadratura controlla la correttezza tecnica dei dati inseriti ed esegue il ricalcolo dei protocolli
Cancellazione esercizi serve per cancellare gli esercizi contabili vecchi.
Forzatura partite contabili serve per chiudere o aprire automaticamente tutte le partite in un intervallo di date.
Configura corrispettivi permette di configurare i dati per la procedura di inserimento corrispettivi.
Numerazione fogli permette di stampare una serie di fogli numerati con un titolo prescelto.


Questa procedura risulta particolarmente utile a coloro che hanno un grande numero di fatture di acquisto da importare in contabilità. Infatti velocizza di molto la procedura di importazione riducendo le operazioni ripetitive.

Per utilizzarla, per prima cosa si copiano in una cartella di propria scelta tutti i files XML delle fatture di acquisto che di solito vengono scaricati dal proprio portale. Quindi si lancia la procedure che chiede le seguenti cose:

Cartella di importazione | Premoendo il pulsante collegato, si apre la finestra di ricerca dei files. Si deve scegliere un file contenuto nella cartella da importare.
Cancella files importati | Inserendo questa spunta alla fine delle operazioni di importazione i files importati vengono cancellati.
Modalità di pagamento automatica | Quando si importano le fatture di acquisto, se il fornitore non è presente Zefiro esegue la registrazione automatica, ma alla fine chiede di inserire il codice della modalità di pagamento e tutti gli altri dati integrativi. Di solito questo campo si lascia vuoto e durante i controlli si inseriscono i dati integrativi. Ma nel caso che ci siano molte fatture con molti fornitori, può essere utile utile inserire la modalità di pagamento, in questo modo ai fornitori viene assegnato il codice e l'importazione avviene in modo automatico e silente, salvo poi andare manualmente a sistemare i dati.
Applica pagamento concordato | Questa spunta si comporta in modo analogo a quanto avviene con l'importazione manuale delle fatture da primanota e permette di scegliere se accettare le condizioni di pagamento del fornitore o se valgono quelle concordate.
Data registrazione | Inserire la data di registrazione dei documenti. In caso che la data del documento sia sucessiva a questa, in fase di importazione verrà forzata la data di registrazione uguale a quella del documento.

Alla fine quando si da la conferma, vengono letti ed analizzati tutti i documenti e viene presentata la lista dei dati trovati da cui si può scegliere alcune operazioni da fare prima di dare la conferma per l'importazione.

Se nella cartella oltre alle fatture valide sono presenti anche files diversi, essi vengono visualizzati con la segnalazione che si tratta di documenti errati e non verranno importati.

Per ciascun documento vengono presentati i dati più rilevanti tra cui i riferimenti di data e numero, il nome del file, il nome del fornitore e se il documento contiene allegati.

Siccome Zefiro registra i numeri di documento come dato numerico di sei cifre, ed invece nelle fatture elettroniche si possono trovare anche dati alfabetici, viene calcolato automaticamente un numero, che però può non essere corretto, in tal caso si deve fare doppio click sulla riga per inserire manualmente il numero corretto. In questa fase si può anche forzare la data di registrazione ed inserire la contropartita contabile che si desidera applicare.

Per ciascun documento prima di procedere alla importazione, è possibile eseguire la stampa che consiste nella presentazione di una pagina web con il contenuto della fattura in chiaro. In caso di presenza di allegati, esiste l'opzione che permette di aprire la cartella che contiene gli allegati in modo che possano essere aperti per poterli analizzare.

Esiste un comando che non è obbligatorio, ma è fortemente consigliato e che si chiama "Controllo registrazioni e fornitori".
Questo comando analizza tutti i documenti e se ci sono fornitori nuovi vengono inseriri automaticamente. Vengono anche cercate le registrazioni di primanota per controllare se le fatture in fase i importazione sono già presenti in modo da evitare registrazioni doppie. Quando ci sono fornitori nuovi, è anche molto utile inserire la contropartita contabile, perché in tal caso essa verrà memorizzata come contropartita abituale del fornitore.

Si pssono anche spuntare individualmente le fatture da importare, escludendo quelle non spuntate. Alla fine quando si preme il pulsante di conferma, viene eseguita l'importazione di tutti i documenti. In questa fase, se non è stato fatto prima vengono anche importati i fornitori non presenti e viene fatto il controllo dei documenti doppi, ma è meglio farlo prima per fare in modo che la procedura sia il più automatica possibile.


La procedura di inserimento corrispettivi è stata sviluppata per permettere di inserire in modo veloce tutti i corrispettivi di una serie di giorni.

Spesso i corrispettivi vengono inseriti giornalmente a mano in un registro vidimato e poi periodicamente vengono copiati nel programma gestionale per effettuare i calcoli dell'iva e per stampare le liquidazioni periodiche, quindi è utile una procedura che permette di effettuare questo inserimento in modo veloce. In seguito se necessario si possono fare modifiche manuali alle scritture inserite.

La procedura si sviluppa in tre fasi. In un primo momento si inseriscono i dati relativi alla causale contabile, alle date e gli altri parametri. Poi si inseriscono i corrispettivi giorno per giorno ed infine la macchina genera automaticamente le scritture contabili. I numeri da inserire sono gli importi lordi, la procedura effettua gli scorpori in base alle aliquote previste.

Prima di utilizzare questa procedura è necessario configurare le righe delle aliquote previste con la procedura di configurazione corrispettivi. Per ogni giorno si possono inserire fino ad un massimo di 10 righe.

Prima di iniziare ad inserire i numeri vengono richiesti i seguenti dati:

Causale | Inserire il codice della causale da utilizzare nelle scritture contabili, vengono accettate solo le causali compatibili, cioè quelle che nel campo procedure compatibili hanno il codice 'CO'.
Registro IVA | Questo dato viene richiesto solo se sono stati configurati nelle preferenze di contabilità i registri iva multipli e permette di inserire ad esempi i corrispettivi di più punti vendita.
Descrizione | Inserire la descrizione della scrittura contabile.
Da Data | Inserire una data dell'esercizio contabile corrente.
A Data | Inserire una data dell'esercizio contabile corrente successiva alla data iniziale.
Codice giornale | Questo dato viene richiesto solo se sono stati configurati nelle preferenze di contabilità i registri contabili multipli.
Codice cassa | Inserire il sottoconto della cassa, viene proposto quello configurato nella causale.

Dopo aver confermato, se i dati sono corretti viene presentata la lista dei giorni scelti e per ciascuna riga si possono inserire gli importi solo delle righe configurate.

Per ciascuna aliquota si inseriscono gli importi lordi e la macchina effettua lo scorporo in base alla aliquota della riga. Vengono anche visualizzati i totali e questo è può essere utile per integrare i dati inseriti manualmente nel registro cartaceo avendo la sicurezza che i calcoli sono esatti.

La macchina fa anche il calcolo dei totali del periodo considerato, per fare questo è disponibile un comando speciale nella lista dei giorni. Questa funzione viene utilizzata ad esempio quando si inseriscono i corrispettivi di tutto un mese poiché i totali corrispondono con i totali di pagina.

È prevista anche la possibilità di caricare i dati copiandoli da un foglio Excel o LibreOffice, questo è comodo perché permette un inserimento dati ancora più veloce.
Per fare questo si inseriscono nel foglio di calcolo i dati da copiare con le colonne di aliquota uguali a quelle configurate in Zefiro. Poi si copia l'area di foglio contenente i dati e nella procedura di inserimento corrispettivi si esegue il comando "Importa da foglio di calcolo", i dati copiati verranno incollati a partire dalla riga corrente.

Dopo aver finito di inserire i corrispettivi del periodo preso in considerazione, si da conferma premendo il pulsante di conferma oppure il tasto F12 ed a questo punto vengono effettuate tutte le scritture contabili giorno per giorno. Vengono fatte scritture solo per i giorni che hanno almeno un numero inserito.

La procedura è irreversibile, dopo aver dato conferma si potranno solo modificare le singole scritture contabili, consigliamo quindi di controllare attentamente i numeri prima di confermare.


 Questa procedura viene utilizzata a fine anno per eseguire automaticamente le scritture di chiusura di bilancio e di riapertura. Vengono calcolati i saldi di ogni sottoconto, quindi con la scrittura di chiusura vengono chiusi i conti patrimoniali ed il cono economico e viene rilevato l'utile o la perdita di esercizio, alla fine viene effettuata la scrittura che riapre i conti patrimoniali nell'esercizio successivo.
La particolarità di questa procedura è che dopo averla eseguita è possibile cancellare le scritture di chiusura e di apertura ed eseguirla nuovamente, questo è utile perché consente di fare le chiusure temporaneamente per avere i saldi contabili dei conti ed in seguito dopo aver eseguito tutte le scritture di rettifica ed aver controllato tutto, si possono cancellare le scritture temporanee ed eseguire la chiusura definitiva.

I dati da inserire sono:
Data Chiusura | Inserire la data della scrittura di chiusura, solitamente coincide con la data di fine esercizio, ma si può eseguire la chiusura anche in data successiva, in tal caso la scrittura avrà come esercizio di competenza quello di chiusura per le stampe delle schede e dei bilanci.
Data Apertura | Inserire la data di apertura, se la data di chiusura è l'ultimo giorno dell'esercizio da chiudere viene proposto il primo giorno dell'esercizio successivo.
Esercizio | Inserire l'esercizio da chiudere, viene proposto quello della data di chiusura.
Codice giornale | Se è stata scelta l'opzione dei registri multipli, viene chiesto il codice del registro si cui devono essere effettuate le scritture.
Conferma generazione scritture | Per eseguire la procedura si deve confermare questa voce.
Alla fine vengono eseguite le scritture di chiusura ed apertura.


Le procedure per la fatturazione elettronica tra privati hanno introdotto l'obbligo di registrare le fatture di acquisto alla data in cui vengono ricevute nel Sistema di Interscambio (SdI) e di calcolare l'IVA "per compentenza", cioè nel periodo di emissione della fattura, perciò se una fattura porta la data del mese di ottobre ma viene ricevuta in novembre, ai fini dell'IVA viene calcolata ad ottebre ed ai fini contabili viene conteggiata in novembre.

Questo comporta problemi di interpretazione a livello di bilancio soprattutto se si desidera calcolare bilanci di verifica infra-annuali, infatti esiste una discrepanza tra le fatture emesse che risultano registrate nel mese di competenza e le fatture di acquisto che vengono registrate dopo il mese di competenza.

Per ovviare a questo problema interpretativo, è stata realizzata questa procedura che esegue dei giroconti sul conto "Fatture da Ricevere" in modo da assegnare le voci di costo nel periodo di competenza e non in quello di registrazione.

L'uso di questa procedura è soprattutto importante a fine anno in modo da chiudere l'esercizio con la situazione reale dei costi.

I dati da inserire sono:

Da data registrazione, a data registrazione | Si devono inserire i limiti di data in cui vengono lette le registrazioni le date devono essere comprese nello stesso mese.
Codice causale contabile | Inserire il codice della causale contabile utilizzata per le scritture.
Codice registro contabile | Si può inserire il codice del registro in cui verranno esegite le scritture. Questo rende possibile ad esempio effettuare le scritture in un registro extra-contabile che può essere utilizzato solo per il calcolo di bilanci infra-annuali.
Scrittura riepilogativa | Si può scegliere se fare una scrittura per ogni fattura, oppure una scrittura unica riepilogativa per tutte le fatture del periodo. Consigliamo di fare una singola scrittura per le registrazioni infra-annuali e una scrittura per fattura per i giroconti di fine anno.

Avviata la procedura, per ogni fattura, o in modo riepilogativo, vengono fatte due scritture di giroconto. La prima scrittura, nel periodo di competenza anticipa i costi che sono stati rilevati oltre il periodo, e la seconda scrittura che dopo la registrazione della fattura storna gli anticipi fatti con la prima scrittura.

Per fare in modo che la procedura funzioni, la causale scelta, dovrà avere nella lista dei sottoconti il "Tipo di accumulo" con codice "C" in modo di sapere che sottoconto utilizzare per i girconti.

Inoltre, se si desidera che nelle scritture dettagliate vengano evidenziati anche i conti dei fornitori, si dovrà inserire nella causale una riga con "Tipo di accumulo" con codice "A"

La procedura può essere ripetuta più volte, ma prima di ripeterla è necessario cancellare manualmente le scritture precedenti per evitare la doppia imputazione dei costi.


 Questa procedura esegue alcuni test sui dati contabili inseriti e può essere eseguita saltuariamente, soprattutto conviene effettuarla prima di eseguire stampe definitive.

I dati richiesti sono:
Verifica quadrature contabile | Con questa procedura vengono verificate le corrispondenze tra dare ed avere, la consistenza tra i dati di testata e di riga, la correttezza dei sottoconti e le righe prive di testate.
Verifica scritture IVA | Viene eseguito il controllo delle scritture IVA, si controlla la consistenza tra i dati di tesata ed i dati di riga, l'imposta calcolata rispetto all'imposta inserite, la correttezza dei totali e la consequenzialità dei protocolli.
Includi segnalazioni | Questa opzione indica se includere nella stampa anche la segnalazione di anomalie che potrebbero non essere errori.

Alla fine se vengono trovati errori viene effettuata la stampa della lista.


Questa procedura controlla le sequenze di protocollo delle registrazioni IVA ed in caso di errori di sequenza esegue la correzione.

I protocolli vengono letti per tutti i registri di Acquisto, Vendite e Corrispettivi a partire dalla ultima data stampata definitivamente. Eventuali errori antecedenti alle stampe definitive non vengono rilevati.

Se non ci sono errori viene semplicemente segnalata la correttezza dei dati.

In caso di errori, viene presentata la lista dei registri che contengono errori e per ciascuno viene evidenziato il protocollo errato e quello atteso. Se si mette la spunta, quando si conferma, i protocolli vengono ricalcolati.

I protocolli seguono l'anno solare ed iniziano da 1 a partire dal primo gennaio. Può capitare di avere necessità di partire con numerazioni diverse, in questo caso è necessario indicare nei numeratori il numero precedente a quello di partenza con data antecedente.

E' importante eseguire questa procedura prima della stampa definitiva dei registri IVA, infatti eventuali errori nei protocolli potrebbero generare errori nella stampa con il rischio di omettere la stampa di alcune scritture.


La norma sull'IVA (DPR 633/72) stabilisce che le imprese che svolgono operazioni esenti ai sensi dell'articolo 10, devono calcolare la deducibilità degli acquisti seguendo una regola che chiamata pro-rata.

La percentuale di indeducibilità viene determinata facendo la proporzione tra le operazioni di vendita o prestazione di servizi esenti e quelle deducibili. Solitamente il calcolo viene fatto a fine anno e le percentuali rilevate vengono applicate per tutto l'anno seguente ed in sede della successiva dichiarazione iva annuale si effettua il conguaglio.

In Zefiro è possibile indicare la percentuale di indeducibilità pro-rata da calcolare per l'anno in corso e se sono presenti percentuali di indeducibilità durante le liquidazioni periodiche viene applicato il calcolo.

La percentuale di indeducibilità viene applicata ai singoli registri iva, quindi è possibile avere percentuali diverse su registri diversi.

La configurazione si fa inserendo le percentuali nei registri soggetti.


 Questa procedura permette di cancellare esercizi contabili, vengono cancellati tutti i movimenti contabili e tutti i dati collegati all'esercizio contabile indicato. Normalmente non è necessario eseguire questa procedura perché non c'è alcuna controindicazione a conservare gli esercizi contabili passati, è quindi solo per scelta dell'utente che viene eseguita.

Cancellazione esercizi contabili

I dati da inserire sono:
Esercizio da cancellare | Inserire l'anno dell'esercizio da cancellare, non si può cancellare l'esercizio in corso.
Conferma cancellazione esercizio. | Viene richiesta la conferma per poter effettuare la cancellazione.

Alla fine viene eseguita la procedura di cancellazione.


 La procedura di forzatura partite permette di chudere o riaprire automaticamente tutte le partite che sono contabilmente aperte ma che si desidera chudere forzatamente perchè compensate o chiuse nella realtà. Le partite che sono state chuse forzosamente possono essere riaperte in qualsiasi momento.

I dati da inserire sono:
Codice cliente o fornitore | Se si desidera si possono forzare le partite di un solo cliente o fornitore.
Tipo anagrafica | Si possono forzare tutte le partite oppure si può limitare l'elaborazione ai soli clienti, o ai soli fornitori. Attenzione che se si sceglie di forzare un tipo di alagrafica ed è stato scelto un codice dell'anagrafica opposta, ad esempio se si sceglie un cliente e si limita la forzatura ai soli fornitori, non viene effettuata nessuna forzatura.
Tipo forzatura | Si può forzare la chiusura o la riapertura delle partite chuse forzosamente.
Da data a data. | Si indicano le date iniziale e finale delle partite da forzare, per data partita si intende la data del documento che ha generato la partita. La data finale è obbligatoria.
Conferma | Per poter eseguire l'operazione si deve spuntare questa casella di spunta.

Alla fine viene eseguita la procedura di forzatura.


La procedura di configurazione dei corrispettivi è necessaria per poter utilizzare la procedura di inserimento dei corrispettivi e serve per configurare i codici IVA ed i sottoconti da utilizzare in fase di inserimento dei corrispettivi.

Si possono inserire fino a 10 righe per l'inserimento dei corrispettivi di un giorno, nella procedura di inserimento verranno visualizzate solo le righe che hanno tutti i dati, è necessario che i dati inseriti siano corretti per evitare scritture contabili errate. I dati da inserire per ciascuna riga sono:

Descrizione | Inserire la descrizione che si desidera che compaia nella finestra di richiesta dei corrispettivi del giorno.
Codice IVA | Inserire il codice IVA per la riga, si possono inserire più righe con lo stesso codice iva per sottoconti di contropartita diversi.
Sottoconto | Inserire il sottoconto di contropartita per la riga corrente.

Alla fine i dati vengono memorizzati in modo permanente e saranno utilizzati fino a quando non vengono effettuate modifiche.


Questa procedura permette di stampare pagine con una intestazione ed una numerazione ed è utile per prestampare i fogli che poi verranno utilizzati per la stampa dei registri contabili.

I dati da inserire sono:

Testo con numerazione | È il titolo della stampa che comparirà su ogni pagina.
Riga | È possibile stampare il titolo nella parte superiore o nella parte inferiore del foglio, e si può scegliere su quale riga da 1 a 5 per evitare che il testo che verrà stampato in seguito si sovrapponga al titolo della stampa. Premendo il tasto collegato si apre la lista delle scelte.
Testo aggiuntivo | Oltre alla prima riga del titolo si può aggiungere una seconda riga di testo.
Riga | Anche per la seconda riga di testo si può decidere in quale posizione stampare.
Allineamento testo | Si può decidere se si desidera stampare a sinistra della pagina oppure al centro o a destra.
Dimensione carattere | si può scegliere la dimensione dei caratteri delle stampe.
Grassetto e corsivo | Con queste opzione si può scegliere se stampare in grassetto e/o corsivo.
Da pagina - A pagina | Si sceglie la numerazione delle pagine da stampare.
Posizione numeri | Il numero di pagina viene stampato a fianco della prima riga di testo. Si può scegliere se stampare il numero a destra o a sinistra del titolo.
Aggiungi anno | In alcune stampe per la numerazione è richiesta la presenza dell'anno di stampa, con questa opzione si scegliere se aggiungere anche questo dato.

Alla fine viene effettuata la stampa delle pagine.


 Il menù di gestione scadenze permette di gestire tutte le problematiche legate alle scadenze attive e passive, le scadenze dipendono dai documenti (fatture e note d'accredito) e dalle modalità di pagamento, spesso le fatture vengono pagate dopo un certo periodo di tempo le procedure di scadenzario permettono di ricordare le date in cui devono o dovrebbero essere effettuati incassi e pagamenti e di eseguire un certo numero di procedure collegate a tale gestione. Le scadenze hanno un legame forte con la contabilità, infatti molte procedure generano automaticamente le scritture contabili. Le voci disponibili sono:

Incassi e pagamenti esegue una procedura per la registrazione interattiva di incassi e pagamenti
Scadenze Clienti è un menù che contiene tutte le voci rilevanti per la gestione delle scadenze dei clienti
Scadenze Fornitori è un menù che contiene tutte le voci rilevanti per la gestione delle scadenze dei fornitori
Elenco per data esegue la stampa delle scadenze suddivise per data di scadenza e con subtotali e totali.
Flusso finanziario è una stampa che mette a confronto scadenze dei clienti con scadenze dei fornitori
Cancella scadenze con questa procedura si può eseguire la cancellazione globale di parte o tutte le scadenze
Preferenze con questa voce si inseriscono alcuni dati di configurazione rilevanti per la gestione scadenze


Questa procedura permette di effettuare le scritture contabili di incasso e pagamento per le scadenze che non vengono trattate automaticamente dal programma, generalmente viene utilizzato per le rimesse dirette dei clienti e per il pagamento dei fornitori.

I dati vengono inseriti utilizzando la modalità di gestione documenti, In testata vengono richiesti:

Causale | Inserire il codice della causale contabile utilizzata per le scritture di incasso o pagamento, vengono accettate solo le causali compatibili con la procedura, premendo il pulsante collegato si apre la lista delle Causali contabili.
Descrizione | Si può inserire la descrizione che comparirà nella testata della scrittura contabile.
Data | Inserire la data della scrittura contabile
Giornale | Questa opzione viene presentata solo se sono stati scelti i registri multipli, permette di scegliere il registro contabile su cui effettuare le scritture.
Codice cliente/fornitore | Inserire il codice di sottoconto del Cliente o Fornitore, vengono accettati solo sottoconti compatibili con la causale inserita, premendo il pulsante collegato si apre la lista appropriata. Se si lascia vuoto questo campo, vengono lette tutte le scadenze dei clienti o fornitori a seconda della causale impiegata.
Codice contropartita | Inserire il codice del sottoconto utilizzato per l'incasso o il pagamento, premendo il pulsante collegato si apre la lista dei conti.

Dopo aver inserito i dati di testata vengono lette le scadenze del cliente o fornitore inserito e se ne vengono trovate di non pagate si passa alle righe in cui per ogni scadenza si può inserire:

Importo | Inserire l'importo da incassare o pagare, viene proposto il totale della scadenza.
Descrizione riga | E' possibile inserire la descrizione di riga, viene proposta automaticamente l'ultima descrizione inserita.
Differenze importo | Se si inserisce un importo diverso da quello della scadenza, si deve specificare che cosa si desidera fare della differenza di importo, si può scegliere di scrivere una scadenza contenente la differenza di importo se è stato incassato o pagato un acconto, oppure si può scegliere di considerare la differenza come sconto o arrotondamento ed in questo caso la scadenza viene cancellata e nella scrittura contabile verrà specificato lo sconto.

Il Comando speciale
Importo totale | Permette di inserire l'importo totale che si sta incassando o pagando, dopo aver inserito l'importo, nella testata viene visualizzato il totale, gli incassi o pagamenti registrati e la differenza. Se si desidera si può anche effettuare il ricalcolo degli importi incassati assegnando l'importo a ciascuna rata fino ad esaurimento dell'importo inserito. In questo caso viene anche chiesto se si desidera riassegnare gli importi o applicare il calcolo sugli importi già assegnati.
Incassa/paga tutto | Questa procedura prepare il pagamento o l'incasso di tutte le rate.

Alla fine dell'inserimento viene effettuata la scrittura di incasso o pagamento e vengono cancellate le scadenze completamente pagate o incassate.

Se si dispone del modulo di agenti e provvigioni A questo punto viele presentata la lista delle provvigioni non liquidate presenti per i documenti di cui abbiamo incassato le scadenze in modo da poterle rendere liquidabili.


 Questo menù contiene tutte le voci necessarie alla gestione delle scadenze dei clienti.

Scadenze clienti è l'archivio che contiene le scadenze dei clienti
Distinta bancaria è la procedura che si usa per preparare la presentazione degli effetti in banca
Preparazione RIBA si esegue dopo la distinta bancaria per preparare il dischetto degli incassi elettronici
Ristampa Distinta permette di ristampare le distinte presentate in precedenza.
Stima castelletto è una stampa che elenca le ricevute presentate e non ancora incassate
Incassi ed insoluti permette di registrare gli incassi delle ricevute effettivamente avvenuti e gli insoluti.


L'archivio delle scadenze contiene fisicamente sia le scadenze dei clienti che quelle dei fornitori che vengono però suddivise a seconda della richiesta che viene effettuata. Di norma le scadenze vengono generate automaticamente dalla registrazione di primanota di fatture di acquisto e vendita e delle note d'accredito oppure dall'inserimento di fatture e note nei documenti di magazzino e vengono utilizzate le regole di calcolo presenti nelle modalità di pagamento, ma possono essere introdotta anche manualmente a causa della presenza di modalità di pagamento veramente molto particolari o di situazioni amministrative anche particolari.

I dati da inserire sono:

Codice Cliente | Inserire in codice del cliente debitore
Tipo documento | E' il tipo di documento che genera la scadenza, i tipi disponibili sono gli stessi inseribili in primanota.
Registro | E' il codice del registro IVA su cui è stata registrata la fattura.
Data e numero documento | Inserire la data ed il numero di documento, nel caso di scadenze raggruppate a livello di distinta bancaria questi campi sono vuoti. e non accessibili.
Totale documento | Contiene l'importo totale del documento che ovviamente è diverso dall'importo della rata nel caso di scadenze frazionate, anche questo campo è vuoto e non accessibile in caso di scadenze raggruppate.
Data e num. scadenza | E' la data di scadenza del pagamento cioè la data entro la quale si prevede l'incasso. Il numero è il numero progressivo di rata per il documento in caso di scadenze frazionate.
Importo della rata | E' l'importo da incassare alla scadenza. Nel caso di scadenze raggruppate contiene la somma degli importi delle scadenze che ne fanno parte.
Tipo effetto | Indica la modalità in cui avverranno i pagamenti, può assumere gli stessi valori presenti in Modalità di pagamento, il tipo determina i meccanismi di incasso disponibili, ad esempio le ricevute bancarie e le tratte vengono incassate mediante presentazione della distinta bancaria, le rimesse dirette ed i bonifici bancari invece vanno incassati utilizzando la procedura di incassi e pagamenti.
Addebito automatico RID | Questo campo è rilevante solo per i tipi effetto 'R', e serve ad indicare che si utilizza il formato RID al posto di RIBA. Viene spuntato automaticamente quando la modalità di pagamento che ha generato la scadenza è di tipo RID.
Banca di presentazione | Questo campo non viene gestito manualmente, viene invece inserito dalla procedura di presentazione della distinta bancaria, e serve per tutte le procedure che riguardano la presentazione effetti.
Data num. distinta e rata | Anche questi campi vengono inseriti dalla procedura di presentazione della distinta bancaria, e servono per tutte le procedure che riguardano la presentazione effetti.
Stato di avanzamento Lo stato di avanzamento indica il momento di vita della scadenza, può assumere i valori:
1 | GENERATA la scadenza è stata generata dalle procedure i inserimento primanota o di gestione documenti.
2 | MODIFICATA la scadenza è stata inserita manualmente o modificata in seguito.
3 | DISTINTA STAMPATA è stata stampata la distinta bancaria
4 | EFFETTI STAMPATI è stato preparato il file di presentazione RIBA o RID
5 | INSOLUTO il cliente non ha effettuato il pagamento alla scadenza pattuita.
6 | INCASSATA la scadenza è stata incassata, in realtà questa voce non si presenta dato che ad incasso effettuato le scadenze vengono cancellate.

I Comandi speciali disponibili sono:

Duplica scadenza | Questa procedura permette di duplicare automaticamente una scadenza.
Raggruppa scadenze | Con questa procedura si può effettuare il raggruppamento delle scadenze, cioè indicare tutte le scadenze che fanno parte di questa scadenze, normalmente questa procedura non viene utilizzata perché il raggruppamento viene effettuato automaticamente dalla procedura di presentazione della distinta bancaria.
Prepara avvisi di scadenza | Questa procedura prepara una lista delle scadenze di tipo Bonifico e Rimessa Diretta scadute o prossime alla scadenza e permette di inviarle automaticamente via email. Si possono stampare individualmente, per ciascuna scadenza si può scegliere l'indirizzo di spedizione ed il nome del tracciato da utilizzare, infine si possono spuntare le scadenze da inviare via mail. Quando si preme il pulsante di conferma vengono inviate tutte la mail.
Insoluto | Con questa procedura si può indicare che la scadenza è andata insoluta. Questo comporta alcune cose. Se la scadenza è una ricevuta bancaria viene trasformata in rimessa diretta e viene posto la stato ad "INSOLUTO". Poi viene anche fatta la stampa di un sollecito con eventuale addebito di spese. Infine viene fatta la scrittura contabile che riapre il cliente nel caso si tratti di un effetto presentato.
Spunta scadenze | E' possibile spuntare le scadenze per stampare o preparare gli avvisi solamente per quelle spuntate.


La procedura di raggruppamento scadenze offre una efficace visione sulle scadenze presenti.

Le scadenze vengono raggruppate per cliente, e per ciascuno vengono evidenziati alcuni utili dati che sono: la data della prima scadenza, il saldo contabile, viene poi suddiviso il numero delle scadenze già scadute da quelle future e viene fatta la suddivisione tra le Riba e gli altri tipi di scadenza. Infine vengono evidenziati il numero e gli importi degli insoluti.

Questo meccanismo permette di avere un colpo d'occhio immediato sulle situazioni che devono essere esaminate.

Per ogni riga sono disponibili vari comandi:

Telefoni e contatti | Si può aprire direttamente la lista dei telefoni e contatti del cliente corrente.
Scehda contabile | Si possono esaminare i dati della scheda contabile del cliente.
Partite contabili | Si possono esaminare le partite aperte del cliente.
Vedi scadenze | Se necessario si può aprire la lista delle scadenze del cliente.
Spunta, spunta tutti, spunta nessuno | Le singole righe possono essere spuntate per poi stampare solo le posizioni che interessano.

Dalla lista raggruppata si può fare la stampa delle schede di scadenze. Si possono stampare solo le schede che desideriamo togliendo le spunte a quelle che non interessano. Per la stampa vengono richiesti i seguenti dati:

Solo scaduti | Si può scegliere di stampare solo le scadenze già scadute evitando di stampare quelle future.
Evidenza insoluti | Se si desidera si possono stampare gli insoluti anche separatamente dalle altre scadenza in modo da dare loro evidenza maggiore.
Anche effetti presentati. | Si può decidere di escludere dalla stampa le Riba già presentate in banca.
Agente | Si può decidere di stampare solo le scadenze delle vendite effettuate da un singolo agente oppure di tutti.
Salto pagina | Si può decidere di stampare una scheda per pagina oppure di stampare le schede in modo continuativo.


Questa procedura viene utilizzata per preparare la distinta da presentare in banca per l'incasso di effetti.

La presentazione solitamente viene effettuata utilizzando gli strumenti di Home Banking forniti dalla banca.

I formati disponibili per l'incasso sono RIBA e RID, il primo è di gran lunga il più utilizzato. La scelta del formato dipende dalla modalità di pagamento.

Se tra le scadenze disponibili per la presentazione sono presenti contemporaneamente effetti RIBA e RID, prima di proseguire il programma chiede il tipo di effetti da prendere in considerazione dato che ogni distinta è in grado di gestire solo uno dei due formati. Se invece le scadenze sono di un solo tipo questa domanda non viene fatta.

I dati vengono inseriti utilizzando la modalità di gestione documenti, In testata vengono richiesti:

Tipo presentazione | Inserire la descrizione del tipo di presentazione degli effetti, solitamente può essere "SALVO BUON FINE" ma può essere anche "AL DOPO INCASSO" o altro, viene proposta la descrizione presente nelle preferenze.
Giornale | Questa opzione viene presentata solo se sono stati scelti i registri multipli, permette di scegliere il registro contabile su cui effettuare le scritture.
Data presentazione | Inserire la data di presentazione della distinta.
Banca di presentazione | Si inserisce il codice della banca in cui viene presentata la distinta, premendo il pulsante collegato si apre la lista delle Banche contenente solo le banche che hanno inserito il sottoconto di movimentazione del piano dei conti, e che quindi sono banche con cui lavoriamo.

Dopo aver inserito i dati di testata, nelle righe viene presentata la lista delle scadenze di tipo 'R' ricevuta bancaria e 'T' tratta non ancora presentate all'incasso, viene anche effettuato il raggruppamento delle scadenze per i clienti che prevedono questa opzione e questo serve per ridurre le spese bancarie in caso di scadenze multiple alla stessa data.

A questo punto si può scegliere quali sono le scadenze da presentare alla banca indicata, la scelta delle scadenze dipende da vari fattori tra cui il fido ancora disponibile o altro. In testata viene visualizzato l'importo totale delle scadenze presentabili, l'importo di quelle presentate e la differenza.

Se per un cliente sono presenti note d'accredito, non ancora pagate, è possibile effettuare lo storno scegliendo una delle scadenze dello stesso cliente. Lo storno può essere fatto solamente se l'importo della nota è inferiore a quello della scadenza. Il risultato è una scadenza che raggruppa anche la nota.

Alla fine se la distinta viene confermata viene effettuata la stampa della distinta e la registrazione della scrittura contabile di presentazione effetti nella quale il cliente viene chiuso con il sottoconto di portafoglio effetti se presente o altrimenti con il sottoconto di movimentazione.

Nella stampa viene indicato normalmente l'indirizzo del cliente, se si desidera che venga indicato un indirizzo diverso si può inserire nei RECAPITI dei clienti un indirizzo di destinazione riba o in alternativa una sede operativa diversa dall'indirizzo principale.


Questa procedura serve per preparare il file per la presentazione in banca degli effetti elettronici.

Oggi normalmente questa operazione viene fatta utilizzando le procedure di importazione del programma di Home Banking fornito dalla banca. Però nulla vieta di salvare il file su una chiave USB o su un disco e portarlo fisicamente in banca.

Il programma riconosce automaticamente se la distinta in oggetto deve preparare effetti RIBA o RID. Poi è responsabilità dell'utente spedirli in modo appropriato. Normalmente i programmi di Home Banking hanno voci separate per l'importazione dei diversi tipi di tracciato, oppure sono in grado di riconoscerli in modo automatico.

Gli effetti vengono inviati normalmente all'indirizzo del cliente, se si desidera che vengano inviate ad un indirizzo diverso si può inserire nei RECAPITI dei clienti un indirizzo di destinazione riba o in alternativa una sede operativa diversa dall'indirizzo principale.

La procedura è molto semplice, basta indicare il numero di distinta presente nella stampa della distinta, se si desidera si può indicare un nome diverso di file rispetto a quello memorizzato nelle preferenze ed infine si può indicare se è necessario aggiungere i caratteri di fine riga nel tracciato, questo è richiesto da alcuni programmi di Home Banking.


 Questa procedura serve per ristampare una distinta bancaria stampata in precedenza, viene semplicemente chiesto il numero della distinta da ristampare ed il tipo di presentazione.


Questa procedura serve per annullare una distinta bancaria già generata, su tutte le scadenze di quella distinta vengono tolti i riferimenti di distinta e quindi vengono riaperte per successive ripresentazioni.

Naturalmente per evitare doppie presentazioni è necessario che questa procedura venga eseguita prima di effettuare la preparazione RI.BA.

È anche necessario cancellare manualmente la scrittura contabile eventualmente generata dalla precedente generazione distinta bancaria.


Questa procedura viene eseguita quando la banca ci invia l'estratto conto mensile in cui compare la lista degli effetti incassati e di quelli insoluti e serve per cancellare le scadenze pagate e mettere in moto tutte le procedure contabili necessarie.

I dati vengono inseriti utilizzando la modalità di gestione documenti, In testata vengono richiesti:

Banca di presentazione | Si inserisce il codice della banca in cui sono stati presentati gli effetti, premendo il pulsante collegato si apre la lista delle Banche contenente solo le banche che hanno inserito il sottoconto di movimentazione del piano dei conti, e che quindi sono banche con cui lavoriamo.
Giornale | Questa opzione viene presentata solo se sono stati scelti i registri multipli, permette di scegliere il registro contabile su cui effettuare le scritture.
Fino data scadenza | Inserire la data massima di inclusione della scadenza degli effetti, viene proposto l'ultimo giorno del mese precedente a quello attuale.
Data incasso | Inserire la data delle registrazioni contabili di incasso ed insoluto, viene proposta la data odierna.
Spese insoluto | In questo campo si possono inserire le spese che la banca ci ha addebitato in caso di insoluti, nella scrittura contabile automatica di registrazione degli insoluti verrà registrato l'importo, perché funzioni è necessario che nella causale sia presente il conto da utilizzare con l'indicatore funzionale "-".
Rimborso clienti | In questo campo si può indicare l'importo del rimborso che chiediamo ai clienti per ciascun insoluto che ci viene fatto, viene proposto l'importo memorizzato nelle preferenze.

Dopo aver inserito i dati viene presentata la lista degli effetti e per ciascuno si può scegliere se è stato incassato o se è andato insoluto. Ad ogni variazione di selezione, vengono visualizzate le somme di incassate, insolute e resto per facilitare il confronto con l'estratto conto bancario.

Alla fine quando si da conferma, vengono effettuate le seguenti operazioni:

  • Vengono cancellate le scadenze pagate.
  • Viene effettuata la stampa dei solleciti di pagamento per gli insoluti
  • Vengono fatte le scritture di insoluto che riaprono contabilmente il cliente.
  • Vengono marcati gli insoluti con stato avanzamento '5' = insoluto e vengono trasformati in rimessa diretta.
  • Vengono effettuate le scritture di giroconto tra effetti in portafoglio e banca per le scadenze incassate se la banca prevede l'utilizzo del conto di effetti all'incasso. Inoltre se la banca prevede anche il conto di anticipazione SBF il giroconoto viene effettuato tra anticipazioni ed sbf.
  • Nella generazione della scrittura di accredito SBF, se nella causale viene inserita la procedura compatibile "IR", viene fatta una riga di conto ordinario per ogni scadenza, altrimenti viene fatta una riga unica con tutte le scandeze accreditate. La scelta dipende da come la banca presenta le scritture di giroconto negli estratti conto.
  • Se si dispone del modulo di agenti e provvigioni viene presentata la lista delle provvigioni non liquidate presenti per i documenti di cui abbiamo incassato le scadenze in modo da poterle rendere liquidabili.


Questa procedura stampa la lista degli insoluti ricevuti da clienti in un periodo indicato. I dati per la stampa vengono prelevati dai dati contabili e non dalle scadenze, per questo motivo è necessario che sia stato abilitato il modulo di contabilità.

Per il corretto funzionamento è indispensabile rispettare alcune condizioni, vengono riconosciute come insoluto solo le scritture contabili con la causale corrispondente a quella di insoluto inserita nelle preferenze ed è necessario che i riferimenti di partita contabile siano corretti.

I dati da inserire sono:

Da data | Data iniziale usata per la ricerca degli insoluti.
A data | Data finale usata per la ricerca degli insoluti.
Tipo ordinamento | Si può scegliere di stampare i dati degli insoluti per data di insoluto o per cliente, se si fa la stampa per cliente vengono calcolati i subtotali per ciascun cliente.

Dopo aver confermato viene effettuata la stampa che riporta per ciascun insoluto l'importo insoluto, l'importo totale della fattura oggetto di insoluto ed il saldo attuale della partita contabile.

Se i dati riportati appartengono a più esercizi, vengono fatti i subtotali per ciascun esercizio.


 Questo menù contiene tutte le voci necessarie alla gestione delle scadenze dei fornitori.

Scadenze fornitori è l'archivio che contiene le scadenze dei fornitori
Impegno bancario permette di stampare la lista delle scadenze che devono essere pagate presso ciascuna banca.


Questo archivio è lo stesso delle scadenze dei Clienti, cambia solamente il numero dei dati richiesti che viene limitato a quelli necessari per la gestione delle scadenze dei fornitori. Di norma le scadenze vengono generate automaticamente dalla registrazione di primanota di fatture di acquisto e vendita e delle note d'accredito e vengono utilizzate le regole di calcolo presenti nelle modalità di pagamento, ma possono essere introdotta anche manualmente a causa della presenza di modalità di pagamento veramente molto particolari o di situazioni amministrative anche particolari.

I dati da inserire sono:

Codice Fornitore | Inserire in codice del fornitore creditore, premendo il pulsante collegato si apre la lista dei Fornitori
Tipo documento | E' il tipo di documento che genera la scadenza, i tipi disponibili sono gli stessi inseribili in primanota, premendo il pulsante collegato si apre la lista di scelte.
Registro | E' il codice del registro IVA su cui è stata registrata la fattura.
Data e numero documento | Inserire la data ed il numero di documento, nel caso di scadenze raggruppate a livello di distinta bancaria questi campi sono vuoti. e non accessibili.
Totale documento | Contiene l'importo totale del documento che ovviamente è diverso dall'importo della rata nel caso di scadenze frazionate, anche questo campo è vuoto e non accessibile in caso di scadenze raggruppate.
Data e num. scadenza | E' la data di scadenza del pagamento cioè la data entro la quale si dovrà effettuare il pagamento. Il numero è il numero progressivo di rata per il documento in caso di scadenze frazionate.
Importo della rata | E' l'importo da incassare alla scadenza. Nel caso di scadenze raggruppate contiene la somma degli importi delle scadenze che ne fanno parte.
Tipo effetto | Indica la modalità in cui avverranno i pagamenti, può assumere gli stessi valori presenti in Modalità di pagamento, premendo il pulsante collegato si apre la lista di scelte, il tipo determina i meccanismi di incasso e pagamento disponibili, ad esempio le ricevute bancarie, le tratte ed i bonifici vengono pagate con la procedura di Pagamento ricevute e bonifici, mentre invece le rimesse dirette verranno pagate con la procedura di incassi e pagamenti.
Addebito automatico RID | Questo campo è rilevante solo per i tipi effetto 'R', e serve ad indicare se il fornitore ci effettua l'addebito automatico tramite RID. Viene spuntato automaticamente quando la modalità di pagamento che ha generato la scadenza è di tipo RID. In questo modo facendo la stampa delle scadenze dei fornitori, si possono escludere automaticamente quelle che hanno l'addebito automatico.
Banca di presentazione | Se nell'anagrafica del fornitore è stato detto in quale banca verranno appoggiare le Ricevute Bancare, quel valore viene riportato in questa posizione e questo serve per fare stampe con la lista delle ricevute attese nelle banche per il pagamento con la procedura di Pagamento ricevute e bonifici


 Questa procedura permette di effettuare il pagamento delle ricevute bancarie emesse dai fornitori e dei bonifici bancari concordati con i fornitori.

Pagamento ricevute e bonifici

Il vantaggio di utilizzare questa procedura rispetto alla procedura di Incassi e Pagamenti consiste nel fatto che per le ricevute bancarie si possono riportare i dati dei pagamenti con gli stessi importi presenti nel resoconto che spedisce la banca. Invece per i bonifici si può stampare la distinta dei bonifici da pagare con riportati gli estremi di bonifico dei fornitori.

I dati vengono inseriti utilizzando la modalità di gestione documenti, In testata vengono richiesti:

Data pagamento | Viene proposta la data odierna, ed il dato inserito verrà riportato nella scrittura contabile.
Tipo scadenza | Si può scegliere tra Ricevute e Bonifici, se si sceglie ricevute, vengono presentate le ricevute bancarie e le tratte che i fornitori ci appoggiano sulla banca che scegliamo, nel caso dei bonifici invece vengono presentati tutti i bonifici non ancora pagati.
Giornale | Questa opzione viene presentata solo se sono stati scelti i registri multipli, permette di scegliere il registro contabile su cui effettuare le scritture.
Codice cliente/fornitore | Inserire il codice di sottoconto del Cliente o Fornitore, vengono accettati solo sottoconti compatibili con la causale inserita, premendo il pulsante collegato si apre la lista appropriata.
Banca di pagamento | Si inserisce il codice della banca in cui verranno effettuati i pagamenti, premendo il pulsante collegato si apre la lista delle Banche contenente solo le banche che hanno inserito il sottoconto di movimentazione del piano dei conti, e che quindi sono banche in cui abbiamo un conto corrente.

Dopo aver inserito i dati di testata, nelle righe viene presentata la lista delle scadenze, che possono essere selezionate con i Comandi speciali che sono:
Seleziona scadenza | Questo comando permette di selezionare e deselezionare una singola scadenza.
Seleziona tutte | Permette di selezionare tutte le scadenze in un colpo solo.

Nel caso dei bonifici si può anche eseguire la stampa della distinta.

Se ci sono note d'accredito che il fornitore ha stornato dalle riba, è possibile inserirle tra i pagamenti in modo da avere una scrittura unica che tenga presente gli storni.

Alla fine quando si conferma il documento, viene fatta la scrittura contabile e vengono cancellate le scadenze selezionate. Nel caso dei bonifici viene anche eseguita la stampa della distinta.


La procedura di pagamento bonifici liberi serve per preparare un file che può essere importato con le procedure di Home Banking e per stampare una distinta delle operazioni fatte.

I beneficiari dei bonifici devono essere inseriti come fornitori in questo modo il programma ricorda i dati anagrafici ed i codici IBAN.

Nella testata dati da inserire sono:

Data pagamento | È la data in cui viene spedita la distinta. Per ciascun pagamento è possibile indicare una data di esecuzione diversa.
Banca di pagamento | È la nostra banca presso cui vogliamo effettuare il pagamento.
Causale pagamento | Viene proposta la lista delle causali accettate dalla procedure bancarie.
Descrizione predefinita | Questa descrizione verrà riproposta per ciascun bonifico che andiamo ad inserire.

Per ciascuna riga si deve inserire

Codice fornitore | Inserire il codice del fornitore beneficiario del bonifico. Si possono registrare anche fornitori che non sono fornitori nel senso stretto come ad esempio i dipendenti per l'emissione dei bonifci degli stipendi.
Importo | Inserire l'importo del bonifico
Descrizione | Inserire la descrizione della causale del bonifico. Viene proposta quella presente in testata.
Data esecuzione | Si può inserire la data in cui si desidera che venga eseguito il pagamento, se si lascia vuoto il bonifico viene eseguito alla data inserita in testata.

Alla conferma viene preparato il file da spedire ed effettuata la stampa di una distinta. Se ci sono errori nei codici IBAN o nei codici dei fornitori avviene una segnalazione e l'operazione non viene portata a termine.


Questa è una stampa molto importante per la gestione dello scadenzario. Infatti permette di ottenere la lista delle scadenze che possono essere ordinate e raggruppate per data, oppure di stampare la scheda delle scadenze di ciascun cliente o fornitore. Le scadenze possono essere filtrate secondo alcuni parametri.

Oltre a fare la stampa globale di tutte le scadenze dal menu di gestione delle scadenze, è anche possibile ottenere la stampa dalla tabella dei clienti o dei fornitori, ed in questo caso verranno stampate solo le scadenze dei clienti o fornitori selezionati o spuntati

I dati da inserire sono:

Tipo anagrafica | Inserire 'C' per Clienti e 'F' per Fornitori, premendo il pulsante collegato si apre la lista di scelte. Questo dato non viene chiesto se si richiede la stampa dalla lista dei clienti o fornitori.
Codice anagrafica | E' una selezione sui codici dei Clienti o Fornitori. Questo dato non viene chiesto se si richiede la stampa dalla lista dei clienti o fornitori.
Codice registro | E' una selezione sul registro IVA delle scadenze, permette di stampare le scadenze di un solo registro o di tutti.
Tipo scadenza | E' una selezione sui tipi di scadenza
Data scadenza | E' una selezione sulle date di scadenza, permette di escludere dalla stampa le scadenze fuori dalla selezione.
Tipo stampa | Esistono due tipi di stampa, si può effettuare la lista per data di scadenza oppure le schede per ogni cliente/fornitore.
Anche effetti presentati | Questa voce viene presentata solo per le scadenze dei clienti e serve per escludere dalla stampa gli effetti già presentati all'incasso con la procedura di distinta bancaria.
Escludi addebiti automatici | Questa voce viene presentata solo per le scadenze dei fornitori e serve per escludere dalla stampa le scadenze che prevedono l'addebito automatico in conto corrente.
Salto pagina | Se si stampano le schede, viene chiesto se si desidera saltare a pagina nuova alla fine di ogni scheda.
Stampa totali | Se si stampano le schede viene chiesto se si desiderano i totali per ogni cliente/fornitore.
Codice agente | Nel caso di stampa delle scadenze dei clienti si possono stampare solo le scadenze relative alle vendite effettuate da un agente oppure tutte.

Alla fine viene effettuata la stampa.


Questa stampa permette di ottenere tre tipi di stampe che forniscono informazioni diverse sullo stato finanziario previsto per le banche in cui abbiamo i nostri conti correnti.

Le stampe possibili sono:

Stima castelletto
 Questa stampa è molto utile ai fini della gestione e della pianificazione delle ricevute bancarie. Il castelletto è il fido che la banca concede con copertura delle ricevute bancarie presentate all'incasso, banche diverse praticano interessi passivi diversi su questi fidi ed interessi maggiori nel caso che che vengano presentati effetti per importi superiori al fido concesso per questo motivo nel caso che la ditta disponga di fidi presso più banche è importante controllare la disponibilità presso le varie banche prima di presentare le ricevuto per l'accredito in modo da evitare di pagare inutilmente interessi maggiori,il castelletto disponibile per ciascuna banca viene inserito nell'archivio delle banche.. Nella stampa viene evidenziata la data di scadenza e la data di valuta che è la data in cui effettivamente vengono accreditati gli effetti, il caloclo della valuta viene effettuato tenendo conto dei giorni di valuta memorizzati nell'archivio delle banche, i giorni di valuta possono essere calcolati come giorni effettivi di calendario o come giorni lavorativi, nel secondo caso ai giorni vengono sommati i sabati e le domeniche ed i giorni di festività nazionale.
Lista bonifici attivi Con questa stampa si ottiene la lista dei bonifici che i clienti dovrebbero pagare presso la banca scelta. La banca su cui si chiede al cliente di effettuare il bonifico viene scelto in fase di introduzione della Primanota o dei Documenti di magazzino.
Lista ricevute passive | Questa stampa permette di ottenere la lista delle ricevute bancarie che verranno presentate dai fornitori sulla banca scelta. Questo può avvenire perché nelle anagrafiche dei fornitori viene indicata la banca su cui il fornitore chi appoggia le ricevute.
Flusso finanziario | Questa stampa permette di leggere in modo raggruppato tutti i dati presenti nelle precedenti stampe, presenta infatti le ricevute passive, i bonifici attivi attesi e le ricevute attive presentate, gli importi sono incolonnati per cliente e fornitore e ad ogni scritture vengono riportati i progressivi. In questo modo si ottiene una stima dei flussi finanziari previsti sulla banca scelta. Ovviamente in questa stampa non si tiene conto delle sopravvenienze per cui non è prevista la banca in anticipo, ad esempio non si tiene conto dei bonifici passivi e delle rimesse dirette

Gli altri dati richiesti sono:

Banca di presentazione | Inserire il codice della banca di cui si desidera la stampa, premendo il pulsante collegato si apre la lista delle Banche contenente solo le banche che hanno inserito il sottoconto di movimentazione del piano dei conti, e che quindi sono banche presso cui abbiamo un conto corrente.
Raggruppa per data | Con questa opzione si sceglie se raggruppare le scadenze per data di scadenza e nel caso vengono stampati i totali per data.
Calcola saldo contabile | Questo dato viene chiesto solo per la stampa del flusso finanziari e serve ad indicade se si desidera far partite il calcolo dal saldo contabile della banca. Si mette la spunta se contabilmente questo dato è aggiornato.

Alla fine viene effettuata la stampa. Affinché questa stampa dia risultati attendibili è necessario eliminare le scadenza che sono state già pagate o che sono andate insolute. Per eseguire la cancellazione in modo automatico si possono utilizzare vare procedure di incasso e pagamento come ad esempio la procedura di Incassi ed Insoluti o la procedura di Incassi e Pagamenti.

in modo da eliminare le scadenze che sono già state pagate o che sono andate insolute.


 Questa interessante stampa mette a confronto le scadenze dei clienti e dei fornitori e visualizza il saldo progressivo della differenza tra i pagamenti da effettuare e gli incassi previsti.

In congiunzione con i saldi delle banche permette di prevedere le situazioni finanziari future.


Questa procedura controlla se ci sono differenze tra i saldi contabili di Clienti e Fornitori con la somma delle scadenze.

In caso di differenze viene presentata una lista e per ogni anagrafica è possibile vedere la scheda contabile, le partite e la lista delle scadenze. In questo modo si possono analizzare i dati ed apportare le opportune correzioni.

Siccome il controllo viene fatto su tutte le scadenze, la procedura funziona solo per l'esercizio corrente. Ed è anche necessario che per l'esercizio corrente sia presente il bilancio di Apertura che può essere calcolato in ogni momento con la procedura di Chiusura ed apertura automatica di bilancio.


 Con questa procedura si possono effettuare cancellazioni globali di scadenze, solitamente viene utilizzata se per qualsiasi motivo non è stato gestito lo scadenzario per un certo periodo e quindi si sono accumulate scadenza non aggiornate.

I dati da inserire sono:
Tipo anagrafica | Inserire 'C' per Clienti e 'F' per Fornitori, premendo il pulsante collegato si apre la lista di scelte.
Tipo scadenza | E' una selezione sui tipi di scadenza
Cancella fino a data | Inserire la data limite di cancellazione delle scadenze
Confermi la cancellazione | Per eseguire la cancellazione si deve confermare, questo serve per evitare cancellazioni indesiderate.
Alla fine viene eseguita la cancellazione.


Con questa procedura se memorizzano alcuni dati di configurazione della gestione delle scadenze.

I dati da inserire sono:

Causale presentazione effetti | Inserire il codice della causale contabile utilizzata dalla procedura di presentazione della distinta bancaria per la presentazione degli effetti, premendo il pulsante collegato si apre la lista delle causali contabili.
Causale ricevute incassate | Inserire il codice della causale contabile utilizzata per il giroconto da effetti in portafoglio a banca nella procedura di incassi ed insoluti, premendo il pulsante collegato si apre la lista delle causali contabili
Causale insoluto clienti | Inserire il codice della causale contabile utilizzata in caso di insoluto nella procedura di incassi ed insoluti, premendo il pulsante collegato si apre la lista delle causali contabili
Rimborso insoluti chiesto ai clienti | In questa posizione si inserisce l'importo che viene chiesto ai clienti per il rimborso delle spese per ciascun insoluto, viene utilizzato dalla procedura che stampa i solleciti nella procedura di incassi ed insoluti.
Descrizione tipo accredito effetti | Inserire in questa posizione la descrizione del tipo di accredito che viene proposto nella procedura di presentazione della distinta bancaria e di ristampa distinta.
Nome file RIBA | Inserire il nome del file utilizzato per la preparazione dischetto RIBA.
Descrizione creditore | Inserire quattro righe di descrizione del nome del creditore RIBA, queste informazioni vengono copiate nelle RIBA.
Firma creditore RIBA | Inserire il nome breve del creditore RIBA, questo dato viene riportato nel file delle RIBA.
Codice fiscale del creditore | Inserire il codice fiscale del creditore, questo dato è richiesto nei tracciati RI.BA.


 Questo menù contiene le voci necessarie per la gestione del magazzino e dei documenti di magazzino, si può gestire il carico e scarico, oppure si può gestire solo la produzione di documenti, i documenti possono generare altri documenti, per esempio dagli ordini vengono generati i ddt e dai ddt vengono generate le fatture. Il programma fornisce anche statistiche approfondite sulle merci vendute. Le voci disponibili sono:

Documenti permette di inserire, modificare e cancellare i documenti di magazzino
Stampe contiene alcune interessati stampe.
Vendita al banco serve per la gestione della vendita al minuto e la stampa di etichette barcode.
Elaborazioni questo menù permette di eseguire operazioni saltuarie.
Inventario con le voci di questo menù si gestiscono le giacenze di magazzino e gli inventari.
Preferenze questa voce serve per memorizzare alcuni parametri di configurazione.


Tutte le operazioni di magazzino avvengono inserendo documenti di magazzino e tutti i documenti vengono inseriti con questa voce, ad eccezione di alcuni documenti che vengono generati automaticamente da alcune procedure come ad esempio la fatturazione automatica o dalla procedura di inserimento giacenze o anche dalla procedura di vendita al banco, ma in ogni caso i documenti possono essere modificati o cancellati con questa procedura.

I documenti possono fare carico e scarico di magazzino come ad esempio i DDT a Clienti oppure I DDT da Fornitori oppure non fare alcuna movimentazione come ad esempio le fatture differite. Altri documenti possono essere solo descrittivi come ad esempio i Preventivi a Cliente o altri ancora possono essere documenti generanti per altri documenti come ad esempio gli Ordini a Clienti e gli Ordini a Fornitori.

Poiché le giacenze vengono calcolate leggendo i documenti, le modifiche fatte ai documenti che fanno carico e scarico si riflettono immediatamente sulla giacenza di magazzino questo fino a quando non viene eseguita una procedura di consolidamento dei documenti che rende definitivo il documento ed irrilevante ai fini della giacenza.

Quando si cancella un documento vengono fatti alcuni controlli che servono per rafforzare il controllo sulle cancellazioni. Viene richiesta un ulteriore conferma per cancellare gli ordini non completamente evasi, viene richiesta ulteriore conferma per cancellare i documenti convalidati e viene chiesto se si desidera ripristinare le quantità evase per i documenti che hanno effettuato evasione.

Quando si inserisce un nuovo documento, prima di tutto viene chiesto il tipo documento da utilizzare:

Dopo aver inserito un codice valido viene presentato l'inserimento del documento che avviene utilizzando la modalità di gestione documenti.

I dati richiesti in testata dipendono dal tipo di documento e dalla configurazione del programma, a seconda del tipo di documento può essere chiesto:

Data movimento | E' la data utilizzata per la movimentazione del magazzino. I documenti vengono di norma ordinati con questa data.
Codice Anagrafica | A seconda del tipo documento si deve inserire il codice del Cliente oppure del Fornitore. Premendo il pulsante collegato si apre l'archivio corretto, alla conferma vengono assegnati alcuni valori predefiniti e vengono anche fatti alcuni controlli di congruenza, ad esempio viene evidenziata la situazione del fido in caso di sforamento. In caso di fattura emessa alla pubblica amministrazione viene automaticamente assegnato al cliente il registro iva dedicato alla PA. Se si emettono fatture al "Cliente per fattura semplificata", la fattura elettronica utilizzerà il formato di fattura semplificata ed in questo modo si potrà evitare di inserire i dati anagrafici del cliente, ma sarà sufficiente inserire la Partita IVA o il Codice Fiscale.
Data documento | Si inserisce la data che compare nel documento, se non ci sono motivi particolari per fare diversamente, si inserisce la stessa data inserita nel campo Data movimento, la data potrebbe essere diversa solo per i DDT da fornitori che potrebbero essere emessi in data antecedente a quella in cui arriva la merce.
Numero documento | Questo dato non viene chiesto durante l'inserimento di tipi di documentocon la numerazione automatica poiché viene chiesto alla fine dell'inserimento, questo meccanismo serve ad evitare errori di numerazione in condizioni di multiutenza.
Registro IVA | Il programma può gestire registri multipli, se è stata abilitata questa funzione viene chiesto il registro IVA a cui appartiene questo documento. In caso di fattura emessa alla pubblica amministrazione viene accettato solo il registro IVA dedicato alla PA.
Lotto rintracciabilità | Questo dato viene chiesto in modifica dei documenti di carico se è stata attivata la procedura di rintracciabilità degli alimenti e serve a modificare il lotto di carico in caso di necessità, solitamente non è necessario apportare modifiche.
Modalità di Pagamento | Questo dato viene chiesto solo per i documenti a Clienti, viene proposto automaticamente il codice presente nell'anagrafica del Cliente. Premendo il pulsante collegatosi apre la lista delle Modalità di Pagamento. La modalità indicate serve a calcolare le scadenze che verranno visualizzate nei documenti che lo prevedono e generate in fase di contabilizzazione delle fatture.
Banca per bonifici | Se il tipo di pagamento della modalità di pagamento è per mezzo di bonifico bancario viene visualizzato questo pulsante che permette di indicare su quale banca il cliente dovrà accreditare il bonifico bancario. Questi dati verranno indicati nella stampa della fattura ed il codice della banca verrà riportato nella scadenza in modo da poter stampare la lista dei bonifici attesi in ogni banca. Nelle preferenze può essere indicata la banca predefinita.
Codice Agente | Questo dato viene chiesto solo per i documenti a clienti, si deve inserire il codice dell'agente che effettua la vendita, viene proposto l'agente presente in anagrafica del Cliente. Premendo il pulsante collegatosi apre la lista degli Agenti.
Numero listino | E' il codice del listino usato per inserire i prezzi. Questo campo viene utilizzato solo per i documenti a Clienti e viene proposto il codice listino memorizzato nell'anagrafica del cliente. Premendo il pulsante collegatosi apre la lista dei Listini.
Codice commessa | Questo dato è disponibile se è stato abilitato il modulo di gestione commesse. Si inserisce il codice articolo che viene utilizzato per identificare la commessa. Vengono presentati solo gli articoli che appartengono alla categoria delle commesse. Se si inserisce un codice il dato viene proposto in tutte le righe che lo compongono.
Cambio | Se il listino scelto non è espresso in Euro ma in altra valuta, viene visualizzato questo pulsante che apre un campo in cui si può inserire il tasso di cambio del giorno in cui viene emesso il documento, viene proposto il valore presente nell'archivio delle valute straniere.
Riferimenti esterni | In questo campo libero si possono inserire riferimenti del cliente o del fornitore per facilitare il reperimento di documenti.
Data consegna | Questo dato viene chiesto solo se il documento è un Ordine o un Carico da conto lavoro e serve ad indicare la data entro cui presumibilmente dovrà essere evaso il documento.
Codice deposito | E' il codice in cui vengono fatti i movimenti di magazzino, viene proposto il deposito principale memorizzato nelle preferenze di magazzino. Se si cambia il codice, ed il deposito ha un registro IVA predefinito, viene cambiato il codice registro del documento. Premendo il pulsante collegatosi apre la lista dei Depositi.
Destinatario | Questo dato viene chiesto solo se il tipo di documento non prevede l'inserimento dei dati di trasporto, permette di inserire il codice di un clienteche può essere ricercato anche premendo il pulsante collegato. Serve per raggruppare i documenti secondo un secondo criterio che può essere utile quando si vogliono ricercare i documenti appartenenti ad un cliente raggruppati per destinazione.
Codice esenzione cliente | I Clienti possono essere esentati dal pagamento dell'IVA per vari motivi, ad esempio gli esportatori abituali dichiarano ai loro fornitori di essere esportatori e per questo sono esenti da IVA fino al raggiungimento di un determinato Plafond di acquisti. Nei documenti a Cliente si può inserire il codice di esenzione e viene proposto automaticamente quello del Cliente. Nelle righe verrà proposto questo codice invece del codice tipico dell'articolo. Premendo il pulsante collegato si apre la lista dei Codici IVA.
Note | In questo memosi possono inserire annotazioni relative al documento.

Dopo aver inserito la testata si passa alla gestione delle righe, nei documentiche evadono altri tipi di documento ad esempio i DDT che evadono Ordini, in questo momento viene letto l'archivio per vedere se ci sono documenti da evadere ed in caso affermativo viene presentata la lista di evasione, in tale lista vengono visualizzate le righe dei documenti da evadere non evase o parzialmente evase e viene richiesta la quantità da evadere. La lista di evasione può essere richiamata anche come comando speciale sulle righe.

Se si stanno facendo fatture al "Cliente per fattura semplificata", a questo punto vengono richiesti Partita IVA o Codice Fiscale che sono i dati sufficienti per emettere quel tipo di fatture.

Se il tipo di documento è tra quelli previsti per le autofatture SDI, a questo punto viene chiesto il codice del Tipo di Documento SDI ed eventualmente il codice idSdI del documento di riferimento. Il documento di riferimento.

Ad esempio se abbiamo ricevuto una fattura in "Reverse Charge", possiamo inserire un documento autofattura di tipo "SDI", come codice fornitore indichiamo il codice del fornitore originale, come data documento indichiamo la data in cui abbiamo ricevuto la fattura ed in questa posizione inseriamo il codice "TD16" che è quello previsto per questo tipo di operazione e come codice di riferimento inseriamo il codice assegnato da SdI in fase di ricezione. Nelle righe del documento andremo ad inserire la somma imponibile con l'aggiunta dell'iva come previsto dalla normativa per il Reverse Charge.

Una volta giunti alle righe, si possono inserire tre tipi di righe. Nella riga Articolo si esegue la movimentazioni di articoli codificati.

I dati richiesti sono:
Codice Articolo | Inserire il codice dell'articolo, in caso di articolo con varianti si può inserire direttamente il codice seguito dal carattere indicato come separatore nelle preferenzee dalle varianti dell'articolo. Se non si inserisce la parte variante per gli articoli che prevedono varianti viene automaticamente aperta la finestra di inserimento varianti. Se si preme il pulsante collegato o si inserisce un codice incompleto o errato si apre la lista degli articoli.
Quantità | Inserire la quantità di articolo, si possono inserire anche quantità con un massimo di tre decimali. Se si preme il pulsante collegatosi può calcolare la conversione di unità di misura, può capitare infatti che si acquisti in unità di misura diversa da quella di vendita, oppure che si voglia specificare nella vendita le quantità utilizzando misure che determinano la quantità.
Codice commessa | Questo dato è disponibile se è stato abilitato il modulo di gestione commesse. Si inserisce il codice articolo che viene utilizzato per identificare la commessa. Vengono presentati solo gli articoli che appartengono alla categoria delle commesse. In un singolo documento ci possono essere righe che fanno riferimento a commesse diverse.
Lotto rintracciabilità | Questo dato viene richiesto solo se si sta inserendo un documento di scarico e se è stata attivata la procedura di rintracciabilità degli alimenti. Viene proposto l'ultimo lotto di carico dell'articolo inserito, ma nella lista di scelte sono presenti gli ultimi lotti di carico in cui era presente l'articolo per scegliere quello effettivamente impiegato.
Prezzo unitario | Il prezzo da applicare viene proposto automaticamente quando si inserisce l'articolo, e deriva da un calcolo piuttosto sofisticato che viene illustrato in dettaglio nella pagina del calcolo dei prezzi di vendita. Se si preme il pulsante collegato il programma va a cercare se in precedenza era stato acquistato o venduto lo stesso prodotto allo stesso Cliente o Fornitore ed in caso affermativo presenta le condizioni praticate l'ultima volta per poterle eventualmente applicare nuovamente.
Sconto 1-3 | Il programma può gestire fino ad un massimo di tre sconti per ogni riga, il calcolo avviene calcolando lo sconto 1, quindi sul importo residuo viene applicato lo sconto 2 e di seguito lo sconto 3, questo porta ad un risultato ben diverso da quello che si otterrebbe se prima si sommassero le aliquote di sconto e poi le si applicasse. Ad esempio se l'importo è 100,00 e gli sconti sono 20+10+5 con il primo calcolo si ottiene 68,40 e con il secondo calcolo si ottiene 65.00. Gli sconti vengono proposti utilizzando la scontistica o gli sconti fissi di listino.
Provvigioni | Viene proposta la percentuale di provvigione ottenuta dalla scontistica.
Altre annotazioni Questa voce permette di inserire una breve annotazione agguntiva alla riga, si può utilizzare per esempio per inserire i codici articoli utilizzati da clienti o fornitori, oppure per inserire lotti di produzione o numeri di matricola.
Se è stato attivato il modulo di vendita prodotti per agricoltura, compare un pulsante che permette di ricercare il lotti di produzione inseriti con le bolle di carico in questa stessa posizione.
Se è stato attivato il modulo di gestione matricole, compare un pulsante che ha una doppia funzionalità. Se è stato inserito il codice dell'articolo, presenta la lista di tutte le matricole dei prodotti in giacenza. Se invece non è stato inserito il codice articolo, inserendo qui la matricola e cliccando sul pulsante viene trovato l'articolo a cui appartiene la matricola.
La corretta gestione delle matricole implica che quando si acquistano prodotti con matricola si inseriscano documenti di carico con una riga per ogni articolo con matricola diversa e che il codice venga inserito qui, poi quando si fanno documenti di scarico, si deve inserire la matricola che viene scaricata utilizzando le modalità di ricerca illustrate.
Codice IVA | Inserire il codice IVA della riga. Premendo il pulsante collegatosi apre la lista dei Codici IVA. Se in testata è stato inserito un codice d'esenzione, viene proposto quel codice, altrimenti viene preso il codice IVA presente in anagrafica degli Articoli.
Data consegna | Per i documenti che prevedono evasione (Ordini e conto lavoro), viene chiesta la data di consegna prevista della riga, viene proposta la data presente in testata.
Varianti | Questo pulsante è presente solo se è stata abilitata la gestione delle varianti e permette di inserire o modificare i codici e le opzioni delle varianti. Negli articoliè presente il codice della tabella di varianti, ogni tabella prevede fino ad un massimo di dieci varianti per articolo. Premendo il pulsante si apre una finestra che propone le varianti presenti in tabella e permette di scegliere le opzioni per ciascuna variante ed eventualmente anche di togliere o aggiungere varianti non previste in tabella. per ogni opzione viene proposto il valore predefiniti presente nell'archivio delle variantied eventualmente anche la misura associata con la variante.
Descrizione | Si può modificare la descrizione che compare nella riga.

Si possono inserire anche righe extramagazzino che servono per inserire righe valorizzate che non fanno riferimento ad alcun articolo di magazzino, la corrette gestione consiglierebbe di fare uso sporadico di questa possibilità perché queste righe non possono generare movimentazione e quindi non generano statistiche, inoltre la gestione degli articoli è flessibile e consente di inserire anche descrizioni diverse.

I dati richiesti sono:
Descrizione | Inserire la descrizione del bene che viene ceduto.
Quantità | Inserire la quantità di bene ceduto. Se si preme il pulsante collegatosi può calcolare la conversione di unità di misura, che nel caso delle righe extramagazzino prima di tutto chiede unità di misura ed unità di misura alternativa.
Prezzo unitario | Inserire il prezzo unitario.
Sconto 1-3 | Il programma può gestire fino ad un massimo di tre sconti per ogni riga, il calcolo avviene calcolando lo sconto 1, quindi sul importo residuo viene applicato lo sconto 2 e di seguito lo sconto 3, questo porta ad un risultato ben diverso da quello che si otterrebbe se prima si sommassero le aliquote di sconto e poi le si applicasse. Ad esempio se l'importo è 100,00 e gli sconti sono 20+10+5 con il primo calcolo si ottiene 68,40 e con il secondo calcolo si ottiene 65.00.
Provvigioni | Inserire la provvigione da riconoscere al l'agente, Viene proposta automaticamente la percentuale inserita nel primo campo della tabella degli agenti.
Unità di misura | Inserire la descrizione dell'unità di misura con cui viene valorizzato il bene.
Codice IVA | Inserire il codice IVA della riga. Premendo il pulsante collegatosi apre la lista dei Codici IVA. Se in testata è stato inserito un codice d'esenzione, viene proposto quel codice altrimenti viene proposto il codice inserito nelle preferenzeper le spese bancarie.
Data consegna | Per i documenti che prevedono evasione (Ordini e conto lavoro), viene chiesta la data di consegna prevista della riga, viene proposta la data presente in testata.
Tipo Stampa | Con questa voce si può indicare quando si vuole che venga stampata questa riga, ad esempio nel caso di beni immateriali si desidera che non vengano stampati nella bolla ma vengano stampati nella fattura, in questo contesto ha senso inserire '1' che stampa la riga sempre o '4' che la stampa solo nei documenti generati. Premendo il pulsante collegatosi apre la lista di scelte.

L'ultimo tipo di riga inseribile è la riga descrittiva, questo tipo di riga è ininfluente ai fini del calcolo degli importi e serve per aggiungere descrizioni nel corpo del documento.

I dati da inserire sono:
Descrizione Inserire la descrizione che si vuole inserire nel documento.
Leggi tracciato Questo pulsante permette di inserire velocemente testi usati frequentemente come riga descrittiva, premendolo si apre la lista dei testi disponibili, il testo scelto sostituisce il testo eventualmente inserito in precedenza.
NOTA TECNICA:I testi ripetitivi devono essere inseriti nelle "Risorse Utente" con Tipo uguale a "TM" e codice che inizia con "MMG_NOTE" seguito da qualche carattere diverso per ogni testo.
Tipo Stampa Con questa voce si può indicare quando si vuole che venga stampata questa riga. Premendo il pulsante collegatosi apre la lista di scelte che sono:
1 | STAMPA SEMPREla riga viene stampata sempre
2 | NON STAMPAREla riga non viene stampata mai, è una annotazione interna dell'utente
3 | QUESTO DOCUMENTOla riga viene stampata solo in questo documento e non in eventuali documenti generati, ad esempio si possono inserire con questo codice annotazioni da stampare in bolla ma che non devono essere riportate in fattura.
4 | DOCUMENTO GENERATOla riga viene stampata solo sul documento generato.

Sulle righe del documento possono essere disponibili alcuni Comandi speciali:

Tipo stampa descrizione: Questo comando consente di indicare come e quando stampare la riga. Ad esempio se si inseriscono in un DDT beni immateriali come ad esempio le ore di lavoro si può decidere di stamparlo solo in fattura e non nel DDT.
1, 2, 3 Righe documento | Premendo 1, 2 o 3 si inseriscono in modo più veloce ed agevole le righe di tipo Articolo, Extramagazzino e Descrittiva.
Decimali prezzi documento La maggior parte degli operatori economici utilizzano i prezzi con due decimali (ad esempio Euro 10,99), ma a volte questo non è sufficiente, Zefiro permette di scegliere a livello globale se utilizzare 2 o 4 decimali per i prezzi e se si scelgono 4 decimali in tutti i campi in cui si inserisce un prezzo e in tutte le stampe, verranno presentati i 4 decimali.
Alle volte però strutturalmente si usano i 2 decimali ma può servire di avere necessità di più decimali solo in casi specifici ed isolati. Con questa opzione, è possibile decidere solo per questo documento di utilizzare un numero diverso dallo standard, ed in fase di stampa si terrà conto della scelta fatta, inoltre se il documento è un ordine oppure un DDT, tutti i documenti generati terranno conto dei decimali modificati.
Si può inserire un numero da 0 (zero) a 4, se si inserisce Zero vale la configurazione standard del programma.
Inserimento Kit di prodotti | Questa voce è disponibile se non è attivato il modulo di distinta base e permette di inserire contemporaneamente un gruppo dei prodotti. Può essere utile ad esempio per inserire confezioni di prodotti oppure kit di manutenzione. I kit vanno inseriti nella gestione articoli e quando si inserisce un Kit si può decidere se inserire anche una riga descrittiva che contiene la descrizione del kit.
Calcola totali | Viene aperta una finestra in cui vengono calcolati i totali della fattura con il dettaglio per aliquota IVA, è la stessa finestra che viene presentata a piede se il tipo documento prevede l'inserimento dei totali documento.
Duplica riga | Con questa procedura viene duplicata la riga corrente.
Assegna prezzi Questo comando permette di modificare in modo veloce i prezzi di tutte le righe. Si apre una lista con tutte le righe del documento e si puo inserire velocemente il prezzo su ciascuna riga, oppure si possono spuntare le righe ed a quelle spuntate applicare un prezzo fisso oppure l'ultimo prezzo di listino. Alla fine le righe spuntate vengono aggiornate nel documento.
Questa procedura sostituisce la precedente procedura chiamate "Aggiorna prezzi"
Applica sconti | Questa procedura permette di inserire automaticamente uno sconto in tutte le righe. Lo sconto viene inserito nel primo vuoto dei tre sconti disponibili, ad esempio se una riga ha già uno sconto, ne viene aggiunto un secondo, se tutti e tre gli sconti sono impegnati, lo sconto indicato viene aggiunto all'ultimo. Si può anche indicare se si desidera applicare direttamente lo sconto al prezzo unitario.
Importa file di testo | Questa procedura permette di importare le righe del documento da un file di testo utilizzando il formato della importazione di articoli.
Altri dati riga Nelle singole righe dei documenti si possono inserire informazioni aggiuntive che a volte hanno significato solo per alcuni tipi di documento.
I dati che si possono inserire sono:
Numeri 1 - 5: In ciascuna riga dei documenti sono disponibili valori numerici aggiuntivi che possono essere utilizzati per i motivi più svariati, ad esempio per inserire il peso delle riga o per i riferimenti di evasione di clienti o anche per i parametri di conversione di unità di misura. Con questo comando si possono modificare questi dati.
Data e numero riferimento:Alcune righe contengono riferimenti a documenti generanti, ad esempio nei DDT durante l'evasione degli ordini vengono memorizzati gli estremi dell'ordine evaso, con questa procedura si può modificare i dati di evasione.
Costo:Ogni riga inserita si porta dietro il costo unitario rilevato nel momento dell'inserimento, se serve si può modificare.
Arrotondamento:Succede raramente, ma se si desidera, si può arrotondare il totale della riga corrente, ad esempio se il totale calcolato della riga è 154,96 e noi vogliamo portarlo a 155,00 possiamo inserire in questa posizione 0,04 ed il nuovo valore arrotondato verrà applicato al documento ed a tutti i documenti e calcoli generati. Però i tracciati stampa normalmente non ne tengono conto, se si desidera si può richedere una modifica specifica dei tracciati.
Quantità evasa e forza evasione: Nei documenti che prevedono evasione (Ordini e Carico da Conto Lavoro), viene memorizzata la quantità evasa dai documenti generati con la procedura di evasione, in questa posizione si può modificare la quantità ed eventualmente forzare la chiusura dell'evasione in caso di quantità diverse dall'ordinato.
Provvigioni capoarea: Nella gestione delle provvigioni è possibile assegnare provvigioni a capoarea in funzione delle vendite effettuate dai sotto agenti. Solitamente il calcolo è automatico in base alle regole assegnate per gli articoli. Se si lascia questo valore a Zero valgono le regole impostate per gli agenti, altrimenti è possibile forzare la provvigione in caso di accordi diversi o per righe extra magazzino.
Raggruppa righe | Alle volte può accadere di avere righe articolo con codici duplicati, questo accade ad esempio quando si evadono ordini in tempi diversi. In questo caso è possibile raggruppare le righe per riunire righe con articoli uguali. Il raggruppamento avviene ordinando gli articoli secondo il documento evaso e avviene solo se articolo, prezzi, sconti e riferimenti di evasione sono identici.
Genera righe automatiche | Questo comando serve per generare automaticamente righe di magazzino come illustrato nella tabella Righe automatiche documenti.
Controllo fido | Se stiamo inserendo un documento di clienti, con questo comando è possibile controllare la situazione del fido comprensivo del valore delle righe inserite.
Dati FatturaPA | Se il documento che si sta modificando è una fattura emessa alla Pubblica Amministrazione, con questo comando si possono inserire dati aggiuntivi che vengono esportati nella fattura elettronica e che possono essere richiesti dal ente a cui emettiamo fattura. Si possono inserire Il numero del ordine, il codice CUP, il codice CIG e se si desidera si può forzare l'applicazione a tutte le righe che compongono il documento. Il formato della FatturaPA richiede obbligatoriamente la presenza del numero ordine se sono presenti altri dati come ad esempio il codice CIG.
Conversione tipo riga Questo comando permette di trasformare le righe Articolo in Extramagazzino e viceversa. Se si converte da extramagazzino ad articolo la descrizione viene conservata, viceversa se si converte da articolo ad extramagazzino, viene applicata la descrizione dell'articolo.
Prezzi, sconti e gli altri parametri vengono conservati.
Spunta righe | Questo comando apre la colonna delle spunte a sinistra delle colonne. in questo modo si possono spuntare le righe ed alcuni comandi che vengono applicati a tutte le righe si applicano solo alle righe spuntate. Facendo click con il pulsante destro sulla colonna si possono spuntare tutte le righe oppure azzerare le spunte.
Comandi extra | Questo comando è disponibile solo per le righe descrittive e permette di attivare comandi che effettuano particolari formattazioni dei dati della riga descrittiva. In caso di esigenze particolari si possono richiedere personalizzazioni che facciano uso di questo comando.
Importa righe da file | Questa procedura permette di importare le righe del documento da file esterno utilizzando uno dei formati previsti. Il formato più comune è quello generato dalla lettura di codici con il programma per Android chiamato "Liste di Codici", ma sono supportati anche files in formato Excel e LibreOffice. Per una spiegazione più dettagliata consultare la voce dedicata alla Lettura liste di articoli
Importa righe da terminale Questa procedura è disponibile solo se è stata configurata la procedura di importazione da terminale nelle preferenze di magazzinoe serve per leggere le righe del documento con un terminale portatile e quindi importarle nel documento corrente.
A differenza della procedura precedente in cui si sceglie il file da leggere, in questo caso il formato è fisso e determinato dalla procedura configurata nelle preferenze.
Inserisci righe automatiche | Nei tipi documento è possibile inserire un certo numero di righe che possono essere inserite automaticamente nei documenti. Con questo comando si effettua l'inserimento delle righe.
Lista preferiti | Questo comando, disponibile per i documenti dei clienti e dei fornitori, apre una finestra con la lista degli articoli preferiti inseriti per il cliente o per il fornitore corrente. Nella lista si inserisce la quantità desiderata per ogni articolo ed è possibile anche aggiornare la quantità predefinita per questo articolo.
Genera preferiti | è possibile generare o aggiornare automaticamente i preferiti di questo cliente o fornitore, si spuntano gli articoli da aggiornare e la procedura aggiorna i preferiti alla data del documento.
Evadi ordini / conto lavoro I documenti che prevedono l'evasione di altri documenti come ad esempio i DDT che evadono gli ordini, nel passaggio dalla testata alle righe eseguono la ricerca di eventuali documenti da evadere e presentano la lista delle righe non completamente evase, la stessa lista può essere visualizzata richiamando questo comando.
Per ogni riga si può evadere la quantità desiderata, si può forzare la chiusura della riga anche se la quantità che si evade è diversa dalla quantità residua ed infine si può modificare prezzo e sconti che dal momento di emissione dell'ordine a quello di evasione potrebbero essere cambiati.
La procedura di evasione dispone di alcuni comandi per effettuare l'evasione completa di un ordine o di tutti gli ordini in sospeso e per raggruppare le evasioni per codice articolo.
Copia righe | Questo comando permette di copiare un certo numero di righe del documento corrente per poi poterle incollare su questo stesso documento o su altri documenti. Si apre una lista con le righe attualmente presenti nel documento ed è possibile spuntare quelle che si desidera copiare.
Incolla righe | Questo comando è presente solo se in precedenza è stata fatta la copia di alcune righe di un documento e consente di incollare le righe in coda al documento corrente. è da notare che con al procedura di copia ed incolla si possono copiare gruppi di righe tra un documento ed un altro.

Al termine dell'inserimento delle righe, a seconda della configurazione prevista dal tipo di documento, vengono chiesti ulteriori dati.
Se si sta inserendo un documento di produzione vengono automaticamente generate le righe di scarico dei materiali impiegati per produrre i materiali indicati nelle righe articolo. Per fare questo vengono utilizzate le materie prime indicate nella distinta base degli articoli nelle quantità previste. I documenti di produzione possono eseguire il calcolo della produzione al primo livello oppure esplosa, nel primo livello viene presa in considerazione solo la materia prima della distinta dell'articolo, nel secondo caso quando viene trovato un componente che a sua volta ha una distinta base, viene esploso nei suoi componenti per raggiungere la materia prima finale.
Se è stato attivato il controllo automatico del fido in caso di sforamento viene presenta la richiesta per la conferma.
Alcuni documenti prevedono la possibilità di visualizzare i totali del documento e di inserire alcuni importi.

Se il documento è una fattura a cliente e si supera l'importo minimo per attivare la modalità di pagamento alternativo, viene chiesto di attivare la nuova modalità di pagamento.

I dati da inserire sono:
Sconto % | Questo dato solitamente viene preso dalla modalità di pagamento e serve ad indicare uno sconto finanziario accordato in base alla modalità di pagamento, non si dovrebbe usare per sconti legati alla merce, questo sconto viene applicato sugli importi imponibili.
Ritenuta | Questo pulsante è visibile sono per i documenti che sono fatture con ritenuta d'acconto e permette di variare la percentuale di ritenuta, di imponibile non soggetto e di Enasarco solo per questo documento, è utile per chi ha profili diversi di fatturazione con ritenuta o per coloro a cui le condizioni cambiano nel tempo.
Sconto importo | Si può inserire l'importo di uno sconto fisso o di un arrotondamento, lo sconto viene applicato sul totale del documento, è appropriato solo per inserire arrotondamenti.
Spese incasso | Si possono inserire le spese addebitate per l'incasso degli effetti.
Spese bolli | Si possono inserire le spese per i bolli apposti sull'originale del documento.
Acconto pagato | Si può inserire l'importo dell'acconto già pagato dal cliente, tale importo verrà defalcato dal totale a pagare e dalle scadenze generate.

Per i documenti che prevedono il trasporto della merce, vengono richiesti i dati di trasporto. Non tutti i dati richiesti sono obbligatori per legge, ma vengono proposti perché possono essere necessari in alcune occasioni. I tracciati stampa non sempre tengono conto di questi campi, in caso di necessità si dovranno modificare i tracciati.

I dati da inserire sono:
Causale del trasporto | Inserire la causale del trasporto. Premendo il pulsante collegatosi apre la lista di scelte, le causali con codice numerico da '0' a '9' sono causali di vendita e nei documenti di consegna come ad esempio i DDT a clienti indicano che il documento verrà fatturato con la procedura di fatturazione automatica.
Spedizione | Indicare il soggetto che effettua il trasporto che può essere il mittente, il destinatario oppure un vettore. Premendo il pulsante collegatosi apre la lista di scelte.
Porto | Indicare se il porto è franco o assegnato. Premendo il pulsante collegatosi apre la lista di scelte.
Codice vettore | Se il trasporto viene effettuato da un vettore, in questa posizione si indica il codice del vettore incaricato. Premendo il pulsante collegatosi apre la lista dei Vettori.
Destinazione merce | Indicare la destinazione della merce se è diversa dell'indirizzo del destinatario, premendo il pulsante si apre una finestra di dialogo che chiede i dati necessari.
Recapiti memorizzati | Questo pulsante serve per scegliere la destinazione della merce dalla lista delle destinazioni memorizzata nei recapiti dei clienti o dei fornitori. La destinazione viene copiata nella casella memo della destinazione.
Aspetto dei beni | Inserire la descrizione dell'aspetto esteriore dei beni, questo dato non è più richiesto obbligatoriamente per legge, ma viene spesso utilizzato per comodità del trasportatore e del destinatario. Premendo il pulsante collegatosi apre la lista di scelte.
Colli | Anche questo dato non è più obbligatorio, ma viene utilizzato per facilitare il lavoro di magazzinieri, trasportatori e destinatari. Premendo il pulsante collegato si può calcolare il numero dei colli in base alle righe del documento. Inserendo un particolare dato nel file di configurazione AGC.INI, si può fare in modo che il programma utilizzi un campo degli articoli per calcolare i pezzi per confezione ed in questo modo calcolare il numero di colli in modo corretto.
Peso | Si può inserire il peso della merce trasportata a beneficio del trasportatore e per calcolare eventuali costi di trasporto. Premendo il pulsante collegato si può calcolare il peso degli articoli la cui unità di misura inizia con "Kg" oppure "KG", oppure degli articoli che hanno un numero diverso da zero nel campo rapporto di conversione ed i Kg nell'unità di misura alternativa.
Data ed ora inizio trasporto | Si possono inserire i dati di inizio trasporto.
Destinatario | Questo campo permette di inserire un codice di destinatario alternativo per la merce, serve per stampare nel documento un indirizzo alternativo con riferimento nel corpo del documento del destinatario originale, oppure per raggruppare i documenti secondo un codice alternativo. Se il valore è diverso da zero, in fase di stampa viene chiesto se stampare l'indirizzo del destinatario oppure quello dell'anagrafica di testata.

Prima di procedere al salvataggio del documento vengono eseguite ancora alcune elaborazioni.

I documenti che prevedono la numerazione automatica richiedono la conferma del numero previsto dal numeratore.

Se è un documento di carico ed è stata attivata la procedura di rintracciabilità degli alimenti viene assegnato il numero di lotto. Se il documento prevede il calcolo della ritenuta d'acconto vengono automaticamente generate le righe di rimborso con gli articoli elencati in preferenze di magazzino.

Se il cliente ha la sospensione d'imposta, viene automaticamente inserita una dicitura che indica la sospensione.

Se il cliente si inseriscono i dati relativa alla dichiarazione di intento per gli esportatori abituali, viene inserita una riga con tale dicitura.

Quando si modifica un documento che è una fattura differita generata dalla procedura di Fatturazione automatica, le modifiche fatte vengono riportate anche nei DDT che hanno generato la fattura. Ovviamente se si aggiungono righe nuove, queste non saranno riportate nei DDT.

Se è stata attivata la procedura di Vendita fitosanitari e se il documento è una bolla di vendita che contiene prodotti tossici e nocivi, viene chiesto il codice del soggetto che possiede l'autorizzazione all'uso di questi prodotti. I soggetti autorizzati vanno inseriti come clienti e vengono riconosciuti perché nel codice libero vengono riportati i dati di autorizzazione. Il codice viene memorizzato nel campo destinatario contenuto nei dati di trasporto. Per questo tipo di documenti viene stampato automaticamente un modulo per la firma di accettazione di questo tipo di prodotti.

A questo punto il documento viene salvato e se il documento lo prevede, viene proposta la stampa.

I dati da inserire sono:
Tracciato stampa | Inserire il nome del tracciato utilizzato per fare le stampe, viene proposto quello memorizzato nel tipo documentoche può essere cambiato in caso di necessità ad esempio per inserire o escludere i prezzi in bolla, oppure per stampare documenti in lingua straniera.
Numero copie | Viene proposto il numero inserito nel tipo documento.
Cambia intestazione | Con questa opzione si può scegliere di stampare il documento con una intestazione alternativa, questo permette ad esempio a chi usualmente stampa i documenti su carta intestata, di stampare direttamente su fax o in formato PDF utilizzando comunque una intestazione valida.
Riepilogo righe articoli | Questa opzione permette di raggruppare in un unica riga più righe con lo stesso articolo e lo stesso prezzo, il raggruppamento viene effettuato a livello di stampa, nel documento tali righe rimangono separate.
Listino alternativo | Questa opzione permette di stampare il documento utilizzando prezzi diversi da quelli memorizzati nel documento e può essere utile per confrontare i prezzi di vendita da quelli si acquisto, oppure per confrontare i prezzi applicati rispetto ai prezzi di un listino standard. Per la stampa con il listino alternativo si può utilizzare il normale tracciato del documento, oppure si può utilizzare un tracciato che mette a confronto i prezzi del documento con i prezzi del listino prescelto, con il programma viene fornito il tracciato "D_CONFRONTO" che è stato messo a punto per questo scopo. Le righe extra magazzino non vengono influenzate da questa opzione.
Spedizione a destinatario | Questo dato viene chiesto solo per i documenti che richiedono l'inserimento dei dati di trasporto e se in tali dati viene inserito un codice di destinatario, se selezionata stampa nell'intestazione del documento i dati del destinatario e riporta nel corpo del documento il riferimento cliente o fornitore del documento.
Seleziona righe | In fase di stampa è possibile selezionare (filtrare) le righe da stampare. Quando si effettuano le selezioni, la procedura esclude le righe filtrate e calcola i totali solo sulle righe effettivamente stampate. Il programma dispone di un sistema di filtro standard che può essere applicato a tutti i documenti, ma il personale tecnico è in grado di attivare filtri personalizzati per specifici tipi di documento.
Codice listino | Se si sceglie di stampare con il listino alternativo, viene chiesto il codice listino da applicare. se si inserisce zero, vengono applicati i prezzi di costo, questo consente di calcolare il ricarico lordo applicato.
Gruppo clienti | Se si sceglie di stampare con il listino alternativo, viene chiesto il gruppo clienti, questo permette di applicare la scontistica di questo gruppo di clienti ai prezzi calcolati.

La stampa non è obbligatoria e può essere omessa per effettuarla eventualmente in un secondo momento.

Le Stampe disponibili per l'archivio dei documenti sono:

Lista documenti | Viene effettuata una lista semplice dei documenti.
Controllo numerazione | Questa stampa permette di controllare la sequenza numerica dei documenti inseriti. Vengono esaminati e stampati tutti i documenti per cui è prevista la numerazione automatica e vengono rilevati eventuali errori di numerazione. Si consiglia di selezionare solo i documenti che si desidera controllare, ad esempio solo i DDT del mese non ancora fatturati.
Stampa riepilogo | Questa stampa legge tutte le righe dei documenti per calcolare gli importi, si può eseguire la stampa seguendo alcuni criteri di ordinamento, si può chiedere che venga calcolato il solo totale delle righe, oppure che vengano calcolati anche eventuali spese e sconti a piede, si può chiedere anche l'ordinamento per vari criteri, il subtotale per ogni anagrafica e/o per mese e si possono escludere gli articoli appartenenti a determinati gruppi, ad esempio per distinguere tra merce e spese di trasporto o altro. Infine c'è la possibilità di stampare solo le fatture e le note di credito ed in questo caso le note vengono stornate dalle fatture.
Lista righe | Questa stampa permette di elencare gli articoli presenti nei documenti selezionati. La stampa può essere ordinata secondo vari criteri e si può decidere se includere anche le righe extramagazzino e descrittive. Molto utile è anche la possibilità di scegliere gli articoli da presentare attivando gli opportuni filtri.
Lista completa | La lista completa stampa per ogni documento anche tutte le righe che lo compongono, vengono anche stampati i totali del documento. Si può richiedere, l'ordinamento secondo vari criteri e se si desidera si può chiedere di stampare le sole righe con valore zero, questa opzione è utile per ricercare i documenti da valorizzare.
Riepilogo righe | Questa stampa legge tutte le righe dei documenti considerati e raggruppa le righe con lo stesso articolo sommando quantità e valore di carico e scarico.
Ristampa documenti | Se i documenti selezionati sono tutti dello stesso tipo si può eseguire la ristampa i tutti i documenti.
Stampa saldaconto | Questa stampa è disponibile solo se è stato installato il modulo "SCF" e permette di stampare il saldaconto fatture

La grande utilità di alcune di queste stampe sta nella possibilità di selezionare i dati da stampare, infatti spesso può essere utile richiedere la stampa del riepilogo o della lista completa dei DDT di vendita del periodo, oppure si possono ristampare tutte le fatture i fine mese e così via.

I comandi speciali disponibili per i documenti sono:
Ristampa documento | Per i tipi di documentoche sono stampabili, viene fornita la possibilità di eseguire la ristampa. Il tracciato stampa proposto è quello memorizzato nel tipo documento, ma se nel cliente o fornitore viene inserito un tracciato preferenziale alternativo, viene preferito rispetto a quello standard.
Invia e-mail Questa voce è presente solo se è stata configurata correttamente la gestione dell'invio di documenti tramite e-mail.
Permette di inviare rapidamente tramite e-mail il documento corrente. Vengono chiesti il tracciato stampa, l'indirizzo a cui inviare, la richiesta di ricevuta di ritorno ed un eventuale testo da aggiungere a quello standard del messaggio, l'indirizzo e-mail proposto è quello presente nell'anagrafica del cliente o del fornitore, inoltre se tra i contatti ci sono altri indirizzi e-mail viene visualizzato un pulsante che permette di scegliere quello desiderato. Alla conferma viene spedito il documento.
Invia e-mail di tutti i documenti | Può capitare di avere la necessità di inviare contemporaneamente un certo numero di documenti, oppure semplicemente di preparare i documenti in formato PDF per conservarli o copiarli in qualche modo. Questa procedura semplifica questa operazione ed è disponibile solo se sono state attivate le spunte dei documenti. La procedura chiede se si desidera la ricevuta di ritorno ed un eventuale testo aggiuntivo, chiede anche se si desidera inviare le mail oppure preparare i documenti PDF solamente. Si può decidere di inviare tutti i documenti ad un singolo indirizzo e-mail che può essere scelto tra quelli disponibili per il cliente o fornitore del documento corrente, oppure se si lascia in bianco il campo per ogni documento viene scelto l'indirizzo e-mail preferenziale. Alla conferma vengono letti tutti i documenti spuntati e se sono stampabili e se il cliente/fornitore ha configurata la mail per la spedizione dei documenti, il documento viene preparato in PDF ed inviato via mail.
Lista e-mail inviate | Quando i documenti vengono inviati tramite e-mail, vengono memorizzati i parametri di spedizione effettuata. Con questa voce è possibile esaminare la lista delle mail inviate.
Invia e-mail generica Per ogni documento, è possibile inviare una mail generica con un testo predisposto. Si possono preparare diversi testi standard in base al tipo di documenti, ed anche testi generici adatti a tutti i documenti. La preparazione dei testi richiede alcune competenze e quindi va richiesta al personale tecnico. Tecnicamente si deve aggiungere una "Risorsa" di tipo "EMT" con il codice composto dalla sigla "GTMG" seguita dalla sigla del tipo di docummento.
Viene proposta una finestra con il testo della mail da inviare, in base alle varie configurazioni si possono inserire alcuni dati fissi scelti da una lista ed alla fine viene inviata la mail.
Vedi Lista e-mail | Si può vedere la lista delle e-mail inviate per questo documento.
Stato documento Con questo documento si possono inserire degli indicatori di "Stato" del documento, ad esempio se è stato inviato il documento via mail, lo si può indicare inserendo una lettera "M", ed in seguito ad esempio si potrebbero cercare tutti i documenti che non sono stati inviati.
Scegliendo questo comando si alre la lista degli stati previsti per questo tipo di documento e si possono spuntare quelli appropriati. Il programma in alcuni casi è in grado di inserire automaticamente alcuni stati previsti. Ad esempio se una fattura è stata contabilizzata, la procedura di contabilizzazione inserisce automaticamente lo stato "C". Esistono alcuni stati predefiniti ed altri si possono inserire, per maggiori dettagli consultare la tabella dei Tipi di documento
Apri cartella documenti allegati Ogni documento può disporre di una propria cartella per memorizzare documenti di qualsiasi natura. Questo comando apre la cartella che l'utente può utilizzare come preferisce. Quando si invia il documento via mail, i files contenuti nella cartella vengono inviati come allegati, se non si desidera allegare i documenti, si possono inserire in sottocartelle che il programma non esamina.
Attenzione! Dato che il nome della cartella di destinazione è composto dagli estremi del documento Zefiro non garantisce l'univocità della cartella rispetto al documento dato che si possono inserire documenti diversi con gli stessi riferimenti, inoltre se si cambiano data, numero o codice anagrafica, viene rotto il legame con il documento e la cartella rimane orfana.
Invia e-mail schede di sicurezza | Se è stata attivata la procedura di Vendita fitosanitari e se il documento è una bolla di vendita che contiene prodotti tossici e nocivi, con questa procedura è possibile inviare automaticamente una mail con il link per scaricare da internet tutte le schede di sicurezza per i prodotti fitosanitari contenuti nel documento.
Invio a sito FTP Questa voce è presente solo se è stata configurata correttamente la gestione dell'invio di documenti a sito FTP.
Permette di inviare un singolo documento al sito. A differenza della procedura globale, in questa posizione è possibile scegliere il tracciato da utilizzare. Questo è utile se si desidera per un particolare documento un tracciato diverso da quello standard.
Esportazione documento | Zefiro dispone di un meccanismo per esportare automaticamente i dati dei documenti in vari formati come ad esempio "CSV", oppure Excel o LibreOffice. L'esportazione può variare a seconda delle necessità e quindi spesso questa funzionalità richiede personalizzazioni. Se un documento ha una procedura valida di esportazione per il tipo di documento e per il cliente o fornitore implicato, compare questa voce che permette la scrittura del file di esportazione. Inoltre, quando si inviano i documenti via email, se il documento prevede l'esportazione, è possibile allegare direttamente il file alle mail che vengono inviate. per maggiori dettaglio consultare la pagina sulle importazione documenti da file
Esportazione dati documento | Questa voce è disponibile se vengono attivate le spunte, es esegue le esportazione ad un foglio Excel o LibreOffice di tutti i documenti spuntati con tutte le righe che contiene. Le colonne da esportare possono essere configurate nel file AGC.ini alla sezione "[TESMOVDOC]".
Duplica documento | I documenti possono essere duplicati per velocizzare l'introduzione di documenti ripetitivi. In fase di duplicazione viene chiesto se si desidera aggiornare i prezzi di vendita o di costo agli ultimi prezzi presenti.
Genera nota d'accredito | Con questa procedura è possibile generare una nota d'accredito a partire da una fattura. La nota viene preparate con le righe presenti nella fattura, ma può essere modificata. Viene aggiunta una riga descrittiva con i rifermenti della fattura ed anche i dati per riportare i riferimenti nella nota d'accredito elettronica.
Riferimenti documento fattura | Nella preparazione della nota d'accredito elettronica, si possono inserire i riferimenti alla fattura accreditata. Questi dati vengono generati automaticamente dalla procedura "Genera nota d'accredito", ma possono essere modificati in caso di Note inserite manualmente.
Genera movimentazione in cantiere | Questa procedura è disponibile solo per i documenti di carico da fornitore e se è stata attivata la funzionalità di Commesse rapide. Permette di generare automaticamente lo scarico a cliente del materiale caricato con il DDT del fornitore. Viene usata quando il fornitore scarica il materiale direttamente presso la sede del cliente.
Rigenera scadenze | Questa opzione è disponibile solo se non si dispone del modulo di contabilità e si dispone del modulo di gestione scadenze, serve per rigenerare le scadenze in caso di modifiche al documento.
Rigenera provvigioni | Questa opzione è disponibile solo se si dispone del modulo di gestione provvigioni, serve per rigenerare le provvigioni in caso di modifiche al documento.
Fattura elettronica | Questa opzione è disponibile solo per le fatture e le note d'accredito e permette di generare il documento in formato XML. Per maggiori dettagli consultare la guida completa
Fatturabilità documento | Dopo aver eseguito la procedura di fatturazione automatica, i documenti fatturabili inseriti nelle fatture non possono più essere fatturati per evitare fatturazioni doppie, con questa procedura si possono rendere nuovamente fatturabili i documenti.
Modifica dati trasporto | Con questa opzione è possibile modificare i dati di trasporto senza entrare nel documento e quindi in modo molto più rapido.
Cambia prezzi e listino Questa opzione consente di cambiare i prezzi ed il listino applicato ad un documento di clienti.
Si possono variare solo i prezzi in percentuale, oppure si possono applicare i prezzi di listino ed eventualmente variarli in percentuale, o infine si può variare solo il codice del listino senza variare i prezzi.
Attiva storico/corrente Questa voce è disponibile solo se è stata attivata la gestione dello storico, inoltre perché sia visibile è necessario attivare un particolare parametro in un file di configurazione chiamato 'AGC.INI' normalmente gestito da personale tecnico.
Se attivata permette di passare dai documenti storici a quelli correnti e viceversa senza uscire dal programma.
Etichette colli | Con questa procedura si possono stampare le etichette da applicare ai colli per la spedizione della merce. Le etichette possono essere automatiche a partire da un documento, oppure libere per ciascun articolo. Per ciascun articolo si possono inserire i riferimenti dell'ordine del cliente ed alcune righe di note libere. Si può anche modificare la quantità totale ed il numero di pezzi per ogni confezione, per ogni confezione si può variare il numero di pezzi effettivamente presente. La stampa puo essere personalizzata secondo le esigenze, a questa procedura è anche possibile collegare una stampate dedicata per etichette.
Saldaconto fattura
Archivio saldaconto 		Queste procedure sono disponibili solo se è stato installato il modulo "SCF" e permette di inserire i dati di saldaconto fatture
Contabilizza fattura di acquisto | Questa stampa è disponibile solo se è stato installato il modulo di Contabilità ordinaria ("CNT") e permette di registrare la fattura in contabilità. Vengono fatti tutti i controlli necessari alla corretta contabilizzazione ed eventualmente vengono registrate anche le scadenze. Il programma non permette che lo stesso documento venga registrato più volte. Se sono stati fatti errori di registrazione è necessario modificare manualmente il documento, oppure cancellare la registrazione e rifare la contabilizzazione.
Scrittura contabile anticipo da clienti Quando di incassa l'importo di un DDT, è possibile fare una scrittura per annotare l'anticipo da cliente e per poi chiudere il conto di anticipi nel momento della registrazione contabile della fattura.
Per mettere in funzione la procedura è necessario attivare alcuni requisiti:
Si deve inserire nelle preferenze di contabilità il codice della causale usata per la registrazione degli anticipi (solitamente "CA ") ed è necessario che la modalità di pagamento inserita nel DDT per cui si desidera registrare l'anticipo sia di tipo "Pagato".
Se nella causale contabile di anticipi è presente il riferimento al sottoconto dei clienti, nella scrittura viene fatto un giroconto che serve ad evidenziare nelle schede che il cliente ha effettuato l'anticipo.
Dopo aver fatto la scrittura di anticipo, nel DDT viene annotato l'importo anticipato e viene posto un indicatore che serve a segnalare che è stata fatta la scrittura di anticipo.
Quando successivamente si fanno le fatture con la procedura di fatturazione automatica se vengono trovati anticipi in DDT, e la causale di incasso clienti ha il riferimento al conto di anticipi, nella scrittura di incasso viene chiuso in cliente con il conto di anticipi invece della cassa.
Cerca note | Questa procedura cerca nelle righe descrittive dei documenti selezionati il testo richiesto, alla fine viene presentata la lista dei documenti che contengono il testo.
Cerca annotazioni | Questa procedura cerca nelle altre annotazioni delle righe articolo dei documenti selezionati il testo richiesto, alla fine viene presentata la lista dei documenti che contengono il testo. Questa ricerca è utile ad esempio per trovare i lotti descrittivi di rintracciabilità alimenti.
Telefoni e contatti | Nei documenti di clienti e fornitori viene aperta direttamente la lista dei telefoni e contatti, è molto utile per e accedere direttamente senza dover ricercare negli archivi di clienti e fornitori.
Cerca Cliente/Fornitore | Questo comando facilita la ricerca dei documenti di uno specifico cliente o fornitore. Per eseguire ci si posiziona su un documento di clienti o fornitori e si richiama il comando, in risposta si apre la lista specifica che permette fare la ricerca alfabetica. Alla fine viene attivata la ricerca sulla colonna del codice con il codice del cliente o fornitore prescelto.
Stampe etichette | Questa procedura chiama la procedura di stampa etichettee permette di stampare in un colpo solo tutte le etichette degli articoli contenuti in un documento.
Genera ordini a fornitori | Dagli ordini da Cliente, è possibile generare automaticamente i rispettivi ordini a Fornitore. Se i prodotti hanno una Distinta Base di produzione, viene esplosa la distinta e si effettuano gli ordini per i componenti o la materia prima, altrimenti vengono fatti gli ordini per gli articoli ordinati dai clienti. Nel secondo caso, se è stato applicato un rapporto di conversione (ad esempio tra Confezioni e Kg) viene applicato il rapporto di conversione alla quantità ordinata al fornitore.
Chiudi/Apri commessa | Questa procedura è disponibile solo se è stata attivata la gestione delle commesse e solo per i documenti di tipo commessa. Serve per chiudere o riaprire una commessa, questo è utile quando si gestiscono molte commesse poiché le commesse chiuse non vengono visualizzate in fase di ricerca e questo facilita la scelta e diminuisce gli errori. Le commesse possono essere chiuse e riaperte senza problemi perché l'unica cosa che cambia è la presenza di un indicatore e non viene implicata alcuna modifica ai dati.
Stampe documenti articoli | Questa voce è visibile solo se è stata attivata la gestione dei documenti collegati agli articoli nel file AGC.INI. In questo caso, si può in un colpo solo stampare tutti i documenti collegati agli articoli presenti nel documento.
Evasione/Ripristino documento | Questa procedura, disponibile solo in corrispondenza di ordini o di documenti di conto lavoro. Alle volte succede che ci siano ordini che sono stati evasi solo parzialmente ma che non verranno più evasi per la restante parte, con questa voce si può forzare la chiusura, oppure, in modo inverso, se si desidera si possono azzerare tutti i dati di evasione e ripristinare l'ordine in caso di evasioni errate.
Evadibilità ordine | Questa procedura, disponibile solo in corrispondenza di ordini a clienti, permette di verificare se l'ordine è evadibile. Per ogni articolo vengono calcolate la giacenza e le quantità ordinate da clienti ed a fornitori. Alla fine viene presentata una stampa con il dettaglio e l'indicazione se l'ordine è evadibile oppure già evaso.
Residuo evasione ordini | Controlla lo stato di evasione degli ordini evasi dal documento corrente. Legge tutte le righe articolo e per ogni riga che risulta essere l'evasione di un ordine, legge l'ordine e stampa lo stato di evasione indicando le righe dell'ordine che non sono evase. Si può inserire la tolleranza al di sotto della quale la riga viene considerata evasa e si può scegliere se prendere in considerazione le righe con evasione superiore rispetto all'ordine.
Controllo righe evase | Se un documento ha effettuato evasioni ogni riga contiene i riferimenti alla riga evasa, ad esempio un DDT evade un ordine. Con questa procedura è possibile individuare le righe evase e confrontare e modificare le quantità evase.
Spunta documenti | Viene attivata la spunta dei documenti.
Evadi documento Questa procedura è alternativa alla procedura di evasione che viene automaticamente avviata all'interno dei documenti che permettono l'evasione e viene usata quando il documento da evadere viene evaso completamente. È disponibile solo per i tipi do documentoche nel campo libero 3 hanno indicato il tipo documento da generare, un esempio di applicazione è con le fatture pro forma che sono documenti temporanei che vengono emessi in attesa del pagamento da parte del cliente, ad avvenuto pagamento si va sulla fattura pro forma e si lancia questa procedura la quale genera una fattura immediata uguale alla fattura pro forma.
Con questa procedura si possono anche generare automaticamente le fatture differite a partire da un singolo DDT.
Se è stato installato il modulo di commercio elettronico e se nel campo riferimenti esterni è presente la sigla inserita automaticamente dalla procedura di importazione, oltre ad evadere l'ordine viene anche effettuata la notifica di evasione avvenuta. Viene scritto un file di nome "ORDERS.CSV" nella cartella di esportazione del modulo di e-commerce, e quando questi dati vengono trasferiti nel programma ZenCart, viene inviata una notifica al cliente e viene cambiato lo stato dell'ordine.
Rintraccia alimenti | Con questa procedura si esegue la stampa delle rintracciabilità degli alimenti. Se il documento è di carico vengono rintracciati tutti i destinatari a cui è stato ceduto l'alimento, se è un documento di scarico, prima vengono individuati i documenti di carico e quindi tutti i destinatari.
Stato cauzione | Questa opzione è disponibile quando si utilizza il modulo di depositi cauzionali, e permette di cambiare lo stato di generazione di cauzioni e riepiloghi cauzioni.
Stampa bolla di carico | Questa voce è disponibile per i documenti di trasferimento se si utilizzano i moduli di tentata vendita e di gestione depositi, chiama la procedura utilizzata per stampare la bolla di caricoper il deposito su cui è stato effettuato il trasferimento, l'utilizzo di questa procedura presuppone che si utilizzino i depositi per la gestione della giacenza dei mezzi di tentata vendita.
Visualizza righe | Con questa voce si visualizza o si nasconde la visualizzazione delle righe del documento, è utile per vedere in modo veloce il contenuto del documento senza doverci entrare in modifica.


 In questo menù sono contenute alcune interessanti stampe, le voci disponibili sono:

Riepilogo vendite questa è la principale stampa statistica.
Lista ordini inevasi permette di stampare lo stato di evasione degli ordini.
Lista conto lavoro inevaso simile alla precedente serve per la gestione del conto lavoro.
Rintraccia alimenti permette di individuare i clienti a cui è stato venduto un determinato prodotto.
Stampa etichette permette di stampare etichette da attaccare ai prodotti.


Questa è la principale stampa statistica del programma di magazzino, la statistica viene effettuata sui movimenti di scarico, quindi vengono prese in considerazione i DDT e non le Fatture, i dati possono essere raggruppati secondo vari criteri e con le opportune selezioni si possono ricavare virtualmente tutte le informazioni statistiche di cui si può aver bisogno, restano escluse dalle statistiche le righe extramagazzino.

I dati da inserire sono:

Raggruppamento Indicare il tipo di raggruppamento dei dati, le scelte possibili sono:
T | CATEGORIA viene effettuato il raggruppamento per categorie di articoli, questa è una delle scelte più frequenti.
A | ARTICOLO se gli articoli sono pochi si può richiedere la statistica per singolo articolo, se sono tanti questa scelta potrebbe risultare dispersiva.
C | CLIENTE si possono esaminare le vendite raggruppate per cliente.
F | FORNITORE ABITUALE si può controllare l'utile che viene realizzato per ciascun fornitore abituale degli articoli.
Z | ZONA le vendite vengono raggruppate per le zone di appartenenza dei clienti.
P | PROVINCIA raggruppamento per provincia in alternativa alla zona
G | AGENTE raggruppamento delle vendite per l'agente che ha effettuato la vendita.
Data movimento | E' una selezione sulla data del movimento di magazzino.
Articoli | E' una selezione sui codici degli articoli.
Clienti | E' una selezione sui codici dei clienti a cui vengono effettuate le vendite.
Agenti | E' una selezione sugli agenti che effettuano la vendita.
Prezzo unitario | E' una selezione sul prezzo di vendita realizzato, interessante per conoscere gli utili sulle diverse fasce di prezzo.
Deposito | E' una selezione sui depositi, viene proposto il deposito principale.
Ordinamento | Con questa voce si può scegliere il tipo di ordinamento che si desidera. Le scelte possibili sono: Per Codice, Quantità, Costo totale ed Importo totale.
Tipo movimenti | Questa voce disponibile sono se è stata attivata la gestione dello storico permette di scegliere se eseguire la statistica su tutti i movimenti, oppure solo su quelli correnti o solo sui dati storici.
Altre selezioni ariticoli | Permette di selezionare gli articoli secondo vari criteri.
Altre selezioni clienti | Permette di selezionare i clienti secondo vari criteri.
Calcola costo medio | Il costo dei prodotti venduti viene calcolato normalmente utilizzando come riferimento il costo ultimo determinato nel momento della vendita ed in assenza di questo utilizzando il costo ultimo memorizzato nell'articolo. Premendo questo pulsante è possibile scegliere di calcolare il costo facendo una media degli acquisti di un periodo di riferimento. Si inserisce la data iniziale e finale di calcolo, se la data finale è vuota non viene effettuato il calcolo del costo medio.
Stampa dettaglio | Se si desidera si può stampare il dettaglio di vendita per ciascun cliente, nel caso venga richiesto il raggruppamento per cliente, il dettaglio viene fatto per categoria di prodotti.

Alla fine viene effettuata la stampa nella quale compaiono alcuni dati interessanti che illustrano l'utile lordo realizzato.


Questa stampa è simile a qualla che si può ottenere con il riepilogo vendite ma analizza i dati di acquisto invece di quelli di vendita.

I dati da inserire sono:

Raggruppamento Indicare il tipo di raggruppamento dei dati, le scelte possibili sono:
T | CATEGORIA viene effettuato il raggruppamento per categorie di articoli, questa è una delle scelte più frequenti.
A | ARTICOLO se gli articoli sono pochi si può richiedere la statistica per singolo articolo, se sono tanti questa scelta potrebbe risultare dispersiva.
F | FORNITORE si può indicare il fornitori di cui si vuole indagare i costi.
Data movimento | E' una selezione sulla data del movimento di magazzino.
Articoli | E' una selezione sui codici degli articoli.
Fornitore | E' una selezione sui codici dei fornitori da cui sono stati fatti acquisti.
Deposito | E' una selezione sui depositi, viene proposto il deposito principale.
Tipo movimenti | Questa voce disponibile sono se è stata attivata la gestione dello storico permette di scegliere se eseguire la statistica su tutti i movimenti, oppure solo su quelli correnti o solo sui dati storici.
Altre selezioni ariticoli | Permette di selezionare gli articoli secondo vari criteri.
Altre selezioni fornitori | Permette di selezionare i fornitori secondo vari criteri.

Alla fine viene effettuata la stampa.


Questa procedura permette eseguire una utile stampa di tipo statistico.

Vengono prese in considerazione le vendite effettuate per il periodo tra date indicate e vengono suddivise per mese e per anno, quindi vengono stampate secondo l'ordinamento prescelto.

In questo modo si possono fare raffronti di fatturato per i vari anni ed i vari mesi. Oltre a fare la stampa è possibile generare automaticamente un foglio Excel contenente gli stessi dati, questo è comodo per generare automaticamente grafici di andamento.

I dati da inserire sono:

Tipo raggruppamento | Si può scegliere se raggruppare le vendite per Cliente o per Categoria di Articoli.
Tipo ordinamento | I dati possono essere esposti o evidenziando per ciascun gruppo (Cliente o categoria) i dati di ciascun anno, oppure evidenziando per ciascun anno tutte le vendite di ciascun gruppo.
Data inizio e fine | Si inserisce la data iniziale e la data finale di calcolo. Vengono proposti l'anno precedente e quello corrente, ma si possono esaminare anche periodi diversi, la data iniziale parte sempre dal primo del mese e la data finale dall'ultimo del mese.
Agenti | Se le vendite vengono fatte da agenti spesso è utile analizzare le vendite di ciascun agente.
Codice deposito | Questo dato viene chiesto solo se è stata attivato il modulo di multi-deposito.
Altre selezioni ariticoli | Permette di selezionare gli articoli secondo vari criteri.
Altre selezioni clienti | Permette di selezionare i clienti secondo vari criteri.
Export Excel | Se nella macchina è installato Microsoft Excel, si può scegliere di eseguire l'esportazione ad Excel invece di stampare.


Questa procedura serve per stampare il resoconto di una commessa rapida. Le commesse rapide si possono abilitare attivando il parametro "DDF2CTR" nel file di configurazione AGC.INI

Le commesse rapide vengono utilizzate da impiantisti (ad esempio elettricisti o idraulici) che hanno necessità di monitorare in modo semplice e veloce i consumi di materiali e di prestazioni per un lavoro da fare.

Le commesse vengono identificate attraverso un codice che viene inserito nel campo "Riferimenti Cliente" nella gestione dei documenti. L'utilizzo del codice non è obbligatorio, infatti è possibile anche fare resoconti da data a data per ciascun cliente senza utilizzo del codice, ma è utile per rendere chiaramente evidenti le commesse e per facilitare le ricerche.

La codifica delle commesse è interamente a carico del'utente, il programma non controlla la coerenza dei codici e nemmeno eventuali assegnazioni errate a clienti diversi.

Tutte le operazioni sulle commesse avvengono tramite movimenti di magazzino, i materiali vengono scaricati ai clienti ed eventualmente viene recuparato quello che resta. tutte le operazioni vengono valorizzate al costo e poi la fattura viene fatta a corpo secondo quanto convenuto.

Analogamente ai materiali, è opportuno registrare con documenti di scarico anche le ore di lavoro eseguite nel cantiere e questo renderà i consuntivi più veritieri.

La configurazione standard prevede di utilizzare i tipi di docunento CTF per registrare i DDT o le Fatture Immeditate che il fornitore consegna direttamente in cantiere, il tipo di documento CTS per registrare i materiali che noi portiamo in cantiere ed infine il tipo CTR per riportare indietro i materiali rimasti in cantiere dopo aver finito il lavoro.

Spesso accade che il materiale venga consegnato dai fornitori direttamente presso il cantiere del cliente. Dal punto di vista del magazzino, si effettuano movimenti di carico normali nel magazzino con il documento del fornitore e contestualmente si esegue un movimento automatico di scarico presso il cliente con l'apposita procedura presente nella gestione dei documenti. Dal punto di vista del magazzino, risultano un carico ed uno scarico dei materiali con saldo Zero.

Spesso l'impiantista nel proprio furgone trasporta i materiali più utilizzati che in caso di necessità vengono prelevati. Per la gestione delle giacenze di magazzino e per ottenere consuntivi corretti, è opportuno annotare questi consumi e produrre un documento di tipo CTS.

La modalità di gestione cantieri ovviamente non modifica in nessun modo l'operatività standard del programma, qundi per i lavori veloci o per la vendita di materiali che non implica la fatturazione a corpo, si utilizzano i normiali DDT e Fatture immediate o differite.

Questa stampa legge tutti gli scarichi che sono stati fatti presso il cliente e tutti i resi di materiale dal cliente al deposito principale. La differenza tra scarico e carico indica il materiale effettivamente consumato. Ed il confronto con la fatturazione ci permette di stabilire la redditività.

Per la stampa del resoconto i dati da inserire sono:

Da data a data movimenti | Inserire la data inziale e finale dei movimenti da analizzare
Riferimento commessa | Si può inserire il codice della commessa da cercare che è il codice descrittivo che abbiamo inserito nei "Riferimenti esterni" dei Documenti. Se si preme il pulsante collegato, viene cercato il codice e se viene trovato vengono assegnati automaticamente la data iniziale ed il codice del cliente
Codice cliente | E' il codice del cliente a cui appartiene la commessa. Se non si inserisce il codice della commessa vengono considerati tutti i movimenti del cliente nel intervallo di date inserito.
Elenco movimenti | Si può stampare l'elenco dei movimenti implicati, i movimento possono essere ordinati per codice articolo o per data di movimentazione.
Stampa documenti | Si può stampare la lista dei documenti implicati, si possono stampare solo i totali, oppure anche i movimenti contenuti in ciascun documento.
Riepilogo articoli | Se si desidera si può stampare il riepilogo per articolo dei movimenti effettuati.

Alla fine viene effettuata la stampa che evidenzia tutti i costi sostenuti, in modo da stabilire la redditività della commessa.

In alternativa a questa modalità operativa, Zefiro dispone del modulo di gestione commesse che però è molto più articolato ed in alcune situazioni potrebbe essere eccessivo rispetto alle necessità.


Con questa stampa si può tenere sotto controllo la situazione degli ordini, viene stampata la lista utilizzando diversi formati e si possono realizzare varie selezioni.

I dati da inserire sono:

Tipo ordinamento | Si può scegliere di ordinare la stampa per data documento, per codice articolo o per data di consegna.
Tipo anagrafica | Si può stampare gli ordini dei Clienti o dei Fornitori, premendo il pulsante collegato si apre la lista di scelte.
Tipo ordinamento documenti | Se si sceglie di ordinare la stampa per documento, si può scegliere di ordinare i documenti trovati secondo vari criteri.
Stampa dettagliata | La stampa dettagliata contiene oltre alla riga dell'ordine anche la lista dei DDT che la hanno evasa. Questa voce è disponibile solo nell'ordinamento per documento.
Anche descrittive | Nel caso della stampa ordinata per documento, è possibile stampare anche le righe descrittive.
Anche righe evase | Con questa opzione si indica se si desidera includere o escludere le righe totalmente evase.
Riepilogo | Questa opzione è disponibile solo per la stampa ordinata per articolo e serve per indicare se si desidera stampare la lista di tutte le righe degli articoli o solo il totale per ciascun articolo.
Clienti/Fornitori | E' una selezione sui codici dei clienti o dei fornitori
Data movimento | E' una selezione sulla data di movimento degli ordini
Data consegna | E' una selezione sulla data di consegna prevista degli ordini
Articoli | E' una selezione sugli articoli presenti negli ordini.
Deposito | E' una selezione sui depositi, viene proposto il deposito principale.

Alla fine viene effettuata la stampa, il tracciato cambia a seconda del tipo di ordinamento scelto.


Questa stampa è molto simile alla stampa degli ordini inevasi. Ma invece di stampare i dati degli ordini stampa i dati del conto lavoro inevaso.


Questa stampa è simile alla stampa della Lista ordini inevasi infatti da gli stessi risultati a parità di parametri di ricerca.

La differenza sta nel fatto che in questa stampa si esegue il raggruppamento dei dati secondo alcuni parametri.

I dati da inserire sono:

Tipo evasione | Si può scegliere se leggere gli ordini oppure il conto lavoro.
Tipo anagrafica | Si possono esaminare i dati di Clienti o di fornitori
Tipo ordinamento | I dati possono essere raggruppati secondo uno dei tre criteri disponibili Nel raggruppamento per cliente vengono elencati tutti documenti dei clienti. Nel raggruppamento per data consegna vengono evidenziati tutti gli articoli da consegnare per ciascuna data. Infine nel raggruppamento per articolo vengono evidenziate tutte le dati di consegna di ciascun articolo.
Selezioni | Si possono selezionare i documenti da esaminare secondo vari parametri.

Alla fine viene effettuata la stampa secondo i criteri selezionati.


Questa procedura produce una stampa utile per la gestione finanziaria.

Leggento i dati agli acquisti effettuati, e quindi ai carichi di magazzino da fornitore, stima gli importi che dovranno essere pagati e le date di scadenza di tali importi sulla base della modalità di pagamento abituale stabilita con i fornitori.

In questo modo si possono pianificare gli acquisti tenendo sotto controllo le esposizioni finanziarie previste per tali acquisti.

I dati da inserire sono:

Data inizio calcolo | É la data da cui parte la lettura dei documenti di carico, viene proposta una data a ritroso di 4 mesi che spesso è sufficiente per leggere tutti i documenti che devono ancora scadere, ma se abbiamo con i fornitori scadenze più lunghe si può inserire una data antecedente.
Data inizio scadenze | Viene proposta la data di inizio del mese in corso, tutte le scadenze antecedenti a questa data vengono escluse perché normalmente già pagate.
Ordinamento per fornitore | Esistono due ordinamenti possibili: per data e per fornitore, di norma viene eseguito l'ordinamento per data che ci dice a ciascuna data quali sono gli importi da pagare, è però possibile scegliere l'ordinamento per fornitore che ci da gli importi che vanno a scadere per ciascun fornitore.
Codice fornitore | Si può scegliere di stampare i dati di un singolo fornitore, lasciando il valore a zero, vengono letti i dati di tutti i fornitori.
Anche documenti senza prezzo | Se viene spuntata questa opzione, vengono stampate anche le scadenze dei documenti a cui non sono stati inseriti i prezzi. Altrimenti queste scadenze vengono omesse.

Alla fine viene eseguita la stampa che porta i dati calcolati con l'ordine prescelto con subtotali per data o fornitore e totali finali.


Le fattue elettroniche sono in formato XML che è efficiente da elaborare per i computers, ma faticoso da leggere per gli umani.

Questa procedura trasforma una fattura elettronica in una pagina web facilmente leggibile e stampabile. Il formato di visualizzazione, dipende da un foglio di stile che si occupa della impaginazione.

Attualmente vengono messi a disposizione il formato ministeriale proposto da Agenzia delle Entrate ed il formato realizzato da AssoSoftware

Si sceglie il file e si indica il formato richiesto, ed alla fine viene aperta la pagina web con la fattura che può essere visualizzata e stampata.


Questa procedura esegue il controllo formale delle fatture elettroniche. Usa la stessa tecnologia usata dai portali di Fattura Elettronica e dal Sistema di Interscambio.

In caso di errori viene lanciata una stampa che elenca gli errori riscontrati usando la terminologia tecnica del sistema di verifica, ma facilita la ricerca per la correzione degli errori.


Questo menù contiene voci che vengono usate saltuariamente e che eseguono elaborazioni sui dati inseriti.


Questa procedura serve per generare e stampare le fatture dei DDT di vendita inseriti e non ancora fatturati, oltre ai DDT si possono fatturare altri documenti con la stessa funzionalità come ad esempio Rapporti di lavorazione e Ricevute fiscali.

La circolare della Agenzia delle Entrate 14/2019 impone che le fatture differite espongano come data documento la data del ultimo DDT emesso per ciascun cliente, in contrasto con la prassi consolidata in precedenza con cui si metteva la data di fine mese indipendentemente dalla data dei DDT. Zefiro permette di agire in entrambe i modi attivando una spunta specifica.

I dati da inserire sono:

Tipo documento | Inserire il tipo di documento per le fatture generate, vengono accettati solo i tipi di documenti validi. Premendo il pulsante collegato si apre la lista dei Tipi di documento compatibili.
Deposito | Questo dato viene chiesto solo se è presente il modulo di gestione multideposito e permette di indicare il deposito in cui vengono registrati i documenti emessi, se al deposito è stato assegnato un numero di registro specifico, lo stesso viene riportato automaticamente nel campo corrispondente.
Data fattura | Inserire la data che avranno i documenti generati. Se si sceglie di assegnare come data la data del ultimo DDT, si può lascare vuoto questo campo ed i documenti avranno come data di registrazione la stessa data del documento.
Registri | Questa opzione viene chiesta solo se sono stati abilitati i registri multipli, si inserisce il codice di registro dei documenti generati ed il codice registro dei documenti generanti, se non si inserisce questo secondo codice verranno raggruppati i DDT di tutti i registri.
DDT da Data | Vengono presi in considerazione i DDT a partire da questa data.
Fino a Data | Vengono presi in considerazione i DDT fino a questa data.
Codice cliente | Si può scegliere di stampare le fatture per un solo cliente oppure per tutti. Premendo il pulsante collegato si apre la lista dei Clienti
Causale | Si può scegliere di includere solo i DDT con una certa causale del trasporto oppure tutti i DDT fatturabili.
Scegli clienti da fatturare | Se si spunta questa casella, prima di iniziare la stampa viene presentata la lista dei clienti per i quali sono stati trovati DDT da fatturare. In questa lista si può decidere quali clienti fatturare subito e quali in un secondo momento, e anche l'ordine in cui verranno fatturati. Nella lista dei clienti da fatturare per ciascuno vengono indicati il numero di DDT, il totale da fatturare e un indicatore ce ci sono promemoria per il cliente. Se si desidera si può anche scegliere quali DDT fatturare e quali lasciare per un secondo momento. Questo è particolarmente utile quando il cliente richiede fatture diverse per diversi documenti ad esempio può accadere che richieda fatture separate per ciascuna destinazione diversa oppure per separare le fatture di merce e di prestazione di servizi. Se un cliente ha un promemoria, facendo click sui comandi speciali c'è un'opzione per visualizzare il promemoria.
Invio tramite e-mail | Con l'avvento della fattura elettronica tra privati, decade l'obbligo di stampare le fatture e di spedirle ai clienti, però può essere utile stampare una copia ad uso interno (ad esempio per allegare i DDT emessi) e può essere gradito l'invio di una copia di cortesia ai clienti. Si deve anche tener conto del fatto che per i clienti privati, gli esteri ed alcune categorie di titolari di partita IVA, non c'è obbligo di Fattura Elettronica e quindi il documento cartaceo è ancora in vigore. Questa opzione è disponibile solo se è stata correttamente configurata la gestione dell'invio di documenti tramite e-mail. Se è spuntata, quando vengono stampate le fatture, il programma riconosce quali sono il clienti abilitati ai documenti in formato PDF ed al loro stampa una copia in meno delle fatture dato che a essi non viene spedita la copia cartacea.
Applica data ultimo DDT | Come prescritto dalla Circolare 14/2019 della Agenzia delle Entrate, Le fatture devono riportare la data dell'ultimo DDT emesso per ciascun cliente. Con questa spunta si fa in modo di gestire la datazione corretta. Se si toglie, si utilizza la modalità precedente che prevedeva la datazione delle fatture a fine mese.
Comunicazioni alla clientela | Premendo il pulsante si apre una finestra in qui si può inserire una nota che verrà riportata alla fine di tutte le fatture. Può essere utilizzata per esempio per comunicare la chiusura per ferie, gli auguri natalizi o comunicazioni di tipo fiscale.
Tracciato stampa | Viene proposto il tracciato presente nel tipo documento.
Copie | Viene proposto il numero di copie presente nel tipo documento.
Riepilogo righe articoli | Si può decidere di raggruppare in stampa le righe dello stesso articolo, nel documento comunque le righe non risulteranno raggruppate.
Numero massimo di fatture | Se si inserisce un valore diverso da zero viene generato solo il numero di fatture indicato, altrimenti vengono generate tutte le fatture trovate. Questa funzionalità è utile per generare solo un numero limitato di fatture per facilitare controlli, eseguire contabilizzazioni parziali o altro.

Alla fine vengono generate le fatture, vengono aggiornati gli indicatori di fatturazione dei DDT coinvolti e d infine vengono stampate le fatture, le fatture possono anche essere modificate e ristampate in seguito.

Con la versione 1.6 delle specifiche per le fatture elettroniche le fatture differite devono avere avere il codice tipo documento "TD24", se non viene assegnato un codice specifico nel tipo di documento assegnato, viene messo automaticamente il codice previsto dalle specifiche.

In ogni singola fattura il cui imponibile supera l'importo minimo previsto per il cliente, viene automaticamente inserita la modalità di pagamento alternativa.

Se il cliente è un ente pubblico, la fattura viene assegnata automaticamente al registro iva dedicato alle fatture nei confronti delle PA.

Nota

Zefiro è in grado di gestire le problematiche connesse alla legislazione che riguarda le merci deperibili di cui alla legge n.27 del 24/03/12.

Chi è soggetto a tale legislazione deve attivare il parametro di configurazione presente nel file di configurazione AGC.INI e poi deve indicare nel campo degli articoli appositamente configurato i giorni di scadenza per ciascun prodotto. Se questo valore rientra nei parametri previsti per legge (60 giorni), viene considerato deperibile e dovrà essere fatturato a parte qualora la modalità di pagamento applicata al cliente preveda più di 30 giorni di scadenza.

Prima di effettuare fatturazione automatica il programma chiede se si desidera fatturare i prodotti deperibili o gli altri. Se scelgono i deperibili vengono letti tutti i DDT e vengono inclusi nelle fatture solo gli articoli deperibili se il pagamento abituale supera i 30 giorni e viene forzata la modalità di pagamento alternativa. Questa prima fattura NON modifica il marcatore di fattura eseguita nei DDT e perciò si deve fare attenzione ad effettuarla una ed una sola volta.

Dopo aver emesso le fatture dei prodotti deperibili si può fare la fatturazione degli altri prodotti (Scegliendo la voce "Altri" alla richiesta). Con questa modalità verranno fatturati tutti i prodotti non deperibili oppure i deperibili se la modalità di pagamento non supera i 30 giorni. Questa operazione esegue anche l'aggiornamento del indicatore di fatturazione eseguita.

Esiste anche una terza modalità operativa che consente di eseguire la fatturazione nel modo tradizionale e si attiva scegliendo "Tutti", ma in regime di merce deperibile non dovrebbe essere usata.

Nota

Alle volte accade che si eseguano fatturazioni automatiche errate, se le modifiche da fare sono di modesta entità, si possono modificare manualmente le fatture differite ed in automatico verranno modificati anche i DDT che le hanno generate. Se invece le modifiche sono corposte, il programma Zefiro permette di recedere dalla fatturazione automatica attraverso i seguenti passi:

  1. Si cancellano le fatture generate nell'archivio dei documenti
  2. Si rimettono a fatturabili i DDT del periodo con la procedura di fatturabilità documento.
  3. Si riporta indietro il numeratore delle fatture al numero precedente alla prima fattura sbagliata.
Ovviamente è preferibile fare queste operazioni prima della contabilizzazione delle fatture, altrimenti sarà necessario recedere anche da questo.


Con questa procedura vengono registrate in contabilità le fatture inserite con la gestione documenti o con la fatturazione automatica, durante la contabilizzazione vengono anche generate le scadenze ed in caso di arrotondamenti o acconti o pagamento effettuato vengono direttamente eseguite le scritture di incasso.

I dati da inserire sono:

Causale contabile fatture di vendita | È possibile scegliere la causale contabile delle registrazioni contabili, vengono accettate solo causali compatibili con le fatture di vendita.
Causale contabile note di accretido | È possibile scegliere la causale contabile delle registrazioni contabili, vengono accettate solo causali compatibili con le note di accredito.
Fino a data | Inserire la data limite per la contabilizzazione dei documenti.
Data movimenti | Si può inserire la data di registrazione contabile dei documenti, se si lascia in bianco questo campo viene effettuata la registrazione alla data del documento.
Registri IVA | Se è stata abilitata la gestione del multiregistro, compare questo campo che permette di scegliere i registri da fatturare, vengono proposti tutti i disponibili e si possono togliere quelli che si desidera fatturare in un secondo momento.

Alla fine vengono effettuate le scritture contabili di documento e di incasso se le fatture risultano incassate o se ci sono acconti, e vengono generate le scadenze per le fatture non incassate.

In fase di contabilizzazione nelle fatture appartenenti al registro delle Fatture PA viene eseguito lo storno del debito della parte IVA, come previsto della norma dello "Split payment" e di conseguenza viene generata la scadenza solo per la parte imponibile.


Questa procedura permette di preparare le fatture elettroniche da spedire al "Sistema di Interscambio" per maggiori dettagli consultare la guida completa

Esistono due modalità per preparare le fatture elettroniche, si possono preparate tutte le fatture non ancora spedite fino ad una certa data, oppure si può spedire o rispedire una singola fattura.

Il sistema in fase di spedizione assegna ad ogni fattura o nota d'accredito un numero univoco di spedizione che viene utilizzato per calcolare il nome del file da spedire, questo codice viene utilizzato dal programma per capire se il documento è già stato spedito per evitare codici duplicati.

Spesso gli intermediari utilizzati per l'invio a SdI, quando importano i files xml da inviare al sistema di interscambio, aggiungono al testo informazioni proprie e sostituiscono i nomi con propri numeratori univoci, quindi la denominazione deve essere considerata soprattutto una informazione interna.

La procedura per la spedizione cumulativa delle fatture chiede i seguenti dati:

Da data fattura | Propone il primo gennaio dell'anno corrente.
A data fattura | Propone la data corrente.
Anche già preparate | Chiede se si desidera proporre solo le fatture mai preparate oppure anche quelle preparate in precedenza comprese tra le date indicate. Solitamente non serve mettere la spunta su questa opzione ed in tal modo verranno proposte solo le fatture non ancora presentate. E' necessario mettere la spunta solo se si deve rifare la preparazione di una serie di documenti che sono stati preparati in precedenza ma non spediti.
Validazione documenti | Se si spunta questa opzione, dopo aver preparato i files da spedire viene lanciata una procedura che esegue la validazione formale ed in caso di errori lancia una stampa con la lista dei problemi riscontrati. In questo modo risulta più facile fare le opportune correzioni prima della spedizione.
Allega fattura pdf | Se si spunta questa opzione, prima di inviare ongi singola fattura viene fatta la stampa del documento di cortesia in formato PDF e viene inserito come allegato all'interno della fattura elettronica.

Dopo aver dato conferma si presenta la lista delle fatture e delle note di accredito comprese nei parametri di ricerca.

Per ciascun documento vengono presentati data, numero e registro e se presente il numero di invio precedente. Vengono anche presentati la Ragione sociale del cliente e gli estremi di spedizione in modo da evitare di spedire documenti in caso di dati incompleti.

Viene anche indicato il tipo di cliente, che può essere "Normale" e quindi obbligato alla fattura elettronica, oppure "Estero" se il cliente non ha il prefisso "IT" per la partita IVA, "Privato" se ha il codice fiscale ma non la partita IVA, o infine "Esente" se appartiene ad una categoria esentata come ad esempio i Forfettari. Per indicare che il cliente è esente, nel codice di interscambio si devono inserire sette zeri "0000000", in tutti gli altri casi si inserisce il codice corretto oppure si lascia in bianco e Zefiro sarà in grado di inserire il codice corretto in base alla tipologia.

Per ciascuna riga si possono inserire i seguenti dati:

Tipo di documento | E' il codice del tipo di documento previsto dal formato della fattura elettronica a partire dalla versione 1.6 delle specifiche. Si può scegliere il codice appropriato, oppure lasciando in bianco viene calcolato il codice corretto secondo alcuni parametri automatici. Nei Tipi di documento si possono memorizzare i codici predefiniti da assegnare a ciascun documento ma è un dato che si può forzare. La fatturazione automatica in mancanza di un codice specifico assegna automaticamente il codice TD24.
Esclusione riferimenti DDT | Con questa opzione è possibile esludere dal documento elettronico i riferimenti ai DDT, di solito si fa su richiesta dei clienti. Si consideri inoltre che è possibile forzare l'esclusione automatica di alcuni tipi di documento con l'apposito parametro nel file di configurazione AGC.ini, ad esempio si può desiderare di includere i riferimenti ai DDT ma non ai Rapporti di lavorazione.
Sostituire il precedente invio | Questa voce compare solo se al documento è già stato assegnato un codice univoco di spedizione e quindi risulta già spedito in precedenza. Spuntando l'opzione viene assegnato un nuovo codice univoco in modo da tornare ad inviare documenti respinti dal destinatario.
Inserisci allegato | Per ciascuna fattura da spedire è possibile inserire un ulteriore allegato, ad esempio si potrebbe inserire la lista dei DDT, oppure preventivi o conferme d'ordine. L'allegato può essere solo uno, perciò se si ha necessità di spedire più documenti contemporaneamente, consigliamo di inserirli tutti in un unico file compresso.

A questo punto si possono spuntare i documenti che si desidera preparare ed alla fine premendo il pulsante di conferma si procede alla preparazione di tutti i documenti ed alla fine viene chiesto se si desidera procedere alla spedizione automatica utilizzando la procedura scelta in fase di configurazione.

Oltre alla spedizione cumulativa di più documenti, si può spedire o rispedire anche una fattura o una nota di accredito, per fare questo si va nella lista dei documenti e posizionando il cursore sulla riga del documento da spedire si attiva il comando speciale per produrre la fattura elettronica

I dati richiesti sono:

Tipo di documento | E' il codice del tipo di documento previsto dal formato della fattura elettronica a partire dalla versione 1.6 delle specifiche. Si può scegliere il codice appropriato, oppure lasciando in bianco viene calcolato il codice corretto secondo alcuni parametri automatici. Nei Tipi di documento si possono memorizzare i codici predefiniti da assegnare a ciascun documento ma è un dato che si può forzare. La fatturazione automatica in mancanza di un codice specifico assegna automaticamente il codice TD24.
Validazione documento | Se si spunta questa opzione, dopo aver preparato il file da spedire viene lanciata una procedura che esegue la validazione formale ed in caso di errori lancia una stampa con la lista dei problemi riscontrati. In questo modo risulta più facile fare le opportune correzioni prima della spedizione.
Esclusione riferimenti DDT | Con questa opzione è possibile esludere dal documento elettronico i riferimenti ai DDT, di solito si fa su richiesta dei clienti.
Sostituire il precedente invio | Questa voce compare solo se al documento è già stato assegnato un codice univoco di spedizione e quindi risulta già spedito in precedenza. Spuntando l'opzione viene assegnato un nuovo codice univoco in modo da tornare ad inviare documenti respinti dal destinatario.
Inserisci allegato | Per ciascuna fattura da spedire è possibile inserire un ulteriore allegato, ad esempio si potrebbe inserire la lista dei DDT, oppure preventivi o conferme d'ordine. L'allegato può essere solo uno, perciò se si ha necessità di spedire più documenti contemporaneamente, consigliamo di inserirli tutti in un unico file compresso.

Alla fine viene chiesto se si desidera procedere alla spedizione automatica utilizzando la procedura scelta in fase di configurazione.


Questa procedura permette di inviare automaticamente tutte le fatture dei clienti che sono stati configurati per l'invio automatico, ed è disponibile solo se è stata fatta l'opportuna configurazione.

Dal 01/01/2019 è entrato in vigore l'obbligo di fatturazione elettronica tra privati, pertano i documenti cartacei o in formato PDF non hanno alcun valore legale e quindi vanno considerati come semplici documenti di cortesia, con l'eccezione delle fatture emesse nei confronti di soggetti esentati come ad esempio i privati non titolari di partita IVA.

CONFIGURAZIONE DELLA SPEDIZIONE TRAMITE E-MAIL

Per poter spedire documenti tramite e-mail devono essere rispettati alcuni requisiti:

  • Disponibilità di una connessione internet
    Ovviamente per spedire documenti tramite e-mail è necessario essere collegati ad internet, almeno nel momento in cui si desidera effettuare la spedizione.
  • Installazione del driver di stampa PDF
    Per la generazione dei PDF ci appoggiamo al programma gratuito BullZip PDF Printer che deve essere installato nella macchina da cui si vogliono inviare i documenti.
  • Disponibilità di uno o più server SMTP
    Spesso i fornitori di connettività internet offrono la possibilità di inviare la posta elettronica tramite programmi come MS Outlook o Mozilla Thunderbird, ma non sempre questo accade, ad esempio chi accede ad internet tramite chiavette GSM spesso non ha questa possibilità e può leggere ed inviare posta solo tramite web.
    Per poter mandare e-mail da Zefiro è necessario che il provider renda disponibili i dati di configurazione SMTP che sono quelli utilizzati dai programmi citati. E' anche possibile configurare il programma per utilizzare più di un server di spedizione, in questo caso sarà possibile scegliere di volta in volta il server da usare, questo è utile ad esempio per inviare alcuni documenti tramite PEC ed altri in modo normale.
  • Configurazione del tracciato di stampa grafico
    Quando si stampa un documento si può scegliere mettere la spunta su "Cambia intestazione", questo permette di scegliere una intestazione alternativa per il documento, di solito questa intestazione contiene un logo grafico ed è destinata alla stampa su carta bianca. L'invio dei documenti tramite e-mail utilizza questa intestazione.

Una volta soddisfatti i requisiti, si devono inserire dati SMTP in un file di di configurazione di nome SENDMAIL.INI nella cartella del programma Zefiro ed i dati di configurazione dei percorsi PDF nel file di configurazione AGC.INI sempre nella cartella di Zefiro. Per maggiori dettagli consultare il personale tecnico della Compusoft.

Quando tutto è a posto da questo menù si accede alla procedura di invio e-mail.

MODALTITÀ OPERATIVA PER L'INVIO DELLE FATTURE TRAMITE E-MAIL

Essendo le fatture documenti fiscali, è bene concordare con i clienti questo tipo di spedizione per evitare perdite di documenti dovuti a fraintendimenti. Si consiglia quindi di contattare i clienti e chiedere se e su quale indirizzo e-mail desiderano ricevere le fatture, ed inserirlo nei dati anagrafici.

Quando si fanno le fatture differite (solitamente ogni mese oppure ogni 15 giorni), la procedura di fatturazione automatica riconosce i clienti che hanno richiesto questo servizio ed automaticamente stampa una copia cartacea in meno.

Dopo aver generato e stampato le fatture è buona norma effettuare un controllo finale prima di procedere alla loro spedizione. Se non ci sono problemi si può passare all'imbustamento delle fatture cartacee da spedire, e si può lanciare questa procedura che si occupa della spedizione automatica delle fatture elettroniche previste.

I dati da inserire sono:

Tipo documento | Solitamente il tipo di documento è FV, ma eventualmente se ne può scegliere un altro.
Tracciato stampa | Viene proposto il tracciato presente nel tipo documento delle fatture differite, ma si può cambiare.
Data documenti | Inserire la data dei documenti da inviare.
Da numero fattura a numero fattura | Si può scegliere di inviare solo un numero limitato di fatture per volta per evitare che l'invio sia riconosciuto come spam dal server smtp.
Ricevuta di ritorno | Se si mette questa spunta, si richiede la notifica da parte del destinatario di avvenuta ricezione del messaggio.
Testo aggiuntivo | Si può inserire un testo da aggiungere a quello standard del messaggio.
Invia con | Si può scegliere il server da utilizzare per la spedizione dei documenti.
Mittente | Si può scegliere un mittente diverso da quello abituale.

La procedura è totalmente automatica, vengono cercati tra i documenti del tipo indicato generati nella data indicata quelli relativi a clienti che hanno la e-mail per l'invio automatico e quelli trovati vengono inviati immediatamente.


Zefiro, se opportunamente configurato può esportare i documenti di magazzino in formato pdf in un sito web.

La configurazione consiste nel inserire un file di nome QUICKDIR.INI nella cartella del programma Zefiro (di solito C:\CS\AGC). E' anche necessario che Zefiro sia configurato per la spedizione dei documenti tramite e-mail poiché si usa la stessa procedura per stampare automaticamente i documenti in PDF.

L'invio viene fatto utilizzando il protocollo FTP, quindi è necessario avere le credenziali FTP del sito a cui si desidera inviare i dati, si deve anche scaricare da internet il programma WinSCP che viene usato per automatizzare le operazioni di invio.

Nel file INI di configurazione si devono inserire i parametri di accesso tramite FTP, i tipi di documento esportabili e la lista dei clienti e fornitori che sono abilitati all'invio.

Il sito web che ospiterà i dati dovrà ovviamente essere abilitato alla visualizzazione degli stessi personalizzata per ogni cliente/fornitore, per questo motivo abbiamo sviluppato alcuni plugin per i più diffusi gestori di contenuti tra cui Joomla! e WordPress con cui è possibile gestire siti abilitati a questa funzionalità.

Per abilitare i clienti/fornitori a scaricare i propri documenti si dovrà inserirli come utenti del sito e fornirgli codice utente e password. Quindi si dovrà inserire nel file di configurazione QUICKDIR.INI il codice che hanno in Zefiro con il corrispondente codice Joomla, in questo modo al prossimo invio di dati, i loro documenti saranno inclusi nella spedizione.

Quando tutto è configurato correttamente, si può procedere periodicamente ad inviare i dati utilizzando questa procedura.

I dati richiesti sono:

Data inizio | Inserire la data di partenza, viene proposto l'inizio del mese precedente a quello corrente.
Data fine | Inserire la data finale, viene proposta la fine del mese precedente a quello corrente.
Tipo documento | Se si desidera si può limitare l'esportazione ad un solo tipo di documento.
Confermi esportazione | Per proseguire si deve spuntare la conferma.

Dopo aver confermato, vengono presi in esame tutti i documenti di magazzino del periodo indicato e se il tipo di documento è tra quelli previsti per la spedizione ed il cliente/fornitore è abilitato, viene effettuata la stampa in PDF e viene inviato al sito FTP.

Il tracciato di stampa utilizzato per il documento è quello previsto dal tipo di documento, però se per il cliente o fornitore è stato scelto un tracciato diverso, verrà utilizzato quello preferito.

Eventuali documenti già presenti vengono sovrascritti.

La procedura di invio è disponibile anche per ogni singolo cliente o fornitore ed anche per singoli documenti. Quindi in caso di necessità si possono fare spedizioni maggiormente mirate invece di rispedire tutto.


Zefiro, se opportunamente configurato può condividere i documenti di magazzino in formato pdf con i clienti e/o fornitori mediante servizi cloud come DrpoBox, Google Drive oppure Nextcloud

Solitamente questi servizi richiedono la registrazione e poi installando nei propri PC e SmartPhones appositi programmi, consentono di mantenere sincronizzate alcune cartelle locali con i dati presenti su internet.

E' anche possibile fornire a terzi la condivisione di alcune aree ristrette e quindi i documenti che depositiamo nelle nostre cartelle condivise saranno accessibili anche a coloro con cui sono state condivise.

Il sistema funziona su tutti i sistemi cloud che usano questa tecnica, ma il sistema preferenziale usato da noi è Nextcloud, che rispetto agli altri ha il vantaggio di essere gratuito ed OpenSource per qualsiasi dimensione di dati e maggiormente rispettoso della privacy. Per contro per poterlo installare è necessario avere uno spazio internet in cui installare il servizio e lo spazio sufficiente per memorizzare tutti i dati.

La configurazione di Zefiro per utilizzare questo servizio consiste nel inserire un file di nome DOCCLOUD.INI nella cartella del programma Zefiro (di solito C:\CS\AGC). E' anche necessario che Zefiro sia configurato per la spedizione dei documenti tramite e-mail poiché si usa la stessa procedura per stampare automaticamente i documenti in PDF.

Nel file di configurazione si inseriscono i dettagli dei tipi di documento da condividere ed anche la lista dei clienti/fornitori abilitati. La documentazione sui parametri di condigurazione sono contenuti nel file OWNCLOUD.INI di esempio fornito.

Oltre alla configurazione locale, sarà necessario effettuare la configurazione del cloud assegnando a ciascun destinatario le credenziali di accesso e la specifica area in cui potrà trovare i propri documenti. E' consigliabile fornire l'accesso a sola lettura per le aree che contengono i documenti, in questo modo saranno sempre disponibili. Se si desidera si può anche assegnare a ciascun cliente o fornitore dello spazio aggiuntivo in cui depositare comunicazioni, infine è possibile limitare lo spazio messo a disposizione in modo da evitare eccessivi consumi di spazio e banda.

L'invio quindi consiste semplicemente nel salvare nelle cartelle condivise tutti i documenti predisposti per la condivisione, e questo sarà sufficiente perché il sistema propaghi tutti i documenti ai rispettivi destinatari.

Quando tutto è configurato correttamente, si può procedere periodicamente ad inviare i dati utilizzando questa procedura.

I dati richiesti sono:

Data inizio | Inserire la data di partenza, viene proposto l'inizio del mese precedente a quello corrente.
Data fine | Inserire la data finale, viene proposta la fine del mese precedente a quello corrente.
Tipo documento | Se si desidera si può limitare l'esportazione ad un solo tipo di documento.
Confermi esportazione | Per proseguire si deve spuntare la conferma.

Dopo aver confermato, vengono presi in esame tutti i documenti di magazzino del periodo indicato e se il tipo di documento è tra quelli previsti per la spedizione ed il cliente/fornitore è abilitato, viene effettuata la stampa in PDF ed il file viene depositato nella cartella di condivisione.

Il tracciato di stampa utilizzato per il documento è quello previsto dal tipo di documento, però se per il cliente o fornitore è stato scelto un tracciato diverso, verrà utilizzato quello preferito.

Eventuali documenti già presenti vengono sovrascritti.

La procedura di invio è disponibile anche per ogni singolo cliente o fornitore ed anche per singoli documenti. Quindi in caso di necessità si possono fare spedizioni maggiormente mirate invece di rispedire tutto.


Il riepilogo delle cessioni Intrastat permette di stampare un prospetto che può essere copiato sui moduli previsti dal Ministero delle Finanze.

I dettagli su chi sono i soggetti obbligati, sulla modulistica e sulla periodicità possono essere trovati sul sito internet della agenzia delle dogane.

Vengono richieste la data iniziale e finale del periodo da calcolare, il periodo dipende dal volume di affari sviluppato o previsto, può essere a cadenza mensile, trimestrale o annuale.

Il calcolo viene fatto nel modo seguente:

Vengono prese in considerazione tutte le fatture emesse nel periodo preso in considerazione destinate a clienti dei paesi CE esclusi gli italiani. I clienti Ce vengono riconosciuti dal prefisso della partita IVA che deve corrispondere con il codice ISO delle nazioni CE.

Per ogni documento trovato vengono trovati i codici della nomenclatura combinata degli articoli. Il codice viene prima cercato negli articoli, se nell'articolo specifico non è stato specificato alcun codice, la ricerca viene continuata nella categoria di appartenenza, infine se anche nella categoria non è stato dichiarato il codice, significa che l'articolo appartiene ai prodotti che per loro natura sono esclusi dalla normativa.

Le righe extramagazzino dei documenti dovrebbero essere normalmente destinate esclusivamente a merci per natura escluse. Però se si vendono prodotti di categoria uniforme e si desidera comunque utilizzare le righe extramagazzino, si può dichiarare un codice nelle preferenze di magazzino. In alternativa se si desidera descrivere la natura dei beni di volta in volta, conviene utilizzare righe di tipo articolo con codici generici e poi modificare la descrizione.

Dopo aver trovato i dati che devono essere inclusi nel prospetto, viene effettuata la stampa che riporta gli importi per ogni partita IVA e per ogni codice di nomenclatura, viene anche riportato il progressivo degli importi per facilitare la copiatura sui moduli ministeriali.

Nella stampa vengono evidenziate a parte le righe che si riferiscono a prodotti di cui non è stata trovata la nomenclatura Intrastat, in modo da poter verificare se si tratta di un errore o di prodotti normalmente esclusi. Sempre per motivi di controllo, viene esposta anche la ragione sociale dei clienti.

Nel prospetto è presente anche la colonna della massa netta che è un dato richiesto nei moduli intrastat. Il calcolo della massa può variare di molto in base alla tipologia di prodotto, ed alle volte potrebbe anche essere impossibile da calcolare, per questo motivo questa colonna viene lasciata a zero, ma su richiesta è possibile sviluppare personalizzazioni che effettuino il calcolo automaticamente.


 Alle volte succede che i prezzi per le merci vendute vengano concordati dopo che sono stati emessi alcuni DDT non ancora fatturati e che tali prezzo abbiano valore retroattivo. In questi casi è utile una procedura che esamini le bolle non ancora fatturate ed aggiorni i prezzi. Il pericolo di tale procedura è quello di andare a modificare prezzi che non si dovrebbero modificare perciò si deve fare attenzione ad evitare modifiche non desiderate.

I dati da inserire sono:
Clienti | E' una selezione sui codici dei clienti, si può scegliere di applicare la prezzatura a tutti i clienti o solo ad alcuni.
Data movimento | E' una selezione sulla data del movimento, vengono proposte le date dall'inizio alla fine del mese in corso.
Codici Articoli | Con questa selezione si possono prezzare solo alcuni articoli.
Confermi prezzatura | Per poter eseguire la prezzatura, si deve confermare la richiesta.
Registri | Questa opzione viene chiesta solo se sono stati abilitati i registri multipli, si inserisce i codici di registro dei DDT da prezzare. Se non si inserisce nessun registro vengono prezzati tutti.

Alla fine viene eseguita la prezzatura dei DDT che rientrano nelle selezioni, vengono applicate le regole di assegnazione prezzi illustrate per la procedura di gestione documenti.


La procedura di controllo prezzi bolle confronta il prezzo inserito nelle bolle non ancora fatturate con i prezzi di listino.

Nel confrontare i prezzi si tiene anche conto di eventuali prezzi speciali dei clienti e delle scontistiche.

Il controllo viene fatto solo sulle bolle non ancora fatturate, perché questo tipo di stampa ovviamente serve per controllare i prezzi prima della fatturazione e naturalmente vengono esaminate solo le righe articolo dato che per le righe extra magazzino non esistono confronti possibili

I dati da inserire sono:

Da data | Inserire la data iniziale di ricerca, viene proposto l'inizio del mese corrente.
A data | Se si desidera si può inserire la data finale di calcolo.
Codice registro | Questo dato viene chiesto solo se è stata abilitata la gestione multiregistro.
Stampa solo prezzi diversi | Si può scegliere se stampare solo i prezzi che nelle bolle sono diversi rispetto a quelli previsti, oppure stampare tutte le righe articolo.

Alla fine, se ci sono dati difformi, viene effettuata la stampa.


Questa procedura permette di forzare la chiusura o di cancellare i documenti evadibili che rientrano nei parametri fissati. Si applica ad Ordini, Conto Lavoro e Preventivi

I dati da inserire sono:

Tipo anagrafica | Si possono scegliere i documenti dei clienti o dei fornitori
Tipo documento | Si possono scegliere Ordini, Conto Lavoro o Preventivi
Fino a data documento | Vengono letti i docmenti fino alla data di registrazione indicata.
Fino a data consegna | Vengono presi in considerazione solo i documenti fino alla data di cosegna indicata.
Codice deposito | Se è stato abilitato il modulo Multideposito viene chiesto il deposito da esaminare, se serve si deve ripetere l'operazione per tutti i depositi.

Alla conferma viene fatta la lettura di tutti i documenti e vengono presentati quelli che soddisfano i requisiti e per ciascuno vengono indicati il numero totale di righe, le righe evase, quelle parzialmente evase e le non evase.

A questo punto sulla lista si possono fare alcune cose:
Si possono spuntare le righe cumulativamente o una per volta, si possono stampare o modificare i singli documenti o infine si possono cancellare o forzare come chiusi tutti i documenti spuntati.


Questa piccola procedura esegue una cosa che a volte può risultare utile.

I documenti di magazzino hanno la gestione degli indicatori di "Stato" che possono essere modificati manualmente o che vengono attivati automaticamente in determinate condizioni. Ad esempio dopo che un documento è stato stampato viene aggiunto l'indicatore "S", oppure dopo l'invio del documento tramite mail viene aggiunto "M".

Putrroppo le procedure di evasione ordini e preventivi data la loro complessità non sono in grado di attivare automaticamente lo stato. Per questo motivo è stata resa disponibile questa procedura che legge tutti i documenti in un intervallo di date e controlla lo stato di evasione delle righe, e mette "N" se il documento non è evaso, oppure "P" se è parzialmente evaso o infine "E" se è totalmente evaso.

La procedura chiede i limiti di data, poi chiede una serie di spunte per applicare ai clienti, ai fornitori, agli ordini,ai preventivi ad ai documenti di conto lavoro.

La procedura non è invasiva e può essere ripetuta quante volte si desidera.


Zefiro permette di applicare i bolli virtuali nelle fatture elettroniche. Questa procedura stampa una lista delle fatture alle quali è stato applicato l'imposta di bollo virtuale per procedere al pagamento dei bolli a consuntivo.

Vengono chieste la data iniziale e finale del periodo da pagare, e poi viene fatta la stampa che elenca tutte le fatture e riporta il totale da pagare.


Questa procedura permette di importare automaticamente documenti da files.

La configurazione richiede l'intervento di personale tecnico che conosce i meccanismi interni del programma. Si deve intervenire nel file di configurazione "AGC.ini" nelle sezioni: "[DOCEXPORT]", "[DOCIMPORT]" e "[DOCIMPFTP]"

I files da importare solitamente sono di tipo "CSV", Excel o LibreOffice. ed hanno un formato ben specifico, con colonne definite e regole sui dati presenti. Se il file supera le specifiche viene importato, altrimenti si ottiene una segnalazione di errore.

Il sistema consente di configurare più di un tipo di file, ed in base alle regole è in grado di riconoscere il tipo di importazione.

Oltre alla importazione dei documenti, si possono eseguire anche esportazioni direttamente dalla gestione dei documenti. In questo modo, con le opportune configurazioni, è possibile concordare comunicazioni automatiche di documenti tra clienti e fornitori.

Si possono anche configurare sistemi per generare automaticamente ordini a fornitori o qualsiasi altro tipo di documento, non solo, si potrebbero configurare sistemi per eseguire anche altri tipi di elaborazioni automatiche come ad esempio aggiornamenti di listini configurazioni di anagrafiche o altro.


Questa procedura viene incontro alla esigenza molto diffusa di importare anagrafiche articoli in modo automatico.

Accade spesso che i nostri fornitori siano in grado di fornirci liste di articoli in formato MS Excel. Noi mettendo opportunamente a punto un file di configurazione e salvando i dati della tabella in formato testo, siamo in grado di effettuare l'importazione di questi dati.

Non solo, questa stessa procedura può essere eseguita dalla gestione dei documenti di magazzino ed in questo caso è in grado di importare autamaticamente le righe del documento.

Con questa procedura si ottiene quindi un sistema standard per l'import di dati di magazzino, però per poter mettere in atto questa funzionalità è necessario mettere a punto un particolare file di configurazione per ogni formato riconosciuto.

La stesura del file di configurazione richiede alcune competenze tecniche, è opportuno quindi contattare la Compusoft per concordare il formato in modo da ottenere risultati corretti. In fondo a questa pagina riportiamo un esempio di file di configurazione funzionante con alcune annotazioni tecniche che possono aiutare ad adattarlo alle proprie esigenze.

Quando si lancia la procedura viene visualizzata questa pagina:

I dati richiesti sono:

Nome del file di configurazione | Inserire il nome del file di configurazione, se il file trovato è un file di configurazione valido, vengono automaticamente proposti i valori dei campi successivi. Viene anche visualizzata una breve descrizione che indica il tipo dei dati che si stanno importando.
Nome del file di importazione | E' il file di testo che contiene i dati da importare nel formato previsto dal file di configurazione.
Prefisso articoli | Spesso quando si importano articoli in modo automatico, si desidera assegnare un prefisso al codice per riconoscere gli articoli di quel fornitore e per limitare i rischi di collisione di codici.
Categoria | Viene proposta la categoria, gli articoli importati verranno compilati automaticamente con i dati presenti nella categoria.
Numero listino | E' il listino di vendita usato per inserire il prezzo. Oltre a questo listino nel file di configurazione si possono realizzare gli automatismi per calcolare il prezzo di altri listini.
Data inserimento | E' la dati di inserimento per i nuovi articoli
Fornitore abituale | E' il codice fornitore che viene inserito negli articoli.
Cliente di riferimento | E' il codice cliente che viene inserito negli articoli.
Conferma | Per poter eseguire la procedura è necessario spuntare questa casella.
Tutto extramagazzino | Questa voce è presente solo quando si importano le righe di documenti di magazzino ed indica che invece di creare gli articoli, vengono importate solo righe extramagazzino.
Solo diversi da zero | Anche questa voce è presente solo quando si importano le righe di documenti di magazzino e serve ad indicare se si desidera che le righe Articolo vengano importate tutte o solo quelle con la quantità diversa da zero.

Alla fine, viene eseguita l'importazione. La procedura è in grado di effettuare alcuni controlli sulla validità dei dati in ingresso, però data la delicatezza della operazione che si va ad eseguire, raccomandiamo di porre grande attenzione ad utilizzare dati congrui.

Se si esegue l'importazione di righe di documenti di magazzino, a seconda dei dati presenti in ciascuna riga, il programma è in grado di distinguere se importare rige Articolo, oppure Extramagazzino o infine righe Descrittive, la regola è la seguente:
Se la riga non ha codice articolo allora è una riga Extramagazzino, ma se il campo quantità non contiene un numero valido, diventa riga Descrittiva. Queste tecniche permettono di avere una gestione documenti molto flessibile e di attivare comportamenti ripetitivi.

A titolo di esempio riportiamo di seguito un file di configurazione funzionante che utilizza un formato abbastanza comune. Nelle annotazioni sono riportate alcune informazioni tecniche se spiegano il funzionamento.

' COMPUSOFT (c)      by DRIUSSI CLAUDIO
'
'NOME              VALORE
+CONFIG-------------+-----------------------------------------------------------
FILEIN              C:\IMPORT\ARTICOLI.TXT
TITLE               IMPORTAZIONE LISTINO XYZ
PREFART             X
CODCTA              010
CODLST              1
CODFRN              0
CODCLI              0
'PREELAB             csBox(o:aFields[1,2])
'POSTELAB            csBox('Dopo ogni riga')
STARTROW            2

+FIELDS-------------+-----------------------------------------------------------
XCODICE
DESCRIZ
UMIS
LST000000

+XFIELDS------------+-----------------------------------------------------------
CODICE              trim("@PREFART;")+"@XCODICE;"
COSTO               pRound(p100Sub(FromString("@LST000000;","N"),30))
LST000002           p100Sub(FromString("@LST000000;","N"),10)

+NOTE--------------------------------------------------------------------------

Questo tracciato viene utilizzato per importare articoli, oppure per importare
documenti e contemporaneamente anche gli articoli.

In caso di importazione di documenti il tipo di riga generata dipende da alcuni
parametri, se il codice risultante non è vuoto viene comunque generata una riga
articolo, altrimenti viene generata una extramagazzino se c'è un numero (anche
zero nella quantità) oppure una descrittiva se la quantità è una stringa non
numerica.

I campi CONFIG sono campi che servono per configurare la procedura di
importazione:

FILEIN     : nome predefinito del file di importazione
TITLE      : descrizione del tipo di importazione da riportare a video dopo la
             scelta del tracciato
PREFART    : prefisso per i codici articolo
CODCTA     : categoria predefinita se non c'è un campo specifico
CODLST     : codice listino per prezzo vendita, per listini multipli configurare
             le righe
CODFRN     : fornitore
CODCLI     : cliente
PREELAB    : procedura da eseguire prima di ogni riga
POSTELAB   : procedura da eseguire dopo ogni riga
STARTROW   : numero prima riga dati, spesso la prima viene usata per i titoli di
             colonna.

I campi FIELDS, indicano i campi disponibili nella riga del file di testo, a
sinistra c'è il nome del campo, a destra il valore è irrilevante perché il
valore utile viene prelevato dalle righe di importazione. Se il nome del campo
non corrisponde ad un campo della tabella articoli, significa che è un campo
che viene utilizzato per fare altri calcoli.

I campi XFIELDS, non sono presenti nella riga di importazione, ma vengono
calcolati a partire da altri campi FIELDS, XFIELDS o CONFIF

Nei calcoli, le variabili che iniziano con @ (chiocciola) e sono seguite dal
nome della variabile e finiscono con ; (punto e virgola), in fase di calcolo
vengono sostituite con il relativo valore. Sempre nei calcoli, la variabile "o"
indica l'oggetto utilizzato per effettuare i calcoli.

La presenza della categoria di articoli permette di configurare automaticamente
molti dei campi della tabella.

Oltre ai campi della tabella articoli sono presenti alcuni campi che hanno un
significato speciale:

PRUNIT     : Prezzo unitario del documento
SC01       : Sconto del documento
SC02       : Sconto del documento
SC03       : Sconto del documento
QTA        : Quantità documento
LST000000  : Prezzo del listino predefinito
LST000001  : Altri prezzi di listino vengono applicati in presenza del
             corrispondente listino

Se si tenta di importare un documento ma non è presente il campo QTA nella riga,
viene segnalato un errore che impedisce l'importazione utilizzando quel
tracciato.


Questa procedura è disponibile solo se è stata abilitata la gestione della importazione delle liste di codici nella sezione "LISTECODICI" del file di configurazione AGC.INI e fa parte di una serie di procedure atte ad importare dati da terminali portatili.

L'importazione dati da terminali può essere configurata in molti modi per adattare il programma a svariati sistemi di rilevamento dati. Lo standard preferenziale è quello di usare il programma "Liste di Codici" per Android prodotto da noi. Per attivare il programma sui terminali e per configurare il trasferimento dei dati si deve richiedere l'intervento di personale autorizzato dalla Compusoft.

Questa procedura è in grado di leggere una lista letta con il programma "Liste di Codici" e di trasformarla in vari formati tra cui Excel. In questo modo, i dati letti possono essere manipolati per eventuali importazioni successive.

Quando viene attivata questa funzione, vengono anche attivate le procedure di importazione di files in alcune posizioni del programma, principalmente nelle righe dei documenti, si possono importare i files prodotti dal programma "Liste di Codici", ma anche dei files Excel trasformati con questa procedura.

I dati da inserire sono:

Nome del file | Viene proposta la posizione standard di memorizzazione delle liste e si deve scegliere il file da importare.
Tipo di lista | Il programma di lettura dei codici per motivi di controllo, prevede la possibilità di gestire liste di tipo diverso, in questa posizione si indica il tipo di lista che si intende importare. Se il tipo è diverso l'importazione non viene fatta, si può forzare l'importazione scegliendo "Qualsiasi tipo."
Tipo di esportazione | I dati letti possono essere trasformati in vari formati al momento si può esportare in Excel, LibreOffice o testo semplice.

Per comodità in fase di importazione vengono cercati i codici degli articoli e nei files esportati viene presentata anche la descrizione.

Oltre ai campi Codice e quantità, il terminale permette di leggere altri due campi che sono stati denominati "Posizione" e "Riferimento", in fase di importazione vengono rispettivamente inseriti nel campo "Altre annotazioni" e nel campo "Prezzo unitario"

Dettagli tecnici

Il programma "Liste di codici" è in grado di comunicare utilizzando il protocollo FTP, perciò nel computer che riceverà i dati è necessario installare un server FTP. Il personale Compusoft è in grado di fare tutte le configurazione necessarie.


Il saldaconto fatture è una procedura che viene utilizzata da coloro che non intendono utilizzare la contabilità ordinaria ma che vogliono tenere traccia degli incassi delle fatture che emettono.

Questa procedura è disponibile solo per le fatture e le note di accredito emesse, non per le fatture e note ricevute da fornitori. Inoltre è neccessario che sia installato il modulo "SCM"

La gestione del saldaconto viene normalmente effettuata dalla gestione dei documenti di magazzino, posizionando la riga su una fattura o una nota d'accredito di clienti, compaiono le voci "Saldaconto" e "Archivio saldaconto" che permettono di gestire gli incassi per un cliente.

Con la procedura saldaconto, si inserisce il codice del cliente e vengono elencati tutti i suoi documenti. Si può scegliere di vedere solo le partite aperte oppure anche quelle chiuse.

Da questa posizione è possibile fare la stampa della situazione ed anche effettuare l'incasso di una singola fattura o anche inserire un importo che la procedura provvede a distribire nei vari documenti.

Alla fine se si da conferma, vengono fatte le registrazioni.

In alternativa si può utilizzare la procedura "Archivio saldaconto" che abbina ogni fattura ai relativi incassi. Per motivi di manutenzione e per fare la stampa dei movimenti di incasso e pagamento, l'archivio l'archivio è disponibile anche in modo indipendente dai documenti, però non si dovrebbe inserire movimenti manualmente per evitare incongruenze di dati.

Per effettuare il saldaconto, ci si posiziona sulla fattura di cui si deve registrare l'incasso. Poi dal menù dei comandi si sceglie la voce "Saldaconto fattura". A questo punto compare la lista degli incassi già registrati che naturalmente può essere anche vuota. Da quì si possono inserire gli incassi e se si desidera sono disponibili comandi per effettuare il saldo o per forzare la chiusura della partita anche se gli importi incassati non coincidono con il totale del documento.

I dati da inserire sono:

Data pagamento | è la data in cui viene fatto l'incasso.
Tipo pagamento | è la modalità con cui avviene l'incasso, Premendo pulsante collegato o il tasto F2 si apre la lista di scelte
Importo | Inserire l'importo incassato.
Descrizione | Volendo è possibile inserire una piccola descrizione aggiuntiva.
Altri dati | Gli altri dati presenti nella registrazione solitamente sono modificabili solo per motivi di manutenzione, essi derivano dal documento a cui si riferisce la riga di saldaconto e vengono gestiti in automatico quando quando si inseriscono saldaconto dal documento. Sono: Data e numero movimento, tipo e codice anagrafica, tipo, date e numero documento e codice registro.

I Comandi speciali disponibili sono:
Saldo | Questa procedura legge gli importi già incassati e li confronta con il totale del documento, se gli importi incassati sono inferiori al totale del documento, viene proposto di effettuare automaticamente una scrittura di saldo.
Forza chiusura | Se ci sono differenze tra gli importi incassati ed il totale documento, però la partita deve essere considerata chiusa, perché compensata o per altri motivi, con questa procedura si può forzare la chiusura.

Alla fine quando di esce dalla gestione del saldaconto, il programma esegue un confronto tra gli importi incassati ed il totale del documento e se è il caso chiude automaticamente il saldaconto. Tale controllo viene fatto anche se si eseguono modifiche agli importi della fattura.

Per il saldaconto sono disponibili due stampe.

La stampa dei movimenti, disponibile dalla gestione del saldaconto, semplicemente stampa la lista dei movimenti.

La stampa del saldaconto invece è disponibile dalla gestione dei documenti e permette di stampare la lista delle fatture e note con il proprio saldaconto e saldo. Questa stampa puo essere abbinata alle selezioni per ottenere dati specifici di un determinato cliente.


Questa procedura è stata introdotta in occasione dell'entrata in vigore del decreto sul cambio dell aliquota IVA da 20% a 21% il 17/09/2011. E serve per fare la conversione automatica degli archivi.

Dal 01/10/2013 l'aliquota 21% è stata portata al 22%, la procedura funziona correttamente anche con la nuova aliquota e le note operative che seguono restano ancora valide.

Prima di lanciare la procedura è necessario fare alcune modifiche:

  • Inserire il nuovo codice IVA, con la nuova aliquota. Se necessario si possono gestire più codici per la stessa aliquota (ad esempio per separare vari tipi di costi e di ricavi).
  • Modificare le preferenze di magazzino ed inserire la nuova aliquota per le spese bancarie e spese bolli.
  • Modificare le preferenze di contabilità per l'iva normale nelle procedure per calcolo del margine (per coloro che sono soggetti al regime del margine).

I dati da inserire sono:

Vecchio codice IVA | Inserire il vecchio codice IVA, se ci sono più codici con la stessa aliquota ripetere l'operazione per tutti i codici.
Nuovo codice IVA | Inserire il nuovo codice IVA. Più "vecchi codici" possono essere convogliati su uno o più nuovi codici a seconda delle necessità
Data di validità | Inserire la data i entrata in vigore della nuova aliquota.
Anche ordini non evasi | Se si desidera si possono aggiornare anche le righe degli ordini che non sono stati evasi, così nel momento in cui avverrà l'evasione verrà fatta con il codice iva aggiornato. Oltre agli ordini di clienti e fornitori vengono aggiornati anche i documenti di conto lavoro.
Conferma operazione | Per eseguire, si deve spuntare questa scelta.

Quando viene confermata, la procedura esegue la conversione dei codici iva degli articoli, delle categorie di articoli, ed infine esegue una elaborazione di tutti i documenti di magazzino.

Nei documenti, vengono aggiornate tutte le righe non evase degli ordini con data precedente alla data di validità e vengono aggiornati tutti i documenti con data successiva alla data di validità con esclusione delle fatture differite che giustamente devono portare il codice iva dei DDT che le hanno generate.

In caso di documenti a scorporo, viene ricalcolato il nuovo scorporo tenendo conto dell'aliquota iva aggiornata, quindi la parte imponibile risulterà essere diversa da prima.

I prezzi di listino in caso di listini a scorporo non vengono modificati, e quindi la parte imponibile risulterà modificata automaticamente in funzione della differenza di aliquota. Questo perché riteniamo che sia comunque bene che le variazioni di prezzo debbano essere monitorate in modo diretto. Eventualmente per fare modifiche automatiche si possono utilizzare le procedure già disponibili nella gestione degli articoli.


Le liste di articoli servono a velocizzare alcune operazioni con gli articoli, di norma questo archivio non viene utilizzato direttamente ma all'interno della gestione degli articoli.

I dati da inserire sono:

Numero lista | È il numero di lista a cui appartiene questo articolo
Codice articolo | È l'articolo che appartiene alla lista. Premendo pulsante collegato si apre la lista degli Articoli.
Codici varianti | Questo dato è disponibile solo se è attivato il modulo di gestione varianti e permette di gestire la lista delle varianti dell'articolo. Si attiva premendo il pulsante di gestione varianti.
Quantità | È la quantità per questo articolo.


Questa procedura esegue alcuni controlli sui documenti di magazzino presenti nel programma in modo da garantire la coerenza e consistenza dei dati.

L'affidabilità dei dati è importante per tutte le operazioni che hanno a che fare con i calcoli di giacenze, ed è particolarmente importante eseguire questa procedura prima di eseguire procedure che operano massicciamente sui dati come ad esempio il consolidamento o la storicizzazione dei documenti.

I dati da inserire sono:

Attiva correzzione automatica | Con questa opzione si indica che si desidera che il programma esegua la correzzione degli errori rilevati che è in grado di effettuare in modo automatico senza decisione da parte dell'operatore.
Da data, A data | Indicare i limiti di data entro cui eseguire il controllo.
Numero massimo di errori | Indicare il numero massimo di errori da rilevare prima di effettuare la stampa.

Alla conferma vengono il programma esegue le seguenti operazioni:

  • Controlla che tutte le righe abbiano la corrispondente testata.
  • Controlla che i dati di testata siano coerenti con il tipo di documento e che le righe siano coerenti con la testata.
  • Controlla che i codici inseriti si riferiscano a dati presenti, i codici controllati sono: Clienti/Fornitori, Depositi, Listini, Articoli, Codici IVA, viene anche controllato che i codici siano coerenti con il tipo di documento.
  • Controlla i calcoli del valore della riga.
Se vengono trovati errori, dopo aver eseguito il controllo vengono stampati gli errori rilevati in modo da poter intervenire per la loro correzzione.


La gestione dell'inventario con Zefiro viene realizzata utilizzando procedura anche sofisticate. Questo menù contiene tutto ciò che è necessario per gestire le operazioni sulle giacenze.

Il calcolo delle giacenze in Zefiro viene fatta con il metodo del Costo medio ponderato e viene eseguito leggendo i movimenti di magazzino inseriti con i documenti di magazzino a partire dall'ultimo consolidamento di giacenze registrato nelle giacenze.

Calcolo giacenze con il metodo del costo medio ponderato

Il calcolo delle giacenze avviene in questo modo:

  • Il calcolo inizia dal giorno successivo alla giacenza consolidata antecedente alla data di giacenza richiesta.
  • Vengono letti i movimenti di magazzino successivi fino alla data richiesta
  • I movimenti di carico aumentano quantità e valore ed il costo medio è dato da valore diviso giacenza.
  • I movimenti di scarico diminuiscono la quantità ed il valore della giacenza è dato dal costo medio precedente moltiplicato per la giacenza residua.
  • Se la giacenza va a Zero (o sottozero in caso di errori di registrazione), il valore va a Zero ed il costo ultimo rilevato verrà utilizzato per i movimenti di carico e scarico successivi.
  • Il calcolo della giacenza si interrompe alla fine della data di giacenza richiesta.

Come si vede il sistema di calcolo è molto flessibile e permette di determinare i dati in modo accurato e dinamico. Ma può portare ad imprecisioni si si vanno a modificare accidentalmente documenti inseriti in precedenza e può risultare lento se i dati da leggere sono tanti.

Per questi motivi sono stati introdotte procedure che permettono di consolidare le giacenze in un determinato momento, questo consente da un lato di velocizzare le operazioni di calcolo evitando di leggere i movimenti antecedenti al consolidamento, e dall'altro evitano che operazioni accidentali vadano ad alterare i dati, infatti modifiche o cancellazioni di documenti antecedenti diventano irrilevanti ai fini della giacenza.

Da notare che i consolidamenti sono l'ultima scrittura del giorno, quindi gli eventuali movimenti della data consolidata non vengono presi in considerazione e sono considerati antecedenti al consolidamento

Operazioni inventariali

Zefiro non obbliga a fare operazioni di chiusura o apertura di magazzino, ma consente di gestire le giacenze in modo dinamico.

Dovendo però inserire l'inventario nei documenti di bilancio annuale, è comunque consuetudine di fare un inventario ad ogni fine anno. Consigliamo quindi di fare un consolidamento ad ogni fine anno, però ciò non è obbligatorio, infatti le procedure di calcolo delle giacenze funzionano correttamente anche in assenza di consolidamento.

D'altra parte, le operazioni di consolidamento si possono fare in qualsiasi momento anche in date diverse, anche più volte all'anno ed anche su un numero parziale di articoli. Questo come detto in precedenza rende stabile l'inventario e velocizza le operazioni di calcolo.

Per fare l'inventario, solitamente si parte facendo il consolidamento e la stampa dell'inventario alla data desiderata. In caso di archivi grandi consigliamo di suddividere la stampa per categorie o secondo altri criteri prescelti. Conviene anche fare l'esportazione dei dati per lavorare in modo più comodo su un foglio di calcolo.

Successivamente si fanno i controlli manuali e le rettifiche sui dati stampati anche direttamente sui fogli di calcolo.

Quando sono finiti i controlli si possono inserire le giacenze, magari importando i fogli di calcolo opportunamente corretti.

Alla fine quando tutti gli inserimenti delle giacenze consolidate sono stati fatti, si può procedere all'azzeramento delle giacenze degli articoli non presenti.

Tutte le operazioni descritte possono essere fatte in tempi diversi, e se necessario si possono fare rettifiche manuali ed anche ripetizioni di procedure.

Procedure disponibili

Per eseguire tutte le operazioni sulle giacenze sono disponibili le seguenti procedure

Stampa inventario con questa procedura si effettua la stampa del inventario ad una certa data.
Giacenze alla data Si possono consolidare le giacenze o azzerare le giacenze degli articoli non presenti in inventario.
Inserimento giacenze Con questa procedura si inseriscono le rettifiche di giacenza constatate con l'inventario
Giacenze consolidate E' la tabella che materialmente contiene i dati delle giacenze consolidate e che permette eventuali modifiche manuali.


La stampa dell'inventario permette di stampare le giacenze di magazzino alla data scelta.

I dati da inserire sono:
Tipo stampa Le scelte possibili sono:
Inventario al costo medio | Il costo viene valorizzato al costo medio ponderato, questo significa che i movimenti di carico incrementano il valore complessivo del valore del movimento ed i movimenti di scarico decrementano il valore complessivo del costo medio della giacenza di quel momento moltiplicato per la quantità.
Inventario al costo ultimo | Il costo viene valorizzato al prezzo pagato l'ultima volta che l'articolo è stato acquistato fino alla data dell'inventario.
Lista giacenze negative | Viene fatta la stampa dei soli articoli che hanno giacenza negativa alla data indicata, la valorizzazione avviene al costo standard.
Costo standard | Negli articoli vengono memorizzati il costo ultimo pagato e la data dell'ultimo movimento. Il costo standard può essere inserito manualmente e non viene mai modificato. Scegliendo questa opzione la valorizzazione viene fatta al costo standard, e se non è presente, si applica il costo ultimo. Solitamente questo tipo di valorizzazione viene scelta da coloro che non inseriscono i movimenti di carico ed inseriscono le giacenze solo in caso di necessità.
Tipo articoli Si può eseguire la stampa dei soli articoli che hanno una giacenza diversa da zero oppure di tutti gli articoli o solo quelli esauriti o che non sono mai stati movimentati o infine gli articoli la cui giacenza è sotto la scorta minima.
Per la gestione della scorta minima è necessario configurare nel file AGC.ini il numero del campo numerico libero degli articoli utilizzato per memorizzare la quantità minima di giacenza.
Anche non fiscali | Con questa opzione si può scegliere se stampare anche gli articoli che sono stati classificati come "Non fiscali" nell'anagrafica, o se invece si desidera escluderli.
Solo movimentati | Con questa opzione si possono escludere dalla stampa gli articoli che non sono mai stati movimentati. Serve per coloro che utilizzano molti listini ma non movimentano tutti gli articoli.
Selezioni | Premendo questo pulsante si può eseguire una selezione per limitare il numero degli articoli da stampare a quelli che soddisfano la selezione.
Ordinamento | Premendo questo pulsante si può scegliere l'ordinamento della stampa secondo quelli previsti per gli articoli.
Fino a Data | Inserire la data di cui si vuole conoscere la giacenza, sono compresi nella stampa tutti i movimenti del giorno indicato.
Deposito | Indicare il codice del deposito di cui si vuol conoscere la giacenza. Premendo il pulsante collegato si apre la lista dei Depositi.
Esporta Se si mette la spunta, alla fine della stampa viene esportata la lista degli articoli stampati in uno dei formati supportati, ad esempio Excel, LibreOffice o CSV. Si può anche scegliere il formato di esportazione, cioè la disposizione delle colonne di esportazione alcune delle quali sono predisposte per operazioni di importazioni con altre procedure del programma.
Ad esempio, se si stampa la lista del sottoscorta, il formato "Ordini a fornitori" può essere utilizzato per preparare gli ordini da inviare ai fornitori configurando una procedura di importazione in Importazione Documenti da file. In questo caso viene preparata la colonna con la quantità da ordinare che è data dalla scorta minima meno la giacenza, inoltre nella colonna "PREZZO" si può inserire il prezzo per il fornitore che può essere diverso dal costo calcolato della giacenza.
Con il formato "Import documenti" si può preparare una lista compatibile con le procedure di importazione righe dei documenti. Questo stesso formato può anche essere usato per l'inserimento delle giacenzeconsolidate.

Alla fine viene eseguita la stampa e se richiesto anche l'esportazione.


Le norme sul magazzino fiscale prevedono che, al superamento di alcuni parametri fiscali, si deve stampare il "Giornale di magazzino", e devono essere disponibili le schede con i progressivi ed i saldi.

Le schede di magazzino vengono stampate direttamente dalla anagrafica degli Articoli. Questa procedura invece esegue la stampa cronologica dei movimenti di carico e scarico e le eventuali rilevazioni di giacenza alla data.

I dati da inserire sono:

Da data a data | Inserire le date di riferimento per la stampa.
Codice deposito | Questo dato viene chiesto solo se è attivato il multi-deposito.
Stampa rilevamento giacenze | Se si desidera si può includere od escludere le scritture di rilevamento giacenza dalla stampa.

Alla conferma viene eseguita la stampa.

Il programma non memorizza alcun progressivo, è quindi compito dell'operatore la scelta dei periodi di stampa e della scelta dei depositi. Non vengono nemmeno bloccate le modifiche ai documenti, quindi si consiglia di effettuare la stampa quando le scritture di magazzino sono consolidate.


Questa procedura esegue alcune operazioni globali di consolidamento delle giacenze e si usa soprattutto durante le operazioni per l'inserimento dell'inventario annuale.

I dati da inserire sono:

Tipo operazione Sono disponibili tre tipi di operazione:
  • Consolida giacenze: viene fatto il calcolo giacenze con lo stesso procedimento usato per la stampa inventario e vengono fatte tutte le scritture consolidate che poi potranno essere sistemate con la procedura di inserimento giacenze oppure direttamente nell'archivio delle giacenze consolidate.
  • Azzera giacenze non consolidate: azzera le giacenze degli articoli non ancora consolidati.
  • Azzera TUTTE le giacenze: è simile alla precedente, ma azzera anche le giacenze degli articoli che hanno già giacenze consolidate alla data di rilevamento, va perciò utilizzata con cautela se siamo sicuri del eventuali dati di giacenza inseriti in precedenza sono inattendibili.
Data inventario | Inserire la data in cui si desidera registrare le operazioni di consolidamento.
Azzera anche articoli non movimentati | Può capitare che il nostro archivio degli articoli contenga molti articoli che abbiamo inserito per avere il listino, ma che in realtà non utilizziamo. Di norma, se un articolo non ha movimenti di magazzino, non viene registrata la scrittura di azzeramento, ma se desideriamo con questa spunta possiamo forzare la registrazione anche per questi articoli.
Conferma | Per eseguire la procedura si deve confermare.

Alla fine viene registrato il consolidamento delle giacenze nell'archivio delle giacenze consolidate

Questa procedura fa parte delle operazioni da eseguire per l'inventario annuale. La procedura comune consiste nel consolidare le giacenze alla data, poi si procede a correggere eventuali errori con la proceduda di Inserimento giacenze alla fine, quando tutto è corretto si procede all'azzeramento di tutti gli articoli movimentati ma non presenti a magazzino. In questo modo si evita che registrazioni errate in data antecedente vadano ad influire si dati rilevati.

In alternativa si potrebbe fare un azzeramento di tutti gli articoli e poi inserire solo gli articoli presenti. La scelta operativa dipende dal gusto personale, dal punto di vista operativo è equivalente. La cosa importante è che tutti gli articoli presenti vengano correttamente inventariati.


 ead>

Questa procedura serve per facilitare l'inserimento dell'inventario di magazzino. Nel caso che gestiamo un numero elevato di articoli, le operazioni possono essere fatte in tempi diversi ed è anche possibile fare correzioni sugli stessi dati fino a che il risultato e quindi le giacenze non sono quelle corrette. Sono disponibili varie funzioni per rendere più agevole il lavoro soprattutto con la possibilità di importare ed esportare dati in vari formati.

Quando si inseriscono le giacenze, prima di tutto vengono chiesti alcuni dati per determinare il contesto.

Si deve inserire:

Data inventario | E' la data delle operazioni inventariali che potrebbe essere diversa dalla data corrente, ad esempio bel corso del mese di gennaio si possono inserire le giacenze rilevate al 31 di dicembre dell'anno precedente. Ma si possono anche gestire inventari parziali in altre date nel caso in cui i controlli effettuati dovessero riscontrare differenze. E' importante notare che rilevamenti successivi non incidono su quelli precedenti, ad esempio se viene inventariato un articolo il 31/12, ed il 01/04, l' inventario del 31/12 con le successive movimentazioni vale fino al 31/03 e poi vale il nuovo rilevamento.
Codice Deposito | Questo dato viene chiesto solo se è stato attivata la gestione del multi-deposito e permette di inserire il codice del deposito in cui vengono eseguite le operazioni di inventario.
Max articoli | Questa voce viene chiesta solo se si sta inserendo l'inventario da una lista di articoli e permette di limitare il numero di articoli da elaborare.

Dopo aver inserito i dati richiesti si apre la lista in cui si possono inserire gli articoli che alla fine verranno inseriti nelle giacenze.

Per ogni riga che si inseriscono vengono chiesti i seguenti dati:

Codice articolo | Inserire il codice dell'articolo da inserire in inventario.
Giacenza attuale | Viene proposta automaticamente la giacenza calcolata alla data inserita, per il deposito corrente. e vengono calcolati costo unitario e valore. Inserendo quantità diverse, vengono ricalcolati costo, valore e scostamento.
Costo unitario | Viene proposto il costo unitario, variando questo valore vengono automaticamente ricalcolati valore e scostamenti.
Valore giacenza | Inserire il valore complessivo della giacenza, variando questo valore vengono calcolati automaticamente costo e scostamenti.

Sono disponibili alcuni comandi speciali utili per facilitare il lavoro:

Importa righe da file | Questa procedura consente di importare le righe da un file su disco in uno dei vari formati supportati, ad esempio si possono importare files generati con lettori portatili, oppure generati con fogli Excel o LibreOffice. Il formato delle colonne è determinato ed è lo stesso che viene usato per l'importazione di righe nei documenti di magazzino. Le colonne sono: "CODICE", "QUANTITA'", "POSIZIONE", "COSTO" e "DESCRIZIONE". Le colonne indispensabili sono Codice e Quantità, la Posizione è irrilevante in questo contesto, il Costo se presente permette di forzare il costo unitario, altrimenti verrà applicato il costo determinato dal valore della giancenza attuale. Infine la Descrizione è irrilevante, ma utile per la manutenzione manuale del file.
Importa righe da terminale | Zefiro dispone di varie procedure per leggere i dati da terminali portatili, ad esempio lettori barcode collegati in simulazione di tastiera. Con le adeguate configurazioni si possono facilitare le operazioni di inserimento dati.
Esporta su file | Se si desidera interrompere il lavoro prima di aver finito le operazioni di inserimento giacenze, si possono esportare i dati inseriti fino a questo in un file che potrà essere importato in un secondo momento. Il formato è lo stesso che viene utilizzato per l'importazione da file.

Alla fine se si conferma l'inserimento delle giacenze premendo il pulsante di conferma, vengono eseguite le operazioni di registrazione delle giacenze.

Si deve scegliere il tipo di inventario, che può essere Consolida giacenze In questo caso viene registrato il dato nella tabella delle giacenze consolidate che rende definitivi ed irrilevanti ai fini della giacenza i movimenti antecedenti alla data dell'inventario, questa opzione è quella di uso più frequente si usa ad esempio per l'inventario di fine anno.
Oppure si può scegliere di generare un documento di Differenze inventariali che genera un documento di magazzino contenente le differenze tra la giacenza calcolata e la giacenza rilevata. Questa opzione si sceglie quando nel corso dell'anno vengono riscontrate differenze e si desidera tenere traccia delle differenze riscontrate.

Dopo aver dato conferma vengono effettuate le registrazioni. Nel caso di consolidamento, vengono scritte le nuove giacenze e se per lo stesso articolo alla stessa data erano presenti consolidamenti precedenti, i dati vengono sostituiti con quelli nuovi.


La tabella delle giacenze consolidate è il fulcro della gestione delle giacenze di magazzino. Per una descrizione dettagliata del funzionamento si rimanda alla pagina relativa alla Gestione inventario

In ogni registrazione viene memorizzata la giacenza rilevata per l'articolo indicato alla data indicate e per il deposito scelto.

I dati da inserire sono:

Codice articolo | E' il codice dell'articolo inventariato.
Deposito | Questo dato viene chiesto solo se è stata attivata la modalità di multi-deposito.
Data movimento | E' la data in cui viene effettuato il rilevamento della giacenza.
Quantità | Inserire la quantità rilevata
Costo unitario | Inserire il costo unitario, modificando questo dato viene automaticamente ricalcolato il valore, il pulsante collegato legge il costo ultimo ed il costo standard dell'articolo e lo assegna. Se sono presenti entrambe i costi è possibile scegliere quale applicare.
Valore giacenza | Inserire il valore complessivo della giacenza, modificando questo dato viene automaticamente ricalcolato il costo unitario.

I comandi speciali disponibili sono:

Cancella giacenze | E' disponibile una procedura che esegue automaticamente la cancellazione globale delle giacenze di una determinata data. E' in qualche modo la procedura opposta a quella di azzeramento giacenze con cui si scrivono le giacenze a zero, in questo caso invece si cancellano definitivamente le registrazioni. Si usa se per qualche motivo si desidera ripartire da capo nella gestione di un inventario ad una determinata data.
Controllo valore giacenze | Nel corso del tempo, per tanti motivi il valore della giacenza potrebbe non essere veritiero. Questa procedura permette di confrontare il costo della giacenza rilevata in un intervallo di date con il costo ultimo ed il costo standard inserito negli articoli e presenta una lista in cui vengono spuntate le rige di giacenza rilevata che si scostano oltre la percentuale inserita. Nella lista si possono modificare manualmente le righe per adeguare il valore al valore che si stima essere quello corretto. Alla fine, premendo il pulsante di conferna, vengono aggiornate le righe modificate.


La gestione commesse consiste in una serie di procedure e modalità di utilizzo abbinate alla gestione di magazzino di Zefiro che servono per venire incontro alle necessità di aziende che eseguono produzione su commissione di impianti o macchine o servizi.

Una commessa consiste in una serie di lavori coordinati che devono essere eseguiti e di impiego di materiali che servono per produrre il bene che il cliente ci chiede. Solitamente la fattura al cliente viene fatta a corpo, la gestione della commessa serve per monitorare tutti i costi che sosteniamo in termini di materiali e lavoro impiegati e di produrre la stampa di un consuntivo che ci permette di determinare l'utile lordo realizzato.

Spesso una commessa può essere composta da più sottocommesse che rappresentano le parti che compongono la commessa principale. Questo tipo di suddivisione è conveniente per avere i subtotali dei costi sostenuti. Zefiro riconosce le sottocommesse in modo alfabetico nel codice, ad esempio se una commessa ha il codice "C12324", si possono fare sottocommesse con codice "C12324.01", "C12324.02" e così via. Le sottocommesse a loro volta possono essere suddivise ulteriormente ad esempio con i codici "C12324.01/A", "C12324.01/B" ecc... Però di norma si ritiene sufficiente un solo livello di sottocommessa con eventualmente qualche eccezione di secondo livello.

Le commesse sono memorizzate come particolari articoli di magazzino e per ogni commessa viene inserito un particolare tipo di documento di magazzino che contiene la lista di materiali e di lavorazioni che servono per fare il lavoro.

Il tipo di documento e la categoria di appartenenza degli articoli commessa sono indicati nelle preferenze in modo che il programma sia in grado di riconoscerli nei punti in cui è necessario.

Dopo aver indicato nella commessa i materiali e le lavorazioni che si ritengono necessari per la produzione, è possibile fare la generazione degli ordini ai fornitori. Questo è utile perché spesso i materiali richiesti vengono ordinati in base ai fabbisogni e non per giacenza di magazzino. La procedura propone di ordinare ai fornitori previsti come fornitore preferenziale, però si può cambiare. Le quantità ordinate vengono memorizzate nel campo "quantità 4" delle righe delle commesse in modo da ricordare eventuali ordini già fatti. Questo significa che se si modifica la commessa per aggiungere altri materiali, i nuovi ordini non includeranno merce già ordinata in precedenza. In caso di maggiorazioni di quantità è consigliabile modificare le righe presenti invece di aggiungere righe con lo stesso codice.

Uno stesso ordine a fornitore può contenere righe riferite a commesse diverse per lo stesso materiale ed anche righe che non si riferiscono a nessuna commessa ma che vengono ordinate per magazzino.

A mano a mano che procede la lavorazione si devono indicare le merci impiegate e le lavorazioni che vengono effettuate. Dal punto di vista del magazzino questo corrisponde con una operazione di scarico, poiché dopo aver impiegato le merci esse non sono più disponibili. Per fare questo si usa un particolare tipo di documento che fa l'evasione della commessa (di solito il tipo documento si chiama "CM")

Quando arriva la merce ordinata ai fornitori si effettua il carico di magazzino evadendo l'ordine e poi nel momento che viene impiegata si effettua l'evasione della commessa. Spesso è comodo effettuare l'operazione di scarico a commessa contestualmente con l'arrivo della merce, per questo motivo è stato predisposto un tipo di documento che effettua automaticamente sia le operazioni di carico che quelle di scarico a commessa (di solito il codice è "DFC"), se si desidera invece fare manualmente le due operazioni si può fare un carico da fornitore normale.

Le commesse possono essere sviluppate presso la sede oppure presso cantieri, dipende dalla natura del lavoro, ad esempio gli impianti elettrici o idraulici vengono sviluppati presso le sedi dei clienti. Spesso in questi casi i materiali necessari vengono consegnati dai fornitori direttamente presso il cantiere, per cui non è necessario fare nostri documenti di trasporto. In altri casi invece si devono trasportare merci dalla sede ai cantieri e viceversa. Per questo tipo di operazioni si devono quindi fare documenti di trasporto che hanno solo valenza descrittiva dato che la movimentazione vera viene fatta con i documenti di consumo.

Le lavorazioni vengono catalogate come normali articoli di magazzino che però appartengono alle categorie indicate nelle preferenze. Questo serve per facilitare l'inserimento in alcune condizioni e per riconoscele in fase di evasione commessa.

Per gestire più facilmente le lavorazioni e per poter utilizzare sistemi automatici di rilevazione dei tempi, è stata aggiunta una tabella dei tempi in cui si possono memorizzare le ore lavorate dai vari addetti che poi potranno essere utilizzare per generare automaticamente i documenti di magazzino di consumo materiale. Gli addetti sono memorizzati come Agenti di Zefiro e per ognuno si può indicare il costo orario rilevato in modo da generare consumi con costi veritieri.

La tabella dei tempi dispone di una interessante stampa che assieme all'uso delle selezioni può essere utile per monitorare il lavoro degli addetti con raggruppamenti per addetto, per commessa, per lavorazione e per data.

Per la rilevazione dei tempi può essere utile utilizzare sistemi di rilevazione automatica che permettono di determinare i tempi in modo obiettivo, e quindi di determinare i costi in modo esatto. I sistemi automatici possono essere svariati per questo è stato messo a punto un sistema che facilita l'import/export dei dati delle letture tempi, la Compusoft mette a disposizione alcuni sistemi ed altri possono messi a punto su richiesta.

Lo scopo ultimo della gestione commesse è quello di fare i consuntivi sui costi sostenuti o da sostenere ed eventualmente confrontarli con le fatture emesse. Per questo motivo è disponibile una procedura per la stampa dei consuntivi con evidenza separata dei dati di evasione commessa e ordini a fornitori. E' possibile fare i consuntivi di singole sottocommesse o anche di commesse con tutte le sottocommesse le le appartengono.

Quando una commessa è finita e consegnata, con una procedura è possibile indicare che è chiusa, in questo modo viene esclusa dalla lista delle commesse aperte in modo da limitare gli errori di caricamento dati. Le commesse si possono chiudere e riaprire ed in caso di necessità si possono ricercare anche quelle chiuse.


Questa procedura permette di fare il consuntivo di una commessa.

I dati da inserire sono:

Codice commessa | Inserire il codice della commessa che si desidera esaminare.
Includi sottocommesse | Se si desidera si può includere nel calcolo i valori delle sottocommesse rispetto a quella data.
Tipo stampa | Sono disponibili due tipi di stampa, il consuntivo ed il riepilogo. Il consuntivo espone per ogni commessa tutti gli articoli che la compongono in modo analitico, il riepilogo invece somma tra loro tutti i numeri per gli articoli raggruppando tutte le commesse assieme.
Includi fatture a cliente | Se si desidera si possono includere le fatture emesse in modo da evidenziare l'utile lordo.
Includi dettaglio evasione | Nel consuntivo si può includere la lista dei documenti che evadono la commessa.
Includi ordini a fornitori | Nel consuntivo si può includere la lista di evasione degli ordini a fornitori.
Includi dettaglio articoli | Nel riepilogo si può includere o escludere la lista di tutti gli articoli.

Alla fine viene effettuata la stampa.


L'archivio dei tempi di lavorazione permette di inserire i lavori che vengono effettuate per ogni commessa.

Lo scopo è di determinare in modo obiettivo i costi sostenuti per produrre ogni singola commessa. L'archivio è predisposto per poter essere inserito con sistemi automatici di rilevamento. Questo è molto utile per la determinazione precisa dei tempi.

Una apposita procedura si occupa di trasformare i dati di questa tabella in documenti di magazzino che assegnano i tempi alle varie commesse.

Oltre alla gestione dei costi delle commesse, questa tabella è anche utile per monitorare i tempi lavorati per ogni addetto, oppure per ogni tipo di lavorazione o per commessa. La procedura di stampa abbinata con le selezioni dei dati che ci interessano permette di estrapolare i dati in modo organizzato.

I dati da inserire sono:

Codice addetto | Inserire il codice dell'addetto che fa il lavoro. Per inserire gli addetti si usa la tabella degli agenti.
Data | Inserire la data della lavorazione.
Ora inizio | Inserire l'ora di inizio lavoro.
Ora fine | Inserire l'ora di fine lavoro.
Tempo | Questo campo viene calcolato automaticamente in base all'ora di inizio e di fine lavoro. Per facilitare i calcoli, le frazioni di ore sono memorizzate in centesimi così ad esempio 30 minuti diventano 0,50 ore.
Straordinari | Il programma è in grado di calcolare la quantità che un addetto ha fatto in base ad un semplice algoritmo che considera straordinari tutti i tempi che superano le 8 ore e quelli effettuati nei giorni festivi e di sabato, se necessario si possono eseguire calcoli più sofisticati.
Viaggi | Se si desidera si può inserire le ore impiegate per il viaggio (in caso di interventi esterni), le ore di viaggio sono comprese nel totale del tempo, quindi se nel Tempo sono indicate 7,5 ore e in Viaggi è indicata 1,0 ore significa che il lavoro effettivo risulta essere di 6,5 ore.
Codice lavorazione | Inserire il codice della lavorazione. Il programma propone sono i codici articoli classificati come lavoro in questo modo si limitano gli errori di inserimento.
Codice commessa | Inserire il codice della commessa. Il programma propone sono i codici articoli classificati come commesse in questo modo si limitano gli errori di inserimento.
Descrizione e note | Se si desidera si possono aggiungere descrizioni aggiuntive.
Generazione effettuata | Questa spunta viene inserita automaticamente quando viene fatta la generazione dei documenti di magazzino relativi alle lavoriazioni.

I comandi speciali disponibili sono:

Duplica lavoro | Si può duplicare una singola lavorazione.
Acquisizione rilevazione dati | Se sono stati predisposti sistemi di rilevamento automatico dei tempi, con questa procedura si può effettuare l'importazione. La procedura controlla la correttezza delle timbrature ed in caso segnala eventuali errori.
Ricalcolo straordinari | Gli straordinari vengono calcolati automaticamente se si effettua l'acquisizione dei dati rilevati automaticamente, però in caso di modifiche si può effetture il ricalcolo.

La Stampa permette di scegliere se stampare la lista delle timbrature oppure solo il riepilogo. La lista può essere ordinata per addetto, per lavorazione, per commessa o per data. Ogni tipo di ordinamento permette di ottenere i subtotali per ogni dato.

Una seconda stampa permette di elencare le ore lavorate in ciascun giorno per ciascun addetto indicando ora di entrata e di uscita ed ore ordinare e straordinarie con subtotali per ciascun addetto.


La procedura di rilevamento tempi è una delle possibili procedure utilizzabili per rilevare in modo obiettivo i tempi effettivamente impiegati per le varie lavorazioni. Altre possono essere messe a punto su richiesta.

Il rilevamento dei tempi è importante perché in assenza di un sistema automatico i tempi comunicati dagli addetti possono essere a volte anche molto diversi da quelli effettivi ed invece spesso è necessario avere a disposizione dati esatti.

La rilevazione automatica serve anche per stabilire i tempi che gli addetti non impiegano su commesse specifiche e che invece vengono usati per pause o manutenzioni interne.

A lungo andare questo dato sull'efficienza risulta utile per determinare i costi veri e quindi per sapere quanto addebitare ai clienti.

I dati da inserire sono:

Note | Se si desidera si possono inserire annotazioni riguardo al lavoro che inizia.
Codice commessa | E' il codice della commessa su cui si inizia a lavorare.
Codice lavorazione | E' il codice della lavorazione che si inizia a fare.
Codice addetto | Codice dell'addetto che inizia il lavoro.

Quando si cambia lavoro, il programma sa già che quello che si stava facendo precedente deve essere chiuso e quindi il tempo effettivamente lavorato è quello che passa da quando si inizia un lavoro a quando se ne inizia un altro, oppure si termina il lavoro.

Alle volte può succedere di inserire dati non corretti. Se si desidera annullare l'ultima timbrature si preme il pulsante "Cancella ultimo" che però ha valore solo se premuto entro 30 secondi dalla timbratura errata.

Il pulsante "Fine lavoro" permette di chiudere l'ultima lavorazione fatta e di fermare il tempo.

In fase di acquisizione dei dati di rilevamento, è comunque necessario effettuare un controllo sui dati inseriti perché può succedere che gli addetti facciano errori ad esempio dimenticando di timbrare la chiusura lavori.

Ovviamente quando un addetto si accorge di un errore lo può segnalare e quindi dopo l'acquisizione dei dati si possono fare tutte le modifiche manuali del caso.


Questa procedura legge i dati delle lavorazioni eseguite e genera i corrispondenti documenti di magazzino.

Viene chiesta la data delle lavorazioni da generare ed il codice del tipo di documento e vengono generati i documenti.

Si può fare un giorno per volta perciò si deve ripetere l'operazione per tutti i giorni che si deve generare.

Il programma non fa controlli su date già generate o date omesse. L'utente è quindi responsabile della correttezza dei dati elaborati. In caso di modifiche alla tabella dei tempi, si possono cancellare i documenti generati in precedenza e ripetere la generazione.

Se sono state inserite ore straordinarie e/o ore viaggio, vengono generate a parte le righe corrispondenti, nel articolo della lavorazione si può indicare nel campo libero 1 il codice articolo alternativo per le ore straordinarie e nel campo libero 2 il codice alternativo per le ore viaggio, se questi campi sono assenti viene usato lo stesso codice usato per le ore ordinarie.


In questa posizione si inseriscono alcuni parametri di configurazione della gestione commesse

I dati da inserire sono:

Tipo documento commessa | Si inserisce il tipo di documento che viene usato per la gestione delle commesse. Questo dato viene usato internamente dal programma per alcune procedure di calcolo.
Categoria articoli commessa | Gli articoli utilizzati per catalogare le commesse devono appartenere a questa categoria in questo modo sarà possibile filtrarli in modo corretto per facilitare l'inserimento e per ridurre gli errori.
Categorie articoli lavorazioni da - a | Gli articoli utilizzati per catalogare le lavorazioni devono appartenere a categorie alfabeticamente racchiuse tra i codici inseriti, in questo modo sarà possibile filtrarle in modo corretto per facilitare l'inserimento e per ridurre gli errori. Inoltre nell'evasione delle commesse non si esauriscono mai poiché è possibile che la quantità di ore impiegate sia superiore a quella prevista.
Tipo documento consumo materiali | Questo dato viene suggerito quando si utilizza la procedura di generazione documenti lavorazioni
Cartella import/export tempi | Indicare il percorso in qui le procedure di rilevamento tempi depositano i dati temporanei di rilevamento tempi.


Questo menù contiene voci per la gestione della vendita al dettaglio utilizzando lettori di codici a barre e per la stampa di etichette con codice a barre. Le voci disponibili sono:

Vendita al banco è la finestra per la gestione della vendita, effettua lo scarico di magazzino e può essere collegata al registratore di cassa.
Generazione movimenti serve per scrivere i movimenti di vendita rilevati con la procedura di vendita al banco
Stampa etichette questa procedura serve per stampare le etichette con codice a barre da attaccare alla merce.
Gestione svendita serve per automatizzare la generazione dei prezzi di svendita.


Questa procedura viene utilizzata dalle ditte che effettuano la vendita al minuto e la vogliono gestire tramite lettori di codici a barre. Per poter funzionare si deve configurare correttamente le preferenze di magazzino. Prima di tutto vengono chiesti alcuni dati di configurazione generale:

I dati da inserire sono:

Data di vendita | Inserire la data delle vendite, viene proposta la data odierna.
Numero listino | Inserire il numero di listino utilizzato per la vendita, viene proposto quello inserito nelle preferenze di magazzino. Premendo il pulsante collegato si apre la lista dei Listini.
Codice venditore | Inserire il codice del venditore proposto automaticamente alla chiusura della vendita. Premendo il pulsante collegato si apre la lista degli agenti che in questo contesto assumono il ruolo di venditori.
Codice deposito | E' il codice del deposito in cui si fanno le vendite. Premendo il pulsante collegato si apre la lista dei Depositi

Dopo viene presentata la finestra di vendita al banco che rimane sullo schermo fino alla chiusura della giornata.

Questa procedura è fatta per essere utilizzata anche senza premere tasti sulla tastiera, normalmente i codici degli articoli vengono letti con un lettore di codici a barre e con lo stesso lettore vengono chiamati tutti i comandi necessari per la gestione della vendita utilizzando una tabella di codici di comandi. I dati che si possono inserire sono:
Codice Articolo | In questo campo si inserisce il codice dell'articolo venduto, la procedura inserisce automaticamente il prezzo del listino e la quantità 1, il prezzo utilizzato è quello del listino inserito in precedenza, se presente un prezzo di svendita per il prodotto viene utilizzato questo al posto del prezzo normale, quando un codice viene accettato viene aggiunto alla lista delle vendite e viene svuotato il campo per inserire nuove vendite.Premendo il pulsante collegato si apre la lista degli Articoli, si possono inserire articoli con varianti con la stessa tecnica utilizzata nella gestione documenti.
Tasti più e meno | Con questi tasti si aumentano e si diminuiscono le quantità dell'ultimo prodotto inserito.
Quantità | Con questo campo si può modificare la quantità venduta.
Sconti 1 - 3 | Si può inserire lo sconto per questo articolo.
Prezzo unitario | Il prezzo proposto può essere modificato.
Pulsante Reso | Con questo pulsante si cambia di segno la quantità, serve per accettare i resi di merce.
Pulsante Conferma | Con questo pulsante si conferma la vendita e si passa alla chiusura con stampa dello scontrino o di altri documenti.
Pulsante Leggi terminale | Questo pulsante è presente solo se è stata configurata nelle preferenze la procedura di importazione dati terminali, e serve per leggere i dati della vendita da un terminale portatile.
Pulsante Cancella ultimo | Con questo pulsante si cancella l'ultima vendita effettuata.
Pulsante Annulla vendita | Con questo pulsante si cancella tutta la vendita.
Pulsante Ristampa scontrino | Si può ristampare l'ultimo scontrino emesso.
Pulsante Cliente | Si può intestare la vendita ad un cliente ad esempio a scopo di fidelizzazione

Quando si conferma la vendita, viene fatto il controllo che la vendita non sia vuota e che non venga superato un importo massimo prefissato, se la vendita è valida viene presentata la finestra di conferma vendita.

I dati da inserire sono:

Tipo vendita Si possono scegliere quattro tipi di vendita:
Scontrino | Se è presente la procedura per il collegamento con il registratore di cassa, viene effettuata la stampa dello scontrino fiscale.
Ricevuta | Se è presente la procedura di stampa della ricevuta, viene stampata una ricevuta sulla stampante dedicata a questo scopo.
Fattura | Viene generato il documento configurato nelle preferenze come fattura
DDT | Viene generato il documento configurato nelle preferenze come DDT
Tipo pagamento | Si può scegliere il tipo di pagamento tra Contanti, Bancomat, Carta ed altri. Questo dato è ultile per fare i calcoli di fine giornata.
Importo pagato | Inserendo l'importo pagato, la macchina calcola il resto
Codice venditore | Inserire il codice del venditore che ha effettuato la vendita. Premendo il pulsante collegato si apre la lista degli agenti che in questo contesto assumono il ruolo di venditori.
Descrizione 1 e 2 | Si possono inserire descrizioni aggiuntive.
Causale documento | Questo campo viene chiesto solo per la fattura ed il DDT. Viene chiesto il documento di magazzino da generare. Premendo il pulsante collegato si apre la lista dei tipi di documento.
Codice cliente | Questo campo viene chiesto solo per la fattura ed il DDT. Premendo il pulsante collegato si apre la lista dei Clienti.
Modalità di pagamento | Questo campo viene chiesto solo per la fattura ed il DDT. Viene proposto il codice presente in anagrafica del cliente. Premendo il pulsante collegato si apre la lista delle Modalità di pagamento.

Alla fine a seconda del tipo di vendita scelto viene avviata la procedura appropriata. Per le vendite di tipo DDT e Fattura oltre a venir registrata una scrittura di vendita, vengono anche generati i relativi documenti di magazzino, per gli altri tipi di documento invece verrà utilizzata la procedura di generazione movimenti che registra tutti documenti di scarico in modo raggruppato.

Per facilitare la gestione della vendita con lettori di codici a barre, si possono predisporre dei codici stampati che eseguono i comandi presenti nella videata. I codici da stampare sono:
...FINE...
         Con questo comando viene chiusa la vendita.
...INC...
         Con questo comando viene incrementata la quantità di un pezzo
...DEC...
         Con questo comando viene decrementata la quantità di un pezzo
...DEL...
         Con questo comando si cancella l'ultima vendita inserita.
...ALL...
         Con questo comando si cancella tutta la vendita
...IMP...
         Con questo comando si esegue l'importazione della vendita da un terminale portati
...RESO...
         Con questo comando si cambia il segno alla quantità per gestire i resi


L'archivio degli scontrini non viene inserito manualmente, ma viene generato automaticamente dalla procedura di vendita al banco.

Viene poi utlizzato per generare i documenti di magazzino di vendita e per fare stampe di totalizzazione.

I dati inseriri sono sono:

Data e ora | Vengono inserite la data e l'ora in cui viene effettuata la vendita.
Codice Venditore | E' il codice del dipendente che ha effettuato la vendita.
Tipo pagamento | E' il tipo di pagamento effettuato dal cliente, Può essere Contanti, Bancomat, Carte ed altri.
Importo scontrino | E' l'importo totale dello scontrino.
Importo pagato | In fase di vendita si può inserire l'importo pagato dal cliente, in modo che la macchina calcoli il resto.
Note 1 e 2 | Si possono scrivere annotazioni aggiuntive.
Tipo documento | In fase di vendita si può decidere se generare uno scontrino oppure una Fattura o un DDT.
Codice cliente | Si può inserire il cliente che ha effettuato l'acquisto per emettere documenti come Fatture o DDT o per la fidelizzazione.
Movimenti generati | Questa spunta indica se la vendita ha già generato i movimenti di magazzino. Esiste una procedura che esegue automaticamente la generazione dei documenti.
Contenuto scontrino | Lo scontrino generato dalla procedura di vendita al banco è un testo con un formato particolare usato dalle procerure di stampa e di collegamento con i registratori di cassa, viene memorizzato per ristampare ricevute e per generare i documenti di magazzino.

I comandi speciali disponibili sono:

Stampa ricevuta | Si può stampare una ricevuta non fiscale
Stampa scontrino | Si può ristampare lo scontrino, bisogna fare attenzione a non effettuare registrazioni fiscali doppie.
Spunta scontrini | Si pssono spuntare le registrazioni per effettuare stampe che riportino solo le scritture spuntate.

Le Stampe disponibili sono:

Stampa lista scontrini Vien stampata una lista con i totali.


La procedura di vendita al banco genera le registrazioni nel archivio degli scontrini. A fine giornata o comunque quando si desidera si lancia questa procedura che legge le registazioni e genera i documenti di vendita al banco utilizzando i parametri di configurazione contenuti nelle preferenze. Viene generato un documento diverso per ogni Venditore, per ogni data e per ogni cliente.

Prima di eseguire la generazione dei documenti viene chiesta la data di partenza del calcolo, gli scontrini antecedenti alla data non verranno presi in considerazione.


Questa procedura serve per stampare le etichette con i codici a barre da applicare alla merce che servono per il rilevamento automatico della movimentazione. Viene presentata una finestra di Altre tabelle che serve per inserire gli articoli e le quantità da stampare, se la procedura viene chiamata dalla gestione dei documenti di magazzino, le righe vengono riempite con le le righe del documento.

Per ogni riga si deve inserire:

Codice articolo | Inserire il codice dell'Articolo, in caso di articolo con varianti si può inserire direttamente il codice seguito dal carattere indicato come separatore nelle preferenze e dalle varianti dell'articolo. Se non si inserisce la parte variante per gli articoli che prevedono varianti viene automaticamente aperta la finestra di inserimento varianti. Se si preme il pulsante collegato o si inserisce un codice incompleto o errato si apre la lista degli articoli.
Quantità | Inserire il numero di etichette che si desidera stampare per questo codice.
Varianti | Questo pulsante è presente solo per gli articoli con varianti e permette di modificare i codici delle varianti. Negli articoli è presente il codice della tabella di varianti, ogni tabella prevede fino ad un massimo di dieci varianti per articolo. Premendo il pulsante si apre una finestra con tante righe quante sono quelle presenti nella tabella, viene chiesto in ogni riga il codice della variante ed eventualmente anche la misura che assume la variante.
Dopo aver inserito la lista degli articoli che si desidera stampare, si può richiedere la stampa.

Viene presentata una finestra che chiede:
Codice listino | Inserire il codice del listino per la stampa dei prezzi, viene proposto il listino utilizzato per la vendita al banco. Premendo il pulsante collegato si apre la lista dei Listini.
Stampante dedicata | Questa casella di spunta serve per scegliere se stampare le etichette con una stampante apposita dedicata alla stampa di etichette oppure con la procedura interna di stampa. Per stampare su una stampante dedicata deve essere configurata la procedura nelle preferenze.
Numero colonne | Se si effettua la stampa con la procedura interna, si può scegliere il tipo di tracciato da utilizzare in base al numero di colonne di etichette dei fogli da stampare.

E' disponibile un Comando speciale:
Importa righe da terminale
         Se si dispone di terminali portatili per il rilevamento di dati, si possono leggere i dati delle etichette da stampare leggendo i dati del terminale portatile.


E' una procedura molto particolare che serve solo a coloro che vendono prodotti stagionali soggetti a svendita, serve per impostare i prezzi di svendita che verranno utilizzati dalla vendita al banco. I prezzi di svendita vengono memorizzati sul listino di svendita configurato nelle preferenze di magazzino e vengono generati a partire dal prezzo di listino utilizzato per la vendita al banco.

Si deve inserire:
Selezione | Premendo questo pulsante si esegue la selezione per indicare quali sono gli articoli da mettere in svendita al prezzo indicato sotto, il programma impedisce di eseguire la procedura su tutto l'archivio, quindi la selezione è obbligatoria.
Cancella svendita | Con questa opzione si indica se si devono cancellare i prezzi di svendita oppure impostarli.
Sconto | Indicare lo sconto da applicare nel listino di svendita rispetto al listino di vendita normale.
Prezzo fisso | Al posto dello sconto si può inserire il prezzo fisso.
Conferma | Per poter eseguire la procedura è necessario spuntare questo campo.

Alla fine se i dati sono corretti, viene eseguita la procedura prescelta, la procedura può essere eseguita più volte, alla fine per uscire si preme il tasto [Esc] oppure il pulsane annulla.


Il modulo di Commercio elettronico espande le potenzialità di Zefiro aggiungendo la possibilità di acquisire ordini dai clienti via internet.

Le funzioni di e-commerce si appoggiano al programma open-source ZenCart che è stato scelto per la sua completezza e flessibilità, ed anche perché essendo disponibile il codice sorgente, era possibile intervenire per apportare le opportune modifiche.

Per attivare le funzionalità del modulo, ZenCart viene installato presso un internet provider che soddisfa i requisiti richiesti dal programma, e poi dopo aver opportunamente configurato il modulo di interfacciamento, si può stabilire il dialogo con Zefiro attraverso files di import/export.

La caratteristica di maggior rilievo del modulo di interfacciamento è che a ZenCart sono state aggiunte funzionalità "Business to Business" che consentono di effettuare vendite a diverse tipologie di clienti con prezzi diversificati per ciascuna tipologia.

Data la profonda differenza di struttura tra i due programma, si sono dovuti adottare alcuni compromessi che è necessario tenere in considerazione quando si adottano le strategie di prezzo.

Le limitazioni di prezzo sono le seguenti:

  • La scontistica è limitata ad un solo sconto che viene applicato a tutti gli articoli per ciascun gruppo di clienti.
  • I prezzi di listino sono netti e non vengono applicati sconti.
  • Non esiste la gestione dei listini padre, ogni articolo deve avere il proprio prezzo per ciascun listino esportato.
  • Vengono riconosciuti i prezzi speciali dei clienti, ma anche in questo caso non si tiene in considerazione gli sconti.
  • Deve essere presente un listino dei prezzi al pubblico.

In fase di pianificazione è anche necessario ristrutturare le categorie. Dato che ZenCart le tratta in modo gerarchico è necessario organizzarle nello stesso modo anche in Zefiro, per fare questo si inserisce il codice della categoria padre, se questo dato non è presente significa che la categoria è di primo livello.

Nei clienti si passano a ZenCart i dati anagrafici, il gruppo per la gestione dello sconto ed il numero di listino. Tra i dati anagrafici viene trovato anche il cognome e nome presente nel primo telefono inserito. Nel campo utente si inserisce la e-mail che il cliente utilizza per effettuare il login e nella password si inserisce il codice fornito la prima volta, ma che poi l'utente può modificare.

In linea generale tutte le informazioni descrittive presenti in ZenCart hanno la precedenza su quelle presenti in Zefiro, perciò, se si effettuano delle modifiche alle descrizioni delle categorie o degli articoli, le stesse non saranno recepite da ZenCart, questo è stato fatto perché la presentazione dei dati in ZenCart è molto più ricca ed ha valenze estetiche, quindi non è desiderabile che vengano resettate ad ogni importazione.

Allo stesso modo gli utenti del web hanno la possibilità di modificare i propri dati anagrafici che sicuramente saranno più esatti ed aggiornati di quelli che inseriamo noi. Queste modifiche verranno recepite da Zefiro ogni volta che un cliente effettua un ordine.


Questa procedura permette di esportare tutti i dati anagrafici che possono essere importati in ZenCart. I dati vengono depositati nella cartella configurata nelle preferenze, e poi dovranno essere trasferite nell'apposita cartella del sito internet. Di solito questo viene fatto con un programma di FTP (consigliamo FileZilla), le credenziali ed i parametri di configurazione vengono forniti dall'internet provider.

I dati che si possono esportare sono:

Articoli

Vengono esportati solo gli articoli che sono stati predisposti per l'esportazione inserendo nell'apposito campo il codice del gruppo di articoli di appartenenza. Il gruppo determina alcune funzionalità disponibili in ZenCart.

Contemporaneamente agli articoli vengono esportati anche i prezzi di listino ed anche i prezzi speciali per i vari clienti.

Articoli

Vengono esportati i clienti. Il cognome e nome vengono presi dal primo numero di telefono inserito. Vengono esportati anche il gruppo di appartenenza ed il codice listino, e questi dati vengono recepiti sempre da ZenCart perché in questo modo si stabilisce il prezzo che viene applicato.

Una opzione permette di forzare le password dei clienti a quelle presenti in Zefiro. Questa forzatura solitamente viene effettuata solo in fase di installazione perché comporta la necessità di comunicare le nuove password a tutti i clienti.

Categorie

Le categorie sono un dato che raramente viene modificato e quindi l'esportazione si fa solo quando intervengono variazioni.


Gli ordini che vengono acquisiti in ZenCart possono essere importati in Zefiro.

Quando si riceve un ordine, ZenCart ci manda una e-mail di notifica e quindi possiamo effettuare l'esportazione degli ordini acquisiti. La procedura di esportazione genera un file di testo per ogni ordine acquisito e questi files potranno essere prelevati e depositati nella cartella indicata nelle preferenze.

Per effettuare il trasferimento si usa un programma FTP (consigliamo FileZilla), le credenziali ed i parametri di configurazione vengono forniti dall'internet provider.

Quando si effettua l'importazione viene chiesto il codice del documento da utilizzare e viene proposto quello configurato nelle preferenze.

Se il cliente che ha fatto l'ordine non è ancora presente in Zefiro, ne viene fatta l'importazione.

Il documento importato contiene tutti i dati presenti nell'ordine originale compresi i riferimenti di numero e di identificativo cliente, se ci sono spese di trasporto vengono aggiunte utilizzando il codice indicato nelle preferenze. Per non falsare le statistiche, a differenza di ZenCart gli sconti non vengono applicati al piede del documento ma per ciascuna riga di prodotto.

Alla fine viene effettuata una stampa che indica gli ordini che sono stati importati, l'inserimento di nuovi clienti ed eventuali errori.

Attenzione! è importante evadere gli ordini provenienti da ZenCart con la procedura di evasione completa del documento, perché in fase di evasione viene generato il file che notifica a ZenCart (e quindi al cliente), l'avvenuta evasione della merce.


Questa tabella permette di inserire la lista di scelte utilizzabile per indicare gli articoli da esportare a ZenCart. Si devono inserire solo codici numerici poiché i codici alfabetici non vengono riconosciuti.

Negli articoli una procedura permette di inserire a uno a uno gli articoli da esportare ed il tipo di articolo corrispondente in ZenCart.


Le preferenze servono a configurare le funzionalità di commercio elettronico di Zefiro.

I dati da inserire sono:

Directory export | Inserire la posizione in cui verranno depositati i dati da esportare a ZenCart.
Directory import | Inserire la posizione in cui verranno prelevati i dati degli ordini che provengono da ZenCart
Directory storico import | Se si inserisce questo dato, gli ordini importati verranno copiati in questa posizione, in questo modo, in caso di emergenza sarà possibile recuperarli.
Gruppi articoli da non esportare | Si possono indicare in questa posizione i codici di gruppo articoli che non verranno esportati perché non interessanti per il commercio on line. Si possono inserire zero più gruppi anche separati da spazi.
Campo articolo presente nel web | Si inserisce il nome del campo degli articoli utilizzato per indicare la presenza degli articoli nel web. Questo è un dato tecnico che deve essere inserito con una certa cautela.
Codice listino prezzi al pubblico | Inserire il codice del listino utilizzato per i prezzi al pubblico.
Tipo documento ordini importati. | È il codice del tipo di documento preferenzale usato per importare gli ordini. È utile tenere separati gli ordini web con un codice diverso per motivi di ordine e di reperibilità, Il tipo di documento utilizzato dovrà comunque fornire la possibilità di evadere in modo diretto le fatture.
Articolo spese di trasporto | Inserire il codice dell'articolo utilizzato per le spese di trasporto.


 La procedura di gestione della commercializzazione di vini serve ai produttori e commercianti di vini per assolvere alla normativa fiscale che per il loro settore prevede la tenuta di alcuni registri.

Per eseguire queste stampe il programma deve essere in grado di riconosce gli articoli che devono comparire nella stampa dei registri. Per questo scopo, nell'anagrafica degli articoli si inserisce un articolo diverso per ogni formato di recipiente e per ogni qualità di vino. In ognuno di questi articoli si deve indicare (nel campo rapporto di conversione) la capacità del recipiente e del campo indicato dalle preferenze il codice dell'articolo di vino sfuso che il recipiente contiene.

Per la gestione del registro di imbottigliamento e per la corretta gestione del carico e scarico ed infine per la gestione della rintracciabilità degli alimenti, si deve gestire la produzione che consiste nel costruire la distinta base di ogni formato di prodotto e nel fare documenti di produzione ogni volta che si esegue l'imbottigliamento.

Le stampe dei registri prendono atto di quanto registrato nei documenti di magazzino. Le stampe definitive memorizzano l'ultima data e l'ultimo numero progressivo di registrazione in modo da ripartire con i numeri corretti alla stampa successiva, ma non bloccano la possibilità di modificare i documenti stampati, quindi è compito dell'utente fare in modo che non vengano modificati i documenti dopo le stampe definitive e quindi che non si verifichino incongruenze tra i dati memorizzati ed i dati stampati.

Le procedure disponibili sono:

Stampa registro di commercializzazione questa procedura stampa il registro di commercializzazione richiesto dalla normativa.
Stampa registro di imbottigliamento è la procedura che stampa il registro di imbottigliamento.
Stampa giacenze per tipo esegue i calcoli delle quantità di vino contenute nei recipienti in giacenza e da la giacenza complessiva per ciascun tipo di vino.
Preferenze permette di impostare alcuni parametri per l' utilizzo delle procedure.


Nel registro di commercializzazione vengono riportati tutti i movimenti di carico e scarico che vengono effettuati per gli articoli presi in considerazione, pertanto oltre alle registrazioni di vendita vera e propria vengono annotate anche le scritture di carico da produzione o da acquisto e le scritture di rettifica inventariale.

I dati da inserire sono gli stessi richiesti dalla stampa del registro di imbottigliamento e precisamente:

Tipo stampa | Si può fare la stampa di prova, oppure la stampa definitiva o la ristampa, queste ultime due stampe aggiornano i progressivi di stampa che vengono memorizzati nei numeratori, in da ripartire dalle registrazioni successive nelle prossime stampe definitive.
Data di stampa | Questa è la data che compare nel registro stampato.
Da Data | Questo dato richiesto solo dalla stampa di prova e dalla ristampa permette di indicare la data di partenza da cui stampare. Nel caso delle stampa definitiva si parte dal giorno successivo a quello indicato nei numeratori.
Fino a Data | Si inserisce la data fino a cui si deve eseguire la stampa.
Ultimo numero | La numerazione delle scritture parte da 1 (uno) ogni anno, questo dato viene gestito automaticamente nella stampa definitiva, per la stampa di prova e per la ristampa si inserisce il numero precedente al numero della prima scrittura.
Conferma bollato | Per poter eseguire la stampa definitiva e la ristampa si deve confermare l' inserimento del bollato.
Numero pagina | La numerazione dei documenti bollati viene gestita inserendo in questa posizione il numero della prima pagina da stampare.

Alla conferma viene stampato il registro che contiene tutti i movimenti di carico e scarico per gli articoli implicati. Alla fine viene stampato il riepilogo che parte dalla giacenza prima della stampa e somma i carichi e scarichi effettuati dalle registrazioni e riporta le giacenze finali. vengono considerati tutti i formati con cui vengono venduti i vini e calcolate le quantità relative.


Nel registro di imbottigliamento vengono stampate le registrazioni di produzione che trasformano il vino sfuso in vino imbottigliato. Per poter gestire questa stampa è quindi necessario disporre del modulo di gestione della distinta base che permette di inserire documenti di produzione.

I dati da inserire sono gli stessi richiesti dalla stampa del registro di commercializzazione e precisamente:

Tipo stampa | Si può fare la stampa di prova, oppure la stampa definitiva o la ristampa, queste ultime due stampe aggiornano i progressivi di stampa che vengono memorizzati nei numeratori, in da ripartire dalle registrazioni successive nelle prossime stampe definitive.
Data di stampa | Questa è la data che compare nel registro stampato.
Da Data | Questo dato richiesto solo dalla stampa di prova e dalla ristampa permette di indicare la data di partenza da cui stampare. Nel caso delle stampa definitiva si parte dal giorno successivo a quello indicato nei numeratori.
Fino a Data | Si inserisce la data fino a cui si deve eseguire la stampa.
Ultimo numero | La numerazione delle scritture parte da 1 (uno) ogni anno, questo dato viene gestito automaticamente nella stampa definitiva, per la stampa di prova e per la ristampa si inserisce il numero precedente al numero della prima scrittura.
Conferma bollato | Per poter eseguire la stampa definitiva e la ristampa si deve confermare l' inserimento del bollato.
Numero pagina | La numerazione dei documenti bollati viene gestita inserendo in questa posizione il numero della prima pagina da stampare.

Alla conferma viene stampato il registro che contiene tutti i movimenti di produzione per gli articoli implicati. Alla fine viene stampato il riepilogo che indica le quantità complessivamente imbottigliate per ciascun tipo di vino.


Questa procedura permette di stampare una tabella con il riepilogo di tutte le operazioni di carico e scarico che vengono effettuate sugli articoli che contengono vino. Vengono prese in considerazione tutte le scritture che compaiono nel registro di commercializzazione, e per ogni articolo vengono indicate la giacenza, il formato e la quantità corrispondente in vino sfuso.

I dati richiesti per eseguire il calcolo sono: la data limite di giacenza e la scelta se si desidera includere anche gli articoli a giacenza zero.


 Questa voce serve a memorizzare alcuni dati di configurazione del modulo di commercializzazione vini.

I dati da inserire sono:

Categorie articoli vino sfuso | Il programma deve essere in grado di sapere se un articolo è un vino sfuso perché questo è necessario per le procedure di stampa, il programma riconosce gli articoli perché appartengono alle categorie comprese tra quelle indicate. È necessario che le categorie indicate si riferiscano a solo vino sfuso.
Nome campo per articolo vino sfuso | Questo campo serve per indicare quale dei campi liberi degli articoli viene utilizzato per memorizzare il codice dell'articolo di vino utilizzato per una particolare confezione. Il nome deve essere esatto altrimenti si possono verificare malfunzionamenti delle procedure di stampa, i nomi possibili sonoFLD01, FLD02 e FLD03.


La procedura di tentata vendita è utile alle ditte che trasportano la propria merce pressi i propri clienti e rilasciano sul posto il documento di vendita che può essere il DDT oppure la Fattura Immediata. La stessa procedura può essere utilizzata anche dalle ditte che mandano dai clienti gli agenti i quali rilevano gli Ordini che verranno evasi in un secondo momento.

Questa procedura viene abbinata all'utilizzo di terminali portatili che permettono di fare i documenti direttamente dai clienti e di copiarli automaticamente in Zefiro.

I vantaggi nell'utilizzo di questi sistemi sono evidenti. In primo luogo si riducono i tempi e si aumenta la precisione dei documenti fatti presso i clienti, ed in secondo luogo si evita di ricopiare a mano i dati nel programma gestionale risparmiando tempo e diminuendo il rischio di errori.

Zefiro gestisce la tentata vendita in modo modulare, questo significa che può essere collegato a sistemi hardware e software di tentata vendita diversi e personalizzati per ogni tipo di esigenza. La soluzione tipica prevede l'uso come terminali di Computers Palmari basati su sistema operativo PalmOS che stampano i documenti su una stampante ad aghi posizionata nel veicolo.

A causa delle limitazioni dei terminali portatili, la gestione della tentata vendita impone alcune limitazioni rispetto alla gestione dei documenti disponibile in Zefiro, di questo si deve tenere conto per evitare problemi di valorizzazione. Le differenze sono:

  • GESTIONE LISTINI: Il palmare dispone di un solo livello di listino personalizzato. In Zefiro viene cercato il prezzo nel listino del cliente ed a caduta in tutti i listini padre, nel palmare invece si cerca il listino del cliente ed un solo listino padre.
  • SCONTISTICA: In Zefiro la scontistica può essere bypassata dal prezzo di listino, nel palmare lo sconto viene sempre applicato.

Il programma su palmare può richiedere dati aggiuntivi normalmente non presenti nell'anagrafica standard dei Clienti, per poter passare questi valori si devono utilizzare in Zefiro le Variabili utente dei clienti. le variabili riconosciute sono:

  • CODTDO: E' il tipo di documento preferenziale per questo cliente, se non si inserisce viene utilizzato il tipo preferenziale del palmare.
  • NUMGIRO: Nel palmare il clienti possono essere presentati utilizzando l'ordine di giro, in questo campo si inserisce i giro a cui appartiene il cliente.
  • ORDGIRO: In questo campo si inserisce l'ordine di presenza nel giro del cliente.
  • CLIFAT: Zefiro permette di memorizzare nel cliente le destinazioni alternative del cliente per la merce. Nel palmare questo non è possibile, si devono inserire le destinazioni come se fossero clienti e nella variabile CLIFAT si inserisce il codice del cliente a cui verra' intestata la fattura.
Le procedure necessarie per la gestione della tentata vendita sono:

Esportazione dati con questa procedura si preparano di dati da inviare al terminale.
Importazione documenti permette di importare in Zefiro i documenti inseriti nel terminale portatile.
Preferenze con questa voce si configura il funzionamento del collegamento tra Zefiro ed il terminale portatile


Questa procedura prepara i dati da esportare ai terminali, i dati effettivamente esportati dipendono dalla configurazione delle preferenze.Se nelle preferenze si è scelto di eseguire l'esportazione separata per agente, viene chiesto il codice agente ed è necessario ripetere l'operazione per tutti gli agenti.

Questa procedura è necessaria solo se sono state fatte modifiche ai dati da esportare, altrimenti non serve farla.

L'esportazione consiste solo nella preparazione dei dati da esportare, l'esportazione effettiva dipende dal tipo di terminale utilizzato e deve essere eseguita dopo l'esportazione per rendere effettivi i dati nel terminale.

Se si utilizzano i palmari PalmOS si deve eseguire la procedura di sincronizzazione HotSync.


Questa procedura serve per importare in Zefiro i documenti memorizzati nei terminali di tentata vendita.

Prima di lanciare questa procedura si deve lanciare la procedura specifica die terminali che copia fisicamente i dati dai terminal al computer in un formato intermedio, quindi con questa procedura si importano definitivamente i dati.

Se si utilizzano i Palmari PalmOS la procedura intermedia da eseguire si chiama HotSync.

ATTENZIONE: Dopo aver eseguito la procedura intermedia del terminale, è assolutamente indispensabile eseguire subito l'importazione dei documenti e solo dopo aver controllato che i dati siano stati importati correttamente, si possono cancellare i dati nel terminale. Se ci si dimentica di importare i documenti, può succedere che alla prossima sincronizzazione del terminale i dati intermedi vadano persi costringendo ad inserire a mano i documenti.


La procedura di stampa dei DDT di carico serve per assolvere alla disposizione di legge che disciplina la materia della tentata vendita la quale richiede che alla partenza dei mezzi preposti alla vendita venga redatto un DDT con la lista dei prodotti che vengono trasportati.

Strada facendo vengono eseguite le vendite e vengono prodotti i relativi DDT, può anche capitare di effettuare dei carichi integrativi di merce presso fornitori che vengono raggiunti lungo la strada. A fine giornata si inseriscono le quantità vendute e per differenza si ottiene la nuova giacenza del mezzo.

Questa procedura permette di eseguire questa stampa, se è stata abilitata la gestione dei depositi, ad ogni mezzo adibito alla tentata vendita viene assegnato un deposito e la giacenza e le movimentazioni del mezzo corrispondono alla giacenza del deposito, cosicché la giacenza del mattino del mezzo corrisponde alla giacenza finale del giorno prima del deposito.

La procedura può essere lanciata come comando speciale della gestione depositi, oppure autonomamente.

I dati richiesti sono:

Data DDT | Inserire la data del DDT di carico, viene proposta la data del giorno corrente.
Numero DDT | Al momento non c'è la gestione automatica della numerazione dei DDT di carico, quindi la si deve inserire manualmente
Leggi tutti gli articoli | Questa spunta serve per indicare se si desidera che vengano elencati tutti gli articoli di magazzino compresi quelli che hanno giacenza nulla, oppure solo quelli che hanno una giacenza maggiore di zero per il deposito selezionato.
Leggi giacenze | Con questa spunta si indica se si desidera che vengano lette le giacenze degli articoli oppure se si desidera inserire la giacenza a mano.
Leggi movimenti di carico | Con questa spunta si indica se si desidera che vengano letti i movimenti di carico effettuati nel giorno, e quindi i carichi integrativi.
Leggi movimenti di scarico | Con questa spunta si indica se si desidera che vengano letti i movimenti di scarico e quindi se la stampa che si sta facendo è il consuntivo della giornata o il carico iniziale.
Numero righe vuote | Volendo nella stampa si possono includere alcune righe vuote che possono essere compilate a mano.
Codice deposito | Indicare il codice del mezzo per cui si sta facendo il DDT di carico

Dopo aver confermato le scelte, la macchina esegue la lettura degli articoli e di giacenze e movimenti, gli articoli presi in considerazione sono quelli che vengono selezionati in base alle preferenze di tentata vendita.

Alla fine viene presentata una videata con la lista degli articoli trovati e per ogni articolo si possono modificare giacenza e movimenti, si possono anche cancellare o aggiungere righe. Per ogni riga viene chiesto il codice articoli, la giacenza al giorno precedente, i movimenti di carico del giorno ed i movimenti di scarico del giorno.

Quando si è finito di modificare e caricare i dati si può procedere con la stampa.

ATTENZIONE

A causa della struttura del programma, il DDT di carico viene calcolato sulla base delle giacenze del giorno precedente, questo significa che se il deposito viene caricato al mattino prima della partenza, è comunque necessario fare il documento di trasferimento come se fosse stato fatto la sera precedente.


Questa voce serve a memorizzare alcuni dati di configurazione del programma per il collegamento ai terminali di tentata vendita.

I dati da inserire sono:

Categorie articoli da esportare | Si può scegliere di esportare al terminale portatile solo una parte degli articoli di magazzino, con questa voce si indicano le categorie di articoli che verranno esportate, le categorie non comprese verranno ignorate.
Primo gruppo articoli da escludere | Con questa voce si può imporre un ulteriore criterio di selezione degli articoli. Gli articoli con questo codice gruppo o superiore verranno ignorati.
Primo gruppo clienti da escludere | Anche i clienti possono essere esclusi dalla esportazione per evitare di riportare sul terminale clienti che non vengono gestiti con questo sistema. I clienti con codice gruppo uguale o superiore a questo verranno ignorati.
Procedura import/export | Questo parametro serve per configurare la procedura che verrà utilizzata per le operazioni di importazione ed esportazione. Il nome della procedura dipende dal sistema di terminali utilizzati e solitamente viene predisposto del personale tecnico incaricato.
Directory di export | Questa voce come la precedente serve per configurare le procedure di interfaccia tra Zefiro ed i terminali, si inserisce la directory (cartella) usata per esportare i dati.
Directory di import | In questa directory (cartella) il programma di import/export deposita i documenti inseriti nel terminale portatile da importare in Zefiro
Tipi documento importazione | Si possono definire fino a cinque tipi di documento riconosciuti da Zefiro ed inseriti nel terminale portatile. La numerazione dei documenti è a carico del programma del terminale, Zefiro non esegue alcun controllo di numeri duplicati o mancanti.
Esportazione separata per agente | Si può decidere di esportare su ciascun terminale solo i clienti dell'agente abbinato al terminale oppure si può decidere di esportare tutti i clienti su tutti i terminali.


Il Parlamento Europeo con il Regolamento CE 178/2002 del 28/01/2002 per tutelare la salute dei cittadini, impone che a partire dal 01/01/2005 tutti gli operatori del settore alimentare siano in grado di individuare chi ha fornito un determinato alimento e di conseguenza di rintracciare coloro a cui è stato fornito lo stesso alimento.

In particolare nell'Articolo 14/1 viene detto:
Gli alimenti a rischio non possono essere immessi sul mercato.
inoltre all'Articolo 14/6 viene detto:
Se un alimento a rischio fa parte di una partita, lotto o consegna di alimenti della stessa classe o descrizione, si presume che tutti gli alimenti contenuti in quella partita, lotto o consegna siano a rischio.

Da ciò si evince che un programma gestionale atto a gestire la rintracciabilità degli alimenti deve suddividere i prodotti in Lotti che corrispondono al documento di carico del prodotto.

All'Articolo 18/1 viene detto:
È disposta in tutte le fasi della produzione, della trasformazione e della distribuzione la rintracciabilità degli alimenti, dei mangimi, degli animali destinati alla produzione alimentare e di qualsiasi altra sostanza destinata o atta a entrare a far parte di un alimento o di un mangime.
e nell'Articolo 18/2 si dice:
Gli operatori del settore alimentare e dei mangimi devono essere in grado di individuare chi abbia fornito loro un alimento.

Zefiro adempie alla normativa gestendo i "Lotti di rintracciabilità", la procedura è stata sviluppata per fare in modo da limitare il più possibile l'intervento manuale da parte degli operatori. Quasi tutte le operazioni che riguardano la rintracciabilità vengono gestite dalla gestione documenti di magazzino.

Quando si inserisce un documento di carico per acquisto o per produzione alla chiusura del documento viene chiesto il codice di lotto che gli viene assegnato, viene proposto automaticamente un codice composto dall'anno del documento ed un progressivo numerico.

Nei documenti di scarico come ad esempio DDT o Fatture immediate, in ciascuna riga si deve inserire il codice del lotto con cui era stato caricato il prodotto che si sta scaricando, per comodità degli operatori, viene proposto automaticamente il codice dell 'ultimo lotto di carico in cui era presente il prodotto, questo perchè si presuppone che nel settore alimentare i prodotti vengano scaricati con il metodo F.I.F.O. (first in first out) cioè quello che viene caricato per primo viene scaricato per primo e quindi in ogni momento è presente a magazzino solo l'ultimo lotto, ovviamente ciò non è sempre vero, anzi spesso viene caricato un lotto mentre ancora si sta esaurendo il materiale del lotto precedente, in questo caso l'operatore sceglie il lotto effettivamente impiegato, per comodità si consiglia di inserire i DDT di carico nel momento in cui viene esaurita la giacenza precedente in modo da minimizzare la sovrapposizione di lotti.

Un caso particolare di carico e scarico avviene quando si eseguono trasformazioni di alimenti, in questo caso si impiegano alcune materie prime per realizzare un prodotto finito. Questa casistica viene risolta inserendo documenti di produzione che a partire da una distinta base, automaticamente fanno lo scarico della materia prima in base ai prodotti realizzati. In questo caso nelle righe di scarico della materia prima viene indicato il codice del lotto di appartenenza ed alla fine del documento viene generato automaticamente un nuovo lotto per il prodotto finito.

Nei documenti di carico e scarico, tra i comandi speciali è disponibile, in caso di necessità, la stampa della rintracciabilità degli alimenti che nel caso dei documenti di carico rintraccia tutti i documenti che effettuano lo scarico anche considerando le produzioni e nei documenti di scarico va a rintracciare tutti i lotti di carico (considerando anche le produzioni) ed alla fine per ogni carico individuato rintraccia tutti gli scarichi.

Il menù di rintracciabilità dispone di alcune voci utili sui dati inseriti come descritto. le voci disponibili sono:

Rintraccia lotto con questa voce si esegue la stampa di rintracciabilità di un lotto conosciuto
Ricalcola lotti questa procedura viene utilizzata quando ricalcolare i lotti su base temporale
Stampa etichette con questa voce si possono stampare etichette con il codice di rintracciabilità


Questa procedura serve a stampare a partire da un numero di lotto di carico tutti gli scarichi che sono stati effettuati su quel lotto e quindi di individuare tutti i clienti a cui è stato venduto l'alimento appartenente al lotto, normalmente non è necessario utilizzare questa procedura direttamente, infatti è molto più comodo utilizzare le procedure ed i comandi di stampa rintracciabilità presenti nei documenti di magazzino.

Viene chiesto il codice di lotto e quindi viene stampata la rintracciabilità.


 Questa procedura è stata sviluppata per venire incontro all 'esigenza di coloro che per motivi organizzativi non riescono a caricare i documenti di carico e scarico secondo la sequenza temporale corretta, ma ad esempio inseriscono tutti documenti di carico a fine mese, oppure inseriscono i documenti di tentata vendita ogni settimana.

Costoro non riescono a gestire correttamente la rintracci abilità in modo automatico, ma con questa procedura possono ricalcolare i lotti in modo da ricostruire le sequenze temporali stabilite dall'ordine di inserimento dei documenti.

I dati da inserire sono:

Data movimento | Inserire i limiti di date per i documenti da ricalcolare, vengono proposti i limiti del mese corrente.
Codice articoli | Se si desidera si può limitare il ricalcolo solo ad alcuni articoli.
Applica anche a carichi dello stesso giorno | Di norma per ogni documento di scarico, vengono applicati i lotti di carico presenti fino al giorno precedente alla data del documento di scarico, se si spunta questa casella, vengono presi in considerazione anche i carichi effettuati nello stesso giorno del documento di scarico.
Conferma ricalcolo | Per poter procedere al ricalcolo si deve spuntare questa casella.
Registri | Questo campo è visibile solo se è abilitata la gestione dei registri multipli e permette di limitare il ricalcolo solo ad alcuni registri.

Alla fine viene eseguita l'elaborazione.


 Questa procedura è la stessa che viene utilizzata per la stampa delle etichette con barcode, l'unica differenza è che viene utilizzato un altro tracciato stampa che contiene i dati di rintracciabilità al posto del codice a barre.


 La procedura di gestione depositi cauzionali permette di gestire nostri materiali che sono in deposito presso clienti per svariati motivi, tali materiali possono essere sottoposti a cauzione oppure no.
L'esempio tipico di deposito con cauzione è quello della vendita di bevande che vengono vendute in bottiglie o in fusti che sono di nostra proprietà e che il cliente ci dovrà rendere dopo averne consumato il contenuto.
In altri casi il deposito può essere senza cauzione come ad esempio nel caso dei comodati d'uso gratuiti e nel caso delle merci date a noleggio.

La procedura è soprattutto rilevante per la gestione delle cauzioni, infatti il programma è in grado di determinare in base alle vendite effettuate ed ai resi le cauzioni che sono presenti presso clienti e quindi provvedere alla fatturazione delle cauzioni per differenza ovvero alla emissione di nota d'accredito qualora i resi superino il fatturato gli articoli che sono sottoposti a cauzione vengono contrassegnati inserendo in un apposito campo il codice utilizzato per la cauzione. Alcune procedure vengono utilizzate per questo scopo:
Generazione cauzioni è la procedura che legge i DDT di vendita del periodo e genera le cauzioni per gli articoli soggetti ca cauzione.
Riepilogo cauzioni è la procedura che legge le merci date in cauzione ed i resi del periodo e genera il riepilogo per la fatturazione o la nota d'accredito.
Preferenze permette di impostare alcuni parametri per l'utilizzo delle procedure.

Nell'archivio dei clienti sono disponibili stampe che elencano le merci in deposito presso i clienti.

La gestione di comodati e noleggi è meno sofisticata, infatti poggia sulla gestione manuale dei documenti di consegna e di reso.


Questa procedura serve per generare automaticamente i movimenti di cauzione collegati ai DDT di vendita del periodo.

I dati da inserire sono:

Leggi DDT da data a data | Si indica la data iniziale e finale dei DDT di vendita da elaborare, vengono proposti il giorno iniziale e finale del mese in corso.
Data documenti | Inserire la data dei documenti di scarico cauzione, viene proposto l'ultimo giorno del mese corrente.
Codice cliente | Inserire un codice cliente se si desidera eseguire l'elaborazione per un solo cliente, altrimenti lasciare zero ed in questo caso vengono elaborati tutti i clienti. Alcuni clienti possono essere sospesi da cauzione ed allora non vengono elaborati automaticamente, per elaborarli se ne deve indicare il codice.
Forza già elaborate | Per evitare duplicazioni di movimenti di cauzioni, alla fine della elaborazione i DDT elaborati vengono marcati come già elaborati, con questo comando si può forzare la rielaborazione dei DDT già elaborati.

Alla fine viene eseguita la procedura. I DDT presi in considerazione vengono letti e gli articoli che vengono venduti con un articolo di cauzione generano per ciascun cliente un documento di deposito cauzionale, questo documento non viene fatturato ma serve solo a gestire il carico e lo scarico dei depositi presso cliente, un altra procedura si occupa di eseguire il riepilogo delle cauzioni e di fatturare gli importi previsti.


Questa procedura viene eseguita dopo la procedura di generazione cauzioni e dopo che sono stati inseriti manualmente i documenti di reso cauzioni.

I dati da inserire sono gli stessi della procedura di generazione cauzioni ma il significato è leggermente diverso:

Leggi DDT da data a data | Si indica la data iniziale e finale dei DDT di movimento cauzioni da elaborare, vengono proposti il giorno iniziale e finale del mese in corso.
Data documenti | Inserire la data dei documenti di riepilogo, viene proposto l'ultimo giorno del mese corrente.
Codice cliente | Inserire un codice cliente se si desidera eseguire l'elaborazione per un solo cliente, altrimenti lasciare zero ed in questo caso vengono elaborati tutti i clienti. Alcuni clienti possono essere sospesi da cauzione ed allora non vengono elaborati automaticamente, per elaborarli se ne deve indicare il codice.
Forza già elaborate | Per evitare duplicazioni di riepilogo, alla fine della elaborazione i DDT elaborati vengono marcati come già elaborati, con questo comando si può forzare la rielaborazione dei DDT già elaborati.

Alla fine viene eseguita la procedura. Vengono letti i DDT di movimenti di cauzioni ed anche i DDT di vendita e viene confrontato l'importo stimato da fatturare con quello da pagare, se l'importo da fatturare supera quello da pagare viene emesso un documento di riepilogo che è un documento fatturabile che verrà inserito nella prossima fatturazione automatica, viceversa se l'importo da pagare supera quello da fatturare viene emessa una nota d'accredito. Il documento emesso contiene il la quantità totale di ogni articolo di cauzione caricate e scaricate con segno positivo e negativo in modo da evidenziare le movimentazioni effettuate.


Questa voce serve a memorizzare alcuni dati di configurazione per la gestione delle cauzioni.

I dati da inserire sono:

Nome campo per articoli cauzioni | Questo campo serve per indicare quale dei campi liberi degli articoli viene utilizzato per memorizzare il codice dell'articolo utilizzato come cauzione. Il nome deve essere esatto altrimenti si possono verificare malfunzionamenti delle procedure di gestione cauzioni, i nomi possibili sonoFLD01, FLD02 e FLD03.
Documento deposito cauzione presso cliente | La procedura di generazione cauzioni genera documenti con questo codice.
Documento riepilogo cauzioni periodo | La procedura di riepilogo cauzioni genera documenti con questo codice se le vendite superano l'importo del rimborso.
Documento nota d'accredito | La procedura di riepilogo cauzioni genera documenti con questo codice se l'importo del rimborso supera l'importo delle vendite.
Gruppo clienti escluso da cauzione | I clienti appartenenti a questo gruppo non vengono considerati nella gestione delle cauzioni, e quindi sono esenti da cauzione.
Gruppo clienti cauzione sospesa | I clienti appartenenti a questo gruppo vengono elaborati dalle procedure di gestione cauzioni solo se vengono richiamati esplicitamente, altrimenti non vengono elaborati.


L'utilizzo di alcuni prodotti fitosanitari è consentito solo a soggetti che sono dotati di una particolare autorizzazione. Poiché questi sono prodotti pericolosi per la salute, questi soggetti dovranno adottare una serie di precauzioni previste dalla legge (ART 25 D.P.R. 290/01 e successive modificazioni).

Coloro che rivendono questi prodotti dovranno accertarsi che siano maneggiati solo da soggetti autorizzati.

Per poter gestire questa situazione, Zefiro mette a disposizione alcune procedure.

Per prima cosa è necessario identificare gli articoli che sono soggetti a questa normativa, questo si fa inserendo un valore diverso da spazio nel campo disponibile degli articoli. Fatto questo il programma è in grado di identificarli e quindi riesce a stampare nei documenti che contengono prodotti di questo genere un modulo con le informazioni sui prodotti nocivi, permette di identificare il possessore del patentino che ha ritirato la merce, facilita la consegna delle schede di sicurezza inviando una e-mail che permette di scaricarla da un sito internet ed è anche in grado di stampare i registri richiesti dalla legge.

Alcuni prodotti commerciali possono essere composti da più componenti fitosanitari, ma la legge prevede che vengano individuati tutti i singoli prodotti. Per poter stampare tutti i registri identificando i componenti, per questi prodotti commerciali si costruisce un articolo "kit" che identifica la quantità di prodotti fitosanitari contenuti in una singola confezione. Questo è sufficiente perché le stampe dei registri siano in grado di scorporare i singoli componenti indicando le relative quantità.

I prodotti commerciali spesso sono venduti a confezione, ma soccome nei registri è richiesta la gestione delle quantità a KG o a Litri, negli articoli a confezione si deve indicare l'unità di misura alternativa ed il rapporto di conversione. Ad esempio se un prodotti si vende in confezioni da 250gr, si dovrà inserire come unità di misura principale "CONF" e come unità di misura alternativa "KG" e nel rapporto di conversione si inserisce "4", questo significa che sono necessarie 4 confezioni per fare un Kg di prodotto.

Le procedure disponibili sono:
Registro di Carico e Scarico è il registro dei prodotti nocivi acqusitati e venduti per cui è richiesta l'autorizzazione.
Dichiarazione fitosantari è una stampa che riepiloga le vendite di prodotti fitosanitari effettuate nell'anno, i dati vanno riportati sugli appositi moduli.
Giacenze fitosanitari permette di stampare in qualsiasi momento la giacenza attuale di prodotti fitosanitari.
Preferenze Con questa voce si possono inserire i dati che permettono di riconosce i prodotti fitosanitari soggetti alla normativa.


Il registro di carico e scarico permette di stampare tutte le movimentazioni fatte di pordotti fitosantari tossici e nocivi.

E' possibile sceglere se stampare prodotti ordinati per data oppure per numero di registrazione del prodotto fitosanitario. Si può anche scegliere se stampare tutto di seguito o se eseguire un salto pagina alla fine di ciascun prodotto.
Per ogni numero di registrazione vengono stampati i totali del periodo prescelto, anche se sono stati venduti più prodotti commerciali che contengono lo stesso prodotto.

I prodotti stampati sono quelli che hanno un valore diverso da spazio nell'apposito campo della anagrafica articoli.
Viene anche data la possibilità di catalogare i prodotti per gruppi individuati dal valore inserito nel campo ed è possibile inserire gli articoli da cercare.

Per ogni movimentazione vengono stampati i dati dell'articolo e gli estremi del venditore o compratore ed infine la quantità di carico o di scarico espressa sia nella unità di misura della confezione che in KG o Litri.

I dati così ottenuti possono essere ricopiati nel registro vidimanto manuale ammeno che gli ordini preposti al controllo non siano disposti ad accettare il formato stampato.


Questa procedura permette di stampare un prospetto che contiene i dati richiesti dalla "Dichiarazione di vendita di prodotti fitosanitari".

Vengono richieste le date iniziale e finale, di solito si fa la lettura dell'intero anno, ma in caso di necessità si possono indicare date diverse.

Viene anche offerta la possibiltà di scegliere il tipo di ordinamento dei risultati trovati e la possibilità di estrapolare i dati di un solo gruppo di articoli identificato valore inserito nel campo previsto dalla configurazione.

Viene qunidi calcolata la quantità totale venduta nel periodo indicato e viene effettuata la stampa.

I dati così ricavati possono essere ricopiati nel modulo ministeriale, oppure conservati come sono se il formato viene accettato.


Con questa procedura è possibile stampare la giacenza dei prodotti fitosanitari alla data indicata.

Viene anche offerta la possibiltà di scegliere il tipo di ordinamento dei risultati trovati e la possibilità di estrapolare i dati di un solo gruppo di articoli identificato valore inserito nel campo previsto dalla configurazione.

In caso di articoli "kit", vengono calcolate le giacenze dei singoli componenti, in caso di prodotti venduti a confezione viene calcolato il corrispondente quantitativo espresso in KG o Litri.


Questa voce serve a memorizzare alcuni dati di configurazione del programma per la gestione della vendita di prodotti fitosanitari.

I dati da inserire sono:

Campo articoli tossici e nocivi | Indicare in questa posizione il nome del campo della anagrafica degli articoli utilizzato per identificare i prodotti tossici e nocivi (solitamente FLD01) per cui è richiesta l'autorizzazione. Nel utilizzo del programma tutti gli articoli che in questa posizione hanno un dato diverso da spazio vengono considerati tossici e nocivi. Si possono usare sigle diversificate per i prodotti per i quali viene richiesto il patentino e per quelli vendibili senza patentino, poi nel successivo campo si indicano le sigle da escludere dall'obbligo.
Campo articoli num. regisrazione fitofarmaci. | Indicare in questa posizione il nome del campo della anagrafica degli articoli utilizzato per inserire il numero di registrazione del prodotto come fitofarmaco (solitamente FLD02). Tutti gli articoli che hanno un numero di registrazione vengono stampati nella dicharazione dei fitofarmaci.
N. anni di validità del patentino | Quando si effettua una vendita di prodotti fitosanitari, alla fine dell'inserimento del documento viene chiesto il codice del "cliente" titolare del patentino a cui viene consegnata la merce. Nella anagrafica del cliente di inserisce il numero del patentino e la data di emissione. In questa posizione si inseriscono gli anni di validità, in questo modo se il patentino è scaduto, veniamo avvisati per procedere ad aggiornare i dati.
Gruppi di articoli senza patentino | In questa posizione si possono inserire le sigle dei prodotti per cui si deve tenere i registri dei fitofarmaci, ma che non richiedono il patentino. le sigle devono essere separate da spazi e possono essere indifferentemente in maiuscolo o minuscolo.
Indirizzo web cerca scheda fitosanitari | La legge prevede che venga fornita ai soggetti che ritirano i prodotti, la scheda di sicurezza per ciascun prodotto venduto. Per maggiore comodità e sicurezza Zefiro prevede la possibilità di inviare una e-mail con i link per scaricare le schede da internet. I files in formato PDF dovranno essere memorizzati in un sito accessibile e raggiungibili con il comando inserito in questa posizione. Al comando viene passato il numero di registrazione che dovrà essere composto da sole cifre e non dovrà avere zeri iniziali. Per maggiore comodità la Compusoft mette a disposizione un sito in cui saranno reperibili tutte le schede di cui i clienti avranno necessità e che dovranno essere fornite per l'inserimento. Il comando predefinito è: "http://fitosanitari.compusoft.it/scheda.php?num=@numreg"
Indirizzo web archivio fitosanitari | In questa posizione è possibile inserire l'indirizzo di un sito in cui reperire informazioni sulle schede di sicurezza. Questo dato verrà inserito nelle e-mail che verranno inviate ai clienti.


Sono disponibili alcune procedure per la gestione delle provvigioni degli agenti.

Provvigioni è l'archivio che contiene la lista delle provvigioni da liquidare o liquidate.
Liquida provvigioni è la procedura che permette di stampare le provvigioni da liquidare agli agenti
Cancella provvigioni permette di cancellare le provvigioni già liquidate.
Budget agenti è un archivio che consente di inserire il budget previsionale di vendita degli agenti e di controllarne lo scostamento.


L'archivio delle provvigioni normalmente non viene gestito manualmente, infatti le provvigioni vengono generate automaticamente durante l'emissione delle fatture.

Però è possibile modificare manualmente eventuali situazione concordate ed inoltre da questa tabella si possono gestire gli incassi da clienti per determinare la liquidabilità delle provvigioni. Se non si desidera registrare gli incassi per ciascuna vendita, in fase di calcolo delle liquidazioni si può forzare la liquidazione delle provvigioni sui documenti presunti pagati.

I dati da inserire sono:

Codice agente | È il codice dell'agente che ha effettuato la vendita. Premendo pulsante collegato si apre la lista degli Agenti.
Codice cliente | È il codice del cliente a cui è stata fatta la vendita. Premendo pulsante collegato si apre la lista dei Clienti.
Stato avanzamento Indica lo stato in cui si trova la provvigione, premendo pulsante collegato si apre la lista di scelte che possono essere:
1 | NON LIQUIDABILE: indica che il pagamento da parte del cliente non è stato ancora effettuato e quindi le provvigioni non possono essere ancora liquidate.
2 | LIQUIDABILE: indica che la provvigione è liquidabile e quindi durante la fase di stampa della liquidazione questa provvigione verrà inclusa, spesso le provvigioni vengono generate già con questo stato poiché si possono bloccare le provvigioni per fatture non ancora pagate anche in altri modi.
3 | LIQUIDATA: la stampa della liquidazione definitiva attiva automaticamente questo stato che sta ad indicare che la provvigione è stata liquidata.
Imponibile documento | È l'importo imponibile lordo di riferimento per la provvigione, se la provvigione si riferisce all'intero documento è l'imponibile del documento senza considerare sconti e spese a piede, se invece la provvigione si riferisce ad una singola scadenza l'importo si riferisce alla quota di imponibile di quella scadenza. Questo importo si riferisce all'intero documento comprese le righe non soggette a provvigione
Imponibile provvigione | È l'importo imponibile netto di riferimento per la provvigione, se la provvigione si riferisce all'intero documento è l'imponibile dell'intero documento con esclusione delle righe non soggette a provvigione cioè quelle che hanno percentuale provvigione uguale a zero. Se la provvigione si riferisce ad una singola scadenza l'importo si riferisce alla quota di imponibile di quella scadenza.
Importo provvigioni | È l'importo della provvigione calcolato sulle singole righe del documento può essere il totale della provvigione se la liquidazione non è suddivisa in più scadenze oppure una quota.
Tipo documento
Codice registro
Data documento
Numero documento 		Inserire gli estremi del documento, questo dato stabilisce il legame con l'archivio dei documenti, in caso di rigenerazione delle provvigioni vengono sostituite le provvigioni a parità di estremi documento.
Data scadenza | È la data di scadenza della liquidazione della provvigione e dipende dalla configurazione del tipo di liquidazione dell'agente.
Rata | È il numero di scadenza per questo documento
Provvigioni di capoarea | Quando si calcolano le provvigioni dei capoarea, viene messa la spunta in questa posizione.
Modalità di pagamento | È la modalità di pagamento concordata con il cliente. Premendo pulsante collegato si apre la lista delle Modalità di pagamento.
Data pagamento | Inserire la data in qui il cliente effettua realmente il pagamento, questo dato serve a procedure con la liquidazione delle provvigioni.
Incasso ritardatario | Questa casella serve ad indicare che il cliente non ha ancora pagato dopo la scadenza del pagamento, e serve a bloccare la liquidazione delle provvigioni.

I comandi speciali disponibili per i documenti sono:

Incasso scadenza | Questa procedura serve a velocizzare l'inserimento dei dati di incasso della scadenza del cliente in modo da rendere liquidabili le provvigioni. I dati da inserire sono: Data in cui il cliente ha effettuato il pagamento, oppure l'informazione che il pagamento è in ritardo e lo stato attuale di liquidabilità
Spunta provvigioni | è possibile spuntare le righe di provvigioni per stampare solo quelle desiderate.


Questa procedura serve per stampare la lista delle provvigioni maturate dagli agenti, se richiesto si può fare la liquidazione definitiva che oltre a stampare i dati cambia lo stato della provvigione in "LIQUIDATA". Si possono anche fare stampe di prova e ristampe.

I dati da inserire sono:

Tipo di stampa | La stampa può essere di prova, definitiva e ristampa, nel caso della stampa definitiva e della ristampa viene aggiornato lo stato della provvigione a "Liquidata", nel caso della ristampa vengono prese in considerazione anche le provvigioni già liquidate, negli altri casi vengono stampate solo le provvigioni liquidabili.
Da data scadenza a data scadenza | Inserire i limiti di data, la data presa in considerazione è quella della scadenza della liquidazione.
Codice agente | Inserire il codice dell agente a cui si devono liquidare le provvigioni. Premendo pulsante collegato si apre la lista degli Agenti.
Anche non pagate | Questa opzione permette di liquidare anche le provvigioni di cui non è stato registrato l'avvenuto pagamento da parte del cliente. Questo consente di evitare la registrazione degli incassi supponendo che i ritardati pagamenti siano numericamente poco rilevanti.
Anche in ritardo | Nell'archivio delle provvigioni esiste un campo che serve ad indicare il ritardo di pagamento da parte del cliente, di norma le provvigioni per i pagamenti ritardati non vengono liquidate, ma con questa opzione è possibile forzare questa condizione.
Stampa analitica | La stampa può essere analitica o sintetica, la stampa analitica elenca tutte le righe dei documenti oggetto di provvigione, nella stampa sintetica invece vengono presentati solo i totali.
Conferma stampa | La stampa definitiva e la ristampa possono essere effettuate solo se si conferma la stampa.

Alla fine viene eseguita la stampa.


Questa procedura serve per cancellare le provvigioni che sono già state liquidate e che non si intende conservare.

I dati da inserire sono:

Fino a data scadenza | Inserire la data fino a cui cancellare le provvigioni.
Codice agente | Inserire il codice dell agente di cui cancellare le provvigioni. Premendo pulsante collegato si apre la lista degli Agenti. Se non si inserisce un codice vengono cancellate le provvigioni di tutti gli agenti.
Solo liquidate | Si possono cancellare solo le provvigioni già liquidate oppure tutte.
Solo incassate | Si possono cancellare solo le scadenze con data pagamento inserita, in ogni caso non vengono cancellate le scadenze con pagamento in ritardo.
Conferma cancellazione | Per poter eseguire la cancellazione si deve spuntare questa casella.

Alla fine viene effettuata la cancellazione.


Nelle anagrafiche degli agenti è possibile inserire il codice del capoarea di ciascun agente.

Il capoarea prende una provvigione su tutte le vendite effettuate dai subagenti. La percentuale viene calcolata con le stesse regole di calcolo usate per gli altri agenti. A differenza degli agenti ai quali si possono variare le provvigioni nei singoli documenti, per i capiarea le provvigioni rimangono quelle fissate dalla regola di calcolo.

Le righe Extramagazzino non vengono prese in considerazione perché non hanno una regola di calcolo.

Questa procedura serve per calcolare le provvigioni dei capiarea per le fatture e le note di accredito emesse nel periodo considerato. Verranno generate righe di provvigione che utilizzano esattamente tutte le procedure previste per gli altri agenti.

Per determinare se una fattura appartiene al capoarea scelto, si cerca il capoarea dell'agente che ha realizzato la vendita e se necessario poi si cerca ancora il capoarea del capoarea a ritroso fino a trovare il capoarea in oggetto. In questo modo si possono realizzare gerarchie di venditori in cui a tutti vengono calcolate le spettanze.

I dati da inserire sono:

Da Data - A Data | Inserire le date limite dei documenti da esaminare. Eventuali calcoli precedenti verranno sostituiti da quelli nuovi. Vengono proposti i limiti del mese precedente a quello della data corrente.
Codice Agente | Inserire il codice dal capoarea da calcolare. Si deve effettuare il calcolo individuale di tutti gli agenti capiarea.
Conferma | Per proseguire con il calcolo si deve spuntare la casella di conferma.

Alla fine vengono calcolate automaticamente tutte le provvigioni per il capoarea scelto, Se necessario si può ripetere l'operazione facendo attenzione al fatto che eventuali avanzamenti operativi come ad esempio di dati di pagamento dei clienti o lo stato di liquidazione effettuata, verranno rimossi.


Questo archivio è utile per gestire gli obiettivi di vendita degli agenti, per ciascun agente per un periodo di 12 mesi viene stabilito un budget di fatturazione che l'agente dovrebbe realizzare e periodicamente si può calcolare lo scostamento effettivo delle vendite rispetto al budget, questo può servire per calcolare premi e per monitorare l'andamento delle vendite.

I dati da inserire sono:
Codice agente | È il codice dell'agente per cui si stabilisce il budget. Premendo pulsante collegato si apre la lista degli Agenti.
Data iniziale di validità | Inserire la data di inizio della tabella del budget.
Descrizione aggiuntiva | Si può inserire una breve descrizione aggiuntiva.
Budget mesi 1 - 12 | È la tabella dei dodici mesi di calcolo del budget. Per ogni campo si stabilisce il budget del mese a partire dalla data iniziale.
Copia budget | Questo pulsante consente di copiare nei campi della tabella del budget l'importo presente nel campo corrente, questo consente di ridurre le digitazioni.

Lo scopo della tenuta di questo archivio è soprattutto per il calcolo dello scostamento dal budget delle vendite effettive, questo calcolo si ottiene richiedendo la stampa dello scostamento, nella stampa si può richiedere la data finale. Nella stampa vengono evidenziati budget, fatturato e percentuale di scostamento.


Con questa procedura se memorizzano alcuni dati di configurazione della gestione di magazzino.

Preferenze di magazzino

Preferenze di magazzino

Preferenze di magazzino

Preferenze di magazzino

I dati da inserire nella prima pagina sono:

Deposito predefinito | Inserire il codice del deposito proposto automaticamente nella gestione dei documenti.
IVA e contropartita spese incasso | Inserire il codice IVA utilizzato per le spese di incasso addebitate in fattura. Inserire anche il codice di conto utilizzato par la contabilizzazione delle spese, se il campo viene lasciato vuoto viene utilizzato il conto definito nella causale contabile.
IVA e contropartita spese bolli | Inserire il codice IVA utilizzato per le spese per i bolli apposti sull'originale ed addebitate in fattura. Inserire anche il codice di conto utilizzato par la contabilizzazione delle spese, se il campo viene lasciato vuoto viene utilizzato il conto definito nella causale contabile.
Codici registri documenti | Con questa opzione si possono gestire registri dei documenti multipli, i codici dei registri dei documenti coincidono con i registri IVA, il valore inserito qui è lo stesso delle preferenze di contabilità.
Registro IVA PA | Per le fatture emesse verso la Pubblica Amministrazione sono state attivate norme specifiche che riguardano la fatturazione elettronica, la conservazione sostitutiva ed il regime iva di Split Payment, per assolvere a questi obblighi le fatture dovranno essere registrate su un registro iva dedicato che va indicato in questa posizione. Nel secondo campo si può inserire il codice di registro per forzare l'esclusione dallo split payment di singole Fatture PA
Fatturazione separata per agente | Durante la fatturazione automatica, le bolle di un cliente vengono raggruppate in un unica fattura se non ci sono le condizioni per fare fatture separate, ad esempio se le bolle hanno modalità di pagamento diverse o listini diversi. Con questa opzione si indica se si desidera fatture separate per bolle attribuite ad agenti diversi o si desidera comunque un unica fattura attribuita all'agente indicato in anagrafica del cliente.
Cerca barcode in articoli | Questa opzione serve per indicare al programma di cercare prima del codice dell'articolo il codice a barre inserito in anagrafica in alcune procedure che permettono questo tipo di ricerca, ad esempio in gestione Documenti.
Calcola giacenze in riga articolo | Questa opzione permette di abilitare una funzione che durante l'inserimento di nuovi documenti visualizza la giacenza attuale degli articoli che si stanno inserendo.
Visualizza costo in righe docuemnto | Questa opzione permette di abilitare una funzione che durante l'inserimento di nuovi documenti visualizza il costo ultimo degli articoli che si stanno inserendo.
Accumulatore export Fatture e Note | Si inseriscono i codici di numeratore utilizzati per le fatture e per le note d'accredito, questi codici sono utilizzati dalla procedura di contabilizzazione fatture per memorizzare i progressivi di esportazione.
Differenze inventariali positive, negative e pari | Inserire i codici di tipo documento utilizzati dalla procedura di inserimento giacenze per produrre i documenti di rettifiche inventariali. Si inserisce il codice utilizzato per le differenze positive, per le differenze negative e per le giacenze senza differenza.
Tipo cliente contatto e non operativo | Per tipo cliente "contatto" si intende un cliente che non è ancora cliente in quanto non ha ancora acquistato niente ma a cui abbiamo fatto preventivi o che comunque abbiamo gia contattato, il cliente "non operativo" invece è un cliente che aveva acquistato in passato ma che non acquista più per qualsiasi motivo. Inserendo in questa posizione i codici relativi di tipo cliente viene attivata automaticamente la selezione dei clienti durante l'inserimento di Primanota e di Documenti di Magazzino che esclude questi tipi di clienti.
Nascondi automaticamente | Questa spunta attiva automaticamente la selezione dei clienti contatti e non operativi quando si entra nella lista dei clienti.
Gruppo articolo esaurito ed obsoleto | Si possono assegnare articoli a gruppi di articoli esauriti o obsoleti. In questa posizione si definiscono i codici che identificano questi tipi e poi quando si apre la tabella degli articoli questi gruppi possono essere nascosti automaticamente.
Nascondi automaticamente | Questa spunta attiva automaticamente la selezione degli articoli esauriti ed obsoleti quando si entra nella lista degli articoli.

I dati da inserire nella seconda pagina sono:
Banca predefinita per bonifici bancari. | Indicare in questa posizione il codice della banca che verrà utilizzata di preferenza per i bonifici dei clienti. Il codice verrà proposto automaticamente nelle procedure di Primanota e di Documenti di Magazzino in caso di pagamento dei clienti a mezzo bonifico bancario.
Procedura calcolo codice articolo
         Inserire i questo campo il nome della procedura utilizzata per il calcolo automatico dei codici degli articoli. Quando viene introdotto un nuovo articolo, se nella categoria di appartenenza viene specificato di calcolare il codice, viene utilizzata questa procedura per effettuare il calcolo. Le procedure disponibili sono:
newCodeNormal () | Con questa procedura si calcola il codice utilizzando i tre caratteri del codice della categoria più un progressivo numerico di sette cifre, volendo si può passare come parametri il numero di caratteri della categoria ed il numero di caratteri del progressivo.
newCodeEAN13 () | Con questa procedura viene calcolato un codice EAN13 composto da un prefisso più il codice della categoria più un progressivo di sette cifre più il codice di controllo finale, per il funzionamento corretto è necessario che le categorie abbiano codice numero riempito con zeri. Come argomento si può passare il prefisso, quello proposto automaticamente è '20'
newBarCodeEAN13 () | Questa procedura funziona esattamente come la precedenta ma serve per calcolare automaticamente il codice alternativo invece del codice primario degli articoli. Va applicata solo se il calcolo automatico viene effettuato sul codice alternativo e non sul codice primario.
newCodeCalc () | Questa procedura serve per calcolare con un prefisso inserito manualmente nel campo codice durante l'inserimento degli articoli. Come parametri si può inserire il numero di caratteri del prefisso ed il numero di cifre da usare per il progressivo. Si usa questa procedura quando il prefisso di 3 caratteri della categoria non è sufficiente come prefisso mnemonico.
Procedura stampa etichette barcode | Inserire il nome della procedura da utilizzare per la stampa delle etichette con barcode da applicare alla merce, viene di solito utilizzata per pilotare speciali stampanti per etichette, se non si inserisce niente, viene utilizzata la procedura interna di stampa etichette che stampa su stampante laser o inkjet su speciali fogli di etichette facilmente reperibili sul mercato.
Procedura importazione dati terminali Il programma prevede la possibilità di importare dati rilevati con terminali palmari, questo campo serve per inserire il nome della procedura utilizzata per leggere i dati dal terminale. Viene utilizzata da varie procedure del programma in cui è utile utilizzare terminali portatili.
Esistenono alcune procedure speciali per inserire in rapida successione codici letti da lettori barcode collegati in caduta di tastiera. I loro nomi sono impKeyboardRows(), impCodArtRows() e impMemoRows(). La scelta dipende dai gusti e dalle prestazioni del lettore.
Se si desidera, si può inserire una procedura diversa per ogni posto di lavoro, per fare questo di deve scrivere un file di testo di nome "IMPROWS.PRG" nella cartella locale "C:\CS" di ogni posto di lavoro, il testo deve essere una sola riga con il nome della procedura da attivare.
Documento vendita al banco, Fattura, DDT e Ordine a Fornitore | Vengono chiesti i codici di alcuni tipi di documenti utilizzati dalla procedura di vendita al banco e di gestione liste di articoli.
Cliente per fattura elettronica semplificata e listino e listino svendita per vendita al banco. Questo campo ha una doppia funzione. Viene utilizzato per le procedure di vendita al banco e per la fattura elettronica semplificata.

Se nei Documenti di Magazzino viene emessa una fattura a questo cliente, non sara necessario inserire i dati anagrafici e verrà emessa una fattura elettronica semplificata inserendo solo la Partita IVA o il Codice Fiscale del cliente.

Per la vendita al banco invece, Si inseriscono i codici utilizzati dalle procedure di vendita al banco. Il cliente è quello utilizzato dalla procedura di generazione movimenti e serve per intestare le vendite a clienti generici. Il listino e quello utilizzato per ricavare i prezzi dalla procedura di vendita al banco. Il listino di svendita viene utilizzato solo dalle ditte che gestiscono le vendite stagionali, se è presente il prezzo del listino di svendita esse viene utilizzato al posto del prezzo di listino normale.
Procedura scontrino vendita al banco | Questa procedura viene utilizzata per collegare un registratore di cassa alla procedura di vendita al banco, se presente viene lanciata alla chiusura di ciascuna vendita.
Procedura ricevuta vendita al banco | Al posto della stampa dello scontrino su registratore di cassa si può effettuare la stampa di una ricevuta su carta libera, questa procedura serve per effettuare tale stampa.
Codice Intrastat per righe Extramagazzino | Nelle stampe dei riepiloghi intrastat verrà utilizzato questo codice per le righe extramagazzino.
Separatore varianti e lunghezza codice | Queste opzioni servono per la gestione delle varianti. Nei documenti ed in altre posizioni del programma, si possono inserire i codici degli articoli assieme ai codici di variante, il separatore è il carattere che viene usato per separare la parte codice dalla parte variante, ovviamente ne il codice ne le varianti possono contenere questo carattere. In alternativa si possono gestire codici di articolo a lunghezza fissa, in questo caso non c'è carattere di separazione e la parte variante del codice è quella oltre la lunghezza inserita, se il valore di questo campo è zero, viene utilizzato il carattere separatore.

I dati da inserire nella terza pagina sono:
Directory posizioni immagini | In questo punto si può inserire la directory da usare per inserire le immagini degli articoli. Le immagini vengono visualizzate nella gestione degli articoli e possono essere inserite in alcune stampe di listini.
Directory per archivio storico | In questo punto si può inserire la directory da usare per la gestione dell'archivio storico, se non si inserisce niente, oppure il percorso è errato o non ci sono dati corretti nella directory di destinazione, lo storico non viene attivato.
Percentuale ritenuta, percentuale non soggetta e ritenuta Enasarco | Coloro che emettono documenti con calcolo della ritenuta d'acconto devono inserire la percentuale di ritenuta a cui sono soggetti. Alcuni soggetti applicano la ritenuta solo su una parte dell'imponibile ed alcuni sono soggetti ad una seconda ritenuta che è il contributo Enasarco. Nei documenti di magazzino che sono fatture con ritenuta è possibile modificare queste percentuali solo per il singolo documento.
Campo per massimale Enasarco | Quando si supera il plafond per l'applicazione della ritenuta Enasarco, bisogna indicare il fattura l'importo residuo su cui applicare la ritenuta, inserire in questa posizione il nome del campo dei documenti di magazzino in cui inserire questo dato. Se il valore è Zero il calcolo Enasarco viene fatto sull'imponibile soggetto a ritenuta, se si inserisce -1, oppure si mette la percentuale a Zero, la ritenuta Enasarco non viene applicata.
Gruppo articoli soggetti a ritenuta da - a | Questi dati sono utili solo se si emettono documenti con calcolo della ritenuta d'acconto. Verranno inclusi nel calcolo della ritenuta d'acconto solo gli articoli che alfabeticamente appartengono ai gruppi compresi tra i dati inseriti.
Articolo rimborso e percentuale 1 - 3 | Coloro che sono soggetti a ritenuta d'acconto, spesso addebitano ai clienti importi in percentuale sulle prestazioni per previdenza integrativa o rimborso spese. Se si inseriscono in questa posizione il codice dell'articolo e la percentuale da applicare, nei documenti emessi automaticamente vengono aggiunte le righe di addebito. Si possono utilizzare fino a 3 righe di addebito rimborso.
Descrizione numeri utente | Negli articoli sono disponibili tre campi numerici liberi utilizzati per scopi speciali dagli utenti, in questi campi si inserisce la descrizione di questi campi.
Descrizione campi utente | Negli articoli sono disponibili tre campi alfabetici liberi utilizzati per scopi speciali dagli utenti, in questi campi si inserisce la descrizione di questi campi.
I dati da inserire nella quarta pagina sono:
Descrizione numeri utente | Negli articoli sono disponibili 20 campi numerici liberi utilizzati per scopi speciali dagli utenti, in questi campi si inserisce la descrizione di questi campi.
Descrizione campi utente | Negli articoli sono disponibili 3 campi alfabetici liberi utilizzati per scopi speciali dagli utenti, in questi campi si inserisce la descrizione di questi campi.
Indirizzo sito aziendale | Si può inseire l'indirizzo del sito aziendale che potrà essere riportato nei documenti.
Indirizzo informativa privacy | Se abbiamo messo online il testo della informativa privacy in osservanza alle norme GDPR, possiamo inserire l'indirizzo in questa posizione, in questo modo in tutti i documenti i clienti potranno trovare i riferimenti.


La gestione delle commesse di forniture è stata pensata per rispondere alla esigenza specifica delle attività che forniscono a clienti finali beni come mobili, arredo bagno e forniture edili in genere.

Di solito viene fatto un preventivo in cui vengono elencati tutti i beni che vengono scelti ed anche il lavoro di montaggio che di solito viene fatto a cura del fornitore presso la sede del cliente.

Se il cliente accetta il preventivo, solitamente viene richiesto un acconto ed in seguito si devono fare tutti gli ordini ai fornitori ed attendere la consegna, quando la merce arriva presso la sede della ditta o direttamente presso il cliente, si procede al montaggio. Il procedimento di consegna e montaggio può avvenire anche in tempi diversi, può anche succedere che per colpa di inconvenienti che si possono verificare sia necessario ritornare per completare il montaggio o eseguire riparazioni.

A lavoro ultimato si procede con l'emissione del documento di vendita che può essere una Fattura Immediata, oppure una Ricevuta Fiscale o infine un DDT. Anche l'emissione dei documenti di vendita può essere fatta in più volte, nel caso dei DDT in seguito viene emessa fattura utilizzando la consueta procedura di Fatturazione Automatica di Zefiro.

Quando si inseriscono i preventivi si caricano i dati anagrafici dei clienti in modo descrittivo, in seguito se il cliente conferma l'acquisto, si effettua la registrazione tra i clienti acquisiti, in questo modo il nominativo potrà essere utilizzato per future promozioni o comunicazioni.

È possibile anche effettuare la vendita senza registrare il cliente, ma in questo caso si dovrà utilizzare solamente la Ricevuta fiscale come documento di vendita.

L'intero procedimento di vendita viene gestito dalla tabella delle Commesse da cui è possibile generare automaticamente tutti i documenti di magazzino richiesti, monitorare lo stato in cui si trovano le commesse e fare alcune interessanti stampe.

La tabella delle righe delle commesse serve per fornire un diverso metodo di aggregazione dei dati per effettuare stampe statistiche oppure per vedere i dati in modo slegato dalle commesse.

Infine si possono inserire alcune preferenze riguardo ad alcuni dati comuni.


L'archivio delle Commesse forniture permette la gestione completa di ciascuna commessa.

A mano a mano che evolve lo stato di avanzamento del lavoro, si possono effettuare tutte le procedure connesse che possono essere la generazione degli ordini ai fornitori o i documenti di vendita finali.

Da questa posizione si effettua anche la stampa della copia commissione e delle schede per il calcolo del margine operativo della vendita.

Il documento è composto da una testata contenente tutti i dati anagrafici e dalle righe con l'elenco dei materiali venduti. Nelle righe viene evidenziato il prezzo di costo ed il prezzo di vendita, in questo modo si può controllare in ogni momento il margine operativo.

I dati da inserire nella testata sono:

Numero | Viene proposto un numero progressivo automatico che identifica la commissione.
Data commessa | Si inserisce la data in cui viene redatto il preventivo che in seguito può diventare commessa.
Codice cliente | Si può inserire il codice del cliente a cui viene fatto il preventivo. Inizialmente si può lasciare vuoto questo dato ed inserire le informazioni anagrafiche del cliente. In seguito si può decidere di registrare il cliente e da quel momento in poi per fare modifiche ai dati anagrafici si dovrà modificare il cliente registrato.
Cognome nome ed indirizzo | I dati anagrafici sono modificabili solo se non è stato registrato il cliente.
Zona | Inserire la zona di appartenenza del cliente a fini statistici
Origine segnalazione | Questo campo indica il modo in cui il cliente è giunto da noi, ha solo valore statistico.
Codice pagamento | Inserire la modalità di pagamento concordata con il cliente.
Deposito | Questo dato viene richiesto solo se è stata abilitata la modalità multi-deposito ed è utile ad esempio quando ci sono più punti vendita.
Banca d'appoggio | In caso di pagamenti bancari si inserisce la banca in cui appoggiare RiBa o Rid
Numero listino | Si inserisce il codice del listino utilizzato per la vendita. I prezzi inseriti avranno scorporo iva o iva aggiunta a seconda della configurazione del listino scelto.
Codice IVA | Se si lascia vuoto questo campo viene utilizzato il codice iva standard degli articoli. Altrimenti si può inserire il codice iva specifico in base ad eventuali agevolazioni di legge.
Altro | Premendo il pulsante si possono inserire dati fiscali del cliente ed altro.
Contatti | Si inseriscono numeri di telefono, e-mail ed eventuali altri contatti del cliente.
Codice Agente | Si inserisce il codice del venditore che effettua la vendita.
Stato provvigioni | Se sono previste provvigioni si inserisce lo stato di liquidazione.
Acconto provvigioni | Nel caso siano stati dati all'agente acconti sulle provvigioni da liquidare si può inserire in questa posizione l'importo complessivo anticipato fino a questo momento.
Consegna prevista | Inserire la data di consegna prevista.
Acconto versato | Spesso al atto della firma della commissione si richiede un acconto che viene inserito in questa posizione. Le scadenze successivamente generate terranno conto di questo importo.
Stato della commessa | Si inserisce lo stato in qui si trova attualmente la commessa. Di solito è calcolato automaticamente e corrisponde allo stato più basso presente nelle righe.
Codice vettore | Indicare chi è incaricato del trasporto. Potrebbe essere un vettore, ma anche una squadra di montatori da noi incaricata.
Tempo montaggio | Se si desidera si può inserire il tempo previsto di montaggio che può essere utile per pianificare il lavoro.
Dati consegna | Si possono inserire alcuni dati aggiuntivi che possono essere riportati in stampa.
Descrizione della consegna | Si possono inserire annotazioni libere.

Dopo aver inserito la testata si possono inserire le righe che descrivono la merce da consegnare ed anche costi ed annotazioni interne.

Si possono inserire cinque tipi di riga a seconda delle necessità.

I primi tre tipi corrispondono ai tipi di riga presenti nei documenti di magazzino, gli altri invece vengono inseriti ad uso interno. I tipi di riga sono:

1 - Riga articolo Con questa riga si inserisce un articolo che viene venduto, l'articolo può essere generico e poi si può modificare la descrizione per specificare esattamente la natura del bene venduto.
Si inseriscono prezzo di listino, prezzo di costo e prezzo di vendita praticato. Il prezzo di costo può essere determinato automaticamente a partire dal prezzo di listino, infatti negli articoli si può inserire lo sconto praticato dal fornitore sul prezzo di listino consigliato. Nelle preferenze si può configurare questo meccanismo.
Al prezzo praticato si può applicare automaticamente un sconto e la percentuale proposta può essere configurata negli articoli, lo sconto può essere applicato direttamente al prezzo, oppure come percentuale sul prezzo proposto,
Di seguito si inserisce la quantità, un eventuale sconto sul prezzo praticato, il codice IVA e la provvigione concessa all'agente.
Infine si inseriscono i dati che servono per la consegna che sono: il codice del fornitore, la data dell'ordine a fornitore, la data in cui il bene viene ritirato dal fornitore per effettuare la consegna e lo stato di avanzamento in cui si trova attualmente la riga. Lo stato di avanzamento più basso delle righe determina lo stato complessivo della commessa. Ad esempio se ci sono 3 righe delle quali 2 sono state consegnate ed una no, lo stato della commessa corrisponderà a non consegnato.
2 - Riga extra magazzino | La riga extra magazzino è molto simile alla riga articolo, la differenza è che si effettua la vendita senza indicare un articolo e questo significa che non ci sono ne automatismi ne statistiche. Viene inserita per compatibilità con le righe dei documenti di magazzino, ma in linea di massima non dovrebbe essere usata se non per usi veramente particolari.
3 - Riga descrittiva | Si inserisce una descrizione che si desidera che compaia sia nella stampa del preventivo sia nei documenti di vendita.
4 - Spesa sostenuta | Si possono inserire anche righe che registrano un costo sostenuto e che non fanno parte delle righe dei documenti generati ma servono per documentare costi che faranno parte dei calcoli della scheda consuntiva.
5 - Nota operativa | Si possono inserire descrizioni ad uso interno che non verranno incluse nei documenti generati.

I comandi speciali disponibili sono:

Telefoni e contatti | È una scorciatoia per inserire o vedere velocemente i contatti del cliente
Stampa commessa | Si stampa la commessa che verrà consegnata al cliente per la firma in caso di accettazione. Vengono stampate le righe di tipo 1, 2 e 3 con i prezzi di vendita.
Genera nuovo cliente | Se non è stato ancora generato il cliente, lo si può fare con questa procedura. La generazione del cliente non è obbligatoria ma è consigliata dopo che il cliente ha confermato l'acquisto, poiché può essere utile per la registrazione di ulteriori acquisti e per motivi di marketing.
Genera ordini a fornitori | Dopo che il cliente ha confermato l'ordine si procede con la generazione degli ordini a fornitore, con questa procedura viene presentata la lista delle righe non ancora ordinate tra le quali scegliere e se necessario si può cambiare il fornitore. Alla fine quando si conferma viene generato un ordine per ogni fornitore, vine aggiornato lo stato delle righe ordinate e viene ricalcolato lo stato della commessa.
Genera documento di vendita | Con questa procedura si possono generare i documenti di vendita per i materiali disponibili e pronti per la consegna. Se il cliente non è stato ancora generato, viene richiesto se si desidera generarlo in questo momento. Si può scegliere il tipo di documento da generare e viene proposto quello indicato nelle preferenze. Dopo aver scelto il tipo di documento viene presentata la lista dei materiali pronti tra i quali si può scegliere quelli da spedire.
Duplica commessa | Se si desidera si può duplicare una commessa per vari motivi, ad esempio per fare diverse versioni di un preventivo, oppure per duplicare commesse tipiche.
Commessa ricorrente | Si può memorizzare una lista di commesse con contenuti ricorrenti per evitare di ridigitare spesso contenuti simili. Questa procedura permette di aggiungere la commessa corrente alle commesse ricorrenti e di generare nuove commesse a partire dalla liste delle commesse ricorrenti o di cancellare commesse ricorrenti inserite in precedenza e non più utili.
Visualizza righe | Con questo comando si può aggiungere la visualizzazione automatica delle righe delle commesse in modo che non sia necessario entrare dentro a ciascuna commessa per vederne il contenuto.
Spunta commesse | Questo comando permette di aprire una colonna in qui è possibile spuntare le commesse. La spunta serve per fare selezioni particolare e per stampare la lista delle sole commesse spuntate.

Le Stampe disponibili sono:

Lista commesse | Si può stampare una semplice lista delle commesse selezionate o spuntate. Il valore ed il costo delle commesse viene calcolato e nella stampa viene anche calcolato il totale.
Scheda commessa | Questa procedura stampa un consuntivo della commessa, vengono evidenziati tutti gli importi sia di vendita che di costo e vengono esposte tutte le righe in modo da avere un quadro completo della storia e del valore della commessa.


La tabella delle righe delle commesse contiene la lista di tutte le righe che sono contenute nelle varie commesse.

Normalmente non si dovrebbero modificare i contenuti delle righe da questa posizione, ma solo dalla gestione normale delle commesse. È utile avere la lista delle righe per eseguire selezioni particolari, ad esempio si possono selezionare tutte le righe ordinate ad un fornitore e pronte per il ritiro, oppure la lista delle righe consegnate in un certo periodo.

L'unica operazione che è utile eseguire da questa posizione è il cambiamento dello stato di alcune righe, ad esempio se un fornitore ci comunica che alcuni materiali sono pronti, ne possiamo cambiare lo stato.

Per modifica lo stato velocemente è possibile attivare le spunte e spuntare tutte le righe interessate, a questo punto se si chiede la modifica dello stato l'operazione avrà effetto su tutte le righe spuntate.

Si può anche stampare la lista dei dati selezionati o spuntati, e nella lista vengono visualizzati prezzi e costi per la determinazione dell'utile lordo. I valori calcolati vengono anche totalizzati.


In questa posizione si inseriscono alcuni parametri di configurazione della gestione commesse forniture

I dati da inserire sono:

Numero listino | Si inserisce il codice del listino preferenziale, spesso si usa un listino con prezzi iva inclusa.
Codice modalità di pagamento | È la modalità di pagamento preferenziale per le nuove commesse.
Causale documento ordine a fornitore | Dal archivio delle commesse si possono generare automaticamente gli ordini a fornitore, in questa posizione si inserisce la causale di documento utilizzata.
Causale documento fattura | Quando si effettua la vendita per commesse con cliente codificato viene proposta la causale della fattura, di solito si utilizza la fattura immediata.
Causale documento ricevuta fiscale | Quando si effettua la vendita per commesse con cliente non codificato viene proposta la causale della ricevuta fiscale ma si può scegliere altri tipi di documento.
Codice cliente ricevuta fiscale | Se si effettua la vendita senza codificare il cliente, viene utilizzato un codice di cliente generico, di solito comunque si preferisce codificare tutti i clienti che effettuano acquisti.
Numero campo sconto articoli | Questo valore viene utilizzato per eseguire un calcolo particolare: Nelle righe articolo, spesso si utilizzano articoli generici e poi si modifica la descrizione per specificare la natura della merce. Un modo per utilizzare questa funzionalità potrebbe essere quella di inserire un prodotto generico per ogni fornitore e per ogni linea di prodotto, in questo caso si può indicare il numero di campo generico in cui inserire lo sconto che il fornitore ci applica rispetto al prezzo di listino ed in questo modo quando inseriamo il prezzo nelle righe viene automaticamente calcolato il prezzo di costo scontato.
Numero campo articoli sconto a clienti | Nel numero di campo generico degli articoli indicato da questo campo, si può inserire lo sconto massimo o abituale praticato ai clienti rispetto al prezzo di listino. In questo modo quando si inseriscono le commesse, in corrispondenza del campo "Prezzo praticato" premendo il pulsante viene proposta l'aliquota indicata. La percentuale di sconto può essere scorporata dal prezzo netto praticato, oppure applicata come sconto di riga.


L'archivio della distinta base serve per la gestione della produzione.

La produzione è un processo di trasformazione in cui alcuni materiali attraverso una o più fasi di lavorazione cambiano natura. Normalmente vengono utilizzate "Materie prime" che messe assieme ed opportunamente lavorate danno origine ad un "Prodotto finito", quindi il prodotto finito è un Composto che contiene vari Componenti. Alle volte il processo è più complesso, infatti capita spesso che le materie prime vengono assemblate per produrre "Semilavorati" i quali a loro volta saranno i componenti di ulteriori Semilavorati o di Prodotti finiti. Una fase di produzione che da materie prime e semilavorati genera semilavorati o prodotti finiti viene chiamata "Livello".

La Distinta Base serve ad indicare quali componenti concorrono a costituire un composto, nel programma sia i componenti che i composti sono articoli di magazzino, nella distinta si possono indicare come componenti materiali fisici che possono essere materia prima o semilavorati ma si possono indicare anche le lavorazioni che servono a produrre il composto.

Normalmente la distinta viene inserita scegliendo da voce "Distinta Base" dal menù degli articoli, questo consente di gestire assieme tutte le righe della distinta di un articolo, l'aspetto delle singole righe è il seguente:

A seconda della posizione in cui si inseriscono le righe di distinta vengono abilitati o disabilitati i campi di codice composto e componente.

I dati di inserire sono:

Codice composto | E' il codice dell'articolo padre della distinta. Premendo il pulsante collegato si apre la lista degli Articoli. Questo campo se la distinta viene gestita dagli articoli non viene richiesto perché è implicito l'articolo di cui stiamo sviluppando la distinta.
Codice componente Indicare il codice del componente che appartiene al composto. Premendo il pulsante collegato si apre la lista degli Articoli. Bisogna fare attenzione nell'inserimento dei composti a non inserire i cosiddetti "Riferimenti Circolari" cioé codici di articoli che sono composti della stessa distinta e che quindi mandano in errore il programma quando si esplode la distinta. Ad esempio se ho il composto "ART01" il quale ha nella distinta il componente "ART02" il quale a sua volta ha nella distinta l'articolo "ART01", nel momento che esplodo la distinta entro in un circolo vizioso in cui per aprire il figlio devo aprire il padre e viceversa andando avanti all'infinito fino a mandare in errore il programma.
Numero riga Questo dato serve per dare una sequenza logica ai composti della distinta, ad esempio potrebbe essere utile ordinare le lavorazioni a seconda dell'ordine in cui vengono eseguite.
Tipo riga Serve per indicare il tipo di componente, questo dato viene essere usato da varie procedure del programma per eseguire elaborazioni diverse a seconda del caso. Premendo il pulsante collegato si apre la lista di scelte che sono:
1 COMPONENTE | Il componente è un materiale fisico che deve essere disponibile per poter eseguire la produzione del composto.
2 DISTINTA | Questa opzione serve per inserire in distinta sequenze ripetitive di distinta, durante l'esplosione della distinta, in presenza di questo codice viene presa la distinta del composto ed inserita al posto del composto stesso. Se allo stesso componente si assegna il tipo riga "1", l'articolo viene trattato come semilavorato e l'esplosione avviene ad un livello inferiore.
3 LAVORAZIONE INTERNA | Con questa opzione si indica che la riga descrive una lavorazione eseguita internamente, questo dato è utile nella gestione degli ordini di produzione e per filtrare i calcoli dei fabbisogni.
4 LAVORAZIONE ESTERNA | Con questa opzione si indica che la riga descrive una lavorazione eseguita esternamente da ditte terziste, e quindi permette di automatizzare la gestione degli ordini a fornitori e per filtrare i calcoli dei fabbisogni.
Quantità composto Indicare la quantità di composto per cui viene applicata la quantità di componente solitamente in questo campo si inserisce "1", ma la quantità potrebbe essere diversa per ridurre gli errori di arrotondamento. Ad esempio se per imballere usiamo cartoni che contengono 12 pezzi del prodotto, si può inserire "12" nella quantità composto e "1" nella quantità componente.
Quantità componente Indicare la quantità di componente da impiegare in rapporto alla quantità di composto. La quantità effettivamente impiegata durante i calcoli di produzione e data dalla formula: Q1/Q2xQ3 dove Q1 è la quantità di componente, Q2 è la quantità di composto e Q3 è la quantità ordinata.
Percentuale sfrido In questo campo è possibile indicare un modificatore percentuale della quantità impiegata che tiene conto della percentuale medio di spreco di materia prima. La percentuale viene applicata dopo aver eseguito il calcolo precedente.
Formula calcolo In alternativa ai calcoli inseriti in precedenza si può inserire una formula di calcolo diversa, normalmente non è necessario attivare questa funzionalità, in caso di necessità contattare la Compusoft per mettere a punto modalità di calcolo speciali.
Note distinta | Per ogni riga di distinta si può inserire una breve annotazione, Premendo il pulsante memo si inserisce la descrizione.
Quantità misure 1-5 Questi campi vengono utilizzati solo se si inserisce una formula di calcolo e servono per inserire ulteriori parametri nel calcolo della formula, possono essere utili nei casi in cui il calcolo dipende dalle misure. La particolarità di questo tipo calcolo è che le quantità su cui agisce possono essere ereditate dalle distinte padre.
Se non si utilizza la formula di calcolo, questi campi diventano neutri e possono essere utilizzati per inserire dati gestiti dall'utente.
Data ultima modifica | Il programma automaticamente inserisce la data in cui viene modificata la distinta, in questo modo gli operatori possono sapere se la distinta è aggiornata.
Altri dati | Le righe della distinta dispongono di alcuni campi liberi a disposizione degli operatori, che possono essere usati per vari motivi, ad esempio si potrebbero inserire riferimenti di disegni o di programmi macchina.

La gestione della produzione è materia complessa che richiede un'attenta pianificazione per ottenere i migliori risultati. Gestire la produzione senza aver esaminato bene tutte le implicazioni delle proprie scelte può portare ad maggiore complessità di gestione e talvolta ad ottenere risultati non corretti o insufficienti che possono anche costringere a rivedere completamente le scelte fatte inizialmente.

Vogliamo pertanto esporre alcune regole di carattere generale di cui si dovrebbe tener conto quando si pianifica la gestione della produzione. Come sempre le regole sono solo linee guida che devono essere seguite ma non in maniera tassativa.

La prima regola è anche la regola base per tutte le altre e dice: tra due opzioni scegliere sempre quella più semplice e scegliere quella più complessa solo quando è veramente necessario.

La produzione può essere sviluppata su un numero variabile di livelli. Quando è possibile tenere il più basso possibile il numero di livelli, si dovrebbe evitare di fare distinte più profonde di 5 o 6 livelli, naturalmente questo dipende dalla complessità dei prodotti che produciamo. Un numero minore di livelli comporta minore introduzione di dati nel programma e quindi minore lavoro di gestione, d'altra parte alcune volte è necessario gestire un numero maggiore di livelli, si consiglia di aumentare i livelli nel caso che i semilavorati dei livelli intermedi siano parti indipendenti che possono essere usati su più prodotti o se hanno linee di produzione indipendenti.

Alcune volte potrebbe essere il caso di raggruppare più articoli in un articolo unico, ad esempio se una lavorazione richiede le operazioni di "Rifilatura" e di "Levigatura" che comunque vanno sempre eseguite assieme, si potrebbe creare un unico articolo.


Questa procedura rende definitivi i movimenti di carico e scarico effettuati con l'inserimento di documenti di magazzino.

Per ogni riga dei documenti di carico e scarico viene scritta una riga di giacenza consolidata con la giacenza ed il valore progressivo, il valore progressivo viene calcolato con il metodo del costo medio ponderato, questo significa che per i movimenti di carico il progressivo di valore il progressivo di valore viene incrementato del valore del movimenti e per i movimenti di scarico il valore viene decrementato del valore unitario medio di quel momento moltiplicato per la quantità.

Alla fine vengono aggiornati i documenti in modo che non producano più movimentazione di carico e scarico. Se si modifica un documento consolidato, nel titolo della finestra compare la segnalazione che il documento è già stato consolidato e che quindi eventuali modifiche sono irrilevanti.

I dati da inserire sono:

Fino a Data | Inserire la data limite, verranno consolidati tutti i documenti fino alla data indicata compresa.
Conferma consolidamento giacenze | Per poter eseguire la procedura si deve confermare con questa voce.

Alla fine viene eseguita la procedura.


Questa procedura che è utile a coloro che gestiscono una grande mole di movimenti di magazzino, serve per togliere dall'archivio corrente una parte dei dati di magazzino più vecchi per copiarli in un secondo archivio chiamato STORICO. In questo modo l'archivio corrente ha sempre un numero non eccessivo di registrazioni e le prestazioni sono sempre ottimali.

I dati copiati nel archivio storico, non vanno persi ma sono sempre disponibili per le consultazioni e per le statistiche. In tutte le stampe interessate, se è attivato viene chiesto il tipo di dati che si desidera vedere.

Per attivare la gestione dello storico, è necessario inserire nella apposita voce delle preferenze di magazzino la directory che viene utilizzato per la sua gestione. In tale posizione ci deve essere un archivio contente tutti i files utilizzati dagli archivi di Zefiro. Se il percorso è errato o non contiene i giusti dati la procedura di gestione storico non viene attivata. Di solito si utilizza per lo storico un archivio gestito dalla procedura di "Archivio di lavoro", in questo modo lo storico è a tutti gli effetti un archivio gestibile da Zefiro.

Prima di eseguire la storicizzazione, si deve eseguire la procedura di "Consolida documenti", poiché per motivi tecnici, la storicizzazione opera solo sui documenti consolidati, eventuali documenti non ancora consolidati verranno ignorati, però potranno essere storicizzati la volta successiva dopo che saranno stati convalidati.

Questa procedura esegue notevoli operazioni di cancellazione e di copia di dati, perciò per evitare problemi di perdite di dati, prima di incominciare è necessario fare le copie sia dell'archivio corrente che dell'archivio storico. Si consiglia inoltre di eseguirla con l'assistenza di personale tecnico.

Quando si fanno aggiornamenti del programma che comportano modifiche alla struttura dei dati, è molto importante ricordarsi di aggiornare anche l'archivio storico, altrimenti alcune delle funzionalità potrebbero risultare compormesse.

I dati da inserire sono:

Fino a Data | Inserire la data limite, verranno storicizzati tutti i documenti fino alla data indicata compresa.
Conferma storicizzazione movimenti | Per poter eseguire la procedura si deve confermare con questa voce.

Alla conferma viene eseguita la procedura che fa esattamente le seguenti cose:

Prima di tutto vengono copiati su un archivio temporaneo tutti di documenti consolidati ed i documenti che non creano movimentazione di magazzino. (Ricordiamo che prima di eseguire questa procedura è bene effettuare il consolidamento dei documenti). I dati copiati vengono cancellati dall'archivio corrente.

La seconda operazione aggiunge allo storico i dati copiati nell'archivio temporaneo, alla fine di questa operazione i dati temporanei vengono cancellati.

Poi vengono aggiornati gli articoli dell'archivio storico, questa operazione viene eseguita cancellando da storico tutti gli articoli ed i dati correlati che sono presenti anche nell'archivio corrente, poi si aggiungono all'archivio storico i dati aggiornati provenienti dall'archivio corrente. Questa procedura opera in questo modo per preservare nello storico eventuali articoli che sono stati cancellati nell'archivio corrente ma che sono utilizzati in storico.

L'ultima operazione consiste nel copiare dall'archivio corrente a quello storico tutti gli archivi implicati nella gestione del magazzino come ad esempio i Clienti, i Fornitori, gli Agenti, le Modalità di pagamento, i Tipi di Documento e così via.


In ottemperanza all'art 37 del D.L. 233/2006 viene prodotto l'allegato di clienti e fornitori che contiene l'importo complessivo delle fatture emesse e ricevute al netto di note di accredito.

Per il corretto funzionamento della procedura è necessario che siano stati inseriti i dati anagrafici dell'azienda.

Viene prodotto un file di testo nel formato richiesto dalla agenzia delle entrate, tale file dovrà essere spedito mediante la procedura EntraTel da parte di un soggetto autorizzato ed iscritto al CAF. Solitamente i consulenti fiscali delle aziende sono qualificati per effettuare questo tipo di spedizioni.

I dati da inserire sono:

Codice fiscale intermediario. | Inserire il Codice Fiscale del soggetto che materialmente effettua la spedizione, solitamente la spedizione viene effettuata dal consulente fiscale dell'azienda.
Iscrizione al CAF dell'intermediario | Inserire il codice di iscrizione al CAF dell'intermediario. Questo dato è obbligatorio.
Comunicazione predisposta da | Inserire il soggetto che materialmente prepara il file da spedire alla Agenzia delle Entrate. Può essere il contribuente oppure l'intermediario.
Data impegno | Inserire la data in cui viene preparata la comunicazione.
Nome del file | Inserire il nome del file che conterrà i dati da spedire.
Stampa prospetto | Indicare se si desidera che venga stampato un prospetto leggibile dei dati che vengono preparati per la spedizione.

Dopo aver confermato questi dati viene eseguita la procedura che legge tutti i dati delle fatture e note di acquisto e di vendita, calcola i totali e registra sul file indicato questi dati.

Nel corso dell'operazione vengono controllati i codici fiscali e le partite IVA ed in caso di errore viene emessa una segnalazione. La segnalazione non è bloccante, ed il file viene prodotto anche in presenza di codici errati, ma si consiglia di correggere tutti gli errori prima di procedere alla spedizione del file.

Il file risultante dalla esecuzione della procedura deve essere fornito all'intermediario che effettua la spedizione.

L'Agenzia delle Entrate prevede che la spedizione venga spezzata in più files nel caso che il file superi la dimensione di 3 mega compressi che è un file di dimensioni enormi per questo tipo di dato. Nel caso il file risultato dovesse raggiungere questa dimensione contattate la Compusoft per provvedere alla riduzione in più files.